Deploying IPv6 in Unified Communications Networks with Cisco Unified Communications Manager
Configuring Cisco Integrated Services Routers
Downloads: This chapterpdf (PDF - 366.0KB) The complete bookPDF (PDF - 3.86MB) | Feedback

Configuring Cisco Integrated Services Routers

Table Of Contents

Configuring Cisco Integrated Services Routers

Cisco ISR Configuration for an IPv6 SIP Trunk

Cisco ISR Configuration for an FXS Port

Cisco ISR Configuration for an MTP Resource


Configuring Cisco Integrated Services Routers


Revised: June 08, 2010, OL-19142-02

 

This appendix contains IPv6 configuration examples for the following components on Cisco Integrated Services Routers (ISRs):

IPv6 SIP trunks

FXS ports

Media termination point (MTP) resources

For additional information on IPv6 configuration, refer to the following documentation:

Cisco IOS Voice Command Reference

http://www.cisco.com/en/US/docs/ios/voice/command/reference/vr_book.html

Cisco IOS IPv6 Command Reference

http://www.cisco.com/en/US/docs/ios/ipv6/command/reference/ipv6_book.html

Cisco ISR Configuration for an IPv6 SIP Trunk

!
boot-start-marker
boot system flash:c3845-adventerprisek9_ivs-mz.124-22.T
boot-end-marker
!
card type t1 0 0
card type t1 0 1
!
clock timezone EST -5
clock summer-time EDT recurring
network-clock-participate wic 0 
network-clock-participate wic 1 
!
ip source-route
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
isdn switch-type primary-4ess
!
voice service voip 
 sip
  bind control source-interface GigabitEthernet0/0
  bind media source-interface GigabitEthernet0/0
! 
controller T1 0/1/1
 clock source internal
 cablelength long 0db
 pri-group timeslots 1-24
 description T1 PRI - SIP Trunk to CUCM
!
interface GigabitEthernet0/0
 ip address 101.1.0.2 255.255.255.0
 duplex full
 speed auto
 media-type rj45
 ipv6 address 2001:101:1:1::4/64
 ipv6 nd ra mtu suppress
 ipv6 ospf 1 area 0
 no keepalive
!
interface Serial0/1/1:23
 description PRI - SIP Trunk to CUCM - SIPv6 controlled
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn protocol-emulate network
 isdn incoming-voice voice
 no cdp enable
!
router eigrp 101
 network 101.0.0.0
 no auto-summary
!
router ospf 1
 log-adjacency-changes
 network 101.0.0.0 0.255.255.255 area 0
!
ip forward-protocol nd
!
ipv6 router ospf 1
 log-adjacency-changes
!
voice-port 0/1/1:23
 description PRI Trunk                      
!
dial-peer voice 10 pots
 description SIP controlled PRI to CUCM
 destination-pattern 502T
 incoming called-number .
 direct-inward-dial
 port 0/1/1:23
!
dial-peer voice 100 voip
 destination-pattern .T
 session protocol sipv2
 session target ipv6: 2001:101:1::16
 dtmf-relay rtp-nte
 no vad
!
dial-peer voice 101 voip
 destination-pattern .T
 session protocol sipv2
 session target ipv6: 2001:101:1::15
 dtmf-relay rtp-nte
 no vad
!
sip-ua 
!
end

Cisco ISR Configuration for an FXS Port

ip source-route
!
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
stcapp ccm-group 1
stcapp
!
voice service voip 
!
voice-card 0
 dspfarm
 dsp services dspfarm
!
interface GigabitEthernet0/0
 no ip address
 duplex full
 speed auto
 ipv6 address 2001:101:1:1::7/64
 ipv6 nd ra mtu suppress
 ipv6 ospf 1 area 0
 no keepalive
!
router ospf 1
 log-adjacency-changes
 network 101.0.0.0 0.255.255.255 area 0
!
ip forward-protocol nd
!
ipv6 router ospf 1
 router-id 101.1.1.7
 log-adjacency-changes
!
control-plane
!
voice-port 0/0/0
 timeouts ringing infinity
!
voice-port 0/0/1
 timeouts ringing infinity
!
voice-port 0/0/2
 timeouts ringing infinity
!
voice-port 0/0/3
 timeouts ringing infinity
!
sccp local GigabitEthernet0/0
sccp ccm 2001:101:1::16 identifier 3 version 7.0 
sccp ccm 2001:101:1::15 identifier 1 version 7.0 
sccp
!
sccp ccm group 1
 associate ccm 1 priority 1
 associate ccm 3 priority 3
!
dial-peer voice 1 pots
 service stcapp
 port 0/0/0
!
dial-peer voice 2 pots
 service stcapp
 port 0/0/1
!
dial-peer voice 3 pots
 service stcapp
 port 0/0/2
!
dial-peer voice 4 pots
 service stcapp
 port 0/0/3
!

Cisco ISR Configuration for an MTP Resource

boot system flash:c2800nm-adventerprisek9_ivs-mz.124-22.T
!
network-clock-participate wic 0 
!
ip source-route
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
voice service voip 
!
voice-card 0
 dspfarm
 dsp services dspfarm
!
interface GigabitEthernet0/0
 ip address 101.1.200.2 255.255.255.252
 duplex auto
 speed auto
 ipv6 address 2001:101:1:200::2/64
 ipv6 nd ra mtu suppress
 ipv6 ospf 1 area 0
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/1.112
 description VOICE VLAN
 encapsulation dot1Q 112
 ip address 101.1.1.5 255.255.255.0
 ipv6 address 2001:101:1:1::5/64
 ipv6 nd ra mtu suppress
 ipv6 ospf 1 area 0
!
interface GigabitEthernet0/1.120
 description DATA VLAN
 encapsulation dot1Q 120
 ip address 101.1.20.5 255.255.255.0
 ipv6 address 2001:101:1:20::5/64
 ipv6 nd ra mtu suppress
 ipv6 ospf 1 area 0
!
router eigrp 101
 network 101.0.0.0
 no auto-summary
!
router ospf 1
 log-adjacency-changes
 network 101.0.0.0 0.255.255.255 area 0
!
ip forward-protocol nd
!
ipv6 router ospf 1
 log-adjacency-changes
!
sccp local GigabitEthernet0/1.112
sccp ccm 101.1.0.16 identifier 2 version 7.0 
sccp ccm 101.1.0.15 identifier 1 version 7.0 
sccp ccm 2001:101:1::15 identifier 3 version 7.0 
sccp ccm 2001:101:1::16 identifier 4 version 7.0 
sccp
!
sccp ccm group 1
 associate ccm 1 priority 1
 associate ccm 2 priority 2
 associate ccm 3 priority 3
 associate ccm 4 priority 4
 associate profile 1 register CONF-1
 associate profile 2 register MTP-1
 associate profile 3 register XCODE-1
!
dspfarm profile 3 transcode
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec pass-through
 codec g722-64
 codec g729r8
 codec ilbc
 maximum sessions 3
 associate application SCCP
!
dspfarm profile 1 conference
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec g729r8
 codec g729br8
 maximum sessions 3
 associate application SCCP
!
dspfarm profile 2 mtp
 codec g711ulaw
 codec pass-through
 maximum sessions software 110
 associate application SCCP
!
!