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Introduction
Prime Collaboration Provisioning application provides a single user interface for the following:

• Cisco Unified Communications Manager

• Cisco Unity Connection

• Cisco Unified Communications Manager IM and Presence Service

This document provides steps to install and provision Prime Collaboration Provisioning on a Cisco Business
Edition 6000 (BE 6000) server.

For more details, see the Prime Collaboration Provisioning Guide:

http://www.cisco.com/en/US/docs/net_mgmt/prime/collaboration/10.0/provisioning/guide/Cisco_Prime_
Collaboration_Provisioning_Guide_10.html

The following applications are configured through their respective native interface and not through Prime
Collaboration Provisioning:

• Cisco Contact Center Express

• Cisco Video Communication Server

• Cisco Emergency Responder

• Cisco Unified Attendant Console

• Cisco Paging Server
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Workflow
Use this document along with other Cisco Business Edition 6000 documentation to complete the following
tasks:

AudienceGo HereTaskDay

PartnerSee the installation guide for
your application
here.

Installation0

PartnerBegin configuration by using
Cisco Unified Configurator for
Collaboration (CUCC), a tool
that establishes the base
configuration across Unified
Communications Manager and
Unity Connection. For
information about this tool,
please see this site.

Base Configuration1

PartnerReverse sync into Prime
Collaboration and use it for
customization.
Infrastructure Provisioning, on
page 9

User and User Service
Configuration, on page 25

Customization2

IT AdministratorHand over Prime to an IT
admininistrator who can
perform MACD work.
User and User Service
Configuration, on page 25

Moves, Adds,
Changes, and
Deletes (MACDs)

3 and on

Related Documentation
The following URL provides Cisco gateway considerations for IP telephony network:

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/srnd/10x/gateways.html

The following URL provides a link to the Cisco Unified Configurator for Collaboration, whichhelps you
quickly install, configure, and deploy basic telephony and simple voice messaging:

http://www.cisco.com/c/en/us/solutions/enterprise/design-zone-branch-wan/cisco_validated.html
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Obtaining Documentation and Submitting a Service Request
For information on obtaining documentation, using the Cisco Bug Search Tool (BST), submitting a service
request, and gathering additional information, seeWhat's New in Cisco Product Documentation, at: http://
www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html.

Subscribe toWhat's New in Cisco Product Documentation, which lists all new and revised Cisco technical
documentation, as an RSS feed and deliver content directly to your desktop using a reader application. The
RSS feeds are a free service.
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C H A P T E R  1
Preparation

Ensure that the BE6000 server is rack-mounted, connected to electrical power source and customer data
network as illustrated in the Quick Start Guide (QSG), which is included in the shipping box. Also ensure
that a monitor and keyboard are connected to the server.

Note

Before you proceed with installation, collect the network information from the data network administrator.

• Concepts, page 1

• Obtain Application, page 3

• License File, page 3

• Virtual Machine Requirements, page 4

• Cisco Unified Communications Manager and Cisco Unity Connection Integration, page 4

• Log In To Application, page 4

Concepts
Prime Collaboration introduces the following concepts:

User

A user with services provisioned like phone, voicemail, and email.

Domain

An area that is managed by a single administrator. Each domain has a domain administrator. Most
BE6K deployments have a single domain as part of a Standard Prime installation. Multiple domains
are available with Prime Collaboration Advanced (available for purchase) that can be used for complex
Business Edition 6000 deployments.

User Roles

Control which products and services that an IT administrator can order for a user. User roles can function
across service areas.
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Service Area

A logical partition that defines the class of services for the services ordered in that service area. A
service area is linked to a single call processor (Unified CommunicationsManager), message processor
(Cisco Unity Connection) and presence processor (IM and Presence Service). User roles and Directory
Number Blocks (DNB) are associated with a service area. A Service Area roughly corresponds to a
site or physical location.

Example 1

A single site customer deployment with user role type executives, managers, employees, contractors and
common area (such as lobby or a conference room) phones.

The following table provides a typical example of how these concepts can be defined.
ServicesPhonesUser Role

Phone, Line, VM, Presence,
Voicemail to Email, Extension
Mobility, SNR

99xx, EX60Executives

Phone, Line, VM, Presence,
Voicemail to Email, Extension
Mobility

89xxManagers

Phone, Line, VM, Presence,
Voicemail to Email

69xxEmployees

Phone, Line, VM, Presence,
Voicemail to Email

6921Contractors

Phone, Line7937Conference Room

Phone, Line69xxLobby

Location 1: Company1Domain

DNBUser RoleService Area

408555XXXX-1310LobbySan Jose

919555XXXX-1300Lobby, Employee, Contractor,
Conference Room

RTP

972555XXXX-1030Lobby, Executive, ManagerRichardson

Example 2

Amulti site customer deployment with user role type executives, managers, employees, contractors, conference
room and common area (such as lobby) phones.

This example is a complex deployment with multiple administrators: one administrator who manages the
east coast, one who manages the west coast along with multiple sites under each domain.

Note

The following table provides a typical example of how these concepts can be defined.
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ServicesPhonesUser Role

Phone, Line, VM, Presence, Email,
Extension Mobility, SNR

99xx, EX60Executives

Phone, Line, VM, Presence, Email,
Extension Mobility

89xxManagers

Phone, Line, VM, Presence, Email69xxEmployees

Phone, Line, VM, Presence, Email6921Contractors

Phone, Line7937Conference Room

Phone, Line69xxLobby

Location 1: Company2, West Coast. IT administrator: BobDomain

DNBUser RoleService Area

415555XXXX-1310LobbySan Francisco

310555XXXX-1300Employee, Contractor, Conference
Room

Los Angeles

206555XXXX-1030Executive, ManagerSeattle

Location 2: Company2, East Coast. IT administrator: BillDomain

DNBUser RoleService Area

646888XXXX-1497LobbyNew York

617888XXXX-1490Employee, Conference RoomBoston

305888XXXX-1340Executive, ManagerMiami

Obtain Application
Prime Collaboration Provisioning, along with the license file, is preloaded on the Cisco BE 6000 server
datastore. You can also download the provisioning application and the license from the Product Upgrade Tool
(PUT). You must have a valid contract to place an order through the PUT.

License File
The license file allows you to manage the following:

• Single cluster

• 1000 users and 2500 devices

• One Cisco Unified Communications Manager

• One IM and Presence Service
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• Self Care user logins

Virtual Machine Requirements
Disk SpaceNICMemory

Reservation
RAMCPU

Reservation
Number of
CPUs

Endpoints
Managed in
Prime
Collaboration

90 GB1 GB2 GB2 GB2 GHz1Up to 2500
endpoints
(small)

Cisco Unified Communications Manager and Cisco Unity
Connection Integration

The instructions for integrating Cisco Unified Communications Manager with Cisco Unity Connection by
Skinny Call Control Protocol (SCCP) are provided in the URL that follows. Cisco Unity Connection supports
SCCP integration when Unified Communications Manager has only SCCP phones or has both SCCP and SIP
phones.

http://www.cisco.com/en/US/docs/voice_ip_comm/connection/10x/integration/guide/cucm_sccp/
cucintcucmskinny070.html

The following URL provides Cisco Unified Communications Manager SIP Trunk Integration with Cisco
Unity Connection:

http://www.cisco.com/en/US/docs/voice_ip_comm/connection/10x/integration/guide/cucm_sip/
cucintcucmsip060.html

Log In To Application
Procedure

Step 1 Open a browser session on your PC.
Step 2 Enter http://<Prime Collaboration IP Address>.

The Prime Collaboration login page appears.
Step 3 Log in as a globaladmin, using the same the credentials that you specified during initial configuration.
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C H A P T E R  2
Initial Configuration

• Virtual Appliance Installation, page 5

• Activate Services, page 5

• Install License, page 6

Virtual Appliance Installation
To deploy and install the Prime Collaboration Provisioning virtual machine, see the Installation Guide for
Cisco Business Edition 6000:

http://www.cisco.com/en/US/partner/products/ps11369/prod_installation_guides_list.html

The complete installation time for the Prime Collaboration Provisioning application is approximately 30
minutes.

Activate Services

For 10.0(1), some of these services are automatically activated.Note

For Cisco Prime Collaboration Provisioning to interact with Cisco Unified Communications Manager and
IM and Presence Service servers, you must activate the Cisco AXL Web Service on both servers.

Procedure

Step 1 Perform the following actions to enable services on Cisco Unified Communications Manager:
a) Log on to native web interface.
b) Go to Navigation > Cisco Unified Serviceability and click Go.
c) Click Tools > Service Activation.
d) Enable the following services, as per the site requirements:

• Cisco CallManager
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• Cisco CTIManager

• Cisco Extension Mobility

• Cisco TFTP

• Cisco AXL Web Services

• Cisco DirSync

e) Click Save.

Step 2 Perform the following actions to enable services on IM and Presence Service:
a) Log on to native web interface.
b) Enter the Unified Communications Manager Publisher configuration: the Hostname and IP Address.
c) Enter AXL login information for the Unified Communications Manager Publisher: the AXL User and

Password.
d) Enter the Security Password for secure communication among Unified Communications Manager and

the IM and Presence Service server. This password must match the security password configured on the
Unified Communications Manager Publisher node.

e) Verify the information and click Confirm to proceed.
f) At the top right corner, go to Navigation > Cisco Unified IM and Presence Serviceability and clickGo.
g) Select Tools > Service Activation.
h) Enable the following services, as per the site requirements:

• Cisco SIP Proxy

• Cisco Presence Engine

• Cisco Sync Agent

• Cisco AXL Web Services

• Cisco XCP Connection Manager

• Cisco XCP Directory Service

• Cisco XCP Authentication Service

i) Click Save.

Install License
Procedure

Step 1 Log in to the Prime Collaboration Provisioning web interface using globaladmin credentials.
Step 2 Navigate to the license management user interface under the Administration tab.
Step 3 Copy the new license fileto the license directory.
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Example:
PCP10BENNL2500.lic

Step 4 Remove any other licenses from the license directory.
Prime Collaboration Provisioning automatically updates to the BE6000 version.
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C H A P T E R  3
Infrastructure Configuration

• Cisco Unified Configurator for Collaboration, page 9

• Infrastructure Provisioning, page 9

• Add Device, page 10

• Infrastructure and User Synchronization, page 10

• Configure LDAP Server Synchronization, page 12

• Delete Device, page 15

• Enable Cisco Jabber Services, page 16

Cisco Unified Configurator for Collaboration

Assuming a base configuration has been established on the Unified Communcations Manager and Unity
connection servers, you can reverse sync the configuration and add devices into Prime Provisioning.

Note

Begin your configuration by using Cisco Unified Configurator for Collaboration (CUCC). See the following
URL for CUCC package downloads that also contain further information in the embedded online help:

http://www.cisco.com/en/US/solutions/ns340/ns414/ns742/ns816/cisco_validated.html

Infrastructure Provisioning
The Infrastructure Configuration page lets you browse the infrastructure configuration settings of a Call
Processor and Unified Message Processor. Through this page, you can add, edit, or delete the configuration
settings of a Call Processor and Unified Message Processor.
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The Infrastructure Configuration feature applies to Call Processors that are based on Cisco Unified
Communications Manager devices and Unified Message Processors that are based on only Cisco Unity
Connection.

Note

If you are reverse synchronizing a Cisco BE 6000 that you installed using CUCC, you can use this section
for general administration and further customization.

Tip

Add Device
Follow this procedure to add devices (applications) to Provisioning.

Procedure

Step 1 Choose Design > Infrastructure Setup.
Step 2 In the Infrastructure Setup page, Click Add to add devices to Provisioning.
Step 3 In the Add Device window, select the required application from the drop-down list and enter the necessary

information such as Name and IP address.
For the device name, valid values are space, alphanumeric characters (A-Z, a-z, 0-9), underscore (_),
hyphen (-), period (.), and at sign (@).

Note

Step 4 Click Save.
Devices are added to Provisioning. You will see two status messages appearing at the bottom of the page.
One on whether the addition of the device was successful or not, and another on the Test Connection stating
whether the connectivity test was successful or not . Devices with multiple applications are added as separate
devices in the table.

While adding Cisco Unity Connection 10.0, you must configure both Unity Connection administrator
and Operating System (OS) administrator credentials.

Note

Infrastructure and User Synchronization
You use the infrastructure synchronization to synchronize the infrastructure data in the devices. The
infrastructure synchronization retrieves device information that is used across multiple users.

To synchronize infrastructure configuration products and users:

Procedure

Step 1 Choose Design > Infrastructure Setup.
Step 2 Hover over Quick View of the device for which you want to run synchronization.
Step 3 Do one of the following:
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To initiate Infrastructure Synchronization, click Start Infrastructure Synchronization•

• To initiate User Synchronization, click Start User Synchronization

The progress of synchronization is displayed in the Quick View under Synchronization Status.

Step 4 Click View Detailed Logs.
A synchronization log is created, listing the objects that could not be assigned. It also shows a warning message
if an unknown element is received from the device. This log is replaced each time a synchronization occurs.

If you see the warning message “Skipped unexpected element,” you can ignore it. The message
indicates that Provisioning does not support the item that was sent back from the device.

Note

If the status of an infrastructure or user synchronization does not change for an extended period of time, verify
that the Nice service is running. Run the following command to check if the Nice service is running:
ps -aef | grep nice
If the Nice service is stopped, restart the service, and then restart the infrastructure or user synchronization.

If you wish to manage the Analog Phones, you have to update the ipt.properties file. In this file, update the
dfc.ipt.cisco.callmanager.analog_phone_support to Y and then do the user synchronization. You must restart
Provisioning after the user synchronization is completed.

For the list of Cisco Unified Communications Manager objects that Provisioning synchronizes, see Cisco
Unified Communications Manager Objects that Are Synchronized.

You use the infrastructure synchronization to synchronize the unified messaging infrastructure data in
Provisioning with the Unified Message Processor:

• SubscriberTemplate—A Subscriber Template in Cisco Unity, Cisco Unity Connection, and the e-mail
message processor.

• UnifiedMessagingFeatureSpecification—A class of service in Cisco Unity, Cisco Unity Connection,
and the e-mail message processor.

You use the user synchronization to synchronize the unified messaging user data in Provisioning with the
Unified Message Processor.

• UMInfo—A user in Cisco Unity, Cisco Unity Connection, and Cisco Unity Express in conjunction with
their user’s voicemail and e-mail information.

• VoiceMailInfo—A user in Cisco Unity, Cisco Unity Connection, and Cisco Unity Express in conjunction
with UMInfo and EmailInfo.

• EmailInfo—A user in Cisco Unity and Cisco Unity Connection in conjunction with VoiceMailInfo and
UMInfo.

If during the synchronization of Cisco Unity Express you encounter device connection errors, close all
Telnet sessions on the Cisco Unity Express system and restart the synchronization. Cisco Unity Express
only allows one Telnet session at a time. Provisioning cannot synchronize with a Cisco Unity Express
device that has another telnet session open.

Note
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IM and Presence 9.0 and higher versions are integrated with Cisco Unified Communications Manager.
Due to this, user synchronization will be disabled for IM and Presence 9.0 and higher versions. User
information will be directly synchronized from Cisco Unified Communications Manager.

Note

For IM and Presence, use the Infrastructure synchronization to synchronize the User Settings Infrastructure
data with Provisioning.

After upgrading your Cisco Unified Communications Manager, you must perform User Synchronization
manually to synchronize change notification settings.

Note

Configure LDAP Server Synchronization
Procedure

Step 1 Choose Design > User Provisioning Setup.
Step 2 From the Domains table, select a Domain and click Edit.
Step 3 In the Domain Configuration page, select an LDAP Server.
Step 4 In the LDAP Settings pane, you configure the information Provisioning gets from the LDAP server. (For

descriptions of the fields in this page, see ).
Step 5 For all the changes on the LDAP server to be synchronized to Provisioning, select the following:

• Mode—Authentication and Synchronization.

• Update existing user details—All fields.

• Action when LDAP users deleted—Delete user only.

• User Search base—Enter a user search base.

• Filter query for synchronization—Synchronize all users.

Step 6 Click Save.

To schedule synchronization, set the Synchronization Interval and Synchronization Start Date in the LDAP
Settings pane.

After saving the Domain Configuration page, select the Domain and hover over Quick view. Select Start
LDAP Synchronization.

After an LDAP synchronization, a report is created. The report lists the operations that could not be performed
during synchronization. Operation failure can be due to incorrect data entered into the LDAP server or incorrect
user settings.
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You cannot delete an LDAP server which is associated to a Domain. You must remove the LDAP server
from the Domain to delete it.

Note

Table 1: LDAP Settings Fields

DescriptionField

• Authentication Only—The LDAP server is used only for user
authentication.

• Authentication and Synchronization—The LDAP server is used both to
provide user authentication and to obtain user information.

Mode

• All fields—If any user information is changed in the LDAP server, the
same information is updated in Provisioning.

• Do not update—User information in Provisioning is not updated when
there are changes to the user information in the LDAP server.

Update Existing User
Details

• Do not delete—When a user is deleted in the LDAP server, the
corresponding user in Provisioning is not deleted.

• Delete user only—When a user is deleted in the LDAP server, the
corresponding user is deleted in Provisioning alone.

• Delete user with services—When a user is deleted in the LDAP server,
only the corresponding user service is deleted in the device and in
Provisioning. The user is not deleted in the device, but deleted in
Provisioning.

Action when LDAP users
deleted

The user search base. Provisioning searches for users under the base. CN-Users,
DC-Cisco, DC-com.

This search base is used only for LDAP synchronization; it is not used for
authentication.

In the Microsoft Active Directory server, you can use the command dsquery
user to list the complete user search base.

User Search Base
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DescriptionField

Lists which user fields in Cisco Unified Communications Manager correspond
to certain LDAP user fields. The only fields you can configure in Provisioning
are the following:

• Contact phone number—Select either telephone number or ipPhone.

• Contact email—Select either mail or sAMAccountName.

• User ID—User ID can be mapped to the following fields in LDAP server:

◦employeeNumber

◦mail

◦sAMAccountName

◦telephoneNumber

◦userPrincipalName

Field Mapping

• Synchronize all users—All users will be synchronized.

• Simple query—You can configure a query by using a combination of the
following fields:

◦User ID

◦Department

◦Contact phone number

◦Contact email
You can use an asterisk (*) for a partial string search.

• Advanced query—You can enter any LDAP query; for example:

(&(sAMAccountName=johndoe)(department=Cisco*)(mail=john@cisco.com)).

Filter Query for
Synchronization

The table below lists the field mapping between Provisioning and the LDAP server. The data in the specified
Provisioning field is synchronized with the user data in the corresponding LDAP field.

Table 2: LDAP Field Mapping

LDAP FieldProvisioning Field

telephoneNumber or ipPhone number.Phone Number

mail or sAMAccountName.Email
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LDAP FieldProvisioning Field

User ID can be mapped to the following fields in LDAP server:

• employeeNumber

• mail

• sAMAccountName

• telephoneNumber

• userPrincipalName

User ID

givenName.First Name

sn.Last Name

Delete Device
To completely remove a device from Provisioning, you must delete it through the Infrastructure Setup page.

Note the following points when you are deleting a device:

• No active released orders, including unrecoverable or recoverable errors.

• No active batch projects.

• No synchronizations in progress.
If these conditions are not met, a message appears on the page when you attempt to delete a device.
Avoid performing any activities until the deletion is complete.

• Before deleting a AAA server, make sure it is not assigned to a Domain.

• There must not be any pending orders on the device. You do not need to be in maintenance mode to
delete the device capability. However, if another capability is already configured on the router, system
must be in maintenance mode to remove the other capability.

Procedure

Step 1 Put Provisioning in maintenance mode.
Step 2 Choose Design > Infrastructure Setup.
Step 3 In the Infrastructure Setup page, select the device you want to delete and click Delete.
Step 4 In the confirmation dialog box, click OK to confirm deletion.
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Enable Cisco Jabber Services
You can enable Cisco Jabber services for devices in Prime Collaboration Provisioning. Cisco Jabber services
allow you to interact with instant messaging and availability.

Cisco Jabber service is available for Cisco Unified Communications Manager 9.1.1 and above version,
and Cisco Unified Presence only.

Note

Procedure

Step 1 Choose Deploy > Unified Communication Services.
Step 2 In the Unified Communication Services page, click Enable.
Step 3 Enter the SIP Profile, Service Profile, Softkey template fields and Service Parameter information, and click

Apply. You can click View Order to see the order details in the User Record page. The date when the Jabber
Service is enabled appears.

After you enable Cisco Jabber service for a call processor, you cannot edit or disable
it.

Note
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C H A P T E R  4
Domain and Service Area Configuration

• Add Domain, page 17

• Add Service Area, page 17

• Add Directory Number Block, page 20

• Add User Role, page 21

• Synchronize Domain, page 22

• Deploy Infrastructure, page 23

Add Domain
After you create a Domain, you can add Service Areas and user roles that have access to your new domain.
You can also create a service template and assign it to a Service Area and User Role. A service template can
be associated to several such combinations of Service Areas and User Roles.

Procedure

Step 1 Choose Design > User Provisioning Setup.
Step 2 Click Add, to add new domains in the Domains page.
Step 3 Enter the necessary fields such as Call Processors, Message Processors, synchronization rules, LDAP settings

and so on, and click Save. You need to provide a Domain Name for the Name field. Valid values are space,
alphanumeric characters (A-Z, a-z, 0-9), and the following special characters: _ - . / : ; = ? @ ^ ‘ { } [ ] | ~.
You can set the Domain Synchronization rules in the Synchronization Rules pane. Select the Synchronization
Rules for Cisco Unified Communications Manager and Unity Connection. Mouse over the (?) icon for details
on the specific synchronization rule.

Add Service Area
When configuring a Service Area, you can do the following:
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• Map the Service Area to the corresponding Call Processor objects by specifying its Call Processors and
related objects (for a Cisco Unified Communications Manager, some examples are route partition, and
device pool), Unified Message Processor, and Unified Presence Processor.

• Specify the user types for the Service Area (only users within a Service Area can order products from
it).

The Employee user role is the default based on the Domain rule DefaultUserType.

• Create directory number blocks for the Service Area users.

• Unified Presence Processor settings will list the Presence processor if the selected Call Processor has
associated Presence processors.

After a Service Area is assigned to a Domain, it cannot be moved to a different Domain. Further, after a
Call Processor, Unified Message Processor, or Unified Presence Processor is assigned to a Service Area,
it cannot be changed.

Note

Procedure

Step 1 Choose Design > User Provisioning Setup.
Step 2 Select the Domain for which you want to create a Service Area.
Step 3 Expand the Domain, and select Service Area.
Step 4 Click Add.
Step 5 In the Service Area Configuration page, enter the necessary fields and click Save. The table below describes

the necessary fields.

To edit an existing Service Area, expand the list of Service Areas in the left pane, and click a particular Service
Area to edit. You can also select a Service Area from the table and click Edit.
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Table 3: Service Area Configuration Fields

DescriptionField

Configuration of common device settings for the Service Area. The following
settings are controlled by Common Device Configuration:

• Softkey Template

• User Hold MOH Audio Source

• Network Hold MOH Audio Source

• User Locale

• MLPP Indication

• MLPP Preemption

• MLPP Domain

This field appears only if you selected Cisco Unified
Communications Manager 6.0.

Note

Common Device Config

Location to be assigned to a device.Location

Route partition for the Service Area. This is the same as a partition in Cisco
Unified Communications Manager.

Partition

Device pool for the Service Area.Device Pool

Voice gateway references for the Service Area.Voice Gateway References

Available only for Cisco Unity Connection and integrated with an external
Exchange Server for IMAP client support.

To configure an external Exchange Server for IMAP in Cisco Unity
Connection, on the Cisco Unity Connection system, go to System Settings >
External Services > Add New, and fill in the required fields.

Email Processors

Subscriber Template to be used to disable unified messaging for a user in the
Unified Message Processor.

Subscriber Template without
TTS Enabled

Prime Collaboration Provisioning Guide for Cisco Business Edition 6000, Release 10.0(1)    
   OL-31212-01 19

Domain and Service Area Configuration
Add Service Area



DescriptionField

Class of Service Template to be used to enable unified messaging for a user
in the UnifiedMessage Processor. It is used in conjunction with the Subscriber
Template.

To enable TTS for a CoS, you must configure the following in Cisco Unity
Connection:

• For Cisco Unity Connection 8.x, do one of the following:

◦Select Allow Users to Access Voice Mail Using an IMAP Client
field (under Licensed Features).

◦Select AllowAccess to Advanced Features field and AllowAccess
to Exchange Email by Using Text to Speech (TTS) (under Licensed
Features).

Subscriber CoS with TTS
Enabled

Class of Service Template to be used to disable unified messaging for a user
in the UnifiedMessage Processor. It is used in conjunction with the Subscriber
Template.

Subscriber CoSwithout TTS
Enabled

Directory number block assigned for that Service Area.Directory Number Blocks

• Common Device Config, Location and Partition fields apply only to Cisco Unified Communications
Manager.

• Subscriber CoS with TTS Enabled, and Subscriber CoS without TTS Enabled fields apply only to Unity
and Unity Connection.

Add Directory Number Block

The Minimum Length field indicates the minimum number of digits that a directory number can contain
before the prefix is added. This is used by the system to pad numbers with zeros. For example, if prefix
= 408, first number = 0, last number = 100, and minimum length = 4, then the range of the directory
number block would be 4080000 through 4080100.

Note

To Edit, select the Directory Number Block, and click Edit. Make the necessary changes and click Save. To
discard the changes, click Cancel.

To delete a Directory Number Block, click Delete.
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Procedure

Step 1 Choose Design > User Provisioning Setup.
Step 2 Expand the Domain and Service Area in the left selector pane, and select the required Service Area.
Step 3 In the Directory Number Block(s) field, click Add Row.
Step 4 Complete the fields as required and click Save.

Add User Role
User roles control which products and services a user can order.

The default user roles are:

• Employee—Default role assigned to new users.

The Employee user role should be configured tomatch the typical setup of employees in your organization.
If you do not configure the employee user role to meet your needs, you may not see all the desired
options in the employee user record.

• Executive

• Pseudo—Used to order phones that do not have an associated user. Pseudo users cannot be renamed or
removed.

A pseudo user is authorized to manage phone and directory number inventory.

These user roles exist in each Domain in Provisioning. Each set of user roles may be customized in each
Domain by adding, removing, or changing these predefined user roles.

Before You Begin

You must first add a user, then assign the user the Pseudo user role.

If users already exist on Unified CommunicationsManager or if they have been synchronized from LDAP,
you do not need to add users.

Note

Procedure

Step 1 Choose Design > User Provisioning Setup.
Step 2 In the All Domains pane, expand a specific domain and click User Roles.
Step 3 In the User Roles for a specific domain page, click Add.
Step 4 In the User Role Configuration page, enter the required details for user role name, domain, lines, services,

service bundles, and click Save.
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• To change a user role configuration, select a user role, click Edit in the User Role for a specific domain,
and save the modifications.

• To delete a user role, select a user role, click Delete in the User Role for a specific domain, and click
OK.

Associate User Role with Service
A user whose role is associated with specific endpoints can order them. You can create orders for endpoints
and services, individual services, or you can order bundled services.

Procedure

Step 1 Choose Design > User Provisioning Setup.
Step 2 In the All Domains pane, expand a specific domain, click User Roles.
Step 3 In the User Roles for the selected domain pane, click Add.
Step 4 Specify a name for the user role and associate it with the necessary Endpoints, Lines, Services and Service

Bundles. You can check or uncheck as many Endpoints, Services and Service Bundles as needed.
To modify the user role configuration, select User Roles. In User Roles for a specific domain, select
a user role and click Edit.

Note

Step 5 Click Save.

Synchronize Domain
Before You Begin

Domain synchronization cannot be started without configuring synchronization rules.

Procedure

Step 1 Choose Design > User Provisioning Setup.
Step 2 From the Domains table, hover over quick view of the Domain you want to synchronize, and click Start

Domain Synchronization.
A popup appears saying that the Domain Synchronization has started successfully. The Last Synchronization
field in Quick View displays the status of synchronization along with the start and completion time.

What to Do Next

Partners can now customize Infrastructure by using theDeploymenu. The Infrastructure configuration window
allows you to customize Core UC applications from one location.
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Deploy Infrastructure
Procedure

Step 1 Choose Deploy > Infrastructure Configuration.
All available devices are listed in the left pane.

Step 2 Expand each device to view the infrastructure product of that device.
Step 3 Click the desired infrastructure product to cross launch or launch it natively:

•When you cross-launch, the Find and List page of the device appears. Click Add New, enter the necessary
information, and click Save.

• Some of the infrastructure products (whose versions are earlier than 10.0) are launched natively, where
you can add a product instance and configure it within Provisioning. Perform the following steps:

1 ClickAdd and enter the necessary information in the Infrastructure Configuration - configure Product
Instance page. An asterisk next to a field indicates a required field.

2 Click Apply or Save as Draft.
Apply sends the configuration immediately to the device. Save as Draft saves the configuration
locally. At a later time, the service can be pushed to the device either by clicking Apply or by using
infrastructure configuration scheduling.

When you choose Save as Draft, the provisioning state of the object changes to Uncommitted Add.
The operational status is inactive, meaning that the object has not been pushed to the device.

Clicking Applymay cause the devices to restart and end calls in progress.Note
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C H A P T E R  5
User and User Service Configuration

• Add User, page 25

• Order Service for a User, page 26

• Process Order, page 41

Add User

If you already used CUCC, then users are synced and ready for order processing. You can use Prime
Collaboraiton to add additional features and services to these users.

Note

Procedure

Step 1 Choose Deploy > User Provisioning.
Step 2 In the User Provisioning page, click Add.
Step 3 In the Add User window, enter the User ID, Domain, and Last name. Also, enter values for other fields if

required.
To launch quick view for a particular domain or user role, while selecting the domain and user role, click the
drop-down menu and hover on the quick view icon.

Step 4 In the Save and Begin Provisioning drop-down, perform the following actions as necessary:

• To save the details and launch the Service Provisioning page for the user, click Save and Begin
Provisioning.

• To save the details and add another user, click Save and Add Another.

• To save the details and close the Add User window, click Save and Close.
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Note • If you are removing a user who has services associated, you are notified to disassociate the
services before removing the user.

• Pseudo role allows you to provision phones without an associated user in the Call Processor.

•While selecting roles for user, the default or Employee user role should be configured to match
the typical setup of employees in your organization. If you do not configure the default or
Employee user role to meet your needs, you may not see all the desired options in the employee
user record.

• The DefaultUserType rule controls which user role is set as the default. Provisioning comes
with the Employee user role configured as the default user role. If you update the default user
role name for a domain in Provisioning, make sure you update the DefaultUserType rule with
the new default role name for that domain.

• Changing the username does not also change the phone or line description field for the user (if
a phone or line was ordered for the previous username).

• For Cisco Unified Communications Manager, the combination of characters for First Name
and Last Name cannot exceed 30 characters.

• If a user does not have any associated services, you are prompted to confirm removal of the
user.

•When a service is disassociated from a user, the service is not deleted or disassociated on the
device (processor); it is only disassociated within Provisioning.

•When a subsequent Domain synchronization occurs, depending on the synchronization rules,
the user could be created again, and the services could be associated with the user.

Order Service for a User

A partner can hand this section to the IT administrator who can performmoves, adds, changes, and deletes
(MACDs) with this tool.

Note

Creating orders for all services follow the same basic procedure.

A user might not have access to all services. The list of services that appear in a given user record depends
on the following:

• User role assigned to the user, and the Domains and Service Areas available to the user.

• Availability of resources to support delivery within the Service Areas (for example, a Cisco Unity or
Cisco Unity Connection system must be available to provide Unified Messaging).

• Provisioning system configuration.

Service dependencies:

• Line requires an existing endpoint.

• Voicemail and Email require an existing Line.
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• Unified Messaging requires Email.

• Extension Mobility Line requires Extension Mobility Access.

Procedure

Step 1 Choose Deploy > User Provisioning.
Step 2 In the User Provisioning page, select a user.
Step 3 In the User Service Details page, click New Service.
Step 4 Select a Service Area from the drop down list. Rest your mouse pointer over the quick view icon for information

on a Service Area in the drop-down list.
Step 5 Click Continue.

All available services which you can provision are displayed, see .

Step 6 Select the service that you want to provision and click Continue.
If endpoints are not displayed in the list for a user, you must associate the user role of a specific user
to endpoints.

Note

Step 7 In the Service Provisioning page, follow the Order Entry wizard, entering the required information for the
service.
When placing orders, note the following:

• The <Service Type> Information and Advanced Order Configuration panes provide specifications for
the selected service.

• Users with Advanced Order or Administrator authorization role can access the Advanced Order
Configuration pane. However, an order can be completed or an endpoint can be provisioned without
using Advanced Order configuration.

To clear the value of a provisioning attribute that has a numeric value in the Cisco Unified
Communications Manager, you must enter zero as the value. If you do not specify any value
and leave the field blank, you cannot clear the value of the provisioning attribute.

Note

Step 8 Click Continue to create the order.
Step 9 Click Confirm, and then click OK. You can view the order number in the Service Details page. Verify order

status by reviewing the Provisioning History pane. To search for a specific order, see .
You can use the global search option (search available in the right corner of the home page) to search Subscriber
ID and Last Name, MAC address and Directory Number.

• For Subscriber ID and Last Name search, alphanumeric characters (A-Z, a-z, 0-9), hyphens (-),
underscores (_), dots (.), at signs (@), space and apostrophe are allowed. Example, AASJKUser006,
AAS*, AA*, *SJKUser006, 3242#@!#########&@!*@(3), AANewRDUser00*

• For MAC Address search, alphanumeric characters (A-Z, a-z, 0-9), dash (-), period (.), and underscore
(_) are allowed. Example, 0024C444C3C6, 0024*, *24

• For Directory Number search, alphanumeric characters, period, and underscore are not allowed. Special
characters such as +, ?, (), and - are allowed in the directory number. Example, \+0000057, \+0000*,
\+*, *0000*, *57
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Note •When you search for phones using the MAC address in the global search option, use the format
xxxxxxxxxxxx.

• A minimum of three characters in the search string is recommended to enable faster retrieval
of search results.

To view the provisioning attributes for an ordered service, in the Service Details page, hover over the desired
service, and then click View in the Actions list.

To add user notes to an ordered service, in the Service Details page, hover over the desired service, and then
click User Notes in the Actions list.

To create a template for the service you have created, click Create Template from Quick View. Enter the
necessary details and click Create Template. A template will be created for the service with all its values.

If you are deploying a large number of services, you may want to combine these activities into a single activity.
The batch provisioning functionality of Provisioning enables you to create a single batch that contains multiple
types of orders. You can also combine multiple types of services into a single batch operation.

To configure a batch project, choose Deploy > Batch Provisioning.

While provisioning a service, if selecting the Security Profile Provisioning Attribute results in an error,
uncheck the Protected Device option for the order to complete successfully. Make sure the Cluster and
Device Security Modes are configured appropriately for the Cisco Unified Communications Manager
cluster. For information about the security parameters in Cisco Unified Communications Manager, see
Cluster and Security Modes in the Cisco Unified Communications Manager Security Guide for your
release, available here: http://www.cisco.com/en/US/products/sw/voicesw/ps556/prod_maintenance_
guides_list.html.

Note

Table 4: Provisioning Services

DescriptionService

Enables Mobility for the selected user on the selected Call Processor. When
ordering using default parameters, the following provisioning attributes are
used:

• Enable Mobility: True

• Enable Mobile Voice Access: True

• Max Desk Pickup Wait Time: 1000 ms

• Remote Destination Limit: 4

• Primary User Device

This service is available only for Cisco Unified Communications Manager
6.0.x and later.

Enable Mobility Support
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Enables presence messaging updates by enabling the user's Presence Server
license on a Call Processor. This option is available only for Cisco Unified
CommunicationsManager 8.x and later. You will not be able to see this service
for ordering until you associate the service to a user role.)

Enable Presence

Enables the use of Cisco Unified Personal Communicator by enabling the
user's Unified Personal Communicator license on a Call Processor. This is a
bundle of Enable Presence Client and Client User Settings.
Enable Presence Client is available only for Cisco Unified Communications
Manager 8.x and later. This service is available only when you order Enable
Presence.

You will not be able to see this service for ordering until you associate the
service to a user role.

Enable Presence Client

Includes an Extension Mobility device profile, line, and voicemail for the
selected user on the selected Call Processor.
This bundle enables you to create standard provisioning services such as
Extension Mobility, line, and voicemail in a single order. You will not be able
to see this service for ordering until you associate the service to a user role.

Enhanced Mobility Service

Includes an Extension Mobility device profile, line, voicemail, e-mail and
unified messaging for the selected user on the selected Call Processor.
You will not be able to see this service for ordering until you associate the
service to a user role.

Enhanced Mobility Service
with Unified Messaging

Enables Unified Personal Communicator user settings on a Unified Presence
Processor. Client User Settings can be ordered only through bundle services
such as Enable Client Service or Presence Service.
You will not be able to see this service for ordering until you associate the
service to a user role.

Client User Settings
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• Enables use of a personal computer along with a physical endpoint (both
ring at the same time), or a CTI port (a virtual phone defined on Unified
Communications Manager).

• Not supported on Unified Communications Manager Express, or when
ordering from a Call Processor based on Unified Communications
Manager Express.

•Will not appear in your service list if all of your available Call Processors
already support SoftPhone. A list of valid Service Areas appears for
specific Call Processors that are available to you.

•When ordering, specify the server name or IP address of the user's
computer in the Associated PC field.

• Although you enable this service based on Service Area, you can do so
only once per Unified Communications Manager, even if more Service
Areas are associated with it.

• Applies only to a Cisco SoftPhone that uses a CTI port. Cisco IP
Communicator does not use CTI ports to communicate with Unified
Communications Manager, but acts as a physical endpoint with a MAC
address. To order Cisco IP Communicator, you must order a physical
endpoint and select Cisco IP Communicator as the endpoint type.

• Required for Cisco Jabber for Desktop to function as a desktop phone
on a Cisco Jabber for Desktop client.

Enable SoftPhone Support

Includes an endpoint, line, and voicemail. The line is automatically associated
with the endpoint that you ordered, and the voicemail is automatically
associated with the line.
When placing an order for Enhanced Endpoint Service on a Cisco Unified
Communications Manager Express, you must enter the call-forward
provisioning attributes. When entering an order, click Advanced Order
Configuration and in the Voicemail Configuration Template provisioning
attribute, enter the following commands: call-forward busy <voice mail

port/dn> call-forward noan <voice mail port/dn> timeout <seconds>

For a Cisco Unity Express Service Area, enter only alphabetical characters in
the VoiceMail Display Name field. If you use other types of characters, orders
for the user will fail.

For Cisco Unity Express Service Area, you cannot add, modify, or cancel
orders when the infrastructure or user synchronization is in progress.

Enhanced Endpoint Service
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Enables users to log into a specific endpoint type and have their endpoint
device profile applied to it. This service is available either by itself, or bundled
with a line.

Extension Mobility is available for ordering only if the optional extension
mobility details are entered for a Call Processor when it is added to
Provisioning.

When placing an order for Extension Mobility Access in a Service Area that
supports SIP phones, select a phone button template only for the following
Cisco Unified IP Phones: 7911, 7941, 7942, 7945, 7961, 7962, 7965, 7970,
7971, or 7975.
The order will fail if ExtensionMobility is not supported on the selected phone
button template.

While ordering Extension Mobility Access for iPhones, order may fail if you
use the default values for the following attributes:

• DND Option

• DND Incoming Call Alert (Set-only Attribute)

• MLPP Indication

For ordering Extension Mobility Access for iPhones, it is recommended that
you create a service template with the following values for these attributes
and apply the template while creating an order:

• DND Option—Call Reject

• DND Incoming Call Alert—Disable

• MLPP Indication—Off

Extension Mobility Access
or Access with Line

The directory number/line ordered for a device profile on a Cisco Unified
Communications Manager. It can be ordered as an upgrade when the user
already has Extension Mobility Access.

Extension Mobility Line

Allows you to order Jabber service. Cisco Jabber service is orderable for Cisco
Jabber for Tablet, Cisco Jabber for Desktop, Cisco Jabber for Android, Cisco
Jabber for BlackBerry, and Cisco Jabber for iPhone. You must at least have
an employee's role for user role type to view the Cisco Jabber Service in the
order page.
If you are upgrading from Prime Collaboration 9.0 to Prime Collaboration
9.5 version, you will not be able to see this service for ordering until you
associate the service to a user role

Cisco Jabber Service
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Line service can be provisioned for a user with or without an endpoint. No
shipping, assignment, receipt, or tracking (for returns) steps are required for
provisioning a new Line service.

The Upgrade designation next to the Line service indicates that a line is being
ordered for an existing endpoint.
For Call Processors, the display for a line cannot exceed 30 characters. Make
sure that the combination of characters for First Name and Last Name does
not exceed 30 characters. If this limit is exceeded, when you place an order,
the Call Processor sends an error.

End User Association is automatically provisioned for Line services.

Line

Order a line on a shared endpoint when users require their own separate lines
on the same physical endpoint. When this service is provisioned, the endpoint
and all lines on it are displayed in each of the user record.

The Shared icon appears next to the endpoint that is shared in the user record.

Line on a Shared Endpoint

Consists of an endpoint, line, voicemail, and e-mail.Messaging Service
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Order an endpoint that does not have a line or a directory number associated
with it. Must not be associated with a line or a directory number.

For SIP phones, select Yes to enable Extension Mobility for the following
Unified IP Phones only: 7911, 7941, 7942, 7945, 7961, 7962, 7965, 7970,
7971, 7975. Extension Mobility is not supported for any other SIP phones.

Guidelines for endpoint names:

• Unified Personal Communicator:

◦Must match the username. (UPC is automatically added to the
endpoint name after the order is provisioned.)

◦Must contain uppercase letters (A-Z) or numbers (0-9). Other
characters are ignored.

◦May contain 12 additional characters after UPC.

For example, if the username is john_jackson, enter
JOHNJACKSON.

• Cisco Jabber for iPhone:

◦Must contain the prefix TCT. (If you do not enter it, Provisioning
automatically adds it.)

◦Must contain no more than 15 characters, including the prefix.

◦Must consist only of alphanumeric characters (A-Z, a-z, 0-9).
Provisioning converts lowercase letters to uppercase before pushing
the information to the endpoint.

• CTI port-Must contain 1 to 15 characters: alphanumeric (A-Z, a-z, 0-9),
underscore (_), hyphen (-), or period (.)

• IP Communicator-Must contain 1 to 15 characters: alphanumeric (A-Z,
a-z, 0-9), underscore (_), hyphen (-), or period (.).

Cisco Services Framework-Must contain 1 to 15 alphanumeric characters
(A-Z, a-z, 0-9).

Endpoint attributes are displayed based on the supported features for
the selected endpoint type.

Note

Endpoint
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Adds a new endpoint and a line.
While ordering Endpoint service, the maximum number of lines is dependent
on the phone button template for the phone type (if a phone button template
is available). For Cisco Unified Communications Manager Express, because
no phone button templates are available, the maximum number of lines is
defined in the product catalog for each endpoint type.

When placing endpoint service orders for Cisco Unified Communications
Manager Express, note the following: Provisioning always provisions the
ephone-dn with a dual-line.

• Provisioning always provisions the ephone-dn with a dual-line

• During user synchronization, Provisioning synchronizes all the
ephone-dns with single-line, dual-line, and octo-line.

• The endpoint should not have orphan ephone-dns (those that are not
used by, or associated to, an ephone).

Endpoint attributes are displayed based on the supported features for
the selected endpoint type.

Note

Endpoint Service

Order Remote Destination Profile for users, configure their attributes, and
allow selection/configuration of a Remote Destination Profile Line, which
supports Single Number Reach (SNR).
Remote Destination Profile does not support Change Owner and Replace
operations.

You will not be able to see this service for ordering until you associate the
service to a user role.

Remote Destination Profile

Order unlimited Remote Destination Profile Lines in a single Remote
Destination Profile. Remote Destination Profile Line supports Auto-assign or
Chosen types of Lines.

Remote Destination Profile Line can be shared among users and the same
destination can be shared between Remote Destination Profile, Line, and
Enable Mobility Access Line. In this scenario, all types of lines are displayed
as shared lines.

In Remote Destination Profile, you can order VoiceMail or ExtensionMobility
as they are ordered in the Line services.
You can order Remote Destination Profile with any user role but not as a
pseudo user.

You will not be able to see this service for ordering until you associate the
service to a user role.

Remote Destination Profile
Line

Enable the Remote Destination Profile service for all Service Areas to shares
this Call Processor and also add a Remote Destination Profile Line.

You can order Remote Destination Profile with any user role but not as a
pseudo user.

You will not be able to see this service for ordering until you associate the
service to a user role.

Remote Destination Profile
Service
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Configure an Enable Mobility, Remote Destination Profile, and Remote
Destination Profile Line.
For mobility to work on a desktop phone, you must do the following:

• Configure the Line on the phone and Remote Destination Profile to be
shared.

• Configure the User ID that is used for the Remote Destination as an
Owner.

• Create a softkey template in Cisco Unified Communications Manager
and assign it to a desk phone. Provisioning does not support softkey
customization. You must create a customized template in Cisco Unified
Communications Manager.

You will not be able to see this service for ordering until you associate the
service to a user role.

Single Number Reach
Service

You can create an order to add the Unified Messaging feature if you already
have e-mail and voicemail. The UnifiedMessaging feature allows the retrieval
of e-mail from your voicemail, and the retrieval of voicemail from your e-mail.
In Cisco Unity, you will be enabling the Text-to-Speech (TTS) capability. In
Cisco Unity Connection, you will be enabling the TTS and Internet Mail
Access Protocol (IMAP) capability.

The Upgrade designation next to the UnifiedMessaging service indicates that
the existing e-mail and voicemail are being upgraded to include the Unified
Messaging feature.

Unified Messaging

AUnifiedMessaging Service order includes the line, endpoint, voicemail and
e-mail, and Unified Messaging services.
The list of services that are available to users is based on user roles and
Provisioning system configuration. To modify this list to include the services
you require, contact your Provisioning administrator.

Unified Messaging Service
1

Enables presence messaging by enabling the user's presence service settings
on a Call Processor.
To configure User Services, do the following:

1 Add the Presence Server to Provisioning and perform the Infrastructure
synchronization.

2 Add the Presence Server to the Service Area that will be used for ordering.

User Services is available for Cisco Unified Communications
Manager 9.x.

Note

For Cisco Unified Communications Manager 10.0 and above, User
Services will not be available as an orderable service. It is added by
default, when you create an order for a service.

Note

User Services
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Create orders for additional Voicemail and Email services if the user already
has a line.
The Upgrade designation next to the Voicemail and Email service indicates
that the line service is being upgraded to include voicemail and e-mail.

When placing an order for voicemail on Cisco Unified Communications
Manager Express, you must enter the call-forward provisioning attributes.
When entering an order, click Advanced Order Configuration and in the
Voicemail Configuration Template provisioning attribute, enter the following
commands: call-call-forward busy <voice mail port/dn> forward

noan <voice mail port/dn> timeout <seconds>

Voicemail and Email
(bundle)

Create orders for additional Voicemail services if the user already has a line.
The Upgrade designation next to the voicemail service indicates that the Line
service is being upgraded to include voicemail.

When placing an order for voicemail on a Cisco Unified Communications
Manager Express, you must enter the call-forward provisioning attributes.
When entering an order, click Advanced Order Configuration and in the
Voicemail Configuration Template provisioning attribute, enter the following
commands: call-forward busy <voice mail port/dn>call-forward noan

<voice mail port/dn> timeout <seconds>

Voicemail (individually)

Create orders for additional Email services if the user already has a line and
voicemail.
The Upgrade designation next to the Email service indicates that the Line
service is being upgraded to include e-mail.

Email (individually)
2

1 After ordering Email or Unified Messaging Service on Cisco Unity, there is an initial delay in appending the full Domain
information to the email address in the User Record Details page. After placing the order, you should run user synchronization
and Domain synchronization so that the complete email address appears.

2 After ordering Email or Unified Messaging Service on Cisco Unity, there is an initial delay in appending the full Domain
information to the email address in the User Record Details page. After placing the order, you should run user synchronization
and Domain synchronization so that the complete email address appears.

Table 5: Order Entry Fields

DescriptionGUI Element

The name (DNS resolvable) or IP address of the computer to be used with the
SoftPhone support.

Associated PC

Enter the e-mail ID. It cannot contain spaces.Email ID

Enter the name to be used in the From field of the e-mail.Display Name (Email)

Select Yes or No .Enable Extension
Mobility

   Prime Collaboration Provisioning Guide for Cisco Business Edition 6000, Release 10.0(1)
36 OL-31212-01  

User and User Service Configuration
Order Service for a User



Select one of the following: Auto-assigned-System automatically assigns a
directory number.
Chosen Line-User specifies a directory number. The directory number cannot
include dashes or spaces.

Extension Mobility Line

Select one of the following:

• Auto-assigned-System automatically assigns a directory number.

• Chosen Line-You specify a directory number. The directory number cannot
include dashes or spaces.

After the line is configured, to save your settings, you must click the save icon
on the right side of the page.
After you make a selection, the Advanced Order Configuration option appears
on the page. You can then configure the provisioning attributes for the line. You
can copy the provisioning attributes of a configured line on the same endpoint
by selecting the line from the Copy Line field and clicking Done.

Line Type

You can either enter a directory number directly into the field, or you can choose
a directory number by clicking the Chooser icon.
If you click the Chooser icon, a Directory Number search page appears. To use
the Directory Number search page, do the following:

1 In the Directory Number search page, choose your search criteria from the
following:

• Directory Number-Enter a specific number to search for.

• Available DNs-When selected, all directory numbers that are available
in the Provisioning database are displayed.

• Reserved DNs-When selected, all directory numbers that are reserved
for the user for whom the order is being placed are displayed.

• DN Blocks-The directory number blocks that are configured for the
Service Area on which the order is being placed are displayed.

2 Click Find. Your search results appear

3 Click the desired directory number.

The number is entered into the Directory Number field.

Directory Number
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During the order process, a page appears that lists the available line positions on
the endpoint. Next to the line position, it indicates whether or not the line position
is available.
In the line position page, you can do the following:

• Configure the line type-ClickNot Assigned next to the line, and in the next
page, configure the line type. After the line is configured, you must click
the save icon on the right side of the page, to save your settings.

• Change line position-Click the up or down arrow beside the line position.

Line position is not supported on CiscoUnified CommunicationsManager Express
or Extension Mobility Access Lines.

Line Position

Select an endpoint from the list.Selected Endpoint

(Optional) Select aMAC address or enter one. In case of Analog endpoints, MAC
address is generated based on the selected voice port.

MAC Address

Select an endpoint type from the list.Endpoint Type

Select the protocol. Endpoints support both SCCP and SIP, or any one. Provision
with the default protocol set in the Provisioning Attribute.

Protocol

Select a target endpoint from the list.Target Endpoint

List of available Phone Button Templates.Phone Button Template

List of available Service Templates.Service Template

Select an analog voice gateway reference.
Before executing the user synchronization, the infrastructure synchronization
should be executed. During user synchronization, if the synced back analog
endpoint is associated to a voice gateway reference that does not exist in IM, then
the voice port instance creation and its association will be skipped. As a result,
the analog endpoint will not be manageable through Provisioning.

Synchronization of analog endpoints and IM instance creation will be done only
for the Call Processor versions 6.x and above. For Call Processors versions 5.x
and below the analog endpoint instance creation will be skipped since the analog
voice gateway support is provided only for Call Processor version 6.x and above.

The Analog Voice Gateway Reference field is enhanced to include the description
of the gateway along with the alphanumeric reference number. While configuring
the Voice Gateway infrastructure service, if the gateway description is provided,
then the description will appear in the Analog Voice Gateway Reference field.

Analog Voice Gateway
Reference

Name of the Remote Destination Profile.Name

Description of the Remote Destination Profile.Description

Name of the selected Remote Destination Profile.Selected Remote
Destination Profile
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List of available Service Areas.
If a Service Area has a Unity Connection configured as a Unified Messaging
Processor, and the Unity Connection does not have an external e-mail server,
Provisioning will not list this Service Area as an option when ordering Email.

Service Area

List of available e-mails for which you can enable Unified Messaging.Unified Messaging

Used for Tool for Auto-Registered Phones Support (TAPS) phones. If you check
this check box, Provisioning creates a phone with a dummyMAC address, which
is unique in the system.
After a TAPS phone is provisioned on the Cisco Unified Communications
Manager and updated with a real MAC address, you must run a user and Domain
synchronization in Provisioning. This updates the dummy MAC address in
Provisioning with the real MAC address.

After a dummy endpoint is ordered, change and cancel orders do not require a
user or Domain synchronization.

Use Dummy MAC
Address

Enter an alias for the voicemail.Voicemail Alias

Enter a display name for the voicemail.Voicemail Display Name

Based on the Analog Voice Gateway Reference field, the relevant Voiceport is
populated. You can view the list of occupied and available ports. Only the
available port will be selected for ordering.

Voiceport

Lists the available provisioning attributes for the ordered service. This allows
you to set provisioning attributes when placing an order. Click the plus sign (+)
next to the Advanced Order Configuration option to expand this pane.
To unset the value of a provisioning attribute that has a numeric value in Cisco
Unified Communications Manager, you must enter a zero for the value. If you
only clear the value, the provisioning attribute is not unset in Cisco Unified
Communications Manager.

Advanced Order Configuration is available only to users who are assigned the
Advanced Ordering authorization role.

Advanced Order
Configuration

Opens a search page that lists reserved endpoints. A reserved endpoint is booked
for a specific user.

Choose a reserved
endpoint
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Opens a search page that lists all the endpoints in the system that are supported
by the user role. Copy endpoint allows you to provision a new endpoint with the
same settings of an existing endpoint.

To copy settings, in the search page, select an endpoint and clickOK to confirm
that you want the endpoint's settings copied to the new endpoint.

This feature is available only to users with the Advanced Ordering role.

When you have Global access, you can copy all the endpoints that are orderable
for the user, includingmanaged and unmanaged endpoints, as long as the endpoint
belongs to the same Call Processor.

When you have Domain access, you can only copy managed endpoints that are
orderable for the user and are in the user's manageable Domains, as long as the
endpoint belongs to the same Call Processor.

Because some settings are unique to each endpoint, not all settings are copied to
the new endpoint. The following settings are not copied to the new endpoint:

• Directory Number

• MAC Address

• Endpoint Description

When an endpoint is copied, services are not copied to the new endpoint. For
example, if lines, voicemails or e-mails exist on the endpoint, they will not be
copied to the new endpoint. In addition to this, the set only attributes associated
with the endpoint are not copied.

Through Copy endpoint you can only copy the provisioning attributes that are
set while creating an order.

If the Cisco Unified Communications Manager version for the copied endpoint
does not support an attribute, or if the copied endpoint type does not support an
attribute, the attribute is cleared on the new endpoint.

You are allowed to copy only an analog phone to another analog phone. Copying
an IP phone to analog phone is not allowed.

When an endpoint is copied, the provisioning attributes that are set during the
add order are only copied.

Once the Order is completed, in Cisco Unified Communications Manager, the
Overriding Common settings check box is enabled. It means that the default
attributes of the new endpoint have been modified.

Copy endpoint
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You can order Cisco Jabber services only if you have enabled Jabber on a Cisco
Unified Communications Manager. To enable Jabber for a Cisco Unified
CommunicationsManager, chooseDeploy >Unified Communication Services.

Select a Jabber service from the list:

• Cisco Jabber for Tablet

• Cisco Jabber for iPhone

• Cisco Jabber for Desktop

• Cisco Jabber for Blackberry

• Cisco Jabber for Android

Orderable Cisco Jabber
Services

Process Order
After you submit orders for users, the orders are approved and then shipped. Depending on how your
Provisioning system is configured, these steps may be automatic or may require processing by users.

You can assign four possible activities to users during the order processing stage. The activities are assigned
based on the rules set for the Domain.

• Approve orders—Approves orders before provisioning can occur, and can also reject orders. This user
must be assigned the Approval authorization role. This is controlled by the following rules:

• IsAuthorizationRequiredForAddOrder

• IsAuthorizationRequiredForChangeOrder

• IsAuthorizationRequiredForCancelOrder

• Assignment—Assigns MAC address to an endpoint. This user must be assigned the Assignment role.
This is controlled by the rule PhoneAssignmentDoneBy.

• Shipping—Ships the order. This user must be assigned the Shipping authorization role. This is controlled
by the rule PhoneShippingDoneBy.

• Receiving—Done by the user who has the Receiver user role. Indicates that an ordered endpoint has
been received. This is controlled by the rule PhoneReceiptDoneBy.

An administrator can configure how these activities are assigned.Note
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C H A P T E R  6
Self Care Portal Configuration

• Using Prime Collaboration Self-Care, page 43

• Creating a Self-Care Account, page 44

• Launching Prime Collaboration Self-care, page 45

• Customizing Your Personal Settings, page 45

• Self-Care User Migration Script, page 50

Using Prime Collaboration Self-Care
Prime Collaboration provides a telephone Self-Care portal, which allows you to control preference settings
such as user name, password and so on. You can update your own account and services by using the Self-Care
portal. The Self-Care feature enables you to modify line settings, manage services, and configure phone
options.

A new Self-Care feature is introduced in Cisco Unified Communications Manager 10.0. This Self-Care can
be accessed from Cisco Unified CM only. You can enable Prime Collaboration Self-Care, that is, Self-Care
from Prime Collaboration Provisioning for Cisco Unified CM 10.0 and lower versions.

Prime Collaboration Self-Care is also available for Cisco Unified CM 10.0 and Cisco Unity Connection
10.0 along with CM based Self-Care. The administrator must turn-off the "Enable Prime Collaboration
Self-Care" check box in the User Provisioning page if Prime Collaboration Self-Care is not used.

Note

Cisco Unified Communications Manager Self-Care is recommended when the environment is Cisco Unified
CM 10.0 only with Cisco Unity Connection 10.0 only, or Users with services on only one Cisco Unified CM
10.x cluster.

When Cisco Unified Communications Manager is shared between two or more users, and if one or more
users are using LDAP, Prime Self-Care will be used regardless of the version of Cisco Unified
Communications Manager.

Note

To enable Prime Collaboration Self-Care, see Creating a Self-Care Account, on page 44.
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To enable CM based Self-Care, see Cisco Unified Communications Self Care Portal User Guide, Release
10.0.0

Creating a Self-Care Account
You can create a Self-Care account in standalone or converged Prime Collaboration Provisioning. You can
choose to enable or disable Self-Care for each user you create.

Note • To assign Self-Care roles, you must enable the CreateSelfCareAccounts rule while creating a new
domain. The CreateSelfCareAccounts rule is disabled by default.

• You can also assign Self-Care roles in an already existing domain by running the Self-CareMigration
Utility. This will enable Self-Care role for already existing users. See Self-Care User Migration
Script, on page 50 for details.

• The SelfCareUser check box is available only if the CreateSelfCareAccounts rule is enabled.

• After creating users, the users can login to Self-Care only after the globaladmin or domain-admin
changes their account password. By default, the user password is empty. You must specify a default
password in the DefaultCUPMPassword Data field and set Enabled to true to set the default password.

To create a Self-Care account for a user:

Procedure

Step 1 Choose Deploy > User Provisioning.
Step 2 Click Add User and check the Enable Prime Collaboration Self-Care check box.
Step 3 Enter the necessary user information and save.

Enabling or Disabling Self-Care Using Batch Provisioning
You can enable Self-Care while creating new users using Batch Provisioning. To enable Self-Care for a user,
provide the authorization role as SelfCareUser in the batch action file.

Batch Provisioning can also be used to enable or disable Self-Care role for an existing user. To enable provide
the authorization role as SelfCareUser, and to disable provide none in the batch action file.

The CreateSelfCareAccounts rule must be enabled for the domain to create a Self-Care account.Note

For information on Batch Provisioning see Managing Batch Projects, on page 53.
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Launching Prime Collaboration Self-care
Based on your user role, you can launch Self-Care.

If you are using IE 10, you must select the Standards mode for the Self-Care portal to work properly.Note

A user with only Self-Care role will be directed to the self-care portal after login:

Procedure

Step 1 In a browser enter, http://<provisioning-ip>/cupm/selfcareuser/Login.
Step 2 Use Self-Care credentials to log in.

Since the user has only Self-Care role, he will be able to access only the Self-Care menu. Provisioning menus
will not be available for such a user.

Launching Prime Collaboration Self-care from Personal Settings
If a user has a Self-Care role along with other authorization roles (Maintenance, Ordering, Activity Roles and
so on), then the user can launch Self-Care from the Personal Settings menu.

To launch Personal Settings:

Procedure

Step 1 Login to Provisioning using your credentials.
Step 2 Choose Deploy > User Provisioning.
Step 3 Select a user, and click Provision Services.
Step 4 Select Personal Settings to update self-care options for the selected user

You can click Launch Self-Care from the User's Quick View.

Customizing Your Personal Settings
Self-Care enables you to set individual attributes and personal preferences for the following aspects of phone
use:

• Phone options include configuring speed dial numbers, do not disturb options, and music when a call is
placed on hold.

• Profile options allow you to configure options for extension mobility and single number reach.

• Line options for a specific line on the phone, such as call forwarding, caller identification, and
notifications.
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• User options for the phone user, such as passwords and personal identification numbers (PINs).

You can update the /opt/cupm/sep/ipt.properties file to hide or display the features displayed in the Phone
Settings, Line Settings, and User Settings page of Self-Care portal. For example, if you want to configure the
features in the Phone settings, your entries would be:
enabled features for Phone Settings should be provided as follows:
General,SpeedDials,DoNotDisturb,Locale,MusicOnHold,Others
dfc.ipt.selfcare.phone.features=General,SpeedDials,DoNotDisturb,Locale,MusicOnHold,Others#

You must log in as root user to update the ipt.properties file. You must restart the cupm services for the
changes to take effect.

Note

To configure Self-Care options:

Procedure

Step 1 In a browser, enter http://<provisioning-ip>/cupm/selfcareuser/Login.
Step 2 Enter your username and password.

The Self-Care portal screen appears. The Self-Care portal screen contains the following elements:

• Phone carousel—The phone carousel (positioned in the lower left side of the screen) contains icons for
the phones and service profiles that you can configure. Click the icons at either side of the visible icons
to view the additional phones or profiles.

• Main menu—The main menu options (to the right of the phone carousel) are Phone Settings, Line
Settings, and User Settings. Depending on your selection in the phone carousel, the Phone Settings
option might be replaced by Extension Mobility Settings or Single Number Reach Settings.

• Configuration area—The configurable categories for the selected main menu option appear next. When
you click a category, such as Speed Dials, the right side of the screen displays the configurable options.

Step 3 In the phone carousel, select the phone or profile you want to configure.
Step 4 In the Line Settings menu, make sure that you select the correct line for the options you are configuring.

The following options are available for you to configure in the Self-Care portal:

• Configuring Phone / Extension Mobility Settings

• Configuring Single Number Reach Settings

• Configuring Line Settings

• Configuring User Settings

Configuring Phone / Extension Mobility Setting
The following table lists the Phone and Extension Mobility settings you can perform using Self-Care.
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Table 6: Configuring Phone / Extension Mobility Setting

ProcedureDescriptionSettings

Choose Phone Settings > MAC Address,
enter a valid MAC address for your phone,
then click Save.

Update your phone MAC address.General

Choose Phone Settings > Speed Dials , then
click Add. Enter the necessary information
and click Save.

Add phone numbers for speed dialing.

Add a comma between the numbers to
pause speed dialing. You can add any
number of commas. Default delay for a
comma is two seconds.

Speed Dials

Choose Phone Settings > Do Not Disturb,
then check the Enable DoNot Disturb check
box.

Enable or disable the Do Not Disturb
feature.

Select the action to be taken if an incoming
call arrives while the DoNoDisturb feature
is enabled.

Do Not Disturb

Choose Phone Settings > Locale, then
choose your location from the User Locale
drop-down list, and click Save.

Select your work and network locales for
time and language support.

Locale

Choose Phone Settings > Music On Hold,
then choose the audio source to play when
you place a call on hold from the User Hold
Audio Source drop-down list, and click
Save.

Select the source of the music to be played
when you place a user on hold.

Music On Hold

Choose Phone Settings > Others, then check
or uncheck the check box as required for
each option, then click Save .

Enable or disable the following options:

• Speakerphone

• Speakerphone and headset

• Video

• PC Port use

• Extension Mobility

Others

Line Settings
The following table lists the available line settings for each line of the selected phone or profile:
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Table 7: Line Settings

ProcedureDescriptionSettings

Choose Line Settings then
select Call Forward, Caller
ID, Notification, or Music
On Hold to update and click
Save.

Set default call-forwarding options.

Customize call-forwarding for external or internal incoming
calls.

Call Forward

Configure caller ID options.Caller ID

Set audio and visual options for incoming calls and
notification of messages.

Notification

Select the source of the music to be played when a call is
placed on hold.

Music On Hold

User Settings
The following table lists the available User Settings:

Table 8: User Settings

ProcedureDescriptionSettings

Choose User Settings, then select
Information, Password or PIN to update
and click Save.

Update your name.

Enter your email address.

Select your primary phone.

Information

Update your password.Password

Update your personal identification number.PIN

Common Self-Care Tasks
The following table lists all the common self-care tasks a user can perform:

Table 9: Common self-care Tasks

ProcedureTask

Choose User Settings > Passwords.Change a password
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ProcedureTask

Choose User Settings > PIN.

You can change your phone and voice mail PINs. Phone PIN
is to reset the Cisco Unified Communications Manager (or
Extension Mobility) PIN, and voice mail is to reset the Unity
Connection PIN.

Note

Change a PIN

Choose Phone Settings > Others, then check the Disable Speakerphone
check box.

Disable use of a speakerphone

Choose Phone Settings > Others, then check the Cisco Extension
Mobility check box.

Enable extension mobility

Choose Phone Settings > Others, then check the Enable Video check
box.

Enable video calls

Choose Line Settings > Call Forward, then set the options for
forwarding incoming calls.

Forward calls

Choose User Settings > Information, and enter your email address.Provide e-mail information

Choose User Settings > Information, and choose the preferred device
from the Primary Device drop-down list.

Select a different phone as your
primary device.

Choose Line Settings > Notification, then choose the notification
options for incoming calls and messages.

Select call and message
notifications

Choose Phone Settings >Music OnHold, then choose the audio source
to use when you or the network places a call on hold.

Select the source for music for calls
on hold

Configuring Single Number Reach
The Single Number Reach feature enables you to associate a another phone number with your business IP
phone number. When a call is received on the business phone number, Provisioning Manager automatically
directs the call to ring on the phone you specify as well as the business phone. In this way, the Single Number
Reach feature enables callers to reach you by dialing a single number, regardless of your location.

To configure an alternate number for Single Number Reach:
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Procedure

Step 1 In the phone carousel, select the icon associated with the remote destination profile.
Step 2 Choose Single Number Reach Settings > Alternate Numbers.
Step 3 Provide the information as described in the Table 10: Field Description for Single Number Reach table, then

click Save.
Step 4 If needed, click Add New to add an additional alternate number.

Table 10: Field Description for Single Number Reach

DescriptionField

Enter the alternate number that Provisioning Manager is to direct
calls to when calls are received on your primary phone.

Alternate Number

(Optional) Enter a description of the alternate number.Description

Check the check box to enable incoming calls to ring on multiple
phones at the same time.

Enable Reach Me Anywhere

Check the check box if the alternate number is for a mobile device.This is a mobile device

Enter the length of time (in tenths of seconds) that Provisioning
Manager should wait for you to answer the call on the primary
phone before directing the call to the alternate number.

Allow me… seconds to answer

Enter the length of time (in tenths of seconds) that Provisioning
Manager should ring at the alternate number.

Continue ringing the alternate number
for… seconds

Enter the length of time (in tenths of seconds) that Provisioning
Manager should wait after directing a call to the alternate device
before connecting a call on the device. This delay prevents calls
from being picked up by automated greetings, such as voice mail,
on the device.

If the alternate number answers within
… seconds

Check the check box for the line to associate with this alternate
number.

Line Association Information

Self-Care User Migration Script
The SelfCareMigrationUtility can be invoked during the migration, or from the CLI, after migration. The tool
processes all the users in the domains that have CreateSelfCareAccounts rule and DefaultCUPMPassword
rule set.
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This tool can be run through CLI from /opt/cupm/sep/ipt/bin. It can be run either globally (means for all
domains) or for a single domain.

To run script:

Procedure

Step 1 Go to /opt/cupm/sep/ipt/bin.
Step 2 Run:./SelfCareMigrationUtility.sh ALL ENABLE

• ALL—Indicates all domains.

• ENABLE—Enables selfcare for all users in the domain specified.

Tto disable selfcare option, run:

./SelfCareMigraionUtility.sh ALL DISABLE

The script can be run at the domain level also. To do this, run:

./SelfCareMigrationUtility.sh DOMAIN NAME [ENABLE | DISABLE]

For more information on migration, see the Cisco Prime Collaboration 10.0 Migration Guide.
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A P P E N D I X  A
Batch Provisioning

• Managing Batch Projects, page 53

Managing Batch Projects
Batch Provisioning support is provided for all the devices of Unified Communications Manager, Unity
Connection, Unity, Presence Processor, Unity Express, Call Manager Express, and Generic IOS Router. Users
with the Administration role can provision devices using batch provisioning.

Sample batch files for all devices are available in the opt/cupm/sep/ipt/config/sample/batchProvisioning
directory.

After you create a batch action file, you must create the batch project that it belongs to. When you upload a
batch action file, its contents are converted to batch actions, and the columns that are common to all batch
actions in the batch action file are displayed.

You must upload batch action files in the correct order according to any dependencies that exist between the
batch actions. For more information about these dependencies, see Guidelines for Creating Batch Action Files.

To create a batch project:

Procedure

Step 1 Choose Deploy > Batch Provisioning.
Step 2 In the Configure a Batch Project page, click the New icon.
Step 3 In the Create a New Batch Project page, type a name and add notes for the batch project.
Step 4 Click Create. After the batch project is created, you can upload one or more batch action files to the batch

project.
Step 5 In the Configure a Batch Project screen, click Upload a Batch Action File.
Step 6 In the Upload a Batch Action file page, do one of the following

• In the File to Upload field, type the full directory path and filename of the file to be uploaded.

• Click Browse and then locate and click the file to be uploaded.
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Step 7 Click Upload.
Step 8 You can do one or more of the following:

• Upload another batch action file (repeat this procedure).

• Run the batch project immediately, or schedule it to run later. See the table below for canceling, pausing
and other operations on Batch Projects.

• Schedule the batch project to be run later (see Managing Batch Projects, on page 53).

It is currently not possible to edit batch projects or batch action files in Provisioning. Instead, you can update
the batch action files manually and then upload them into a new batch project, and delete the batch projects
that you no longer require.

You can delete batch projects that you no longer require. To delete a batch project, click the Delete icon beside
the batch project name.

Table 11: Managing Batch Projects

ProcedureBatch Operation

1 In the Configure a Batch Project page, click the
Chooser icon and select the batch project that you
require.

2 In the Project Schedule pane, click Now.

3 Click OK. The batch project is started and the
status changes to In Progress. (To refresh the
screen, click the Refresh icon. When the batch
project has completed, the status changes to
Complete.

To run a batch project immediately

1 In the Project Schedule Pane, click the Select
Schedule Date icon.

Specify a date and time, as well as a Coordinated
Universal Time (UTC) Offset or Location (if
required), in the dialog box that appears.

2 Click Select.

A clock icon appears in the Status section to
indicate that the batch project has been scheduled.

Batch projects created for infrastructure
configuration cannot be restarted if there
is a failure.

Note

To schedule or reschedule a batch project
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1 Select a batch project that you require

2 In the Project Schedule pane, click Abort.

3 Click OK to cancel the batch project.

You can cancel (abort) a batch project that is in
progress. Provisioning completes any actions that are
in progress, but does not submit any further actions.

To cancel a batch project

1 Select a batch project that you require

2 In the Project Schedule pane, click Pause next to
Project Pause Date/Time.

Click OK to confirm.
3 Click the Refresh icon. The status of the project

is changed to Paused.

4 You have the following options:

• To restart the batch project, click Restart.
The batch project is restarted.

• To cancel the batch project, click Abort.
The batch project is canceled.

When you pause a batch project, Provisioning
completes actions that are in progress, but does not
submit any more.

To pause a project

1 In the Configure a Batch Project page, in the Pause
Execution section, click the Chooser icon, next to
Project Pause Date/Time.

2 Click OK to confirm. The Select Date and Time
dialog box appears.

3 Specify a date and time, as well as a UTC Offset
or Location, (if required), and then click Select.
A date and time appear next to Pause Execution,
to indicate that the batch project has been
scheduled to pause.

You can schedule a pause in a batch project, for
example, if you have scheduled a batch project to
start at a later time, but you want to ensure that it stops
before a scheduled maintenance down-time.

To schedule a batch project to pause
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1 In the Configure a Batch Project page, under the
Project Schedule pane, click the Clear icon next
to the Project Start Date/Time.

2 Click OK to confirm.

You can cancel a scheduled batch project provided
that it has not started processing.

To cancel a scheduled batch project

1 In the Project Schedule section, click the Clear
icon.

2 Click OK to confirm. The scheduled pause for
the batch project is cleared.

To cancel a scheduled pause for a batch project

Click View in the Batch Project Actions pane.
The View Batch Action Details page appears. This
page displays all configured information for the batch
project action.

In Batch Provisioning, during endpoint order, users
with any user role can add a new endpoint. Even a
pseudo user can add an endpoint.

To view the batch project details

In the Configure a Batch Project page, the Batch
Project Actions pane displays the status of each batch
action project. After a batch project has completed,
you can check the user records of the users to verify
that orders have been processed.

To see details of a single running order within a batch
project, administrators can also use My Activities
(Deploy >User Provisioning >MyActivities) to view
each order as it is executed in the workflow

To view the current status of a batch project
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