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Preface

The preface describes who should read this publication and provides the 
document conventions.

The preface includes the following topics:

• Purpose, page v

• Audience, page vi

• Related Documentation, page vi

• Obtaining Documentation, page viii

• Obtaining Technical Assistance, page x

Purpose
The Automatic Location Information Formatting Tool (AFT) enables you to 
modify the automatic location information (ALI) records that you create in 
Cisco Emergency Responder to a format that is compatible with the one used by 
your service provider.

The ALI Formatting Tool User Guide provides you with the information that you 
need to understand, install, use, and troubleshoot the ALI Formatting Tool (AFT).
v
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Audience
Audience
Network engineers, system administrators, and telecommunications engineers 
should review this guide to learn the steps that are required to install, use and 
troubleshoot AFT. You should be familiar with Cisco Emergency Responder and 
Cisco CallManager before deploying AFT.

Related Documentation
For information about Cisco CallManager and additional information about 
Cisco Emergency Responder (Cisco ER), refer to these publications:

• These Cisco Emergency Responder documents are available at:

http://www.cisco.com/univercd/cc/td/doc/product/voice/respond/index.htm

– Release Notes for Cisco Emergency Responder

– Cisco Emergency Responder Administration Guide

– Cisco  Emergency Responder User’s Guide (also built into the end-user 
interface as the Cisco ER online help system)

• Cisco CallManager documents are available at:

http://www.cisco.com/univercd/cc/td/doc/product/voice/c_callmg/index.htm

Online Help and Document Conventions
The ALI Formatting Tool User Guide is built into the end-user interface as the 
AFT online help system. AFT’s online help system provides task-oriented help 
that is available from the AFT window.

The help system includes an index and is organized the same way as the 
ALI Formatting Tool User Guide.

• Using the Online Help, page vii

• Document Conventions, page vii
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Online Help and Document Conventions
Using the Online Help
You can access online help in any of these ways:

• From the Help menu, access the contents of the online help system by 
selecting Help > Contents and Index or by clicking on the Help icon, a 
question mark.

• For a printed version of the manual associated with the application, or to view 
or search an Adobe Acrobat version of the help system, click the View PDF 
button in the top frame of the help system. If you have Adobe Acrobat 
installed (either as an independent application or as a plug-in to your 
browser), the document opens.

From Acrobat, you can search the entire manual, print the entire manual or 
selected pages, or read the manual online.

Document Conventions
This publication uses the following conventions:

Convention Description

boldface font Commands and keywords are in boldface.

italic font Arguments for which you supply values are in italics.

string A nonquoted set of characters. Do not use quotation 
marks around the string or the string will include the 
quotation marks.

screen font Terminal sessions and information the system displays 
are in screen font.

boldface screen 
font

Information you must enter is in boldface screen font.

italic screen font Arguments for which you supply values are in italic 
screen font.

Action > Reports Command paths in a graphical user interface (GUI).
vii
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Obtaining Documentation
Notes use the following convention:

Note Means reader take note. Notes contain helpful suggestions or references to 
material not covered in the publication.

Cautions use the following convention:

Caution Means reader be careful. In this situation, you might do something that could 
result in equipment damage or loss of data.

Obtaining Documentation
Cisco provides several ways to obtain documentation, technical assistance, and 
other technical resources. These sections explain how to obtain technical 
information from Cisco Systems.

Cisco.com
You can access the most current Cisco documentation on the World Wide Web at 
this URL:

http://www.cisco.com/univercd/home/home.htm

You can access the Cisco website at this URL:

http://www.cisco.com

International Cisco websites can be accessed from this URL:

http://www.cisco.com/public/countries_languages.shtml
viii
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Obtaining Documentation
Documentation CD-ROM
Cisco documentation and additional literature are available in a Cisco 
Documentation CD-ROM package, which may have shipped with your product. 
The Documentation CD-ROM is updated regularly and may be more current than 
printed documentation. The CD-ROM package is available as a single unit or 
through an annual or quarterly subscription.

Registered Cisco.com users can order a single Documentation CD-ROM (product 
number DOC-CONDOCCD=) through the Cisco Ordering tool:

http://www.cisco.com/en/US/partner/ordering/ordering_place_order_ordering_t
ool_launch.html

All users can order monthly or quarterly subscriptions through the online 
Subscription Store:

http://www.cisco.com/go/subscription

Ordering Documentation
You can find instructions for ordering documentation at this URL:

http://www.cisco.com/univercd/cc/td/doc/es_inpck/pdi.htm

You can order Cisco documentation in these ways:

• Registered Cisco.com users (Cisco direct customers) can order Cisco product 
documentation from the Networking Products MarketPlace:

http://www.cisco.com/en/US/partner/ordering/index.shtml

• Nonregistered Cisco.com users can order documentation through a local 
account representative by calling Cisco Systems Corporate Headquarters 
(California, U.S.A.) at 408 526-7208 or, elsewhere in North America, by 
calling 800 553-NETS (6387). 

Documentation Feedback
You can submit comments electronically on Cisco.com. On the Cisco 
Documentation home page, click Feedback at the top of the page.
ix
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Obtaining Technical Assistance
You can e-mail your comments to bug-doc@cisco.com.

You can submit comments by using the response card (if present) behind the front 
cover of your document or by writing to the following address:

Cisco Systems
Attn: Customer Document Ordering
170 West Tasman Drive
San Jose, CA 95134-9883

We appreciate your comments.

Obtaining Technical Assistance
Cisco provides Cisco.com, which includes the Cisco Technical Assistance Center 
(TAC) website, as a starting point for all technical assistance. Customers and 
partners can obtain online documentation, troubleshooting tips, and sample 
configurations from the Cisco TAC website. Cisco.com registered users have 
complete access to the technical support resources on the Cisco TAC website, 
including TAC tools and utilities. 

Cisco.com
Cisco.com offers a suite of interactive, networked services that let you access 
Cisco information, networking solutions, services, programs, and resources at any 
time, from anywhere in the world. 

Cisco.com provides a broad range of features and services to help you with these 
tasks:

• Streamline business processes and improve productivity 

• Resolve technical issues with online support

• Download and test software packages

• Order Cisco learning materials and merchandise

• Register for online skill assessment, training, and certification programs

To obtain customized information and service, you can self-register on Cisco.com 
at this URL:

http://tools.cisco.com/RPF/register/register.do
x
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Obtaining Technical Assistance
Technical Assistance Center
The Cisco TAC is available to all customers who need technical assistance with a 
Cisco product, technology, or solution. Two types of support are available: the 
Cisco TAC website and the Cisco TAC Escalation Center. The type of support that 
you choose depends on the priority of the problem and the conditions stated in 
service contracts, when applicable.

We categorize Cisco TAC inquiries according to urgency:

• Priority level 4 (P4)—You need information or assistance concerning Cisco 
product capabilities, product installation, or basic product configuration. 
There is little or no impact to your business operations.

• Priority level 3 (P3)—Operational performance of the network is impaired, 
but most business operations remain functional. You and Cisco are willing to 
commit resources during normal business hours to restore service to 
satisfactory levels.

• Priority level 2 (P2)—Operation of an existing network is severely degraded, 
or significant aspects of your business operations are negatively impacted by 
inadequate performance of Cisco products. You and Cisco will commit 
full-time resources during normal business hours to resolve the situation.

• Priority level 1 (P1)—An existing network is “down,” or there is a critical 
impact to your business operations. You and Cisco will commit all necessary 
resources around the clock to resolve the situation.

Cisco TAC Website

The Cisco TAC website provides online documents and tools to help troubleshoot 
and resolve technical issues with Cisco products and technologies. To access the 
Cisco TAC website, go to this URL:

http://www.cisco.com/tac

All customers, partners, and resellers who have a valid Cisco service contract have 
complete access to the technical support resources on the Cisco TAC website. 
Some services on the Cisco TAC website require a Cisco.com login ID and 
password. If you have a valid service contract but do not have a login ID or 
password, go to this URL to register:

http://tools.cisco.com/RPF/register/register.do
xi
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Obtaining Additional Publications and Information
If you are a Cisco.com registered user, and you cannot resolve your technical 
issues by using the Cisco TAC website, you can open a case online at this URL:

http://www.cisco.com/tac/caseopen

If you have Internet access, we recommend that you open P3 and P4 cases online 
so that you can fully describe the situation and attach any necessary files.

Cisco TAC Escalation Center

The Cisco TAC Escalation Center addresses priority level 1 or priority level 2 
issues. These classifications are assigned when severe network degradation 
significantly impacts business operations. When you contact the TAC Escalation 
Center with a P1 or P2 problem, a Cisco TAC engineer automatically opens a case.

To obtain a directory of toll-free Cisco TAC telephone numbers for your country, 
go to this URL:

http://www.cisco.com/warp/public/687/Directory/DirTAC.shtml

Before calling, please check with your network operations center to determine the 
Cisco support services to which your company is entitled: for example, 
SMARTnet, SMARTnet Onsite, or Network Supported Accounts (NSA). When 
you call the center, please have available your service agreement number and your 
product serial number.

Obtaining Additional Publications and Information
Information about Cisco products, technologies, and network solutions is 
available from various online and printed sources.

• The Cisco Product Catalog describes the networking products offered by 
Cisco Systems, as well as ordering and customer support services. Access the 
Cisco Product Catalog at this URL:

http://www.cisco.com/en/US/products/products_catalog_links_launch.html
xii
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Obtaining Additional Publications and Information
• Cisco Press publishes a wide range of networking publications. Cisco 
suggests these titles for new and experienced users: Internetworking Terms 
and Acronyms Dictionary, Internetworking Technology Handbook, 
Internetworking Troubleshooting Guide, and the Internetworking Design 
Guide. For current Cisco Press titles and other information, go to Cisco Press 
online at this URL:

http://www.ciscopress.com

• Packet magazine is the Cisco quarterly publication that provides the latest 
networking trends, technology breakthroughs, and Cisco products and 
solutions to help industry professionals get the most from their networking 
investment. Included are networking deployment and troubleshooting tips, 
configuration examples, customer case studies, tutorials and training, 
certification information, and links to numerous in-depth online resources. 
You can access Packet magazine at this URL:

http://www.cisco.com/go/packet

• iQ Magazine is the Cisco bimonthly publication that delivers the latest 
information about Internet business strategies for executives. You can access 
iQ Magazine at this URL:

http://www.cisco.com/go/iqmagazine

• Internet Protocol Journal is a quarterly journal published by Cisco Systems 
for engineering professionals involved in designing, developing, and 
operating public and private internets and intranets. You can access the 
Internet Protocol Journal at this URL:

http://www.cisco.com/en/US/about/ac123/ac147/about_cisco_the_internet_
protocol_journal.html

• Training—Cisco offers world-class networking training. Current offerings in 
network training are listed at this URL:

http://www.cisco.com/en/US/learning/le31/learning_recommended_training
_list.html
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C H A P T E R 1

Overview of ALI Formatting Tool

The Automatic Location Information Formatting Tool (AFT) enables you to 
modify the automatic location information (ALI) records that you create in 
Cisco Emergency Responder to a format that is compatible with the one used by 
your service provider.

Cisco Emergency Responder (Cisco ER) helps you manage emergency calls in 
your telephony network. Emergency Responder tracks a system’s phones and 
locations and exports this information in ALI records that conform to National 
Emergency Number Association (NENA) 2.0, 2.1, and 3.0 formats. However, 
many service providers do not use NENA standards. You can use AFT to modify 
the Emergency Responder-generated ALI records according to service 
provider-specific formats. That service provider then uses the reformatted file to 
update their ALI database.

The ALI Formatting Tool User Guide provides you with the information that you 
need to understand, install, use and troubleshoot AFT. Service provider-specific 
information is described in the appendix.

Note SBC Ameritech does not use additional service provider-specific fields. See 
Appendix A, “Using the ALI Formatting Tool for SBC Ameritech” for 
information on when you need to change the Function Code.
1-1
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Chapter 1      Overview of ALI Formatting Tool
Overview of Enhanced 911
These topics provide an overview of Emergency Responder and the ALI 
formatting tool:

• Overview of Enhanced 911, page 1-2

• Overview of the ALI Formatting Tool, page 1-3

• Understanding E911 and Emergency Responder Terminology, page 1-4

Overview of Enhanced 911
Cisco Emergency Responder (Cisco ER) helps you manage emergency calls in 
your telephony network so that you can respond to these calls effectively and so 
that you can comply with your local ordinances concerning the handling of 
emergency calls. In North America, these local ordinances are called “enhanced 
911,” or E911. Other countries and locales might have similar ordinances.

Enhanced 911 (E911) extends the basic 911 emergency call standard to make it 
more reliable.

In basic 911 in North America, if a caller dials 911, the call is routed to a public 
safety answering point (PSAP), also called the 911 operator. The PSAP is 
responsible for talking to the caller and arranging the appropriate emergency 
response, such as sending police, fire, or ambulance teams.

E911 extends this standard with these requirements:

• The emergency call must be routed to the local PSAP based on the location 
of the caller. In basic 911, the call simply needs to be routed to some PSAP, 
not necessarily the local one.

• The caller’s location information must be displayed at the emergency 
operator’s terminal. This information is obtained by querying an automatic 
location information (ALI) database.

In E911, the location of the caller is determined by the emergency location 
identification number (ELIN), which is a phone number the PSAP can dial to 
reconnect to the emergency caller if the emergency call is cut off for any reason, 
or if the PSAP simply needs to talk to the caller again. The emergency call is 
routed to the PSAP based on the location information associated with this number. 
For multi-line phone systems, such as an office system, the ELIN can be 
associated with more than one telephone by grouping the phones in an emergency 
response location (ERL). In this case, the location the PSAP receives would be 
1-2
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Chapter 1      Overview of ALI Formatting Tool
Overview of the ALI Formatting Tool
the address of an office building. For large buildings, the location would include 
additional information such as floor or region on a floor. Each ERL requires a 
unique ELIN.

Related Topics

• Overview of the ALI Formatting Tool, page 1-3

• Understanding E911 and Emergency Responder Terminology, page 1-4

Overview of the ALI Formatting Tool
The ALI Formatting Tool (AFT) reads the automatic location information (ALI) 
file generated by Cisco Emergency Responder (Cisco ER) and displays all the 
ELIN records in the AFT interface. You can use AFT to:

• Easily view the details of the ALI records. ALI files are difficult to read in the 
NENA fixed-length format. AFT reads the ALI files and presents the NENA 
fields in an interface that is easy to read.

• Select a record and update the value for ALI fields. AFT allows you to edit 
the ALI fields to customize them to meet the requirements of different service 
providers. You service provider can then read the reformatted ALI files and 
use them to update their ELIN records.

• Perform bulk updates on multiple ALI records. Using the bulk update feature, 
you can apply common changes to all the records that you have selected, to 
one area code, or to one area code and one city code.

• Selectively export ALI records based on Area Code, City Code or a 4-digit 
Directory Number. By selecting to export all the ALI records in an Area 
Code, for example, you can quickly access all the ELIN records for each 
service provider allowing you to easily support multiple service providers.

Related Topics

• Overview of Enhanced 911, page 1-2

• Understanding E911 and Emergency Responder Terminology, page 1-4

• Chapter 3, “Using the ALI Formatting Tool”
1-3
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Chapter 1      Overview of ALI Formatting Tool
Understanding E911 and Emergency Responder Terminology
Understanding E911 and Emergency Responder 
Terminology

Table 1-1 defines some of the key terminology used in this document.

Table 1-1 E911 and Emergency Responder Terminology

Term Definition

ALI Automatic location information. Information that ties an ELIN to a location, and 
is used to route emergency calls from that ELIN to the correct local PSAP. 
Information that is presented to the PSAP to help the PSAP locate the emergency 
caller. In Emergency Responder, you fill in ALI data for each ERL, and submit 
the ALI data to your service provider for inclusion in the ALI database.

ANI Automatic number identification. ANI is another name for ELIN. 

CAMA Centralized automated message accounting. An analog phone trunk that connects 
directly to an E911 selective router, bypassing the PSTN.

DID Direct inward dial. A telephone number obtained from your service provider that 
can be used to dial into your telephone network. DIDs are used for ELINs.

ELIN Emergency location identification number. A phone number that routes the 
emergency call to the local PSAP, and which the PSAP can use to call back the 
emergency caller. The PSAP might need to call the number if the emergency call 
is cut off, or if the PSAP needs additional information after normally ending the 
emergency call. See ALI.

emergency call A call made to the local emergency number, such as 911. Emergency Responder 
routes the call to the service provider’s network, where the call is routed to the 
local public safety answering point (PSAP).

emergency caller The person who places the emergency call. The caller might require help for a 
personal emergency, or might be reporting a more general emergency (fire, theft, 
accident, and so forth).

ERL Emergency response location. The area from which an emergency call is placed. 
This is not necessarily the location of the emergency. If an emergency caller is 
reporting a general emergency, the actual emergency might be in a different area. 
In Emergency Responder, you assign switch ports and phones to ERLs, and ERL 
definitions include ALI data.
1-4
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Chapter 1      Overview of ALI Formatting Tool
Understanding E911 and Emergency Responder Terminology
ESZ Emergency service zone. The area covered by a given PSAP. This area usually 
includes several police and fire departments. For example, a city and its suburbs 
might be serviced by one PSAP.

Each ESZ is assigned a unique emergency service number (ESN) to identify it.

MSAG Master street address guide. A database listing of all valid street address ranges 
within a community, the contents of which is typically managed by a local 
government organization. The MSAG database service can be managed by a local 
government organization, an incumbent local exchange carrier, or by a database 
service provider (often the same as the ALI database service provider).

NENA National Emergency Number Association. The organization that recommends 
data and file formats for ALI definitions and other emergency call requirements 
in the United States. Emergency Responder uses the NENA formats for ALI data 
export files. Your service provider might have additional restrictions on data 
format, so ensure that your ALI entries abide by your service provider’s rules.

PSAP Public safety answering point. This is the organization that receives emergency 
calls, for example, the 911 operator. The PSAP is staffed by people trained in 
handling emergency calls. The PSAP talks to the emergency caller and notifies 
the appropriate public service organizations (such as police, fire, or ambulance) 
of the emergency and its location.

Table 1-1 E911 and Emergency Responder Terminology (continued)

Term Definition
1-5
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Understanding E911 and Emergency Responder Terminology
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C H A P T E R 2

Installing the ALI Formatting Tool

Use these topics to install ALI Formatting Tool (AFT):

• System Requirements, page 2-1

• Installing the ALI Formatting Tool, page 2-2

System Requirements
The ALI Formatting Tool (AFT) requires the following software components to 
operate:

• Cisco Emergency Responder 1.1 (Cisco ER) or later

• Microsoft Windows 2000

The ALI Formatting Tool (AFT) supports all hardware platforms supported by 
Emergency Responder. Refer to the Cisco Emergency Responder Administration 
Guide for Cisco ER-supported Cisco Media Convergence Server (MCS) hardware 
platforms.

Note You must install AFT on the same server with Cisco ER.

Related Topics

• Installing the ALI Formatting Tool, page 2-2
2-1
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Chapter 2      Installing the ALI Formatting Tool
Installing the ALI Formatting Tool
Installing the ALI Formatting Tool
The ALI Formatting Tool (AFT) is downloadable from the Internet. To install 
AFT, perform the following steps:

Procedure

Step 1 Start the Cisco MCS or Cisco certified server and log in to Windows 2000.

Step 2 Use a web browser to access the following URL:

http://www.cisco.com/cgi-bin/tablebuild.pl/aft

Step 3 Download the AFT installation file that is specific to your service provider.

The AFT .exe files are named as shown here:

CER-aft-<serviceprovider>.<mainrelease> - <minorrelease> 
-<maintrelease>.exe

where serviceprovider is the name of your Service Provider

and mainrelease, minorrelease and maintrelease make up the AFT release 
number.

For example, to select the SBC Ameritech AFT, click on: 
CER-aft-SBC_Ameritech.1-1-1.exe

Step 4 Double-click on the downloaded file to launch the installer.

The Welcome to the ALI Formatting Tool (AFT) Installation Wizard screen 
appears.

Step 5 At this point, the installation checks for the presence of Cisco ER 1.1 or later.

If Cisco ER 1.1 or later is not present, you are prompted to install it. The 
installation of AFT will not continue until Cisco ER 1.1 or later is present.

Step 6 Click Next.

The License Agreement Screen appears.

Step 7 Select Accept and click Next.

The User Information Screen appears.

Step 8 Enter the user name and organization information and click Next.
2-2
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Chapter 2      Installing the ALI Formatting Tool
Installing the ALI Formatting Tool
Step 9 Select administrator rights by clicking on one of the following choices:

• For me 

• For all who use the computer 

Step 10 Click Next.

The Ready to Install screen appears.

Step 11 Click Next.

Step 12 To test that the application successfully loaded, install the new shortcut path and 
launch the AFT application. Go to:

a. Start > Programs > Cisco Emergency Responder > AFT > 
<serviceprovider (NENA version)>

For SBC Ameritech, go to:

Start > Programs > Cisco Emergency Responder > AFT > 
SBC Ameritech (NENA 2.0)

The AFT login screen appears.

b. To log in to AFT, enter your Cisco ER Main Administrator or ERL 
Administrator login ID and Password.

Related Topics

• System Requirements, page 2-1

• Chapter 3, “Using the ALI Formatting Tool”
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Using the ALI Formatting Tool

This section provides information about how to use the ALI Formatting Tool 
(AFT):

• Using the ALI Formatting Tool Interface, page 3-1

• Using AFT to Generate a Formatted ALI File, page 3-7

Using the ALI Formatting Tool Interface
To familiarize yourself with the AFT interface, select the pull-down menus from 
the AFT main menu to see the options. Hold your mouse over each AFT icon to 
view the icon description in the tool tip box.

These topics will help you become familiar with the AFT interface:

• ALI Formatting Tool Fields, page 3-2

• Using the Tool Bar and Icons, page 3-3
3-1
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ALI Formatting Tool Fields
You can edit the following fields using AFT:

• The header and trailer fields. The ALI Formatting Tool (AFT) displays all the 
ALI record data in the ALI tab. The ALI file consists of one header record and 
one trailer record only; there is not an individual header and trailer record for 
each ELIN record.

• The Function/Transaction Code field. Refer to the Appendix A, “Using the 
ALI Formatting Tool for SBC Ameritech” for more information.

• Any service provider-specific fields. SBC Ameritech does not have any 
service provider-specific fields.

You cannot edit the following fields using AFT:

• The ALI records fields that you configure and edit through 
Cisco Emergency Responder (Cisco ER). They are disabled (greyed out) in 
AFT.

• The record count field. This trailer field cannot be edited in AFT because 
AFT calculates this number internally based on the number of records 
selected to export.

Related Topics

• Using the Tool Bar and Icons, page 3-3

• Before You Generate Files, page 3-7

• Generating a Formatted ALI File, page 3-8
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Using the Tool Bar and Icons
Use Table 3-1 to learn how you use the AFT interface to perform the main AFT 
tasks.

Use the “Generating a Formatted ALI File” section on page 3-8 for a step-by-step 
procedure about putting the tasks together and generating reformatted ALI files.

Table 3-1 Using the AFT Interface

Task Procedure Notes

Give a NENA file as input to 
AFT

Use one of these methods:

• Click the File Open icon.

• Select Menu > File > Open 
(Ctrl+O).

If the NENA files are on the 
Master CER server and AFT 
is installed on the Standby 
CER server, you can use the 
Open Window Dialog box to 
browse to a shared Master 
CER folder.

Go to a specific ELIN 
number 

1. Select Menu > File > Go to ELIN 
(Ctrl+E).

2. Enter the ELIN number.

If the ELIN is present, it is 
selected in the tree and the 
ALI tab is populated with 
data for that record.

If it is an invalid record 
number, a message displays 
with the valid range of 
numbers.

Go to a specific record 1. Select Menu > File > Go to Record 
Number (Ctrl+R).

2. Enter the record number.

If the record number is valid, 
that record is selected in the 
tree and the ALI tab is 
populated with data for that 
record.

If it is an invalid record 
number, a message displays 
with the valid range of 
numbers.
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View ALI details for an 
ELIN/Select an ELIN to edit 
its ALI fields

Click on the ELIN in the tree. This highlights the ELIN 
and populates its details in 
the right pane of the 
window.

You can then edit the ALI 
records by entering new 
values in the ALI editable 
fields.

Undo record change/Redo 
record change

Use one of these methods:

• Click the Undo/Redo icon.

• Select Menu > Edit > Undo 
record/Redo record change 
(Ctrl+Z/Ctrl+Y).

The Undo/Redo option 
remembers the last 20 record 
changes.

Cut/Copy/Paste record input Use one of these methods:

• Click the Cut/Copy/Paste icon.

• Select Menu > Edit > 
Cut/Copy/Paste 
(Ctrl+X/Ctrl+C/Ctrl+V).

Table 3-1 Using the AFT Interface (continued)

Task Procedure Notes
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Select ALI records to be 
exported to your service 
provider

In the tree, click in the ELIN check box. 
Use one of the following options:

• Select all ELINs in the tree by 
checking the root node of the tree.

• Select all ELINs with a specific area 
code by checking the Area Code in 
the tree. For example, checking the 
408 check box will select all the 
numbers in the 408 area code.

• Select all ELINs with a specific City 
Code by checking the City Code in 
the tree. For example, clicking on 
228 will also select 228-9333 and 
228-5672.

• Select an individual ELIN by 
checking the 4-digit directory 
number, for example, 9933.

Check marks will indicate 
the ELINs that are selected.

Generate Formatted File Use one of the following methods:

• Click the Generate Formatted File 
icon.

• Go to Menu > Tools and click 
Generate Formatted File (Ctrl+G).

AFT generates an ALI file in 
a format that your service 
provider can read.

Table 3-1 Using the AFT Interface (continued)

Task Procedure Notes
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Related Topics

• ALI Formatting Tool Fields, page 3-2

• Using AFT to Generate a Formatted ALI File, page 3-7

Perform a bulk update to the 
ALI files

1. Use one of these methods:

– Click the Bulk Update icon. 

– Select Menu > Tools > Bulk 
Update (Ctrl+B). 

AFT displays the bulk update form.

2. Select one of the following options:

– To apply the changes to all 
records, click the first tab, Apply 
All.

– To apply the changes to one area 
code, click the second tab, 
Apply by Area Code.

– To apply the change to one area 
code and one city code, click the 
third tab, Apply by Area Code 
and City Code.

The bulk update feature 
saves the changes 
automatically. 

Save updates to the ALI file Select Menu > Tools > Save Record 
(Ctrl+S).

The new value is saved and 
displayed in the interface. 

If you modify an ALI record 
but do not save the changes, 
an alert asks if you want to 
save the changes.

Close AFT Select Menu > File > Exit. If you try to close AFT 
without saving changes, 
AFT asks if you want to 
generate a formatted file.

Table 3-1 Using the AFT Interface (continued)

Task Procedure Notes
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Using AFT to Generate a Formatted ALI File
Use the following topics to generate a formatted ALI file:

• Before You Generate Files, page 3-7

• Generating a Formatted ALI File, page 3-8

Before You Generate Files
Make sure you have completed the following tasks before you begin to use AFT 
to generate an exported file:

• You have installed, set up and used Cisco Emergency Responder (Cisco ER) 
to configure ERLs with the ELIN and ALI information and to generate a 
NENA file. For information on performing these tasks, refer to the 
Cisco Emergency Responder Administration Guide.

• You have successfully installed, launched and tested AFT. See Chapter 2, 
“Installing the ALI Formatting Tool,”

• You understand which specific information you modify for your service 
provider. For details, see Appendix A, “Using the ALI Formatting Tool for 
SBC Ameritech.”
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Generating a Formatted ALI File
To use AFT to generate a formatted file, perform the following steps:

Procedure

Step 1 Provide a NENA file generated by Cisco Emergency Responder (Cisco ER) as 
input to AFT in one of these ways:

• Select Menu > File > Open (Ctrl+O) and browse to select the file name.

• Use the File Open icon and enter the file name.

Tip If the NENA files are on the Master Cisco ER server and AFT is installed on the 
Standby Cisco ER server, you can use the Open Window Dialog box to browse to 
a shared Master Cisco ER folder.

AFT displays all the ELINs from the NENA file in a tree box in the left side of 
the page by the Area Code, City Code and 4-digit directory number.

Step 2 To view details of the ALI files, click on an ELIN in the tree.

This highlights the ELIN and populates its details in the right pane of the window.

Step 3 Edit the ALI fields by entering new values in the editable fields.

Step 4 Save any changes that you made to the ALI file:

Select Menu > Tools > Save Record (Ctrl+S).

Step 5 Select the ELINs that you want to export to the service provider by clicking in the 
corresponding check boxes in the tree.

• To select all ELINs in the tree, check the root node of the tree.

• To select all ELINs with a specific area code, click in the Area Code check 
box in the tree. For example, clicking the 408 check box will select all the 
numbers in the 408 area code. All the 408 numbers display check marks.

• To select all ELINs with a specific City Code, click in the City Code check 
box. For example, selecting 228 will also select 228-9333 and 228-5672.

• To select an individual ELIN, click in the 4-digit check box, for example, 
9933

Check marks will indicate the ELINs that are selected.
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Step 6 Update the service provider-fields in AFT:

For details about the service provider-specific information required, see 
Appendix A, “Using the ALI Formatting Tool for SBC Ameritech.”

Step 7 At this point, if the service provider-specific field is common for many ELIN 
records (for example, if all the ELIN records share the same Private Switch Code), 
you can use AFT’s Bulk Update feature:

a. Select Menu > Tools >  Bulk Update (Ctrl+B) or the Bulk Update icon.

AFT displays the bulk update form.

b. Select one of the following options:

– To apply the changes to all records, click the first tab: Apply All.

– To apply the changes to one area code, click the second tab: Apply by 
Area Code.

– To apply the changes to one area code and one city code, click the third 
tab: Apply by Area Code and City Code.

Step 8 Generate a formatted file in one of these way:

• Go to Menu > Tools and click Generate Formatted File (Ctrl+G).

• From the Tool Bar, click the Generate Formatted File icon.

AFT generates an ALI file in a format specific to your service provider and 
prompts you for a location to save it.

Step 9 Enter a location where you want to store the formatted file.

Step 10 Using the service provider’s preferred method of transmitting files, send the ALI 
file to your service provider so they can update their E911 database with the 
ELINs from the AFT ALI file.

Tip Be sure to keep a copy of the AFT ALI file for your records. This will be helpful 
if the service providers reports errors; you can make any required changes to the 
file without having to re-do all the AFT formatting changes. 
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Step 11 Your service provider returns the status of the ALI files.

• If your service provider reports that there are no errors, you can continue 
using AFT to generate more formatted records or you can quit the program.

• If your service provider reports that there are ALI errors, perform the 
following steps:

– Make corrections to the formatted file that you sent to the service 
provider. All the error codes for the service providers are defined in the 
ALI format documentation for that service provider. Refer to their 
documentation to determine the errors in your file and correct the errors 
using AFT.

Note If an error occurs in fields that cannot be edited using AFT, you must 
use CER to correct the fields. Then use AFT to generate the file again.

– Send the corrected file to your service provider. Again, be sure to keep a 
copy of your corrected file for your records.

– Repeat this process until your service provider can read the formatted 
files and can use them to update their ELIN records.

Related Topics

• Using the Tool Bar and Icons, page 3-3

• Chapter 4, “Troubleshooting the ALI Formatting Tool”

• Appendix A, “Using the ALI Formatting Tool for SBC Ameritech”
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Troubleshooting the ALI Formatting 
Tool

These topics address problems you might encounter using the ALI Formatting 
Tool (AFT) and provide ways to resolve them: 

• Collecting Error and Trace Messages, page 4-1

• Troubleshooting AFT Problems, page 4-2

• Frequently Asked Questions, page 4-4

Collecting Error and Trace Messages
The ALI Formatting Tool (AFT) logs errors, warnings, record changes, and 
information messages using a logging device that is similar to the one that 
Cisco Emergency Responder (Cisco ER) uses.

Note Un-installing AFT does not remove the AFT logs. This allows you to use the logs 
to find details about old AFT transactions.

For bulk operations, AFT logs information related to the bulk operation, not 
individual record updates.
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Troubleshooting AFT Problems
You can access the AFT logs, in one of two ways. Go to:

• the log folder at:

C:\ProgramFiles\CiscoSystems\AFT\logs\<providername> 

• the install folder at:

C:\Program Files\CiscoSystems\AFT\<providername>

and follow the shortcut to the AFT logs.

Related Topics

• Troubleshooting AFT Problems, page 4-2

• Frequently Asked Questions, page 4-4

Troubleshooting AFT Problems
Use the following sections to resolve AFT problems:

• Cannot Install AFT, page 4-2

• Cannot Log In To AFT, page 4-3

• Cannot Locate the AFT Logs, page 4-3

Cannot Install AFT
Problem: You receive an error message when you try to install AFT on a 
Windows 2000 system.

Action: Cisco Emergency Responder (Cisco ER) must be installed before you 
can install AFT. You must install AFT on the same server with Cisco ER. 

Make sure that Cisco ER is installed, then try to install AFT again.
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Cannot Log In To AFT
Problem: You get an “Invalid Login” message when you try to log in to AFT.

Action: You must be a member of CERSystemAdmin and CERERLAdminGroup 
for Cisco Emergency Responder (Cisco ER). Check the group membership at:

Start > Control Panel > Administrative Tools > Computer Management > 
Users and Groups > Groups

Cannot Locate the AFT Logs
Problem: You cannot find the AFT Logs.

Action: The ALI Formatting Tool (AFT) is installed in:

C:\Program Files\CiscoSystems\AFT\<providername>

Follow the shortcut in this folder to the AFT Log Folder.

All AFT logs are saved here: 

C:\ProgramFiles\CiscoSystems\AFT\logs\<providername>

Related Topics

• Collecting Error and Trace Messages, page 4-1

• Frequently Asked Questions, page 4-4
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Frequently Asked Questions
Q. My Service Provider accepts NENA 2.0 files. From the 

Cisco Emergency Responder (Cisco ER) documentation, I see that Cisco ER 
itself generates NENA 2.0 files. Will I need to use AFT for sending ALI files 
to my service provider?

A. Cisco ER was designed to generate ALI files in NENA 2.0, 2.1 and 3.0 
format. However, many service providers have specific fields that they use for 
internal purposes. If their fields are missing, they might reject the ALI file 
you send them from Cisco ER. These ALI files need formatting for the 
service provider-specific fields. This might be adding, removing, or changing 
the position of some fields. AFT is a small application that you can download 
from CCO and use for formatting the ALI files which Cisco ER generates 
according to your service provider’s requirements.

Q. In my Cisco ER setup, I have a set of ELINs that I bought from 
SBC Ameritech (Ameritech) and another set of ELINs that I bought from 
Sprint. I have configured these ELINs in Cisco ER. I did an ALI export and 
exported the ELINs to a single file. How will I send this ELIN file separately 
to Ameritech and Sprint?

A. You can use AFT to accomplish this task. Perform the following steps:

Procedure

Step 1 Download the AFT for Ameritech and download the AFT for Sprint from CCO 
and install them on your Cisco ER server.

Step 2 Give the ALI file exported from Cisco ER as input to the Ameritech AFT. 

Step 3 Perform the necessary formatting selectively for the Ameritech ELINs:

Step 4 Use the Ameritech Area Code which is different from the Sprint area code. Send 
this file of the Ameritech ELINs to Ameritech. 

Step 5 Repeat steps 2 - 4 to generate a file containing just the Sprint ELINs by using AFT 
for Sprint.
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Related Topics

• Collecting Error and Trace Messages, page 4-1

• Troubleshooting AFT Problems, page 4-2
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 P P E N D I X A

Using the ALI Formatting Tool for 
SBC Ameritech

SBC Ameritech (Ameritech) does not have any service provider-specific fields 
that you must modify using the ALI Formatting Tool (AFT). However, when using 
AFT to format records for Ameritech, you may need to modify the Function Code. 
Use the following information along with Chapter 3, “Using the ALI Formatting 
Tool” to generate ALI files in a format that Ameritech can use to update their 
ELIN records.

Changing the Function Code

Cisco Emergency Responder (Cisco ER) sets the Function Code to one of the 
following:

• I for Inserting a new ALI record (the default)

• C for Updating an ALI record, such as changing a street name

• D for Deleting an ALI record

If you make changes to an ALI record in Cisco ER to correct errors reported by 
Ameritech, you may need to use AFT to change the Function Code for ELIN 
records. Example A-1 illustrates when you need to change the function code.
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Example A-1 Changing the Function Code

Cisco ER initially generates ALI records with a function code of I, for insert. 
After you format a file and export it to Ameritech using AFT, Ameritech may 
reject the file because of an error. The error may be that the street suffix is 
incorrect, for example. You cannot change the street suffix in AFT because this 
field is disabled in AFT. You must change the ALI record using Cisco ER.

When Cisco ER generates the ALI record the second time after you make the 
change, it sets the Function Code to C because it assumes that the first file was 
accepted. Use AFT to change the Function Code for ELIN records from C to I.

Then, generate the format using AFT, and send the reformatted file to Ameritech.
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