Guest

Cisco BTS 10200 Softswitch

Multiple Cisco BTS 10200 Softswitches Sharing a Point Code in D-Link Configuration

  • Viewing Options

  • PDF (299.2 KB)
  • Feedback
Multiple Cisco BTS 10200 Softswitches Sharing a Point Code in D-Link Configuration

Table Of Contents

Multiple Cisco BTS 10200 Softswitches Sharing a Point Code in D-Link Configuration

OVERVIEW

PLANNING

Restrictions and Limitations

INSTALLING

CONFIGURING

BTS-1 ISUP Provisioning

BTS-1 TCAP Provisioning

BTS-2 ISUP Provisioning

BTS-2 TCAP Provisioning

ITP-1 (STP-1) Configuration

ITP-2 (STP-2) Configuration

OPERATING

Billing Fields

Measurements

Announcements

Command Responses

Tones

Cause Codes

Recoverable and Non-Recoverable Error Codes

TROUBLESHOOTING

Events and Alarms

REFERENCES

CLI Reference Guide

Related Documents


Multiple Cisco BTS 10200 Softswitches Sharing a Point Code in D-Link Configuration


Feature History

Release
Modification

Release 4.4

This feature was introduced.


This document describes the provisioning steps and network configuration necessary for a point code to be shared by multiple BTSes for ISUP signaling deployed with a Cisco ITP in "D" (diagonal) link configuration. It contains the following sections.

OVERVIEW

PLANNING

INSTALLING

CONFIGURING

OPERATING

TROUBLESHOOTING

REFERENCES

OVERVIEW

The Cisco IP Transfer Point (ITP) supports routing of signaling messages based on circuit identification code (CIC), which enables Cisco BTS 10200 Softswitches (BTS) to share point codes. This document discusses the network configuration and provisioning process necessary for two Cisco BTS 10200 Softswitches to share a single point code for ISUP signaling when deployed with a Cisco ITP in a "D" link configuration. It assumes that each BTS that is sharing the ISUP point code continues to use a separate point code for TCAP signaling that is not shared with TCAP applications on the other BTS.


Note TCAP signaling uses SUA as the transport protocol. M3UA based TCAP interoperability is not supported on any current release of the Cisco BTS 10200 Softswitch.


PLANNING

This section provides information on prerequisites and limitations applicable to this feature:

Restrictions and Limitations

This feature assumes that each BTS continues to use a separate point code for TCAP signaling that is not shared with TCAP applications on the other BTS.

INSTALLING

There are no new, modified, or deleted requirements for installation procedures for the Cisco BTS 10200 Softswitch as a result of the feature covered in this document.

CONFIGURING

This section provides sample provisioning for two BTSes sharing an OPC. In the following example, opc-id = opc1 is shared between BTSes for ISUP and also is used by the first BTS for TCAP. The second BTS uses opc2 for TCAP.


Note These tasks include examples of CLI commands that illustrate how to provision the specific feature. Most of these tables have additional tokens that are not included in the examples. For a complete list of all CLI tables and tokens, refer to the Cisco BTS 10200 Softswitch Command Line Interface Reference Guide.


BTS-1 ISUP Provisioning

## Provisioning on BTS-1 sharing the point code with BTS-2

add opc id=opc1; point-code=5-5-5; point-code-type=ANSI_CHINA;

add dpc id=dpc1; point-code=1-46-8; point-code-type=ANSI_CHINA ;

add sg id=sg1; priority=1;

add sg id=sg2; priority=1;

add sg-grp id=sg-grp1; sg1-id=sg1; sg2-id=sg2;

add sgp id=sgp1; sg-id=sg1;

add sgp id=sgp2; sg-id=sg2;

add sctp-assoc-profile id=sctp-prof1;

add sctp-assoc id=ca-sgp1-sctp; sgp-id=sgp1; sctp-assoc-profile-id=sctp-prof1; platform-id=CA146; remote-port=2905; remote-tsap-addr1=10.0.1.195; remote-tsap-addr2=10.128.1.195; dscp=AF11; ip-tos-precedence=ROUTINE;

add sctp-assoc id=ca-sgp2-sctp; sgp-id=sgp2; sctp-assoc-profile-id=sctp-prof1; platform-id=CA146; remote-port=2905; remote-tsap-addr1=10.0.0.150; remote-tsap-addr2=10.128.0.150; dscp=AF11; ip-tos-precedence=ROUTINE;

add user-part-variant id=ANSISS7_GR317;

add routing-key id=rk1; opc-id=opc1; sg-grp-id=sg-grp1; si=ISUP; rc=1; platform-id=CA146;

add call-ctrl-route id=dpc1-route; dpc-id=dpc1; routing-key-id=rk1; si=ISUP; user-part-variant-id=ANSISS7_GR317;

add call-ctrl-route id=dpc2-route; dpc-id=dpc2; routing-key-id=rk1; si=ISUP; user-part-variant-id=ANSISS7_GR317;

add mgw-profile id=as5300-prof; mgw-type=AS5300; mgcp-version=MGCP_1_0;

add mgw id=as5300-1; mgw-profile-id=as5300-prof; call-agent-id=CA146; tsap-addr=as5300-1.cisco.com; type=TGW;

add termination prefix=S1/DS1-0/; port-start=1; port-end=23 or 31; type=trunk; mgw-id=as5300-1;

add ss7-ansi-tg-profile id=ss7-prof1;

add trunk-grp id=1; call-agent-id=CA146; tg-type=SS7; tg-profile=ss7-prof1; call-ctrl-route-id=dpc1-route;

add trunk cic-start=1; cic-end=23; type=trunk; mgw-id=as5300-1; termination-prefix=S1/DS1-0/; tgn-id=1; termination-port-start=1; termination-port-end=23;

add route id=dpc1-route; tg-selection=RR; tgn1-id=1;

add route-guide id=dpc1-rg; policy-type=ROUTE; policy-id=dpc1-route;

add destination id=dpc1-dest; route-type=ROUTE; route-guide-id=dpc1-rg;

BTS-1 TCAP Provisioning

add dpc id=stp1; point-code=1-10-2; point-code-type=ANSI_CHINA ;

add sccp-nw id=1; net-ind=NATIONAL; SUB_SVC=NATIONAL; HOP-Count=3;

# Subsystem Profile

add subsystem-profile id=SS_LNP; platform-id=FSAIN205; description=LNP subsystem;

add subsystem-profile id=SS_800A; platform-id=FSAIN205; description=AIN 800 subsystem;

add subsystem-profile id=SS_800T; platform-id=FSAIN205; description=IN1 800 subsystem;

add subsystem-profile id=SS_CNAM; platform-id=FSPTC235; description=CNAM subsystem;

# Subsystem

add subsystem id=SS_LNP; opc-id=opc1; local-ssn=247; remote-ssn=247; sccp-nw-id=1; SCCP_VERSION=ANS92; TCAP_VERSION=ANS92; APPLICATION_VERSION=AIN01;

add subsystem id=SS_800A; opc-id=opc1; local-ssn=248; remote-ssn=248; sccp-nw-id=1; SCCP_VERSION=ANS92; TCAP_VERSION=ANS92; APPLICATION_VERSION=AIN01;

add subsystem id=SS_CNAM; opc-id=opc1; local-ssn=232; remote-ssn=232; sccp-nw-id=1; SCCP_VERSION=ANS92; TCAP_VERSION=ANS92; APPLICATION_VERSION=IN1;

add subsystem id=SS_800T; opc-id=opc1; local-ssn=254; remote-ssn=254; sccp-nw-id=1; SCCP_VERSION=ANS92; TCAP_VERSION=ANS92; APPLICATION_VERSION=IN1;

# Routing key

add routing-key id=rk_lnp; opc-id=opc1; sg-grp-id= sg-grp1; si=SCCP; rc=4402; PLATFORM_ID=FSAIN205; ssn-id=SS_LNP;

add routing-key id=rk_800a; opc-id=opc1; sg-grp-id= sg-grp1; si=SCCP; rc=4403; PLATFORM_ID=FSAIN205; ssn-id=SS_800A;

add routing-key id=rk_cnam; opc-id=opc1; sg-grp-id= sg-grp1; si=SCCP; rc=4404; PLATFORM_ID=FSPTC235; ssn-id=SS_CNAM;

add routing-key id=rk_800t; opc-id=opc1; sg-grp-id= sg-grp1; si=SCCP; rc=4401; PLATFORM_ID=FSAIN205; ssn-id=SS_800T;

# SCTP assoc profile, this can be the same as in ISUP provisioning

add sctp-assoc-profile id=sctp_prof;

# SCTP assoc

add sctp-assoc id= ain-sgp1-sctp; sgp-id= sgp1; sctp-assoc-profile-id=sctp_prof; REMOTE_PORT=14001; REMOTE_TSAP_ADDR1=10.0.1.195; remote-tsap-addr2=10.128.1.195; PLATFORM_ID=FSAIN205; DSCP=NONE; IP_TOS_PRECEDENCE=FLASH; LOCAL_RCVWIN=64000; MAX_INIT_RETRANS=5; MAX_INIT_RTO=1000;

add sctp-assoc id= ain-sgp2-sctp; sgp-id= sgp2; sctp-assoc-profile-id=sctp_prof; REMOTE_PORT=14001; REMOTE_TSAP_ADDR1=10.0.0.150; remote-tsap-addr2=10.128.0.150; PLATFORM_ID=FSAIN205; DSCP=NONE; IP_TOS_PRECEDENCE=FLASH; LOCAL_RCVWIN=64000; MAX_INIT_RETRANS=5; MAX_INIT_RTO=1000;

add sctp-assoc id= pots-sgp1-sctp; sgp-id= sgp1; sctp-assoc-profile-id=sctp_prof; REMOTE_PORT=14001; REMOTE_TSAP_ADDR1=10.0.0.150; remote-tsap-addr2=10.128.1.195; PLATFORM_ID= FSPTC235; DSCP=NONE; IP_TOS_PRECEDENCE=FLASH; LOCAL_RCVWIN=64000; MAX_INIT_RETRANS=5; MAX_INIT_RTO=1000;

add sctp-assoc id= pots-sgp2-sctp; sgp-id= sgp2; sctp-assoc-profile-id=sctp_prof; REMOTE_PORT=14001; REMOTE_TSAP_ADDR1=10.0.0.150; remote-tsap-addr2=10.128.0.150; PLATFORM_ID= FSPTC235; DSCP=NONE; IP_TOS_PRECEDENCE=FLASH; LOCAL_RCVWIN=64000; MAX_INIT_RETRANS=5; MAX_INIT_RTO=1000;

add sccp-route opc-id=opc1; dpc-id=stp1; ssn-id=SS_800T; rk-id=rk_800t;

add sccp-route opc-id=opc1; dpc-id=stp1; ssn-id=SS_800A; rk-id=rk_800a;

add sccp-route opc-id=opc1; dpc-id=stp1; ssn-id=SS_LNP; rk-id=rk_lnp;

add sccp-route opc-id=opc1; dpc-id=stp1; ssn-id=SS_CNAM; rk-id=rk_cnam;

# SLHR Profile

add slhr-profile id=slhr_800t; description=Service Logic Host Routing Table for IN1 800 Service;

add slhr-profile id=slhr_lnp; description=Service Logic Host Routing Table for AIN LNP Service;

add slhr-profile id=slhr_800a; description=Service Logic Host Routing Table for AIN 800 Service;

add slhr-profile id=slhr_cnam; description=Service Logic Host Routing Table for IN1 CNAM Service;

# SLHR

add slhr id=slhr_800t; opc-id=opc1; dpc-id=stp1; ssn-id=SS_800T; gtt-req=Y; tt=254; GTT_ADDR_TYPE=CDPN; GTT_ADDR=3;

add slhr id=slhr_lnp; opc-id=opc1; dpc-id=stp1; ssn-id=SS_LNP; gtt-req=Y; tt=11; GTT_ADDR_TYPE=CDPN; GTT_ADDR=3;

add slhr id=slhr_800a; opc-id=opc1; dpc-id=stp1; ssn-id=SS_800A; gtt-req=Y; tt=8; GTT_ADDR_TYPE=CDPN; GTT_ADDR=3;

add slhr id=slhr_cnam; opc-id=opc1; dpc-id=stp1; ssn-id=SS_CNAM; gtt-req=Y; tt=5; GTT_ADDR_TYPE=CLGN; GTT_ADDR=3;

add slhr id=slhr_acar; opc-id=opc1; dpc-id=itp-ap; ssn-id=SS_ACAR; gtt-req=Y; tt=251; GTT_ADDR_TYPE=CDPN; GTT_ADDR=10;

# CA Config

add CA-Config type=DEFAULT-TOLL-FREE-SLHR-ID; datatype=string; value=slhr_800a;

add CA-Config type=DEFAULT-LNP-SLHR-ID; datatype=string; value=slhr_lnp;

add CA-Config type=DEFAULT-LIDB-SLHR-ID; datatype=string; value=slhr_cnam;

add CA-Config type=ACAR-SLHR-ID; datatype=string; value=slhr_acar;

add CA-Config type=SCP-RESPONSE-TMR; datatype=integer; value=6;

#Pop is changed with the OPC of TCAP so that TCAP queries will use that OPC.

change pop id=69; opc-id=opc1; my_lrn=4692559999

BTS-2 ISUP Provisioning

## Provisioning on BTS-2 sharing the point code with BTS-1

add opc id=opc1; point-code=5-5-5; point-code-type=ANSI_CHINA;

add dpc id=dpc1; point-code=1-46-8; point-code-type=ANSI_CHINA ;

add sg id=sg1; priority=1;

add sg id=sg2; priority=1;

add sg-grp id=sg-grp1; sg1-id=sg1; sg2-id=sg2;

add sgp id=sgp1; sg-id=sg1;

add sgp id=sgp2; sg-id=sg2;

add sctp-assoc-profile id=sctp-prof1;

add sctp-assoc id=ca-sgp1-sctp; sgp-id=sgp1; sctp-assoc-profile-id=sctp-prof1; platform-id=CA147; remote-port=2905; remote-tsap-addr1=10.0.1.195; remote-tsap-addr2=10.128.1.195; dscp=AF11; ip-tos-precedence=ROUTINE;

add sctp-assoc id=ca-sgp2-sctp; sgp-id=sgp2; sctp-assoc-profile-id=sctp-prof1; platform-id=CA147; remote-port=2905; remote-tsap-addr1=10.0.0.150; remote-tsap-addr2=10.128.0.150; dscp=AF11; ip-tos-precedence=ROUTINE;

add user-part-variant id=ANSISS7_GR317;

add routing-key id=rk1; opc-id=opc1; sg-grp-id=sg-grp1; si=ISUP; rc=2; platform-id=CA146;

add call-ctrl-route id=dpc1-route; dpc-id=dpc1; routing-key-id=rk1; si=ISUP; user-part-variant-id=ANSISS7_GR317;

add call-ctrl-route id=dpc2-route; dpc-id=dpc2; routing-key-id=rk1; si=ISUP; user-part-variant-id=ANSISS7_GR317;

add mgw-profile id=as5300-prof; mgw-type=AS5300; mgcp-version=MGCP_1_0;

add mgw id=as5300-1; mgw-profile-id=as5300-prof; call-agent-id=CA146; tsap-addr=as5300-1.cisco.com; type=TGW;

add termination prefix=S1/DS1-0/; port-start=1; port-end=23 ; type=trunk; mgw-id=as5300-2;

add ss7-ansi-tg-profile id=ss7-prof1;

add trunk-grp id=1; call-agent-id=CA147; tg-type=SS7; tg-profile=ss7-prof1; call-ctrl-route-id=dpc1-route;

add trunk cic-start=24; cic-end=46; type=trunk; mgw-id=as5300-2; termination-prefix=S1/DS1-0/; tgn-id=1; termination-port-start=1; termination-port-end=23;

add route id=dpc1-route; tg-selection=RR; tgn1-id=1;

add route-guide id=dpc1-rg; policy-type=ROUTE; policy-id=dpc1-route;

add destination id=dpc1-dest; route-type=ROUTE; route-guide-id=dpc1-rg;

BTS-2 TCAP Provisioning

add opc id=opc2; point-code=7-7-7; point-code-type=ANSI_CHINA;

add dpc id=stp1; point-code=1-10-2; point-code-type=ANSI_CHINA ;

add sccp-nw id=1; net-ind=NATIONAL; SUB_SVC=NATIONAL; HOP-Count=3;

# Subsystem Profile

add subsystem-profile id=SS_LNP; platform-id=FSAIN206; description=LNP subsystem;

add subsystem-profile id=SS_800A; platform-id=FSAIN206; description=AIN 800 subsystem;

add subsystem-profile id=SS_800T; platform-id=FSAIN206; description=IN1 800 subsystem;

add subsystem-profile id=SS_CNAM; platform-id=FSPTC236; description=CNAM subsystem;

# Subsystem

add subsystem id=SS_LNP; opc-id=opc2; local-ssn=247; remote-ssn=247; sccp-nw-id=1; SCCP_VERSION=ANS92; TCAP_VERSION=ANS92; APPLICATION_VERSION=AIN01;

add subsystem id=SS_800A; opc-id=opc2; local-ssn=248; remote-ssn=248; sccp-nw-id=1; SCCP_VERSION=ANS92; TCAP_VERSION=ANS92; APPLICATION_VERSION=AIN01;

add subsystem id=SS_CNAM; opc-id=opc2; local-ssn=232; remote-ssn=232; sccp-nw-id=1; SCCP_VERSION=ANS92; TCAP_VERSION=ANS92; APPLICATION_VERSION=IN1;

add subsystem id=SS_800T; opc-id=opc2; local-ssn=254; remote-ssn=254; sccp-nw-id=1; SCCP_VERSION=ANS92; TCAP_VERSION=ANS92; APPLICATION_VERSION=IN1;

# Routing key

add routing-key id=rk_lnp; opc-id=opc2; sg-grp-id= sg-grp1; si=SCCP; rc=4402; PLATFORM_ID=FSAIN205; ssn-id=SS_LNP;

add routing-key id=rk_800a; opc-id=opc2; sg-grp-id= sg-grp1; si=SCCP; rc=4403; PLATFORM_ID=FSAIN205; ssn-id=SS_800A;

add routing-key id=rk_cnam; opc-id=opc2; sg-grp-id= sg-grp1; si=SCCP; rc=4404; PLATFORM_ID=FSPTC235; ssn-id=SS_CNAM;

add routing-key id=rk_800t; opc-id=opc2; sg-grp-id= sg-grp1; si=SCCP; rc=4401; PLATFORM_ID=FSAIN205; ssn-id=SS_800T;

# SCTP assoc profile, this can be the same as in ISUP provisioning

add sctp-assoc-profile id=sctp_prof;

# SCTP assoc

add sctp-assoc id= ain-sgp1-sctp; sgp-id= sgp1; sctp-assoc-profile-id=sctp_prof; REMOTE_PORT=14001; REMOTE_TSAP_ADDR1=10.0.1.195; remote-tsap-addr2=10.128.1.195; PLATFORM_ID=FSAIN206; DSCP=NONE; IP_TOS_PRECEDENCE=FLASH; LOCAL_RCVWIN=64000; MAX_INIT_RETRANS=5; MAX_INIT_RTO=1000;

add sctp-assoc id= ain-sgp2-sctp; sgp-id= sgp2; sctp-assoc-profile-id=sctp_prof; REMOTE_PORT=14001; REMOTE_TSAP_ADDR1=10.0.0.150; remote-tsap-addr2=10.128.0.150; PLATFORM_ID=FSAIN206; DSCP=NONE; IP_TOS_PRECEDENCE=FLASH; LOCAL_RCVWIN=64000; MAX_INIT_RETRANS=5; MAX_INIT_RTO=1000;

add sctp-assoc id= pots-sgp1-sctp; sgp-id= sgp1; sctp-assoc-profile-id=sctp_prof; REMOTE_PORT=14001; REMOTE_TSAP_ADDR1=10.0.1.195; remote-tsap-addr2=10.128.1.195; PLATFORM_ID= FSPTC236; DSCP=NONE; IP_TOS_PRECEDENCE=FLASH; LOCAL_RCVWIN=64000; MAX_INIT_RETRANS=5; MAX_INIT_RTO=1000;

add sctp-assoc id= pots-sgp2-sctp; sgp-id= sgp2; sctp-assoc-profile-id=sctp_prof; REMOTE_PORT=14001; REMOTE_TSAP_ADDR1=10.0.0.150; remote-tsap-addr2=10.128.0.150; PLATFORM_ID= FSPTC236; DSCP=NONE; IP_TOS_PRECEDENCE=FLASH; LOCAL_RCVWIN=64000; MAX_INIT_RETRANS=5; MAX_INIT_RTO=1000;

add sccp-route opc-id=opc2; dpc-id=stp1; ssn-id=SS_800T; rk-id=rk_800t;

add sccp-route opc-id=opc2; dpc-id=stp1; ssn-id=SS_800A; rk-id=rk_800a;

add sccp-route opc-id=opc2; dpc-id=stp1; ssn-id=SS_LNP; rk-id=rk_lnp;

add sccp-route opc-id=opc2; dpc-id=stp1; ssn-id=SS_CNAM; rk-id=rk_cnam;

# SLHR Profile

add slhr-profile id=slhr_800t; description=Service Logic Host Routing Table for IN1 800 Service;

add slhr-profile id=slhr_lnp; description=Service Logic Host Routing Table for AIN LNP Service;

add slhr-profile id=slhr_800a; description=Service Logic Host Routing Table for AIN 800 Service;

add slhr-profile id=slhr_cnam; description=Service Logic Host Routing Table for IN1 CNAM Service;

# SLHR

add slhr id=slhr_800t; opc-id=opc2; dpc-id=stp1; ssn-id=SS_800T; gtt-req=Y; tt=254; GTT_ADDR_TYPE=CDPN; GTT_ADDR=3;

add slhr id=slhr_lnp; opc-id=opc2; dpc-id=stp1; ssn-id=SS_LNP; gtt-req=Y; tt=11; GTT_ADDR_TYPE=CDPN; GTT_ADDR=3;

add slhr id=slhr_800a; opc-id=opc2; dpc-id=stp1; ssn-id=SS_800A; gtt-req=Y; tt=8; GTT_ADDR_TYPE=CDPN; GTT_ADDR=3;

add slhr id=slhr_cnam; opc-id=opc2; dpc-id=stp1; ssn-id=SS_CNAM; gtt-req=Y; tt=5; GTT_ADDR_TYPE=CLGN; GTT_ADDR=3;

add slhr id=slhr_acar; opc-id=opc2; dpc-id=itp-ap; ssn-id=SS_ACAR; gtt-req=Y; tt=251; GTT_ADDR_TYPE=CDPN; GTT_ADDR=10;

# CA Config

add CA-Config type=DEFAULT-TOLL-FREE-SLHR-ID; datatype=string; value=slhr_800a;

add CA-Config type=DEFAULT-LNP-SLHR-ID; datatype=string; value=slhr_lnp;

add CA-Config type=DEFAULT-LIDB-SLHR-ID; datatype=string; value=slhr_cnam;

add CA-Config type=ACAR-SLHR-ID; datatype=string; value=slhr_acar;

add CA-Config type=SCP-RESPONSE-TMR; datatype=integer; value=6;

#Pop is changed with the OPC of TCAP so that TCAP queries will use that OPC.

change pop id=69; opc-id=opc2; my_lrn=4692559999

ITP-1 (STP-1) Configuration

The following sample ITP configuration is provided as an example. For detailed information, refer to the Cisco IP Transfer Point Configuration Guides at:

http://www.cisco.com/en/US/products/sw/wirelssw/ps1862/prod_configuration_guides_list.html

######################

#sh run

Building configuration...

Current configuration : 5530 bytes

:)

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname va-2651-10

!

boot system flash c2600-itpk9-mz.122-23.SW1.bin

enable secret 5 $1$d9dn$/XIhJBgnDRxd6/M9Yptvt0

enable password cisco

!

!

ipc zone default

association 1

no shutdown

protocol sctp

local-port 9000

local-ip 10.0.1.195

remote-port 9001

remote-ip 10.0.5.239

!

ip subnet-zero

!

!

ip domain-name hrndevtest.cisco.com

ip name-server 10.0.0.6

!

ip ssh version 1

cs7 multi-instance

cs7 instance 0 variant ANSI

cs7 instance 0 network-name ComcastNet

cs7 instance 0 point-code 3.100.5

cs7 instance 1 variant ANSI

cs7 instance 1 network-name CBeyond

cs7 instance 1 point-code 5.100.5

!

!

!

isdn voice-call-failure 0

call rsvp-sync

!

!

!

!

!

!

redundancy inter-device

!

!

controller T1 0/0

framing esf

linecode ami

channel-group 0 timeslots 1

description inet-98 link 6

!

controller T1 0/1

framing esf

linecode ami

channel-group 0 timeslots 2

description inet-98 link 7

!

controller T1 0/2

framing esf

linecode b8zs

channel-group 0 timeslots 1

!

controller T1 0/3

framing esf

linecode b8zs

channel-group 0 timeslots 1

!

!

!

interface FastEthernet0/0

ip address 10.0.1.195 255.255.0.0

speed auto

full-duplex

!

interface Serial0/0:0

no ip address

encapsulation mtp2

!

interface FastEthernet0/1

ip address 10.128.1.195 255.255.0.0

duplex auto

speed auto

!

interface Serial0/1:0

no ip address

encapsulation mtp2

!

interface Serial0/2:0

no ip address

encapsulation mtp2

!

interface Serial0/3:0

no ip address

encapsulation mtp2

!

cs7 group grp-2651-10 9004

local-ip 10.0.1.195

shutdown

peer grp-7200-1 9003

remote-ip 10.0.5.239

!

cs7 local-peer 7000

local-ip 10.0.1.195

local-ip 10.128.1.195

!

!

cs7 instance 0 linkset ls5 3.200.1

shutdown

!

cs7 instance 0 linkset ls6 3.200.7

shutdown

!

cs7 instance 1 linkset ls1 5.200.2

link 0 Serial0/1:0

!

cs7 instance 1 linkset ls3 5.200.3

link 0 Serial0/0:0

!

cs7 instance 1 linkset lset2 1.10.2

link 0 Serial0/2:0

!

cs7 instance 1 linkset c-link 5.100.6

link 0 sctp 10.0.0.150 10.128.0.150 7000 7000

!

cs7 instance 0 route-table

update route 3.100.6 255.255.255 linkset ls6 priority 1

!

update route 3.100.7 255.255.255 linkset ls6 priority 1

!

update route 3.100.2 255.255.255 linkset ls6 priority 2

!

update route 3.100.1 255.255.255 linkset ls5 priority 1

!

cs7 instance 1 route-table

update route 1.46.1 255.255.255 linkset ls1 priority 1

!

update route 1.46.8 255.255.255 linkset ls3 priority 1

!

update route 1.46.1 255.255.255 linkset c-link priority 9

!

update route 1.46.8 255.255.255 linkset c-link priority 9

!

!

cs7 sua 14001

local-ip 10.0.1.195

local-ip 10.128.1.195

!

cs7 m3ua 2905

local-ip 10.0.1.195

local-ip 10.128.1.195

!

cs7 sgmp 9101

local-ip 10.0.1.195

local-ip 10.128.1.195

!

cs7 mated-sg ITP4 9101

remote-ip 10.0.0.150

remote-ip 10.128.0.150

!

cs7 asp hrn2Asp 11146 2905 m3ua

remote-ip 192.168.51.130

remote-ip 192.168.151.130

!

cs7 asp hrn3Asp 11146 2905 m3ua

remote-ip 192.168.60.102

remote-ip 192.168.160.102

!

cs7 asp hrn4asp 11146 2905 m3ua

remote-ip 10.0.0.205

remote-ip 10.128.0.181

!

cs7 asp hrn2Aasp 12205 14001 sua

remote-ip 192.168.51.130

remote-ip 192.168.151.130

!

cs7 asp hrn2Asp2 11146 2905 m3ua

remote-ip 192.168.51.131

remote-ip 192.168.151.131

!

cs7 asp hrn2Basp 12205 14001 sua

remote-ip 192.168.51.131

remote-ip 192.168.151.131

!

cs7 asp hrn3Aasp 12205 14001 sua

remote-ip 192.168.60.102

remote-ip 192.168.160.102

!

cs7 asp hrn3Asp2 11146 2905 m3ua

remote-ip 192.168.60.103

remote-ip 192.168.160.103

!

cs7 asp hrn3Basp 12205 14001 sua

remote-ip 192.168.60.103

remote-ip 192.168.160.103

!

cs7 instance 1 as btsLNP1 sua

routing-key 4402 5.5.5 si sccp ssn 247

asp hrn2Aasp

asp hrn2Basp

traffic-mode override

!

cs7 instance 1 as bts800A1 sua

routing-key 4403 5.5.5 si sccp ssn 248

asp hrn2Aasp

asp hrn2Basp

traffic-mode override

!

cs7 instance 1 as bts800T1 sua

routing-key 4401 5.5.5 si sccp ssn 254

asp hrn2Aasp

asp hrn2Basp

traffic-mode override

!

cs7 instance 1 as btsCNAM1 sua

routing-key 4404 5.5.5 si sccp ssn 232

asp hrn2Aasp

asp hrn2Basp

traffic-mode override

!

cs7 instance 1 as hrn2As1 m3ua

routing-key 1 5.5.5 si isup cic 1 23

asp hrn2Asp

asp hrn2Asp2

network-appearance 1

!

cs7 instance 1 as hrn3As1 m3ua

routing-key 2 5.5.5 si isup cic 24 65535

asp hrn3Asp2

asp hrn3Asp

network-appearance 1

!

cs7 instance 1 as btsAsLNP2 sua

routing-key 4502 7.7.7 si sccp ssn 247

asp hrn3Aasp

asp hrn3Basp

traffic-mode override

!

cs7 instance 1 as bts800A2 sua

routing-key 4503 7.7.7 si sccp ssn 248

asp hrn3Aasp

asp hrn3Basp

traffic-mode override

!

cs7 instance 1 as bts800T2 sua

routing-key 4501 7.7.7 si sccp ssn 254

asp hrn3Aasp

asp hrn3Basp

traffic-mode override

!

cs7 instance 1 as btsCNAM2 sua

routing-key 4504 7.7.7 si sccp ssn 232

asp hrn3Aasp

asp hrn3Basp

traffic-mode override

!

ip classless

ip route 192.168.51.0 255.255.255.0 10.0.0.3

ip route 192.168.60.0 255.255.255.0 10.0.0.3

ip route 192.168.151.0 255.255.255.0 10.0.0.3

ip route 192.168.160.0 255.255.255.0 10.0.0.3

ip http server

!

!

!

logging history size 500

!

!

!

!

control-plane

!

!

dial-peer cor custom

!

!

!

!

banner motd ^C

********************

*** BTS - HRN4 ***

*** Mehmet Baser ***

********************

^C

!

line con 0

line aux 0

line vty 0 4

no login

!

!

end

ITP-2 (STP-2) Configuration

#sh runn

Building configuration...

Current configuration : 4931 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname va-2651-35

!

boot system flash c2600-itpk9-mz.122-23.SW1.bin

enable password cisco

!

ip subnet-zero

!

!

ip domain-name hrndevtest.cisco.com

ip name-server 10.0.0.6

!

ip ssh version 1

cs7 multi-instance

cs7 instance 0 variant ANSI

cs7 instance 0 network-name Regression

cs7 instance 0 point-code 2.100.5

cs7 instance 1 variant ANSI

cs7 instance 1 network-name CBeyond

cs7 instance 1 point-code 5.100.6

no cs7 accounting checkpoint-interval

no cs7 accounting gtt-checkpoint-interval

!

!

!

call rsvp-sync

!

!

!

!

!

!

controller T1 0/0

shutdown

framing esf

linecode b8zs

channel-group 0 timeslots 1

!

controller T1 0/1

framing esf

linecode b8zs

channel-group 0 timeslots 1

!

controller T1 0/2

framing esf

linecode ami

channel-group 0 timeslots 1

description inet-98 link 5

!

controller T1 0/3

framing esf

linecode ami

channel-group 0 timeslots 1

description inet-98 link 8

!

!

!

interface FastEthernet0/0

ip address 10.0.0.150 255.255.0.0

duplex auto

speed auto

!

interface Serial0/0:0

no ip address

encapsulation mtp2

shutdown

!

interface FastEthernet0/1

ip address 10.128.0.150 255.255.0.0

duplex auto

speed auto

!

interface Serial0/1:0

no ip address

encapsulation mtp2

!

interface Serial0/2:0

no ip address

encapsulation mtp2

!

interface Serial0/3:0

no ip address

encapsulation mtp2

!

!

cs7 local-peer 7000

local-ip 10.0.0.150

local-ip 10.128.0.150

!

!

cs7 instance 0 linkset ls1 2.100.2

shutdown

!

cs7 instance 0 linkset ls3 2.100.6

shutdown

!

cs7 instance 1 linkset ls4 5.200.2

link 0 Serial0/2:0

!

cs7 instance 1 linkset ls5 5.200.3

link 0 Serial0/3:0

!

cs7 instance 1 linkset lset1 1.10.2

link 0 Serial0/1:0

!

cs7 instance 1 linkset c-link 5.100.5

link 0 sctp 10.0.1.195 10.128.1.195 7000 7000

!

cs7 instance 0 route-table

cs7 instance 1 route-table

update route 1.46.1 255.255.255 linkset ls4 priority 1

!

update route 1.46.8 255.255.255 linkset ls5 priority 1

!

update route 1.46.1 255.255.255 linkset c-link priority 9

!

update route 1.46.8 255.255.255 linkset c-link priority 9

!

!

cs7 sua 14001

local-ip 10.0.0.150

local-ip 10.128.0.150

!

cs7 m3ua 2905

local-ip 10.0.0.150

local-ip 10.128.0.150

!

cs7 sgmp 9101

local-ip 10.0.0.150

local-ip 10.128.0.150

!

cs7 mated-sg ITP4 9101

remote-ip 10.0.1.195

remote-ip 10.128.1.195

!

cs7 asp btsAsp 11146 2905 m3ua

remote-ip 10.0.0.205

remote-ip 10.128.0.181

!

cs7 asp hrn2Asp 11146 2905 m3ua

remote-ip 192.168.51.130

remote-ip 192.168.151.130

!

cs7 asp hrn3Asp 11146 2905 m3ua

remote-ip 192.168.60.102

remote-ip 192.168.160.102

!

cs7 asp hrn2Aasp 12205 14001 sua

remote-ip 192.168.51.130

remote-ip 192.168.151.130

!

cs7 asp hrn2Asp2 11146 2905 m3ua

remote-ip 192.168.51.131

remote-ip 192.168.151.131

!

cs7 asp hrn2Basp 12205 14001 sua

remote-ip 192.168.51.131

remote-ip 192.168.151.131

!

cs7 asp hrn3Aasp 12205 14001 sua

remote-ip 192.168.60.102

remote-ip 192.168.160.102

!

cs7 asp hrn3Asp2 11146 2905 m3ua

remote-ip 192.168.60.103

remote-ip 192.168.160.103

!

cs7 asp hrn3Basp 12205 14001 sua

remote-ip 192.168.60.103

remote-ip 192.168.160.103

!

cs7 instance 1 as btsLNP1 sua

routing-key 4502 5.5.5 si sccp ssn 247

asp hrn2Aasp

asp hrn2Basp

traffic-mode override

!

cs7 instance 1 as bts800A1 sua

routing-key 4403 5.5.5 si sccp ssn 248

asp hrn2Aasp

asp hrn2Basp

traffic-mode override

!

cs7 instance 1 as bts800T1 sua

routing-key 4401 5.5.5 si sccp ssn 254

asp hrn2Aasp

asp hrn2Basp

traffic-mode override

!

cs7 instance 1 as btsCNAM1 sua

routing-key 4404 5.5.5 si sccp ssn 232

asp hrn2Aasp

asp hrn2Basp

traffic-mode override

!

cs7 instance 1 as hrn2As1 m3ua

routing-key 1 5.5.5 si isup cic 1 23

asp hrn2Asp

asp hrn2Asp2

network-appearance 1

!

cs7 instance 1 as hrn3As1 m3ua

routing-key 2 5.5.5 si isup cic 24 65535

asp hrn3Asp2

asp hrn3Asp

network-appearance 1

!

cs7 instance 0 as btsAsLNP2 sua

routing-key 4502 7.7.7 si sccp ssn 247

asp hrn3Aasp

asp hrn3Basp

traffic-mode override

!

cs7 instance 1 as bts800A2 sua

routing-key 4503 7.7.7 si sccp ssn 248

asp hrn3Aasp

asp hrn3Basp

traffic-mode override

!

cs7 instance 1 as bts800T2 sua

routing-key 4501 7.7.7 si sccp ssn 254

asp hrn3Aasp

asp hrn3Basp

traffic-mode override

!

cs7 instance 1 as btsCNAM2 sua

routing-key 4504 7.7.7 si sccp ssn 232

asp hrn3Aasp

asp hrn3Basp

traffic-mode override

!

ip classless

ip route 192.168.51.0 255.255.255.0 10.0.0.3

ip route 192.168.60.0 255.255.255.0 10.0.0.3

ip route 192.168.151.0 255.255.255.0 10.0.0.3

ip route 192.168.160.0 255.255.255.0 10.0.0.3

no ip http server

!

!

!

logging history size 500

!

!

!

!

control-plane

!

!

dial-peer cor custom

!

!

!

!

banner motd ^CC

********************

*** BTS - HRN4 ***

*** Mehmet Baser ***

********************^C

!

line con 0

line aux 0

line vty 0 4

password cisco

login

!

!

end

OPERATING

This section explains how this feature affects the following operational areas:

Billing Fields

Measurements

Announcements

Command Responses

Tones

Cause Codes

Recoverable and Non-Recoverable Error Codes

Billing Fields

There are no new, modified, or deleted billing fields related to the features described in this document.


Note See the Cisco BTS 10200 Softswitch Billing Guide for detailed information regarding billing fields.


Measurements

There are no new, modified, or deleted measurements related to the features described in this document.


Note See the Measurements section for a complete list of all traffic measurements.


Announcements

There are no new, modified, or deleted announcements related to the features described in this document.


Note See the Announcements section for details on the announcement files and announcement provisioning.


Command Responses

There are no new, modified, or deleted command responses related to the features described in this document.


Note See the Command Responses section for a complete list of system command responses.


Tones

There are no new, modified, or deleted command responses related to the features described in this document.


Note See the Tones section for a complete list of tones.


Cause Codes

There are no new, modified, or deleted command responses related to the features described in this document.


Note See the Cause Codes section for a complete list of cause codes.


Recoverable and Non-Recoverable Error Codes

There are no new, modified, or deleted error codes related to the features described in this document.>>


Note See the Error Codes section for a complete list of error codes.


TROUBLESHOOTING

This section lists the Events and Alarms that are new, revised, or deleted as a result of this feature.

Events and Alarms

There are no new, modified, or deleted events or alarms related to the features described in this document.


Note See the Events and Alarms section for details about causes and corrective actions.


REFERENCES

The following sections provide references related to <<Features>>.

CLI Reference Guide

There are no new, modified, or deleted CLI commands or tokens related to the features described in this document.


Note All existing commands used with this feature are documented in the Cisco BTS 10200 Softswitch Command Reference Guide.


Related Documents

Related Topic
Document Title

Release Notes, Release 4.4

Cisco BTS 10200 Softswitch Release Notes for Release 4.4

System Overview

Cisco BTS 10200 Softswitch System Description, Release 4.4

Provisioning

Cisco BTS 10200 Softswitch Provisioning Guide, Release 4.1, 4.2, and 4.4

Operations and Maintenance

Cisco BTS 10200 Softswitch Operations and Maintenance Guide, Release 4.1, 4.2, and 4.4

CLI Commands

Cisco BTS 10200 Softswitch Command Line Interface Reference Guide, Software Releases 4.1, 4.2, 4.4.1, and 4.4