Cisco Internet Streamer CDS 2.5 Software Configuration Guide
CLI Commands
Downloads: This chapterpdf (PDF - 272.0KB) The complete bookPDF (PDF - 4.65MB) | Feedback

CLI Commands

Table Of Contents

CLI Commands

Multi-Port Support

Configuring Port Channel

Redundant Dedicated Management Ports

Configuring Redundant Management Ports

Switch Port-Channel Configuration for Content Acquirer and Edge Service Engine

Verifying Port Channel Configuration

Configuring Last-Resort Routing

Configuring Standby Interfaces

Standby Interface with Switch Failover Configuration Procedure

Other CLI Commands

CDNFS cleanup Command

cache content Command

Service Router Redirect Burst Control Command


CLI Commands


This appendix covers the following topics:

Multi-Port Support

Configuring Port Channel

Configuring Last-Resort Routing

Configuring Standby Interfaces

Other CLI Commands

Multi-Port Support

Multi-port support allows the configuration of multiple interfaces, each with a different IP address, all used for streaming traffic. An interface could be a gigabit Ethernet channel, a port channel, or a standby group. Multi-port support allows for utilization of the total bandwidth available on the CDE220-2S3i and is introduced solely to support the CDE220-2S3i platform to use all 12 gigabit Ethernet interfaces.


Note Multi-port support is only supported on the CDE220-2S3i platform, which is supported in Release 2.5.7 and later releases.


The main reason Multi-port support is added is because a switch has a hard limit of 8 interfaces that can be grouped into a port-channel, so to fully use all 12 gigabit Ethernet interfaces, multi-port support was added.


Note Before Release 2.5 only a single streaming interface could be configured; the streaming interface was configured as the primary interface. To separate management and streaming traffic, the management interface was configured as a dedicated management interface by using the CDSM's Device Activation page. A port channel, as well as a standby group, could be created for the management interface to provide redundancy.

In Release 2.5, the streaming interface is introduced for streaming content.


Redirection with Proximity Engine

If an SE is configured with more than one streaming interface IP address and the SR uses proximity-based routing, the Proximity Engine uses the first valid IP address when performing the proximity check. Proximity-based routing is used to select the closest Service Engine for a specified client IP address, and it is assumed the client has the same proximity to all IP addresses of the SE.

The first valid streaming interface is the first interface displayed in the show run command. The order in which the streaming interfaces display depends on the order of configuration, as well as the history of the configuration modifications (for example, if a streaming interface was deleted and then added again). It is not possible to guarantee a certain display order of the streaming interfaces; therefore, it is not possible to guarantee that a certain streaming interface IP address is used for the proximity check.

Configuring Multi-Port Support

Multi-port support allows for configuring a list of streaming interfaces. If there are 14 gigabit Ethernet channels in the system, then there could be a maximum of 14 streaming interfaces, each with their own unique IP address. This example is for the CDE220-2G2, which has 10 gigabit Ethernet interfaces. The CDE110 and CDE205 have 2 gigabit Ethernet interfaces and the CDE220-2S3i has 14 gigabit Ethernet interfaces.

The following commands can be used to add a streaming interface.

SE-CDE220-1(config)# streaming-interface portChannel 1
SE-CDE220-1# show run
! CDS version 2.5.0
!
device mode service-engine
!
!
hostname SE-CDE220-1
!
primary-interface PortChannel 1
!
interface Standby 1
 ip address 1.2.3.4 255.255.255.0
 exit
interface Standby 3
 ip address 4.5.6.7 255.255.255.0
 exit
!
interface PortChannel 1
 ip address 7.9.0.3 255.255.0.0
 exit
!
interface GigabitEthernet 1/0
 shutdown
 exit
interface GigabitEthernet 2/0
 standby 3
 exit
interface GigabitEthernet 3/0
 channel-group 1
 exit
interface GigabitEthernet 4/0
 channel-group 1
 exit
interface GigabitEthernet 5/0
 channel-group 1
 exit
interface GigabitEthernet 6/0
 channel-group 1
 exit
interface GigabitEthernet 7/0
 shutdown
 exit
interface GigabitEthernet 8/0
 shutdown
 exit
interface GigabitEthernet 9/0
 shutdown
 exit
interface GigabitEthernet 10/0
 shutdown
 exit
!
streaming-interface PortChannel 1
streaming-interface GigabitEthernet 8/0
 
   

Use the no form of the command to delete an interface. The following example shows the deletion of a streaming interface:

SE-CDE220-1(config)# no streaming-interface gigabitEthernet 8/0
SE-CDE220-1# show run
! CDS version 2.5.0
!
device mode service-engine
!
!
hostname SE-CDE220-1
!
primary-interface PortChannel 1
!
interface Standby 1
 ip address 1.2.3.4 255.255.255.0
 exit
interface Standby 3
 ip address 4.5.6.7 255.255.255.0
 exit
!
interface PortChannel 1
 ip address 7.9.0.3 255.255.0.0
 exit
!
interface GigabitEthernet 1/0
 shutdown
 exit
interface GigabitEthernet 2/0
 standby 3
 exit
interface GigabitEthernet 3/0
 channel-group 1
 exit
interface GigabitEthernet 4/0
 channel-group 1
 exit
interface GigabitEthernet 5/0
 channel-group 1
 exit
interface GigabitEthernet 6/0
 channel-group 1
 exit
interface GigabitEthernet 7/0
 shutdown
 exit
interface GigabitEthernet 8/0
 shutdown
 exit
interface GigabitEthernet 9/0
 shutdown
 exit
interface GigabitEthernet 10/0
 shutdown
 exit
!
streaming-interface PortChannel 1
 
   
SE-CDE220-1(config)# no streaming-interface gigabitEthernet 8/0
No Configuration exists to delete
 
   

Multiple IP Addresses and Default Gateway Example

The following example shows how to configure the streaming interfaces on a CDE220-2S3i with multiple IP addresses and a default gateway, plus adding the necessary IP routes.


Note If the CDE220-2S3i has multiple IP addresses and is configured in a private network address space, then each internal IP address needs an external NAT entry defined on the main core router or switch.

The IP default gateway can only be configured when the physical network connection and VLAN is configured and active on the switch or router. If the VLAN is not ready when you configure the IP default gateway, you get an error message stating that the default gateway address is invalid.


This example consists of the following steps:


Step 1 Creating a port channel.

CC1-2S3-4(config)# interface portChannel 1
CC1-2S3-4(config-if)# ip add 8.4.0.8 255.255.0.0
CC1-2S3-4(config-if)# exit
CC1-2S3-4(config)# interface portChannel 2
CC1-2S3-4(config-if)# ip add 6.22.1.2 255.255.255.0
CC1-2S3-4(config-if)# exit
CC1-2S3-4(config)# interface portChannel 3
CC1-2S3-4(config-if)# ip add 6.23.1.2 255.255.255.0
CC1-2S3-4(config-if)# exit
CC1-2S3-4(config)#
 
   

Step 2 Creating an IP default gateway. This step cannot be done unless the physical network connection and switch side VLAN is configured first.

CC1-2S3-4(config)# ip default-gateway 8.4.0.1 6.22.1.1 6.23.1.1
CC1-2S3-4(config)#
 
   

Step 3 Adding IP routes to the subnet table.


Note In Release 2.5.9 and later releases, the interface keyword has been obsoleted and it is no longer necessary to configure default source policy routes. After you define the default gateways for all interfaces, the source policy routes are automatically generated in the routing table. For more information, see the Release Notes for Internet Streamer CDS 2.5.9.


CC1-2S3-4(config)# ip route 0.0.0.0 0.0.0.0 8.4.0.1 interface 8.4.0.8
CC1-2S3-4(config)# ip route 0.0.0.0 0.0.0.0 6.22.1.1 interface 6.22.1.2
CC1-2S3-4(config)# ip route 0.0.0.0 0.0.0.0 6.23.1.1 interface 6.23.1.2
CC1-2S3-4(config)# exit
CC1-2S3-4# show ip route
Destination      Gateway          Netmask
---------------- ---------------- ----------------
6.22.1.2         0.0.0.0          255.255.255.255
8.4.0.8          0.0.0.0          255.255.255.255
6.23.1.2         0.0.0.0          255.255.255.255
6.23.1.0         0.0.0.0          255.255.255.0
6.22.1.0         0.0.0.0          255.255.255.0
8.4.0.0          0.0.0.0          255.255.0.0
0.0.0.0          8.4.0.1          0.0.0.0
0.0.0.0          6.22.1.1         0.0.0.0
0.0.0.0          6.23.1.1         0.0.0.0
 
   
Number of route cache entries: 14
 
   
Table for interface 8.4.0.8 :
0.0.0.0          0.0.0.0          8.4.0.1
 
   
Table for interface 6.22.1.2 :
0.0.0.0          0.0.0.0          6.22.1.1
 
   
Table for interface 6.23.1.2 :
0.0.0.0          0.0.0.0          6.23.1.1
 
   

Step 4 Adding gigabit Ethernet interfaces into the port channel.

CC1-2S3-4(config)# interface gigabitEthernet 3/0 channel-group 1
CC1-2S3-4(config)# interface gigabitEthernet 4/0 channel-group 1
CC1-2S3-4(config)# interface gigabitEthernet 5/0 channel-group 1
CC1-2S3-4(config)# interface gigabitEthernet 6/0 channel-group 1
CC1-2S3-4(config)# interface gigabitEthernet 7/0 channel-group 2
CC1-2S3-4(config)# interface gigabitEthernet 8/0 channel-group 2
CC1-2S3-4(config)# interface gigabitEthernet 9/0 channel-group 2
CC1-2S3-4(config)# interface gigabitEthernet 10/0 channel-group 2
CC1-2S3-4(config)# interface gigabitEthernet 11/0 channel-group 3
CC1-2S3-4(config)# interface gigabitEthernet 12/0 channel-group 3
CC1-2S3-4(config)# interface gigabitEthernet 13/0 channel-group 3
CC1-2S3-4(config)# interface gigabitEthernet 14/0 channel-group 3
 
   

Step 5 Creating a streaming interface for the port channel.

CC1-2S3-4(config)# streaming-interface portchannel 1
CC1-2S3-4(config)# streaming-interface portchannel 2
CC1-2S3-4(config)# streaming-interface portchannel 3
 
   

Service Router Monitoring

The Service Router now associates multiple IP addresses to a particular SE. From the SR, use the following command to check the list of IP addresses of the SE.

SR# show service-router services sename SE-CDE220-1
 
   
-- Services Status Of SE: SE-CDE220-1-
IP Address              : 7.9.0.7
IP Address              : 2.2.2.2
Aliveness               : up
Critical Service(s)     : Running
Service WEB
        Running         : Yes
        Threshold       : Not reached
 
   
Service WMT
        Running         : Yes
        Threshold       : Not reached
 
   
Service MS
        Running         : No
 
   
Service FMS
        Running         : Yes
        Threshold       : Not reached
 
   

The SEs send keepalives to the SR at stipulated intervals. In the keepalives, the list of the IP addresses associated with the particular SE are also sent. Along with the list of interfaces and their corresponding IP addresses, the network interface card (NIC) utilization for each of these interfaces is also sent. If a particular interface is not active, that particular IP is not sent in the keepalive. If no streaming interfaces are configured, then no keepalives are sent to the SR.

The SR chooses an SE interface with the least NIC utilization and redirects the client request to that particular IP address. If the NIC utilization of all the interfaces are equal, then the interface for streaming is chosen at random. The NIC utilization is the maximum of the average ingress bandwidth percentage and the average egress bandwidth percentage of the interface.

The NIC utilization for each of interface is tracked and check if the threshold has been exceeded. The utilization values monitored on the service monitor are sent to the SR. The NIC sampling interval and the number of samples can be configured using the CDSM. The NIC threshold of an SE is reached only when the thresholds of all the streaming interfaces have been reached.

The current NIC status can be checked using the following command:

SE-CDE220-1# show service-router service-monitor
 
   
NIC
Interface             : PortChannel 1
Average BW In         : 0%
Average BW Out        : 0%
Threshold             : Not reached
 
   
Interface             : Standby 2
Average BW In         : 0%
Average BW Out        : 0%
Threshold             : Not reached
 
   

Configuring Port Channel

To configure an EtherChannel, you use the PortChannel interface configuration command. Port Channel, also known as EtherChannel, supports the grouping of up to eight same-speed network interfaces into one virtual interface. EtherChannel also provides interoperability with Cisco routers, switches, and other networking devices or hosts supporting EtherChannel; load balancing; and automatic failure detection and recovery based on each interface's current link status.


Note To achieve the best throughput, we recommend you configure a port channel for the eight gigabit Ethernet ports on the line card. Up to eight gigabit Ethernet interfaces can be put into the same port channel.


Redundant Dedicated Management Ports

On a CDE200 configured as an SE or SR, there are six gigabit Ethernet ports. On a CDE220-2G2 configured as an SE or SR, there are ten gigabit Ethernet ports. All the ports can be used for delivery traffic such as RTSP, as well as system management traffic to communicate with other CDS devices such as the CDSM. To prevent all the bandwidth being used by delivery traffic, a dedicated management port setup is often recommended.

In case of physical failure on a single port, channel bonding configuration of multiple gigabit Ethernet ports is also recommended for both delivery traffic and management traffic.


Note A port channel configured with a default gateway is only for delivery traffic. Delivery traffic places highest bandwidth demand on the CDS network. A port channel configured as the primary interface carries delivery traffic.



Note If an EtherChannel (also known as port channel) is used between the upstream router or switch and the SE for streaming real-time data, the EtherChannel load balance algorithms on the upstream switch or router and the SE should be configured as "src-ip" and "dst-ip" respectively. Using this configuration ensures session stickiness and general balanced load-distribution based on clients' IP addresses. Also, distribute your client IP address space across multiple subnets so that the load-balancing algorithm is effective in spreading the traffic among multiple ports.


On a CDE200, two gigabit Ethernet ports on the motherboard (GigabitEthernet 1/0 and 2/0) can be bundled for the management port channel, and four gigabit Ethernet ports (GigabitEthernet 3/0, 4/0, 5/0, and 6/0) on the network interface card (NIC) can be bundled for the traffic port channel.

On a CDE220-2G2, two gigabit Ethernet ports on the motherboard (GigabitEthernet 1/0 and 2/0) can be bundled for the management port channel, and eight gigabit Ethernet ports (GigabitEthernet 3/0 to 10/0) on the NICs can be bundled for the traffic port channel for maximum throughput. For more redundancy, you can configure two channel groups of four interfaces each (3/0 to 6/0 and 7/ 0 to 10/0) that are standbys for each other.

Configuring Redundant Management Ports

To configure redundant dedicated management ports on a CDE200 using the CLI, do the following:


Step 1 Configure two port channels with different subnets for each one.

SE(config)# interface PortChannel 1
SE(config-if)# ip address 3.1.7.73 255.255.255.0
SE(config-if)# exit 
SE(config)# interface PortChannel 2
SE(config-if)# ip address 3.1.8.200 255.255.255.0
SE(config-if)# exit
 
   

Step 2 Assign the interfaces to the two port channels. PortChannel 1 has four gigabit Ethernet interfaces for application traffic, and PortChannel 2 has two gigabit Ethernet interfaces for management traffic.

SE(config)# interface GigabitEthernet 1/0
SE(config-if)# channel-group 2
SE(config-if)# exit
SE(config)# interface GigabitEthernet 2/0
SE(config-if)# channel-group 2
SE(config-if)# exit
SE(config)# interface GigabitEthernet 3/0
SE(config-if)# channel-group 1
SE(config-if)# exit
SE(config)# interface GigabitEthernet 4/0
SE(config-if)# channel-group 1
SE(config-if)# exit
SE(config)# interface GigabitEthernet 5/0
SE(config-if)# channel-group 1
SE(config-if)# exit
SE(config)# interface GigabitEthernet 6/0
SE(config-if)# channel-group 1
SE(config-if)# exit 
 
   

Note The port channel carrying delivery traffic should always be configured as channel-group 1 and set as the primary interface.


Step 3 Configure the delivery port channel as the primary interface.

SE(config)# primary-interface PortChannel 1 
 
   

Step 4 Configure a default gateway for the delivery traffic.

SE(config)# ip default-gateway 3.1.7.1 
 
   

Step 5 Set the load balancing algorithm to the destination IP address.

SE(config)# port-channel load-balance dst-ip
 
   

Step 6 Configure a static route to the CDSM (4.0.5.5) to specify that all management traffic goes through this interface.

SE(config)# ip route 4.0.5.5 255.255.255.255 3.1.8.1
 
   

Step 7 Configure the port channel and VLANs on the switch that the SE is directly connected to.

SW3750(config)# interface Port-channel1
SW3750(config-if)# switchport access vlan 201
SW3750(config-if)# exit 
SW3750(config)# interface Port-channel2
SW3750(config-if)# switchport access vlan 202
SW3750(config-if)# exit 
SW3750(config)# interface GigabitEthernet1/0/1
SW3750(config-if)# description Connected to portchannel2
SW3750(config-if)# switchport access vlan 202
SW3750(config-if)# channel-group 2 mode on
SW3750(config-if)# exit 
SW3750(config)# interface GigabitEthernet1/0/2
SW3750(config-if)# description Connected to portchannel2
SW3750(config-if)# switchport access vlan 202
SW3750(config-if)# channel-group 2 mode on
SW3750(config-if)# exit 
SW3750(config)# interface GigabitEthernet1/0/3
SW3750(config-if)# description connected to portchannel1
SW3750(config-if)# switchport access vlan 201
SW3750(config-if)# channel-group 1 mode on
SW3750(config-if)# exit 
SW3750(config)# interface GigabitEthernet1/0/4
SW3750(config)-if# description connected to portchannel1
SW3750(config-if)# switchport access vlan 201
SW3750(config-if)# channel-group 1 mode on
SW3750(config-if)# exit 
SW3750(config)# interface GigabitEthernet1/0/5
SW3750(config-if)# description connected to portchannel1
SW3750(config-if)# switchport access vlan 201
SW3750(config-if)# channel-group 1 mode on
SW3750(config-if)# exit 
SW3750(config)# interface GigabitEthernet1/0/6
SW3750(config-if)# description connected to portchannel1
SW3750(config-if)# switchport access vlan 201
SW3750(config-if)# channel-group 1 mode on 
SW3750(config-if)# exit 
SW3750(config)# interface Vlan201
SW3750(config-if)# ip address 3.1.7.1 255.255.255.0
SW3750(config-if)# exit 
SW3750(config)# interface Vlan202
SW3750(config-if)# ip address 3.1.8.1 255.255.255.0 
SW3750(config-if)# exit 
 
   

Step 8 Set the load balancing algorithm to the source IP address.

SW3750(config)# port-channel load-balance src-ip
 
   

Note The optimal load-balance setting on the switch for traffic between the Content Acquirer and the edge Service Engine is dst-port, which is not available on the 3750, but is available on the Catalyst 6000 series.



Switch Port-Channel Configuration for Content Acquirer and Edge Service Engine

The Cisco Catalyst 6500 Series Switch supports more port-channel load-balance options than the Cisco Catalyst 3750 Series Switch. The Cisco Catalyst 6500 Series Switch allows for full utilization of all eight port- channels grouped together between the Content Acquirer and the edge SE when dst-port is selected as the port-channel load-balance option. When the Cisco Catalyst 3750 Series Switch is used, the content is fetched by way of a single gigabit Ethernet interface because there is no dst-port load-balance option.

The following configuration recommendation for the switch port-channel load-balance option, and Content Acquirer and edge SE load-balance options, fully use all eight ports when the edge SE is fetching content from the Content Acquirer because of cache-miss requests:

Content Acquirer port-channel load-balance option is set to round-robin

Edge SE port-channel load-balance option is set to dst-ip

Cisco Catalyst 6500 Series Switch instead of Cisco Catalyst 3750 Series Switch to use the dst-port option

Cisco Catalyst 6500 Series Switch port-channel load-balance option is set to dst-port

Verifying Port Channel Configuration

To verify the setup before application traffic is sent, use the following commands:

SE# clear statistics all 
SE# show interface portChannel 1
Interface PortChannel 1 (2 physical interface(s)):
GigabitEthernet 3/0 (active)
GigabitEthernet 4/0 (active)
GigabitEthernet 5/0 (active)
GigabitEthernet 6/0 (active)
---------------------
Type:Ethernet
Ethernet address:00:04:23:D8:86:02
Internet address:3.1.7.73
Broadcast address:3.1.7.255
Netmask:255.255.255.0
Maximum Transfer Unit Size:1500
Metric:1
Packets Received: 28
Input Errors: 0
Input Packets Dropped: 0
Input Packets Overruns: 0
Input Packets Frames: 0
Packet Sent: 40
Output Errors: 0
Output Packets Dropped: 0
Output Packets Overruns: 0
Output Packets Carrier: 0
Output Queue Length:0
Collisions: 0
Flags:UP BROADCAST RUNNING MASTER MULTICAST 
 
   
SE# show interface portChannel 2
Interface PortChannel 2 (4 physical interface(s)):
GigabitEthernet 1/0 (active)
GigabitEthernet 2/0 (active)
---------------------
Type:Ethernet
Ethernet address:00:30:48:33:01:26
Internet address:3.1.8.200
Broadcast address:3.1.8.255
Netmask:255.255.255.0
Maximum Transfer Unit Size:1500
Metric:1
Packets Received: 6
Input Errors: 0
Input Packets Dropped: 0
Input Packets Overruns: 0
Input Packets Frames: 0
Packet Sent: 0
Output Errors: 0
Output Packets Dropped: 0
Output Packets Overruns: 0
Output Packets Carrier: 0
Output Queue Length:0
Collisions: 0
Flags:UP BROADCAST RUNNING MASTER MULTICAST 
 
   

To verify the setup after application traffic is sent, use the following:

SE# show interface portChannel 1
Interface PortChannel 1 (4 physical interface(s)):
GigabitEthernet 3/0 (active)
GigabitEthernet 4/0 (active)
GigabitEthernet 5/0 (active)
GigabitEthernet 6/0 (active)
--------------------
Type:Ethernet
Ethernet address:00:04:23:D8:86:02
Internet address:3.1.7.73
Broadcast address:3.1.7.255
Netmask:255.255.255.0
Maximum Transfer Unit Size:1500
Metric:1
Packets Received: 1875
Input Errors: 0
Input Packets Dropped: 0
Input Packets Overruns: 0
Input Packets Frames: 0
Packet Sent: 5221
Output Errors: 0
Output Packets Dropped: 0
Output Packets Overruns: 0
Output Packets Carrier: 0
Output Queue Length:0
Collisions: 0
Flags:UP BROADCAST RUNNING MASTER MULTICAST
 
   
SE# show interface portChannel 2
Interface PortChannel 2 (2 physical interface(s)):
GigabitEthernet 1/0 (active)
GigabitEthernet 2/0 (active)
---------------------
Type:Ethernet
Ethernet address:00:30:48:33:01:26
Internet address:3.1.8.200
Broadcast address:3.1.8.255
Netmask:255.255.255.0
Maximum Transfer Unit Size:1500
Metric:1
Packets Received: 21
Input Errors: 0
Input Packets Dropped: 0
Input Packets Overruns: 0
Input Packets Frames: 0
Packet Sent: 0
Output Errors: 0
Output Packets Dropped: 0
Output Packets Overruns: 0
Output Packets Carrier: 0
Output Queue Length:0
Collisions: 0
Flags:UP BROADCAST RUNNING MASTER MULTICAST 
 
   

In the Devices Table page on the CDSM (Devices > Devices), the SE or SR status should be "Online." The IP address for the device always shows the IP address of the port channel's primary interface.

Configuring Last-Resort Routing

Last-resort routing is applicable when load-based routing is enabled and all Service Engines have exceeded their thresholds or all Service Engines in the domain are offline. The Service Router can redirect requests to a configurable alternate domain when all Service Engines serving a client network region are overloaded.


Note If the last-resort domain is not configured and the Service Engine thresholds are exceeded, requests are redirected to the origin server.


To configure last-resort routing, use the service-router lastresort domain domain alternate alternate global configuration command, where domain is the service routing domain name, and alternate is where to route requests.

service-router lastresort domain domain alternate alternate
 
   

In the example below, srfqdn.cisco.com is the service routing domain name, and www.cisco.com is the alternate domain name.

SR(config)# service-router ?
lastresort Configure lastresort domain
leastloaded Enable Load Based Routing
location-based-routing Configure location based routing
SR(config)# service-router lastresort ?
domain Configure domain
SR(config)# service-router lastresort domain srfqdn.cisco.com ?
alternate Configure alternate domain
SR(config)# service-router lastresort domain srfqdn.cisco.com alternate ?
WORD Configure alternate domain name
SR(config)# service-router lastresort domain srfqdn.cisco.com alternate www.cisco.com ?
<cr> 
SE(config)# service-router lastresort domain srfqdn.cisco.com alternate www.cisco.com
 
   

For information on configuring an error domain in which to redirect clients to that are not part of the coverage zone, see the "Configuring Last-Resort Routing" section or see the service-router command in Cisco Internet Streamer CDS 2.5 Command Reference.

Configuring Standby Interfaces

You can configure one ore more interfaces to act as a backup interface (a standby interface) for another interface on a Service Engine. This feature is called standby interface support. Standby groups, which are logical groups of interfaces, are used to implement this feature. When an active network interface fails (because of cable trouble, Layer 2 switch failure, high error count, or other failures) and that interface is part of a standby group, a standby interface can become active and take the load off the failed interface.

A standby group must have at least two interfaces. Interfaces that are part of a standby group are called member interfaces. After you create a standby group, you define which interfaces should be assigned to this logical group. As part of defining the member interfaces, you specify the priority of each member interface in a standby group. The member interface with the highest assigned priority is the active interface for that particular standby group. If the active interface fails, the operational member interface with the next highest priority in the standby group comes up, and so forth. If all member interfaces of a particular standby group are down and then one of the member interfaces comes up, the CDS software detects this situation and brings up the standby group on the member interface that just came up.

The failure or failover of member interfaces within a standby group triggers alarms and traps (if alarms and traps are enabled on the Service Engine). Alarms are sent out when failover occurs between member interfaces in a standby group. Specifically, minor alarms are sent out when member interfaces fail, and these alarms are cleared automatically when the interface failover has been successfully completed. Major alarms are sent out if the standby group goes down (no member interface in a standby group can be brought up).


Note A physical interface can belong to more than one standby group, and a single interface can act as a standby interface for more than one standby group.


To configure standby interfaces, interfaces are logically assigned to standby groups. The following rules define the standby group relationships:

Each standby group is assigned a unique standby IP address, shared by all member interfaces of the standby group. The IP address of the standby group is shared among the member interfaces; however, only the active interface of the standby group uses this shared IP address at any one time. This shared IP address is configured as an alias on the active interface.

Duplex and speed settings of the member interfaces can be configured for better reliability.

If a physical interface is a member of a port-channel group, it cannot join a standby group. If a physical interface is a member of a standby group, it cannot join a port-channel group.

Maximum number of standby groups on a Service Engine is four.


Note Interface IP addresses and standby group IP addresses must be on different subnets to ensure reliable operation. You can use dummy IP addresses in the private address space to serve as interface primary IP addresses, and use the real Service Engine IP address to serve as the standby group IP address in a different subnet to satisfy this requirement. When dummy IP addresses are used, these interface IP addresses serve only as substitutes to bring up the interface. For example, the Service Engine interface requires an IP address on an interface for initialization. Make sure to configure the interface default gateway using the ip default-gateway global configuration command instead of the ip route command.


Each interface in a standby group is assigned a priority. The operational interface with the highest priority in a standby group is the active interface. Only the active interface uses the group IP address.

Priority of an interface in a standby group can be changed at run time. The member interface that has the highest priority after this change becomes the new active interface (the default action is to preempt the currently active interface if an interface with higher priority exists).

Maximum number of errors allowed on the active interface before the interface is shut down and the standby is brought up is configured with the errors option, which is disabled by default.


Tip If an interface belongs to more than one standby group, you can configure the interface with a different priority in each standby group for better load balancing. For example, interfaces gigabit Ethernet 0/0 and gigabit Ethernet 0/1 are both in Standby Group 1 and in Standby Group 2. If you configure gigabit Ethernet 0/0 with the highest priority in Standby Group 1 and configure gigabit Ethernet 0/1 with the highest priority in Standby Group 2, Standby Group 1 uses gigabit Ethernet 0/0 as the active interface, while Standby Group 2 uses gigabit Ethernet 0/1 as the active interface. This configuration allows each interface to back up the other one, if one of them fails.


Use the interface standby global configuration command to create standby groups on Service Engines.


Note Unlike port channels, standby groups do not support IP ACLs at a group level. However, you can configure a member interface of a standby group to support an IP ACL at the interface level. For example, you can individually configure the two member interfaces of Standby Group 1 (the gigabit Ethernet 0/0 interface and the gigabit Ethernet 0/1 interface) to support an IP ACL named ACL1 but you cannot configure the Standby Group 1 to support ACL1.


To configure an interface to be a backup for another interface, use the standby interface configuration command. To restore the default configuration of the interface, use the no form of this command.

standby group_number {description text | errors max-errors | ip ip-address netmask | priority piority_level | shutdown}

no standby group_number {description text | errors max-errors | ip ip-address netmask | priority priority_level | shutdown}

Syntax Description

group_number

Standby group number (1-4).

description

(Optional) Sets the description for the specified interface.

text

Description for the specified interface. The maximum length of the description text is 240 characters.

errors

Sets the maximum number of errors allowed on the active interface before the interface is shut down and the standby interface is brought up. This option is disabled by default.

max-errors

Maximum number of errors (1-2147483647).

ip

Sets the IP address for the specified standby group (Standby Group 1, 2, 3, or 4).

ip-address

IP address of the specified standby group (Standby Group 1, 2, 3, or 4). The group IP address and netmask of a standby group must be configured on all the member interfaces.

netmask

Netmask of the specified standby group (Standby Group 1, 2, 3, or 4).

priority

Sets the priority of the member interface within a standby group. The priority of a member interface can be changed at run time. The member interface that has the highest priority after this change becomes the new active interface (the default action is to preempt the currently active interface if an interface with higher priority exists).

priority_level

Each member interface is assigned a priority number. The member interface with the highest priority number is the active interface for that standby group. Only the active interface uses the group IP address.

If the priority option is specified without a priority number, the default value of 100 is used.

shutdown

(Optional) Shuts down the specified standby group (Standby Group 1, 2, 3, or 4). You can shut down a standby group even if you have not configured a group IP address of the standby group.

Note When a standby group is shut down, all the alarms previously raised by this standby group are cleared.


Examples

The following example configures three gigabit Ethernet interfaces to be part of the same standby group, with interface 1/0 as the active interface:

Console(config-if)# interface GigabitEthernet 1/0 standby 2 priority 300
Console(config-if)# interface GigabitEthernet 2/0 standby 2 priority 200
Console(config-if)# interface GigabitEthernet 3/0 standby 2 priority 100
Console(config-if)# interface standby 2 errors 1000
 
   

The following example displays information about the standby group configuration by entering the show standby EXEC command. In the following sample command output, one standby group (Standby Group 1) is configured on this Service Engine. The command output also shows which member interface is the active interface. In this case, the active interface is the gigabit Ethernet slot 3/port 0 interface.

ServiceEngine# show standby
Standby Group:1
IP address: 172.16.10.10, netmask: 255.255.254.0
Maximum errors allowed on the active interface: 10000
		Member interfaces:
				GigabitEthernet 3/0 priority: 300
				GigabitEthernet 3/1 priority: 200
				GigabitEthernet 3/2 priority: 100
 
   
		Active interface: GigabitEthernet 3/0
 
   

Note To display information about a specific standby group configuration, enter the show interface standby group_number EXEC command.


The following example creates a standby group, Standby Group 1:

ServiceEngine# configure
ServiceEngine(config)# interface standby 1
ServiceEngine(config-if)#
 
   

The following example assigns a group IP address of 10.10.10.10 and a netmask of 255.0.0.0 to Standby Group 1:

ServiceEngine(config-if)# ip address 10.10.10.10 255.0.0.0
ServiceEngine(config-if)# errors 500
 
   

The following example shows how to add two gigabit Ethernet interfaces to Standby Group 1 and then assign each of these member interfaces a priority within the group:

1. Add a gigabit Ethernet interface 0/0 to Standby Group 1 and assign a priority of 150.

ServiceEngine(config)# interface GigabitEthernet 0/0
ServiceEngine(config-if)# standby 1 priority 150
 
   

2. Add a second gigabit Ethernet interface 0/1 to Standby Group 1 with the default priority value of 100.

ServiceEngine(config)# interface GigabitEthernet 0/1
ServiceEngine(config-if)# standby 1
ServiceEngine(config-if)# exit
ServiceEngine(config)#
 
   

Because gigabit Ethernet 0/0 is assigned the highest priority (a priority number of 150) of all the member interfaces in the group, it is chosen as the active interface for the group if it can be brought up.

The following example removes the gigabit Ethernet 0/1 interface from Standby Group 1 using the no form of the standby command:

ServiceEngine(config)# interface FastEthernet 0/1
ServiceEngine(config-if)# no standby 1
ServiceEngine(config-if)# exit
ServiceEngine(config)#
 
   

The following example shows how to shut down Standby Group 1. When a standby group is shut down, all the alarms previously raised by this standby group are cleared.

ServiceEngine(config)# interface standby 1
ServiceEngine(config-if)# shutdown
ServiceEngine(config)# exit
 
   

The following example shows how to tear down Standby Group 1:

ServiceEngine(config)# interface standby 1
ServiceEngine(config-if)# no ip address 10.10.10.10 255.0.0.0
Please remove member interface(s) from this standby group first.
ServiceEngine(config)# interface GigabitEthernet 2/0
ServiceEngine(config-if)# no standby 1
ServiceEngine(config-if)# exit
ServiceEngine(config)# interface standby 1
ServiceEngine(config-if)# no ip address 10.10.10.10 255.0.0.0
ServiceEngine(config-if)# exit
ServiceEngine(config)# no interface standby 1
ServiceEngine(config)# exit
 
   

Standby Interface with Switch Failover Configuration Procedure

This procedure describes how to configure a standby interface for two port channels and a standby interface for two management interfaces on a device with a total of six interfaces.

To configure a standby interface with two port channels, do the following:


Step 1 Configure gigabit Ethernet 1/0 and gigabit Ethernet 2/0 as management interfaces and create one standby interface for redundancy.

SE(config)# interface GigabitEthernet 1/0
SE(config-if)# standby 2 priority 200
SE(config-if)# exit
SE(config)# interface GigabitEthernet 2/0
SE(config-if)# standby 2
SE(config-if)# exit
SE(config-if)# interface Standby 2 
SE(config-if)# description for management 
SE(config-if)# ip address 4.0.7.127 255.255.255.0
SE(config-if)# exit
 
   

Step 2 Add gigabit Ethernet 3/0 and gigabit Ethernet 4/0 to port channel 1, add gigabit Ethernet 5/0 and gigabit Ethernet 6/0 to port channel 2, and create a standby interface for these two port channels for redundancy.

SE(config)# interface GigabitEthernet 3/0
SE(config-if)# channel-group 1
SE(config-if)# exit
SE(config)# interface GigabitEthernet 4/0
SE(config-if)# channel-group 1
SE(config-if)# exit
SE(config)# interface GigabitEthernet 5/0
SE(config-if)# channel-group 2
SE(config-if)# exit
SE(config)# interface GigabitEthernet 6/0
SE(config-if)# channel-group 2
SE(config-if)# exit
SE(config)# interface PortChannel 1
SE(config-if)# standby 1 priority 120
SE(config-if)# exit
SE(config)# interface PortChannel 2
SE(config-if)# standby 1 priority 200
SE(config-if)# exit
SE(config)# interface Standby 1
SE(config-if)# description for traffic
SE(config-if)# ip address 7.35.0.7 255.255.0.0
SE(config-if)# exit
SE(config)# primary-interface Standby 1
 
   

Note Port channel 1 is bundled to switch 1 and port channel 2 is bundled to switch 2.



Other CLI Commands

This section lists other CLI commands that may be useful.

CDNFS cleanup Command

To manage the CDS network file system (cdnfs), use the cdnfs EXEC command.

cdnfs {browse | cleanup {info | start | stop} | delete-unused-ecdnfs-files}

There are no default behavior or values.

Syntax Description

browse

Browses the cdnfs directories and files.

cleanup

Cleans up the unwanted entries in the cdnfs.

info

Summarizes the information about unwanted entries without starting the cleanup process.

start

Starts the cleanup of unwanted entries in the cdnfs.

stop

Stops the cleanup of unwanted entries in the cdnfs.


The CDNFS cleanup command is an EXEC command.

The CDS network file systems (cdnfs) stores the prefetched CDS network content by all supported protocols. The cdnfs cleanup command cleans up the content of deleted channels from the acquisition distribution database. In certain cases, the Content Acquirer is not notified by the Centralized System (CMS) about deleted delivery services, and it fails to clear all unified name space (UNS) cases, the cdnfs cleanup EXEC command can be used to clean up all UNS content associated with deleted delivery services.


Note You can use cdnfs cleanup start to clean up the orphan content. Orphan content is content that is not associated with any delivery service to which a Service Engine is subscribed.


The cdnfs browse command is an interactive command and has the following interactive commands used to view the CDS network files and directories:

SE# cdnfs browse
------ CDNFS interactive browsing ------
dir, ls: list directory contents
cd,chdir: change current working directory
info: display attributes of a file
more: page through a file
cat: display a file
exit,quit: quit CDNFS browse shell
 
   

The cdnfs cleanup command synchronizes the state of the acquisition and distribution database with the content stored on the cdnfs. You should use this command after replacing a failed disk drive.

cache content Command

To set the number of cache entries in the CDS network file system (cdnfs), use the cache content global configuration command.

cache content max-cached-entries 1-10000000

Syntax Description

content

Browses the cdnfs directories and files.

max-cached-entries

Cleans up the unwanted entries in the cdnfs.

1-10000000

Summarizes the information about unwanted entries without starting the cleanup process.


Maximum cache entries is set to 3000000 by default.

The CDS, by default, allows a maximum of three million cached entries, regardless of the amount of space available in CDNFS. Use this command to restrict the maximum number of contents in the CDS.

Previously, the Internet Streamer CDS software did not restrict adding new content to CDS network file system (CDNFS) as long as there was enough disk space for the asset. The cache content max-cached command restricted the number of assets, but it was not a hard limit. New content was always added and the CDS would delete old content in attempt to keep within the limits configured. The CDS could actually have more content than the configured limit, because the process to delete content is slower than the process to add content. The same situation applies to disk-usage based deletion, where deletion occurs when 90 percent of the CDNFS is used.

In Release 2.5.9-b117, content addition is stopped at 105 percent of the maximum object count or 95 percent of the CDNFS capacity (disk usage). For example, if the maximum number of objects has been configured as 3,000,000 (which is the default value), the CDS starts deleting content if the object count reaches 3,000,000, but adding content is still allowed. Adding content stops when the maximum number of content objects reaches 3,150,000 (105 percent of 3,000,000), which allows time for the content deletion process to reduce the number of objects in the CDS to the configured limit. Adding content resumes only after the number of objects is 3,000,000 or less. The same logic applies to disk usage. The deletion process starts when disk usage reaches 90 percent, adding content stops when disk usage reaches 95 percent, and adding content resumes only after the disk usage percentage reaches 90 percent or less.

If adding content has been stopped because either the content count reached 105 percent of the limit or the disk usage reached 95 percent of capacity, a UCACHE BUSY error message is sent to the Web Engine, Windows Media Streaming, or Movie Streamer, and the protocol engine performs a cut-through or a bypass.

The show cdnfs usage command shows the current status of whether the content is able to be cached or not. Following is an example of the output:

# show cdnfs usage 
Total number of CDNFS entries  :    2522634
Total space                    :     4656.3 GB
Total bytes available          :     4626.0 GB
Total cache size               :        2.4 GB
Total cached entries           :    2522634   
Cache-content mgr status       : Cachable
Units: 1KB = 1024B; 1MB = 1024KB; 1GB = 1024MB
 
   

If the maximum object count is reached, the following is displayed:

Cache-content mgr status       : caching paused[ max count 105% of configured reached ]
 
   

If the disk usage reaches more than 95 percent, the following is displayed:

Cache-content mgr status       : caching paused[ disk max 95% of disk usage reached ]
 
   

Note When the CDS is just started or the ucache process (which is cache content manager) is just restarted, it performs a scan of the entire CDNFS. During this period, the deletion starts at 94 percent (not 90 percent) and adding content stops at 95 percent.


Service Router Redirect Burst Control Command

The SR can handle higher transactions per second (TPS) than the SE. The SR learns about the SEs system resources and protocol engine states through the SE keepalive, which occurs every two seconds. If a burst of client requests come into the SR between two SE keepalives, the SR may not know about the SE state and it could route the request to an already overloaded SE.

With request routing burst control, you can configure how many requests the SR redirects to the SEs during a burst in requests. that is, what TPS the SEs can handle successfully. This augments the SE keepalive.

If two SEs are associated with a delivery service and one of the SEs burst rate is reached, the SR redirects the requests to the other SE. All routing methods continue to work with burst control. Burst control is similar to the SE thresholds for memory, CPU, and so on.

service-router redirect-burst-control {enable | rate 1-100000 }

Syntax Description

enable

Enables the burst control feature. The redirect burst control is disabled by default.

rate

Set the TPS for the SEs. This is the TPS per SE.

1-100000

TPS for each SE. The default is 100,000.