Software Configuration Guide, Cisco IOS Release 15.2(2)E (Catalyst 2960, 2960-S, 2960-SF and 2960-Plus Switches)
Configuring Network Security with ACLs
Downloads: This chapterpdf (PDF - 1.76MB) The complete bookPDF (PDF - 16.3MB) | The complete bookePub (ePub - 3.49MB) | Feedback

Configuring Network Security with ACLs

Contents

Configuring Network Security with ACLs

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to http:/​/​www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Restrictions for Configuring Network Security with ACLs

General Network Security

The following are restrictions for configuring network security with ACLs:

  • Not all commands that accept a numbered ACL accept a named ACL. ACLs for packet filters and route filters on interfaces can use a name. VLAN maps also accept a name.

  • A standard ACL and an extended ACL cannot have the same name.

  • Though visible in the command-line help strings, appletalk is not supported as a matching condition for the deny and permit MAC access-list configuration mode commands.

IPv4 ACL Network Interfaces

The following restrictions apply to IPv4 ACLs to network interfaces:

  • Apply an ACL only to inbound Layer 2 interfaces. Apply an ACL to either outbound or inbound Layer 3 interfaces.

  • When controlling access to an interface, you can use a named or numbered ACL.

  • If you apply an ACL to a port that is a member of a VLAN, the port ACL takes precedence over an ACL applied to the VLAN interface.

  • If you apply an ACL to a Layer 2 interface that is a member of a VLAN, the Layer 2 (port) ACL takes precedence over an input Layer 3 ACL applied to the VLAN interface or a VLAN map applied to the VLAN.

  • If you apply an ACL to a Layer 3 interface and routing is not enabled on the switch, the ACL only filters packets that are intended for the CPU, such as SNMP, Telnet, or web traffic.

  • You do not have to enable routing to apply ACLs to Layer 2 interfaces.

  • When you configure an egress ACL to permit traffic with a particular DSCP value, you must use the original DSCP value instead of a rewritten value.


Note


By default, the router sends Internet Control Message Protocol (ICMP) unreachable messages when a packet is denied by an access group on a Layer 3 interface. These access-group denied packets are not dropped in hardware but are bridged to the switch CPU so that it can generate the ICMP-unreachable message. They do not generate ICMP unreachable messages. 

ICMP unreachable messages can be disabled on router ACLs with the no ip unreachables interface command.


MAC ACLs on a Layer 2 Interface

After you create a MAC ACL, you can apply it to a Layer 2 interface to filter non-IP traffic coming in that interface. When you apply the MAC ACL, consider these guidelines:

  • You can apply no more than one IP access list and one MAC access list to the same Layer 2 interface. The IP access list filters only IP packets, and the MAC access list filters non-IP packets.

  • A Layer 2 interface can have only one MAC access list. If you apply a MAC access list to a Layer 2 interface that has a MAC ACL configured, the new ACL replaces the previously configured one.


Note


The mac access-group interface configuration command is only valid when applied to a physical Layer 2 interface. You cannot use the command on EtherChannel port channels.


Information about Network Security with ACLs

ACL Overview

Packet filtering can help limit network traffic and restrict network use by certain users or devices. ACLs filter traffic as it passes through a router or switch and permit or deny packets crossing specified interfaces. An ACL is a sequential collection of permit and deny conditions that apply to packets. When a packet is received on an interface, the switch compares the fields in the packet against any applied ACLs to verify that the packet has the required permissions to be forwarded, based on the criteria specified in the access lists. One by one, it tests packets against the conditions in an access list. The first match decides whether the switch accepts or rejects the packets. Because the switch stops testing after the first match, the order of conditions in the list is critical. If no conditions match, the switch rejects the packet. If there are no restrictions, the switch forwards the packet; otherwise, the switch drops the packet. The switch can use ACLs on all packets it forwards.

You configure access lists on a router or Layer 3 switch to provide basic security for your network. If you do not configure ACLs, all packets passing through the switch could be allowed onto all parts of the network. You can use ACLs to control which hosts can access different parts of a network or to decide which types of traffic are forwarded or blocked at router interfaces. For example, you can allow e-mail traffic to be forwarded but not Telnet traffic.

Access Control Entries

An ACL contains an ordered list of access control entries (ACEs). Each ACE specifies permit or deny and a set of conditions the packet must satisfy in order to match the ACE. The meaning of permit or deny depends on the context in which the ACL is used.

ACL Supported Types

The switch supports IP ACLs and Ethernet (MAC) ACLs:

  • IP ACLs filter IPv4 traffic, including TCP, User Datagram Protocol (UDP), Internet Group Management Protocol (IGMP), and Internet Control Message Protocol (ICMP).

  • Ethernet ACLs filter non-IP traffic.

This switch also supports quality of service (QoS) classification ACLs.

Supported ACLs

The switch supports three types of ACLs to filter traffic:

  • Port ACLs access-control traffic entering a Layer 2 interface. You can apply only one IP access list and one MAC access list to a Layer 2 interface.

  • Router ACLs access-control routed traffic between VLANs and are applied to Layer 3 interfaces in a specific direction (inbound or outbound).

ACL Precedence

When Port ACLs, and router ACLs are configured on the same switch, the filtering precedence, from greatest to least, is port ACL, router ACL. The following examples describe simple use cases:

  • When an input router ACL and input port ACL exist in a switch virtual interface (SVI), incoming packets received on ports to which a port ACL is applied are filtered by the port ACL. Incoming routed IP packets received on other ports are filtered by the router ACL. Other packets are not filtered.

  • When an output router ACL and input port ACL exist in an SVI, incoming packets received on the ports to which a port ACL is applied are filtered by the port ACL. Outgoing routed IP packets are filtered by the router ACL. Other packets are not filtered.

Port ACLs

Port ACLs are ACLs that are applied to Layer 2 interfaces on a switch. Port ACLs are supported only on physical interfaces and not on EtherChannel interfaces. Port ACLs can be applied only on inbound interfaces. The following access lists are supported:

  • Standard IP access lists using source addresses

  • Extended IP access lists using source and destination addresses and optional protocol type information

  • MAC extended access lists using source and destination MAC addresses and optional protocol type information

The switch examines ACLs on an interface and permits or denies packet forwarding based on how the packet matches the entries in the ACL. In this way, ACLs control access to a network or to part of a network.

Figure 1. Using ACLs to Control Traffic in a Network. This is an example of using port ACLs to control access to a network when all workstations are in the same VLAN. ACLs applied at the Layer 2 input would allow Host A to access the Human Resources network, but prevent Host B from accessing the same network. Port ACLs can only be applied to Layer 2 interfaces in the inbound direction.

When you apply a port ACL to a trunk port, the ACL filters traffic on all VLANs present on the trunk port. When you apply a port ACL to a port with voice VLAN, the ACL filters traffic on both data and voice VLANs.

With port ACLs, you can filter IP traffic by using IP access lists and non-IP traffic by using MAC addresses. You can filter both IP and non-IP traffic on the same Layer 2 interface by applying both an IP access list and a MAC access list to the interface.


Note


You cannot apply more than one IP access list and one MAC access list to a Layer 2 interface. If an IP access list or MAC access list is already configured on a Layer 2 interface and you apply a new IP access list or MAC access list to the interface, the new ACL replaces the previously configured one.


Router ACLs

You can apply router ACLs on switch virtual interfaces (SVIs), which are Layer 3 interfaces to VLANs; on physical Layer 3 interfaces; and on Layer 3 EtherChannel interfaces. You apply router ACLs on interfaces for specific directions (inbound or outbound). You can apply one router ACL in each direction on an interface.

An ACL can be used with multiple features for a given interface, and one feature can use multiple ACLs. When a single router ACL is used by multiple features, it is examined multiple times.

The switch supports these access lists for IPv4 traffic:

  • Standard IP access lists use source addresses for matching operations.

  • Extended IP access lists use source and destination addresses and optional protocol type information for matching operations.

As with port ACLs, the switch examines ACLs associated with features configured on a given interface. However, you can apply only inbound port ACLs, while router ACLs are supported in both directions. As packets enter the switch on an interface, ACLs associated with all inbound features configured on that interface are examined. After packets are routed and before they are forwarded to the next hop, all ACLs associated with outbound features configured on the egress interface are examined.

ACLs permit or deny packet forwarding based on how the packet matches the entries in the ACL, and can be used to control access to a network or to part of a network.

ACEs and Fragmented and Unfragmented Traffic

IP packets can be fragmented as they cross the network. When this happens, only the fragment containing the beginning of the packet contains the Layer 4 information, such as TCP or UDP port numbers, ICMP type and code, and so on. All other fragments are missing this information.

Some access control entries (ACEs) do not check Layer 4 information and therefore can be applied to all packet fragments. ACEs that do test Layer 4 information cannot be applied in the standard manner to most of the fragments in a fragmented IP packet. When the fragment contains no Layer 4 information and the ACE tests some Layer 4 information, the matching rules are modified:

  • Permit ACEs that check the Layer 3 information in the fragment (including protocol type, such as TCP, UDP, and so on) are considered to match the fragment regardless of what the missing Layer 4 information might have been.

  • Deny ACEs that check Layer 4 information never match a fragment unless the fragment contains Layer 4 information.

Example: ACEs and Fragmented and Unfragmented Traffic

Consider access list 102, configured with these commands, applied to three fragmented packets:


Switch(config)# access-list 102 permit tcp any host 10.1.1.1 eq smtp
Switch(config)# access-list 102 deny tcp any host 10.1.1.2 eq telnet
Switch(config)# access-list 102 permit tcp any host 10.1.1.2
Switch(config)# access-list 102 deny tcp any any


Note


In the first and second ACEs in the examples, the eq keyword after the destination address means to test for the TCP-destination-port well-known numbers equaling Simple Mail Transfer Protocol (SMTP) and Telnet, respectively.


  • Packet A is a TCP packet from host 10.2.2.2., port 65000, going to host 10.1.1.1 on the SMTP port. If this packet is fragmented, the first fragment matches the first ACE (a permit) as if it were a complete packet because all Layer 4 information is present. The remaining fragments also match the first ACE, even though they do not contain the SMTP port information, because the first ACE only checks Layer 3 information when applied to fragments. The information in this example is that the packet is TCP and that the destination is 10.1.1.1.

  • Packet B is from host 10.2.2.2, port 65001, going to host 10.1.1.2 on the Telnet port. If this packet is fragmented, the first fragment matches the second ACE (a deny) because all Layer 3 and Layer 4 information is present. The remaining fragments in the packet do not match the second ACE because they are missing Layer 4 information. Instead, they match the third ACE (a permit).

    Because the first fragment was denied, host 10.1.1.2 cannot reassemble a complete packet, so packet B is effectively denied. However, the later fragments that are permitted will consume bandwidth on the network and resources of host 10.1.1.2 as it tries to reassemble the packet.

  • Fragmented packet C is from host 10.2.2.2, port 65001, going to host 10.1.1.3, port ftp. If this packet is fragmented, the first fragment matches the fourth ACE (a deny). All other fragments also match the fourth ACE because that ACE does not check any Layer 4 information and because Layer 3 information in all fragments shows that they are being sent to host 10.1.1.3, and the earlier permit ACEs were checking different hosts.

Standard and Extended IPv4 ACLs

This section describes IP ACLs.

An ACL is a sequential collection of permit and deny conditions. One by one, the switch tests packets against the conditions in an access list. The first match determines whether the switch accepts or rejects the packet. Because the switch stops testing after the first match, the order of the conditions is critical. If no conditions match, the switch denies the packet.

The software supports these types of ACLs or access lists for IPv4:

  • Standard IP access lists use source addresses for matching operations.

  • Extended IP access lists use source and destination addresses for matching operations and optional protocol-type information for finer granularity of control.

IPv4 ACL Switch Unsupported Features

Configuring IPv4 ACLs on the switch is the same as configuring IPv4 ACLs on other Cisco switches and routers.

The switch does not support these Cisco IOS router ACL-related features:

  • Non-IP protocol ACLs or bridge-group ACLs

  • IP accounting

  • Inbound and outbound rate limiting (except with QoS ACLs)
  • Reflexive ACLs and dynamic ACLs are not supported. (except for some specialized dynamic ACLs used by the switch clustering feature)

Access List Numbers

The number you use to denote your ACL shows the type of access list that you are creating.

This lists the access-list number and corresponding access list type and shows whether or not they are supported in the switch. The switch supports IPv4 standard and extended access lists, numbers 1 to 199 and 1300 to 2699.

Table 1 Access List Numbers

Access List Number

Type

Supported

1–99

IP standard access list

Yes

100–199

IP extended access list

Yes

200–299

Protocol type-code access list

No

300–399

DECnet access list

No

400–499

XNS standard access list

No

500–599

XNS extended access list

No

600–699

AppleTalk access list

No

700–799

48-bit MAC address access list

No

800–899

IPX standard access list

No

900–999

IPX extended access list

No

1000–1099

IPX SAP access list

No

1100–1199

Extended 48-bit MAC address access list

No

1200–1299

IPX summary address access list

No

1300–1999

IP standard access list (expanded range)

Yes

2000–2699

IP extended access list (expanded range)

Yes

In addition to numbered standard and extended ACLs, you can also create standard and extended named IP ACLs by using the supported numbers. That is, the name of a standard IP ACL can be 1 to 99; the name of an extended IP ACL can be 100 to 199. The advantage of using named ACLs instead of numbered lists is that you can delete individual entries from a named list.

Numbered Standard IPv4 ACLs

When creating an ACL, remember that, by default, the end of the ACL contains an implicit deny statement for all packets that it did not find a match for before reaching the end. With standard access lists, if you omit the mask from an associated IP host address ACL specification, 0.0.0.0 is assumed to be the mask.

The switch always rewrites the order of standard access lists so that entries with host matches and entries with matches having a don’t care mask of 0.0.0.0 are moved to the top of the list, above any entries with non-zero don’t care masks. Therefore, in show command output and in the configuration file, the ACEs do not necessarily appear in the order in which they were entered.

After creating a numbered standard IPv4 ACL, you can apply it to , to terminal lines, or to interfaces.

Numbered Extended IPv4 ACLs

Although standard ACLs use only source addresses for matching, you can use extended ACL source and destination addresses for matching operations and optional protocol type information for finer granularity of control. When you are creating ACEs in numbered extended access lists, remember that after you create the ACL, any additions are placed at the end of the list. You cannot reorder the list or selectively add or remove ACEs from a numbered list.

The switch does not support dynamic or reflexive access lists. It also does not support filtering based on the type of service (ToS) minimize-monetary-cost bit.

Some protocols also have specific parameters and keywords that apply to that protocol.

You can define an extended TCP, UDP, ICMP, IGMP, or other IP ACL. The switch also supports these IP protocols:

These IP protocols are supported:

  • Authentication Header Protocol (ahp)

  • Encapsulation Security Payload (esp)

  • Enhanced Interior Gateway Routing Protocol (eigrp)

  • generic routing encapsulation (gre)

  • Internet Control Message Protocol (icmp)

  • Internet Group Management Protocol (igmp)

  • any Interior Protocol (ip)

  • IP in IP tunneling (ipinip)

  • KA9Q NOS-compatible IP over IP tunneling (nos)

  • Open Shortest Path First routing (ospf)

  • Payload Compression Protocol (pcp)

  • Protocol-Independent Multicast (pim)

  • Transmission Control Protocol (tcp)

  • User Datagram Protocol (udp)

Resequencing ACEs in an ACL

Sequence numbers for the entries in an access list are automatically generated when you create a new ACL. You can use the ip access-list resequence global configuration command to edit the sequence numbers in an ACL and change the order in which ACEs are applied. For example, if you add a new ACE to an ACL, it is placed at the bottom of the list. By changing the sequence number, you can move the ACE to a different position in the ACL.

Named IPv4 ACLs

You can identify IPv4 ACLs with an alphanumeric string (a name) rather than a number. You can use named ACLs to configure more IPv4 access lists in a router than if you were to use numbered access lists. If you identify your access list with a name rather than a number, the mode and command syntax are slightly different. However, not all commands that use IP access lists accept a named access list.


Note


The name you give to a standard or extended ACL can also be a number in the supported range of access list numbers. That is, the name of a standard IP ACL can be 1 to 99 and . The advantage of using named ACLs instead of numbered lists is that you can delete individual entries from a named list.


Consider these guidelines before configuring named ACLs:

  • Numbered ACLs are also available.

  • A standard ACL and an extended ACL cannot have the same name.

Related References

Hardware and Software Treatment of IP ACLs

ACL processing is performed in hardware. If the hardware reaches its capacity to store ACL configurations, all packets on that interface are dropped.


Note


If an ACL configuration cannot be implemented in hardware due to an out-of-resource condition on a switch or stack member, then only the traffic in that VLAN arriving on that switch is affected. Software forwarding of packets might adversely impact the performance of the switch or switch stack, depending on the number of CPU cycles that this consumes.


When you enter the show ip access-lists privileged EXEC command, the match count displayed does not account for packets that are access controlled in hardware. Use the show access-lists hardware counters privileged EXEC command to obtain some basic hardware ACL statistics for switched and routed packets.

Time Ranges for ACLs

You can selectively apply extended ACLs based on the time of day and the week by using the time-range global configuration command. First, define a time-range name and set the times and the dates or the days of the week in the time range. Then enter the time-range name when applying an ACL to set restrictions to the access list. You can use the time range to define when the permit or deny statements in the ACL are in effect, for example, during a specified time period or on specified days of the week. The time-range keyword and argument are referenced in the named and numbered extended ACL task tables.

Time-based access lists trigger CPU activity because the new configuration of the access list must be merged with other features and the combined configuration loaded into the hardware memory. For this reason, you should be careful not to have several access lists configured to take affect in close succession (within a small number of minutes of each other.)


Note


The time range relies on the switch system clock; therefore, you need a reliable clock source. We recommend that you use Network Time Protocol (NTP) to synchronize the switch clock.


Including comments in ACLs

You can use the remark keyword to include comments (remarks) about entries in any IP standard or extended ACL. The remarks make the ACL easier for you to understand and scan. Each remark line is limited to 100 characters.

The remark can go before or after a permit or deny statement. You should be consistent about where you put the remark so that it is clear which remark describes which permit or deny statement. For example, it would be confusing to have some remarks before the associated permit or deny statements and some remarks after the associated statements.

To include a comment for IP numbered standard or extended ACLs, use the access-list access-list number remark remark global configuration command. To remove the remark, use the no form of this command.

IPv4 ACL Interface Considerations

For inbound ACLs, after receiving a packet, the switch checks the packet against the ACL. If the ACL permits the packet, the switch continues to process the packet. If the ACL rejects the packet, the switch discards the packet.

For outbound ACLs, after receiving and routing a packet to a controlled interface, the switch checks the packet against the ACL. If the ACL permits the packet, the switch sends the packet. If the ACL rejects the packet, the switch discards the packet.

When you apply an undefined ACL to an interface, the switch acts as if the ACL has not been applied to the interface and permits all packets. Remember this behavior if you use undefined ACLs for network security.

How to Configure ACLs

Configuring IPv4 ACLs

These are the steps to use IP ACLs on the switch:

SUMMARY STEPS

    1.    Create an ACL by specifying an access list number or name and the access conditions.

    2.    Apply the ACL to interfaces or terminal lines. You can also apply standard and extended IP ACLs to VLAN maps.


DETAILED STEPS
     Command or ActionPurpose
    Step 1Create an ACL by specifying an access list number or name and the access conditions.   
    Step 2Apply the ACL to interfaces or terminal lines. You can also apply standard and extended IP ACLs to VLAN maps.   

    Creating a Numbered Standard ACL

    Follow these steps to create a numbered standard ACL:

    SUMMARY STEPS

      1.    enable

      2.    configure terminal

      3.    access-list access-list-number {deny | permit} source source-wildcard ]

      4.    end

      5.    show running-config

      6.    copy running-config startup-config


    DETAILED STEPS
       Command or ActionPurpose
      Step 1enable


      Example:
      Switch> enable
      
      
       

      Enables privileged EXEC mode. Enter your password if prompted.

       
      Step 2configure terminal


      Example:
      
      Switch# configure terminal
      
      
       

      Enters the global configuration mode.

       
      Step 3access-list access-list-number {deny | permit} source source-wildcard ]


      Example:
      Switch(config)# access-list 2 deny your_host
      
      
       

      Defines a standard IPv4 access list by using a source address and wildcard.

      The access-list-number is a decimal number from 1 to 99 or 1300 to 1999.

      Enter deny or permit to specify whether to deny or permit access if conditions are matched.

      The source is the source address of the network or host from which the packet is being sent specified as:

      • The 32-bit quantity in dotted-decimal format.

      • The keyword any as an abbreviation for source and source-wildcard of 0.0.0.0 255.255.255.255. You do not need to enter a source-wildcard.

      • The keyword host as an abbreviation for source and source-wildcard of source 0.0.0.0.

      (Optional) The source-wildcard applies wildcard bits to the source.

      Note   

      Logging is supported only on ACLs attached to Layer 3 interfaces.

       
      Step 4end


      Example:
      
      Switch(config)# end
      
      
       

      Returns to privileged EXEC mode.

       
      Step 5show running-config


      Example:
      Switch# show running-config
      
      
       

      Verifies your entries.

       
      Step 6copy running-config startup-config


      Example:
      Switch# copy running-config startup-config
      
      
       

      (Optional) Saves your entries in the configuration file.

       
      Related References

      Creating a Numbered Extended ACL

      Follow these steps to create a numbered extended ACL:

      SUMMARY STEPS

        1.    configure terminal

        2.    access-list access-list-number 
{deny | permit} protocolsource source-wildcarddestination destination-wildcard [precedence precedence] [tos tos] [fragments] [time-range time-range-name] [dscp dscp]

        3.    access-list access-list-number {deny | permit} tcp source source-wildcard [operator port] destination destination-wildcard [operator port] [established] [precedence precedence] [tos tos] [fragments] [time-range time-range-name] [dscp dscp] [flag]

        4.    access-list access-list-number 
{deny | permit} udpsource source-wildcard [operator port] destination destination-wildcard [operator port] [precedence precedence] [tos tos] [fragments] [time-range time-range-name] [dscp dscp]

        5.    access-list access-list-number 
{deny | permit} icmp source source-wildcard destination destination-wildcard [icmp-type | [[icmp-type icmp-code] | [icmp-message]] [precedence precedence] [tos tos] [fragments] [time-range time-range-name] [dscp dscp]

        6.    access-list access-list-number 
{deny | permit} igmp source source-wildcard destination destination-wildcard [igmp-type] [precedence precedence] [tos tos] [fragments] [time-range time-range-name] [dscp dscp]

        7.    end


      DETAILED STEPS
         Command or ActionPurpose
        Step 1configure terminal


        Example:
        
        Switch# configure terminal
        
        
         

        Enters the global configuration mode.

         
        Step 2access-list access-list-number 
{deny | permit} protocolsource source-wildcarddestination destination-wildcard [precedence precedence] [tos tos] [fragments] [time-range time-range-name] [dscp dscp]

        Example:
        
        Switch(config)# access-list 101 permit ip host 10.1.1.2 any precedence 0 tos 0 log
        
        
         

        Defines an extended IPv4 access list and the access conditions.

        The access-list-number is a decimal number from 100 to 199 or 2000 to 2699.

        Enter deny or permit to specify whether to deny or permit the packet if conditions are matched.

        For protocol, enter the name or number of an P protocol: ahp, eigrp, esp, gre, icmp, igmp, igrp, ip, ipinip, nos, ospf, pcp, pim, tcp, or udp, or an integer in the range 0 to 255 representing an IP protocol number. To match any Internet protocol (including ICMP, TCP, and UDP), use the keyword ip.

        Note    This step includes options for most IP protocols. For additional specific parameters for TCP, UDP, ICMP, and IGMP, see the following steps.

        The source is the number of the network or host from which the packet is sent.

        The source-wildcard applies wildcard bits to the source.

        The destination is the network or host number to which the packet is sent.

        The destination-wildcard applies wildcard bits to the destination.

        Source, source-wildcard, destination, and destination-wildcard can be specified as:

        • The 32-bit quantity in dotted-decimal format.

        • The keyword any for 0.0.0.0 255.255.255.255 (any host).

        • The keyword host for a single host 0.0.0.0.

        The other keywords are optional and have these meanings:

        • precedence—Enter to match packets with a precedence level specified as a number from 0 to 7 or by name: routine (0), priority (1), immediate (2), flash (3), flash-override (4), critical (5), internet (6), network (7).

        • fragments—Enter to check non-initial fragments.

        • tos—Enter to match by type of service level, specified by a number from 0 to 15 or a name: normal (0), max-reliability (2), max-throughput (4), min-delay (8).

        • time-range—Specify the time-range name.

        • dscp—Enter to match packets with the DSCP value specified by a number from 0 to 63, or use the question mark (?) to see a list of available values.

        Note   

        If you enter a dscp value, you cannot enter tos or precedence. You can enter both a tos and a precedence value with no dscp.

         
        Step 3access-list access-list-number {deny | permit} tcp source source-wildcard [operator port] destination destination-wildcard [operator port] [established] [precedence precedence] [tos tos] [fragments] [time-range time-range-name] [dscp dscp] [flag]


        Example:
        Switch(config)# access-list 101 permit tcp any any eq 500
        
        
         

        Defines an extended TCP access list and the access conditions.

        The parameters are the same as those described for an extended IPv4 ACL, with these exceptions:

        (Optional) Enter an operator and port to compare source (if positioned after source source-wildcard) or destination (if positioned after destination destination-wildcard) port. Possible operators include eq (equal), gt (greater than), lt (less than), neq (not equal), and range (inclusive range). Operators require a port number (range requires two port numbers separated by a space).

        Enter the port number as a decimal number (from 0 to 65535) or the name of a TCP port. Use only TCP port numbers or names when filtering TCP.

        The other optional keywords have these meanings:

        • established—Enter to match an established connection. This has the same function as matching on the ack or rst flag.

        • flag—Enter one of these flags to match by the specified TCP header bits: ack (acknowledge), fin (finish), psh (push), rst (reset), syn (synchronize), or urg (urgent).

         
        Step 4access-list access-list-number 
{deny | permit} udpsource source-wildcard [operator port] destination destination-wildcard [operator port] [precedence precedence] [tos tos] [fragments] [time-range time-range-name] [dscp dscp]

        Example:
        Switch(config)# access-list 101 permit udp any any eq 100
        
        
         

        (Optional) Defines an extended UDP access list and the access conditions.

        The UDP parameters are the same as those described for TCP except that the [operator [port]] port number or name must be a UDP port number or name, and the flag and established keywords are not valid for UDP.

         
        Step 5access-list access-list-number 
{deny | permit} icmp source source-wildcard destination destination-wildcard [icmp-type | [[icmp-type icmp-code] | [icmp-message]] [precedence precedence] [tos tos] [fragments] [time-range time-range-name] [dscp dscp]

        Example:
        Switch(config)# access-list 101 permit icmp any any 200
        
        
         

        Defines an extended ICMP access list and the access conditions.

        The ICMP parameters are the same as those described for most IP protocols in an extended IPv4 ACL, with the addition of the ICMP message type and code parameters. These optional keywords have these meanings:

        • icmp-type—Enter to filter by ICMP message type, a number from 0 to 255.

        • icmp-code—Enter to filter ICMP packets that are filtered by the ICMP message code type, a number from 0 to 255.

        • icmp-message—Enter to filter ICMP packets by the ICMP message type name or the ICMP message type and code name.

         
        Step 6access-list access-list-number 
{deny | permit} igmp source source-wildcard destination destination-wildcard [igmp-type] [precedence precedence] [tos tos] [fragments] [time-range time-range-name] [dscp dscp]

        Example:
        
        Switch(config)# access-list 101 permit igmp any any 14
        
        
         

        (Optional) Defines an extended IGMP access list and the access conditions.

        The IGMP parameters are the same as those described for most IP protocols in an extended IPv4 ACL, with this optional parameter.

        igmp-type—To match IGMP message type, enter a number from 0 to 15, or enter the message name: dvmrp, host-query, host-report, pim, or trace.

         
        Step 7end


        Example:
        
        Switch(config)# end
        
        
         

        Returns to privileged EXEC mode.

         
        Related Concepts

        Creating Named Standard ACLs

        Follow these steps to create a standard ACL using names:

        SUMMARY STEPS

          1.    enable

          2.    configure terminal

          3.    ip access-list standard name

          4.    Use one of the following:

          • deny {source [source-wildcard] | host source | any} [log]
          • permit {source [source-wildcard] | host source | any} [log]

          5.    end

          6.    show running-config

          7.    copy running-config startup-config


        DETAILED STEPS
           Command or ActionPurpose
          Step 1enable


          Example:
          Switch> enable
          
          
           

          Enables privileged EXEC mode. Enter your password if prompted.

           
          Step 2configure terminal


          Example:
          
          Switch# configure terminal
          
          
           

          Enters the global configuration mode.

           
          Step 3ip access-list standard name


          Example:
          
          Switch(config)# ip access-list standard 20
          
          
           

          Defines a standard IPv4 access list using a name, and enter access-list configuration mode.

          The name can be a number from 1 to 99.

           
          Step 4Use one of the following:
          • deny {source [source-wildcard] | host source | any} [log]
          • permit {source [source-wildcard] | host source | any} [log]


          Example:
          
          Switch(config-std-nacl)# deny 192.168.0.0 0.0.255.255 255.255.0.0 0.0.255.255
          
          

          or

          
          Switch(config-std-nacl)# permit 10.108.0.0 0.0.0.0 255.255.255.0 0.0.0.0
          
          
           

          In access-list configuration mode, specify one or more conditions denied or permitted to decide if the packet is forwarded or dropped.

          • host source—A source and source wildcard of source 0.0.0.0.

          • any—A source and source wildcard of 0.0.0.0 255.255.255.255.

           
          Step 5end


          Example:
          Switch(config-std-nacl)# end
          
          
           

          Returns to privileged EXEC mode.

           
          Step 6show running-config


          Example:
          Switch# show running-config
          
          
           

          Verifies your entries.

           
          Step 7copy running-config startup-config


          Example:
          Switch# copy running-config startup-config
          
          
           

          (Optional) Saves your entries in the configuration file.

           
          Related Concepts
          Related References

          Creating Extended Named ACLs

          Follow these steps to create an extended ACL using names:

          SUMMARY STEPS

            1.    enable

            2.    configure terminal

            3.    ip access-list extended name

            4.    {deny | permit} protocol {source [source-wildcard] | host source | any} {destination [destination-wildcard] | host destination | any} [precedence precedence] [tos tos] [established] [log] [time-range time-range-name]

            5.    end

            6.    show running-config

            7.    copy running-config startup-config


          DETAILED STEPS
             Command or ActionPurpose
            Step 1enable


            Example:
            Switch> enable
            
            
             

            Enables privileged EXEC mode. Enter your password if prompted.

             
            Step 2configure terminal


            Example:
            
            Switch# configure terminal
            
            
             

            Enters the global configuration mode.

             
            Step 3ip access-list extended name


            Example:
            
            Switch(config)# ip access-list extended 150
            
            
             

            Defines an extended IPv4 access list using a name, and enter access-list configuration mode.

            The name can be a number from 100 to 199.

             
            Step 4{deny | permit} protocol {source [source-wildcard] | host source | any} {destination [destination-wildcard] | host destination | any} [precedence precedence] [tos tos] [established] [log] [time-range time-range-name]

            Example:
            
            Switch(config-ext-nacl)# permit 0 any any
            
            
             

            In access-list configuration mode, specify the conditions allowed or denied. Use the log keyword to get access list logging messages, including violations.

            • host source—A source and source wildcard of source 0.0.0.0.

            • host destintation—A destination and destination wildcard of destination 0.0.0.0.

            • any—A source and source wildcard or destination and destination wildcard of 0.0.0.0 255.255.255.255.

             
            Step 5end


            Example:
            
            Switch(config-ext-nacl)# end
            
            
             

            Returns to privileged EXEC mode.

             
            Step 6show running-config


            Example:
            Switch# show running-config
            
            
             

            Verifies your entries.

             
            Step 7copy running-config startup-config


            Example:
            Switch# copy running-config startup-config
            
            
             

            (Optional) Saves your entries in the configuration file.

             

            When you are creating extended ACLs, remember that, by default, the end of the ACL contains an implicit deny statement for everything if it did not find a match before reaching the end. For standard ACLs, if you omit the mask from an associated IP host address access list specification, 0.0.0.0 is assumed to be the mask.

            After you create an ACL, any additions are placed at the end of the list. You cannot selectively add ACL entries to a specific ACL. However, you can use no permit and no deny access-list configuration mode commands to remove entries from a named ACL.

            Being able to selectively remove lines from a named ACL is one reason you might use named ACLs instead of numbered ACLs.

            What to Do Next

            After creating a named ACL, you can apply it to interfaces or to VLANs .

            Related Concepts
            Related References

            Configuring Time Ranges for ACLs

            Follow these steps to configure a time-range parameter for an ACL:

            SUMMARY STEPS

              1.    enable

              2.    configure terminal

              3.    time-range time-range-name

              4.    Use one of the following:

              • absolute [start time date] 
[end time date]
              • periodic day-of-the-week hh:mm to [day-of-the-week] hh:mm
              • periodic {weekdays | weekend | daily} hh:mm to hh:mm

              5.    end

              6.    show running-config

              7.    copy running-config startup-config


            DETAILED STEPS
               Command or ActionPurpose
              Step 1enable


              Example:
              Switch(config)# enable
              
              
               

              Enables privileged EXEC mode. Enter your password if prompted.

               
              Step 2configure terminal


              Example:
              
              Switch# configure terminal
              
              
               

              Enters the global configuration mode.

               
              Step 3time-range time-range-name


              Example:
              
              Switch(config)# time-range workhours
              
              
               

              Assigns a meaningful name (for example, workhours) to the time range to be created, and enter time-range configuration mode. The name cannot contain a space or quotation mark and must begin with a letter.

               
              Step 4Use one of the following:
              • absolute [start time date] 
[end time date]
              • periodic day-of-the-week hh:mm to [day-of-the-week] hh:mm
              • periodic {weekdays | weekend | daily} hh:mm to hh:mm


              Example:
              
              Switch(config-time-range)# absolute start 00:00 1 Jan 2006 end 23:59 1 Jan 2006
              
              

              or

              
              Switch(config-time-range)# periodic weekdays 8:00 to 12:00
              
              
               

              Specifies when the function it will be applied to is operational.

              • You can use only one absolute statement in the time range. If you configure more than one absolute statement, only the one configured last is executed.

              • You can enter multiple periodic statements. For example, you could configure different hours for weekdays and weekends.

              See the example configurations.

               
              Step 5end


              Example:
              
              Switch(config)# end
              
              
               

              Returns to privileged EXEC mode.

               
              Step 6show running-config


              Example:
              Switch# show running-config
              
              
               

              Verifies your entries.

               
              Step 7copy running-config startup-config


              Example:
              Switch# copy running-config startup-config
              
              
               

              (Optional) Saves your entries in the configuration file.

               
              What to Do Next

              Repeat the steps if you have multiple items that you want in effect at different times.

              Related Concepts

              Applying an IPv4 ACL to a Terminal Line

              You can use numbered ACLs to control access to one or more terminal lines. You cannot apply named ACLs to lines. You must set identical restrictions on all the virtual terminal lines because a user can attempt to connect to any of them.

              Follow these steps to restrict incoming and outgoing connections between a virtual terminal line and the addresses in an ACL:

              SUMMARY STEPS

                1.    enable

                2.    configure terminal

                3.    line [console | vty] line-number

                4.    access-class access-list-number {in | out}

                5.    end

                6.    show running-config

                7.    copy running-config startup-config


              DETAILED STEPS
                 Command or ActionPurpose
                Step 1enable


                Example:
                Switch(config)# enable
                
                
                 

                Enables privileged EXEC mode. Enter your password if prompted.

                 
                Step 2configure terminal


                Example:
                
                Switch# configure terminal
                
                
                 

                Enters the global configuration mode.

                 
                Step 3line [console | vty] line-number


                Example:
                
                Switch(config)# line console 0
                
                
                 

                Identifies a specific line to configure, and enter in-line configuration mode.

                • console—Specifies the console terminal line. The console port is DCE.

                • vty—Specifies a virtual terminal for remote console access.

                The line-number is the first line number in a contiguous group that you want to configure when the line type is specified. The range is from 0 to 16.

                 
                Step 4access-class access-list-number {in | out}

                Example:
                
                Switch(config-line)# access-class 10 in
                
                
                 

                Restricts incoming and outgoing connections between a particular virtual terminal line (into a device) and the addresses in an access list.

                 
                Step 5end


                Example:
                
                Switch(config-line)# end
                
                
                 

                Returns to privileged EXEC mode.

                 
                Step 6show running-config


                Example:
                Switch# show running-config
                
                
                 

                Verifies your entries.

                 
                Step 7copy running-config startup-config


                Example:
                Switch# copy running-config startup-config
                
                
                 

                (Optional) Saves your entries in the configuration file.

                 

                Applying an IPv4 ACL to an Interface

                This section describes how to apply IPv4 ACLs to network interfaces.

                Beginning in privileged EXEC mode, follow these steps to control access to an interface:

                SUMMARY STEPS

                  1.    configure terminal

                  2.    interface interface-id

                  3.    ip access-group {access-list-number | name} {in | out}

                  4.    end

                  5.    show running-config

                  6.    copy running-config startup-config


                DETAILED STEPS
                   Command or ActionPurpose
                  Step 1configure terminal


                  Example:
                  
                  Switch# configure terminal
                  
                  
                   

                  Enters the global configuration mode.

                   
                  Step 2interface interface-id


                  Example:
                  
                  Switch(config)# interface gigabitethernet1/0/1
                  
                  
                   

                  Identifies a specific interface for configuration, and enter interface configuration mode.

                  The interface can be a Layer 2 interface (port ACL), or a Layer 3 interface (router ACL).

                   
                  Step 3ip access-group {access-list-number | name} {in | out}


                  Example:
                  
                  Switch(config-if)# ip access-group 2 in
                  
                  
                   

                  Controls access to the specified interface.

                  The out keyword is not supported for Layer 2 interfaces (port ACLs).

                   
                  Step 4end


                  Example:
                  
                  Switch(config-if)# end
                  
                  
                   

                  Returns to privileged EXEC mode.

                   
                  Step 5show running-config


                  Example:
                  
                  Switch# show running-config
                  
                  
                   

                  Displays the access list configuration.

                   
                  Step 6copy running-config startup-config


                  Example:
                  
                  Switch# copy running-config startup-config
                  
                  
                   

                  (Optional) Saves your entries in the configuration file.

                   

                  Creating Named MAC Extended ACLs

                  You can filter non-IPv4 traffic on a VLAN or on a Layer 2 interface by using MAC addresses and named MAC extended ACLs. The procedure is similar to that of configuring other extended named ACLs.

                  Follow these steps to create a named MAC extended ACL:

                  SUMMARY STEPS

                    1.    enable

                    2.    configure terminal

                    3.    mac access-list extended name

                    4.    {deny | permit} {any | host source MAC address | source MAC address mask} {any | host destination MAC address | destination MAC address mask} [type mask | lsap lsap mask | aarp | amber | dec-spanning | decnet-iv | diagnostic | dsm | etype-6000 | etype-8042 | lat | lavc-sca | mop-console | mop-dump | msdos | mumps | netbios | vines-echo | vines-ip | xns-idp | 0-65535] [cos cos]

                    5.    end

                    6.    show running-config

                    7.    copy running-config startup-config


                  DETAILED STEPS
                     Command or ActionPurpose
                    Step 1enable


                    Example:
                    Switch> enable
                    
                    
                     

                    Enables privileged EXEC mode. Enter your password if prompted.

                     
                    Step 2configure terminal


                    Example:
                    
                    Switch# configure terminal
                    
                    
                     

                    Enters the global configuration mode.

                     
                    Step 3mac access-list extended name


                    Example:
                    
                    Switch(config)# mac access-list extended mac1
                    
                    
                     

                    Defines an extended MAC access list using a name.

                     
                    Step 4{deny | permit} {any | host source MAC address | source MAC address mask} {any | host destination MAC address | destination MAC address mask} [type mask | lsap lsap mask | aarp | amber | dec-spanning | decnet-iv | diagnostic | dsm | etype-6000 | etype-8042 | lat | lavc-sca | mop-console | mop-dump | msdos | mumps | netbios | vines-echo | vines-ip | xns-idp | 0-65535] [cos cos]

                    Example:
                    
                    Switch(config-ext-macl)# deny any any decnet-iv
                    
                    

                    or

                    
                    Switch(config-ext-macl)# permit any any
                    
                    
                     

                    In extended MAC access-list configuration mode, specifies to permit or deny any source MAC address, a source MAC address with a mask, or a specific host source MAC address and any destination MAC address, destination MAC address with a mask, or a specific destination MAC address.

                    (Optional) You can also enter these options:

                    • type mask—An arbitrary EtherType number of a packet with Ethernet II or SNAP encapsulation in decimal, hexadecimal, or octal with optional mask of don’t care bits applied to the EtherType before testing for a match.

                    • lsap lsap mask—An LSAP number of a packet with IEEE 802.2 encapsulation in decimal, hexadecimal, or octal with optional mask of don’t care bits.

                    • aarp | amber | dec-spanning | decnet-iv | diagnostic | dsm | etype-6000 | etype-8042 | lat | lavc-sca | mop-console | mop-dump | msdos | mumps | netbios | vines-echo | vines-ip | xns-idp—A non-IP protocol.

                    • cos cos—An IEEE 802.1Q cost of service number from 0 to 7 used to set priority.

                     
                    Step 5end


                    Example:
                    
                    Switch(config-ext-macl)# end
                    
                    
                     

                    Returns to privileged EXEC mode.

                     
                    Step 6show running-config


                    Example:
                    Switch# show running-config
                    
                    
                     

                    Verifies your entries.

                     
                    Step 7copy running-config startup-config


                    Example:
                    Switch# copy running-config startup-config
                    
                    
                     

                    (Optional) Saves your entries in the configuration file.

                     

                    Applying a MAC ACL to a Layer 2 Interface

                    Follow these steps to apply a MAC access list to control access to a Layer 2 interface:

                    SUMMARY STEPS

                      1.    enable

                      2.    configure terminal

                      3.    interface interface-id

                      4.    mac access-group {name} {in }

                      5.    end

                      6.    show mac access-group [interface interface-id]

                      7.    show running-config

                      8.    copy running-config startup-config


                    DETAILED STEPS
                       Command or ActionPurpose
                      Step 1 enable


                      Example:
                      Switch> enable
                      
                      
                       

                      Enables privileged EXEC mode. Enter your password if prompted.

                       

                      Step 2configure terminal


                      Example:
                      
                      Switch# configure terminal
                      
                      
                       

                      Enters the global configuration mode.

                       
                      Step 3interface interface-id


                      Example:
                      
                      Switch(config)# interface gigabitethernet1/0/2
                      
                      
                       

                      Identifies a specific interface, and enter interface configuration mode. The interface must be a physical Layer 2 interface (port ACL).

                       
                      Step 4mac access-group {name} {in }


                      Example:
                      
                      Switch(config-if)# mac access-group mac1 in
                      
                      
                       

                      Controls access to the specified interface by using the MAC access list.

                      Port ACLs are supported in the inbound directions only.

                       
                      Step 5end


                      Example:
                      Switch(config-if)# end
                      
                      
                       

                      Returns to privileged EXEC mode.

                       
                      Step 6show mac access-group [interface interface-id]


                      Example:
                      
                      Switch# show mac access-group interface gigabitethernet1/0/2
                      
                      
                       

                      Displays the MAC access list applied to the interface or all Layer 2 interfaces.

                       
                      Step 7show running-config


                      Example:
                      
                      Switch# show running-config 
                      
                      
                       

                      Verifies your entries.

                       
                      Step 8copy running-config startup-config


                      Example:
                      Switch# copy running-config startup-config 
                      
                      
                       

                      (Optional) Saves your entries in the configuration file.

                       

                      After receiving a packet, the switch checks it against the inbound ACL. If the ACL permits it, the switch continues to process the packet. If the ACL rejects the packet, the switch discards it. When you apply an undefined ACL to an interface, the switch acts as if the ACL has not been applied and permits all packets. Remember this behavior if you use undefined ACLs for network security.

                      Monitoring IPv4 ACLs

                      You can monitor IPv4 ACLs by displaying the ACLs that are configured on the switch, and displaying the ACLs that have been applied to interfaces and VLANs.

                      When you use the ip access-group interface configuration command to apply ACLs to a Layer 2 or 3 interface, you can display the access groups on the interface. You can also display the MAC ACLs applied to a Layer 2 interface. You can use the privileged EXEC commands as described in this table to display this information.

                      Table 2 Commands for Displaying Access Lists and Access Groups
                      Command Purpose

                      show access-lists [number | name]

                      Displays the contents of one or all current IP and MAC address access lists or a specific access list (numbered or named).

                      show ip access-lists [number | name]

                      Displays the contents of all current IP access lists or a specific IP access list (numbered or named).

                      show ip interface interface-id

                      Displays detailed configuration and status of an interface. If IP is enabled on the interface and ACLs have been applied by using the ip access-group interface configuration command, the access groups are included in the display.

                      show running-config [interface interface-id]

                      Displays the contents of the configuration file for the switch or the specified interface, including all configured MAC and IP access lists and which access groups are applied to an interface.

                      show mac access-group [interface interface-id]

                      Displays MAC access lists applied to all Layer 2 interfaces or the specified

                      Layer 2 interface.

                      You can also monitor VLAN maps by displaying information about VLAN access maps or VLAN filters. Use the privileged EXEC commands in this table to display VLAN map information.



                      Table 3 Commands for Displaying VLAN Map Information
                      Command Purpose

                      show vlan access-map [mapname]

                      Displays information about all VLAN access maps or the specified access map.

                      show vlan filter [access-map name | vlan vlan-id]

                      Displays information about all VLAN filters or about a specified VLAN or VLAN access map.

                      IPv4 ACL Configuration Examples

                      This section provides examples of configuring and applying IPv4 ACLs. For detailed information about compiling ACLs, see the Cisco IOS Security Configuration Guide, Release 12.4 and to the Configuring IP Services” section in the “IP Addressing and Services” chapter of the Cisco IOS IP Configuration Guide, Release 12.4.

                      ACLs in a Small Networked Office

                      Figure 2. Using Router ACLs to Control Traffic. This shows a small networked office environment with routed Port 2 connected to Server A, containing benefits and other information that all employees can access, and routed Port 1 connected to Server B, containing confidential payroll data. All users can access Server A, but Server B has restricted access.

                      Use router ACLs to do this in one of two ways:

                      • Create a standard ACL, and filter traffic coming to the server from Port 1.

                      • Create an extended ACL, and filter traffic coming from the server into Port 1.

                      Examples: ACLs in a Small Networked Office

                      This example uses a standard ACL to filter traffic coming into Server B from a port, permitting traffic only from Accounting’s source addresses 172.20.128.64 to 172.20.128.95. The ACL is applied to traffic coming out of routed Port 1 from the specified source address.

                      
                      Switch(config)# access-list 6 permit 172.20.128.64 0.0.0.31
                      Switch(config)# end
                      Switch# how access-lists
                      Standard IP access list 6
                          10 permit 172.20.128.64, wildcard bits 0.0.0.31
                      Switch(config)# interface gigabitethernet1/0/1
                      Switch(config-if)# ip access-group 6 out
                      
                      

                      This example uses an extended ACL to filter traffic coming from Server B into a port, permitting traffic from any source address (in this case Server B) to only the Accounting destination addresses 172.20.128.64 to 172.20.128.95. The ACL is applied to traffic going into routed Port 1, permitting it to go only to the specified destination addresses. Note that with extended ACLs, you must enter the protocol (IP) before the source and destination information.

                      
                      Switch(config)# access-list 106 permit ip any 172.20.128.64 0.0.0.31
                      Switch(config)# end
                      Switch# show access-lists
                      Extended IP access list 106
                          10 permit ip any 172.20.128.64 0.0.0.31
                      Switch(config)# interface gigabitethernet1/0/1
                      Switch(config-if)# ip access-group 106 in
                      
                      

                      Example: Numbered ACLs

                      In this example, network 36.0.0.0 is a Class A network whose second octet specifies a subnet; that is, its subnet mask is 255.255.0.0. The third and fourth octets of a network 36.0.0.0 address specify a particular host. Using access list 2, the switch accepts one address on subnet 48 and reject all others on that subnet. The last line of the list shows that the switch accepts addresses on all other network 36.0.0.0 subnets. The ACL is applied to packets entering a port.

                      
                      Switch(config)# access-list 2 permit 36.48.0.3
                      Switch(config)# access-list 2 deny 36.48.0.0 0.0.255.255
                      Switch(config)# access-list 2 permit 36.0.0.0 0.255.255.255 
                      Switch(config)# interface gigabitethernet2/0/1
                      Switch(config-if)# ip access-group 2 in
                      
                      
                      Related Concepts

                      Examples: Extended ACLs

                      In this example, the first line permits any incoming TCP connections with destination ports greater than 1023. The second line permits incoming TCP connections to the Simple Mail Transfer Protocol (SMTP) port of host 128.88.1.2. The third line permits incoming ICMP messages for error feedback.

                      
                      Switch(config)# access-list 102 permit tcp any 128.88.0.0 0.0.255.255 gt 1023
                      Switch(config)# access-list 102 permit tcp any host 128.88.1.2 eq 25
                      Switch(config)# access-list 102 permit icmp any any
                      Switch(config)# interface gigabitethernet2/0/1
                      Switch(config-if)# ip access-group 102 in
                      
                      

                      In this example, suppose that you have a network connected to the Internet, and you want any host on the network to be able to form TCP connections to any host on the Internet. However, you do not want IP hosts to be able to form TCP connections to hosts on your network, except to the mail (SMTP) port of a dedicated mail host.

                      SMTP uses TCP port 25 on one end of the connection and a random port number on the other end. The same port numbers are used throughout the life of the connection. Mail packets coming in from the Internet have a destination port of 25. Because the secure system of the network always accepts mail connections on port 25, the incoming are separately controlled.

                      
                      Switch(config)# access-list 102 permit tcp any 128.88.0.0 0.0.255.255 eq 23
                      Switch(config)# access-list 102 permit tcp any 128.88.0.0 0.0.255.255 eq 25
                      Switch(config)# interface gigabitethernet1/0/1
                      Switch(config-if)# ip access-group 102 in
                      
                      

                      In this example, the network is a Class B network with the address 128.88.0.0, and the mail host address is 128.88.1.2. The established keyword is used only for the TCP to show an established connection. A match occurs if the TCP datagram has the ACK or RST bits set, which show that the packet belongs to an existing connection. Gigabit Ethernet interface 1 on stack member 1 is the interface that connects the router to the Internet.

                      
                      Switch(config)# access-list 102 permit tcp any 128.88.0.0 0.0.255.255 established
                      Switch(config)# access-list 102 permit tcp any host 128.88.1.2 eq 25
                      Switch(config)# interface gigabitethernet1/0/1
                      Switch(config-if)# ip access-group 102 in
                      
                      
                      Related Concepts

                      Examples: Named ACLs

                      Creating named standard and extended ACLs

                      This example creates a standard ACL named internet_filter and an extended ACL named marketing_group. The internet_filter ACL allows all traffic from the source address 1.2.3.4.

                      
                      Switch(config)# ip access-list standard Internet_filter
                      Switch(config-ext-nacl)# permit 1.2.3.4
                      Switch(config-ext-nacl)# exit
                      
                      

                      The marketing_group ACL allows any TCP Telnet traffic to the destination address and wildcard 171.69.0.0 0.0.255.255 and denies any other TCP traffic. It permits ICMP traffic, denies UDP traffic from any source to the destination address range 171.69.0.0 through 179.69.255.255 with a destination port less than 1024, denies any other IP traffic, and provides a log of the result.

                      
                      Switch(config)# ip access-list extended marketing_group
                      Switch(config-ext-nacl)# permit tcp any 171.69.0.0 0.0.255.255 eq telnet
                      Switch(config-ext-nacl)# deny tcp any any
                      Switch(config-ext-nacl)# permit icmp any any
                      Switch(config-ext-nacl)# deny udp any 171.69.0.0 0.0.255.255 lt 1024
                      Switch(config-ext-nacl)# deny ip any any log
                      Switch(config-ext-nacl)# exit
                      
                      

                      The Internet_filter ACL is applied to outgoing traffic and the marketing_group ACL is applied to incoming traffic on a Layer 3 port.

                      
                      Switch(config)# interface gigabitethernet3/0/2
                      Switch(config-if)# no switchport
                      Switch(config-if)# ip address 2.0.5.1 255.255.255.0
                      Switch(config-if)# ip access-group Internet_filter out
                      Switch(config-if)# ip access-group marketing_group in
                      
                      

                      Deleting individual ACEs from named ACLs

                      This example shows how you can delete individual ACEs from the named access list border-list:

                      
                      Switch(config)# ip access-list extended border-list
                      Switch(config-ext-nacl)# no permit ip host 10.1.1.3 any
                      
                      
                      Related Concepts

                      Examples: Time Range Applied to an IP ACL

                      This example denies HTTP traffic on IP on Monday through Friday between the hours of 8:00 a.m. and 6:00 p.m (18:00). The example allows UDP traffic only on Saturday and Sunday from noon to 8:00 p.m. (20:00).

                      
                      Switch(config)# time-range no-http
                      Switch(config)# periodic weekdays 8:00 to 18:00
                      !
                      Switch(config)# time-range udp-yes
                      Switch(config)# periodic weekend 12:00 to 20:00
                      !
                      Switch(config)# ip access-list extended strict
                      Switch(config-ext-nacl)# deny tcp any any eq www time-range no-http
                      Switch(config-ext-nacl)# permit udp any any time-range udp-yes
                      !
                      Switch(config-ext-nacl)# exit
                      Switch(config)# interface gigabitethernet2/0/1
                      Switch(config-if)# ip access-group strict in
                      
                      
                      Related Concepts

                      Examples: Commented IP ACL Entries

                      In this example of a numbered ACL, the workstation that belongs to Jones is allowed access, and the workstation that belongs to Smith is not allowed access:

                      
                      Switch(config)# access-list 1 remark Permit only Jones workstation through
                      Switch(config)# access-list 1 permit 171.69.2.88
                      Switch(config)# access-list 1 remark Do not allow Smith workstation through
                      Switch(config)# access-list 1 deny 171.69.3.13
                      
                      

                      In this example of a numbered ACL, the Winter and Smith workstations are not allowed to browse the web:

                      
                      Switch(config)# access-list 100 remark Do not allow Winter to browse the web
                      Switch(config)# access-list 100 deny host 171.69.3.85 any eq www
                      Switch(config)# access-list 100 remark Do not allow Smith to browse the web
                      Switch(config)# access-list 100 deny host 171.69.3.13 any eq www
                      
                      

                      In this example of a named ACL, the Jones subnet is not allowed access:

                      
                      Switch(config)# ip access-list standard prevention
                      Switch(config-std-nacl)# remark Do not allow Jones subnet through
                      Switch(config-std-nacl)# deny 171.69.0.0 0.0.255.255
                      
                      

                      In this example of a named ACL, the Jones subnet is not allowed to use outbound Telnet:

                      
                      Switch(config)# ip access-list extended telnetting
                      Switch(config-ext-nacl)# remark Do not allow Jones subnet to telnet out
                      Switch(config-ext-nacl)# deny tcp 171.69.0.0 0.0.255.255 any eq telnet
                      
                      
                      Related Concepts

                      Examples: Troubleshooting ACLs

                      If this ACL manager message appears and [chars] is the access-list name,

                      
                      ACLMGR-2-NOVMR: Cannot generate hardware representation of access list [chars]
                      
                      

                      The switch has insufficient resources to create a hardware representation of the ACL. The resources include hardware memory and label space but not CPU memory. A lack of available logical operation units or specialized hardware resources causes this problem. Logical operation units are needed for a TCP flag match or a test other than eq (ne, gt, lt, or range) on TCP, UDP, or SCTP port numbers.

                      Use one of these workarounds:

                      • Modify the ACL configuration to use fewer resources.

                      • Rename the ACL with a name or number that alphanumerically precedes the ACL names or numbers.

                      To determine the specialized hardware resources, enter the show platform layer4 acl map privileged EXEC command. If the switch does not have available resources, the output shows that index 0 to index 15 are not available.

                      For more information about configuring ACLs with insufficient resources, see CSCsq63926 in the Bug Toolkit.

                      For example, if you apply this ACL to an interface:

                      
                      permit tcp source source-wildcard destination destination-wildcard range 5 60
                      permit tcp source source-wildcard destination destination-wildcard range 15 160
                      permit tcp source source-wildcard destination destination-wildcard range 115 1660
                      permit tcp source source-wildcard destination destination-wildcard
                      
                      

                      And if this message appears:

                      
                      ACLMGR-2-NOVMR: Cannot generate hardware representation of access list [chars]
                      
                      

                      The flag-related operators are not available. To avoid this issue,

                      • Move the fourth ACE before the first ACE by using ip access-list resequence global configuration command:

                        
                        permit tcp source source-wildcard destination destination-wildcard
                        permit tcp source source-wildcard destination destination-wildcard range 5 60
                        permit tcp source source-wildcard destination destination-wildcard range 15 160
                        permit tcp source source-wildcard destination destination-wildcard range 115 1660
                        
                        

                        or

                      • Rename the ACL with a name or number that alphanumerically precedes the other ACLs (for example, rename ACL 79 to ACL 1).

                      You can now apply the first ACE in the ACL to the interface. The switch allocates the ACE to available mapping bits in the Opselect index and then allocates flag-related operators to use the same bits in the hardware memory.

                      Additional References

                      Related Documents

                      Related Topic Document Title

                      IPv4 Access Control List topics

                      Securing the Data Plane Configuration Guide Library, Cisco IOS XE Release 3SE (Catalyst 3850 Switches)

                      http:/​/​www.cisco.com/​en/​US/​docs/​ios-xml/​ios/​security/​config_library/​xe-3se/​3850/​secdata-xe-3se-3850-library.html

                      Error Message Decoder

                      Description Link

                      To help you research and resolve system error messages in this release, use the Error Message Decoder tool.

                      https:/​/​www.cisco.com/​cgi-bin/​Support/​Errordecoder/​index.cgi

                      MIBs

                      MIB MIBs Link

                      All supported MIBs for this release.

                      To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

                      http:/​/​www.cisco.com/​go/​mibs

                      Technical Assistance

                      Description Link

                      The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

                      To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

                      Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

                      http:/​/​www.cisco.com/​support