Catalyst 2950 Switch Hardware Installation Guide, August 2004
Configuring the Switch with the CLI-Based Setup Program
Downloads: This chapterpdf (PDF - 360.0KB) The complete bookPDF (PDF - 4.62MB) | Feedback

Configuring the Switch with the CLI-Based Setup Program

Table Of Contents

Configuring the Switch with the CLI-Based Setup Program

Accessing the CLI

Accessing the CLI Through Express Setup

Accessing the CLI Through the Console Port

Taking Out What You Need

Connecting to the Console Port

Starting the Terminal-Emulation Software

Connecting to a Power Source

Entering the Initial Configuration Information

IP Settings

Completing the Setup Program


Configuring the Switch with the CLI-Based Setup Program


This appendix provides a command-line interface (CLI)-based setup procedure for a standalone switch. For product overview information, see "Overview." Before connecting the switch to a power source, review the safety warnings in "Installation." For installation procedures on rack-mounting your switch, connecting to the Gigabit Ethernet Interface Converter (GBIC) modules, or connecting to the small form-factor pluggable (SFP) modules, see "Installation."

These steps describe how to do a simple installation:

1. Accessing the CLI

2. Taking Out What You Need

3. Connecting to the Console Port

4. Starting the Terminal-Emulation Software

5. Connecting to a Power Source

6. Entering the Initial Configuration Information

Accessing the CLI

For an unconfigured switch, you can access the CLI through Express Setup or through the console port.

Accessing the CLI Through Express Setup

Express Setup is supported on switches running Cisco IOS Release 12.1(14)EA1 or later. If you are installing an unconfigured switch, see the Cisco IOS release label on the rear panel of the switch to determine the release.


Note For switches running releases earlier than Cisco IOS Release 12.1(14)EA1, go to the "Taking Out What You Need" section.


You can access the CLI on an unconfigured switch by placing the switch in Express Setup mode and then by connecting a switch Ethernet port to the Ethernet port of your PC or workstation. To put the switch into Express Setup mode, follow the steps described in the getting started guide for powering on the switch and using Express Setup.

After the switch is in Express Setup mode, open a Telnet session to the switch by entering the IP address 10.0.0.1. Enter the setup user EXEC command. See these sections in this chapter to then configure the switch by using the CLI:

Entering the Initial Configuration Information

Completing the Setup Program

After you have entered the configuration information for the switch, use the write memory privileged EXEC command to save it to Flash memory.


Note While in Express Setup mode, the IP address 10.0.0.1 is active until you enter the write memory command. You lose the Telnet connection after entering the write memory command.


For more information about using the CLI, see the switch command reference for this release.

Accessing the CLI Through the Console Port

You can access the CLI on a configured or unconfigured switch by connecting the console port of the switch to the serial port on your PC or workstation and accessing the switch through a Telnet session. To access the switch through the console port, follow these steps:

"Taking Out What You Need" section.

"Connecting to the Console Port" section

"Starting the Terminal-Emulation Software" section

"Connecting to a Power Source" section

"Entering the Initial Configuration Information" section

Taking Out What You Need

Remove the items shown in Figure D-1 from the shipping container:

Figure D-1 Catalyst 2950 Switch, Adapter Cable, and AC Power Cord

1

Catalyst 2950 switch

3

AC power cord

2

RJ-45-to-DB-9 adapter cable

   


Note You need to provide the Category 5 straight-through cables to connect the switch ports to other Ethernet devices.


Connecting to the Console Port

You can use the console port to perform the initial configuration. To connect the switch console port to a PC, use the supplied RJ-45-to-DB-9 adapter cable.

Follow these steps to connect the PC or terminal to the switch:


Step 1 Using the supplied RJ-45-to-DB-9 adapter cable, insert the RJ-45 connector into the console port on the rear of a switch, as shown in Figure D-2.

Step 2 Attach the DB-9 female DTE of the adapter cable to a PC serial port, or attach an appropriate adapter to the terminal.


Figure D-2 Connecting a Switch to a PC

1

Catalyst 2950 switch

3

RJ-45-to-DB-9 adapter cable

2

Power cord

   

Starting the Terminal-Emulation Software

Before you power on the switch, start the terminal-emulation session so that you can see the output display from the power-on self-test (POST).

The terminal-emulation software—frequently a PC application such as Hyperterminal or ProcommPlus—makes communication between the switch and your PC or terminal possible.

Follow these steps to start a terminal-emulation session:


Step 1 Start the terminal-emulation program if you are using a PC or terminal.

Step 2 Configure the baud rate and character format of the PC or terminal to match these console port default characteristics:

9600 baud

8 data bits

1 stop bit

No parity

None (flow control)


Connecting to a Power Source

This section has instructions for connecting the switch to AC power. For instructions about connecting the Catalyst 2950G-24-EI-DC or Catalyst 2950ST-24 LRE 997 switch to DC power, see "Connecting to DC Power."

For a switch other than a Catalyst 2950G-24-EI-DC or a Catalyst 2950ST-24 LRE 997 switch, follow these steps to connect to an AC power source:


Step 1 Connect one end of the supplied AC power cord to the power connector on the switch rear panel.


Note For an LRE switch, connect one end of the supplied AC power cord to the power connector on the switch front panel.


Figure D-2 shows how to connect the AC power cord to the connector on the switch rear panel.

Step 2 Connect the other end of the power cable to a grounded AC outlet.



Note If you are connecting the switch to a Cisco redundant power system (RPS), see the documentation that shipped with your RPS.


When the switch powers on, it begins the POST, a series of tests that runs automatically to ensure that the switch functions properly. If POST fails, see "Troubleshooting," to determine a course of action.

Entering the Initial Configuration Information

To set up the switch, you need to complete the setup program, which runs automatically after the switch is powered on. You must assign an IP address and other configuration information necessary for the switch to communicate with the local routers and the Internet. This information is also required if you plan to use the Network Assistant to configure and manage the switch.

IP Settings

You will need this information from your network administrator before you complete the setup program:

Switch IP address

Subnet mask (IP netmask)

Default gateway (router)

Enable secret password

Enable password

Telnet password

Completing the Setup Program

Follow these steps to complete the setup program and to create an initial configuration for the switch:


Step 1 Enter Yes at these two prompts.

Would you like to enter the initial configuration dialog? [yes/no]: yes

At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.

Basic management setup configures only enough connectivity
for management of the system, extended setup will ask you
to configure each interface on the system.

Would you like to enter basic management setup? [yes/no]: yes

Step 2 Enter a host name for the switch, and press Return.

On a command switch, the host name is limited to 28 characters; on a member switch to 31 characters. Do not use -n, where n is a number, as the last character in a host name for any switch.

Enter host name [Switch]: host_name

Step 3 Enter an enable secret password, and press Return.

The password can be from 1 to 25 alphanumeric characters, can start with a number, is case sensitive, allows spaces, but ignores leading spaces. The secret password is encrypted, and the enable password is in plain text.

Enter enable secret: secret_password

Step 4 Enter an enable password, and press Return.

Enter enable password: enable_password

Step 5 Enter a virtual terminal (Telnet) password, and press Return.

The password can be from 1 to 25 alphanumeric characters, is case sensitive, allows spaces, but ignores leading spaces.

Enter virtual terminal password: terminal-password

Step 6 (Optional) Configure Simple Network Management Protocol (SNMP) by responding to the prompts. You can also configure SNMP later through the command-line interface (CLI), the device manager, or the Network Assistant application. To configure SNMP later, enter no.

Configure SNMP Network Management? [no]: no

Step 7 Enter the interface name (physical interface or virtual local-area network [VLAN] name) of the interface that connects to the management network, and press Return. For this release, always use vlan1 as that interface.

Enter interface name used to connect to the
management network from the above interface summary: vlan1

Step 8 Configure the interface by entering the switch IP address and subnet mask and pressing Return. The IP address and subnet masks shown below are examples.

Configuring interface vlan1:
Configure IP on this interface? [yes]: yes 
IP address for this interface: 10.4.120.106
Subnet mask for this interface [255.0.0.0]: 255.0.0.0

Step 9 Enter Y to configure the switch as the cluster command switch. Enter N to configure it as a member switch or as a standalone switch.

If you enter N, the switch appears as a candidate switch in the Network Assistant GUI. You can configure the switch as a command switch later through the CLI, the device manager, or the Network Assistant application. To configure it later, enter no.

Would you like to enable as a cluster command switch? [yes/no]: no

You have now completed the initial configuration of the switch, and the switch displays that configuration. This is an example of the output that appears:

The following configuration command script was created: 
hostname host_name 
enable secret 5 $1$Max7$Qgr9eXBhtcBJw3KK7bc850 
enable password my 
line vty 0 15 
password my_password 
snmp-server community public 
! 
no ip routing 
! 
interface Vlan1 
no shutdown 
ip address 172.20.139.145 255.255.255.224 
! 
interface Vlan2 
shutdown 
no ip address 
! 
interface FastEthernet0/1 
! 
interface FastEthernet0/2 
! 
...<output abbreviated> 
!!! 
interface GigabitEthernet0/1 
! 
interface GigabitEthernet0/2 
! 
end 

Step 10 These choices appear:

[0] Go to the IOS command prompt without saving this config.

[1] Return back to the setup without saving this config.

[2] Save this configuration to nvram and exit.

If you want to save the configuration and use it the next time the switch reboots, save it 
in nonvolatile RAM (NVRAM) by selecting option 2.

Enter your selection [2]:2

Make your selection, and press Return.


After you complete the setup program, the switch can run the default configuration that you created. If you want to change this configuration or want to perform other management tasks, use one of these tools:

CLI

Device manager from your browser (for one switch)

Network Assistant (for one or more switches)

To use the CLI, enter commands at the Switch> prompt through the console port by using a terminal-emulation program or through the network by using Telnet. For configuration information, see the switch software configuration guide or the switch command reference.

To use the Network Assistant, see the Getting Started with Cisco Network Assistant guide.