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Administering Statistical Data Collection

This chapter describes how to administer Statistical Data Collection in the Cisco Data Center Network 
Manager for LAN (DCNM-LAN).

You can use the Statistical Data Collection feature to control the statistics monitoring processes that you 
have created for one of the many device configuration features that support statistics. You can also use 
the Statistical Data Collection feature to delete unwanted statistical data on demand or automatically.

This chapter includes the following sections:

• Information About Statistical Data Collection, page 30-1

• Licensing Requirements for Statistical Data Collection, page 30-2

• Prerequisites for Statistical Data Collection, page 30-2

• Guidelines and Limitations for Statistical Data Collection, page 30-3

• Configuring Statistical Data Collection, page 30-3

• Viewing the Status of Statistical Data Collectors, page 30-10

• Field Descriptions for Statistical Data Collection, page 30-10

• Additional References, page 30-11

• Feature History for Statistical Data Collection, page 30-12

Information About Statistical Data Collection
You can use the Statistical Data Collection feature to control the statistics monitoring processes that you 
have created for one of the many device configuration features that support statistics.

When you choose Statistical Data Collection on the Feature Selector pane, the Contents pane shows 
information about each statistical collection and allows you to control them. You can also use this feature 
to purge old data from the statistical database.

You can configure the length of time that Cisco Data Center Network Manager for LAN (DCNM-LAN) 
waits before retrieving statistical data from devices that it is monitoring. By default, DCNM-LAN 
retrieves statistical data from monitored devices every 30 seconds. You can increase the length of time 
to a maximum of 4 minutes. For more information, see the “Configuring Monitoring Preferences” 
section on page 14-17.

This section includes the following topics:

• Automatic and Manual Purging of Statistical Data, page 30-2

• Virtualization Support, page 30-2
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Automatic and Manual Purging of Statistical Data
You can use the Statistical Data Collection feature to delete unwanted statistical data. DCNM-LAN 
supports automatic purging of statistical data. You can configure the following aspects of automatic 
statistical data purging:

• Days of the week and time of day that automatic purging occurs.

• Whether DCNM-LAN determines which statistical data to purge by the age of the data or by a 
maximum number of database entries.

• Whether DCNM-LAN deletes the statistical data entries that it purges or consolidates them into one 
entry.

You can also manually purge statistical data.

Virtualization Support
DCNM-LAN treats each virtual device context (VDC) on a Cisco NX-OS device as a separate device. 
Statistical data collections contain statistics from objects within devices.

Licensing Requirements for Statistical Data Collection
The following table shows the licensing requirements for this feature:

Prerequisites for Statistical Data Collection
Statistical data collection has the following prerequisites:

• The DCNM-LAN server must be able to connect to the devices.

• The system clocks for the DCNM-LAN server and DCNM-LAN client must be synchronized.
If the system clocks are not synchronized, scheduling tasks for data collection may start or end at 
incorrect times.

• The Cisco NX-OS device must be running a supported version of Cisco NX-OS.

• The Cisco NX-OS device must have the minimal configuration that is required to enable device 
discovery to succeed. For more information, see the “Verifying the Discovery Readiness of a Cisco 
NX-OS Device” section on page 27-7.

Product License Requirement

Cisco 
DCNM-LAN

Real-time monitoring requires no license.

Cisco DCNM-LAN requires a LAN Enterprise license for the following features:

• Maintaining a history of statistical data

• Using overview charts

For information about obtaining and installing a Cisco DCNM LAN Enterprise license, see the Cisco DCNM 
Installation and Licensing Guide, Release 7.1.x.
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Guidelines and Limitations for Statistical Data Collection
The Statistical Data Collection feature has the following configuration guidelines and limitations:

• Collections are created by starting monitoring for a new chart. For more information, see the 
“Starting Statistical Monitoring for a Chart” section on page 14-12.

• For the Statistical Data Collection feature, the DCNM-LAN client does not automatically update the 
information shown in the Summary pane. To ensure that you are viewing current information, from 
the menu bar, choose View > Refresh.

• When you start statistical monitoring for one or more charts and then close the DCNM-LAN client, 
a dialog box prompts you to decide whether to stop the collections or let them run. We recommend 
that you stop any unnecessary collections when you log out of the DCNM-LAN client. This practice 
conserves database space and decreases the server load.

• We recommend that you configure automatic purging of statistical data to ensure that the 
DCNM-LAN database size does not grow too large.

• You cannot always map the statistics data with the data collectors scheduler. However, a single 
scheduler can collect data for multiple graphs, and therefore, the statistics chart name need not 
match the data collector scheduler.

Configuring Statistical Data Collection
This section includes the following topics:

• Starting and Stopping Statistical Data Collection, page 30-3

• Using Modes in Statistics Charts, page 30-4

• Deleting Statistical Data from a Collection, page 30-5

• Deleting a Collection, page 30-6

• Deleting Data from the Statistics Database, page 30-6

• Enabling and Disabling Automatic Statistical Data Purging, page 30-7

• Configuring Automatic Statistical Data Purge Settings, page 30-8

• Purging Statistical Data Now, page 30-9

Starting and Stopping Statistical Data Collection
You can use the Statistical Data Collection feature to start and stop a statistical data collection process. 
Each collection process represents a statistical monitoring process that you created by starting 
monitoring for a device configuration feature.

DETAILED STEPS

Step 1 From the Feature Selector pane, choose DCNM Server Administration > Statistical Data Collection. 

A table of statistical data collectors appears in the Contents pane. Each row corresponds to a collector 
for a particular device. The Status field displays whether the collector is running or is stopped.

Step 2 Click the collector that you want to start or stop.
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Step 3 Do one of the following:

• To start a collector, from the menu bar, choose Actions > Start Collection. The Status field changes 
to Running.

• To stop a collector, from the menu bar, choose Actions > Stop Collection. The Status field changes 
to Stopped.

You do not need to save your changes.

Using Modes in Statistics Charts
You use statistics charts to toggle between the delta mode and the rate mode. The below table lists the 
features that contain statistics charts and delta mode/rate mode toggle button.

DETAILED STEPS

Step 1 From the Feature Selector pane, choose the appropriate feature. For example, if you wanted to see 
statistics for the Ethernet feature, choose Interfaces > Physical > Ethernet.

The available devices appear in the Summary pane.

Path Feature

Interfaces > Physical Ethernet Interface

Interfaces > Physical Management Interface

Interfaces > Logical Loopback Interface

Interfaces > Logical Port Channel

Interfaces > Logical vPC

Switching VLAN

Switching > Spanning Tree Rapid PVST+

Switching > Spanning Tree MST

Switching > Fabricpath ISIS Process

Switching > Layer 2 Security Port Security

Switching > Layer 2 Security ARP Inspection

Switching > Layer 2 Security DHCP Snooping

Switching > Layer 2 Security Traffic Storm Control

Switching > Layer 2 Security IGMP Snooping

Security DOT1x

Security > Access Control IPv4 ACL

Security > Access Control IPv6 ACL

Security > Access Control MAC ACL

Security > AAA Server Groups

Inventory Virtual Switch
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Step 2 From the Summary pane, double-click the device.

Step 3 From the Summary pane, double-click Slots.

Step 4 Click the interface.

Step 5 From the Details pane, choose the Statistics tab.

Step 6 In the toolbar, click New Chart and then from the menu bar drop-down list, choose the chart that you 
want to view. For example, if you wanted to see statistics for traffic, choose Traffic Statistics Chart.

Step 7 (Optional) To toggle between the statistics mode and the rate mode, click the button to the right of the 
Select Frequency drop-down list.

RELATED TOPICS

• Deleting Statistical Data from a Collection, page 30-5

• Deleting a Collection, page 30-6

Deleting Statistical Data from a Collection
You can delete statistical data from a collection. This feature allows you to delete all the data from a 
collection without affecting data from other collections and without deleting the collection itself. Each 
collection process represents a statistical monitoring process that you created by starting monitoring for 
a device configuration feature.

DETAILED STEPS

Step 1 From the Feature Selector pane, choose DCNM Server Administration > Statistical Data Collection. 

A table of statistical data collectors appears in the Contents pane. Each row corresponds to a collector 
for a particular device. Devices are listed alphabetically. The Status field displays whether the collector 
is running or is stopped.

Step 2 Right-click the collection.

Step 3 From the menu bar, choose Actions > Delete Statistical Data.

DCNM-LAN deletes all statistical data from the collection.

RELATED TOPICS

• Starting and Stopping Statistical Data Collection, page 30-3

• Deleting a Collection, page 30-6

• Deleting Data from the Statistics Database, page 30-6

• Starting Statistical Monitoring for a Chart, page 14-12
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Deleting a Collection
You can delete a collection of statistical data from a specific device. Each collection process represents 
a statistical monitoring process that you created by starting monitoring for a device configuration 
feature.

Note If you want to delete all data from a collections rather than deleting the collection itself, perform the 
steps in the “Deleting Statistical Data from a Collection” section on page 30-5.

BEFORE YOU BEGIN

Determine which collection of data you want to delete.

DETAILED STEPS

Step 1 From the Feature Selector pane, choose DCNM Server Administration > Statistical Data Collection. 

A table of statistical data collectors appears in the Contents pane. Devices are listed alphabetically. Each 
row corresponds to a collection of statistical data for a particular device.

Step 2 Click the collection of data that you want to delete.

Step 3 From the menu bar, choose Actions > Delete Collection.

The collection is deleted.

You do not need to save your changes.

RELATED TOPICS

• Starting and Stopping Statistical Data Collection, page 30-3

• Deleting Statistical Data from a Collection, page 30-5

• Deleting Data from the Statistics Database, page 30-6

• Starting Statistical Monitoring for a Chart, page 14-12

Deleting Data from the Statistics Database
You can delete statistical data from the statistics database.

Note If you want to delete all data from a specific collection rather than deleting old data from all collections, 
perform the steps in the “Deleting a Collection” section on page 30-6.

BEFORE YOU BEGIN

Determine the date and time of the newest statistical data that you want to delete. When you follow the 
steps in this procedure, DCNM-LAN deletes all statistics that are older than the date and time that you 
select.
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DETAILED STEPS

Step 1 From the Feature Selector pane, choose DCNM Server Administration > Statistical Data Collection.

The Statistics Database area appears in the Contents pane, below the table of statistical data collectors.

Step 2 From the Delete statistical data older than drop-down list, select the date and time of the newest statistics 
that you want to delete and click OK.

Step 3 Click Delete.

DCNM-LAN deletes all statistics older than the date and time that you specified.

RELATED TOPICS

• Deleting Statistical Data from a Collection, page 30-5

• Deleting a Collection, page 30-6

• Enabling and Disabling Automatic Statistical Data Purging, page 30-7

• Configuring Automatic Statistical Data Purge Settings, page 30-8

• Purging Statistical Data Now, page 30-9

Enabling and Disabling Automatic Statistical Data Purging
You can enable or disable the automatic purging of statistical data from the DCNM-LAN statistics 
database.

DETAILED STEPS

Step 1 From the Feature Selector pane, choose DCNM Server Administration > Statistical Data Collection.

The Statistical Database Administration tab appears in the Details pane, below the table of statistical 
data collectors.

Step 2 Under Auto Purge Settings, do one of the following:

• To enable automatic statistical data purging, check Enable Auto Purge.

• To disable automatic statistical data purging, uncheck Enable Auto Purge.

Step 3 From the menu bar, choose File > Deploy to save your changes to the DCNM-LAN server.

RELATED TOPICS

• Deleting Data from the Statistics Database, page 30-6

• Configuring Automatic Statistical Data Purge Settings, page 30-8

• Purging Statistical Data Now, page 30-9
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Configuring Automatic Statistical Data Purge Settings
You can configure when automatic statistical data purging occurs and the criteria that DCNM-LAN uses 
to determine which statistical data to purge.

BEFORE YOU BEGIN

Determine when you want automatic statistical data purging to occur. A good recommendation is that 
you configure automatic statistical data purging to occur when DCNM-LAN usage is low.

If you perform backups of your DCNM-LAN databases, consider scheduling automatic statistical data 
purging after database backups have occurred, to ensure that you retain a record of all statistical data.

Determine what criteria you want DCNM-LAN to use to determine which statistical data to purge. The 
two criteria available are as follows:

• Age of statistical data—DCNM-LAN can purge all statistical data entries that are older than a 
specific number of days, weeks, or months.

• Number of statistical data entries in the database—When the number of statistical data entries in the 
database exceeds the maximum number that you specify, DCNM-LAN can purge the oldest 
statistical data entries first until the maximum number is not exceeded.

If you enable both criteria, DCNM-LAN applies them independently of each other.

DETAILED STEPS

Step 1 From the Feature Selector pane, choose DCNM Server Administration > Statistical Data Collection.

The Statistical Database Administration tab appears in the Details pane, below the table of statistical 
data collectors.

Step 2 Under Purge Threshold, configure the criteria that DCNM-LAN uses to determine which statistical data 
to purge. You can configure either or both of the criteria using the information in Table 30-1.

Table 30-1 Purge Criteria

Step 3 Configure the action that you want DCNM-LAN to take on statistical database entries that meet the 
purge criteria. You can choose one of the following:

Purge Criteria How to Configure

Age of statistical data 1. Check Data older than.

2. From the first drop-down list, choose the 
number of days, weeks, or months.

3. From the second drop-down list, choose 
Days, Weeks, or Months, as needed.

Number of statistical data entries in the database 1. Check Stats. Entries 
Exceed(0-2147483647).

2. In the box, enter the maximum number of 
entries that you want to allow in the statistical 
database.
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• Delete—DCNM-LAN deletes the database entries that meet the purge criteria.

• Consolidate—DCNM-LAN merges all statistical data entries that meet the purge criteria into one 
entry

Step 4 Under Auto Purge Settings, follow these steps to configure when you want automatic purging to occur:

a. Check the days-of-the-week check boxes to specify which days of the week that you want automatic 
purging to occur.

b. Use the Run at box to configure the exact time on the specified days that you want automatic 
statistical data purging to occur.

Step 5 (Optional) If you want to enable automatic statistical data purging, check Enable Auto Purge.

Step 6 From the menu bar, choose File > Deploy to save your changes to the DCNM-LAN server.

RELATED TOPICS

• Deleting Data from the Statistics Database, page 30-6

• Enabling and Disabling Automatic Statistical Data Purging, page 30-7

• Purging Statistical Data Now, page 30-9

Purging Statistical Data Now
You can purge statistical data on demand, using the automatic statistical data purge settings to determine 
which statistical data are purged.

Tip If you want to delete statistical data on demand, based on the exact age of the statistical data entries, see 
the “Deleting Data from the Statistics Database” section on page 30-6.

BEFORE YOU BEGIN

Ensure that the automatic statistical data purge settings are configured as needed. For more information, 
see the “Configuring Automatic Statistical Data Purge Settings” section on page 30-8.

DETAILED STEPS

Step 1 From the Feature Selector pane, choose DCNM Server Administration > Statistical Data Collection.

The Statistical Database Administration tab appears in the Details pane, below the table of statistical 
data collectors.

Step 2 Under Purge, click Purge Now.

DCNM-LAN deletes statistical data, using the automatic statistical data purge settings to determine 
which statistical data entries to purge.

RELATED TOPICS

• Deleting Data from the Statistics Database, page 30-6
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• Enabling and Disabling Automatic Statistical Data Purging, page 30-7

• Configuring Automatic Statistical Data Purge Settings, page 30-8

Viewing the Status of Statistical Data Collectors
To view the status of statistical data collectors, from the Feature Selector pane, choose DCNM Server 
Administration > Statistical Data Collection.

Collector status and other information appear in the Statistical Data Collectors area in the Contents pane. 
For information about the fields that appear, see the “Field Descriptions for Statistical Data Collection” 
section on page 30-10.

Field Descriptions for Statistical Data Collection
This section includes the following field descriptions for the Statistical Data Collection feature:

• Summary Pane, page 30-10

• Statistical Database Administration Tab, page 30-11

Summary Pane

Table 30-2 Summary Pane

Field Description

Statistical Data Collectors

Last Refresh Time Display only. Date and time that the DCNM-LAN client updated information 
shown on the Content pane.

Collector ID Display only. Name and IP address of the device for the corresponding 
poller.

Owner Display only. Username of the DCNM-LAN user who started monitoring for 
the chart that corresponds to the collection.

Device Display only. Name and IP address of the device that is providing the 
statistical data in the collection.

Objects Display only. Description of the entity on the device that is providing the 
statistical data in the collection.

For example, if the collection has statistical data for a rule that is assigned 
the sequence number 10 and is in an IPv4 ACL named acl-01, this field 
displays acl-01,seqNo=10. 

If the collection has data for the Ethernet 1/5 port, this field displays 
Ethernet1/5.

Collected Statistics Display only. Type of statistical data in the collection. For example, if the 
collection has statistical data for a rule in an IPv4 ACL, this field displays 
IpAclAceMatchStatistics.

Status Display only. Whether the collector is started or stopped.
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Statistical Database Administration Tab

Additional References
For additional information related to administering statistical data collection, see the following sections:

• Related Documents, page 30-12

• Standards, page 30-12

Statistics Database

Delete statistical data 
older than

Date and time of the newest statistical data to be deleted from the statistics 
database. There is no default value for this field.

Table 30-3 Statistical Database Administration Tab

Field Description

Delete statistical data 
older than

Date and time of the newest statistical data to be deleted from the statistics 
database. There is no default value for this field.

Purge

Action Whether automatic statistical data purging deletes or consolidates statistical 
data entries that trigger the purge threshold. Consolidation merges all 
statistical data entries that trigger the purge threshold into one entry.

Purge Threshold

Data older than Whether, during automatic statistical data purging, DCNM-LAN deletes 
statistics entries that are older than the age specified in the drop-down lists 
located to the right of this check box. By default, this check box is 
unchecked. If you check the check box, the default age is 1 day.

Stat. Entries Exceed Whether, during automatic statistical data purging, DCNM-LAN deletes the 
oldest statistics entries until the number of entries equals the number in the 
box located to the right of this check box. By default, this check box is 
unchecked. If you check the check box, the default number of event is 
25,000.

Auto Purge Settings

Enable Auto Purge Whether automatic purging of statistical data is enabled. By default, this 
check box is disabled.

Run on Days of the week that automatic purging of statistical data occurs. By 
default, none of the check boxes are checked. If you check the Daily check 
box, the check boxes for the individual days of the week become unavailable.

Run at Time of day that automatic purging of statistical data occurs, on the days of 
the week that automatic purging is enabled.

Table 30-2 Summary Pane (continued)

Field Description
30-11
Cisco Prime DCNM Fundamentals Guide, Release 7.2.x



Chapter 30      Administering Statistical Data Collection
Feature History for Statistical Data Collection
Related Documents

Standards

Feature History for Statistical Data Collection
Table 30-4 lists the release history for this feature.

Related Topic Document Title

Device discovery Chapter 27, “Administering Device Discovery”

Standards Title

No new or modified standards are supported by this 
feature, and support for existing standards has not been 
modified by this feature.

—

Table 30-4 Feature History for Statistical Data Collection

Feature Name Releases Feature Information

Statistical Data Collection 5.0(2) No change from Release 4.2.
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