Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 6.x
Configuring VRRP
Downloads: This chapterpdf (PDF - 276.0KB) The complete bookPDF (PDF - 6.2MB) | The complete bookePub (ePub - 1.41MB) | The complete bookMobi (Mobi - 2.5MB) | Feedback

Table of Contents

Configuring VRRP

Finding Feature Information

Information About VRRP

VRRP Operation

VRRP Benefits

Multiple VRRP Groups

VRRP Router Priority and Preemption

vPC and VRRP

VRRP Advertisements

VRRP Authentication

VRRP Tracking

BFD

High Availability

Virtualization Support

Information About VRRPv3

VRRPv3 Benefits

VRRS

Using VRRS with VRRPv3

High Availability

Licensing Requirements for VRRP

Guidelines and Limitations for VRRP

Guidelines and Limitations for VRRPv3

Default Settings

Configuring VRRP

Enabling the VRRP Feature

Configuring VRRP Groups

Configuring VRRP Priority

Configuring VRRP Authentication

Configuring Time Intervals for Advertisement Packets

Disabling Preemption

Configuring VRRP Interface State Tracking

Configuring VRRPv3

Enabling the VRRPv3 Feature

Creating VRRPv3 Groups

Configuring the Delay Period for FHRP Client Initialization

Configuring VRRPv3 Control Groups

Configuring VRRS Pathways

Verifying the VRRP Configuration

Monitoring VRRP Statistics

Configuration Examples for VRRP

Configuration Examples for VRRPv3

Additional References

Related Documents

Feature History for VRRP

Finding Feature Information

Your software release might not support all the features documented in this module. For the latest caveats and feature information, see the Bug Search Tool at https//tool.cisco.com/bugsearch/ and the release notes for your software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the New and Changed Information section or the Feature History table below.

Information About VRRP

VRRP allows for transparent failover at the first-hop IP router by configuring a group of routers to share a virtual IP address. VRRP selects a master router in that group to handle all packets for the virtual IP address. The remaining routers are in standby and take over if the master router fails.

This section includes the following topics:

VRRP Operation

A LAN client can determine which router should be the first hop to a particular remote destination by using a dynamic process or static configuration. Examples of dynamic router discovery are as follows:

  • Proxy ARP—The client uses Address Resolution Protocol (ARP) to get the destination it wants to reach, and a router responds to the ARP request with its own MAC address.
  • Routing protocol—The client listens to dynamic routing protocol updates (for example, from Routing Information Protocol [RIP]) and forms its own routing table.
  • ICMP Router Discovery Protocol (IRDP) client—The client runs an Internet Control Message Protocol (ICMP) router discovery client.

The disadvantage to dynamic discovery protocols is that they incur some configuration and processing overhead on the LAN client. Also, if a router fails, the process of switching to another router can be slow.

An alternative to dynamic discovery protocols is to statically configure a default router on the client. Although, this approach simplifies client configuration and processing, it creates a single point of failure. If the default gateway fails, the LAN client is limited to communicating only on the local IP network segment and is cut off from the rest of the network.

VRRP can solve the static configuration problem by enabling a group of routers (a VRRP group) to share a single virtual IP address. You can then configure the LAN clients with the virtual IP address as their default gateway.

Figure 1-1 shows a basic VLAN topology. In this example, Routers A, B, and C form a VRRP group. The IP address of the group is the same address that was configured for the Ethernet interface of Router A (10.0.0.1).

Figure 1-1 Basic VRRP Topology

 

Because the virtual IP address uses the IP address of the physical Ethernet interface of Router A, Router A is the master (also known as the IP address owner ). As the master, Router A owns the virtual IP address of the VRRP group and forwards packets sent to this IP address. Clients 1 through 3 are configured with the default gateway IP address of 10.0.0.1.

Routers B and C function as backups. If the master fails, the backup router with the highest priority becomes the master and takes over the virtual IP address to provide uninterrupted service for the LAN hosts. When router A recovers, it becomes the master again. For more information, see the “VRRP Router Priority and Preemption” section.


NoteIn Cisco NX-OS Release 4.1(2) and later, packets received on a routed port destined for the VRRP virtual IP address terminates on the local router, regardless of whether that router is the master VRRP router or a backup VRRP router. This includes ping and Telnet traffic. Packets received on a Layer 2 (VLAN) interface destined for the VRRP virtual IP address terminates on the master router. In Cisco NX-OS Release 4.1(2) and later, packets received on a routed port destined for the VRRP virtual IP address terminates on the local router, regardless of whether that router is the master VRRP router or a backup VRRP router. This includes ping and Telnet traffic. Packets received on a Layer 2 (VLAN) interface destined for the VRRP virtual IP address terminates on the master router.


VRRP Benefits

The benefits of VRRP are as follows:

  • Redundancy—Enables you to configure multiple routers as the default gateway router, which reduces the possibility of a single point of failure in a network.
  • Load sharing—Allows traffic to and from LAN clients to be shared by multiple routers. The traffic load is shared more equitably among available routers.
  • Multiple VRRP groups—Supports multiple VRRP groups on a router physical interface if the platform supports multiple MAC addresses. Multiple VRRP groups enable you to implement redundancy and load sharing in your LAN topology.
  • Multiple IP addresses—Allows you to manage multiple IP addresses, including secondary IP addresses. If you have multiple subnets configured on an Ethernet interface, you can configure VRRP on each subnet.
  • Preemption—Enables you to preempt a backup router that has taken over for a failing master with a higher priority backup router that has become available.
  • Advertisement protocol—Uses a dedicated Internet Assigned Numbers Authority (IANA) standard multicast address (224.0.0.18) for VRRP advertisements. This addressing scheme minimizes the number of routers that must service the multicasts and allows test equipment to accurately identify VRRP packets on a segment. IANA has assigned the IP protocol number 112 to VRRP.
  • VRRP tracking—Ensures that the best VRRP router is the master for the group by altering VRRP priorities based on interface states.

Multiple VRRP Groups

You can configure multiple VRRP groups on a physical interface. For the number of supported VRRP groups, see the Cisco Nexus 7000 Series NX-OS Verified Scalability Guide .

The number of VRRP groups that a router interface can support depends on the following factors:

  • Router processing capability
  • Router memory capability

In a topology where multiple VRRP groups are configured on a router interface, the interface can act as a master for one VRRP group and as a backup for one or more other VRRP groups.

Figure 1-2 shows a LAN topology in which VRRP is configured so that Routers A and B share the traffic to and from clients 1 through 4. Routers A and B act as backups to each other if either router fails.

Figure 1-2 Load Sharing and Redundancy VRRP Topology

This topology contains two virtual IP addresses for two VRRP groups that overlap. For VRRP group 1, Router A is the owner of IP address 10.0.0.1 and is the master. Router B is the backup to Router A. Clients 1 and 2 are configured with the default gateway IP address of 10.0.0.1.

For VRRP group 2, Router B is the owner of IP address 10.0.0.2 and is the master. Router A is the backup to router B. Clients 3 and 4 are configured with the default gateway IP address of 10.0.0.2.

VRRP Router Priority and Preemption

An important aspect of the VRRP redundancy scheme is the VRRP router priority because the priority determines the role that each VRRP router plays and what happens if the master router fails.

If a VRRP router owns the virtual IP address and the IP address of the physical interface, this router functions as the master. The priority of the master is 255.

Priority also determines if a VRRP router functions as a backup router and the order of ascendancy to becoming a master if the master fails.

For example, if Router A, the master in a LAN topology, fails, VRRP must determine if backups B or C should take over. If you configure Router B with priority 101 and Router C with the default priority of 100, VRRP selects Router B to become the master because it has the higher priority. If you configure routers B and C with the default priority of 100, VRRP selects the backup with the higher IP address to become the master.

VRRP uses preemption to determine what happens after a VRRP backup router becomes the master. With preemption enabled by default, VRRP switches to a backup if that backup comes online with a priority higher than the new master. For example, if Router A is the master and fails, VRRP selects Router B (next in order of priority). If Router C comes online with a higher priority than Router B, VRRP selects Router C as the new master, even though Router B has not failed.

If you disable preemption, VRRP switches only if the original master recovers or the new master fails.

vPC and VRRP

VRRP interoperates with virtual port channels (vPCs). vPCs allow links that are physically connected to two different Cisco Nexus 7000 series devices to appear as a single port channel by a third device. See the Cisco Nexus 7000 Series NX-OS Layer 2 Switching Configuration Guide for more information on vPCs.

vPC forwards traffic through both the master VRRP router as well as the backup VRRP router. See the “Configuring VRRP Priority” section.


NoteYou should configure VRRP on the primary vPC peer device as active and VRRP on the vPC secondary device as standby. You should configure VRRP on the primary vPC peer device as active and VRRP on the vPC secondary device as standby.


VRRP Advertisements

The VRRP master sends VRRP advertisements to other VRRP routers in the same group. The advertisements communicate the priority and state of the master. Cisco NX-OS encapsulates the VRRP advertisements in IP packets and sends them to the IP multicast address assigned to the VRRP group. Cisco NX-OS sends the advertisements once every second by default, but you can configure a different advertisement interval.

VRRP Authentication

VRRP supports the following authentication functions:

  • No authentication
  • Plain text authentication

VRRP rejects packets in any of the following cases:

  • The authentication schemes differ on the router and in the incoming packet.
  • Text authentication strings differ on the router and in the incoming packet.

VRRP Tracking

VRRP supports the following two options for tracking:

  • Native interface tracking— Tracks the state of an interface and uses that state to determine the priority of the VRRP router in a VRRP group. The tracked state is down if the interface is down or if the interface does not have a primary IP address.
  • Object tracking—Tracks the state of a configured object and uses that state to determine the priority of the VRRP router in a VRRP group. See Chapter 1, “Configuring Object Tracking” for more information on object tracking.

If the tracked state (interface or object) goes down, VRRP updates the priority based on what you configure the new priority to be for the tracked state. When the tracked state comes up, VRRP restores the original priority for the virtual router group.

For example, you may want to lower the priority of a VRRP group member if its uplink to the network goes down so another group member can take over as master for the VRRP group. See the “Configuring VRRP Interface State Tracking” section for more information.


NoteVRRP does not support Layer 2 interface tracking. VRRP does not support Layer 2 interface tracking.


BFD

This feature supports bidirectional forwarding detection (BFD). BFD is a detection protocol that provides fast-forwarding and path-failure detection times. BFD provides subsecond failure detection between two adjacent devices and can be less CPU-intensive than protocol hello messages because some of the BFD load can be distributed onto the data plane on supported modules. See the Cisco Nexus 7000 Series NX-OS Interfaces Configuration Guide for more information.

High Availability

VRRP supports high availability through stateful restarts and stateful switchovers. A stateful restart occurs when the VRRP process fails and is restarted. Stateful switchover occurs when the active supervisor switches to the standby supervisor. Cisco NX-OS applies the run-time configuration after the switchover.

Virtualization Support

VRRP supports virtual routing and forwarding (VRF) instances. VRF exists within virtual device contexts (VDCs). By default, Cisco NX-OS places you in the default VDC and default VRF unless you specifically configure another VDC and VRF.

If you change the VRF membership of an interface, Cisco NX-OS removes all Layer 3 configurations, including VRRP.

For more information, see the Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide and Chapter1, “Configuring Layer 3 Virtualization”

Information About VRRPv3

VRRP version 3 (VRRPv3) enables a group of switches to form a single virtual switch in order to provide redundancy and reduce the possibility of a single point of failure in a network. The LAN clients can then be configured with the virtual switch as their default gateway. The virtual switch, representing a group of switches, is also known as a VRRPv3 group.

This section includes the following topics:

VRRPv3 Benefits

The benefits of VRRPv3 are as follows:

  • Interoperability in multi-vendor environments.
  • Support for the IPv4 and IPv6 address families.
  • Improved scalability through the use of VRRS pathways.

VRRS

Virtual router redundancy service (VRRS) improves the scalability of VRRPv3 by providing a stateless redundancy service to VRRS pathways and VRRS clients by monitoring VRRPv3. VRRPv3 acts as a VRRS server that pushes VRRPv3 status information (such as current and previous redundancy states, active and inactive Layer 2 and Layer 3 addresses, and so on) to VRRS pathways and all registered VRRS clients.

VRRS clients are other Cisco processes or applications that use VRRPv3 to provide or withhold a service or resource dependent upon the state of the group. VRRS pathways are special VRRS clients that use the VRRS database information to provide scaled first-hop gateway redundancy across scaled interface environments.

VRRS by itself is limited to maintaining its own state. Linking a VRRS client to a VRRPv3 group provides a mechanism that allows VRRS to provide a service to client applications so that they can implement stateless or stateful failovers. A stateful failover requires communication with a nominated backup before the failure so that operational data is not lost when the failover occurs.

VRRS pathways operate in a similar way to clients but are integrated with the VRRS architecture. They provide a means to scale first-hop gateway redundancy by allowing you to configure a virtual address across hundreds of interfaces. The virtual gateway state of a VRRS pathway follows the state of a First-Hop Redundancy Protocol (FHRP) VRRS server.

Using VRRS with VRRPv3

VRRPv3 notifies VRRS of its current state (master, backup, or nonoperational initial state [INIT]) and passes that information to pathways or clients. The VRRPv3 group name activates VRRS and associates the VRRPv3 group with any clients or pathways that are configured as part of VRRS with the same name.

Pathways and clients act on the VRRPv3 server state. When a VRRPv3 group changes states, VRRS pathways and clients alter their behavior (performing tasks such as shutting down interfaces or appending accounting logs) depending on the state received from VRRS.

High Availability

VRRPv3 does not support stateful switchovers.

Licensing Requirements for VRRP

The following table shows the licensing requirements for this feature:

 

Product
License Requirement

Cisco NX-OS

VRRP requires no license. Any feature not included in a license package is bundled with the Cisco NX-OS system images and is provided at no extra charge to you. For a complete explanation of the Cisco NX-OS licensing scheme, see the Cisco NX-OS Licensing Guide .

Guidelines and Limitations for VRRP

VRRP has the following configuration guidelines and limitations:

  • You cannot configure VRRP on the management interface.
  • When VRRP is enabled, you should replicate the VRRP configuration across devices in your network.
  • We recommend that you do not configure more than one first-hop redundancy protocol on the same interface.
  • You must configure an IP address for the interface that you configure VRRP on and enable that interface before VRRP becomes active.
  • Cisco NX-OS removes all Layer 3 configurations on an interface when you change the interface VRF membership, port channel membership, or when you change the port mode to Layer 2.
  • When you configure VRRP to track a Layer 2 interface, you must shut down the Layer 2 interface and reenable the interface to update the VRRP priority to reflect the state of the Layer 2 interface
  • BFD for VRRP can only be configured between two routers.
  • The VRRP IP address must be different than any physical IP address of the devices participating in the VRRP, otherwise the ARP or MAC entries will be corrupted and may cause forwarding problems.

Guidelines and Limitations for VRRPv3

VRRPv3 has the following configuration guidelines and limitations:

  • VRRPv3 is not intended as a replacement for existing dynamic protocols. VRRPv3 is designed for use over multi-access, multicast, or broadcast-capable Ethernet LANs.
  • VRRPv3 is supported only on Ethernet and Fast Ethernet interfaces, bridge group virtual interfaces (BVIs), and Gigabit Ethernet interfaces as well as on Multiprotocol Label Switching (MPLS) virtual private networks (VPNs), VRF-aware MPLS VPNs, and VLANs.
  • When VRRPv3 is in use, VRRPv2 is unavailable. To configure VRRPv3, you must disable any VRRPv2 configuration.
  • Full network redundancy can be achieved only if VRRPv3 operates over the same network path as the VRRS pathway redundant interfaces. For full redundancy, the following restrictions apply:

– VRRS pathways should use the same physical interface as the parent VRRPv3 group or be configured on a subinterface with the same physical interface as the parent VRRPv3 group.

– VRRS pathways can be configured on switch virtual interfaces (SVIs) only if the associated VLAN shares the same trunk as the VLAN on which the parent VRRPv3 group is configured.

  • VRRS is currently available only for use with VRRPv3.
  • Use VRRPv3 millisecond timers only where absolutely necessary and with careful consideration and testing. Millisecond values work only under favorable circumstances. The millisecond timer values are compatible with third-party vendors, as long as they also support VRRPv3.

Default Settings

Table 1-1 lists the default settings for VRRP parameters.

 

Table 1-1 Default VRRP Parameters

Parameters
Default

VRRP

Disabled

Advertisement interval

1 seconds

Authentication

No authentication

Preemption

Enabled

Priority

100

VRRPv3

Disabled

VRRS

Disabled

VRRPv3 secondary address matching

Enabled

Priority of a VRRPv3 group

100

VRRPv3 advertisement timer

1000 milliseconds

Configuring VRRP

This section includes the following topics:


NoteIf you are familiar with the Cisco IOS CLI, be aware that the Cisco NX-OS commands for this feature might differ from the Cisco IOS commands that you would use. If you are familiar with the Cisco IOS CLI, be aware that the Cisco NX-OS commands for this feature might differ from the Cisco IOS commands that you would use.


Enabling the VRRP Feature

You must globally enable the VRRP feature before you can configure and enable any VRRP groups.

To enable the VRRP feature, use the following command in global configuration mode:

 

Command
Purpose

feature vrrp

 

Example :

switch(config)# feature vrrp

Enables VRRP.

To disable the VRRP feature in a VDC and remove all associated configurations, use the following command in global configuration mode:

 

Command
Purpose

no feature vrrp

 

Example :

switch(config)# no feature vrrp

Disables the VRRP feature in a VDC.

Configuring VRRP Groups

You can create a VRRP group, assign the virtual IP address, and enable the group.

You can configure one virtual IPv4 address for a VRRP group. By default, the master VRRP router drops the packets addressed directly to the virtual IP address because the VRRP master is only intended as a next-hop router to forward packets. Some applications require that Cisco NX-OS accept packets addressed to the virtual router IP. Use the secondary option to the virtual IP address to accept these packets when the local router is the VRRP master.

Once you have configured the VRRP group, you must explicitly enable the group before it becomes active.

BEFORE YOU BEGIN

Ensure that you are in the correct VDC (or use the switchto vdc command).

Ensure that you configure an IP address on the interface (see the “Configuring IPv4 Addressing” section).

SUMMARY STEPS

1. configure terminal

2. interface interface-type slot/port

3. vrrp number

4. address ip-address [ secondary ]

5. no shutdown

6. (Optional) show vrrp

7. (Optional) copy running-config startup-config

DETAILED STEPS

 
Command
Purpose

Step 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

Enters global configuration mode.

Step 2

interface interface - type slot/port

 

Example:

switch(config)# interface ethernet 2/1

switch(config-if)#

Enters interface configuration mode.

Step 3

vrrp number

 

Example:

switch(config-if)# vrrp 250

switch(config-if-vrrp)#

Creates a virtual router group. The range is from 1 to 255.

Step 4

address ip-address [ secondary ]

 

Example:

switch(config-if-vrrp)# address 192.0.2.8

Configures the virtual IPv4 address for the specified VRRP group. This address should be in the same subnet as the IPv4 address of the interface.

Use the secondary option only if applications require that VRRP routers accept the packets sent to the virtual router's IP address and deliver to applications.

Step 5

no shutdown

 

Example :

switch(config-if-vrrp)# no shutdown

switch(config-if-vrrp)#

Enables the VRRP group. Disabled by default.

Step 6

show vrrp

 

Example:

switch(config-if-vrrp)# show vrrp

(Optional) Displays VRRP information.

Step 7

copy running-config startup-config

 

Example:

switch(config-if-vrrp)# copy running-config startup-config

(Optional) Saves this configuration change.

Configuring VRRP Priority

The valid priority range for a virtual router is from 1 to 254 (1 is the lowest priority and 254 is the highest). The default priority value for backups is 100. For devices whose interface IP address is the same as the primary virtual IP address (the master), the default value is 255.

If you configure VRRP on a vPC-enabled interface, you can optionally configure the upper and lower threshold values to control when to fail over to the vPC trunk. If the backup router priority falls below the lower threshold, VRRP sends all backup router traffic across the vPC trunk to forward through the master VRRP router. VRRP maintains this scenario until the backup VRRP router priority increases above the upper threshold.

BEFORE YOU BEGIN

You must enable VRRP (see the “Configuring VRRP” section).

Ensure that you have configured an IP address on the interface (see the “Configuring IPv4 Addressing” section).

Ensure that you are in the correct VDC (or use the switchto vdc command).

SUMMARY STEPS

1. configure terminal

2. interface interface-type slot/port

3. vrrp number

4. shutdown

5. priority leve l [ forwarding-threshold lower lower-value upper upper-value ]

6. no shutdown

7. (Optional) show vrrp

8. (Optional) copy running-config startup-config

DETAILED STEPS

 
Command
Purpose

Step 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

Enters global configuration mode.

Step 2

interface interface-type slot/port

 

Example:

switch(config)# interface ethernet 2/1

switch(config-if)#

Enters interface configuration mode.

Step 3

vrrp number

 

Example:

switch(config-if)# vrrp 250

switch(config-if-vrrp)#

Creates a virtual router group.

Step 4

shutdown

 

Example :

switch(config-if-vrrp)# shutdown

switch(config-if-vrrp)#

Disables the VRRP group. Disabled by default.

Step 5

priority level [ forwarding-threshold lower lower-value upper upper-value ]

 

Example:

switch(config-if-vrrp)# priority 60 forwarding-threshold lower 40 upper 50

 

Sets the priority level used to select the active router in an VRRP group. The level range is from 1 to 254. The default is 100 for backups and 255 for a master that has an interface IP address equal to the virtual IP address.

Optionally, sets the upper and lower threshold values used by vPC to determine when to fail over to the vPC trunk. The lower-value range is from 1 to 255. The default is 1. The upper-value range is from 1 to 255. The default is 255.

Step 6

no shutdown

 

Example :

switch(config-if-vrrp)# no shutdown

switch(config-if-vrrp)#

Enables the VRRP group. Disabled by default.

Step 7

show vrrp

 

Example:

switch(config-if-vrrp)# show vrrp

(Optional) Displays a summary of VRRP information.

Step 8

copy running-config startup-config

 

Example:

switch(config-if-vrrp)# copy running-config startup-config

(Optional) Saves this configuration change.

Configuring VRRP Authentication

You can configure simple text authentication for a VRRP group.

BEFORE YOU BEGIN

Ensure that the authentication configuration is identical for all VRRP devices in the network.

Ensure that you have enabled VRRP (see the “Configuring VRRP” section).

Ensure that you have configured an IP address on the interface (see the “Configuring IPv4 Addressing” section).

Ensure that you are in the correct VDC (or use the switchto vdc command).

SUMMARY STEPS

1. configure terminal

2. interface interface-type slot/port

3. vrrp number

4. shutdown

5. authentication text password

6. no shutdown

7. (Optional) show vrrp

8. (Optional) copy running-config startup-config

DETAILED STEPS

 
Command
Purpose

Step 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

Enters global configuration mode.

Step 2

interface interface-type slot/port

 

Example:

switch(config)# interface ethernet 2/1

switch(config-if)#

Enters interface configuration mode.

Step 3

vrrp number

 

Example:

switch(config-if)# vrrp 250

switch(config-if-vrrp)#

Creates a virtual router group.

Step 4

shutdown

 

Example :

switch(config-if-vrrp)# shutdown

switch(config-if-vrrp)#

Disables the VRRP group. Disabled by default.

Step 5

authentication text password

 

Example:

switch(config-if-vrrp)# authentication text aPassword

Assigns the simple text authentication option and specifies the keyname password. The keyname range is from 1 to 255 characters. We recommend that you use at least 16 characters. The text password is up to eight alphanumeric characters.

Step 6

no shutdown

 

Example :

switch(config-if-vrrp)# no shutdown

switch(config-if-vrrp)#

Enables the VRRP group. Disabled by default.

Step 7

show vrrp

 

Example:

switch(config-if-vrrp)# show vrrp

(Optional) Displays a summary of VRRP information.

Step 8

copy running-config startup-config

 

Example:

switch(config-if-vrrp)# copy running-config startup-config

(Optional) Saves this configuration change.

Configuring Time Intervals for Advertisement Packets

You can configure the time intervals for advertisement packets.

BEFORE YOU BEGIN

You must enable VRRP (see the “Configuring VRRP” section).

Ensure that you have configured an IP address on the interface (see the “Configuring IPv4 Addressing” section).

Ensure that you are in the correct VDC (or use the switchto vdc command).

SUMMARY STEPS

1. configure terminal

2. interface interface-type slot/port

3. vrrp number

4. shutdown

5. advertisement-interval seconds

6. no shutdown

7. (Optional) show vrrp

8. (Optional) copy running-config startup-config

DETAILED STEPS

 
Command
Purpose

Step 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

Enters global configuration mode.

Step 2

interface interface-type slot/port

 

Example:

switch(config)# interface ethernet 2/1

switch(config-if)#

Enters interface configuration mode.

Step 3

vrrp number

 

Example:

switch(config-if)# vrrp 250

switch(config-if-vrrp)#

Creates a virtual router group.

Step 4

shutdown

 

Example :

switch(config-if-vrrp)# shutdown

switch(config-if-vrrp)#

Disables the VRRP group. Disabled by default.

Step 5

advertisement-interval seconds

 

Example:

switch(config-if-vrrp)# advertisement-interval 15

Sets the interval time in seconds between sending advertisement frames. The range is from 1 to 255. The default is 1 second.

Step 6

no shutdown

 

Example :

switch(config-if-vrrp)# no shutdown

switch(config-if-vrrp)#

Enables the VRRP group. Disabled by default.

Step 7

show vrrp

 

Example:

switch(config-if-vrrp)# show vrrp

(Optional) Displays a summary of VRRP information.

Step 8

copy running-config startup-config

 

Example:

switch(config-if-vrrp)# copy running-config startup-config

(Optional) Saves this configuration change.

Disabling Preemption

You can disable preemption for a VRRP group member. If you disable preemption, a higher-priority backup router does not take over for a lower-priority master router. Preemption is enabled by default.

BEFORE YOU BEGIN

You must enable VRRP (see the “Configuring VRRP” section).

Ensure that you have configured an IP address on the interface (see the “Configuring IPv4 Addressing” section).

Ensure that you are in the correct VDC (or use the switchto vdc command).

SUMMARY STEPS

1. configure terminal

2. interface interface-type slot/port

3. vrrp number

4. shutdown

5. no preempt

6. no shutdown

7. (Optional) show vrrp

8. (Optional) copy running-config startup-config

DETAILED STEPS

 
Command
Purpose

Step 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

Enters global configuration mode.

Step 2

interface interface-type slot/port

 

Example:

switch(config)# interface ethernet 2/1

switch(config-if)#

Enters interface configuration mode.

Step 3

vrrp number

 

Example:

switch(config-if)# vrrp 250

switch(config-if-vrrp)#

Creates a virtual router group.

Step 4

no shutdown

 

Example :

switch(config-if-vrrp)# no shutdown

Enables the VRRP group. Disabled by default.

Step 5

no preempt

 

Example:

switch(config-if-vrrp)# no preempt

Disables the preempt option and allows the master to remain when a higher-priority backup appears.

Step 6

no shutdown

 

Example :

switch(config-if-vrrp)# no shutdown

Enables the VRRP group. Disabled by default.

Step 7

show vrrp

 

Example:

switch(config-if-vrrp)# show vrrp

(Optional) Displays a summary of VRRP information.

Step 8

copy running-config startup-config

 

Example:

switch(config-if-vrrp)# copy running-config startup-config

(Optional) Saves this configuration change.

Configuring VRRP Interface State Tracking

Interface state tracking changes the priority of the virtual router based on the state of another interface in the device. When the tracked interface goes down or the IP address is removed, Cisco NX-OS assigns the tracking priority value to the virtual router. When the tracked interface comes up and an IP address is configured on this interface, Cisco NX-OS restores the configured priority to the virtual router (see the“Configuring VRRP Priority” section).


NoteFor interface state tracking to function, you must enable preemption on the interface. For interface state tracking to function, you must enable preemption on the interface.



NoteVRRP does not support Layer 2 interface tracking. VRRP does not support Layer 2 interface tracking.


BEFORE YOU BEGIN

You must enable VRRP (see the “Configuring VRRP” section).

Ensure that you have configured an IP address on the interface (see the “Configuring IPv4 Addressing” section).

Ensure that you have enabled the virtual router (see the “Configuring VRRP Groups” section).

Ensure that you are in the correct VDC (or use the switchto vdc command).

SUMMARY STEPS

1. configure terminal

2. interface interface-type slot/port

3. vrrp number

4. shutdown

5. track interface type number priority value

6. no shutdown

7. (Optional) show vrrp

8. (Optional) copy running-config startup-config

DETAILED STEPS

 
Command
Purpose

Step 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

Enters global configuration mode.

Step 2

interface interface-type slot/port

 

Example:

switch(config)# interface ethernet 2/1

switch(config-if)#

Enters interface configuration mode.

Step 3

vrrp number

 

Example:

switch(config-if)# vrrp 250

switch(config-if-vrrp)#

Creates a virtual router group.

Step 4

shutdown

 

Example :

switch(config-if-vrrp)# shutdown

switch(config-if-vrrp)#

Disables the VRRP group. Disabled by default.

Step 5

track interface type number priority value

 

Example:

switch(config-if-vrrp)# track interface ethernet 2/10 priority 254

Enables interface priority tracking for a VRRP group. The priority range is from 1 to 254.

Step 6

no shutdown

 

Example :

switch(config-if-vrrp)# no shutdown

switch(config-if-vrrp)#

Enables the VRRP group. Disabled by default.

Step 7

show vrrp

 

Example:

switch(config-if-vrrp)# show vrrp

(Optional) Displays a summary of VRRP information.

Step 8

copy running-config startup-config

 

Example:

switch(config-if-vrrp)# copy running-config startup-config

(Optional) Saves this configuration change.

Configuring VRRPv3

This section includes the following topics:


NoteIf you are familiar with the Cisco IOS CLI, be aware that the Cisco NX-OS commands for this feature might differ from the Cisco IOS commands that you would use. If you are familiar with the Cisco IOS CLI, be aware that the Cisco NX-OS commands for this feature might differ from the Cisco IOS commands that you would use.


Enabling the VRRPv3 Feature

You must globally enable the VRRPv3 feature before you can configure and enable any VRRPv3 groups.

To enable the VRRPv3 feature, use the following command in global configuration mode:

 

Command
Purpose

feature vrrpv3

 

Example :

switch(config)# feature vrrpv3

Enables VRRP version 3 and Virtual Router Redundancy Service (VRRS).

Note If VRRPv2 is currently configured, use the no feature vrrp command in global configuration mode to remove the VRRPv2 configuration and then use the feature vrrpv3 command to enable VRRPv3.

To disable the VRRPv3 feature in a VDC and remove all associated configurations, use the following command in global configuration mode:

 

Command
Purpose

no feature vrrpv3

 

Example :

switch(config)# no feature vrrpv3

Disables VRRPv3 and VRRS in a VDC.

Creating VRRPv3 Groups

You can create a VRRPv3 group, assign the virtual IP address, and enable the group.

BEFORE YOU BEGIN

Ensure that the VRRPv3 feature is enabled.

Ensure that you are in the correct VDC (or use the switchto vdc command).

Ensure that you configure an IP address on the interface (see the “Configuring IPv4 Addressing” section).

SUMMARY STEPS

1. configure terminal

2. interface interface-type slot/port

3. vrrpv3 number address-family { ipv4 | ipv6 }

4. (Optional) address ip-address [ primary | secondary ]

5. (Optional) description description

6. (Optional) match-address

7. (Optional) preempt [delay minimum seconds ]

8. (Optional) priority level

9. (Optional) timers advertise interval

10. (Optional) vrrpv2

11. (Optional) vrrs leader vrrs-leader-name

12. (Optional) shutdown

13. (Optional) show fhrp [ interface-type interface-number] [verbose]

14. (Optional) copy running-config startup-config

DETAILED STEPS

 
Command
Purpose

Step 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

Enters global configuration mode.

Step 2

interface interface - type slot/port

 

Example:

switch(config)# interface ethernet 2/1

switch(config-if)#

Enters interface configuration mode.

Step 3

vrrpv3 number address-family { ipv4 | ipv6 }

 

Example:

switch(config-if)# vrrpv3 5 address-family

ipv4

switch(config-if-vrrpv3-group)#

Creates a VRRPv3 group and enters VRRPv3 group configuration mode. The range is from 1 to 255.

Step 4

address ip-address [ primary | secondary ]

 

Example:

switch(config-if-vrrpv3-group)# address

100.0.1.10 primary

(Optional) Specifies a primary or secondary IPv4 or IPv6 address for the VRRPv3 group.

Note To utilize secondary IP addresses in a VRRPv3 group, you must first configure a primary IP address on the same group.

Step 5

description description

 

Example:

switch(config-if-vrrpv3-group)# description

group3

(Optional) Specifies a description for the VRRPv3 group. You can enter up to 80 alphanumeric characters.

Step 6

match-address

 

Example:

switch(config-if-vrrpv3-group)# match-address

(Optional) Matches the secondary address in the advertisement packet against the configured address.

Step 7

preempt [ delay minimum seconds ]

 

Example:

switch(config-if-vrrpv3-group)# preempt

delay minimum 30

(Optional) Enables preemption of a lower priority master switch with an optional delay. The range is from 0 to 3600.

Step 8

priority level

 

Example:

switch(config-if-vrrpv3-group)# priority 3

(Optional) Specifies the priority of the VRRPv3 group. The range is from 1 to 254.

Step 9

timers advertise interval

 

Example:

switch(config-if-vrrpv3-group)# timers advertise 1000

(Optional) Sets the advertisement timer in milliseconds. The range is from 100 to 40950.

Note Cisco recommends that you set this timer to a value greater than or equal to 1 second.

Step 10

vrrpv2

 

Example:

switch(config-if-vrrpv3-group)# vrrpv2

(Optional) Enables support for VRRPv2 simultaneously, to ensure interoperability with devices that support only VRRPv2.

Note VRRPv2 compatibility mode is provided to allow an upgrade from VRRPv2 to VRRPv3. This is not a full VRRPv2 implementation and should be used only to perform an upgrade.

Step 11

vrrs leader vrrs-leader-name

 

Example:

switch(config-if-vrrpv3-group)# vrrs leader leader1

(Optional) Specifies a leader’s name to be registered with VRRS.

Step 12

shutdown

 

Example :

switch(config-if-vrrp3-group)# shutdown

(Optional) Disables VRRP configuration for the VRRPv3 group.

Step 13

show fhrp [ interface-type interface-number ] [verbose]

 

Example:

switch(config-if-vrrp3-group)# show fhrp port-channnel 101 verbose

(Optional) Displays First Hop Redundancy Protocol (FHRP) information.

Use the verbose keyword to view detailed information.

Step 14

copy running-config startup-config

 

Example:

switch(config-if-vrrp3-group)# copy running-config startup-config

(Optional) Saves this configuration change.

Configuring the Delay Period for FHRP Client Initialization

You can configure the delay period for the initialization of FHRP clients.

To configure this feature, use the following command in interface configuration mode:

 

Command
Purpose

fhrp delay {[ minimum ] [ reload ] seconds }

 

Example :

switch(config)# fhrp delay minimum 34

Specifies the delay period for the initialization of FHRP clients. The range is from 0 to 3600 seconds.

The minimum keyword configures the delay period after an interface beomes available.

The reload command configures the delay period after the device reloads.

Configuring VRRPv3 Control Groups

You can configure a VRRPv3 control group.

BEFORE YOU BEGIN

Ensure that the VRRPv3 feature is enabled.

Ensure that you are in the correct VDC (or use the switchto vdc command).

Ensure that you configure an IP address on the interface (see the “Configuring IPv4 Addressing” section).

SUMMARY STEPS

1. configure terminal

2. interface interface-type slot/port

3. ip address ip-address mask [ secondary ]

4. vrrpv3 number address-family { ipv4 | ipv6 }

5. (Optional) address ip-address [ primary | secondary ]

6. (Optional) vrrs leader vrrs-leader-name

7. (Optional) show fhrp [ interface-type interface-number] [verbose]

8. (Optional) copy running-config startup-config

DETAILED STEPS

 
Command
Purpose

Step 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

Enters global configuration mode.

Step 2

interface interface - type slot/port

 

Example:

switch(config)# interface ethernet 2/1

switch(config-if)#

Enters interface configuration mode.

Step 3

ip address ip-address mask [ secondary]

 

Example:

switch(config-if)# ip address 209.165.200.230 255.255.255.224

Configures the IP address on the interface.

Note You can use the secondary keyword to configure additional IP addresses on the interface.

Step 4

vrrpv3 number address-family { ipv4 | ipv6 }

 

Example:

switch(config-if)# vrrpv3 5 address-family

ipv4

switch(config-if-vrrpv3-group)#

Creates a VRRPv3 group and enters VRRPv3 group configuration mode. The range is from 1 to 255.

Step 5

address ip-address [ primary | secondary ]

 

Example:

switch(config-if-vrrpv3-group)# address

209.165.200.227 primary

(Optional) Specifies a primary or secondary IPv4 or IPv6 address for the VRRPv3 group.

Step 6

vrrs leader vrrs-leader-name

 

Example:

switch(config-if-vrrpv3-group)# vrrs leader leader1

(Optional) Specifies a leader’s name to be registered with VRRS.

Step 7

shutdown

 

Example :

switch(config-if-vrrp3-group)# shutdown

(Optional) Disables VRRP configuration for the VRRPv3 group.

Step 8

show fhrp [ interface-type interface-number ] [verbose]

 

Example:

switch(config-if-vrrp3-group)# show fhrp port-channnel 101 verbose

(Optional) Displays First Hop Redundancy Protocol (FHRP) information.

Use the verbose keyword to view detailed information.

Step 9

copy running-config startup-config

 

Example:

switch(config-if-vrrp3-group)# copy running-config startup-config

(Optional) Saves this configuration change.

Configuring VRRS Pathways

You can configure a Virtual Router Redundancy Service (VRRS) pathway. In scaled environments, VRRS pathways should be used in combination with VRRPv3 control groups.

BEFORE YOU BEGIN

Ensure that the VRRPv3 feature is enabled.

Ensure that you are in the correct VDC (or use the switchto vdc command).

Ensure that you configure an IP address on the interface (see the “Configuring IPv4 Addressing” section).

SUMMARY STEPS

1. configure terminal

2. interface interface-type slot/port

3. ip address ip-address mask [ secondary ]

4. vrrs pathway vrrs-tag

5. mac address { mac-address | inherit }

6. address ip-address

7. (Optional) Repeat steps 1 through 6 to configure more pathways.

8. (Optional) show vrrs pathway interface-type number

9. (Optional) show vrrs server

10. (Optional) show vrrs client [ client-name]

11. (Optional) show vrrs tag [ tag-name]

12. (Optional) copy running-config startup-config

DETAILED STEPS

 
Command
Purpose

Step 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

Enters global configuration mode.

Step 2

interface interface - type slot/port

 

Example:

switch(config)# interface port-channel 101

switch(config-if)#

Enters interface configuration mode.

Step 3

ip address ip-address mask [ secondary]

 

Example:

switch(config-if)# ip address 209.165.200.230 255.255.255.224

Configures the IP address on the interface.

Note You can use the secondary keyword to configure additional IP addresses on the interface.

Step 4

vrrs pathway vrrs-tag

 

Example:

switch(config-if)# vrrs pathway path1

switch(config-if-vrrs-pw)#

Defines the VRRS pathway for a VRRS group and enters VRRS pathway configuration mode.

The vrrs-tag argument specifies the name of the VRRS tag that is being associated with the pathway.

Step 5

mac address {mac-address | inherit }

 

Example:

switch(config-if-vrrs-pw)# mac address

fe24.fe24.fe24

Specifies a MAC address for the pathway.

Note The inherit keyword causes the pathway to inherit the virtual MAC address of the VRRPv3 group with which the pathway is associated.

Step 6

address ip-address

 

Example:

switch(config-if-vrrs-pw)# address

209.165.201.10

Defines the virtual IPv4 or IPv6 address for a pathway.

Note A VRRPv3 group is capable of controlling more than one pathway.

Step 7

(Optional) Repeat steps 1 through 6 to configure more pathways.

Step 8

show vrrs pathway interface-type interface-number

 

Example:

switch(config-if-vrrs-pw)# show vrrs pathway port-channel 101

(Optional) Displays the VRRS pathway information for different pathway states, such as active, inactive, and not ready.

Step 9

show vrrs server

 

Example:

switch(config-if-vrrs-pw)# show vrrs server

(Optional) Displays the VRRS server information.

Step 10

show vrrs client [client-name ]

 

Example:

switch(config-if-vrrs-pw)# show vrrs client

(Optional) Displays the VRRS client information.

Step 11

show vrrs tag [tag-name ]

 

Example:

switch(config-if-vrrs-pw)# show vrrs tag

(Optional) Displays the VRRS tag information.

Step 12

copy running-config startup-config

 

Example:

switch(config-if-vrrp3-group)# copy running-config startup-config

(Optional) Saves this configuration change.

Verifying the VRRP Configuration

To display VRRP configuration information, perform one of the following tasks:

 

Command
Purpose

show vrrp

Displays the VRRP status for all groups.

show vrrs client [ client-name]

Displays the VRRS client information.

show vrrs pathway interface-type number

Displays the VRRS pathway information for different pathway states, such as active, inactive, and not ready.

show vrrs server

Displays the VRRS server information.

show vrrs tag [ tag-name]

Displays the VRRS tag information.

show fhrp [ interface-type interface-number] [verbose]

Displays First Hop Redundancy Protocol (FHRP) information.

show interface interface-type

Displays the virtual router configuration for an interface.

Monitoring VRRP Statistics

To display VRRP statistics, use the following commands:

 

Command
Purpose

show vrrp statistics

Displays the VRRP statistics.

Use the clear vrrp statistics command to clear all the VRRP statistics for all interfaces in the device.

Use the clear vrrp vr command to clear the IPv4 VRRP statistics for a specified interface.

Use the clear vrrp ipv4 command to clear all the statistics for the specified IPv4 virtual router.

Configuration Examples for VRRP

In this example, Router A and Router B each belong to three VRRP groups. In the configuration, each group has the following properties:

  • Group 1:

– Virtual IP address is 10.1.0.10.

– Router A will become the master for this group with priority 120.

– Advertising interval is 3 seconds.

– Preemption is enabled.

  • Group 5:

– Router B will become the master for this group with priority 200.

– Advertising interval is 30 seconds.

– Preemption is enabled.

  • Group 100:

– Router A will become the master for this group first because it has a higher IP address (10.1.0.2).

– Advertising interval is the default 1 second.

– Preemption is disabled.

Router A

interface ethernet 1/0
ip address 10.1.0.2/16
no shutdown
vrrp 1
priority 120
authentication text cisco
advertisement-interval 3
address 10.1.0.10
no shutdown
vrrp 5
priority 100
advertisement-interval 30
address 10.1.0.50
no shutdown
vrrp 100
no preempt
address 10.1.0.100
no shutdown

Router B

interface ethernet 1/0
ip address 10.2.0.1/2
no shutdown
vrrp 1
priority 100
authentication text cisco
advertisement-interval 3
address 10.2.0.10
no shutdown
 
vrrp 5
priority 200
advertisement-interval 30
address 10.2.0.50
no shutdown
vrrp 100
no preempt
address 10.2.0.100
no shutdown
 

Configuration Examples for VRRPv3

This example shows how to enable VRRPv3 and create and customize a VRRPv3 group:

switch# configure terminal
switch(config)# feature vrrpv3
switch(config)# interface ethernet 4/6
switch(config-if)# vrrpv3 5 address-family ipv4
switch(config-if-vrrpv3-group)# address 209.165.200.225 primary
switch(config-if-vrrpv3-group)# description group3
switch(config-if-vrrpv3-group)# match-address
switch(config-if-vrrpv3-group)# preempt delay minimum 30
switch(config-if-vrrpv3-group)# show fhrp verbose
Interface Ethernet4/6
Interface handle : 0x1a185000
Reference count : 3
Client 1 : VRRP
Client 2 : PATHWAY
Verify up running : 63 (expired)
Verify up retries : 6
Verify up next retry : 0.000 secs
Reload Delay : 0
Minimum Delay : 30
Delay remaining : 0.000 secs
Interface state : down
IPv4 state : down
IPv6 state : down
Hardware state : present

Additional References

For additional information related to implementing VRRP, see the following sections:

Related Documents

Related Topic
Document Title

Configuring the gateway load balancing protocol

Chapter 1, “Configuring GLBP”

Configuring the hot standby routing protocol

Chapter 1, “Configuring HSRP”

VRRP CLI commands

Cisco Nexus 7000 Series NX-OS Unicast Routing Command Reference

Configuring high availability

Cisco Nexus 7000 Series NX-OS High Availability and Redundancy Guide

Feature History for VRRP

Table 1-2 lists the release history for this feature.

 

Table 1-2 Feature History for VRRP

Feature Name
Releases
Feature Information

VRRPv3 and VRRS

6.2(2)

These features were introduced.

VRRP priority thresholds

4.2(1)

Added support for priority thresholds and vPC.

VRRP object tracking

4.2(1)

Added support for tracking multiple object types in VRRP.

VRRP

4.0(1)

This feature was introduced.