Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 6.x
Configuring Static Routing
Downloads: This chapterpdf (PDF - 207.0KB) The complete bookPDF (PDF - 10.35MB) | Feedback

Table of Contents

Configuring Static Routing

Information About Static Routing

Administrative Distance

Directly Connected Static Routes

Fully Specified Static Routes

Floating Static Routes

Remote Next Hops for Static Routes

Reliable Static Routing Backup Using Object Tracking Deployment

IP Service Level Agreements

BFD

Virtualization Support

Licensing Requirements for Static Routing

Prerequisites for Static Routing

Guidelines and Limitations for Static Routing

Default Settings

Configuring Static Routing

Configuring a Static Route

Configuring a Static Route over a VLAN

Configuring Reliable Static Routing Backup Using Object Tracking

Configuring Virtualization

Verifying the Static Routing Configuration

Configuration Example for Static Routing

Configuration Example for Reliable Static Routing Backup Using Object Tracking

Additional References

Related Documents

Feature History for Static Routing

Information About Static Routing

Routers forward packets using either route information from route table entries that you manually configure or the route information that is calculated using dynamic routing algorithms.

Static routes, which define explicit paths between two routers, cannot be automatically updated; you must manually reconfigure static routes when network changes occur. Static routes use less bandwidth than dynamic routes. No CPU cycles are used to calculate and analyze routing updates.

You can supplement dynamic routes with static routes where appropriate. You can redistribute static routes into dynamic routing algorithms but you cannot redistribute routing information calculated by dynamic routing algorithms into the static routing table.

You should use static routes in environments where network traffic is predictable and where the network design is simple. You should not use static routes in large, constantly changing networks because static routes cannot react to network changes. Most networks use dynamic routes to communicate between routers but might have one or two static routes configured for special cases. Static routes are also useful for specifying a gateway of last resort (a default router to which all unroutable packets are sent).

This section includes the following topics:

Administrative Distance

An administrative distance is the metric used by routers to choose the best path when there are two or more routes to the same destination from two different routing protocols. An administrative distance guides the selection of one routing protocol (or static route) over another, when more than one protocol adds the same route to the unicast routing table. Each routing protocol is prioritized in order of most to least reliable using an administrative distance value.

Static routes have a default administrative distance of 1. A router prefers a static route to a dynamic route because the router considers a route with a low number to be the shortest. If you want a dynamic route to override a static route, you can specify an administrative distance for the static route. For example, if you have two dynamic routes with an administrative distance of 120, you would specify an administrative distance that is greater than 120 for the static route if you want the dynamic route to override the static route.

Directly Connected Static Routes

You must specify only the output interface (the interface on which all packets are sent to the destination network) in a directly connected static route. The router assumes the destination is directly attached to the output interface and the packet destination is used as the next-hop address. The next hop can be an interface, only for point-to-point interfaces. For broadcast interfaces, the next hop must be an IPv4/IPv6 address.

Fully Specified Static Routes

You must specify either the output interface (the interface on which all packets are sent to the destination network) or the next-hop address in a fully specified static route. You can use a fully specified static route when the output interface is a multi-access interface and you need to identify the next-hop address. The next-hop address must be directly attached to the specified output interface.

Floating Static Routes

A floating static route is a static route that the router uses to back up a dynamic route. You must configure a floating static route with a higher administrative distance than the dynamic route that it backs up. In this instance, the router prefers a dynamic route to a floating static route. You can use a floating static route as a replacement if the dynamic route is lost.


Note By default, a router prefers a static route to a dynamic route because a static route has a smaller administrative distance than a dynamic route.


Remote Next Hops for Static Routes

You can specify the next-hop address of a neighboring router that is not directly connected to the router for static routes with remote (nondirectly attached) next-hops. If a static route has remote next hops during data forwarding, the next hops are recursively used in the unicast routing table to identify the corresponding directly attached next hops that have reachability to the remote next hops.

Reliable Static Routing Backup Using Object Tracking Deployment

You can configure Cisco NX-OS to initiate a backup connection from an alternative port if the circuit to the primary gateway is interrupted. You can ensure reliable deployment backups in the case of certain catastrophic events, such as an Internet circuit failure or peer device failure.

Reliable static routing backup using object tracking can determine the state of the primary connection without having to enable a dynamic routing protocol. It also provides a reliable backup solution that can be used for critical circuits that must not go down without automatically engaging a backup circuit.

In a typical scenario, the primary interface of the remote router forwards traffic from the remote LAN to the main office. If the router loses the connection to the main office, the status of the tracked object changes from up to down. When this change occurs, the router removes the routing table entry for the primary interface and installs the preconfigured floating static route on the secondary interface. The router’s secondry interface then forwards traffic to the preconfigured destination. The backup circuit can be configured to use the Internet. When the state of the tracked object changes from down to up, the router reinstalls the routing table entry for the primary interface and removes the floating static route for the secondary interface.

IP Service Level Agreements

This feature uses IP service level agreements (IP SLAs), a network monitoring feature set, to generate ICMP pings to monitor the state of the connection to the primary gateway. An IP SLA is configured to ping a target, such as a publicly routable IP address or a target inside the corporate network. The pings are routed from the primary interface only. A track object is created to monitor the status of the IP SLA configuration. The track object informs the client, the static route, if a state change occurs. The preconfigured floating static route on the secondary interface is installed when the state changes from up to down.


Note User Datagram Protocol (UDP) echo, or any other protocol supported by IP SLAs, can be used instead of ICMP pings.


For more information on IP SLAs, see the Cisco Nexus 7000 Series NX-OS IP SLAs Configuration Guide .

BFD

This feature supports bidirectional forwarding detection (BFD). BFD is a detection protocol designed to provide fast forwarding-path failure detection times. BFD provides subsecond failure detection between two adjacent devices and can be less CPU-intensive than protocol hello messages because some of the BFD load can be distributed onto the data plane on supported modules. See the Cisco Nexus 7000 Series NX-OS Interfaces Configuration Guide for more information.

Virtualization Support

Static routes support virtual routing and forwarding (VRF) instances. VRFs exist within virtual device contexts (VDCs). By default, Cisco NX-OS places you in the default VDC and default VRF unless you specifically configure another VDC and VRF. For more information, see the Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide and Chapter15, “Configuring Layer 3 Virtualization”

Licensing Requirements for Static Routing

The following table shows the licensing requirements for this feature:

 

Product
License Requirement

Cisco NX-OS

Static routing requires no license. Any feature not included in a license package is bundled with the Cisco NX-OS system images and is provided at no extra charge to you. For a complete explanation of the Cisco NX-OS licensing scheme, see the Cisco NX-OS Licensing Guide .

Prerequisites for Static Routing

Static routing has the following prerequisites:

  • If the next-hop address for a static route is unreachable, the static route is not added to the unicast routing table.

Guidelines and Limitations for Static Routing

Static routing has the following configuration guidelines and limitations:

  • You can specify an interface as the next-hop address for a static route only for point-to-point interfaces such as generic routing encapsulation (GRE) tunnels.
  • The forward referencing of static routes is not supported for track objects.

Default Settings

Table 13-1 lists the default settings for static routing parameters.

 

Table 13-1 Default Static Routing Parameters

Parameters
Default

Administrative distance

1

RIP feature

Disabled

Configuring Static Routing

This section includes the following topics:


Note If you are familiar with the Cisco IOS CLI, be aware that the Cisco NX-OS commands for this feature might differ from the Cisco IOS commands that you would use.


Configuring a Static Route

You can configure a static route on the router.

BEFORE YOU BEGIN

Ensure that you are in the correct VDC (or use the switchto vdc command).

DETAILED STEPS

 

Command
Purpose

Step 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

Enters global configuration mode.

Step 2

ip route { ip-prefix | ip-addr / ip-mask } {[ next-hop | nh-prefix ] | [ interface next-hop | nh-prefix ]} [ name nexthop-name] [ tag tag-value] [ pref ]

 

Example :

switch(config)# ip route 192.0.2.0/8 ethernet 1/2 192.0.2.4

Configures a static route and the interface for this static route. Use ? to display a list of supported interfaces. You can specify a null interface by using null 0 .

You can optionally configure the next-hop address.

The preference value sets the administrative distance. The range is from 1 to 255. The default is 1.

ipv6 route ip6-prefix { nh-prefix | link-local-nh-prefix } | ( nexthop [ interface ] | link-local-nexthop [ interface ]} [ name nexthop-name] [ tag tag-value ] [ pref ]

 

Example :

switch(config)# ipv6 route 2001:0DB8::/48 6::6 ethernet 2/1

Configures a static route and the interface for this static route. Use ? to display a list of supported interfaces. You can specify a null interface by using null 0 .

You can optionally configure the next-hop address.

The preference value sets the administrative distance. The range is from 1 to 255. The default is 1.

Step 3

show { ip | ipv6 } static-route

 

Example:

switch(config)# show ip static-route

(Optional) Displays information about static routes.

Step 4

copy running-config startup-config

 

Example:

switch(config)# copy running-config startup-config

(Optional) Saves this configuration change.

This example shows how to configure a static route for a null interface:

switch# configure terminal

switch(config)# ip route 1.1.1.1/32 null 0

switch(config)# copy running-config startup-config

 

Use the no { ip | ipv6 } static-route command to remove the static route.

Configuring a Static Route over a VLAN

You can configure a static route without next hop support over a VLAN, also known as a switch virtual switch (SVI).

BEFORE YOU BEGIN

Ensure that the access port is part of the VLAN.

DETAILED STEPS

 

Command
Purpose

Step 1

switch# c onfigure terminal

 

Enters global configuration mode.

Step 2

switch(config)# feature interface-vlan

Enables VLAN interface mode.

Step 3

switch(config)# interface vlan vlan-id

Creates a n switch virtual inteface (SVI) and enters interface configuration mode.

The range for the vlan-id argument is from 1 to 4094, except for the VLANs reserved for the internal switch.

Step 4

switch(config-if)# ip address ip-addr / length

 

Configures an IP address for the VLAN.

Step 5

switch(config-if)# ip route ip-addr / length } vlan-id

Adds an interface static route without a next hop on the SVI.

The IP address is the address that is configured on the interface that is connected to the switch.

Step 6

switch(config-if)# show ip route

(Optional) Displays routes from the Unicast Route Information Base (URIB).

Step 7

switch(config)# copy running-config startup-config

(Optional) Saves this configuration change.

This example shows how to configure a static route without a next hop over an SVI:

switch# configure terminal

switch(config)# feature interface-vlan

swicth(config)# interface vlan 10

switch(config-if)# ip address 192.0.2.1/8

switch(config-if)# ip route 209.165.200.224/27 vlan 10 <===209,165.200.224 is the IP address of the interface that is configured on the interface that is directly connected to the switch.

switch(config-if)# copy running-config startup-config

 

Use the no ip static-route command to remove the static route.

Configuring Reliable Static Routing Backup Using Object Tracking

You can configure Cisco NX-OS to use Internet Control Message Protocol (ICMP) pings to identify when a connection goes down and initiate a backup connection from any alternative port.

BEFORE YOU BEGIN

Configure both a primary interface and a backup interface to used for reliable static routing backup (see Chapter 2, “Configuring IPv4 Addressing”).

Configure an IP SLA with policy-based routing object tracking to be used for reliable static routing backup (see the Cisco Nexus 7000 Series NX-OS IP SLAs Configuration Guide ).

Configure a routing policy for static routing to be used for reliable static routing backup (see Chapter 13, “Configuring Static Routing”).

Create a track object to be associated with the static route using the track object-id interface command (see Chapter 22, “Configuring Object Tracking”).


Note If you attempt to configure a static route associated with a track object before you create the track object, the static route command is not accepted by the switch.


Ensure that you are in the correct VDC (or use the switchto vdc command).

DETAILED STEPS

 

Command
Purpose

Step 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

Enters global configuration mode.

Step 2

{ip | ipv6} route ip-prefix ip-mask ip-addr track object-number

 

Example:

switch(config)# ip route 0.0.0.0 0.0.0.0 10.1.1.242 track 123

Configures a static route associated wth the track object. The object-number argument specifies that the static route is installed only if the configured track object is up.

Step 3

show {ip | ipv6} static-route track-table

 

Example :

switch(config)# show ip static-route track-table

(Optional) Displays information about the IPv4 or IPv6 static-route track table.

Step 4

show track track-number

 

Example:

switch(config)# show track 123

(Optional) Displays information about a specific tracked object.

Step 5

{ ip | ipv6 } route network-number network-mask {ip-address | interface} [distance] [ name name]

 

Example:

switch(config)# ip route 0.0.0.0 0.0.0.0 10.2.2.125 254

Configures a floating IPv4 or IPv6 static route on the secondary interface.

The network prefix and mask length must be the same as the static route previously configured for the primary interface associated with a track object. The floating static route should have a higher value of preference than the route associated with the track object.

Configuring Virtualization

You can configure a static route in a VRF.

BEFORE YOU BEGIN

Ensure that you are in the correct VDC (or use the switchto vdc command).

DETAILED STEPS

 

Command
Purpose

Step 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

Enters global configuration mode.

Step 2

vrf context vrf-name

 

Example:

switch(config)# vrf context StaticVrf

Creates a VRF and enters VRF configuration mode.

Step 3

ip route { ip-prefix | ip-addr ip-mask } { next-hop | nh-prefix | interface } [ name nexthop-name] [ tag tag-value ] [ pref ]

 

Example :

switch(config-vrf)# ip route 192.0.2.0/8 ethernet 1/2

Configures a static route and the interface for this static route. Use ? to display a list of supported interfaces. You can specify a null interface by using null 0 .

You can optionally configure the next-hop address.

The preference value sets the administrative distance. The range is from 1 to 255. The default is 1.

ipv6 route ip6-prefix { nh-prefix | link-local-nh-prefix } | ( nexthop [ interface ] | link-local-nexthop [ interface ]} [ name nexthop-name] [ tag tag-value ] [ pref ]

 

Example :

switch(config)# ipv6 route 2001:0DB8::/48 6::6 ethernet 2/1

Configures a static route and the interface for this static route. Use ? to display a list of supported interfaces. You can specify a null interface by using null 0 .

You can optionally configure the next-hop address.

The preference value sets the administrative distance. The range is from 1 to 255. The default is 1.

Step 4

show { ip | ipv6 } static-route vrf vrf-name

 

Example:

switch(config-vrf)# show ip static-route

(Optional) Displays information on static routes.

Step 5

copy running-config startup-config

 

Example:

switch(config-vrf)# copy running-config startup-config

(Optional) Saves this configuration change.

This example shows how to configure a static route:

switch# configure terminal

switch(config)# vrf context StaticVrf

switch(config-vrf)# ip route 192.0.2.0/8 192.0.2.10

switch(config-vrf)# copy running-config startup-config

Verifying the Static Routing Configuration

To display the static routing configuration, perform one of the following tasks:

 

Command
Purpose

show {ip | ipv6} static-route

Displays the configured static routes.

show ipv6 static-route vrf vrf-name

Displays static route information for each VRF.

show {ip | ipv6} static-route track-table

Displays information about the IPv4 or IPv6 static-route track table.

show track track-number

Displays information about a specific tracked object.

Configuration Example for Static Routing

This example shows how to configure static routing:

configure terminal

ip route 192.0.2.0/8 192.0.2.10

copy running-config startup-config

 

Configuration Example for Reliable Static Routing Backup Using Object Tracking

This example shows how to configure the primary interface and the backup interface to use for reliable static routing backup:

switch# configure terminal
switch(config)# interface Ethernet 1/0
switch(config-if)# description primary-link
switch(config-if)# ip address 209.165.200.225 255.0.0.0
switch(config-if)# exit
switch(config)# interface Ethernet 2/1
switch(config-if)# ip address 209.165.201.1 255.255.255.0
switch(config-if)# exit
 

This example shows how to configure an IP SLA with policy-based routing object tracking to be used for reliable static routing backup:

switch(config)# ip sla 1
switch(config-ip-sla)# icmp-echo 172.16.23.7
switch(config-ip-sla-echo)# timeout 500
switch(config-ip-sla-echo)# frequency 15
switch(config-ip-sla-echo)# threshold 2
switch(config-ip-sla-echo)# exit
switch(config)# ip sla schedule 10 life forever start-time now
switch(config)# track 123 interface
switch(config-track)# exit
 

This example shows how to configure a routing policy for static routing to be used for reliable static routing backup:

switch(config)# ip access-list static-route-acl
switch(config-acl)# permit icmp any host 172.16.23.7 echo
switch(config-acl)# exit
switch(config)# route-map MY-LOCAL-POLICY permit 10
switch(config-route-map)# match ip address static-route-acl
switch(config-route-map)# set ip next-hop 10.1.1.242
switch(config-route-map)# exit
switch(config)# ip local policy route-map MY-LOCAL-POLICY

 

This example shows how to configure the default route for the primary interface using static routing:

switch(config)# track 123 interface ethernet 2/1 ip routing
switch(config)# ip route 0.0.0.0 0.0.0.0 10.1.1.242 track 123
or
switch(config)# ip route 5.5.5.0/24 209.165.201.2 track 1
or
switch(config)# ip route 6.6.6.0/24 tunnel 1 track 2
or
switch(config)# ip route 7.7.7.0/24 ethernet 2/1 209.165.201.2 track 3
switch(config)# show ip static-route track-table
Static-route for VRF "default"(1)
IPv4 Unicast Static Routes:
5.5.5.0/24, configured nh: 2.2.2.2/32
(not installed in urib)
rnh(installed in urib)
Track Object Id Associated: 1, Track Object State: UP
switch(config)# show track 123
Interface Ethernet1/1 Line Protocol
Line Protocol is UP
1 changes, last change 00:00:16
Tracked by:
IP_STATIC_ROUTING 0
 

The following example shows how to configure a floating static route on a secondary interface:

switch(config)# ip route 0.0.0.0 0.0.0.0 10.1.1.242 254
or
switch(config)# ip route 5.5.5.0/24 209.165.201.2 254
or
switch(config)# ip route 6.6.6.0/24 tunnel 1 254
or
switch(config)# ip route 7.7.7.0/24 ethernet 2/1 209.165.201.2 254

Additional References

For additional information related to implementing static routing, see the following sections:

Related Documents

Related Topic
Document Title

Static Routing CLI

Cisco Nexus 7000 Series NX-OS Unicast Routing Command Reference

VDCs

Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide

Feature History for Static Routing

Table 13-2 lists the release history for this feature.

 

Table 13-2 Feature History for Static Routing

Feature Name
Releases
Feature Information

Static Route over VLAN

6.2(2a)

This feature was introduced.

Reliable static routing backup using object tracking

6.2(2)

This feature was introduced.

Static routing

6.0(1)

Updated for F2 Series modules.

Static routing

5.1(1)

Added the name option to the ip route command.

BFD

5.0(2)

Added support for BFD. See the Cisco Nexus 7000 Series NX-OS Interfaces Configuration Guide for more information.

Static routing

4.0(1)

This feature was introduced.