Cisco Nexus 7000 Series Unicast Routing Command Reference
V Commands
Downloads: This chapterpdf (PDF - 211.0KB) The complete bookPDF (PDF - 18.25MB) | Feedback

Table of Contents

V Commands

vfhrp delay

vrf

vrf context

vrf member

vrrp

vrrpv3 address-family

vrrs leader

vrrs pathway

V Commands

This chapter describes the Cisco NX-OS unicast routing commands that begin with the letter V.

vfhrp delay

To specify the delay period for the initialization of First Hop Redundancy Protocol (FHRP) clients, use the vfhrp delay command.

vfhrp delay {[minimum] [reload] seconds}

 
Syntax Description

minimum

(Optional) Configures the delay period after an interface becomes available.

reload

(Optional) Configures the delay period after the device reloads.

seconds

Seconds. The range is from 0 to 3600.

 
Defaults

None

 
Command Modes

Global configuration mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

6.2(2)

This command was introduced.

 
Usage Guidelines

This command requires the Enterprise Services license.

Examples

This example shows how to specify the delay period for the initialization of FHRP clients:

switch# configure terminal
switch(config)# fhrp delay minimum 90
switch(config)#

 
Related Commands

Command
Description

show fhrp

Displays First Hop Redundancy Protocol (FHRP) information.

vrf

To create a VPN routing and forwarding instance (VRF) or enter the VRF configuration mode and configure submode commands for the Intermediate System-to-Intermediate System Intradomain Routing Protocol (IS-IS), use the vrf command. To remove a VRF instance or disable the VRF configuration mode, use the no form of this command.

vrf name | management

no vrf name | management

 
Syntax Description

name

Name of the VRF.

management

Specifies a configurable VRF name.

 
Command Default

None

 
Command Modes

Address-family configuration
Router configuration
VRF configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

Each VRF mode serves as a separate instance within the IS-IS process. All configuration commands available in the global configuration mode are available in the new VRF mode. For example, each VRF mode must has its own NET configured for that particular instance to be operational. All EXEC commands can be specified to be per-VRF, else with no arguments, it will be applied to the default VRF. Note that interfaces belong to a particular VRF and the appropriate interface will only be applied to the particular interface with the ip/ipv6 router isis command.

The VRF does not become active until you create an identically named VRF in global configuration mode.

When you enter the VRF configuration mode, the following commands are available:

  • address-family —Configures an address family. See the address-family (BGP) command for additional information.
  • authentication key-chain —Sets the authentication key chain string. See the authentication key-chain command for additional information.
  • authentication-check —Checks the authentication. See the authentication-check command for additional information.
  • authentication-type — Sets the authentication type. See the authentication-type command for additional information.
  • default-information — Controls the origination of a default route. See the default-information originate (IS-IS) command for additional information.
  • distance —Configures the administrative distance. See the distance (IS-IS) command for additional information.
  • distribute —Distributes routes between ISIS levels. See the distribute command for additional information.
  • exit —Exits from the current command mode.
  • graceful-restart —Enables the graceful restart for IS-IS process. See the graceful-restart (BGP) command for additional information.
  • hostname —Configures the dynamic hostname for IS-IS. See the hostname dynamic command for additional information.
  • is-type —Configures the IS type for this IS-IS process. See the is-type command for additional information.
  • log-adjacency-changes —Logs the changes in adjacency state. See the log-adjacency-changes (IS-IS ) command for additional information.
  • lsp-gen-interval —Configures the LSP generation interval. See the lsp-gen-interval command for additional information.
  • lsp-mtu —Sets the LSP MTU. See the lsp-mtu command for additional information.
  • max-lsp-lifetime —Sets the maximum LSP lifetime. See the max-lsp-lifetime command for additional information.
  • maximum-paths —Sets the maximum paths per destination. See the maximum-paths (IS-IS) command for additional information.
  • net —Configures the Network Entity Title for this IS-IS process. See the net command for additional information.
  • no —Negates a command or set its defaults.
  • redistribute —Redistributes the information from another routing protocol. See the redistribute (IS-IS ) command for additional information.
  • reference-bandwidth —Changes the reference bandwidth used for setting interface metric. See the reference-bandwidth command for additional information.
  • set-overload-bit —Signals other routers not to use us for transit. See the set-overload-bit command for additional information.
  • shutdown —Shuts down this IS-IS process. See the shutdown (IS-IS) command for additional information.
  • spf-interval —Configures the SPF interval. See the spf-interval command for additional information.
  • summary-address —Configures the IP address summaries. See the summary-address command for additional information.
  • wide-metric-only —Advertises only wide metric. See the wide-metric-only command for additional information.

Examples

The following command shows how to enter VRF configuration mode:

switch(config)# router isis 100
switch(config-router)# vrf management
switch(config-router-vrf)#

 
Related Commands

Command
Description

address-family

Enters the address family mode or a VRF address-family mode.

feature isis

Enables IS-IS on the router.

router isis

Enables IS-IS.

vrf context

To create a virtual routing and forwarding instance (VRF) and enter VRF configuration mode, use the vrf router BGP configuration command. To remove a VRF entry, use the no form of this command.

vrf context { name | management }

no vrf contex t { name | management }

 
Syntax Description

name

Name of the VRF. The name can be any case-sensitive, alphanumeric string up to 32 characters.

management

Specifies a configurable VRF name.

 
Command Default

This command has no default settings.

 
Command Modes

Neighbor address-family configuration
Router bgp configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

The VRF does not become active until you create an identically named VRF in global configuration mode.

When you enter the VRF configuration mode, the following commands are available:

  • address-family —Configures an address-family. See the address-family (BGP) command for additional information.
  • cluster-id { cluster-id | cluster-ip-addr } —Configures the Route Reflector Cluster-ID (router, vrf). Range: 1 to 4294967295. You can enter the cluster identification as a 32-bit quantity or as an IP address. To remove the cluster ID, use the no form of this command. Together, a route reflector and its clients form a cluster. When a single route reflector is deployed in a cluster, the cluster is identified by the router ID of the route reflector.

The cluster-id command is used to assign a cluster ID to a route reflector when the cluster has one or more route reflectors. Multiple route reflectors are deployed in a cluster to increase redundancy and avoid a single point of failure. When multiple route reflectors are configured in a cluster, the same cluster ID is assigned to all route reflectors. This allows all route reflectors in the cluster to recognize updates from peers in the same cluster and reduces the number of updates that need to be stored in BGP routing tables.


Note All route reflectors must maintain stable sessions between all peers in the cluster. If stable sessions cannot be maintained, then overlay route reflector clusters should be used instead (route reflectors with different cluster IDs).


  • exit —Exits from the current command mode.
  • graceful-restart —Configure Graceful Restart functionality. See the graceful-restart (BGP) command for additional information.
  • graceful-restart-helper —Configure Graceful Restart Helper mode functionality. See the graceful-restart (BGP) command for additional information.
  • log-neighbor-changes —Enables logging of the BGP neighbor resets. To disable the logging of changes in BGP neighbor adjacencies, use the no form of this command. The log-neighbor-changes command enables logging of BGP neighbor status changes (up or down) and resets for troubleshooting network connectivity problems and measuring network stability. Unexpected neighbor resets might indicate high error rates or high packet loss in the network and should be investigated.

Using the log-neighbor-changes command to enable status change message logging does not cause a substantial performance impact, unlike, for example, enabling per BGP update debugging. If the UNIX syslog facility is enabled, messages are sent to the UNIX host running the syslog daemon so that the messages can be stored and archived. If the UNIX syslog facility is not enabled, the status change messages are retained in the internal buffer of the router, and are not stored to disk. You can set the size of this buffer, which is dependent upon the available RAM, using the logging buffered command.

The neighbor status change messages are not tracked if the bgp log-neighbor-changes command is disabled, except for the reset reason, which is always available as output of the show ip bgp neighbors and show bgp ipv6 neighbors commands.

The eigrp log-neighbor-changes command enables logging of Enhanced Interior Gateway Routing Protocol (EIGRP) neighbor adjacencies, but messages for BGP neighbors are logged only if they are specifically enabled with the bgp log-neighbor-changes command.

Use the show logging command to display the log for the BGP neighbor changes.

  • neighbor —Configures a BGP neighbor. See the neighbor command for additional information.
  • no —Negates a command or set its defaults
  • router-id ip-addr —Specifies the IP address to use as the router-id.
  • timers bestpath-timeout —Configures the bestpath timeout in seconds. Range: 1 to 3600. Default: 300.

Examples

The following command shows how to enter VRF configuration mode:

switch(config)# router bgp 64496
switch(config-router)# vrf context management
switch(config-router-vrf)#
 

This example shows how to set the local router as one of the route reflectors serving the cluster. You configure the cluster ID to identify the cluster.

switch(config)# router bgp 64496
switch(config-router)# neighbor 192.168.70.24 route-reflector-client
switch(config-router)# cluster-id 10.0.1.2

 

vrf member

To configure object tracking on a virtual routing and forwarding (VRF) instance, use the vrf member command. To remove the object tracking for this route, use the no form of this command.

vrf member vrf-name

no vrf member vrf-name

 
Syntax Description

vrf-name

VRF name. The name can be any case-sensitive, alphanumeric string up to 64 characters.

 
Command Default

None

 
Command Modes

Global configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

Use the vrf member command in object tracking configuration mode to track objects in a nondefault VRF.

This command does not require a license.

Examples

This example shows how to track an IP route in vrf Red:

switch(config)# track 1 ip route 10.10.10.0/8 reachability
switch(config-track)# vrf member Red
 

 
Related Commands

Command
Description

show track

Displays information about object tracking.

track ip route

Tracks an interface.

vrrp

To create a Virtual Router Redundancy Protocol (VRRP) group on a particular Ethernet interface and assign a number to the VRRP group and enter VRRP configuration mode, use the vrrp command. To remove a VRRP group, use the no form of this command.

vrrp number

no vrrp number

 
Syntax Description

number

The VRRP group number, which you can configure for a Gigabit Ethernet port, including the main interfaces and subinterfaces. The range is from 1 to 255.

 
Defaults

None

 
Command Modes

VRRP configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modified

4.0(1)

This command was introduced.

 
Usage Guidelines

You can configure VRRP only if its state is disabled. Make sure that you configure at least one IP address before you attempt to enable a virtual router.

This command does not require a license.

Examples

This example shows how to create a VRRP group:

switch(config-if-vrrp)# vrrp 7
 

This example shows how to create a VRRP group and configure an IPv4 address for the group:

switch# config terminal
switch(config)# interface ethernet 2/1
switch(config-if)# vrrp 7
switch(config-if-vrrp)# address 10.0.0.10
switch(config-if-vrrp)# no shutdown

 
Related Commands

Command
Description

feature vrrp

Enables VRRP.

show vrrp

Displays VRRP configuration information.

clear vrrp

Clears all the software counters for the specified virtual router.

vrrpv3 address-family

To create a Virtual Router Redundancy Protocol version 3 (VRRPv3) group and enter VRRPv3 group configuration mode, use the vrrpv3 address-family command.

vrrpv3 number address-family {ipv4 | ipv6}

 
Syntax Description

number

VRRP number.

ipv4

(Optional) Specifies IPv4 address.

ipv6

(Optional) Specifies IPv6 address.

 
Defaults

None

 
Command Modes

Interface configuration mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

6.2(2)

This command was introduced.

 
Usage Guidelines

This command requires the Enterprise Services license.

Examples

This example shows how to create a VRRPv3 group and enter VRRPv3 group configuration mode:

switch# configure terminal
switch(config)# interface ethernet 2/1
switch(config-if)# vrrpv3 5 address-family ipv4
switch(config-if-vrrpv3-group)#

 
Related Commands

Command
Description

feature vrrpv3

Enables VRRPv3 and VRRS.

timers advertise interval

Sets the advertisement timer in milliseconds.

vrrs leader

To specify a leader’s name to be registered with Virtual Router Redundancy Service (VRRS), use the vrrs leader command.

vrrs leader vrrs-leader-name

 
Syntax Description

vrrs-leader-name

VRRS leader name.

 
Defaults

None

 
Command Modes

config-if-vrrpv3-group mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

6.2(2)

This command was introduced.

 
Usage Guidelines

This command requires the Enterprise Services license.

Examples

This example shows how to specify a leader’s name to be registered with VRRS:

switch# configure terminal
switch(config)# interface ethernet 2/1
switch(config-if)# vrrpv3 5 address-family ipv4
switch(config-if-vrrpv3-group)# address 100.0.1.10 primary
switch(config-if-vrrpv3-group)# description group3
switch(config-if-vrrpv3-group)# match-address
switch(config-if-vrrpv3-group)# preempt delay minimum 30
switch(config-if-vrrpv3-group)# priority 3
switch(config-if-vrrpv3-group)# timers advertise 100
switch(config-if-vrrpv3-group)# vrrs leaderleader1
switch(config-if-vrrpv3-group)#

 
Related Commands

Command
Description

vrrpv3 address-family

Creates a VRRPv3 group and enter VRRPv3 group configuration mode.

vrrs pathway

To define the Virtual Router Redundancy Service (VRRS) pathway for a VRRS group and enter VRRS pathway configuration mode, use the vrrs pathway command.

vrrs pathway vrrs-tag

 
Syntax Description

vrrs-tag

VRRS tag.

 
Defaults

None

 
Command Modes

Interface configuration mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

6.2(2)

This command was introduced.

 
Usage Guidelines

This command requires the Enterprise Services license.

Examples

This example shows how to define the VRRS pathway for a VRRS group and enter VRRS pathway configuration mode:

switch# configure terminal
switch(config)# interface port-channel 100
switch(config-if)# ip address 209.165.200.230 255.255.255.224
switch(config-if)# vrrs pathway path1
switch(config-if-vrrs-pw)#

 
Related Commands

Command
Description

show vrrs pathway

Displays the VRRS pathway information for different pathway states.

show vrrs tag

Displays the VRRS tag information.

show vrrs client

Displays the VRRS client information.

show vrrs server

Displays the VRRS server information.