Cisco Nexus 7000 Series Unicast Routing Command Reference
S Commands
Downloads: This chapterpdf (PDF - 927.0KB) The complete bookPDF (PDF - 18.25MB) | Feedback

Table of Contents

S Commands

set-attached-bit

set as-path

set comm-list delete

set community

set distance

set extcommunity

set extcommunity cost

set extcomm-list delete

set extcommunity rt

set forwarding-address

set interface

set ip address prefix-list

set ip default next-hop

set ip next-hop

set ipv6 default next-hop

set ipv6 next-hop

set level

set local-preference

set metric

set metric-type

set nssa-only

set origin

set path-selection all advertise

set tag

set vrf

set weight

shutdown (BGP)

shutdown (EIGRP)

shutdown (IS-IS)

shutdown (OSPF)

shutdown (OSPFv3)

shutdown (VRRP)

spf-interval

stub

summary-address

summary-address (OSPF)

summary-address (OSPFv3)

suppress-inactive

S Commands

This chapter describes the Cisco NX-OS unicast routing commands that begin with the letter S, except for the show commands.

set-attached-bit

To set the attached (ATT) bit for Intermediate-System-to-Intermediate System (IS-IS), use the set-attached-bit command. To disable this function, use the no form of this command.

set-attached-bit

no set-attached-bit

 
Syntax Description

This command has no arguments or keywords.

 
Defaults

Enabled

 
Command Modes

Router configuration
VRF configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.1(2)

This command was introduced.

 
Usage Guidelines

Use the set-attached-bit command to configure whether to use a Level 1/Level 2 IS-IS router as the default router for Level 1 routers in the same area. If the set-attached-bi t command is disabled, the attached-bit will not be advertised by the router in its Level 1 Link-State Packet (LSP), and other Level 1 routers in the area will not use this router as the default router outside the area.

This command requires the Enterprise Services license.

Examples

This example shows how to unset the attached bit:

switch(config)# router isis Border1
switch(config-router)# no set-attached-bit
 

 
Related Commands

Command
Description

feature isis

Enables IS-IS on the router.

router isis

Enables IS-IS.

set as-path

To modify an autonomous system path (as-path) for Border Gateway Protocol (BGP) routes, use the set as-path command. To not modify the autonomous system (AS) path, use the no form of this command.

set as-path { tag | { prepend as-num [ ... as-num ] | last-as num }}

no as-path { tag | { prepend as-num [.. . as-num ] | last-as num }}

 
Syntax Description

tag

Converts the tag of a route into an autonomous system path. Applies only when redistributing routes into BGP.

prepend as-num

Appends the specified AS number to the autonomous system path of the route that is matched by the route map. Applies to both inbound and outbound BGP route maps. The range is from 1 to 65535. You can configure more than one AS number.

last-as num

Prepends the last AS numbers to the AS path. The range is from 1 to 10.

 
Defaults

The Autonomous system path is not modified.

 
Command Modes

Route-map configuration (config-route-map)

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

You must enter the feature pbr command to enable policy-based routing (PBR) before entering the route-map command.

Use the route-map command to enter route-map configuration mode. Once you enter the route-map command, the prompt changes to the following:

switch(config-route-map)#
 

Once you enter route-map configuration mode, you can enter the set command.

The only global BGP metric available to influence the best-path selection is the autonomous system path length. By varying the length of the autonomous system path, a BGP speaker can influence the best-path selection by a peer further away.

By allowing you to convert the tag into an autonomous system path, the set as-path tag variation of this command modifies the autonomous system length. The set as-path prepend variation allows you to prepend an arbitrary autonomous system path string to BGP routes. Usually, the local autonomous system number is prepended multiple times which increasing the autonomous system path length.

Examples

This example shows how to converts the tag of a redistributed route into an autonomous system path:

switch(config)# route-map test1
switch(config-route-map)# set as-path tag
 

This example shows how to prepend 100 to all the routes advertised to 10.108.1.1:

switch(config)# route-map test1
switch(config-route-map)# match as-path 1
switch(config-route-map)# set as-path prepend 100
!
 
switch(config)# router bgp 64496
switch(config-router)# neighbor 10.108.1.1 remote-as 64497
switch(config-router-neighbor)# address-family ipv4 unicast
switch(config-router-neighbor-af)# route-map set-as-path test1 out

 
Related Commands

Command
Description

match as-path

Matches a BGP autonomous system path access list.

match community

Matches a BGP community.

match ip address

Distributes any routes that have a destination network number address that is permitted by a standard or expanded access list, and performs policy routing on packets.

match ip next-hop

Redistributes any routes that have a next-hop router address passed by one of the access lists specified.

match ip route-source

Redistributes routes that have been advertised by routers and access servers at the address specified by the access lists.

match metric

Redistributes routes with the metric specified.

match tag

Redistributes routes in the routing table that match the specified tags.

route-map (IP)

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.

set as-path

Modifies an autonomous system path for BGP routes.

set community

Sets the BGP communities attribute.

set level

Indicates where to import routes.

set local-preference

Specifies a preference value for the autonomous system path.

set metric

Sets the metric value for a routing protocol.

set metric-type

Sets the metric type for the destination routing protocol.

set next-hop

Specifies the address of the next hop.

set tag

Sets a tag value of the destination routing protocol.

set weight

Specifies the BGP weight for the routing table.

set comm-list delete

To remove communities from the community attribute of an inbound or outbound update, use the set comm-list delete command. To remove a previous set comm-list delete command, use the no form of this command.

set comm-list community-list-name delete

no set comm-list

 
Syntax Description

community-list-name

Standard or expanded community list name. The name is any alphanumeric string up to 63 characters.

 
Command Default

No communities are removed.

 
Command Modes

Route-map configuration (config-route-map)

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

This set command removes communities from the community attribute of an inbound or outbound update using a route map to filter and determine the communities to be deleted. Depending upon whether the route map is applied to the inbound or outbound update for a neighbor, each community that passes the route map permit clause and matches the given community list is removed from the community attribute being received from or sent to the Border Gateway Protocol (BGP) neighbor.

Each entry of a standard community list should list only one community when used with the set comm-list delete command. For example, in order to be able to delete communities 10:10 and 10:20, you must use the following format to create the entries:

switch(config)# ip community-list 500 permit 10:10
switch(config)# ip community-list 500 permit 10:20
 

The following format for a community list entry, while acceptable otherwise, does not work with the set comm-list delete command:

switch(config)# ip community-list 500 permit 10:10 10:20
 

When both the set community community-number and set comm-lis t delete commands are configured in the same sequence of a route-map attribute, the deletion operation ( set comm-list delete ) is performed before the set operation ( set community community-number ).

This command does not require a license.

Examples

This example shows how to remove communities from the community attribute of an inbound or outbound update:

switch(config)# route-map test1
switch(config-route-map)# match as-path 1
switch(config-route-map)# set comm-list list1 delete
 

 
Related Commands

Command
Description

match as-path

Matches a BGP autonomous system path access list.

match community

Matches a BGP community.

match ip address

Distributes any routes that have a destination network number address that is permitted by a standard or expanded access list, and performs policy routing on packets.

match ip next-hop

Redistributes any routes that have a next-hop router address passed by one of the access lists specified.

match ip route-source

Redistributes routes that have been advertised by routers and access servers at the address specified by the access lists.

match metric

Redistributes routes with the metric specified.

match tag

Redistributes routes in the routing table that match the specified tags.

route-map (IP)

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.

set as-path

Modifies an autonomous system path for BGP routes.

set community

Sets the BGP communities attribute.

set level

Indicates where to import routes.

set local-preference

Specifies a preference value for the autonomous system path.

set metric

Sets the metric value for a routing protocol.

set metric-type

Sets the metric type for the destination routing protocol.

set next-hop

Specifies the address of the next hop.

set tag

Sets a tag value of the destination routing protocol.

set weight

Specifies the BGP weight for the routing table.

set community

To set the Border Gateway Protocol (BGP) communities attribute, use the set community command. To delete the entry, use the no form of this command.

set community { none | { aa : nn [... aa:nn ] | additive | local-as | no-advertise | no-export }}

no set community { none | { aa : nn | additive | local-as | no-advertise | no-export }}

 
Syntax Description

none

(Optional) Specifies the no community attribute. You cannot configure any other keyword if you configure the none keyword.

aa : nn

Autonomous system (AS) number and network number entered in the 4-byte new community format. This value is configured with two 2-byte numbers separated by a colon. A number from 1 to 65535 can be entered for each 2-byte number. A single community can be entered or multiple communities can be entered, each separated by a space.

You can configure one ore more AS numbers.

additive

(Optional) Adds to existing community.

You can configure one or more keywords.

local-AS

(Optional) Specifies the local-as community (well-known community). Routes with community are advertised to only peers that are part of the local autonomous system or to only peers within a subautonomous system of a confederation. These routes are not advertised external peers or to other subautonomous systems within a confederation.

You can configure one or more keywords.

no-advertise

(Optional) Specifies the no-advertise community (well-known community). Routes with this community are not advertised to any peer (internal or external).

You can configure one or more keywords.

no-export

(Optional) Specifies the no-export community (well-known community). Routes with this community are advertised to only peers in the same autonomous system or to only other subautonomous systems within a confederation. These routes are not advertised to external peers.

You can configure one or more keywords.

 
Defaults

No BGP communities attributes exist.

 
Command Modes

Route-map configuration (config-route-map)

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

You must have a match clause (even if it points to a “permit everything” list) if you want to set tags.

Use the route-map global configuration command, and the match and set route map configuration commands, to define the conditions for redistributing routes from one routing protocol into another. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria —the conditions under which redistribution is allowed for the current route-map command. The set commands specify the set actions —the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.

The set route map configuration commands specify the redistribution set actions to be performed when all of the match criteria of a route map are met. When all match criteria are met, all set actions are performed.

This command does not require a license.

Examples

This example shows how to configure the routes that pass the autonomous system path access list 1 have the community set to 109:02 and 33:40. Routes that pass the autonomous system path access list 2 have the community set to no-export (these routes will not be advertised to any external BGP [eBGP] peers).

switch(config)# route-map test1 10 permit
switch(config-route-map)# match as-path 1
switch(config-route-map)# set community 109:02 33:40
switch(config-route-map)# exit
switch(config)# route-map test1 20 permit
switch(config-route-map)# match as-path 2
switch(config-route-map)# set community no-export
 

This example shows how to configure the routes that pass the autonomous system path access list 1 have the community set to 109:30. Routes that pass the autonomous system path access list 2 have the community set to local-as (the router will not advertise this route to peers outside the local autonomous system .

switch(config)# route-map test1 10 permit
switch(config-route-map)# match as-path 1
switch(config-route-map)# set community 109:30 additive
switch(config-route-map)# exit
switch(config)# route-map test1 20 permit
switch(config-route-map)# match as-path 2
switch(config-route-map)# set community local-as

 
Related Commands

Command
Description

ip community-list

Creates a community list for BGP and control access to it.

match community

Matches a BGP community.

route-map (IP)

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.

set comm-list delete

Removes communities from the community attribute of an inbound or outbound update.

show ip bgp community

Displays routes that belong to specified BGP communities.

set distance

To set the administrative distance of route, use the set distance command. To disable this function, use the no form of this command.

set distance value

no set distance

 
Syntax Description

value

Specifies the administrative distance for IGP or EBGP routes. The range is from 1 to 255.

 
Defaults

None

 
Command Modes

Route-map configuration (config-route-map)

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

6.1(1)

This command was introduced.

 
Usage Guidelines

This command requires the Enterprise Services license.

Examples

This example shows how to set the administrative distance of route:

switch(config)# route-map test1
switch(config-route-map) set distance 200
switch(config-route-map)#

 
Related Commands

Command
Description

set as-path

Modifies an autonomous system path for BGP routes.

set extcommunity

To set the Border Gateway Protocol (BGP) extended communities attribute, use the set extcommunity command. To delete the entry, use the no form of this command.

set extcommunity { none | { generic { transitive | nontransitive } aa4 : nn [... aa4:nn ]} | additive }

no set extcommunity { none | { generic { transitive | nontransitive } aa4 : nn [... aa4:nn ]} | additive }

 
Syntax Description

none

(Optional) Specifies the no community attribute.

generic

Specifies the generic specific extended community type.

transitive

Configures BGP to propagate the extended community attributes to other autonomous systems.

nontransitive

Configures BGP to propagate the extended community attributes to other autonomous systems.

aa4 : nn

(Optional) Autonomous system number and network number. This value is configured with a 4-byte AS number and a 2-byte network number separated by a colon. The 4-byte AS number range is from 1 to 4294967295 in plaintext notation, or from 1.0 to 56636.65535 in AS.dot notation. You can enter a single community or multiple communities, each separated by a space.

additive

(Optional) Adds to existing community.

 
Defaults

No BGP communities attributes exist.

 
Command Modes

Route-map configuration (config-route-map)

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.2(1)

This command was introduced.

 
Usage Guidelines

Use the set extcommunity command in a route map to set the extended community attribute in a BGP route.

You must have a match clause in a route map (even if it points to a “permit everything” list) if you want to use set commands.

The set commands specify the set actions to be performed when all of the match criteria of a route map are met. When all match criteria are met, all set actions are performed.

This command does not require a license.

Examples

This example shows how to configure a route map that sets the extended community to 1.5:

switch(config)# route-map test1 10 permit
switch(config-route-map)# match as-path 1
switch(config-route-map)# set extcommunity generic transitive 1.5
switch(config-route-map)# exit

 
Related Commands

Command
Description

ip extcommunity-list

Creates a community list for BGP and controls access to it.

route-map

Defines the conditions for redistributing routes from one routing protocol into another.

send-community

Configures BGP to propagate community attributes to BGP peers.

match extcommunity

Matches an extended community in a route map.

ip extcommunity-list

Creates a community list for BGP and controls access to it.

set extcommunity cost

To configure the Border Gateway Protocol (BGP) cost-extended community attribute, use the set extcommunity cost command. To remove the BGP cost-extended community attribute, use the no form of this command.

set extcommunity cost [0-255 | igp community-id cost-value | pre-bestpath community-id cost-value]

no set extcommunity cost [0- 255 | igp community-id cost-value | pre-bestpath community-id cost-value]

 
Syntax Description

0-255

(Optional) Specifies the community ID. The range is from 0 to 255.

igp

(Optional) Specifies the Interior Gateway Protocol (IGP) cost extended community value.

community-id

Community ID. The range is from 0 to 255.

cost-value

Cost value. The range is from 0 to 4294967295.

pre-bestpath

(Optional) Specifies the best path calculation for the cost-extended community attribute.

 
Defaults

None

 
Command Modes

Route-map config submode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

5.2(1)

This command was introduced.

 
Usage Guidelines

You can configure multiple cost community attributes in each route map block or sequence. Each cost community set clause must have a unique ID.

The cost community set clause with the lowest cost is preferred by the best-path selection process when all other attributes are equal.

If you configure a new cost-extended community attribute against an existing community ID, the new cost replaces the old cost.

This command does not require a license.

Examples

This example shows how to configure the BGP cost-extended community value:

switch# configure terminal
switch(config)# route-map IGP2BGP
switch(config-route-map)# set extcommunity cost igp 23 34512
switch(config-route-map)#
 

This example shows how to remove the BGP cost-extended community value:

switch# configure terminal
switch(config)# route-map IGP2BGP
switch(config-route-map)# no set extcommunity cost igp 23 34512
switch(config-route-map)#

 
Related Commands

Command
Description

route-map

Defines the conditions for redistributing routes from one routing protocol into another.

send-community

Configures BGP to propagate community attributes to BGP peers.

set extcommunity

Sets the Border Gateway Protocol (BGP) extended community attributes.

set extcommunity rt

Configure the Border Gateway Protocol (BGP) route target (RT) extended community attributes.

set extcomm-list delete

To remove extended communities from the extended community attribute of an inbound or outbound Border Gateway Protocol (BGP) update, use the set extcomm-list delete command. To remove a previous set extcomm-list delete command, use the no form of this command.

set extcomm-list community-list-name delete

no set extcomm-list

 
Syntax Description

community-list-name

Standard or expanded extended community list name. The name is any alphanumeric string up to 63 characters.

 
Defaults

No communities are removed.

 
Command Modes

Route-map configuration (config-route-map)

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.2(1)

This command was introduced.

 
Usage Guidelines

Use the set extcomm-list command in a route map to delete the extended community attribute in a BGP route.

You must have a match clause in a route-map (even if it points to a “permit everything” list) if you want to use the set commands.

The set commands specify the set actions to be performed when all of the match criteria of a route map are met. When all match criteria are met, all set actions are performed.

When you configure both the set extcommunity community-number and set ext comm-lis t delete commands in the same sequence of a route-map attribute, the deletion operation ( set extcomm-list delete ) is performed before the set operation ( set extcommunity community-number ).

This command does not require a license.

Examples

This example shows how to remove extended communities from the extended community attribute of an inbound or outbound update:

switch(config)# route-map test1
switch(config-route-map)# match as-path 1
switch(config-route-map)# set extcomm-list list1 delete
 

 
Related Commands

Command
Description

match as-path

Matches a BGP autonomous system path access list.

match extcommunity

Matches a BGP extended community.

set extcommunity

Sets the BGP extended communities attribute.

set extcommunity rt

To configure the Border Gateway Protocol (BGP) route target RT-extended community attribute, use the set extcommunity rt command. To remove the BGP RT attribute, use the no form of this command.

set extcommunity rt {extended-community additive] | [additive]}

no set extcommunity rt {extended-community additive] | [additive]}

 
Syntax Description

extended-community

Specifies the extended community name. The extended community name can be specified in the following format:

ASN2:NN: Autonomous system number in the range from 1 to 65535 followed by an integer in the range from 1 to 4294967295.

ASN4:NN: Extended community number in the AA4:NN2 format: 1-4294967295: 1-65535 (or) in the AA2.AA2:NN2 format: 1-65535.1-65535:1-65535.

IPV4:NN: IP address in the dotted decimal format followed by an integer, the range is from 1 to 65535.

additive

Adds to an existing route target RT-extended community.

 
Defaults

None

 
Command Modes

Route-map config submode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

5.2(1)

This command was introduced.

 
Usage Guidelines

Use the show running-config command to display the format in which the RT-extended communities were configured. The RT extended communities are stored in an ascending order.

This command does not require a license.

Examples

This example shows how to configure the BGP RT-extended community attribute:

switch# configure terminal
switch(config)# route-map IGP2BGP
switch(config-route-map)# set extcommunity rt 10.20:30 additive
switch(config-route-map)#

This example shows how to remove the BGP RT-extended community attribute:

switch# configure terminal
switch(config)# route-map IGP2BGP
switch(config-route-map)# no set extcommunity rt 10.20:30 additive
switch(config-route-map)#

 
Related Commands

Command
Description

route-map

Defines the conditions for redistributing routes from one routing protocol into another.

send-community

Configures BGP to propagate community attributes to BGP peers.

set extcommunity

Configures the BGP extended communities attribute.

set extcommunity cost

Configures the BGP cost-extended community attribute.

set forwarding-address

To set the Open Shortest Path First (OSPF) forwarding address for redistributed type-5 link-state advertisements (LSAs), use the set forwarding-address command. To remove the address, use the no form of this command.

set forwarding-address

no forwarding-address

 
Syntax Description

This command has no arguments or keywords.

 
Defaults

No forwarding address is set as a default.

 
Command Modes

Route-map configuration (config-route-map)

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

This command is used by the OSPF to set the forwarding address for the redistributed type-5 LSAs. The value of the forwarding address specified by the autonomous system boundary router (ASBR) can be either 0.0.0.0 or non zero. The 0.0.0.0 address indicates that the originating router (the ASBR) is the next hop:

The forwarding address is set to 0.0.0.0 if the ASBR redistributes routes and OSPF is not enabled on the next hop interface for those routes. This is true if Router 1 does not have OSPF enabled on the Ethernet interface.

All of the following conditions must be met to set the forwarding address field to a nonzero address:

  • OSPF is enabled on the ASBR's next-hop interface.
  • ASBR’s next-hop interface is non passive under OSPF.
  • ASBR’s next-hop interface is not point to point.
  • ASBR’s next-hop interface is not point to multipoint.

Any other conditions besides those listed previously, set the forwarding address to 0.0.0.0.

This command does not require a license.

Examples

This example shows how to set the forwarding address:

switch(config)# route-map test1 10 permit
switch(config-route-map)# set forwarding-address

 
Related Commands

Command
Description

match as-path

Matches a BGP autonomous system path access list.

match community

Matches a BGP community.

match ip address

Distributes any routes that have a destination network number address that is permitted by a standard or expanded access list, and performs policy routing on packets.

match ip next-hop

Redistributes any routes that have a next-hop router address passed by one of the access lists specified.

match ip route-source

Redistributes routes that have been advertised by routers and access servers at the address specified by the access lists.

match metric

Redistributes routes with the metric specified.

match tag

Redistributes routes in the routing table that match the specified tags.

route-map (IP)

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.

set as-path

Modifies an autonomous system path for BGP routes.

set community

Sets the BGP communities attribute.

set level

Indicates where to import routes.

set local-preference

Specifies a preference value for the autonomous system path.

set metric

Sets the metric value for a routing protocol.

set metric-type

Sets the metric type for the destination routing protocol.

set next-hop

Specifies the address of the next hop.

set tag

Sets a tag value of the destination routing protocol.

set weight

Specifies the BGP weight for the routing table.

set interface

To configure an interface to be used for routing, use the set interface command. To revert to the default settings, use the no form of this command.

set interface [null 0 | tunnel-te]

no set interface [null 0 | tunnel-te]

 
Syntax Description

null 0

(Optional) Specifies the null interface. The valid value is 0.

tunnel-te

(Optional) Specifies the traffic engineering (TE) interface. The range is from 0 to 65503.

 
Defaults

None

 
Command Modes

Route-map config submode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

5.2(1)

This command was introduced.

 
Usage Guidelines

The set interface command is used only for policy-based routing (PBR) and is ignored if it is present in a route map that is used for route redistribution or filtering. To remove the static routing for tunnels, use the no set interface command.

When you enter the Null 0 keywords, packets drop.

When you enter the Te-Tunnel keyword, packet are redirected to that TE tunnel if the TE tunnel is up. If the TE tunnel is down, packets are routed to the default tunnel.

This command does not require a license.

Examples

This example shows how to configure an interface to be used for routing:

switch# configure terminal
switch(config)# route-map routemap123
switch(config-route-map)# set interface tunnel-te 25
switch(config-route-map)#
 

This example shows how to remove the static routing for tunnels:

switch# configure terminal
switch(config)# route-map routemap123
switch(config-route-map)# no set interface tunnel-te 25
switch(config-route-map)#

 
Related Commands

Command
Description

route-map

Defines the conditions for redistributing routes from one routing protocol into another.

set local-preference

Specifies a preference value for the autonomous system path.

set ip address prefix-list

To specify the map routes to be injected, use the set ip address prefix-list command.

set ip address prefix-list prefix-list-name

 
Syntax Description

prefix-list-name

Prefix list name.

 
Defaults

None

 
Command Modes

config-route-map mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

6.2(2)

This command was introduced.

 
Usage Guidelines

This command requires the Enterprise Services license.

Examples

This example shows how to specify the map routes to be injected:

switch# configure terminal
switch(config)# router bgp 40000
switch(config-router)# address-family ipv4 unicast
switch(config-router-af)# inject-map ORIGINATE exist-map AGGREGATEcopy-attributes
switch(config-router-af)# exit
switch(config-router)# exit
switch(config)# ip prefix-list AGGREGATE-Route seq 5 permit 10.1.1.0/24
switch(config)# route-map AGGREGATE permit 10
switch(config-route-map)# match ip address prefix-list AGGREGATE-Route
switch(config-route-map)# match ip route-source prefix-list AGGREGATE-Source
switch(config-route-map)# exit
switch(config)# ip prefix-list ORIGINATE-Route seq 4 permit 10.1.1.128/25
switch(config)# route-map ORIGINATE permit 10
switch(config-route-map)# set ip address prefix-list ORIGINATE-Route
switch(config-route-map)#

 
Related Commands

Command
Description

inject-map

Specifies the inject-map and exist-map routes for conditional route injection.

router bgp

Enters Border Gateway Protocol (BGP) configuration mode and assigns the autonomous system number to the local BGP speaker.

set ip default next-hop

To configure a route map that sets the next-hop IPv4 address as the default, use the set ip default next-hop command. To delete an entry, use the no form of this command.

set ip default next-hop ip-address [ ...ip-address ] [ load-share ]

no set ip default next-hop ip-address [ ...ip-address ]

 
Syntax Description

ip-address

IPv4 address of the next hop to which packets are output.The next hop must be an adjacent router. You can configure up to 32 IP addresses.

load-share

(Optional) Enables load sharing.

 
Defaults

Disabled

 
Command Modes

Route-map configuration (config-route-map)

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

An ellipsis (...) in the command syntax indicates that your command input can include multiple values for the ip-address argument .

Use this command to provide certain users a different default route. If the software has no explicit route for the destination in the packet, it routes the packet to this next hop. The first next hop specified with the set ip default next-hop command needs to be adjacent to the router. The optional specified IP addresses are tried in turn.

Use the ip policy route-map command, the route-map global configuration command, and the match and set commands to define the conditions for policy routing packets. The ip policy route-map command identifies a route map by name. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria —the conditions under which policy routing occurs. The set commands specify the set actions —the particular routing actions to perform if the criteria enforced by the match commands are met.

The set clauses can be used with one another. They are evaluated in the following order:

1. set ip next-hop

2. set ip default next-hop


Note The set ip next-hop and set ip default next-hop command are similar but have a different order of operations. Configuring the set ip next-hop command causes the system to use policy routing first and then use the routing table. Configuring the set ip default next-hop command causes the system to use the routing table first and then policy route the specified next hop.


This command does not require a license.

Examples

This example shows how to configure a route map that sets the IPv4 default next-hop address as the default:

switch(config)# ip access-list test
switch(config-ip-acl)# permit ip 192.0.2.0/24 any
switch(config-ip-acl)# exit
switch(config)# route-map equal-access
switch(config-route-map)# match ip address test
switch(config-route-map)# set ip default next-hop ip 192.0.2.3
switch(config-route-map))# exit
switch(config)# interface externet 2/1
switch(config-if)# ip policy route-map equal-access
 
 

 
Related Commands

Command
Description

match as-path

Matches a BGP autonomous system path access list.

match community

Matches a BGP community.

match ip address

Distributes any routes that have a destination network number address that is permitted by a standard or expanded access list, and performs policy routing on packets.

match ip next-hop

Redistributes any routes that have a next hop router address passed by one of the access lists specified.

match ip route-source

Redistributes routes that have been advertised by routers and access servers at the address specified by the access lists.

match metric

Redistributes routes with the metric specified.

match tag

Redistributes routes in the routing table that match the specified tags.

route-map (IP)

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.

set as-path

Modifies an autonomous system path for BGP routes.

set community

Sets the BGP communities attribute.

set level

Indicates where to import routes.

set local-preference

Specifies a preference value for the autonomous system path.

set metric

Sets the metric value for a routing protocol.

set metric-type

Sets the metric type for the destination routing protocol.

set next-hop

Specifies the address of the next hop.

set tag

Sets a tag value of the destination routing protocol.

set weight

Specifies the BGP weight for the routing table.

set ip next-hop

To configure a route map that sets the next-hop IPv4 address, use the set ip next-hop command in route-map configuration mode. To delete an entry, use the no form of this command.

set ip next-hop { ip-address [ ... ip-address ] [ load-share] | peer-address }

no set ip next-hop { ip-address [ ... ip-address ] [ load-share] | peer-address }

 
Syntax Description

ip-address

IP address of the next hop to which packets are output. The next-hop does not need to be adjacent router. You can configure one or more IP addresses.

load-share

(Optional) Enables load sharing.

peer-address

Sets the next hop to be the Border Gateway Protocol (BGP) peering address.

 
Defaults

This command is disabled by default.

 
Command Modes

Route-map configuration (config-route-map)

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

An ellipsis (...) in the command syntax indicates that your command input can include multiple values for the ip-address argument .

Use the ip policy route-map command, the route-map command, and the match and set commands to define the conditions for policy routing packets. The ip policy route-map command identifies a route map by name. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria —the conditions under which policy routing occurs. The set commands specify the set actions —the particular routing actions to perform if the criteria enforced by the match commands are met.

If the first next hop specified with the set ip next-hop command is down, the optionally specified IP addresses are tried in turn.

When the set ip next-hop command is used with the peer-address keyword in an inbound route map of a BGP peer, the next hop of the received matching routes will be set to be the neighbor peering address, overriding any third-party next hops. The same route map can be applied to multiple BGP peers to override third-party next hops.

When the set ip next-hop command is used with the peer-address keyword in an outbound route map of a BGP peer, the next-hop of the advertised matching routes will be set to be the peering address of the local router which disables the next-hop calculation. The set ip next-hop command has finer granularity than the (per-neighbor) neighbor next-hop-self command, because you can set the next hop for some routes, but not for others. The neighbor next-hop-sel f command sets the next hop for all routes sent to that neighbor.

The set clauses can be used with one another. They are evaluated in the following order:

1. set ip next-hop

2. set ip default next-hop

This command does not require a license.

Examples

This example shows three routers are on the same LAN (with IP addresses 10.1.1.1, 10.1.1.2, and 10.1.1.3). Each is in a different autonomous system. The set ip next-hop peer-address command specifies that traffic counter from the router (10.1.1.3) in remote autonomous system 64496 for the router (10.1.1.1) in remote autonomous system 64497 that matches the route map is passed through the router bgp 64498, rather than sent directly to the router (10.1.1.1) in autonomous system 100.

switch(config)# router bgp 64498
switch(config-router)# neighbor 10.1.1.3 remote-as 64496
switch(config-router)# neighbor 10.1.1.3 route-map set-peer-address out
switch(config-router)# neighbor 10.1.1.1 remote-as 64497
!
switch(config)# route-map set-peer-address permit 10
switch(config-route-map)# set ip next-hop peer-address

 
Related Commands

Command
Description

ip policy route-map

Identifies a route map to use for policy routing on an interface.

match ip address

Distributes any routes that have a destination network number address that is permitted by a standard or expanded access list, and performs policy routing on packets.

match length

Bases policy routing on the Level 3 length of a packet.

route-map

Defines the conditions for redistributing routes from one routing protocol to another, or enables policy routing.

set ip default next-hop

Indicates where to output packets that pass a match clause of a route map for policy routing and for which the Cisco NX-OS software has no explicit route to a destination.

set ipv6 default next-hop

To indicate where to output packets that pass a match clause of a route map for policy routing and for which the Cisco NX-OS software has no explicit route to a destination, use the set ipv6 default next-hop command. To delete an entry, use the no form of this command.

set ipv6 default next-hop ipv6-address [ ...ipv6-address ] [ load-share ]

no set ipv6 default next-hop ipv6-address [ ...ipv6-address ]

 
Syntax Description

ipv6-address

IPv6 address of the next hop to which packets are output.The next hop must be an adjacent router. You can configure up to 32 IPv6 addresses.

load-share

(Optional) Enables load sharing.

 
Defaults

This command is disabled by default.

 
Command Modes

Route-map configuration (config-route-map)

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.2(1)

This command was introduced.

 
Usage Guidelines

An ellipsis (...) in the command syntax indicates that your command input can include multiple values for the ipv6-address argument .

Use this command to provide certain users a different default route. If the software has no explicit route for the destination in the packet, then it routes the packet to this next hop. The first next hop specified with the set ipv6 default next-hop command needs to be adjacent to the router. The optional specified IP addresses are tried in turn.

Use the ipv6 policy route-map i nterface configuration command, the route-map global configuration command, and the match and set route-map configuration commands to define the conditions for policy routing packets. The ipv6 policy route-map command identifies a route map by name. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria —the conditions under which policy routing occurs. The set commands specify the set actions —the particular routing actions to perform if the criteria enforced by the match commands are met.

The set clauses can be used with one another. They are evaluated in the following order:

1. set ipv6 next-hop

2. set ipv6 default next-hop


Note The set ipv6 next-hop and set ipv6 default next-hop are similar commands but have a different order of operations. Configuring the set ipv6 next-hop command causes the system to use policy routing first and then use the routing table. Configuring the set ipv6 default next-hop command causes the system to use the routing table first and then policy route the specified next hop.


This command does not require a license.

Examples

This example shows how to configure a route map that sets the IPv6 default next-hop address:

switch(config)# ipv6 access-list test
switch(config-ipv6-acl)# permit ipv6 2001:0DB8::/48 any
switch(config-ipv6-acl)# exit
switch(config)# route-map equal-access
switch(config-route-map)# match ipv6 address test
switch(config-route-map)# set ipv6 default next-hop 2001:0DB8::3
switch(config-route-map))# exit
switch(config)# interface externet 2/1
switch(config-if)# ipv6 policy route-map equal-access
 

 
Related Commands

Command
Description

match as-path

Matches a BGP autonomous system path access list.

match community

Matches a BGP community.

match ipv6 address

Distributes any routes that have a destination network number address that is permitted by a standard or expanded access list, and performs policy routing on packets.

match ipv6 next-hop

Redistributes any routes that have a next hop router address passed by one of the access lists specified.

match ipv6 route-source

Redistributes routes that have been advertised by routers and access servers at the address specified by the access lists.

match metric

Redistributes routes with the metric specified.

match tag

Redistributes routes in the routing table that match the specified tags.

route-map

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.

set as-path

Modifies an autonomous system path for BGP routes.

set community

Sets the BGP communities attribute.

set level

Indicates where to import routes.

set local-preference

Specifies a preference value for the autonomous system path.

set metric

Sets the metric value for a routing protocol.

set metric-type

Sets the metric type for the destination routing protocol.

set next-hop

Specifies the address of the next hop.

set tag

Sets a tag value of the destination routing protocol.

set weight

Specifies the BGP weight for the routing table.

set ipv6 next-hop

To indicate where to output packets that pass a match clause of a route map for policy routing, use the set ipv6 next-hop command in route-map configuration mode. To delete an entry, use the no form of this command.

set ipv6 next-hop { ipv6-address [ ... ipv6-address ] [ load-share] | peer-address }

no set ipv6 next-hop { ipv6-address [ ... ipv6-address ] [ load-share] | peer-address }

 
Syntax Description

ipv6-address

IPv6 address of the next hop to which packets are output. It need not be an adjacent router. You can configure one or more IP addresses.

load-share

(Optional) Enables load sharing.

peer-address

Sets the next hop to be the BGP peering address.

 
Defaults

This command is disabled by default.

 
Command Modes

Route-map configuration (config-route-map)

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.2(1)

This command was introduced.

 
Usage Guidelines

An ellipsis (...) in the command syntax indicates that your command input can include multiple values for the ipv6-address argument .

Use this command to provide certain users a different default route. If the software has no explicit route for the destination in the packet, then it routes the packet to this next hop. The first next hop specified with the set ipv6 default next-hop command needs to be adjacent to the router. The optional specified IP addresses are tried in turn.

Use the ipv6 policy route-map i nterface configuration command, the route-map global configuration command, and the match and set route-map configuration commands to define the conditions for policy routing packets. The ipv6 policy route-map command identifies a route map by name. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria —the conditions under which policy routing occurs. The set commands specify the set actions —the particular routing actions to perform if the criteria enforced by the match commands are met.

The set clauses can be used with one another. They are evaluated in the following order:

1. set ipv6 next-hop

2. set ipv6 default next-hop


Note The set ipv6 next-hop and set ipv6 default next-hop commands are similar but have a different order of operations. Configuring the set ipv6 next-hop command causes the system to use policy routing first and then use the routing table. Configuring the set ipv6 default next-hop command causes the system to use the routing table first and then policy route the specified next hop.


This command does not require a license.

Examples

This example shows how to configure a route map that sets the IPv6 next-hop address:

switch(config)# ipv6 access-list test
switch(config-ipv6-acl)# permit ipv6 2001:0DB8::/48 any
switch(config-ipv6-acl)# exit
switch(config)# route-map equal-access
switch(config-route-map)# match ipv6 address test
switch(config-route-map)# set ipv6 next-hop 2001:0DB8::3
switch(config-route-map))# exit
switch(config)# interface externet 2/1
switch(config-if)# ipv6 policy route-map equal-access
 

 
Related Commands

Command
Description

match as-path

Matches a BGP autonomous system path access list.

match community

Matches a BGP community.

match ipv6 address

Distributes any routes that have a destination network number address that is permitted by a standard or expanded access list, and performs policy routing on packets.

match ipv6 next-hop

Redistributes any routes that have a next-hop router address passed by one of the access lists specified.

match ipv6 route-source

Redistributes routes that have been advertised by routers and access servers at the address specified by the access lists.

route-map

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.

set ipv6 default next-hop

Specifies the address of the next hop.

set level

To indicate where to import routes, use the set level command. To delete an entry, use the no form of this command.

set level { level-1 | level-2 | level-1-2 }

no set level { level-1 | level-2 | level-1-2 }

 
Syntax Description

level-1

Imports routes into a Level 1 area.

level-2

Imports routes into a Level 2 subdomain.

level-1-2

Imports routes into Level 1 and Level 2.

 
Defaults

This command is disabled by default.

 
Command Modes

Route-map configuration (config-route-map)

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

Use the route-map command, and the match and set commands to define the conditions for redistributing routes from one routing protocol into another. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria —the conditions under which redistribution is allowed for the current route-map command. The set commands specify the set actions —the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.

The set route-map configuration commands specify the redistribution set actions to be performed when all the match criteria of a route map are met. When all match criteria are met, all set actions are performed.

This command does not require a license.

Examples

This example shows how to import the routes into the Level 1 area:

switch(config-router)# route-map testcase
switch(config-route-map)# set level level-l

 
Related Commands

Command
Description

ip policy route-map

Identifies a route map to use for policy routing on an interface.

match ip address

Distributes any routes that have a destination network number address that is permitted by a standard or expanded access list, and performs policy routing on packets.

match length

Bases policy routing on the Level 3 length of a packet.

neighbor next-hop-self

Disables next hop processing of BGP updates on the router.

route-map (IP)

Defines the conditions for redistributing routes from one routing protocol to another, or enables policy routing.

set ip default next-hop

Indicates where to output packets that pass a match clause of a route map for policy routing and for which the Cisco NX-OS software has no explicit route to a destination.

set local-preference

To specify a preference value for the autonomous system path, use the set local-preference command in route-map configuration mode. To delete an entry, use the no form of this command.

set local-preference number-value

no set local-preference number-value

 
Syntax Description

number-value

Preference value. The range is from 0 to 4294967295.

 
Defaults

Preference value of 100.

 
Command Modes

Route-map configuration (config-route-map)

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

The preference is sent only to all routers in the local autonomous system.

You must have a match clause (even if it points to a “permit everything” list) if you want to set tags.

Use the route-map command, and the match and set to define the conditions for redistributing routes from one routing protocol into another. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria —the conditions under which redistribution is allowed for the current route-map command. The set commands specify the set actions —the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.

The set commands specify the redistribution set actions to be performed when all the match criteria of a route map are met. When all match criteria are met, all set actions are performed.

You can change the default preference value with the bgp default local-preference command.

This command does not require a license.

Examples

This example shows how to set the local preference to 100 for all routes that are included in access list 1:

switch(config-router)# route-map map-preference
switch(config-route-map)# match as-path 1
switch(config-route-map)# set local-preference 100

 
Related Commands

Command
Description

match as-path

Matches a BGP autonomous system path access list.

match community

Matches a BGP community.

match interface (IP)

Distributes routes that have their next-hop out one of the interfaces specified.

match ip address

Distributes any routes that have a destination network number address that is permitted by a standard or expanded access list, and performs policy routing on packets.

match ip next-hop

Redistributes any routes that have a next-hop router address passed by one of the access lists specified.

match ip route-source

Redistributes routes that have been advertised by routers and access servers at the address specified by the access lists.

match metric (IP)

Redistributes routes with the metric specified.

match route-type (IP)

Redistributes routes of the specified type.

match tag

Redistributes routes in the routing table that match the specified tags.

route-map (IP)

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.

set automatic-tag

Automatically computes the tag value.

set community

Sets the BGP communities attribute.

set ip next-hop

Specifies the address of the next hop.

set level (IP)

Indicates where to import routes.

set local-preference

Specifies a preference value for the autonomous system path.

set metric (BGP, OSPF, RIP)

Sets the metric value for a routing protocol.

set metric-type

Sets the metric type for the destination routing protocol.

set origin (BGP)

Sets the BGP origin code.

set tag (IP)

Sets the value of the destination routing protocol.

set metric

To set the metric value for a routing protocol, use the set metric command. To return to the default metric value, use the no form of this command.

set metric [ + | - ] bandwidth-metric

set metric bandwidth-metric [d elay-metric reliability-metric load-metric mtu ]

no set metric

 
Syntax Description

+

(Optional) Adds to the existing delay metric value.

-

(Optional) Subtracts from the existing delay metric value.

bandwidth-metric

Interior Gateway Routing Protocol (IGRP) bandwidth metric, in Kb/s. The range is from 0 to 4294967295.

delay-metric

(Optional) Interior Gateway Routing Protocol (IGRP) delay metric, in 10 microsecond units. The range is from 1 to 4294967295.

reliability-metric

(Optional) IGRP reliability metric. The range is from 0 to 255.

load-metric

(Optional) IGRP load metric. The range is from 1 to 255.

mtu

(Optional) IGRP maximum transmission unit (MTU) of the path. The range is from 1 to 4294967295.

 
Defaults

None

 
Command Modes

Route-map configuration (config-route-map)

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

4.1(2)

Added the + and - keywords.

 
Usage Guidelines

Use the set metric command to modify the IGRP metric values.


Note We recommend that you consult your Cisco technical support representative before changing the default value.


When you configure the reliability-metric and the load-metric arguments, 255 means 100 percent reliability.

Use the + or - keywords to modify the existing delay metric value. You can modify only the delay metric with these keywords.

Use the route-map command and the match and set command to define the conditions for redistributing routes from one routing protocol into another. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria —the conditions under which redistribution is allowed for the current route-map command. The set commands specify the set actions —the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.

The set commands specify the redistribution set actions to be performed when all the match criteria of a route map are met. When all match criteria are met, all set actions are performed.

This command does not require a license.

Examples

This example shows how to set the bandwidth metric value for the routing protocol to 100:

switch(config)# route-map set-metric
switch(config-route-map)# set metric 100
 

This example shows how to increase the bandwidth metric value for the routing protocol by 100:

switch(config)# route-map set-metric
switch(config-route-map)# set metric +100
 

 
Related Commands

Command
Description

route-map

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.

set metric-type

To set the metric type for the destination routing protocol, use the set metric-type command. To return to the default, use the no form of this command.

set metric-type { internal | external | type-1 | type-2 }

no set metric-type { internal | external | type-1 | type-2 }

 
Syntax Description

internal

Specifies the Intermediate System-to-Intermediate System (IS-IS) internal metric, or the Interior Gateway Protocol (IGP) metric as the multi-exit discriminator (MED) for Border Gateway Protocol (BGP).

external

Specifies the IS-IS external metric.

type-1

Specifies the Open Shortest Path First (OSPF) external Type 1 metric.

type-2

Specifies the OSPF external Type 2 metric.

 
Defaults

This command is disabled by default.

 
Command Modes

Route-map configuration (config-route-map)

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

Use the route-map command with the match and set commands to define the conditions for redistributing routes from one routing protocol into another. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria —the conditions under which redistribution is allowed for the current route-map command. The set commands specify the set actions —the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.

The set commands specify the redistribution set actions to be performed when all the match criteria of a route map are met. When all match criteria are met, all set actions are performed.


Note This command is not supported for redistributing routes into the Border Gateway Protocol (BGP).


This command does not require a license.

Examples

This example sets the metric type of the destination protocol to OSPF external Type 1:

switch(config)# route-map map-type
switch(config-route-map)# set metric-type type-1

 
Related Commands

Command
Description

match as-path

Matches a BGP autonomous system path access list.

match community

Matches a BGP community.

match ip address

Distributes any routes that have a destination network number address that is permitted by a standard or expanded access list, and performs policy routing on packets.

match ip next-hop

Redistributes any routes that have a next-hop router address passed by one of the access lists specified.

match ip route-source

Redistributes routes that have been advertised by routers and access servers at the address specified by the access lists.

match metric (

Redistributes routes with the metric specified.

match route-type

Redistributes routes of the specified type.

match tag

Redistributes routes in the routing table that match the specified tags.

route-map

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.

set as-path

Sets a BGP autonomous system path access list.

set community

Sets the BGP communities attribute.

set ip next-hop

Specifies the address of the next hop.

set level

Indicates where to import routes.

set local-preference

Specifies a preference value for the autonomous system path.

set metric

Sets the metric value for a routing protocol.

set metric-type

Sets the metric type for the destination routing protocol.

set origin

Sets the BGP origin code.

set tag

Sets the value of the destination routing protocol.

set nssa-only

To set a type-7 link-state advertisement (LSA) generated on the Autonomous System Boundary Router (ASBR) with no P-bit set and prevent the type-7 to type-5 LSA conversion in Open Shortest Path First (OSPF), use the set nssa-only command. To remove the type-7 configuration control, use the no form of this command.

set nssa-only

no set nssa-only

 
Syntax Description

This command has no arguments or keywords.

 
Defaults

None

 
Command Modes

Route-map config submode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

5.2(1)

This command was introduced.

 
Usage Guidelines

When you use the set nssa-only command, the settings are applied to all not-so-stubby areas (NSSA) with the type-7 LSA that corresponding to that LSA with no has its P-bit set.

This command does not require a license.

Examples

This example shows how to set a type-7 LSA generated on the ASBR and with no P-bit set and prevent the type-7 to type-5 LSA conversion in OSPF:

switch# configure terminal
switch(config)# route-map IGP2BGP
switch(config-route-map)# set nssa-only
switch(config-route-map)#
 

This example shows how to remove the type-7 configuration control:

switch# configure terminal
switch(config)# route-map IGP2BGP
switch(config-route-map)# no set nssa-only
switch(config-route-map)#

 
Related Commands

Command
Description

nssa-external

Displays information about the NSSA external LSAs.

route-map

Defines the conditions for redistributing routes from one routing protocol into another.

show ip ospf

Displays general information about OSPF routing instances.

set origin

To set the Border gateway Protocol (BGP) origin code, use the set origin command. To delete the entry, use the no form of this command.

set origin { egp as-num [: as-num ] | igp | incomplete }

no set origin

 
Syntax Description

egp as-num

Specifies the AS number for a remote exterior gateway protocol (EGP) system. You can specify the AS number as a 2-byte integer, or a 4-byte integer in aa:nn format. The range is from 1 to 65535.

igp

Specifies a local Interior Gateway Protocol (IGP) system.

incomplete

Specifies an unknown heritage.

 
Defaults

Default origin, based on route in main IP routing table.

 
Command Modes

Route-map configuration (config-route-map)

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

You must have a match clause (even if it points to a “permit everything” list) if you want to set tags.

Use the route-map command, and the match and set command, to define the conditions for redistributing routes from one routing protocol into another. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria—the conditions under which redistribution is allowed for the current route-map command. The set commands specify the set actions—the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.

The set route-map commands specify the redistribution set actions to be performed when all of the match criteria of a route map are met. When all match criteria are met, all set actions are performed.

This command does not require a license.

Examples

This example shows how to set the origin of routes that pass the route map to IGP:

switch(config)# route-map set_origin
switch(config-route-map)# match as-path 10
switch(config-route-map)# set origin igp

 
Related Commands

Command
Description

match as-path

Matches a BGP autonomous system path access list.

match community

Matches a BGP community.

match ip address

Distributes any routes that have a destination network number address that is permitted by a standard or expanded access list, and performs policy routing on packets.

match ip next-hop

Redistributes any routes that have a next-hop router address passed by one of the access lists specified.

match ip route-source

Redistributes routes that have been advertised by routers and access servers at the address specified by the access lists.

match metric

Redistributes routes with the metric specified.

match route-type

Redistributes routes of the specified type.

match tag

Redistributes routes in the routing table that match the specified tags.

route-map

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.

set as-path

Sets a BGP autonomous system path access list.

set community

Sets the BGP communities attribute.

set ip next-hop

Specifies the address of the next hop.

set level

Indicates where to import routes.

set local-preference

Specifies a preference value for the autonomous system path.

set metric

Sets the metric value for a routing protocol.

set metric-type

Sets the metric type for the destination routing protocol.

set origin

Sets the BGP origin code.

set tag

Sets the value of the destination routing protocol.

 

 

set path-selection all advertise

To set the path selection criteria for Border Gateway Protocol (BGP), use the set path-selection all advertise command. To delete the entry, use the no form of this command.

set path-selection all advertise

 
Syntax Description

This command has no arguments or keywords.

 
Defaults

None.

 
Command Modes

Route-map configuration (config-route-map)

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

6.1(1)

This command was introduced.

 
Usage Guidelines

This command does not require a license.

Examples

This example shows how to specify that all paths be advertised for the specified prefix:

switch(config)# route-map Path_selection_rmap

switch(config-route-map)# match ip address prefix-list p1

switch(config-route-map)# set path-selection all advertise
switch(config-route-map)#
 

 
Related Commands

Command
Description

route-map

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.

 

set tag

To set a tag value of the destination routing protocol, use the set tag command. To delete the entry, use the no form of this command.

set tag tag-value

no set tag tag-value

 
Syntax Description

tag-value

Name for the tag. The value is an integer from 0 to 4294967295.

 
Defaults

If not specified, the default action is to forward the tag in the source routing protocol onto the new destination protocol.

 
Command Modes

Route-map configuration (config-route-map)

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

Use the route-map command, and the match and set commands, to define the conditions for redistributing routes from one routing protocol into another. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria —the conditions under which redistribution is allowed for the current route-map command. The set commands specify the set actions —the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.

The set commands specify the redistribution set actions to be performed when all the match criteria of a route map are met. When all match criteria are met, all set actions are performed.

This command does not require a license.

Examples

This example shows how to set the tag value of the destination routing protocol to 5:

switch(config)# route-map test
switch(config-route-map)# set tag 5

 
Related Commands

Command
Description

match as-path

Matches a BGP autonomous system path access list.

match community

Matches a BGP community.

match ip address

Distributes any routes that have a destination network number address that is permitted by a standard or expanded access list, and performs policy routing on packets.

match ip next-hop

Redistributes any routes that have a next-hop router address passed by one of the access lists specified.

match ip route-source

Redistributes routes that have been advertised by routers and access servers at the address specified by the access lists.

match metric

Redistributes routes with the metric specified.

match route-type

Redistributes routes of the specified type.

match tag

Redistributes routes in the routing table that match the specified tags.

route-map

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.

set as-path

Sets a BGP autonomous system path access list.

set community

Sets the BGP communities attribute.

set ip next-hop

Specifies the address of the next hop.

set level

Indicates where to import routes.

set local-preference

Specifies a preference value for the autonomous system path.

set metric

Sets the metric value for a routing protocol.

set metric-type

Sets the metric type for the destination routing protocol.

set origin

Sets the BGP origin code.

set tag

Sets the value of the destination routing protocol.

set vrf

To enable a virtual routing and forwarding (VRF) instance selection within a route map for policy-based routing, use the set vrf command. To disable VRF selection within a route map, use the no form of this command.

set vrf { vrf-name | default | management }

no set vrf [ vrf-name | default | management ]

 
Syntax Description

vrf-name

Name assigned to the VRF.

default

Sets the VRF to the default VRF.

management

Sets the VRF to the management VRF.

 
Defaults

No default behavior or values

 
Command Modes

Route-map configuration (config-route-map)

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

The set vrf command was introduced with the MPLS VPN—VRF Selection using Policy Based Routing feature to provide a PBR mechanism for VRF selection. This command is used to enable VRF selection by policy routing packets through a route map. The route map is attached to the incoming interface. Match criteria is defined in an IP access list or in an IP prefix list. Match criteria can also be defined based on packet length with the match length route map command. You must define the VRF prior to the configuring this command, and you must configure the ip policy route-map interface configuration command must be configured to enable policy routing under the interface or subinterface. If the VRF instance is not defined or if policy routing is not enabled, an error message appears in the console when you attempt to configure the set vrf command.

A PBR routing route map can have only one match or set statement per route-map statement. In addition, a match command cannot refer to more than one Access Control list (ACL) for PBR.


Note You cannot configure with the set ip default next-hop, and set ip next-hop List policy routing commands because a packet cannot be set to an interface and the next hop cannot be changed when the VRF instance is specified. An error message will appear in the console if you attempt to configure the set vrf command with any of the four above set clauses.


This command does not require a license.

This example shows how to configure a route-map sequence that selects and sets a VRF instance based on match criteria defined in three different access lists. (The access list configuration is not shown in this example.) If the route map falls through and a match does not occur, the packet is dropped if the destination is local.

switch(config)# route-map PBR-VRF-Selection permit 10
switch(config-route-map)# match ip address 40
switch(config-route-map)# set vrf VRF_1
!
switch(config)# route-map PBR-VRF-Selection permit 20
switch(config-route-map)# match ip address 50
switch(config-route-map)# set vrf VRF_2
!
switch(config)# route-map PBR-VRF-Selection permit 30
switch(config-route-map)# match ip address 60
switch(config-route-map)# set vrf VRF_3

 
Related Commands

Command
Description

access-list (IP standard)

Defines a standard IP access list.

debug ip policy

Displays IP policy routing packet activity.

ip policy route-map

Identifies a route map to use for policy routing on an interface.

ip vrf

Configures a VRF routing table.

ip vrf receive

Inserts the IP address of an interface as a connected route entry in a VRF routing table.

match ip address

Distributes any routes that have a destination network number address that is permitted by a standard or expanded access list, or performs policy routing on packets.

route-map

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.

set weight

To specify the Border Gateway Protocol (BGP) weight for the routing table, use the set weight command. To delete an entry, use the no form of this command.

set weight number

no set weight [ number ]

 
Syntax Description

number

Weight value. The range is from 0 to 65535.

 
Defaults

The weight is not changed by the specified route map.

 
Command Modes

Route-map configuration (config-route-map)

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

The weight is based on the first matched autonomous system path. The weights assigned with the set weight command override the weights assigned using the neighbor weight command.

This command does not require a license.

Examples

This example shows how to set the BGP weight for the routes that match the autonomous system path access list to 200:

switch(config)# route-map set-weight
switch(config-route-map)# match as-path 10
switch(config-route-map)# set weight 200

 
Related Commands

Command
Description

match as-path

Matches a BGP autonomous system path access list.

match community

Matches a BGP community.

match ip address

Distributes any routes that have a destination network number address that is permitted by a standard or expanded access list, and performs policy routing on packets.

match ip next-hop

Redistributes any routes that have a next-hop router address passed by one of the access lists specified.

match ip route-source

Redistributes routes that have been advertised by routers and access servers at the address specified by the access lists.

match metric

Redistributes routes with the metric specified.

match route-type

Redistributes routes of the specified type.

match tag

Redistributes routes in the routing table that match the specified tags.

route-map

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.

set as-path

Sets a BGP autonomous system path access list.

set community

Sets the BGP communities attribute.

set ip next-hop

Specifies the address of the next hop.

set level

Indicates where to import routes.

set local-preference

Specifies a preference value for the autonomous system path.

set metric

Sets the metric value for a routing protocol.

set metric-type

Sets the metric type for the destination routing protocol.

set origin

Sets the BGP origin code.

set tag

Sets the value of the destination routing protocol.

shutdown (BGP)

To shut down an instance of the Border Gateway Protocol (BGP), use the shutdown command. To disable this function, use the no form of this command.

shutdown

no shutdown

 
Syntax Description

This command has no arguments or keywords.

 
Defaults

Enabled

 
Command Modes

Router configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.1(2)

This command was introduced.

 
Usage Guidelines

Use the shutdown command to disable an instance of BGP without removing the configuration.

This command requires the Enterprise Services license.

Examples

This example shows how to disable BGP 64496:

switch(config)# router BGP 64496
switch(config-router)# shutdown

shutdown (EIGRP)

To shut down an instance of the Enhanced Interior Gateway Routing Protocol (EIGRP), use the shutdown command. To disable this function, use the no form of this command.

shutdown

no shutdown

 
Syntax Description

This command has no arguments or keywords.

 
Defaults

Enabled

 
Command Modes

Address family configuration
Router configuration
Router VRF configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

Use the shutdown command to disable an instance of EIGRP without removing the configuration.

This command requires the Enterprise Services license.

Examples

This example shows how to disable EIGRP 209:

switch(config)# router eigrp 209
switch(config-router)# shutdown

shutdown (IS-IS)

To stop an Intermediate System-to-Intermediate System (IS-IS) router process without removing the process configuration, use the shutdown command. To start a stopped IS-IS process, use the no form of this command.

shutdown

no shutdown

 
Syntax Description

This command has no arguments or keywords.

 
Defaults

No process is stopped.

 
Command Modes

Router configuration
VRF configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

Entering the shutdown command stops a router process but does not remove any configuration parameters. The shutdown command is displayed in the running configuration file when enabled.

This command requires the Enterprise Services license.

Examples

This example shows how to stop an active IS-IS process:

switch(config)# router isis firstcompany
switch(config-router)# shutdown
 

This example shows how to start a stopped a IS-IS process:

switch(config)# router isis firstcompany
switch(config-router)# no shutdown

 
Related Commands

Command
Description

feature isis

Enables IS-IS on the router.

router isis

Enables IS-IS.

shutdown (OSPF)

To stop an Open Shortest Path First (OSPF) instance without removing the configuration, use the shutdown command. To start a stopped OSPF instance, use the no form of this command.

shutdown

no shutdown

 
Syntax Description

This command has no arguments or keywords.

 
Defaults

No process is stopped.

 
Command Modes

Router configuration
VRF configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

Entering the shutdown command stops a router process but does not remove any configuration parameters. The shutdown command is displayed in the running configuration file when enabled.

This command requires the Enterprise Services license.

Examples

This example shows how to stop an active OSPF instance:

switch(config)# router ospf firstcompany
switch(config-router)# shutdown
 

 
Related Commands

Command
Description

feature ospf

Enables OSPF on the router.

router ospf

Configures an OSPF instance.

shutdown (OSPFv3)

To stop an Open Shortest Path First (OSPFv3) instance without removing the configuration, use the shutdown command. To start a stopped OSPF instance, use the no form of this command.

shutdown

no shutdown

 
Syntax Description

This command has no arguments or keywords.

 
Defaults

No process is stopped.

 
Command Modes

Router configuration
VRF configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

Entering the shutdown command stops a router process but does not remove any configuration parameters. The shutdown command is displayed in the running configuration file when enabled.

This command requires the Enterprise Services license.

Examples

This example shows how to stop an active OSPFv3 instance:

switch(config)# router ospfv3 firstcompany
switch(config-router)# shutdown
 

 
Related Commands

Command
Description

feature ospfv3

Enables OSPFv3 on the router.

router ospv3f

Configures an OSPF v3 instance.

shutdown (VRRP)

To disable a Virtual Router Redundancy Protocol (VRRP) configuration, use the shutdown command. To enable a VRRP configuration, use the no form of this command.

shutdown

no shutdown

 
Syntax Description

This command has no arguments or keywords.

 
Defaults

Disabled

 
Command Modes

VRRP configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modified

4.0(1)

This command was introduced.

 
Usage Guidelines

Shut down the virtual router before configuring the virtual router parameters; you can only configure the virtual router after it is in an administrative shutdown state. Enter the no shutdown command to update the virtual router state after completing configuration.

This command does not require a license.

Examples

This example shows how to shut down a VRRP group:

switch(config-if)# vrrp 45
switch(config-if-vrrp)# shutdown
switch(config-if-vrrp)# address 6.6.6.45
switch(config-if-vrrp)# no shutdown

 
Related Commands

Command
Description

feature vrrp

Enables VRRP.

show vrrp

Displays VRRP configuration information.

clear vrrp

Clears all the software counters for the specified virtual router.

spf-interval

To configure the minimum interval between arrivals of a link-state advertisement (LSA), use the spf-interval command. To return to the default setting, use the no form of this command.

spf-interval [ level-1 | level-2 ] spf-max-wait [ spf-initial-wait spf-second-wait ]

no spf-interval

 
Syntax Description

level-1

Specifies the shortest path first (SPF) level-1 interval.

level-2

Specifies the SPF level-2 interval.

spf-max-wait

Maximum interval (in milliseconds) between two consecutive SPF calculations. The range is from 500 to 65535.

spf-initial-wait

(Optional) Initial SPF calculation delay (in milliseconds) after a topology change. The range is from 50 to 65535.

spf-second-wait

(Optional) Hold time between the first and second SPF calculation (in milliseconds). The range is from 50 to 65535.

 
Defaults

None

 
Command Modes

Router configuration
VRF configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

An LSA is used to advertise connected networks.

This command requires the Enterprise Services license.

Examples

This example shows how to set the minimum interval time between arrivals of LSA:

switch(config)# router isis firstcompany
switch(config-router)# spf-interval level-1 500 500 500

 
Related Commands

Command
Description

feature isis

Enables IS-IS on the router.

router isis

Enables IS-IS.

 

stub

To configure a router as a stub using the Enhanced Interior Gateway Routing Protocol (EIGRP), use the stub command. To disable the EIGRP stub routing feature, use the no form of this command.

stub [ [ direct | static | summary | redistributed]] + [leak-map map-name] | receive-only ]

no stub [ [ direct | static | summary | redistributed]] + [leak-map map-name] | receive-only ]

 
Syntax Description

direct

(Optional) Advertises directly connected routes.

static

(Optional) Advertises static routes.

summary

(Optional) Advertises summary routes.

redistributed

(Optional) Advertises redistributed routes from other protocols and autonomous systems.

leak-map map-name

(Optional) Allows dynamic prefixes based on the leak map.

receive-only

(Optional) Sets the router as a receive-only neighbor.

redistributed

(Optional) Advertises redistributed routes from other protocols and autonomous systems.

 
Defaults

Disabled

 
Command Modes

Address-family configuration
Router configuration
Router VRF configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

5.2(5) and 6.1

Added static and summary keywords to the syntax description.

4.0(1)

This command was introduced.

 
Usage Guidelines

Use the stub command to configure a router as a stub where the router directs all IP traffic to a distribution router.

The direct keyword permits EIGRP stub routing to advertise connected routes. This option is enabled by default.

The receive-only keyword restricts the router from sharing any of its routes with any other router in that EIGRP autonomous system, and the receive-only keyword does not permit any other option to be specified because it prevents any type of route from being sent.

The redistributed keyword permits the EIGRP Stub Routing feature to send other routing protocols and autonomous systems. Without the configuration of this option, EIGRP will not advertise redistributed routes.

If you use any of these four keywords ( direct , leak-map , receive-only , redistributed ) with the stub command, only the route types specified by the particular keyword(s) are advertised.

This command requires the Enterprise Services license.

Examples

This example shows how to configure the router as a receive-only neighbor:

switch(config)# router eigrp 1
switch(config-router)# stub receive-only

summary-address

To create the Intermediate-System-to Intermediate System (IS-IS) aggregate addresses, use the summary-address command. To remove the aggregate address, use the no form of this command.

summary-address { ip-addr | ip-prefix / length | ipv6-addr | ipv6-prefix / length } level

 
Syntax Description

ip-addr

IP address of the neighbor in this format: A.B.C.D.

ip-prefix / length

IP prefix and the length of the IP prefix. The length of the IPv6 prefix is a decimal value that indicates how many of the high-order contiguous bits of the address make up the prefix (the network portion of the address). A slash mark must precede the decimal value. Use this format: A.B.C.D/ length .

ipv6-addr

IPv6 address of the neighbor in this format: A:B::C:D.

ipv6-prefix / length

IPv6 prefix and the length of the IPv6 prefix for neighbors in this format: A:B::C:D/ length.

level

Level number. Default: All routes are advertised individually. Valid values are as follows:

  • level-1 —Summarizes the IP address into the level-1 area. Only routes redistributed into level 1 are summarized with the configured address and mask value.
  • level-1-2 —Summarizes the IP address into the level-1 and level-2 areas. Summary routes are applied when redistributing routes into level-1 and level-2 IS-IS, and when level-2 IS-IS advertises level-1 routes as reachable in its area.
  • level-2 —Summarizes the IP address into the level-2 area. Routes learned by level-1 routing are summarized into the level-2 backbone with the configured address and mask value. Redistributed routes into level-2 IS-IS will be summarized also.

 
Command Default

None

 
Command Modes

Address-family configuration
Router configuration
VRF configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

Multiple groups of addresses can be summarized for a given level. Routes learned from other routing protocols can also be summarized. The metric used to advertise the summary is the smallest metric of all the more specific routes. This command reduces the size of the routing table and also reduces the size of the link-state packets (LSPs) and the link-state database (LSDB). It also helps to stabilize the network stability because a summary advertisement depend on many specific routes. A single route flap does not cause the summary advertisement to flap in most cases.

Note that when using summary addresses, other routes might have less information to calculate because the most optimal routing table for all individual destinations are used.

This command requires the Enterprise Services license.

Examples

This example shows how to redistribute directly connected routes into IS-IS. Only the 10.1.0.0 address is advertised the IS-IS level-1 link-state protocol data unit (PDU). The summary address is tagged with 100.

switch(config)# router isis 100
switch(config-router)# address-family ipv4 unicast
switch(config-router-af)# redistribute direct route-map CORE1
switch(config-router-af)# summary-address 10.1.0.0 255.255.0.0

 
Related Commands

Command
Description

address-family

Enters the address family mode or a VRF address-family mode.

feature isis

Enables IS-IS on the router.

router isis

Enables IS-IS.

summary-address (OSPF)

To create aggregate addresses for the Open Shortest Path First (OSPF) protocol, use the summary-address command. To return to the default, use the no form of this command.

summary-address ip-prefix/length [ not-advertise ] [ tag tag ]

no summary-address ip-prefix/length [ not-advertise ] [ tag tag ]

 
Syntax Description

ip-prefix/length

IP prefix designated for a range of addresses, including the prefix length. Specify ip-prefix as an IP address. Specify length as a number from 1 to 31.

not-advertise

(Optional) Suppresses routes that match the specified prefix/length pair.

tag tag

(Optional) Specifies the tag value that can be used as a match value for controlling redistribution using route maps. The range is from 1 to 65535.

 
Defaults

None

 
Command Modes

Router configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

Use the summary-address command to create an aggregate address to replace a series of more-specific addresses. The metric used to advertise the summary is the smallest metric of all the more specific routes.

Use this command to reduce the size of the routing table and allow an OSPF Autonomous System Boundary Router (ASBR) to advertise one external route as an aggregate for all redistributed routes that are covered by the address.

This command requires the Enterprise Services license.

Examples

This example shows how to configure the summary address 192.0.0.0 to include address 192.0.1.0, 192.0.2.0, 192.0.3.0, and so on. Only the address 192.0.0.0 is advertised in an external link-state advertisement.

switch(config)# router ospf 201
switch(config-router)# summary-address 192.0.0.0/16
 

 
Related Commands

Command
Description

redistribute (OSPF

Redistributes external routing protocol routes into OSPF.

summary-address (OSPFv3)

To create aggregate addresses for the Open Shortest Path First version 3 (OSPFv3) protocol, use the summary-address command. To return to the default, use the no form of this command.

summary-address ipv6-prefix/length [ not-advertise ] [ tag tag ]

no summary-address ipv6-prefix/length [ not-advertise ] [ tag tag ]

 
Syntax Description

ipv6-prefix/length

IP prefix designated for a range of addresses, including the prefix length. Specify ip-prefix as an IPv6 address. Specify length as a number from 1 to 128.

not-advertise

(Optional) Suppresses routes that match the specified prefix/length pair.

tag tag

(Optional) Specifies the tag value that can be used as a match value for controlling redistribution using route maps. The range is from 1 to 65535.

 
Defaults

None

 
Command Modes

Address-family configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

Use the summary-address command to create an aggregate address to replace a series of more-specific addresses. The metric used to advertise the summary is the smallest metric of all the more specific routes.

Use this command to reduce the size of the routing table and allow an OSPFv3 Autonomous System Boundary Router (ASBR) to advertise one external route as an aggregate for all redistributed routes that are covered by the address.

This command requires the Enterprise Services license.

Examples

This example shows how to configure the summary address 192.0.0.0 to include address 192.0.1.0, 192.0.2.0, 192.0.3.0, and so on. Only the address 192.0.0.0 is advertised in an external link-state advertisement.

switch(config)# router ospfv3 201
switch(config-router)# address-family ipv6 unicast
switch(config-router)# summary-address 2001:0DB8::0/16
 

 
Related Commands

Command
Description

redistribute (OSPFv3

Redistributes external routing protocol routes into OSPFv3.

suppress-inactive

To advertise the active routes to a Border Gateway Protocol (BGP) peer only, use the suppress-inactive command. To remove the restriction, use the no form of this command. To return to the default setting, use the default form of this command.

suppress-inactive

no | default suppress-inactive

 
Syntax Description

This command has no keywords or arguments.

 
Defaults

BGP advertises routes to a peer as soon as they are installed in the local routing table, even if the routes are not the active routes in the table.

 
Command Modes

Neighbor address-family configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

Use the suppress-inactive command to advertise only active routes to a BGP peer.

This command requires the Enterprise Services license.

Examples

This example shows how to create a summary address. The path advertised for this route is an autonomous system set consisting of all elements contained in all paths that are being summarized.

switch(config)# router bgp 64496
switch(config-router)# neighbor 192.0.2.1/8 remote-as 64497
switch(config-router-neighbor)# address-family ipv4 unicast
switch(config-router-neighbor af)# suppress-inactive

 
Related Commands

Command
Description

route-map map-name

Creates a route map.