Cisco Nexus 7000 Series Unicast Routing Command Reference
N Commands
Downloads: This chapterpdf (PDF - 221.0KB) The complete bookPDF (PDF - 18.25MB) | Feedback

Table of Contents

N Commands

name

name-lookup

neighbor

net

network

nexthop route-map

nexthop trigger-delay

no isis passive-interface

N Commands

This chapter describes the Cisco NX-OS unicast routing commands that begin with the letter N.

name

To specify a master group name, use the name command. To revert to the default setting, use the no form of this command.

name [master-group-name]

no name [master-group-name]

 
Syntax Description

master-group-name

Master group name.

 
Defaults

None

 
Command Modes

config-if-hsrp mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

6.2(2)

This command was introduced.

 
Usage Guidelines

The name command changes a regular Hot Standby Redundancy Protocol (HSRP) group into a master group.

If you do not specify a name, a unique name is automatically generated.

This command requires the Enterprise Services license.

Examples

This example shows how to specify a master group name:

switch# configure terminal
switch(config)# interface ethernet 3/5
switch(config-if)# ip address 11.0.0.1/24
switch(config-if)# hsrp version 2
switch(config-if)# hsrp 10
switch(config-if-hsrp)# name Master-Group-1
switch(config-if-hsrp)#

 
Related Commands

Command
Description

hsrp version 2

Configures the HSRP version 2.

name-lookup

To enable the translation of Open Shortest Path First (OSPF) router IDs to host names, either by looking up the local hosts database or querying domain name server (DNS) names in IPv6, use the name-lookup command. To stop displaying OSPF router IDs as DNS names, use the no form of this command.

name-lookup

no name-lookup

 
Syntax Description

This command has no arguments or keywords.

 
Defaults

None

 
Command Modes

config-router mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

6.2(2)

This command was introduced.

 
Usage Guidelines

The name-lookup command makes it easier to identify a device because it displays the device by name rather than by its router ID or neighbor ID.

This command requires the Enterprise Services license.

Examples

This example shows how to enable the translation of OSPF router IDs to host names, either by looking up the local hosts database or querying DNS names in IPv6:

switch# configure terminal
switch(config)# router ospf 201
switch(config-router)# distance 25
switch(config-router)# log-adjacency-changes
switch(config-router)# maximum-paths 4
switch(config-router)# name-lookup
switch(config-router)#
 

This example shows how to stop displaying OSPF router IDs as DNS names:

switch(config-router)# no name-lookup
switch(config-router)#

 
Related Commands

Command
Description

router ospf

Configures an Open Shortest Path First (OSPF) routing instance.

neighbor

To configure a BGP neighbor (router, vrf) and enter the neighbor configuration mode, use the neighbor command. To remove an entry, use the no form of this command.

neighbor { ip-addr | ip-prefix / length | ipv6-addr | ipv6-prefix / length } [ remote-as { as-num [ . as-num ] | route-map name }

no neighbor { ip-addr | ip-prefix / length | ipv6-addr | ipv6-prefix / length } [ remote-as { as-num [ . as-num ] | route-map name }]

 
Syntax Description

ip-addr

IP address of the neighbor in this format: A.B.C.D.

ip-prefix / length

IP prefix and the length of the IP prefix. The format is x.x.x.x/ length . The length range is from 1 to 32.

ipv6-addr

IPv6 address of the neighbor. The format is A:B::C:D.

ipv6-prefix / length

IPv6 prefix and the length of the IPv6 prefix for neighbors. The format is A:B::C:D/ length. The length range is from 1 to 128.

remote-as

(Optional) Specifies the autonomous system number of the neighbor.

as-num

Number of an autonomous system that identifies the router to other BGP routers and tags the routing information passed along. The range is from 1 to 65535.

. as-num

(Optional) Number of an autonomous system that identifies the router to other BGP routers and tags the routing information passed along. The range is from 1 to 65535.

route-map name

(Optional) Specifies a route map that matches the BGP peer AS number against a list of AS numbers or a regular expression. The name can be any case-sensitive, alphanumeric string up to 63 characters.

 
Defaults

This command has no default settings.

 
Command Modes

Neighbor address-family configuration
Router bgp configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.1(2)

Added support for the route-map keyword.

4.0(1)

This command was introduced.

 
Usage Guidelines

Use the neighbor command to enter the BGP neighbor configuration mode. When you enter the neighbor command, the prompt changes to switch(config-router-neighbor)#.

From the BGP neighbor configuration mode, you can perform the following actions:

  • address-family —Configure an address-family (router, neighbor, vrf). See the address-family (BGP) command for information.
  • description description Describes the neighbor. You can enter up to 80 characters including spaces.
  • disable-connected-check —Disables the connection verification for the directly connected peer. Use the disable-connected-check command is to disable a check for an eBGP peer that is directly connected to the local router. BGP triggers a connection check automatically for all eBGP peers that are known to be single hop away, unless you disable this check with the disable-connected-check command. BGP does not bring up sessions if the check fails. BGP considers an EBGP peer is a single hop away, if the eBGP peer does does not have the ebgp-multihop command configured (that is, the time-to-live (TTL) value is one).

This command is ignored if the route-map keyword is used in the neighbor command.

  • dont-capability-negotiate —Turns off the negotiate capability with this neighbor.
  • dynamic-capability —Enables the dynamic capability.
  • ebgp-multihop —Accepts and attempts BGP connections to external peers that reside on networks that are not directly connected. This command is ignored if the route-map keyword is used in the neighbor command.

Note You should enter this command under the guidance of Cisco technical support staff only.


  • exit —Exits from the current command mode.
  • inherit peer-session session-name —Configures a peer to inherit the configuration from another peer-session template. To remove an inherit statement from a peer-session template, use the no form of this command.
  • no —Negates a command or sets its defaults.
  • transport connection-mode passive —Allows a passive connection setup only. To remove the restriction, use the no form of this command.
  • remove-private-as —Removes the private AS number from the outbound updates.
  • shutdown —Administratively shuts down this neighbor.
  • timers keepalive-time —Configures keepalive and hold timers in seconds. The range is from 0 to 3600. The default is 60.
  • update-source { ethernet mod / port | loopback virtual-interface | port-channel number [ . sub-interface ]} —Specifies the source of the BGP session and updates. The range for virtual-interface is from 0 to 1023. The range for number is from 0 to 4096. The range for sub-interface is from 1 to 4093.

The Cisco NX-OS software allows BGP sessions to use any operational interface for TCP connections, when you enter the update-source command in neighbor configuration mode. To restore the interface assignment to the closest interface, which is called the best local address, use the no form of this command.

You must use the update-source command must to enable IPv6 link-local peering for internal or external BGP sessions.

This command requires the Enterprise Services license.

Examples

This example shows how to configure a single-hop eBGP peering session between two BGP peers that are reachable on the same network segment through a local loopback interfaces on each router:

BGP Peer 1

switch(config)# interface loopback 1
switch(config-if)# ip address 10.0.0.100 255.255.255
switch(config-if)# exit
switch(config)# router bgp 64497
switch(config-router)# neighbor 192.168.0.200 remote-as 64496
switch(config-router-neighbor)# update-source loopback 1
switch(config-router-neighbor)# disable-connected-check

BGP Peer 2

switch(config)# interface loopback 2
switch(config-if)# ip address 192.168.0.200 255.255.255
switch(config-if)# exit
switch(config)# router bgp 64496
switch(config-router)# neighbor 10.0.0.100 remote-as 64497
switch(config-router-neighbor)# update-source loopback 2
switch(config-router-neighbor)# disable-connected-check
 

This example shows how to source BGP TCP connections for the specified neighbor with the IP address of the loopback interface rather than the best local address:

switch(config)# router bgp 64496
switch(config-router)# neighbor 172.16.0.0 remote-as 64496
switch(config-router-neighbor)# update-source Loopback0
 

This example shows how to source IPv6 BGP TCP connections for the specified neighbor in autonomous system 64496 with the global IPv6 address of loopback interface 0 and the specified neighbor in autonomous system 64498 with the link-local IPv6 address of Ethernet interface 2/1:

switch(config)# router bgp 64497
switch(config-router)# neighbor 3ffe::3 remote-as 64496
switch(config-router-neighbor)# update-source Loopback0
switch(config-router-neighbor)# neighbor fe80::2 remote-as 64498
switch(config-router-neighbor)# update-source Ethernet 2/1

 

 
Related Commands

Command
Description

feature bgp

Enables BGP on the router.

route-map

Creates a route map.

net

To configure an Intermediate System-to-Intermediate System (IS-IS) network entity (NET) for the routing process, use the net command. To remove a NET, use the no form of this command.

net net

no net net

 
Syntax Description

net

NET network services access point (NSAP) name or address for the IS-IS routing process; see the “Usage Guidelines” section for additional information about valid values.

 
Defaults

The defaults are as follows:

  • No NET is configured.
  • The IS-IS process is disabled.

 
Command Modes

Router configuration
VRF configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

An IS (intermediate system) is identified by an address known as a network access point (NASAP). The NSAP is divided up into three parts as specified by ISO/AI 10589:

  • Area address—This field is of variable length, composed of high order octets, and it excludes the System ID and N-selector (NSEL) fields. This area address is associated with a single area within the routing domain.
  • System ID—This field is 6 octets long and should be set to a unique value with level-1 and level 2. The system IS defines an end system (ES) or an IS in an area. You configure the area address and the system ID with the NET command. You can display the system ID with the show isis topology command.
  • NSEL—This field is called the N-selector, also referred to as the NSAP, and it specifies the upper-layer protocol. The NSEL is the last byte of the NSAP and identifies a network service user. A network service user is a transport entity or the IS network entity itself. When the N-selector is set to zero, the entire NSAP is called a network entity title (NET).

A NET is an NSAP where the last byte is always the n-selector and is always zero. A NET can be from 8 to 20 bytes in length. The NET is formatted as follows: XX.AAAA.AAAA.AAAA[.AAAA].XX.

Under most circumstances, you should configure one NET only. It is possible to configure two or three NETs, but you should not configure more than one NET except for the following unusual circumstances:

  • A network configuration has multiple areas that are merged.
  • One area in the IS-IS process is being split into multiple areas.

Configuring multiple NETs in these two circumstances can be temporarily useful because multiple area addresses enable you to renumber an area individually as needed.

If you are using IS-IS to perform IP routing only (no connectionless network service routing is enabled), you must configure a NET to define the router ID and area ID.

Examples

This example shows how to configure a router with a NET which consists of the system ID 0000.0c11.1110 and area address 47.0004.0(1)04d.0001:

switch(config)# router isis firstcompany
switch(config-router)# net 47.0004.0(1)04d.0001.00

 
Related Commands

Command
Description

feature isis

Enables IS-IS on the router.

router isis

Enables IS-IS.

network

To configure an IP prefix to advertise, use the network command. To remove the IP prefix to advertise, use the no form of this command.

network ip-addr | ip-prefix / length mask mask-num [ route-map name ]

no network ip-network | ip-prefix / length mask mask-num [ route-map name ]

 
Syntax Description

ip-addr

IP network address to advertise; use the following format: A.B.C.D.

ip-prefix / length

IP prefix and the length of the IP prefix. The length of the IPv6 prefix is a decimal value that indicates how many of the high-order contiguous bits of the address comprise the prefix (the network portion of the address). A slash mark must precede the decimal value. Use the following format: A.B.C.D/length.

mask mask-num

Configures the mask of the IP prefix to advertise in dotted 4-octet format.

route-map name

(Optional) Specifies the name of the route-map to modify attributes.

 
Defaults

This command has no default settings.

 
Command Modes

Neighbor address-family configuration
Router bgp configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

The IP prefix to advertise is considered for bestpath and advertisement to peers only if a route of equal or more specificity is present in the routing table.

Examples

This example shows how to configure an IP prefix to advertise:

switch(config-router-af)# network 2.2.2.2 mask 3.3.3.3 route-map test
switch(config-router-af)#

nexthop route-map

To specify that Border Gateway Protocol (BGP) routes are resolved using only next hops whose routes match specific characteristics, use the nexthop route-map command. To remove the route map, use the no form of this command.

nexthop route-map name

no nexthop route-map name

 
Syntax Description

name

Route map name. The name can be any alphanumeric string up to 63 characters.

 
Defaults

None

 
Command Modes

Address-family configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.2(1)

This command was introduced.

 
Usage Guidelines

Use the nexthop route-map command to configure route policy filtering for next hops.

BGP next-hop filtering allows you to specify that when a next-hop address is checked with the RIB, the underlying route for that next-hop address is passed through the route map. If the route map rejects the route, the next-hop address is treated as unreachable.

BGP marks all next hops that are rejected by the route policy as invalid and does not calculate the best path for the routes that use the invalid next-hop address.

This command requires an Enterprise Services license.

Examples

This example shows how to configure a route map to filter the next-hop address:

switch# config t

switch(config)# route-map CHECK-BGP25 deny 10

switch(config-route-map)# match ip address prefix-list FILTER25

switch(config-route-map)# match source-protocol ospf-o1

switch(config-route-map)# exit

switch(config)# ip prefix-list FILTER25 seq 5 permit 0.0.0.0/0 le 25

switch(config)# router bgp 1.0

switch(config-router)# address-family ipv4 unicast

switch(config-router-af)# nexthop route-map CHECK-BGP25

 

 
Related Commands

Command
Description

feature bgp

Enables BGP.

nexthop trigger-delay

Configures the delay timers for BGP next-hop address tracking.

route-map

Defines the conditions for redistributing routes from one routing protocol into another.

nexthop trigger-delay

To specify that Border Gateway Protocol (BGP) delay for triggering next-hop calculations, use the nexthop trigger-delay command. To set the trigger delay to the default value, use the no form of this command.

nexthop trigger-delay { critical delay | non-critical delay }

no nexthop trigger-delay { critical delay | non-critical delay }

 
Syntax Description

critical delay

Specifies the critical next-hop trigger delay, in milliseconds. The range is from 0 to 4294967295. The default is 3000.

non-critical delay

Specifies the noncritical next-hop trigger delay, in milliseconds. The range is from 0 to 4294967295. The default is 10000.

 
Defaults

Critical delay: 3000 milliseconds.
Noncritical delay: 10000 milliseconds.

 
Command Modes

Address-family configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.2(1)

This command was introduced.

 
Usage Guidelines

Use the nexthop trigger-delay command to modify when BGP processes next-hop address tracking events.

The non-critical delay value must always be set to at least equal or greater than the critical delay value.

The delay should be slightly higher than the time it takes for the Interior Gateway Protocol (IGP) to settle into a steady state after some event (IGP convergence time).

This command requires an Enterprise Services license.

Examples

This example shows how to modify the next-hop address tracking delay:

switch# config t

switch(config)# router bgp 1.0

switch(config-router)# address-family ipv4 unicast

switch(config-router-af)# nexthop trigger-delay critical 5000 non-critical 20000

 

 
Related Commands

Command
Description

feature bgp

Enables BGP.

nexthop route-map

Configures a route map for BGP next-hop address tracking.

no isis passive-interface

To re-enable the sending of routing updates on an Intermediate System-to-Intermediate System (IS-IS) interface and activates only those interfaces that need adjacencies, use the no isis passive-interface command.

no isis passive-interface {level-1 | level-1-2 | level-2}

 
Syntax Description

level-1

(Optional) Suppresses level-1 PDU.

level-1-2

(Optional) Suppresses level-1 and level-2 PDU.

level-2

(Optional) Suppresses level-2 PDU.

 
Defaults

None

 
Command Modes

Interface configuration mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

6.2(2)

This command was introduced.

 
Usage Guidelines

This command requires the Enterprise Services license.

Examples

This example shows how to re-enable sending of routing updates on an IS-IS interface and activates only those interfaces that need adjacencies:

switch# configure terminal
switch(config)# router isis 1
switch(config-router)# passive-interface default level-1
switch(config-router)# exit
switch# configure terminal
switch(config)# interface GigabitEthernet 0/0/0/
switch(config-if# isis passive-interface level-1
switch(config-if)# no isis passive-interface level-1
switch(config-if#

 
Related Commands

Command
Description

isis passive-interface

Blocks sending of routing updates on an IS-IS interface.

default isis passive-interface

Allows all IS-IS interfaces to be set as passive by default.