Cisco Nexus 7000 Series Unicast Routing Command Reference
L Commands
Downloads: This chapterpdf (PDF - 222.0KB) The complete bookPDF (PDF - 18.25MB) | Feedback

Table of Contents

L Commands

load-balancing

local-as

local-as (bgp)

log-adjacency-changes (EIGRP)

log-adjacency-changes (IS-IS)

log-adjacency-changes (OSPF)

log-adjacency-changes (OSPFv3)

log-neighbor-warnings

low-memory exempt

lsp-gen-interval

lsp-mtu

L Commands

This chapter describes the Cisco NX-OS unicast routing commands that begin with the letter L.

load-balancing

To specify the load-balancing method used by the active virtual gateway (AVG) of the Gateway Load Balancing Protocol (GLBP), use the load-balancing command. To disable load balancing, use the no form of this command.

load-balancing [ host-dependent | round-robin | weighted ]

no load-balancing

 
Syntax Description

host-dependent

(Optional) Specifies a load-balancing method based on the MAC address of a host where the same forwarder is always used for a particular host while the number of GLBP group members remains unchanged.

round-robin

(Optional) Specifies a load-balancing method where each virtual forwarder is included in Address Resolution Protocol (ARP) replies for the virtual IP address. This method is the default.

weighted

(Optional) Specifies a load-balancing method that is dependent on the weighting value advertised by the gateway.

 
Defaults

The round-robin method is the default.

 
Command Modes

GLBP configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

Use the host-dependent method of GLBP load balancing when you need each host to always use the same router. Use the weighted method of GLBP load balancing when you need unequal load balancing because gateways in the GLBP group have different forwarding capacities.

This command does not require a license.

Examples

This example show how to configure the host-dependent load-balancing method for the AVG of the GLBP group 10:

switch(config)# interface ethernet 1/1
switch(config-if)# glbp 10
switch(config-glbp)# load-balancing host-dependent

 
Related Commands

Command
Description

glbp

Enters GLBP configuration mode and creates a GLBP group.

show glbp

Displays GLBP information.

weighting

Configures the weighting value and thresholds for the weighted load-balancing method.

weighting track

Configures object tracking for the weighted load-balancing method.

local-as

To configure the Border Gateway Protocol (BGP) local AS number, use the local-as command.

local-as as-number

 
Syntax Description

as-number

(Optional) Autonomous system number. The AS number can be a 16-bit integer or a 32-bit integer in the form of <higher 16-bit decimal number>.<lower 16-bit decimal number>.

 
Defaults

None

 
Command Modes

Router VRF mode

 
Supported User Roles

network-admin
vdc-admin

Release
Modification

4.0(3)

This command was introduced.

 
Usage Guidelines

This command requires the Enterprise Services license.

Examples

This example shows how to configure the local AS number for BGP:

switch# config t
switch(config)# router bgp 65536.33
switch(config-router)# vrf red
switch(config-router-vrf)# local-as 65536.33
 

 
Related Commands

Command
Description

show bgp

Displays information about BGP.

local-as (bgp)

To configure a router to appear as a member of a second autonomous system (AS) in addition to the real AS of the device, use the local-as command. To remove the local AS configuration from the device, use the no form of this command.

local-as autonomous-system-number [no-prepend | replace-as [dual-as]]

no local-as autonomous-system-number [no-prepend | replace-as [dual-as]]

 
Syntax Description

autonomous-system-
number

AS number. The range is from 1 to 4294967295.

no-prepend

(Optional) Specifies not to prepend the local autonomous system number to any routes received from the external Border Gateway Protocol (eBGP) neighbor.

replace-as

(Optional) Specifies to prepend only the local-as number to updates to the eBGP neighbor.

dual-as

(Optional) Configures the eBGP neighbor to establish a peering session using the real autonomous system number (from the local BGP routing process) or by using the autonomous-system number.

 
Defaults

None

 
Command Modes

Neighbor configuration (config-router-neighbor)

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

5.2(1)

This command was introduced.

 
Usage Guidelines

This command does not require a license.

Examples

This example shows how to configure a router to appear as a member of a second AS in addition to the real AS of the device:

switch# configure terminal
switch(config)# router bgp 64496
switch(config-router)# neighbor 192.0.2.1
switch(config-router-neighbor)# local-as 429496 no-prepend replace-as dual-as
switch(config-router-neighbor)#
 
This example shows how to remove the local AS configuration from the device:

switch# configure terminal
switch(config)# router bgp 64496
switch(config-router)# neighbor 192.0.2.1
switch(config-router-neighbor)# no local-as
switch(config-router-neighbor)#

 
Related Commands

Command
Description

router bgp

Creates a BGP instance.

show ip bgp

Displays entries in the BGP routing table.

show ip bgp neighbors

Displays information about BGP neighbors.

log-adjacency-changes (EIGRP)

To enable the logging of changes in Enhanced Interior Gateway Routing Protocol (EIGRP) adjacency state, use the log-adjacency-changes command. To disable the logging of changes in EIGRP adjacency state, use the no form of this command.

log-adjacency-changes

no log-adjacency-changes

 
Syntax Description

This command has no arguments or keywords.

 
Defaults

Adjacency changes are not logged.

 
Command Modes

Address-family configuration
Router configuration
Router VRF configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

This command requires the Enterprise Services license.

Examples

This example shows how to enable logging of adjacency state changes for EIGRP 1:

switch(config)# router eigrp 1
switch(config-router)# address-family ipv6
switch(config-router-af)# log-adjacency-changes

 
Related Commands

Command
Description

ip eigrp log-neighbor-changes

Logs changes to neighbors for an interface.

ip eigrp log-neighbor-warnings

Logs neighbor warnings for an interface.

log-adjacency-changes (IS-IS)

To enable the router to send a syslog message when an Intermediate System-to-Intermediate System Intradomain Routing Protocol (IS-IS) neighbor goes up or down, use the log-adjacency-changes configuration mode command. To disable this function, use the no form of this command.

log-adjacency-changes

no log-adjacency-changes

 
Syntax Description

This command has no arguments or keywords.

 
Defaults

This command is enabled by default.

 
Command Modes

Router configuration
VRF configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

The log-adjacency-changes command is on by default but only up/down (full/down) events are reported.

Examples

This example configures the router to send a syslog message when an IS-IS neighbor state changes:

switch(config)# router isis
switch(config-router)# log-adjacency-changes

 
Related Commands

Command
Description

feature isis

Enables IS-IS on the router.

router isis

Enables IS-IS.

 

log-adjacency-changes (OSPF)

To configure the router to send a syslog message when the state of an Open Shortest Path First (OSPF) neighbor changes, use the log-adjacency-changes command. To turn off this function, use the no form of this command.

log adjacency changes [ detail ]

 
Syntax Description

detail

(Optional) Provides all (DOWN, INIT, 2WAY, EXSTART, EXCHANGE, LOADING, FULL) adjacency state changes.

 
Defaults

The router sends a system message when the state of an OSPF neighbor changes.

 
Command Modes

Router configuration
Router VRF configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

Use the log-adjacency-changes command to display high-level changes to the state of the OSPF neighbor relationship. This command is on by default but only reports the up/down (full/down) events if you do not use the detail keyword.

This command requires the Enterprise Services license.

Examples

This example shows how to configure the router to send a system message when an OSPF neighbor state changes:

switch(config)# router ospf 209
switch(config-router)# log-adjacency-changes detail

 

log-adjacency-changes (OSPFv3)

To configure the router to send a system message when the state of an Open Shortest Path First version 3 (OSPFv3) neighbor changes, use the log-adjacency-changes command. To turn off this function, use the no form of this command.

log adjacency changes [ detail ]

 
Syntax Description

detail

(Optional) Provides all (DOWN, INIT, 2WAY, EXSTART, EXCHANGE, LOADING, FULL) adjacency state changes.

 
Defaults

The router sends a system message when the state of an OSPFv3 neighbor changes.

 
Command Modes

Router configuration
Router VRF configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

Use the log-adjacency-changes command to display high-level changes to the state of the OSPFv3 neighbor relationship. This command is on by default but only reports the up/down (full/down) events if you do not use the detail keyword.

This command requires the Enterprise Services license.

Examples

This example shows how to configure the router to send a system message when an OSPFv3 neighbor state changes:

switch(config)# router ospfv3 209
switch(config-router)# log-adjacency-changes detail

 

log-neighbor-warnings

To enable the logging of Enhanced Interior Gateway Routing Protocol (EIGRP) neighbor warning messages, use the log-neighbor-warnings command. To disable the logging of EIGRP neighbor warning messages, use the no form of this command.

log-neighbor-warnings [ seconds ]

no log-neighbor-warnings

 
Syntax Description

seconds

(Optional) Time interval (in seconds) between repeated neighbor warning messages. The range of seconds is from 1 to 65535.

 
Defaults

Neighbor warning messages are logged.

 
Command Modes

Address-family configuration
Router configuration
Router VRF configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(3)

This command was introduced.

 
Usage Guidelines

Use the log-neighbor-warnings command to enable neighbor warning messages and to configure the interval between repeated neighbor warning messages.

This command requires the Enterprise Services license.

Examples

This example shows how to log neighbor warning messages for EIGRP process 209 and to repeat the warning messages in 5-minute (300 seconds) intervals:

switch(config)# router eigrp 209
switch(config-router)# log-neighbor-warnings 30

 
Related Commands

Command
Description

log-adjacency-changes

Enables logging of EIGRP adjacency state changes.

low-memory exempt

To exempt a Border Gateway Protocol (BGP) neighbor from a low-memory shutdown, use the low-memory exempt command. To make a BGP neighbor eligible for a low-memory shutdown, use the no form of this command.

low-memory exempt

no low-memory exempt

 
Syntax Description

This command has no arguments or keywords.

 
Defaults

Some eBGP peers shut down for severe memory alerts.

 
Command Modes

Neighbor configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.2(1)

This command was introduced.

 
Usage Guidelines

This command requires the Enterprise Services license.

Examples

This example shows how to exempt a neighbor from low-memory shutdown:

switch(config)# router bgp 1.0
switch(config-router)# neighbor 192.0.2.0/24 remote-as 1.5
switch(config-router-af)# low-memory exempt
 

 
Related Commands

Command
Description

feature bgp

Enables BGP.

lsp-gen-interval

To customize the IS-IS throttling of the LSP generation, use the lsp-gen-interval configuration mode command. To restore default values, use the no form of this command.

lsp-gen-interval { level-1 | level-2 } lsp-max-wait [ lsp-initial-wait lsp-second-wait ]

no lsp-gen-interval

 
Syntax Description

level-1

Applies intervals to level-1 areas only.

level-2

Applies intervals to level-2 areas only.

lsp-max-wait

Maximum interval (in seconds) between two consecutive occurrences of an LSP being generated. Range: 500 to 65535. Default: 5.

lsp-initial-wait

(Optional) Initial LSP generation delay (in milliseconds). Range: 50 to 65535. Default: 50.

lsp-second-wait

Hold time between the first and second LSP generation (in milliseconds). Range: 50 to 65535. Default: 50.

 
Defaults

The defaults are as follows:

  • lsp-max-wait : 500
  • lsp-initial-wait : 50
  • lsp-second-wait : 50

 
Command Modes

Router configuration
VRF configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

When you change the default values of this command, use the following guidelines:

  • The lsp-initial-wait argument indicates the initial wait time (in milliseconds) before generating the first LSP.
  • The lsp-second-wait argument indicates the amount of time to wait (in milliseconds) between the first and second LSP generation.
  • Each subsequent wait interval is twice as long as the previous one until the wait interval reaches the lsp-max-wait interval specified, so this value causes the throttling or slowing down of the LSP generation after the initial and second intervals. Once this interval is reached, the wait interval continues at this interval until the network calms down.
  • After the network calms down and there are no triggers for 2 times the lsp-max-wait interval, fast behavior is restored (the initial wait time).

The lsp-mtu command sets the delay (in milliseconds) between successive LSPs being transmitted (including LSPs generated by another system and forwarded by the local system).

You can enter these commands in combination to control the rate of LSP packets being generated, transmitted, and retransmitted.

Examples

This example configures the interval for LSP generation:

switch(config)# router isis
switch(config-router)# lsp-gen-interval 2 50 100

 
Related Commands

Command
Description

feature isis

Enables IS-IS on the router.

router isis

Enables IS-IS.

lsp-mtu

To set the maximum size of a link-state packet (LSP) generated by Cisco NX-OS software, use the lsp-mtu command. To restore the default Maximum Transmission Unit (MTU) size, use the no form of this command.

lsp-mtu bytes

no lsp-mtu

 
Syntax Description

bytes

Maximum LSP size in bytes. Range: 128 to 4352. Default: 1492.

 
Defaults

The default MTU size is 1492 bytes.

 
Command Modes

Router configuration
VRF configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

You can increase the LSP MTU if there is a very large amount of information generated by a single router, because each device is limited to approximately 250 LSPs. In practice, this should never be necessary.

The LSP MTU must never be larger than the smallest MTU of any link in the area. This is because LSPs are flooded throughout the area.

The lsp-mtu command limits the size of LSPs generated by this router only.

Examples

This example sets the maximum LSP size to 1500 bytes:

switch(config)# router isis

switch(config-router)# lsp-mtu 1500

 
Related Commands

Command
Description

feature isis

Enables IS-IS on the router.

router isis

Enables IS-IS.