Cisco Nexus 7000 Series NX-OS MPLS Command Reference
R Commands
Downloads: This chapterpdf (PDF - 224.0KB) The complete bookPDF (PDF - 5.67MB) | Feedback

R Commands

Table Of Contents

R Commands

rd

record-route (LSP attribute configuration mode)

record-route (TE interface configuration mode)

redistribute

redistribute direct route-map

redistribute static route-map

reoptimize events link-up

reoptimize timers

restart

route-target

router bgp

router isis

router ospf

router rip

router-id


R Commands


This chapter describes the Cisco NX-OS Multiprotocol Label Switching commands that begin with R.

rd

To create routing and forwarding tables, use the rd command. To return to the default setting, use the no form of this command.

rd route-distinguisher

no rd route-distinguisher

Syntax Description

route-distinguisher

8-byte value that is added to an IPv4 prefix to create a VPN IPv4 prefix.


Defaults

None

Command Modes

Global configuration mode

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

5.2(1)

This command was introduced.


Usage Guidelines

This command requires the MPLS Services license.

Examples

This example shows how to create routing and forwarding tables:

switch# configure terminal
switch(config)# vrf context vpn1
switch(config-vrf)# rd 1.2:1

Related Commands

Command
Description

mpls ldp configuration

Configures the Multiprotocol Label Switching (MPLS) Label Distribution Protocol (LDP).


record-route (LSP attribute configuration mode)

To record the route used by the label switched path (LSP), use the record-route command.

record-route

Syntax Description

This command has no arguments or keywords.

Command Modes

LSP attribute configuration mode

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

5.2(1)

This command was introduced.


Usage Guidelines

The following holds true for all tunnel-te commands that can be specified both in "TE interface configuration mode" or path-option command line or "LSP attribute configuration mode":

If a setting is specified for an LSP, either via the path-option command directly or by assigning an LSP attribute list to a path-option, takes precedence for that specific path-option.

If no setting is specified for an LSP, then the LSP/path-option inherits any setting specified in the tunnel-te configuration mode: affinity, auto-bw, priority, record-route, protection/fast-reroute.

This command requires the MPLS Services license.

Examples

This example shows how to record the route by LSP:

switch# configure terminal
switch(config)# mpls traffic-eng configuration
switch(config-te)# lsp attributes 1
switch(config-lsp-attr)# record-route

Related Commands

Command
Description

mpls traffic-eng configuration

Configures the Multiprotocol Label Switching (MPLS) Traffic Engineering Protocol (MPLS-TE).


 
   
 
   
 
   

record-route (TE interface configuration mode)

To record the route used by the label switched path (LSP), use the record-route command.

record-route

Syntax Description

This command has no arguments or keywords.

Command Modes

TE interface configuration mode

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

5.2(1)

This command was introduced.


Usage Guidelines

This command requires the MPLS Services license.

Examples

This example shows how to record the route by LSP:

switch# configure terminal
switch(config)# interface tunnel-te 1
switch(config-if-te)# record-route
switch(config-if-te)# 

Related Commands

Command
Description

interface tunnel-te

Configures the traffic engineering (TE) interface.


 
   

redistribute

To redistribute routes from one routing domain into another routing domain, use the redistribute command. To return to the default setting, use the no form of this command.

redistribute {bgp as | direct | {eigrp | ospf | rip} instance-tag | static} route-map map-name

no redistribute {bgp as | direct | {eigrp | ospf | rip} instance-tag | static} route-map map-name

Syntax Description

bgp

Specifies the Border Gateway Protocol (BGP).

as

16-bit integer or a 32-bit integer in the form of a higher 16-bit decimal number and a lower 16-bit decimal number in xx.xx format.

direct

Specifies directly connected routes.

eigrp

Specifies the Enhanced Interior Gateway Routing Protocol (EIGRP).

ospf

Specifies the Open Shortest Path First (OSPF).

rip

Specifies the Routing Information Protocol (RIP).

instance-tag

Instance-tag that can be any case-sensitive, alphanumeric string up to 20 characters.

static

Specifies static routes.

route-map

Specifies the policy to constrain redistribution.

map-name

Name of the map that you used to redistributes routes from one routing domain into another routing domain. The name can be any case-sensitive, alphanumeric string up to 63 characters.


Defaults

None

Command Modes

Route configuration mode

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

5.2(1)

This command was introduced.


Usage Guidelines

This command requires the MPLS Services license.

Examples

This example shows how to redistribute routes from one routing domain into another routing domain:

switch# configure t
switch(config)# feature rip
switch(config)# router rip test1
switch(config-router)# vrf vpn1
switch(config-router-vrf-af)# redistribute bgp 1.0 route-map bagpipe
switch(config-router-vrf-af)#

Related Commands

Command
Description

mpls ldp configuration

Configures the Multiprotocol Label Switching (MPLS) Label Distribution Protocol (LDP).


redistribute direct route-map

To redistribute directly connected routes using the Border Gateway Protocol (BGP), use the redistribute direct route-map command. To return to the default setting, use the no form of this command.

redistribute direct route-map map-tag

no redistribute direct route-map map-tag

Syntax Description

map-tag

Map name that can be any case-sensitive, alphanumeric string up to 63 characters.


Defaults

None

Command Modes

Address family configuration mode

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

5.2(1)

This command was introduced.


Usage Guidelines

This command requires the MPLS Services license.

Examples

This example shows how to redistribute directly connected routes using BGP:

switch# configure t
switch(config)# router bgp 1.1
switch(config-router)# vrf vpn1
switch(config-router-vrf)# address-family ipv4 unicast
switch(config-router-vrf-af)# redistribute direct route-map directMap
switch(config-vrf-af)#

Related Commands

Command
Description

mpls ldp configuration

Configures the Multiprotocol Label Switching (MPLS) Label Distribution Protocol (LDP).


redistribute static route-map

To redistribute static routes by using the Border Gateway Protocol (BGP), use the redistribute static-map command. To return to the default setting, use the no form of this command.

redistribute static route-map map-tag

no redistribute static route-map map-tag

Syntax Description

map-tag

Map name that can be any case-sensitive, alphanumeric string up to 63 characters.


Defaults

None

Command Modes

Address family configuration mode

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

5.2(1)

This command was introduced.


Usage Guidelines

This command requires the MPLS Services license.

Examples

This example shows how to redistribute static routes using BGP:

switch# configure t
switch(config)# router bgp 1.1
switch(config-router)# vrf vpn1
switch(config-router-vrf)# address-family ipv4 unicast
switch(config-router-vrf-af)# redistribute static route-map StaticMap
switch(config-vrf-af)#

Related Commands

Command
Description

mpls ldp configuration

Configures the Multiprotocol Label Switching (MPLS) Label Distribution Protocol (LDP).


reoptimize events link-up

To reoptimize tunnels on link-up events, use the reoptimize events link-up command. To return to the default setting, use the no form of this command.

reoptimize events link-up

no reoptimize events link-up

Syntax Description

This command has no arguments or keywords.

Defaults

None

Command Modes

TE configuration mode

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

5.2(1)

This command was introduced.


Usage Guidelines

This command requires the MPLS Services license.

Examples

This example shows how to reoptimize tunnels on link-up events:

switch# configure t
switch(config)# mpls traffic-eng configuration
switch(config-te)# reoptimize events link-up
switch(config-te)#

Related Commands

Command
Description

mpls traffic-eng configuration

Configures the Multiprotocol Label Switching (MPLS) Traffic Engineering Protocol (MPLS-TE).


reoptimize timers

To configure Multiprotocol Label Switching (MPLS) traffic engineering reoptimize timers, use the reoptimize timers command. To return to the default setting, use the no form of this command.

reoptimize timers {delay cleanup sec | installation sec | frequency sec}

no reoptimize timers {delay cleanup | installation | frequency}

Syntax Description

delay

Specifies the delay reoptimization action.

cleanup

Specifies to delay the cleanup of the reoptimized LSP.

sec

Time in seconds to delay the cleanup of the replaced tunnel LSP. The range is from 0 to 60.

installation

Specifies to delay the replacement of the current LSP by the reoptimized LSP.

sec

Time in seconds to delay the replacement of the tunnel LSP. The range is from 0 to 3600.

frequency

Specifies the interval between reoptimization scans.

sec

Time in seconds between reoptimizations. The range is from 0 to 604800.


Defaults

The default are as follows:

Delay cleanups— The default is 10.

Installation— The default is 3.

frequency— The default is 3600.

Command Modes

TE configuration mode

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

5.2(1)

This command was introduced.


Usage Guidelines

This command requires the MPLS Services license.

Examples

This example shows how to delay the replacement of the current LSP by the reoptimized LSP:

switch# configure t
switch(config)# mpls traffic-eng configuration
switch(config-te)# reoptimize timers delay installation 3000
switch(config-te)#

Related Commands

Command
Description

mpls traffic-eng configuration

Configures the Multiprotocol Label Switching (MPL S) Traffic Engineering Protocol (MPLS-TE).


restart

To gracefully restart the Resource Reservation Protocol (RSVP) process, use the restart ommand. To return to the default settings, use the no form of the command.

restart rsvp

no restart rsvp

Syntax Description

This command has no arguments or keywords.

Defaults

None

Command Modes

EXEC.

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

5.2(1)

This command was introduced.


Usage Guidelines

This command requires the MPLS Services license.

Examples

This example shows how to rate limit the number of messages that are sent to a neighboring router:

switch# restart rsvp
switch# 

Related Commands

Command
Description

mpls ldp configuration

Configures the Multiprotocol Label Switching (MPLS) Label Distribution Protocol (LDP).


route-target

To create a route-target extended community for a virtual routing and forwarding (VRF) instance, use the route target command. To return to the default setting, use the no form of this command.

route-target {import | export} route-target-ext-community

no route-target {import | export} route-target-ext-community

Syntax Description

import

Imports routing information from the target virtual private network (VPN) extended community.

export

Exports routing information to the target virtual private network (VPN) extended community.

route-target-ext-community

Route-target-extended community attributes that you can use to specify the VRF's list of import or export route-target extended communities. You can enter the route-target-ext-community argument as follows:

· 16-bit or 32-bit AS number: your 32-bit number, for example, 1.2:3

· 32-bit IP address: your 16-bit number, for example, 192.0.2.1:1


Defaults

None

Command Modes

Address family configuration mode

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

5.2(1)

This command was introduced.


Usage Guidelines

This command does not require the MPLS Services license.

Examples

This example shows how to create a route-target extended community for a VRF:

switch# configure t
switch(config)# vrf context vpn1
switch(config-vrf)# address-family ipv4 unicast
switch(config-vrf-af)# route-target import 1:101

Related Commands

Command
Description

mpls ldp configuration

Configures the Multiprotocol Label Switching (MPLS) Label Distribution Protocol (LDP).


router bgp

To configure a Border Gateway Protocol (BGP) process for an interface, use the router bgp command. To return to the default setting, use the no form of this command.

router bgp as-number

no router bgp as-number

Syntax Description

as-number

Number of an autonomous system that identifies the router to other BGP routers and tags that the routing information passed along. The AS number can be a 16-bit integer or a 32-bit integer in the form of a higher 16-bit decimal number and a lower 16-bit decimal number in xx.xx format.


Defaults

None

Command Modes

Global configuration mode

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

5.2(1)

This command was introduced.


Usage Guidelines

This command requires the MPLS Services license.

Examples

This example shows how to configure a BGP process for an interface:

switch(config)# router bgp 1.1
switch(config-router)#
 
   

Related Commands

Command
Description

tunnel-te interface

Configures the traffic engineering (TE) interface.


 
   
 
   

router isis

To configure an Intermediate System-to-Intermediate System (IS-IS) routing process, use the router isis command. To return to the default setting, use the no form of this command.

router isis routing-process-tag

no router isis routing-process-tag

Syntax Description

routing-process-tag

Routing process tag. The maximum size is 20 alphanumeric characters.


Defaults

None

Command Modes

Router configuration mode

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

5.2(1)

This command was introduced.


Usage Guidelines

This command requires the MPLS Services license.

Examples

This example shows how to configure an IS-IS routing process:

switch# configure terminal
switch(config)# router isis p1
switch(config-router)#

Related Commands

Command
Description

tunnel-te interface

Configures the traffic engineering (TE) interface.


router ospf

To enable an Open Shortest Path First (OSPF) routing process, use the router ospf command. To return to the default setting, use the no form of this command.

router ospf router-process-tag

no router ospf router-process-tag

Syntax Description

router-process-tag

Process name. The maximum size is 20 alphanumeric characters.


Syntax Description

This command has no arguments or keywords.

Defaults

None

Command Modes

Router configuration mode

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

5.2(1)

This command was introduced.


Usage Guidelines

This command requires the MPLS Services license.

Examples

This example shows how to enable an OSPF routing process:

switch# configure terminal
switch(config)#  router ospf p1
switch(config-router)#

Related Commands

Command
Description

tunnel-te interface

Configures the Multiprotocol Label Switching (MPLS) Label Distribution Protocol (LDP).


router rip

To enable the Routing Information Protocol (RIP), use the router rip command. To return to the default setting, use the no form of this command.

router rip instance-tag

no router rip instance-tag

Syntax Description

instance-tag

Instance tag that can be any case-sensitive, alphanumeric string up to 20 characters.


Defaults

None

Command Modes

Global configuration mode

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

5.2(1)

This command was introduced.


Usage Guidelines

This command requires the MPLS Services license.

Examples

This example shows how to enable RIP:

switch# configure terminal
switch(config)#
switch(config)# feature rip
switch(config)# router rip Test1
switch(config-router)#

Related Commands

Command
Description

tunnel-te interface

Configures the traffic engineering (TE) interface.


router-id

To configure the preferred interface for determining the Label Distribution Protocol (LDP) router ID, use the router-id command. To return to the default setting, use the no form of this command.

router-id loopback interface number [force]

no router-id loopback interface number [force]

Syntax Description

loopback

Specifies the loopback interface. The interface could be Ethernet or any others.

interface number

Virtual interface number. The range is from 0 to 1023.

force

(Optional) Specifies to forcibly change the LDP router ID.


Defaults

None

Command Modes

LDP configuration mode

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

5.2(1)

This command was introduced.


Usage Guidelines

This command requires the MPLS Services license.

Examples

This example shows how to specify the preferred interface for determining the LDP router ID:

switch(config)# mpls ldp
switch(config-ldp)# router-id loopback 2 
switch(config-ldp)#
 
   

This example shows how to assign Ethernet 2/2 interface as the LDP router ID:

switch# configure terminal
switch(config)# mpls ldp
switch(config-ldp)# router-id loopback 0 force

Related Commands

Command
Description

mpls ldp configuration

Configures the Multiprotocol Label Switching (MPLS) Label Distribution Protocol (LDP).