Cisco Nexus 7000 Series NX-OS Interfaces Configuration Guide, Release 6.x
Configuring Layer 3 Interfaces
Downloads: This chapterpdf (PDF - 321.0KB) The complete bookPDF (PDF - 3.66MB) | Feedback

Configuring Layer 3 Interfaces

Table Of Contents

Configuring Layer 3 Interfaces

Information About Layer 3 Interfaces

Routed Interfaces

Subinterfaces

VLAN Interfaces

Loopback Interfaces

Tunnel Interfaces

High Availability

Virtualization Support

Licensing Requirements for Layer 3 Interfaces

Prerequisites for Layer 3 Interfaces

Guidelines and Limitations

Default Settings

Configuring Layer 3 Interfaces

Configuring a Routed Interface

Configuring a Subinterface

Configuring the Bandwidth on an Interface

Configuring a VLAN interface

Configuring Inband Management in the Nexus Chassis

Configuring a Loopback Interface

Assigning an Interface to a VRF

Verifying the Layer 3 Interfaces Configuration

Monitoring Layer 3 Interfaces

Configuration Examples for Layer 3 Interfaces

Related Topics

Additional References

Related Documents

MIBs

Standards

Feature History for Configuring Layer 3 Interfaces


Configuring Layer 3 Interfaces


Revised: October 30, 2013

This chapter describes how to configure Layer 3 interfaces for Cisco NX-OS devices and includes the following sections:

Information About Layer 3 Interfaces

Licensing Requirements for Layer 3 Interfaces

Guidelines and Limitations

Default Settings

Prerequisites for Layer 3 Interfaces

Configuring Layer 3 Interfaces

Verifying the Layer 3 Interfaces Configuration

Monitoring Layer 3 Interfaces

Configuration Examples for Layer 3 Interfaces

Related Topics

Additional References

Feature History for Configuring Layer 3 Interfaces

Information About Layer 3 Interfaces

Layer 3 interfaces forward IPv4 and IPv6 packets to another device using static or dynamic routing protocols. You can use Layer 3 interfaces for IP routing and inter-VLAN routing of Layer 2 traffic.

You cannot configure a shared interface as a Layer 3 interface. See the Cisco NX-OS FCoE Configuration Guide for Cisco Nexus 7000 and Cisco MDS 9500 for information about shared interfaces.

Beginning with Cisco Release 5.2(1), you can configure a Fabric Extender (FEX) port as a Layer 3 interface for host connectivity, but not for routing. See the Configuring the Cisco Nexus 2000 Series Fabric Extender for more information about fabric extenders.

This section includes the following topics:

Routed Interfaces

Subinterfaces

VLAN Interfaces

Loopback Interfaces

Tunnel Interfaces

High Availability

Virtualization Support

Routed Interfaces

You can configure a port as a Layer 2 interface or a Layer 3 interface. A routed interface is a physical port that can route IP traffic to another device. A routed interface is a Layer 3 interface only and does not support Layer 2 protocols, such as the Spanning Tree Protocol (STP).

All Ethernet ports are routed interfaces by default. You can change this default behavior with the CLI setup script or through the system default switchport command.

You can assign an IP address to the port, enable routing, and assign routing protocol characteristics to this routed interface.

Beginning with Cisco Release 4.2(1), you can assign a static MAC address to a Layer 3 interface. By default, the MAC address for the Layer 3 interfaces is the MAC address of the virtual device context (VDC) it is assigned to. For information on configuring MAC addresses, see the Cisco Nexus 7000 Series NX-OS Layer 2 Switching Configuration Guide.

You can also create a Layer 3 port channel from routed interfaces. For more information about port channels, see Chapter 6 "Configuring Port Channels."

Routed interfaces and subinterfaces support exponentially decayed rate counters. Cisco NX-OS tracks the following statistics with these averaging counters:

Input packets/sec

Output packets/sec

Input bytes/sec

Output bytes/sec

Subinterfaces

You can create virtual subinterfaces on a parent interface configured as a Layer 3 interface. A parent interface can be a physical port or a port channel.

Subinterfaces divide the parent interface into two or more virtual interfaces on which you can assign unique Layer 3 parameters such as IP addresses and dynamic routing protocols. The IP address for each subinterface should be in a different subnet from any other subinterface on the parent interface.

You create a subinterface with a name that consists of the parent interface name (for example, Ethernet 2/1) followed by a period and then by a number that is unique for that subinterface. For example, you could create a subinterface for Ethernet interface 2/1 named Ethernet 2/1.1 where .1 indicates the subinterface.

Cisco NX-OS enables subinterfaces when the parent interface is enabled. You can shut down a subinterface independent of shutting down the parent interface. If you shut down the parent interface, Cisco NX-OS shuts down all associated subinterfaces as well.

One use of subinterfaces is to provide unique Layer 3 interfaces to each virtual local area network (VLAN) supported by the parent interface. In this scenario, the parent interface connects to a Layer 2 trunking port on another device. You configure a subinterface and associate the subinterface to a VLAN ID using 802.1Q trunking.

Figure 4-1 shows a trunking port from a switch that connects to router B on interface E 2/1. This interface contains three subinterfaces that are associated with each of the three VLANs carried by the trunking port.

Figure 4-1 Subinterfaces for VLANs

For more information about VLANs, see the Cisco Nexus 7000 Series NX-OS Layer 2 Switching Configuration Guide.

VLAN Interfaces

A VLAN interface, or switch virtual interface (SVI), is a virtual routed interface that connects a VLAN on the device to the Layer 3 router engine on the same device. Only one VLAN interface can be associated with a VLAN, but you need to configure a VLAN interface for a VLAN only when you want to route between VLANs or to provide IP host connectivity to the device through a virtual routing and forwarding (VRF) instance that is not the management VRF. When you enable VLAN interface creation, Cisco NX-OS creates a VLAN interface for the default VLAN (VLAN 1) to permit remote switch administration.

You must enable the VLAN network interface feature before you can see configure it. Beginning in Cisco NX-OS Release 4.2, the system automatically takes a checkpoint prior to disabling the feature, and you can roll back to this checkpoint. See the Cisco Nexus 7000 Series NX-OS System Management Configuration Guide for information on rollbacks and checkpoints.

You must configure the VLAN network interface in the same VDC as the VLAN.


Note You cannot delete the VLAN interface for VLAN 1.


You can route across VLAN interfaces to provide Layer 3 inter-VLAN routing by configuring a VLAN interface for each VLAN that you want to route traffic to and assigning an IP address on the VLAN interface. For more information about IP addresses and IP routing, see the Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide.

Figure 4-2 shows two hosts connected to two VLANs on a device. You can configure VLAN interfaces for each VLAN that allows Host 1 to communicate with Host 2 using IP routing between the VLANs. VLAN 1 communicates at Layer 3 over VLAN interface 1 and VLAN 10 communicates at Layer 3 over VLAN interface 10.

Figure 4-2 Connecting Two VLANs with VLAN interfaces


Note You can configure VLAN interface for an inband management in the Cisco Nexus 7000 Series devices with the F1 Series modules in the chassis.


Loopback Interfaces

A loopback interface is a virtual interface with a single endpoint that is always up. Any packet transmitted over a loopback interface is immediately received by this interface. Loopback interfaces emulate a physical interface. You can configure up to 1024 loopback interfaces per VDC, numbered 0 to 1023.

You can use loopback interfaces for performance analysis, testing, and local communications. Loopback interfaces can act as a termination address for routing protocol sessions. This loopback configuration allows routing protocol sessions to stay up even if some of the outbound interfaces are down.

Tunnel Interfaces

Cisco NX-OS supports tunnel interfaces as IP tunnels. IP tunnels can encapsulate a same-layer or higher layer protocol and transport the result over IP through a tunnel created between two routers. See Chapter 8 "Configuring IP Tunnels," for more information about IP tunnels.

High Availability

Layer 3 interfaces support stateful and stateless restarts. After the switchover, Cisco NX-OS applies the runtime configuration after the switchover.

See the Cisco Nexus 7000 Series NX-OS High Availability and Redundancy Guide for complete information about high availability.

Virtualization Support

Layer 3 interfaces support Virtual Routing and Forwarding instances (VRFs). VRFs exist within virtual device contexts (VDCs). By default, Cisco NX-OS places you in the default VDC and default VRF unless you specifically configure another VDC and VRF. A Layer 3 logical interface (VLAN interface, loopback) configured in one VDC is isolated from a Layer 3 logical interface with the same number configured in another VDC. For example, loopback 0 in VDC 1 is independent of loopback 0 in VDC 2.

You can configure up to 1024 loopback interfaces per VDC.

You can associate the interface with a VRF. For VLAN interfaces, you must configure the VLAN interface in the same VDC as the VLAN.

See the Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide for information about VDCs and see the Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide for information about configuring an interface in a VRF.


Note You must assign an interface to a VRF before you configure the IP address for that interface.


Licensing Requirements for Layer 3 Interfaces

The following table shows the licensing requirements for this feature:

Product
License Requirement

Cisco NX-OS

Layer 3 interfaces require no license. Any feature not included in a license package is bundled with the Cisco NX-OS system images and is provided at no extra charge to you. For a complete explanation of the Cisco NX-OS licensing scheme, see the Cisco NX-OS Licensing Guide.


Prerequisites for Layer 3 Interfaces

Layer 3 interfaces have the following prerequisites:

You have installed the Advanced Services license and entered the desired VDC. (See the Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide if you are configuring VDCs.

You are familiar with IP addressing and basic configuration. See the Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide for more information about IP addressing.

Guidelines and Limitations

Layer 3 interfaces have the following configuration guidelines and limitations:

If you change a Layer 3 interface to a Layer 2 interface, Cisco NX-OS shuts down the interface, reenables the interface, and removes all configuration specific to Layer 3.

If you change a Layer 2 interface to a Layer 3 interface, Cisco NX-OS shuts down the interface, reenables the interface, and deletes all configuration specific to Layer 2.

The Cisco Nexus 2000 Fabric Extender cannot participate in a routing protocol adjacency with a device attached to its port. Only a static direct route is supported. This restriction applies to both of the supported connectivity cases:

SVI with Fabric Extender single port or portchannel in Layer 2 mode.

Fabric Extender port or portchannel in Layer 3 mode.

Layer 3 router interfaces and subinterfaces cannot be configured on an F1 I/O module.

F2-series I/O modules do not support per-VLAN statistics. Therefore, the show interface command does not display per-VLAN Rx/Tx counters or statistics for switch virtual interfaces (SVIs).


Note If you are familiar with the Cisco IOS CLI, be aware that the Cisco NX-OS commands for this feature might differ from the Cisco IOS commands that you would use.


Default Settings

Table 4-1 lists the default settings for Layer 3 interface parameters.

Table 4-1 Default Layer 3 Interface Parameters 

Parameters
Default

Admin state

Shut


Configuring Layer 3 Interfaces

This section includes the following topics:

Configuring a Routed Interface

Configuring a Subinterface

Configuring the Bandwidth on an Interface

Configuring a VLAN interface

Configuring Inband Management in the Nexus Chassis

Configuring a Loopback Interface

Assigning an Interface to a VRF

Configuring a Routed Interface

You can configure any Ethernet port as a routed interface.

BEFORE YOU BEGIN

Ensure that you are in the correct VDC (or use the switchto vdc command).

SUMMARY STEPS

1. configure terminal

2. interface ethernet slot/port

3. no switchport

4. ip address ip-address/length
or
ipv6 address ipv6-address/length

5. (Optional) show interfaces

6. (Optional) show interface status error policy [detail]

7. (Optional) no shutdown

8. (Optional) copy running-config startup-config

DETAILED STEPS

 
Command
Purpose

Step 1 

configure terminal

Example:

switch# configure terminal

switch(config)#

Enters configuration mode.

Step 2 

interface ethernet slot/port

Example:

switch(config)# interface ethernet 2/1

switch(config-if)#

Enters interface configuration mode.

Step 3 

no switchport

Example:

switch(config-if)# no switchport

Configures the interface as a Layer 3 interface and deletes any configuration specific to Layer 2 on this interface.

Step 4 

ip address ip-address/length

Example:

switch(config-if)# ip address 192.0.2.1/8

Configures an IP address for this interface. See the Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide for more information about IP addresses.

ipv6 address ipv6-address/length

Example:

switch(config-if)# ipv6 address 2001:0DB8::1/8

Configures an IPv6 address for this interface. See the Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide for more information about IPv6 addresses.

Step 5 

show interfaces

Example:

switch(config-if)# show interfaces ethernet 2/1

(Optional) Displays the Layer 3 interface statistics.

Step 6 

show interface status error policy [detail]

Example:

switch(config-if)# show interface status 
error policy detail

(Optional) Displays the interfaces and VLANs that produce errors during policy programming. This ensures that policies are consistent with hardware policies.

Use the detail command to display the details of the interfaces that produce an error.

Step 7 

no shutdown

Example:

switch#

switch(config-if)# int e2/1

switch(config-if)# no shutdown

(Optional) Clears the errors on the interfaces and VLANs where policies correspond with hardware policies. This command allows policy programming to continue and the port to come up. If policies do not correspond, the errors are placed in an error-disabled policy state.

Step 8 

copy running-config startup-config

Example:

switch(config)# copy running-config startup-config

(Optional) Saves this configuration change.

Use the medium command to set the interface medium to either point to point or broadcast.

Command
Purpose

medium {broadcast | p2p}

Example:

switch(config-if)# medium p2p

Configures the interface medium as either point to point or broadcast.



Note The default setting is broadcast, and this setting does not appear in any of the show commands. However, if you do change the setting to p2p, you will see this setting when you enter the show running config command.


Use the switchport command to convert a Layer 3 interface into a Layer 2 interface.

Command
Purpose

switchport

Example:

switch(config-if)# switchport

Configures the interface as a Layer 2 interface and deletes any configuration specific to Layer 3 on this interface.


This example shows how to configure a routed interface:

switch# configure terminal

switch(config)# interface ethernet 2/1

switch(config-if)# no switchport

switch(config-if)# ip address 192.0.2.1/8

switch(config-if)# copy running-config startup-config

 
   

The default setting for interfaces is routed. If you want to configure an interface for Layer 2, enter the switchport command. Then, if you change a Layer 2 interface to a routed interface, enter the no switchport command.

Configuring a Subinterface

You can configure one or more subinterfaces on a routed interface or on a port channel made from routed interfaces.

BEFORE YOU BEGIN

Configure the parent interface as a routed interface.

See the "Configuring a Routed Interface" section.

Create the port-channel interface if you want to create a subinterface on that port channel.

Ensure that you are in the correct VDC (or use the switchto vdc command).

SUMMARY STEPS

1. configure terminal

2. interface ethernet slot/port.number

3. ip address ip-address/length
or
ipv6 address ipv6-address/length

4. encapsulation dot1q vlan-id

5. (Optional) show interfaces

6. (Optional) copy running-config startup-config

DETAILED STEPS

 
Command
Purpose

Step 1 

configure terminal

Example:

switch# configure terminal

switch(config)#

Enters configuration mode.

Step 2 

interface ethernet slot/port.number

Example:

switch(config)# interface ethernet 2/1.1

switch(config-subif)#

Creates a subinterface and enters subinterface configuration mode. The number range is from 1 to 4094.

Step 3 

ip address ip-address/length

Example:

switch(config-subif)# ip address 192.0.2.1/8

Configures an IP address for this subinterface. See the Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide for more information on IP addresses.

ipv6 address ipv6-address/length

Example:

switch(config-subif)# ipv6 address 2001:0DB8::1/8

Configures an IPv6 address for this subinterface. See the Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide for more information on IPv6 addresses.

Step 4 

encapsulation dot1Q vlan-id

Example:

switch(config-subif)# encapsulation dot1Q 33

Configures IEEE 802.1Q VLAN encapsulation on the subinterface. The range is from 2 to 4093.

Step 5 

show interfaces

Example:

switch(config-subif)# show interfaces ethernet 2/1.1

(Optional) Displays the Layer 3 interface statistics.

Step 6 

copy running-config startup-config

Example:

switch(config-subif)# copy running-config startup-config

(Optional) Saves this configuration change.

This example shows how to create a subinterface:

switch# configure terminal

switch(config)# interface ethernet 2/1.1

switch(config-if)# ip address 192.0.2.1/8

switch(config-if)# encapsulation dot1Q 33

switch(config-if)# copy running-config startup-config

Beginning with Cisco NX-OS Release 6.1, the output of the show interface eth command is enhanced for the subinterfaces as shown in the following example:

switch# show interface ethernet 1/2.1 
Ethernet1/2.1 is down (Parent Interface Admin down)
admin state is down, Dedicated Interface, [parent interface is Ethernet1/2]
Hardware: 40000 Ethernet, address: 0023.ac67.9bc1 (bia 4055.3926.61d4)
Internet Address is 10.10.10.1/24
MTU 1500 bytes, BW 40000000 Kbit, DLY 10 usec
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation 802.1Q Virtual LAN, Vlan ID 11, medium is broadcast
Auto-mdix is turned off
EtherType is 0x8100 
L3 in Switched:
	ucast: 0 pkts, 0 bytes - mcast: 0 pkts, 0 bytes
L3 out Switched:
    ucast: 0 pkts, 0 bytes - mcast: 0 pkts, 0 bytes

Configuring the Bandwidth on an Interface

You can configure the bandwidth for a routed interface, port channel, or subinterface. Higher layer protocols use a bandwidth parameter to calculate path costs. You can configure the bandwidth on a subinterface with one of the following methods:

Explicit—Sets the bandwidth value for the subinterface directly.

Inherit—Sets the bandwidth that all subinterfaces inherit from the parent interface as either a specific value or as the bandwidth of the parent interface.

If you do not set the subinterface bandwidth or configure it to inherit the bandwidth from the parent interface, Cisco NX-OS determines the subinterface bandwidth as follows:

If the parent interface is up, the bandwidth of the subinterface is the same as the operational speed of the parent interface. For ports, the subinterface bandwidth is the configured or negotiated link speed. For port channels, the subinterface bandwidth is the aggregate of the link speeds of individual members of the port channel.

If the parent interface is down, the bandwidth of the subinterface depends on the type of parent interface:

Port-channel subinterfaces have 100-Mb/s bandwidth for subinterfaces.

1-Gb/s Ethernet ports have 1-Gb/s bandwidth for subinterfaces.

10-Gb/s Ethernet ports have 10-Gb/s bandwidth for subinterfaces.

To configure the bandwidth of an interface, use the following command in interface mode:

Command
Purpose

bandwidth

Example:

switch(config-if)# bandwidth 100000

Configures the bandwidth parameter for a routed interface, port channel, or subinterface.


To configure subinterfaces to inherit the bandwidth from the parent interface, use the following command in interface mode:

Command
Purpose

bandwidth inherit [value]

Example:

switch(config-if)# bandwidth inherit 100000

Configures all subinterfaces of this interface to inherit the bandwidth value configured. If you do not configure the value, the subinterfaces inherit the bandwidth of the parent interface. The range is from 1 to 10000000, in kilobytes.


Configuring a VLAN interface

You can create VLAN interfaces to provide inter-VLAN routing.

BEFORE YOU BEGIN

Ensure that you are in the correct VDC (or use the switchto vdc command).

SUMMARY STEPS

1. configure terminal

2. feature interface-vlan

3. interface vlan number

4. ip address ip-address/length
or
ipv6 address ipv6-address/length

5. (Optional) show interface vlan number

6. (Optional) show interface status error policy [detail]

7. (Optional) no shutdown

8. (Optional) copy running-config startup-config

DETAILED STEPS

 
Command
Purpose

Step 1 

configure terminal

Example:

switch# configure terminal

switch(config)#

Enters configuration mode.

Step 2 

feature interface-vlan

Example:

switch(config)# feature interface-vlan

Enables VLAN interface mode.

Step 3 

interface vlan number

Example:

switch(config)# interface vlan 10

switch(config-if)#

Creates a VLAN interface. The number range is from 1 to 4094.

Step 4 

ip address ip-address/length

Example:

switch(config-if)# ip address 192.0.2.1/8

Configures an IP address for this VLAN interface. See the Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide for more information on IP addresses.

ipv6 address ipv6-address/length

Example:

switch(config-if)# ipv6 address 2001:0DB8::1/8

Configures an IPv6 address for this VLAN interface. See the Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide for more information on IPv6 addresses.

Step 5 

show interface vlan number

Example:

switch(config-if)# show interface vlan 10

(Optional) Displays the Layer 3 interface statistics.

Step 6 

show interface status error policy [detail]

Example:

switch(config-if)# show interface status 
error policy detail

(Optional) Displays the interfaces and VLANs that produce an error during policy programming. This command ensures that policies are consistent with hardware policies.

Use the detail command to display the details of the interfaces that produce an error.

Step 7 

no shutdown

Example:

switch# config-if)

switch(config)# int e3/1

switch(config)# no shutdown

(Optional) Clears the errors on the interfaces and VLANs where policies correspond with hardware policies. This command allows policy programming to continue and the port to come up. If policies do not correspond, the errors are placed in an error-disabled policy state.

Step 8 

copy running-config startup-config

Example:

switch(config-if)# copy running-config startup-config

(Optional) Saves this configuration change.

This example shows how to create a VLAN interface:

switch# configure terminal

switch(config)# feature interface-vlan

switch(config)# interface vlan 10

switch(config-if)# ip address 192.0.2.1/8

switch(config-if)# copy running-config startup-config

Configuring Inband Management in the Nexus Chassis

You can create a VLAN interface for inband management in the Cisco Nexus 7000 Series devices when there are only F1 Series modules in the chassis.


Caution We recommend that you use a dedicated VLAN for inband management on the F1 Series modules. Do not run data traffic on the VLAN that you are using for inband management.

BEFORE YOU BEGIN

Ensure that you are in the correct VDC (or use the switchto vdc command).

SUMMARY STEPS

1. configure terminal

2. feature interface-vlan

3. interface vlan number

4. no shutdown

5. management

6. ip address ip-address/length

7. (Optional) show interface vlan number

8. (Optional) show interface status error policy [detail]

9. (Optional) no shutdown

10. (Optional) copy running-config startup-config

DETAILED STEPS

 
Command
Purpose

Step 1 

configure terminal

Example:

switch# configure terminal

switch(config)#

Enters global configuration mode.

Step 2 

feature interface-vlan
Example:
switch(config)# feature interface-vlan

Enables you to create a VLAN interface.

You must use this command before you can create VLAN interfaces.

Step 3 

interface vlan number

Example:

switch(config)# interface vlan 10

switch(config-if)#

Creates a VLAN interface.

The number range is from 1 to 4094.

Note Configure the VLAN and add the interfaces.

Step 4 

no shutdown
 
        

Example:

switch(config-if)# no shutdown

Brings an interface administratively up (enable/disable an interface).

Step 5 

management

Example:

switch(config-if)# management

Allows in-band management access to a VLAN interface IP address.

Step 6 

ip address ip-address/length

Example:

switch(config-if)# ip address 192.0.2.1/8

Configures an IP address for this VLAN interface.

See the Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide for more information on IP addresses.

Step 7 

show interface vlan number

Example:

switch(config-if)# show interface vlan 10

(Optional) Displays the Layer 3 interface statistics.

Step 8 

show interface status error policy [detail]

Example:

switch(config-if)# show interface status 
error policy detail

(Optional) Displays the interfaces and VLANs that produce an error during policy programming. This ensures that policies are consistent with hardware policies.

Use the detail command to display the details of the interfaces that produce an error.

Step 9 

no shutdown

Example:

switch# config-if)

switch(config)# int e3/1

switch(config)# no shutdown

(Optional) Clears the errors on the interfaces and VLANs where policies correspond with hardware policies. This command allows policy programming to continue and the port to come up. If policies do not correspond, the errors are placed in an error-disabled policy state.

Step 10 

copy running-config startup-config

Example:

switch(config-if)# copy running-config startup-config

(Optional) Saves this configuration change.

This example shows how to create an inband management in the Cisco Nexus 7000 chassis:

switch# configure terminal

switch(config)# feature interface-vlan

switch(config)# interface vlan 5

switch(config)# no shutdown

switch(config)# management

switch(config-if)# ip address 192.0.2.1/8

switch(config-if)# copy running-config startup-config

Configuring a Loopback Interface

You can configure a loopback interface to create a virtual interface that is always up.

BEFORE YOU BEGIN

Ensure that the IP address of the loopback interface is unique across all routers on the network.

Ensure that you are in the correct VDC (or use the switchto vdc command).

SUMMARY STEPS

1. configure terminal

2. interface loopback instance

3. ipv4 address ip-address
or
ipv6 address ip-address

4. (Optional) show interfaces loopback instance

5. (Optional) copy running-config startup-config

DETAILED STEPS

 
Command
Purpose

Step 1 

configure terminal

Example:

switch# configure terminal

switch(config)#

Enters global configuration mode.

Step 2 

interface loopback instance

Example:

switch(config)# interface loopback 0

switch(config-if)#

Creates a loopback interface. The range is from 0 to 1023.

Step 3 

ip address ip-address/length

Example:

switch(config-if)# ip address 192.0.2.100/8

Configures an IP address for this interface. See the Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide for more information on IP addresses.

ipv6 address ipv6-address/length

Example:

switch(config-if)# ipv6 address 2001:0DB8::18/8

Configures an IPv6 address for this interface. See the Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide for more information on IPv6 addresses.

Step 4 

show interfaces loopback instance

Example:

switch(config-if)# show interfaces loopback 0

(Optional) Displays the loopback interface statistics.

Step 5 

copy running-config startup-config

Example:

switch(config-if)# copy running-config startup-config

(Optional) Saves this configuration change.

This example shows how to create a loopback interface:

switch# configure terminal

switch(config)# interface loopback 0

switch(config-if)# ip address 192.0.2.100/8

switch(config-if)# copy running-config startup-config

Assigning an Interface to a VRF

You can add a Layer 3 interface to a VRF.

BEFORE YOU BEGIN

Ensure that you are in the correct VDC (or use the switchto vdc command).

Assign the IP address for a tunnel interface after you have configured the interface for a VRF.

SUMMARY STEPS

1. configure terminal

2. interface interface-type number

3. vrf member vrf-name

4. ip-address ip-prefix/length

5. (Optional) show vrf [vrf-name] interface interface-type number

6. (Optional) copy running-config startup-config

DETAILED STEPS

 
Command
Purpose

Step 1 

configure terminal

Example:

switch# configure terminal

switch(config)#

Enters configuration mode.

Step 2 

interface interface-type number

Example:

switch(config)# interface loopback 0

switch(config-if)#

Enters interface configuration mode.

Step 3 

vrf member vrf-name

Example:

switch(config-if)# vrf member RemoteOfficeVRF

Adds this interface to a VRF.

Step 4 

ip address ip-prefix/length

Example:

switch(config-if)# ip address 192.0.2.1/16

Configures an IP address for this interface. You must do this step after you assign this interface to a VRF.

Step 5 

show vrf [vrf-name] interface interface-type number

Example:

switch(config-vrf)# show vrf Enterprise interface loopback 0

(Optional) Displays VRF information.

Step 6 

copy running-config startup-config

Example:

switch(config)# copy running-config startup-config

(Optional) Saves this configuration change.

This example shows how to add a Layer 3 interface to the VRF:

switch# configure terminal

switch(config)# interface loopback 0

switch(config-if)# vrf member RemoteOfficeVRF

switch(config-if)# ip address 209.0.2.1/16

switch(config-if)# copy running-config startup-config

Verifying the Layer 3 Interfaces Configuration

To display the Layer 3 configuration, perform one of the following tasks:

Command
Purpose

show interface ethernet slot/port

Displays the Layer 3 interface configuration, status, and counters (including the 5-minute exponentially decayed moving average of inbound and outbound packet and byte rates).

show interface ethernet slot/port brief

Displays the Layer 3 interface operational status.

show interface ethernet slot/port capabilities

Displays the Layer 3 interface capabilities, including port type, speed, and duplex.

show interface ethernet slot/port description

Displays the Layer 3 interface description.

show interface ethernet slot/port status

Displays the Layer 3 interface administrative status, port mode, speed, and duplex.

show interface ethernet slot/port.number

Displays the subinterface configuration, status, and counters (including the f-minute exponentially decayed moving average of inbound and outbound packet and byte rates).

show interface port-channel channel-id.number

Displays the port-channel subinterface configuration, status, and counters (including the 5-minute exponentially decayed moving average of inbound and outbound packet and byte rates).

show interface loopback number

Displays the loopback interface configuration, status, and counters.

show interface loopback number brief

Displays the loopback interface operational status.

show interface loopback number description

Displays the loopback interface description.

show interface loopback number status

Displays the loopback interface administrative status and protocol status.

show interface vlan number

Displays the VLAN interface configuration, status, and counters.

show interface vlan number brief

Displays the VLAN interface operational status.

show interface vlan number description

Displays the VLAN interface description.

show interface vlan number private-vlan mapping

Displays the VLAN interface private VLAN information.

show interface vlan number status

Displays the VLAN interface administrative status and protocol status.

show interface status error policy [detail]

Displays errors on interfaces and VLANs that are inconsistent with hardware policies.

The detail command displays the details of the interfaces and VLANs that receive an error.


Monitoring Layer 3 Interfaces

Use the following commands to display Layer 3 statistics:

Command
Purpose

load- interval {interval seconds {1 | 2 | 3}}

Beginning with Cisco NX-OS Release 4.2(1) for the Cisco Nexus 7000 Series devices, sets three different sampling intervals to bit-rate and packet-rate statistics. The range for VLAN network interface is 60 to 300 seconds, and the range for Layer interfaces is 30 to 300 seconds.

show interface ethernet slot/port counters

Displays the Layer 3 interface statistics (unicast, multicast, and broadcast).

show interface ethernet slot/port counters brief

Displays the Layer 3 interface input and output counters.

show interface ethernet slot/port counters detailed [all]

Displays the Layer 3 interface statistics. You can optionally include all 32-bit and 64-bit packet and byte counters (including errors).

show interface ethernet slot/port counters errors

Displays the Layer 3 interface input and output errors.

show interface ethernet slot/port counters snmp

Displays the Layer 3 interface counters reported by SNMP MIBs.

show interface ethernet slot/port.number counters

Displays the subinterface statistics (unicast, multicast, and broadcast).

show interface port-channel channel-id.number counters

Displays the port-channel subinterface statistics (unicast, multicast, and broadcast).

show interface loopback number counters

Displays the loopback interface input and output counters (unicast, multicast, and broadcast).

show interface loopback number counters detailed [all]

Displays the loopback interface statistics. You can optionally include all 32-bit and 64-bit packet and byte counters (including errors).

show interface loopback number counters errors

Displays the loopback interface input and output errors.

show interface vlan number counters

Displays the VLAN interface input and output counters (unicast, multicast, and broadcast).

show interface vlan number counters detailed [all]

Displays the VLAN interface statistics. You can optionally include all Layer 3 packet and byte counters (unicast and multicast).

show interface vlan number counters snmp

Displays the VLAN interface counters reported by SNMP MIBs.


See the Cisco Nexus 7000 Series NX-OS Interfaces Command Reference for information about these commands.

Configuration Examples for Layer 3 Interfaces

This example shows how to configure Ethernet subinterfaces:

interface ethernet 2/1.10

description Layer 3 for VLAN 10

encapsulation dot1q 10

ip address 192.0.2.1/8

This example shows how to configure a VLAN interface:

interface vlan 100
 ipv6 address 33:0DB::2/8
 
   

This example shows how to configure a loopback interface:

interface loopback 3
ip address 192.0.2.2/32

Related Topics

The following topics can give more information on Layer 3 interfaces:

Chapter 6 "Configuring Port Channels"

Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide

Additional References

For additional information related to implementing Layer 3 interfaces, see the following sections:

Related Documents

MIBs

Standards

Related Documents

Related Topic
Document Title

command syntax

Cisco Nexus 7000 Series NX-OS Interfaces Command Reference

IP

"Configuring IP" chapter in the Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide

VLANs

"Configuring VLANs" chapter in the Cisco Nexus 7000 Series NX-OS Layer 2 Switching Configuration Guide


MIBs

MIBs
MIBs Link

IF-MIB

CISCO-IF-EXTENSION-MIB

ETHERLIKE-MIB

To locate and download MIBs, go to the following URL:

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml


Standards

Standards
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.


Feature History for Configuring Layer 3 Interfaces

Table 4-2 lists the release history for configuring layer 3 interfaces.

Table 4-2 Feature History for Configuring Layer 3 Interfaces 

Feature Name
Releases
Feature Information

Display errors during policy programming.

6.2(2)

Added the show interface status error policy command which displays the interfaces and VLANs that produce an error during policy programming.

Clear SNMP counters from the interface

6.2(2)

Updated the clear counters interface command to include a keyword snmp that provides an option to clear SNMP values from the interface.

Enhanced show output for sub-interfaces

6.1(1)

Updated the show interface eth command output.

Three configurable sampling intervals for interface statistics

4.2(1)

Added the load-interval command.

Layer 3 interfaces

4.0(1)

This feature was introduced.