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Licensing Cisco MDS 9000 Family DCNM-SAN 
Software Features

This chapter describes licensing for Cisco Data Center Network Manager for SAN (DCNM-SAN).

This chapter contains the following section:

• Information About Cisco MDS DCNM-SAN Software Licenses, page 1-1

Information About Cisco MDS DCNM-SAN Software Licenses
Licenses are available for all switches in the Cisco MDS 9000 Family. Licensing allows you to access 
specified premium features on the switch after you install the appropriate license for that feature. You 
can also obtain licenses to activate ports on the Cisco MDS 9124 Fabric Switch, the Cisco MDS 9134 
Fabric Switch, the Cisco Fabric Switch for HP c-Class BladeSystem, and the Cisco Fabric Switch for 
IBM BladeCenter. 

Note DCNM-SAN can discover the Cisco MDS 9124 Fabric Switch, Cisco MDS 9134 Fabric Switch and 
Cisco Fabric Switch for HP c-Class BladeSystem that are running NX-OS Release 5.0 and earlier 
versions of software. Cisco NX-OS Release 5.2(1) is not supported on these fabric switches. 

Cisco DCNM can be licensed for SAN and LAN environments separately or together. A significant 
change for Cisco DCNM-SAN, as compared to Cisco Fabric Manager, is that licenses are no longer 
hosted on a specific switch. Instead, the licenses are hosted on the Cisco DCNM-SAN server. All 
existing Cisco Fabric Manager licenses are grandfathered into this model (which means that they 
continue) so customers do not need to order or deploy any additional licenses to manage their existing 
Cisco MDS 9000 Family switches.

Starting from Cisco MDS NX-OS Release 5.2(1a), the DCNM-SAN uses FLEXnet licensing format. 
DCNM-SAN will continue to support permenant switch license formats. However the support will be 
limited to the licenses that are already checked out.

This section contains information related to licensing types, options, procedures, installation, and 
management for the Cisco MDS DCNM-SAN software.

This section contains the following topics:

• Licensing Terminology, page 1-2

• Licensing Model, page 1-3

• Licensing High Availability, page 1-6
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• License Installation, page 1-6

• Obtaining the Switch License Key File, page 1-7

• Installing the Switch License Key File, page 1-8

• Viewing Fabric Licenses, page 1-11

• Adding a License File to Cisco DCNM-SAN Server, page 1-11

• Assigning a License to a Swtich, page 1-12

• Unassigning Licensing to a Switch, page 1-12

• Identifying License Features in Use, page 1-13

• Uninstalling Licenses, page 1-13

• Updating Licenses, page 1-14

• Grace Period Alerts, page 1-14

• License Transfers Between Switches, page 1-15

• Displaying License Information, page 1-15

• DCNM-SAN Server Licensing, page 1-17

Licensing Terminology
The following terms are used in this chapter:

• Licensed feature—Permission to use a particular feature through a license file, a hardware object, 
or a legal contract. This permission is limited to the number of users, number of instances, time span, 
and the implemented switch.

• Licensed application—A software feature that requires a license to be used.

• License enforcement—A mechanism that prevents a feature from being used without first obtaining 
a license.

• Node-locked license—A license that can only be used on a particular switch using the switch’s 
unique host ID. 

• Host IDs—A unique chassis serial number that is specific to each Cisco MDS switch.

• Proof of purchase—A document entitling its rightful owner to use licensed feature(s) on one Cisco 
MDS switch as described in that document. Also known as the claim certificate. 

• Product Authorization Key (PAK)—The PAK allows you to obtain a license key from one of the sites 
listed in the proof of purchase document. After registering at the specified website, you will receive 
your license key file and installation instructions through e-mail.

• License key file—A switch-specific unique file that specifies the licensed features. Each file 
contains digital signatures to prevent tampering and modification. License keys are required to use 
a licensed feature. License keys are enforced within a specified time span. 

• Counted license—The number of licenses issued for a single feature (for example, FCIP). You can 
increase counted licenses (incremental licenses) should a need arise in the future. 

• Missing license—If the bootflash has been corrupted or a supervisor module replaced after a license 
has been installed, that license will show as “missing.” The feature will still work, but the license 
count will be inaccurate. You should reinstall the license as soon as possible.
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• Incremental license—An additional licensed feature that was not in the initial license file. License 
keys are incremental—if you purchase some features now and others later, the license file and the 
software detect the sum of all features for the specified switch.

• Port Activation license—A license that activates additional ports on any of the following:

– Cisco MDS 9124 Multilayer Fabric Switch

– Cisco MDS 9134 Multilayer Fabric Switch

– Cisco Fabric Switch for HP c-Class BladeSystem

– Cisco Fabric Switch for IBM BladeCenter

• Evaluation license—A temporary license. Evaluation licenses are time bound (valid for a specified 
number of days) and are not tied to a host ID (switch serial number).

• Permanent license—A license that is not time bound is called a permanent license. 

• Grace period—The amount of time the features in a license package can continue functioning 
without a license.

• Support—If you purchased Cisco support through a Cisco reseller, contact the reseller directly. If 
you purchased support directly from Cisco Systems, contact Cisco Technical Support at this URL: 
http://www.cisco.com/en/US/support/tsd_cisco_worldwide_contacts.html

Licensing Model
Any feature not included in a license package is bundled with the Cisco MDS 9000 Family switches and 
is provided at no extra charge. We recommend that you do not download more licenses than can be used 
for a module or switch. 

Starting from Cisco MDS NX-OS Release 5.2(1a), the DCNM-SAN uses FLEXnet licensing format to 
be consistant with DCNM-LAN licensing. DCNM-SAN will continue to support permenant switch 
license formats. However the support will be limited to the licenses that are already checked out.

Two types of Cisco DCNM-SAN licenses are available:

• Cisco DCNM-SAN Essentials Edition (comparable to Cisco Fabric Manager) is included at no 
charge with every Cisco MDS 9000 hardware purchase and can also be downloaded from 
http://www.cisco.com/do/dcnm.

• Cisco DCNM-SAN Advanced Edition (comparable to Cisco Fabric Manager Server) provides 
additional capabilities and is required to use the Virtual Machine Topology and Performance feature 
and the Performance Forecasting Charts feature. 

The licensing model defined for the Cisco MDS product line has two options: 

• Feature-based licenses allow features that are applicable to the entire switch. The cost varies based 
on a per-switch usage. Table 1-1 lists the feature-based license packages.

• Module-based licenses allow features that require additional hardware modules. The cost varies 
based on a per-module usage. An example is the 18/4-port MSM module using the FCIP feature. 

Note Each module requires its own separate license. If you replace a module that requires a 
license with a module of the same type (such as replacing a Storage Services Node (SSN-16) 
with another SSN-16), the existing license will support the new module.
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Note The Cisco MDS 9216i and the Cisco MDS 9222i switches enable SAN extension features on the two 
fixed IP services ports only. The features enabled on these ports are identical to the features enabled by 
the SAN extension over IP license on the 14/2-port Multiprotocol Services (MPS-14/2) module. If you 
install a module with IP ports in the empty slot on the Cisco MDS 9216i or the Cisco MDS 9222i switch, 
a separate SAN extension over IP license is required to enable related features, such as FCIP, on the IP 
ports of the additional module.

Table 1-1 Cisco DCNM Feature-Based Licenses

Feature
DCNM Essential 
Edition (Free)

DCNM Advanced 
Edition (Licensed)

FC/FCoE/FICON/iSCSI Topoplgy View

Fabric, Device, and Summary Views

Port, Switch, and fabric-level configuration

Event and security management

Configuration analysis tools

Network diagnostic and troubleshooting tools

Real-time performance monitoring

One command multi-switch CLI access

Device Manager

Template based provisioning

Gold Diagnostics

Heterogeneous storage array discovery

Scale-out federation architecture

SAN Host Path Redundancy Analysis
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Note License packages for Cisco DMM (Cisco Data Mobility Manager) and Cisco SME (Cisco Storage Media 
Encryption) are documented in the Cisco MDS Data Mobility Manager Configuration Guide, and the 
Cisco Storage Media Encryption Configuration Guide.

Automatic fabric failover

VMware vCenter Plug-in

Multiple fabric management

Centralized management server with discovery

Continuous health and event monitoring

Historical performance monitoring and reporting

Event forwarding

DCNM proxy services

Configuration backup, archive, and compare

Roaming user profiles

VMpath analytics

Domain Dashboards

Capacity Manager

Event Snooze

SMI-S1

1. Minimum of one DCNM-SAN Advanced License is required for each fabric.

Table 1-1 Cisco DCNM Feature-Based Licenses (continued)

Feature
DCNM Essential 
Edition (Free)

DCNM Advanced 
Edition (Licensed)
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Licensing High Availability
As with other Cisco MDS DCNM-SAN features, the licensing feature also maintains the following high 
availability standards for all switches in the Cisco MDS 9000 Family:

• Installing any license in any switch is a nondisruptive process.

• Installing a license automatically saves a copy of permanent licenses to the chassis.

• If you have enabled the grace period feature, enabling a licensed feature that does not have a license 
key starts a counter on the grace period. You then have 120 days to install the appropriate license 
keys, disable the use of that feature, or disable the grace period feature. If at the end of the 120-day 
grace period the device does not have a valid license key for the feature, the Cisco DCNM-SAN 
software automatically disables the feature and removes the configuration from the device.

Note Some licenses, for example, Cisco TrustSec, do not have a grace period.

Devices with dual supervisors have the following additional high availability features:

• The license software runs on both supervisor modules and provides failover protection.

• The license key file is mirrored on both supervisor modules. Even if both supervisor modules fail, 
the license file continues to function from the version that is available on the chassis.

License Installation
If you have purchased a new switch through either your reseller or through Cisco Systems, you can:

• Obtain a factory-installed license (only applies to new switch orders).

• Perform a manual license installation (applies to existing switches).

This section contains the following topics:

• Obtaining a Factory-Installed License, page 1-6

• Performing a Manual Installation, page 1-7

Obtaining a Factory-Installed License

You can obtain factory-installed licenses for a new switch.

Detailed Steps

To obtain a factory-installed license for a new Cisco MDS switch, follow these steps:

Step 1 Contact your reseller or Cisco representative and request this service.

Note If you purchased Cisco support through a Cisco reseller, contact the reseller directly. If you 
purchased support directly from Cisco Systems, contact Cisco Technical Support at this URL: 
http://www.cisco.com/en/US/support/tsd_cisco_worldwide_contacts.html

Your switch is shipped with the required licenses installed in the system. The proof of purchase 
document is sent along with the switch.
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Step 2 Obtain the host ID from the proof of purchase document for future use. 

Step 3 Start to use the switch and the licensed features.

Performing a Manual Installation

If you have existing switches or if you wish to install the licenses on your own, you must first obtain the 
license key file and then install that file in the switch (see Figure 1-1). 

Figure 1-1 Obtaining a License Key File

Obtaining the Switch License Key File

Detailed Steps

To obtain new or updated license key files using Device Manager, follow these steps:

Step 1 From the menu bar, choose Physical > Inventory. You see the inventory for the switch. The host ID is 
referred to as the serial number.

Tip Prepend the serial number with VDH=. For example, if the serial number is FOX064317SQ, the 
full serial number is VDH=FOX064317SQ.

Step 2 Obtain either your claim certificate or your proof of purchase document. This document accompanies 
every Cisco MDS switch.

Step 3 Obtain the Product Authorization Key (PAK) from either the claim certificate or the proof of purchase 
document.

Step 4 Locate the website URL from either the claim certificate or the proof of purchase document.

Software claims certificate
Release 1 .1 and 1.2

Proof of purchase
Release 1.3 and above

Website URL

Product authorization key

Website URL

Product authorization key Product authorization key

URL address

Cisco MDS switch

Switch serial number (switch ID)

Internet web browser

License key file

through email

10
52

27

Switch serial number (switch ID)
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Step 5 Access the specified URL that applies to your switch and enter the switch serial number and the PAK.

The license key file is sent to you by e-mail. The license key file is digitally signed to only authorize use 
on the requested switch. The requested features are also enabled once the Cisco DCNM-SAN software 
on the specified switch accesses the license key file.

Caution Install the license key file in the specified MDS switch without making any modifications.

A license is either permanent or it expires on a fixed date. If you do not have a license, the grace period 
for using that feature starts from the first time you start using a feature offered by that license.

Step 6 Use the copy licenses command in EXEC mode to save your license file to one of two locations—the 
bootflash: directory or the slot0: device.

Installing the Switch License Key File
The best way to install licenses on the switches in your fabric is to use the License Wizard provided in 
DCNM-SAN. You can also use Device Manager to install licenses on each switch individually.

Tip If you need to install multiple licenses in any switch in the Cisco MDS 9000 Family, be sure to provide 
unique file names for each license key file.

Note You do not need a license to access a switch with DCNM-SAN. See the “Licensing Model” section on 
page 1-3 for a list of features requiring licenses.

This section contains the following topics:

• Installing Switch Licenses Using DCNM-SAN License Wizard, page 1-8

• Installing or Updating Switch Licenses Using Device Manager, page 1-10

Installing Switch Licenses Using DCNM-SAN License Wizard

Detailed Steps

To install licenses using the DCNM-SAN License Wizard, follow these steps:

Step 1 Log into a switch in the fabric containing the switches for which you want to install licenses.

To install licenses on multiple switches, you do not need to log into each switch; however, the switches 
must be in the fabric you are viewing.

Step 2 Start the License Wizard by choosing Tools > Install >License. Or, you can select Licenses under 
Switches in the Physical Attributes pane.

You see the license information in the Information pane, one line per feature. 

Step 3 Click the Keys tab, and then click the License Install Wizard icon in the toolbar.
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Figure 1-2 License Install Wizard Icon

You see the initial screen of the License Wizard.

Step 4 If you have already obtained the license key files, click the corresponding radio button and proceed to 
Step 6.

Step 5 Click I have the Product Authorization Key (PAK) if you have the authorization key.

Step 6 Select the vendor, from whom you purchased your switch, in the Vendor drop-down list.

The License Server URL changes depending on the vendor you select. If your URL is different, or if you 
select Other as the vendor, enter the correct license server URL.

Step 7 Click Next to continue to the next screen (see Figure 1-3).

Figure 1-3 License Install Wizard Dialog Box

Step 8 Select the switches for which you have PAKs or license key files.

When you check the check box for a switch, the PAK or license file name field for that switch becomes 
editable. The serial number for each switch is shown in the Host ID column.

Step 9 Enter the PAK or license file name for each switch you have selected in the appropriate column. If you 
have the license files on your PC, you can double-click in the License File Name text area to bring up a 
dialog box and browse for the license files.

You can install multiple licenses on the same switch using different PAKs. To do this, enter the PAKs 
separated by commas.

Step 10 Click Finish to transfer the licenses from the host to the switches.

DCNM-SAN accesses the appropriate license site and installs the licenses onto each switch. The status 
of each installation is displayed in the Status column, as follows:
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• success—Install or uninstall operation completed successfully.

• inProgress—License install or uninstall operation is in progress.

• corruptedLicenseFile—License file content is invalid or corrupted.

• targetLicenseFileAlreadyExist—Target license file-name already exists.

• invalidLicenseFileName—License file does not exist.

• duplicateLicense—License file is already installed.

• generalLicensingFailure—General error from License Manager.

• none—No install operation is performed.

• licenseExpiryConflict—License exists with a different expiration date for the feature.

• invalidLicenseCount—License count is invalid for the feature.

Step 11 Click the Close button to close the wizard. To install more licenses at this point, you must close the 
wizard and launch it again.

Installing or Updating Switch Licenses Using Device Manager

Detailed Steps

To install a license on your switch using Device Manager, follow these steps:

Step 1 Select Licenses from the Admin menu.

You see the Licenses dialog box.

Step 2 Click the Install tab.

The HostId shows the "VDH=" portion of the serial number. The rest of the number is completed in Steps 
3 through 5.

Step 3 Enter the uniform resource identifier (URI) from which the license file will be retrieved.

You should already have copied the license file provided by Cisco.com or by some other means (for 
example, through the CLI) to this location.

Step 4 Enter the target file name in the Target Filename field to specify where the license file will be installed.

Step 5 Click Install if you are installing, or Update if you are updating.

You see the status of the installation at the bottom of the dialog box, as follows:

• success—Install or uninstall operation completed successfully.

• inProgress—License install or uninstall operation is in progress.

• corruptedLicenseFile—License file content is invalid or corrupted.

• targetLicenseFileAlreadyExist—Target license file name already exists.

• invalidLicenseFileName—License file does not exist.

• duplicateLicense—License file is already installed.

• generalLicensingFailure—General error from License Manager.

• none—No install operation is performed.

• licenseExpiryConflict—License exists with a different expiration date for the feature.
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• invalidLicenseCount—License count is invalid for the feature.

• notThisHost—License host ID in the license file does not match.

• licenseInGraceMore—Number of licenses in grace period is more than the number in the install 
license file.

• licenseFileNotFound—License file not found for the install, uninstall, or update operation.

• licenseFileMissing—A previously installed license file is found missing.

• invalidLicenseFileExtension—License file does not have a .lic extension.

• invalidURI—Invalid license file URI specified for install operation.

• noDemoLicenseSupport—Demo license not supported.

• invalidPlatform—Invalid platform.

Step 6 Repeat Steps 3 through 5 to install another license, or click Close to close the License Manager dialog 
box.

Viewing Fabric Licenses

Detailed Steps

To view the fabric licenses, follow thses steps:

Step 1 From the menu bar, choose File > Open.

Step 2 Click Refresh to refresh the table. 

Note License state of the fabrics that are unmanaged is displayed as unknown. 

Adding a License File to Cisco DCNM-SAN Server

Prerequisites

You must have network administrator privileges to complete the following proedure.

Before You Begin

Acquire the required licensing file.

Detailed Steps

To add a license file, follow these steps:

Step 1 Log into the Cisco DCNM-SAN server system.

Step 2 Download the license pack file that you received from Cisco into a directory on the server system.
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Step 3 Copy the license file into INSTALL_DIR/dcm/licenses directory.  On a Microsoft Windows system, the 
default INSTALL_DIR value is C:\Program Files\Cisco Systems. 

Step 4 From the menu bar, choose File > Open and then click License Files tab.

Step 5 Click Reload License Files to reload the licences.

Assigning a License to a Swtich

Prerequisites

You must have network administrator privileges to complete the following proedure.

Before You Begin

You need to make sure that the switch that you want to assign a license is not managed. You can verify 

Detailed Steps

To assign a license to a switch, follow thses steps:

Step 1 From the menu bar, choose File > Open and then click License Assignment tab.

Step 2 From the table, select the switch that you want to assign the license to.

Step 3 Click Assign License.

Unassigning Licensing to a Switch

Prerequisites

You must have network administrator privileges to complete the following proedure.

Before You Begin

You need to make sure that the switch that you want to assign a license is not managed. You can verify 

Detailed Steps

To unassign a license to a switch, follow thses steps:

Step 1 From the menu bar, choose File > Open and then click License Assignment tab.

Step 2 From the table, select the switch that you want to unassign the license.

Step 3 Click Unassign License.
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Identifying License Features in Use
When a Cisco MDS DCNM-SAN software feature is enabled, it can activate a license grace period. 

To identify the features active for a specific license using DCNM-SAN, follow these steps:

Step 1 Select a switch from the Fabric pane, or select a group of switches (SAN, fabric, VSAN) from the 
Logical Domains pane.

Step 2 Select Licenses under Switches in the Physical Attributes pane.

You see the contents of the Feature Usage tab in the Information pane, with installed licenses listed in 
the Feature column.

Step 3 Click the Usage tab.

You see the features currently in use in the Application column.

.

Uninstalling Licenses
You can only uninstall a permanent license that is not in use. If you try to delete a permanent license that 
is currently being used, the software rejects the request and issues an error message. Uninstalling an 
unused license causes the grace period to come into effect. The grace period is counted from the first use 
of the feature without a license and is reset when a valid license file is installed.

Note Permanent licenses cannot be uninstalled if they are currently being used. Features turned on by 
permanent licenses must first be disabled, before that license is uninstalled.

Tip If you are using an evaluation license and would like to install a new permanent license, you can do so 
without service disruption and before the evaluation license expires. Removing a permanent license 
immediately triggers a grace period without service disruption. 

Caution Disable related features before uninstalling a license. The delete procedure fails if the license is in use.

Detailed Steps

To uninstall a license, follow these steps:

Step 1 Log into the switch. If you are using DCNM-SAN to remove licenses from multiple switches, you do 
not need to log in to each switch; however, the switches must be in the fabric you are viewing.

Step 2 From the DCNM-SAN Physical Attributes pane, choose Licenses > Switches. You see the license 
information in the Information pane, one line per feature.

From Device Manager menu, choose Admin > Licenses. You see the Licenses dialog box.

Step 3 In DCNM-SAN, click the Keys tab. You see the list of License Key files. Click the name of the license 
you want to remove, and press the Delete keyboard key or click the Delete Row icon in the toolbar.
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In Device Manager, click Uninstall, and enter the name of the License Key file you want to remove. 
Click Apply to remove the License Key file, and click Close to close the dialog box. 

Note To delete a license, you must disable the features enabled by that license. The delete procedure 
fails if the license is in use, and an error message is displayed.

Updating Licenses
If your license is time bound, you must obtain and install an updated license. Contact technical support 
to request an updated license.

Note If you purchased Cisco support through a Cisco reseller, contact the reseller directly. If you purchased 
support directly from Cisco Systems, contact Cisco Technical Support at this URL: 
http://www.cisco.com/en/US/support/tsd_cisco_worldwide_contacts.html

Detailed Steps

To update a license, follow these steps:

Step 1 Obtain the updated license file using the procedure described in the “Obtaining the Switch License Key 
File” section on page 1-7.

Step 2 Save your running configuration to a remote server using the copy command.

Step 3 Verify the name of the file to be updated.

Step 4 Follow the procedure for updating a license described in the “Uninstalling Licenses” section on 
page 1-13.

Grace Period Alerts
Cisco DCNM-SAN gives you a 120-day grace period. This grace period starts or continues when you 
are evaluating a feature for which you have not installed a license. 

Note There is no grace period for licenses purchased for the On-Demand Port Activation license feature.

The grace period stops if you disable a feature you are evaluating, but if you enable that feature again 
without a valid license, the grace period countdown continues where it left off. 

The grace period operates across all features in a license package. License packages can contain several 
features. If you disable a feature during the grace period and there are other features in that license 
package that are still enabled, the countdown does not stop for that license package. To suspend the grace 
period countdown for a license package, you must disable every feature in that license package. 
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The Cisco DCNM-SAN license counter keeps track of all licenses on a switch. If you are evaluating a 
feature and the grace period has started, you will receive console messages, SNMP traps, system 
messages, and Call Home messages on a daily basis. The frequency of these messages become hourly 
during the last seven days of the grace period. 

The following example uses the FICON feature. On January 30th, you enabled the FICON feature, using 
the 120-day grace period. You will receive grace period ending messages as:

• Daily alerts from January 30th to May 21st.

• Hourly alerts from May 22nd to May 30th.

On May 31st, the grace period ends, and the FICON feature is automatically disabled. You will not be 
allowed to use FICON until you purchase a valid license.

Note You cannot modify the frequency of the grace period messages.

Caution After the final seven days of the grace period, the feature is turned off and your network traffic may be 
disrupted. Any future upgrade will enforce license requirements and the 120-day grace period.

License Transfers Between Switches
A license is specific to the switch for which it is issued and is not valid on any other switch. If you need 
to transfer a license from one switch to another, contact your customer service representative.

Note Rehosting licenses is only supported for RMAs.

Note If you purchased Cisco support through a Cisco reseller, contact the reseller directly. If you purchased 
support directly from Cisco Systems, contact Cisco Technical Support at this URL: 
http://www.cisco.com/en/US/support/tsd_cisco_worldwide_contacts.html

Displaying License Information
You can use DCNM-SAN Client or Device Manager to display all license information configured on a 
switch.

This section contains the following topics:

• Viewing License Information in DCNM-SAN Client, page 1-15

• Viewing License Information in Device Manager, page 1-16

• Viewing Licenses Using DCNM Web Client, page 1-16

Viewing License Information in DCNM-SAN Client

Detailed Steps

To view license information in DCNM-SAN, follow these steps:
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Step 1 Select Licenses under Switches in the Physical Attributes pane. You see the license information in the 
Information pane, one line per feature.

Step 2 Click the Feature Usage tab to see the switch, the name of the feature package, the type of license 
installed, the number of licenses used (Installed Count), the expiration date, the grace period (if you do 
not have a license for a particular feature), and any errors (for example, if you have a missing license). 

Step 3 Click the Keys tab to display the information about each of the License Key files installed on your 
switches.

Caution Once an expiration period has started, notifications appear in the DCNM-SAN’s Events pane 
on a daily basis. During the last seven days of the expiration period, these messages are 
displayed hourly. After the final seven days of the expiration period, the feature is turned off 
and your network traffic may be disrupted.

Step 4 Click the Usage tab to see the applications using the feature package on each switch. Use this tab to 
determine which applications depend on each license installed.

Viewing License Information in Device Manager

Detailed Steps

To view license information in Device Manager, follow these steps:

Step 1 Select Admin > Licenses from the menu. 

You see the Licenses dialog box.

Step 2 Click the Features tab to see the name of the feature package, the type of license, the expiration date, 
the grace period (if you do not have a license for a particular feature), and any errors, such as a missing 
license.

Step 3 Click the Files tab to display the information about each of the License Key files installed on your 
switch. 

Step 4 Click the Install tab to install or update a license file. 

Step 5 Click the Usage tab to which applications are using the features on the switch.

Viewing Licenses Using DCNM Web Client

Cisco DCNM Web Client supports viewing license use across the fabric from Fabric Manager Web 
Client. This view summarizes the licenses used on all switches in the fabric. 

To view licenses using Cisco DCNM-SAN Web Client, choose Inventory > Licenses.
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DCNM-SAN Server Licensing
When you install Cisco DCNM-SAN, the basic version of the Cisco DCNM-SAN Server (DCNM-SAN 
Server) is installed with it. To get the enhanced features, such as Performance Manager and remote client 
support you will need to buy and install the Cisco MDS 9000 Family DCNM-SAN Server license 
package.

However, trial use of these enhanced features is available. To enable the 120-day trial, you simply use 
the feature as you would if you had purchased the license. You see a dialog box explaining that this is a 
demo version, enabled for a limited time.

If you are evaluating Cisco DCNM-SAN Server features and want to stop the evaluation period for that 
feature, you can do that using Device Manager.

Detailed Steps

To stop the evaluation using Device Manager, follow these steps:

Step 1 Select Admin > Licenses.

You see the Licenses dialog box.

Step 2 Click the Features tab and select the feature to check in.

When you select the feature, you see a Check In FM button at the bottom of the dialog box.

Step 3 Click Check In FM to stop the demo period timer.

On-Demand Port Activation Licensing
This section describes how to use the on-demand port activation licensing feature on the Cisco MDS 
9124 Fabric Switch, the Cisco MDS 9134 Fabric Switch, the Cisco Fabric Switch for HP c-Class 
BladeSystem, and the Cisco Fabric Switch for IBM BladeCenter.

This section contains the following topics:

• Information About On-Demand Port Activation Licensing, page 1-17

• Configuring Port Activation Licenses, page 1-20

Information About On-Demand Port Activation Licensing
You can expand your SAN connectivity as needed by enabling users to purchase and install additional 
port licenses. By default, all ports are eligible for license activation. On the Cisco MDS 9124 Fabric 
Switch, licenses are allocated sequentially. However, you can move or reassign licenses to any eligible 
port on the switch. 

On the Cisco MDS 9134 Fabric Switch, the first 32 ports operate at 1 Gbps, 2 Gbps, or 4 Gbps. The 
switch has two ports that operate at 10 Gbps. Licenses are allocated sequentially. On the Cisco Fabric 
Switch for HP c-Class BladeSystem and the Cisco Fabric Switch for IBM BladeCenter, licenses for 
internal ports are allocated as the ports come up. Licenses for external ports are allocated sequentially.

This section contains the following topics:
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• Port-Naming Conventions, page 1-18

• Port Licensing, page 1-18

• License Status Definitions, page 1-19

Port-Naming Conventions

Table 1-2 describes the port-naming conventions for the four Cisco Fabric switches.

Port Licensing

On the Cisco MDS 9124 Switch, the first eight ports are licensed by default. You are not required to 
perform any tasks beyond the default configuration unless you prefer to immediately activate additional 
ports, make ports ineligible, or move port licenses.

Figure 1-4 shows the ports that are licensed by default for the Cisco MDS 9124 Switch. 

Figure 1-4 Cisco MDS 9124 Switch Default Port Licenses (fc1/1 - fc1/8)

If you need additional connectivity, you can activate additional ports in 8-port increments with each 
on-demand port activation license, up to a total of 24 ports.

On the Cisco MDS 9134 Switch, the first 24 ports that can operate at 1 Gbps, 2 Gbps, or 4 Gbps are 
licensed by default. If you need additional connectivity, you can activate the remaining eight ports with 
one on-demand port activation license. A separate 10G license file is required to activate the remaining 
two 10-Gbps ports.

Figure 1-5 shows the ports that are licensed by default for the Cisco MDS 9134 Switch. 

Figure 1-5 Cisco MDS 9134 Switch Default Port Licenses (fc1/1 - fc1/24)

Figure 1-6 shows the external ports that are licensed by default for the Cisco Fabric Switch for HP 
c-Class BladeSystem.

Table 1-2 Port-Naming Conventions for Cisco Fabric Switches

Cisco MDS 9124 
Switch

Cisco MDS 9134 
Switch

Cisco Fabric Switch for HP 
c-Class BladeSystem

Cisco Fabric Switch for 
IBM BladeCenter

fc1/1 through fc1/24 fc1/1 through fc1/34 Internal ports: bay1 
through bay16

Internal ports: bay1 
through bay14

External ports: ext1 
through ext8

External ports: ext0 and 
ext15 through ext19

15
98

31
18

40
89
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Figure 1-6 Cisco Fabric Switch for HP c-Class BladeSystem Default Port Licenses (ext1 - ext4)

On the Cisco Fabric Switch for HP c-Class BladeSystem, any eight internal ports and the external ports 
(ext1 through ext4) are licensed by default. A single on-demand port activation license is required to use 
the remaining eight internal and four external ports.

On the Cisco Fabric Switch for IBM BladeCenter, any seven internal ports and the external ports( ext0, 
ext15 and ext16) are licensed by default. A single on-demand port activation license is required to use 
the remaining seven internal and three external ports. 

Figure 1-7 shows the external ports that are licensed by default for the Cisco Fabric Switch for IBM 
BladeCenter.

Figure 1-7 Cisco Fabric Switch for IBM BladeCenter Default Port Licenses (ext0, ext15 - ext16)

If you do not prefer to accept the default behavior and would rather assign a license to a specific port, 
make the port ineligible to receive a license, or move licenses among ports, refer to the “Configuring 
Port Activation Licenses” section on page 1-20.

License Status Definitions

Table 1-3 defines the port activation license status terms.

.

!

Cisco MDS 9124e

EXT 1 EXT 2 EXT 3 EXT 4 EXT 5 EXT 6 EXT 7 EXT 8

LiNK

18
20

72

!

4cb

0

15

16

17

18

19

18
20

74

Table 1-3 Port Activation License Status Definitions

Port Activation License Status Definition

acquired The port is licensed and active.
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By default, when you install additional port license activation packages, the activation status of ports 
changes from “eligible” to “acquired.” If you prefer to accept the default behavior, no further action is 
required.

Note You can uninstall licenses for ports not in use; however, you cannot uninstall default licenses.

Configuring Port Activation Licenses
This section contains the following topics:

• Checking the Status of Licenses, page 1-20

• Making a Port Eligible for a License, page 1-21

• Acquiring a License for a Port, page 1-23

Checking the Status of Licenses

Note The dialog boxes shown in Figures 11-5 and 11-6 apply only to the Cisco MDS 9124 Fabric Switch.

Detailed Steps

To check the number of licenses that are in use using Device Manager, follow these steps:

Step 1 From the menu bar, choose Admin > Licenses. 

You see the Licenses dialog box as shown in Figure 1-8.

eligible The port is eligible to receive a license but does 
not yet have one.

ineligible The port is not allowed to receive a license. 

Table 1-3 Port Activation License Status Definitions (continued)

Port Activation License Status Definition
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Figure 1-8 Licenses Dialog Box

Step 2 Click the Port Licensing tab. 

You see the licenses that are in use as shown in Figure 1-9.

Figure 1-9 Licenses in Use

Step 3 Click Close to close the dialog box.

Making a Port Eligible for a License

By default, all ports are eligible to receive a license. However, if a port has already been made ineligible 
and you prefer to activate it, then you must make that port eligible by using the port-license command. 

To make a port eligible to acquire a license, follow these steps:

Command Purpose

Step 1 switch# config t
switch(config)#

Enters configuration mode.

Step 2 switch(config)# interface fc1/1
switch(config-if)#

Specifies the port interface that you want to make 
eligible for a license. 

Note The name of the port depends on the switch 
you are using. See “Port-Naming 
Conventions” section on page 1-18 for 
information on port names.
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Note The dialog box shown in Figure 11-7 applies only to the Cisco MDS 9124 Fabric Switch.

Detailed Steps

To make multiple ports eligible to acquire a license using Device Manager, follow these steps:

Step 1 From the menu bar, choose Interface > FC All and click the License tab or hold down the Control key, 
and then click each port that you want to make eligible.

Step 2 Right-click the selected ports, select Configure, and click the License tab.

You see the FC Interfaces dialog box as shown in Figure 1-10.

Figure 1-10 FC Interfaces Dialog Box

Step 3 Select eligible from the Config drop-down list for each port that you want to make eligible.

Step 4 Click Apply to save the changes.

Note The dialog box shown in Figure 11-8 applies only to the Cisco MDS 9124 Fabric Switch.

Detailed Steps

To make a single port eligible to acquire a license using Device Manager, follow these steps:

Step 1 Right-click a port, select Configure, and click the License tab.

You see the port licensing options for the selected port as shown in Figure 1-11.

Step 3 switch(config-if)# port-license Makes the port eligible to acquire a license.

switch(config-if)# no port-license Removes a license from a port if it already has been 
assigned, and also makes the port ineligible to 
acquire a license.

Note You can remove licenses only from ports 
that are not in an administrative shutdown 
state.

Command Purpose
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Figure 1-11 License Tab for Selected Port

Step 2 Click the eligible radio button to make the port eligible.

Step 3 Click Apply to save the changes.

Acquiring a License for a Port

If you do not prefer to accept the default on-demand port license assignments, you will need to first 
acquire licenses for ports to which you want to move the license.

To acquire a license for a port, follow these steps:

Detailed Steps

To acquire licenses for multiple ports using Device Manager, follow these steps:

Step 1 Choose Interface > FC All and click the License tab or hold down the Control key, and then click each 
port for which you want to acquire a license.

Step 2 Right-click the selected ports, select Configure, and click the License tab.

You see the FC Interfaces dialog box as shown in Figure 1-10.

Step 3 Select acquire from the Config drop-down list for each port that you want to acquire a license.

Step 4 Click Apply to save the changes.

To acquire a license for a single port using Device Manager, follow these steps:

Command Purpose

Step 1 switch# config t
switch(config)#

Enters configuration mode.

Step 2 switch(config)# interface fc1/1
switch(config-if)#

Specifies the port interface for which you want to 
acquire a license.

Note The name of the port depends on the switch 
you are using. See “Port-Naming 
Conventions” section on page 1-18 for 
information on port names.

Step 3 switch(config-if)# port-license acquire Grants a license to a port or range of ports.

switch(config-if)# no port-license Removes a license from a port or range of ports.
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Step 1 Right-click a port, select Configure, and click the License tab.

You see the port licensing options for the selected port as shown in Figure 1-11.

Step 2 Click the acquire radio button to acquire a license for the port.

Step 3 Click Apply to save the changes.
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