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Administering Auto-Synchronization with 
Devices

This chapter describes how to administer the Auto-Synchronization with Devices feature in Cisco Data 
Center Network Manager (DCNM).

This chapter includes the following sections:

• Information About Auto-Synchronization with Devices, page 15-1

• Licensing Requirements for Auto-Synchronization with Devices, page 15-2

• Prerequisites for Auto-Synchronization with Devices, page 15-2

• Guidelines and Limitations for Auto-Synchronization with Devices, page 15-3

• Configuring Device Auto-Synchronization, page 15-3

• Viewing the Status of Auto-Synchronization Pollers, page 15-8

• Field Descriptions for Auto Synchronization with Devices, page 15-9

• Additional References, page 15-10

• Feature History for Auto-Synchronization with Devices, page 15-11

Information About Auto-Synchronization with Devices
The Auto Synchronizing with Devices feature ensures that the Cisco Data Center Network Manager 
(DCNM) server has current configuration and status information about managed devices. The Cisco 
DCNM server creates one poller process for each device to retrieve the system and accounting logs that 
this feature requires.

When you choose Auto Synchronization with Devices on the Feature Selector, the content pane shows 
information about each poller process and allows you to control them.

You can configure the length of time that Cisco DCNM waits before polling a device again. By default, 
Cisco DCNM polls each managed device every 60 seconds. You can increase the length of time to a 
maximum of 300 seconds. For more information, see the “Configuring the Polling Interval” section on 
page 15-4.

Cisco DCNM polls devices concurrently; however, to avoid polling all devices simultaneously, Cisco 
DCNM begins polling devices in alphabetical device-name order and delays each polling process by a 
short, random amount of time.
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Licensing Requirements for Auto-Synchronization with Devices
This section includes the following topics:

• Automatic and Manual Purging of Event Data, page 15-2

• Virtualization Support, page 15-2

Automatic and Manual Purging of Event Data
You can use the Auto-Synchronization with Devices feature to delete unwanted event data. Cisco DCNM 
supports automatic purging of event data. You can configure the following aspects of automatic event 
data purging:

• Days of the week and time of day that automatic purging occurs.

• Whether Cisco DCNM determines which event data to purge by the age of the data or by a maximum 
number of database entries.

• Severity level of events.

You can also manually purge event data.

Virtualization Support
Cisco DCNM treats each virtual device context (VDC) on a Cisco NX-OS device as a separate device. 
Cisco DCNM creates one poller process per device.

Licensing Requirements for Auto-Synchronization with Devices
The following table shows the licensing requirements for this feature:

Prerequisites for Auto-Synchronization with Devices
The Auto-Synchronization with Devices feature has the following prerequisites:

• The Cisco DCNM server must be able to connect to the devices.

• The Cisco NX-OS device must be running a supported version of Cisco NX-OS.

• The Cisco NX-OS device must have the minimal configuration that is required to enable device 
discovery to succeed. For more information, see the “Cisco NX-OS Device Preparation” section on 
page 6-2.

Product License Requirement

Cisco DCNM Auto-Synchronization with Devices requires no license. Any feature not included in a license package is 
bundled with the Cisco DCNM and is provided at no charge to you. For information about obtaining and 
installing a Cisco DCNM LAN Enterprise license, see the “Installing Licenses” section on page 2-11.
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Guidelines and Limitations for Auto-Synchronization with 
Devices

The Auto-Synchronization with Devices feature has the following configuration guidelines and 
limitations:

• We recommend that you use the default device polling interval unless you encounter issues with 
synchronization due to slow response from devices or to managing many devices. For more 
information, see the “Configuring the Polling Interval” section on page 15-4.

• For the Auto-Synchronization with Devices feature, the Cisco DCNM client does not automatically 
update the information shown in the Summary pane. To ensure that you are viewing current 
information, from the menu bar, choose View > Refresh.

• We recommend that you configure automatic purging of event data to ensure that the Cisco DCNM 
database size does not grow too large.

Configuring Device Auto-Synchronization
Figure 15-1 shows the Auto-Synchronization with Devices content pane.

Figure 15-1 Auto-Synchronization with Devices Content Pane

This section includes the following topics:

• Starting and Stopping a Poller, page 15-4

• Configuring the Polling Interval, page 15-4

• Synchronizing with a Device, page 15-5

• Deleting Data from the Events Database, page 15-6
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• Enabling and Disabling Automatic Event Purging, page 15-6

• Configuring Automatic Event Purge Settings, page 15-7

• Purging Events Now, page 15-8

Starting and Stopping a Poller
You can start and stop a poller for a device. When a poller is stopped, auto-synchronization for the device 
does not occur.

DETAILED STEPS

To start or stop a poller, follow these steps:

Step 1 From the Feature Selector pane, choose DCNM Server Administration > Auto Synchronization with 
Devices.

A table of pollers appears in the Contents pane. Each row corresponds to a poller for a particular device. 
Devices are listed alphabetically. The Poller Status field displays messages about whether the poller is 
running or is stopped.

Step 2 Click the poller that you want to start or stop.

Step 3 Do one of the following:

• To start a poller, from the menu bar, choose Actions > Start Poller. The Poller Status field changes 
to Running.

• To stop a poller, from the menu bar, choose Actions > Stop Poller. The Poller Status field changes 
to Stopped.

You do not need to save your changes.

Configuring the Polling Interval
You can configure how often the Cisco DCNM server synchronizes with managed devices. While 
synchronizing, the Cisco DCNM server fetches accounting and system logs from managed devices. This 
setting affects how frequently features in the Cisco DCNM client receive updated information about 
managed devices.

BEFORE YOU BEGIN

The default polling interval is 60 seconds.

Determine how often you want Cisco DCNM to perform auto-synchronization with managed devices. In 
general, consider the following:

• How often device configurations are changed by means other than Cisco DCNM, such as using the 
command-line interface of a device. If changes by means other than Cisco DCNM are common, 
consider using a short polling interval.

• How important it is to your organization that Cisco DCNM be up to date with managed device 
configurations. If up-to-date configuration information is important to your organization, consider 
using a short polling interval.
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DETAILED STEPS

To configure the polling interval, follow these steps:

Step 1 From the Feature Selector pane, choose DCNM Server Administration > Auto Synchronization with 
Devices.

The device polling interval appears in the Contents pane, above the table of pollers.

Step 2 In the Device Polling Interval field, enter the number of seconds between auto-synchronizations for all 
devices. The default interval is 60 seconds. You can specify an interval between 30 and 300 seconds.

Step 3 From the menu bar, choose File > Deploy to save the polling interval.

Synchronizing with a Device
You can make Cisco DCNM synchronize with a device manually when you do not want to wait for the 
next auto-synchronization to occur.

Note If many configuration changes have occurred on the device since the last successful synchronization, 
consider performing device discovery instead of synchronization. For more information, see 
“Discovering a Device” section on page 7-5.

BEFORE YOU BEGIN

Ensure that you have either configured the device entry with unique device credentials or that Cisco 
DCNM can use the default device credentials to connect to the device. For more information, see the 
“Configuring Default Device Credentials” section on page 7-6.

DETAILED STEPS

To synchronize with a device, follow these steps:

Step 1 From the Feature Selector pane, choose DCNM Server Administration > Auto Synchronization with 
Devices. 

A table of pollers appears in the Contents pane. Each row corresponds to a poller for a particular device. 
Devices are listed alphabetically. 

Step 2 Click the device that you want Cisco DCNM to synchronize with.

Step 3 From the menu bar, choose Actions > Synchronize with Device.

Synchronization begins.

To determine when the synchronization has finished, watch the Last Sync Status column. Typically, 
synchronization with a device occurs in less than 5 minutes.

You do not need to save your changes.
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Deleting Data from the Events Database
You can delete data from the events database based on the exact age of the events. Events that you delete 
can no longer appear in the Event Browser or on a feature-specific Events tab.

Tip If you want to delete events based on the number of events in the database, see the “Purging Events Now” 
section on page 15-8.

BEFORE YOU BEGIN

Determine the date and time of the newest events data that you want to delete. When you follow the steps 
in this procedure, Cisco DCNM deletes all events that are older than the date and time that you select.

DETAILED STEPS

To delete data from the events database, follow these steps:

Step 1 From the Feature Selector pane, choose DCNM Server Administration > Auto Synchronization with 
Devices.

The Events Database Administration tab appears in the Details pane, below the table of pollers.

Step 2 From the Delete events older than drop-down list, choose the date and time of the newest event that you 
want to delete and click OK.

Step 3 Click Delete.

Cisco DCNM deletes all events older than the date and time that you specified.

Enabling and Disabling Automatic Event Purging
You can enable or disable the automatic purging of events from the Cisco DCNM events database.

DETAILED STEPS

To enable or disable automatic event purging, follow these steps:

Step 1 From the Feature Selector pane, choose DCNM Server Administration > Auto Synchronization with 
Devices.

The Events Database Administration tab appears in the Details pane, below the table of pollers.

Step 2 Under Purge Settings, do one of the following:

• To enable automatic event purging, check Enable Auto Purge.

• To disable automatic event purging, uncheck Enable Auto Purge.

Step 3 From the menu bar, choose File > Deploy to save your changes to the Cisco DCNM server.
15-6
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Configuring Automatic Event Purge Settings
You can configure when automatic event purging occurs and the criteria that Cisco DCNM uses to 
determine which events to purge.

BEFORE YOU BEGIN

Determine when you want automatic event purging to occur. We recommend that automatic event 
purging occur when Cisco DCNM usage is low.

If you perform backups of your Cisco DCNM databases, consider scheduling automatic event purging 
after database backups have occurred, to ensure that you retain a record of all events.

Determine what criteria you want Cisco DCNM to use to determine which events to purge. The criteria 
available are as follows:

• Age of event—Cisco DCNM can purge all events that are older than a specific number of days, 
weeks, or months.

• Number of events in the database—When the number of events in the database exceeds the 
maximum number that you specify, Cisco DCNM can purge the oldest events first until the 
maximum number is not exceeded.

• Severity of event—Cisco DCNM can purge events based on the severity level of the event.

If you enable both criteria, Cisco DCNM applies them independently of each other.

DETAILED STEPS

To configure automatic event purge settings, follow these steps:

Step 1 From the Feature Selector pane, choose DCNM Server Administration > Auto Synchronization with 
Devices.

The Events Database Administration tab appears in the Details pane, below the table of pollers.

Step 2 Under Purge Threshold, configure the criteria that Cisco DCNM uses to determine which events to 
purge. You can configure any of the criteria in the following table:

Purge Criteria How to Configure

Age of events 1. Check Data older than.

2. From the first drop-down list, choose the number of days, 
weeks, or months.

3. From the second drop-down list, choose Days, Weeks, or 
Months, as needed.

Number of events in the database 1. Check Total Entries Exceed(0-2147483647).

2. In the box, enter the maximum number of entries that you want 
to allow in the events database.

Severity of event 1. Check Severity. The list of eight severity levels becomes 
available.

2. For each severity level that you want Cisco DCNM to use to 
determine whether to purge events, check the severity level.
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Step 3 Under Purge Settings, follow these steps to configure when you want automatic purging to occur:

a. Check the days-of-the-week check boxes to specify which days of the week that you want automatic 
purging to occur.

b. Use the Run at box to configure the exact time on the specified days that you want automatic event 
purging to occur.

Step 4 (Optional) If you want to enable automatic event purging, check Enable Auto Purge.

Step 5 From the menu bar, choose File > Deploy to save your changes to the Cisco DCNM server.

Purging Events Now
You can purge event data on demand, using the automatic event purge settings to determine which events 
are purged. Events that you delete can no longer appear in the Event Browser or on a feature-specific 
Events tab.

Tip If you want to delete events on demand, based on the exact age of the events, see the “Deleting Data from 
the Events Database” section on page 15-6.

BEFORE YOU BEGIN

Ensure that the automatic event purge settings are configured as needed. For more information, see the 
“Configuring Automatic Event Purge Settings” section on page 15-7.

DETAILED STEPS

To purge events from the events database now, follow these steps:

Step 1 From the Feature Selector pane, choose DCNM Server Administration > Auto Synchronization with 
Devices.

The Events Database Administration tab appears in the Details pane, below the table of pollers.

Step 2 Under Purge Settings, click Purge Now.

Cisco DCNM deletes events, using the automatic event purge settings to determine which events to 
purge.

Viewing the Status of Auto-Synchronization Pollers
To view the status of an auto-synchronization poller, from the Feature Selector pane, choose DCNM 
Server Administration > Auto Synchronization with Devices.

Poller status and information about the synchronization time and status appear in the Pollers area in the 
Contents pane. For information about the fields that appear, see the “Field Descriptions for Auto 
Synchronization with Devices” section on page 15-9.s
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Field Descriptions for Auto Synchronization with Devices
This section includes the following field descriptions for the Auto Synchronization with Devices feature:

• Summary Pane, page 15-9

• Events Database Administration Tab, page 15-9

Summary Pane

Events Database Administration Tab

Table 15-1 Auto Synchronization with Devices Summary Pane

Field Description

Pollers

Device Polling Interval Number of seconds that all pollers wait before the next attempt to 
synchronize with a device. The default value is 60 seconds. Valid values are 
from 30 to 300 seconds.

Last Refresh Time Display only. Date and time that the Cisco DCNM client updated 
information shown on the Content pane.

Device Display only. Name and IP address of the device for the corresponding 
poller.

Poller Status Display only. Whether the poller is running or stopped. A running poller 
attempts to synchronize with the configuration and status information from 
its device at the frequency specified by the Device Polling Interval field.

Last Sync Time Display only. Date and time that the poller last retrieved system and 
accounting log data from the device.

Last Sync Status Display only. Whether the most recent synchronization attempt succeeded or 
failed. If synchronization failed, determine why Cisco DCNM failed to 
connect to the device. If necessary, rediscover the device.

Table 15-2 Events Database Administration Tab

Field Description

Delete events older than Date and time of the newest event to be deleted from the events database. 
There is no default value for this field.

Purge Threshold

Data older than Whether, during automatic event purging, Cisco DCNM deletes events that 
are older than the age specified in the drop-down lists located to the right of 
this check box. By default, this check box is unchecked. If you check the 
check box, the default age is 1 day.

Total Entries Exceed Whether, during automatic event purging, Cisco DCNM deletes the oldest 
events until the number of events equals the number in the box located to the 
right of this check box. By default, this check box is unchecked. If you check 
the check box, the default number of event is 25,000.
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Additional References
For additional information related to administering Auto-Synchronization with Devices, see the 
following sections:

• Related Documents, page 15-10

• Standards, page 15-11

Related Documents

Severity Whether, during automatic event purging, Cisco DCNM deletes events with 
severity levels that are selected from the list of severity levels. By default, 
this check box is disabled.

Severity Levels The severity levels of events that Cisco DCNM deletes during automatic 
event purging. The severity levels are available only if the Severity check 
box is checked. By default, all severity levels are disabled. The severity 
levels are as follows:

• Emergency

• Alert

• Critical

• Error

• Warning

• Notification

• Informational

• Debugging

Purge Settings

Enable Auto Purge Whether automatic purging of event data is enabled. By default, this check 
box is disabled.

Run on Days of the week that the automatic purging of events data occurs. By 
default, none of the check boxes are checked. If you check the Daily check 
box, the check boxes for the individual days of the week become unavailable.

Run at Time of day that automatic purging of event data occurs, on the days of the 
week that automatic purging is enabled.

Table 15-2 Events Database Administration Tab (continued)

Field Description

Related Topic Document Title

Events Chapter 10, “Managing Events”

Device discovery Administering Device Discovery, page 6-1
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Standards

Feature History for Auto-Synchronization with Devices
Table 15-3 lists the release history for this feature.

Standards Title

No new or modified standards are supported by this 
feature, and support for existing standards has not been 
modified by this feature.

—

Table 15-3 Feature History for Auto-Synchronization with Devices

Feature Name Releases Feature Information

Automatic purging based on event severity. 4.2(1) Support was added.

Automatic purging of statistical data 4.1(2) This feature was introduced.

Auto-Synchronization with Devices 4.1(2) This feature was introduced.
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