Cisco Nexus 6000 Series NX-OS Fibre Channel over Ethernet Configuration Guide, Release 6.x
Configuring Cisco Adapter FEX with FCoE
Downloads: This chapterpdf (PDF - 1.28 MB) The complete bookPDF (PDF - 2.5 MB) | The complete bookePub (ePub - 402.0 KB) | Feedback

Configuring Cisco Adapter FEX with FCoE

Configuring Cisco Adapter FEX with FCoE

This chapter contains the following sections:

Overview

The Cisco Adapter Fabric Extender (FEX) feature allows you to create an FCoE connection to a FEX so that you can establish an FCoE connection to a server with a virtual interface card (VIC) adapter.

For example, you could use this feature to connect your Nexus switch to a Cisco UCS C-Series Rack-Mount Server that contains a Cisco UCS P81E Virtual Interface Card, or you could connect it to a third-party server that has a Broadcom BCM57712 Convergence Network Interface Card (C-NIC) installed.

The switch connects to the FEX through a virtual port channel (vPC) while the FEX connects to the server using a standard FCoE link between the FEX and the VIC adapter.

Guidelines and Limitations

If you are using Enhanced vPC, the FEX can be associated with one and only one Cisco Nexus fabric for FCoE forwarding.

If you are using FabricPath, you must use a dedicated link for FCoE traffic.

If you are using a Cisco UCS C-Series Rack-Mount Server with a Cisco UCS P81E Virtual Interface Card (VIC), you must do the following:

  • Configure the VIC in Network Interface Virtualization (NIV) mode, which makes the two unified ports appear to the system as virtual Host Bus Adapters (vHBAs).

  • You cannot connect to the FEX through a VNP port. If this type of connection is used, NIV mode cannot be enabled on the VIC.

  • You must set the NIC mode on the Cisco UCS C-Series Rack-Mount Server to active-standby.

Configuring Cisco Adapter FEX with FCoE

Procedure
     Command or ActionPurpose
    Step 1configure terminal


    Example:
    switch# configure terminal
    switch(config)#
     

    Enters global configuration mode.

     
    Step 2install feature-set virtualization


    Example:
    switch(config) # install feature-set virtualization
    switch(config) #
     

    Installs the virtualization feature set.

     
    Step 3feature-set virtualization


    Example:
    switch(config) # feature-set virtualization
    switch(config)#
     

    Enables the virtualization feature.

     
    Step 4fex fex-chassis-ID


    Example:
    switch(config) # fex 101
    switch(config-fex) # 
     

    Enters configuration mode for the specified FEX.

    The range for fex-chassis_ID is from 100 to 199.

     
    Step 5fcoe


    Example:
    switch(config-fex) # fcoe
    switch(config-fex) # 
     

    Enables Fibre Channel over Ethernet traffic on the FEX.

     
    Step 6interface ethernet [fex-chassis-ID/slot/port]


    Example:
    switch(config-fex)# interface ethernet 101/1/1
    switch(config-if)#
     

    Enters configuration mode for the specified Ethernet interface.

    The range for fex-chassis-ID is from 100 to 199. The slot For FCoE, the range for port is from 1 to 32.

    Note   

    If this is a 10G breakout port, the slot/port syntax is slot/QSFP-module/port.

     
    Step 7switchport mode vntag


    Example:
    switch(config-if) # switchport mode vntag
    switch(config-if) # 
     

    Configures the interface in port mode.

     
    Step 8interface vethernet veth-id


    Example:
    switch(config-if) # interface vethernet 2
    switch(config-if) # 
     

    Creates a virtual Ethernet interface and enters configuration mode for that interface.

    The range of veth-id is from 1 to 1,048,575.

    Note   

    If you have two Cisco Nexus Series switches configured for redundancy, the virtual Ethernet interface ID must be unique on each switch.

     
    Step 9bind interface ethernet [fex-chassis-ID/]slot/port channel channel-no


    Example:
    switch(config-if) # bind interface ethernet 101/1/1 channel 1
    switch(config-if) # 
     

    Binds the specified Ethernet interface to the specified port channel.

    The range for fex-chassis-ID is from 100 to 199. The slot must be 1. For FCoE, the range for port is from 1 to 32. The range for channel-no is from 1 to 4096.

    Note   

    If this is a 10G breakout port, the slot/port syntax is slot/QSFP-module/port.

     
    Step 10switchport mode {trunk|access}


    Example:
    switch(config-if) # switchport mode trunk
    switch(config-if) # 
     

    Configures the interface as a trunk port or an access port.

     
    Step 11switchport trunk allowed vlan vlan-ID


    Example:
    switch(config-if) # switchport trunk allowed vlan 33
    switch(config-if) # 
     
    (Optional)

    If you configured the interface as a trunk port, use this command to specify the VLAN for FCoE traffic.

    The range for vlan-ID is from 1 to 4094, except for the VLANs reserved for internal use.

     
    Step 12switchport access vlan vlan-ID


    Example:
    switch(config-if) # switchport access vlan 33
    switch(config-if) # 
     
    (Optional)

    If you configured the interface as an access port, use this command to specify the VLAN for FCoE traffic.

     
    Step 13interface vfc vfc-id


    Example:
    switch(config-if) # interface vfc 4
    switch(config-if) # 
     

    Creates a virtual Fibre Channel interface on the switch and enters configuration mode.

    The range of vfc-id is from 1 to 8192.

     
    Step 14bind interface vethernet veth-num


    Example:
    switch(config-if) # bind interface veth 2
    switch(config-if) # 
     

    Binds the virtual Fibre Channel interface to the specified virtual Ethernet interface.

    The range of veth-num is from 1 to 1048575.

     
    Step 15no shutdown


    Example:
    switch(config-if) # no shutdown
    switch(config-if) # 
     

    Returns the interface to its default operational state.

     

    This example show how to configure Cisco Adapter FEX with FCoE on SAN fabric A using FEX 101 and the Ethernet interface on channel 1 configured as a trunk port.

    nexus5000-sanA(config)#configure terminal
    nexus5000-sanA(config)# install feature-set virtualization
    nexus5000-sanA(config)# feature-set virtualization
    nexus5000-sanA(config)# fex 101
    nexus5000-sanA(config-fex)# fcoe
    nexus5000-sanA(config-fex)# interface ethernet 101/1/1
    nexus5000-sanA(config-if)# switchport mode vntag
    nexus5000-sanA(config-if)# interface veth 2
    nexus5000-sanA(config-if)# bind interface eth 101/1/1 channel 1
    nexus5000-sanA(config-if)# switchport mode trunk
    nexus5000-sanA(config-if)# switchport trunk allowed vlan 33
    nexus5000-sanA(config-if)# interface vfc 4
    nexus5000-sanA(config-if)# bind interface veth 2
    nexus5000-sanA(config-if)# no shutdown
    
    
    nexus6000-sanA(config)#configure terminal
    nexus6000-sanA(config)# install feature-set virtualization
    nexus6000-sanA(config)# feature-set virtualization
    nexus6000-sanA(config)# fex 101
    nexus6000-sanA(config-fex)# fcoe
    nexus6000-sanA(config-fex)# interface ethernet 101/1/1
    nexus6000-sanA(config-if)# switchport mode vntag
    nexus6000-sanA(config-if)# interface veth 2
    nexus6000-sanA(config-if)# bind interface eth 101/1/1 channel 1
    nexus6000-sanA(config-if)# switchport mode trunk
    nexus6000-sanA(config-if)# switchport trunk allowed vlan 33
    nexus6000-sanA(config-if)# interface vfc 4
    nexus6000-sanA(config-if)# bind interface veth 2
    nexus6000-sanA(config-if)# no shutdown
    
    

    This example shows how to configure Cisco Adapter FEX with FCoE on SAN fabric B using FEX 102 and Ethernet interface on channel 2 as an access port:

    nexus5000-sanB(config)#configure terminal
    nexus5000-sanB(config)# install feature-set virtualization
    nexus5000-sanB(config)# feature-set virtualization
    nexus5000-sanB(config)# fex 102
    nexus5000-sanB(config-fex)# fcoe
    nexus5000-sanB(config-fex)# interface ethernet 102/1/1
    nexus5000-sanB(config-if)# switchport mode vntag
    nexus5000-sanB(config-if)# interface veth 5
    nexus5000-sanB(config-if)# bind interface eth 102/1/1 channel 2
    nexus5000-sanB(config-if)# switchport mode access
    nexus5000-sanB(config-if)# switchport access vlan 40
    nexus5000-sanB(config-if)# interface vfc 6
    nexus5000-sanB(config-if)# bind interface veth 5
    nexus5000-sanB(config-if)# no shutdown
    
    
    nexus6000-sanB(config)#configure terminal
    nexus6000-sanB(config)# install feature-set virtualization
    nexus6000-sanB(config)# feature-set virtualization
    nexus6000-sanB(config)# fex 102
    nexus6000-sanB(config-fex)# fcoe
    nexus6000-sanB(config-fex)# interface ethernet 102/1/1
    nexus6000-sanB(config-if)# switchport mode vntag
    nexus6000-sanB(config-if)# interface veth 5
    nexus6000-sanB(config-if)# bind interface eth 102/1/1 channel 2
    nexus6000-sanB(config-if)# switchport mode access
    nexus6000-sanB(config-if)# switchport access vlan 40
    nexus6000-sanB(config-if)# interface vfc 6
    nexus6000-sanB(config-if)# bind interface veth 5
    nexus6000-sanB(config-if)# no shutdown