Cisco Nexus 6000 Series NX-OS Unicast Routing Command Reference
A Commands
Downloads: This chapterpdf (PDF - 184.0KB) The complete bookPDF (PDF - 4.5MB) | Feedback

A Commands

Table Of Contents

A Commands

area authentication (OSPF)

area default-cost (OSPF)

area filter-list (OSPF)

area nssa (OSPF)

area range (OSPF)

area stub (OSPF)

area virtual-link (OSPF)

authentication (OSPF virtual link)

authentication-key (OSPF virtual link)

auto-cost (OSPF)


A Commands


This chapter describes the Cisco NX-OS Open Shortest Path First (OSPF) commands that begin with A.

area authentication (OSPF)

To enable authentication for an Open Shortest Path First (OSPF) area, use the area authentication command. To remove authentication for an area, use the no form of this command.

area area-id authentication [message-digest]

no area area-id authentication [message-digest]

Syntax Description

area-id

Identifier for the OSPF area where you want to enable authentication. Specify as either a positive integer value or an IP address.

message-digest

(Optional) Enables Message Digest 5 (MD5) authentication on the area specified by the area-id argument.


Command Default

No authentication

Command Modes

Command HistoryRouter configuration mode

Release
Modification

5.0(3)N1(1)

This command was introduced.


Usage Guidelines

Use the area authentication command to configure the authentication mode for the entire OSPF area.

The authentication type and authentication password must be the same for all OSPF devices in an area. Use the ip ospf authentication-key command in interface configuration mode to specify this password.

If you enable MD5 authentication with the message-digest keyword, you must configure a password with the ip ospf message-digest-key command in interface configuration mode.

This command requires the LAN Base Services license.

Examples

This example shows how to configure authentication for area 0 of OSPF routing process 201:

switch(config)# router ospf 201
switch(config-router)# area 0 authentication message-digest
switch(config-router)# interface ethernet 1/1
switch(config-if)# no switchport
switch(config-if)# ip ospf area 0
switch(config)-if# ip ospf message-digest-key 10 md5 0 adcdefgh
 
   

Related Commands

Command
Description

copy running-config startup-config

Saves the configuration changes to the startup configuration file.

ip ospf authentication-key

Assigns a password for simple password authentication for OSPF.

ip ospf message-digest-key

Assigns a password for OSPF MD5 authentication.

show ip ospf interface

Displays OSPF interface-related information.


area default-cost (OSPF)

To specify a cost for the default summary route sent into an Open Shortest Path First (OSPF) stub or not-so-stubby area (NSSA), use the area default-cost command. To remove the assigned default route cost, use the no form of this command.

area area-id default-cost cost

no area area-id default-cost cost

Syntax Description

area-id

Identifier for the OSPF area where you want to configure the default cost. The area ID can be from 0 to 4294967295 or an IP address.

cost

Cost for the default summary route used for a stub or NSSA. The range is from 0 to 16777215.


Command Default

The summary route cost is based on the area border router that generated the summary route.

Command Modes

Command HistoryRouter configuration mode

Release
Modification

5.0(3)N1(1)

This command was introduced.


Usage Guidelines

Use the area default-cost command on an Area Border Router (ABR) attached to a stub or NSSA to configure the metric for the summary default route generated by the ABR into the stub area.

This command requires the LAN Base Services license.

Examples

This example shows how to set a default cost of 20 to stub network 192.0.2.0:

switch(config)# router ospf 201
switch(config-router)# area 192.0.2.0 stub
switch(config-router)# area 192.0.2.0 default-cost 20
switch(config-router)#
 
   

Related Commands

Command
Description

area stub

Defines an area as a stub area.

copy running-config startup-config

Saves the configuration changes to the startup configuration file.

show ip ospf

Displays OSPF information.


area filter-list (OSPF)

To filter prefixes advertised in type 3 link-state advertisements (LSAs) between Open Shortest Path First (OSPF) areas of an Area Border Router (ABR), use the area filter-list command. To change or cancel the filter, use the no form of this command.

area area-id filter-list route-map map-name {in | out}

no area area-id filter-list route-map map-name {in | out}

Syntax Description

area-id

Identifier for the OSPF area where you want to configure filtering. Specify as either a positive integer value or an IP address.

route-map map-name

Specifies the name of a route map used as the filter policy. The map-name argument can be any alphanumeric string of up to 63 characters.

in

Filters networks sent to this area.

out

Filters networks sent from this area.


Command Default

None

Command Modes

Command HistoryRouter configuration mode

Release
Modification

5.0(3)N1(1)

This command was introduced.


Usage Guidelines

Use the area filter-list command to filter Type 3 LSAs. If you apply the route map with the in keyword, the route map filters all Type 3 LSAs originated by the ABR to this area, including Type 3 LSAs that originated as a result of the area range command in another area.

If you apply the route map with the out keyword, the route map filters all Type 3 LSAs that are advertised by the ABR to all other areas including Type 3 LSAs that originate locally as a result of the area range command configured in this area.

Cisco NX-OS implicitly denies any prefix that does not match an entry in the route map.

This command requires the LAN Base Services license.

Examples

This example shows how to filter prefixes that are sent from all other areas to area 1:

switch(config)# router ospf 202
switch(config-router)# area 1 filter-list route-map FilterExternal in 
switch(config-router)#
 
   

Related Commands

Command
Description

area range

Consolidates and summarizes routes at an area boundary.

copy running-config startup-config

Saves the configuration changes to the startup configuration file.

route-map

Defines the conditions for redistributing routes from one routing protocol into another.

show ip ospf policy statistics area

Displays OSPF policy statistics for an area.


area nssa (OSPF)

To configure an area as an Open Shortest Path First (OSPF) not-so-stubby (NSSA) area, use the area nssa command. To remove the NSSA area, use the no form of this command.

area area-id nssa [default-information-originate [route-map map-name]] [no-redistribution] [no-summary] [translate type7 [always | never] [suppress-fa]]

no area area-id nssa [default-information-originate [route-map map-name]] [no-redistribution] [no-summary] [translate type7 [always | never] [suppress-fa]]

Syntax Description

area-id

Identifier for the OSPF NSSA area. The area ID can be from 0 to 4294967295 or an IP address.

default-information-
originate

(Optional) Generates a Type 7 default into the NSSA area. This keyword takes effect only on NSSA area border router (ABR) or NSSA autonomous system border router (ASBR).

route-map map-name

(Optional) Filters the Type 7 default generation based on the route map. The map-name argument can be any alphanumeric string up to 63 characters.

no-redistribution

(Optional) Blocks redistributed link-state advertisements (LSAs) from entering this NSSA area. Use this keyword when the router is both an NSSA ASBR and an NSSA ABR and you want the redistribute command to import routes into the normal areas but not into the NSSA area.

no-summary

(Optional) Allows an area to be an NSSA area but not have summary routes injected into it.

translate type7

(Optional) Translates Type 7 LSAs to type 5 LSAs.

always

(Optional) Always translates LSAs.

never

(Optional) Never translates LSAs.

suppress-fa

(Optional) Suppresses the forwarding address in translated LSAs. The ABR uses 0.0.0.0 as the forwarding IPv4 address.


Command Default

None

Command Modes

Command HistoryRouter configuration mode

Release
Modification

5.0(3)N1(1)

This command was introduced.


Usage Guidelines

Use the area nssa command to create an NSSA area in an OSPF autonomous system. We recommend that you understand the network topology before configuring forwarding address suppression for translated LSAs. Suboptimal routing might result because there might be better paths to reach the destination's forwarding address.

This command requires the LAN Base Services license.

Examples

This example shows how to configure area 1 as an NSSA area:

switch(config)# router ospf 10
switch(config-router)# area 1 nssa
switch(config-router)#
 
   

This example shows how to configure area 1 as an NSSA area and translate Type 7 LSAs from area 1 to Type 5 LSAs, but not place the Type 7 forwarding address into the Type 5 LSAs. (OSPF places 0.0.0.0 as the forwarding address in the Type 5 LSAs.)

switch(config)# router ospf 2
switch(config-router)# area 1 nssa translate type7 suppress-fa
switch(config-router)#
 
   

Related Commands

Command
Description

copy running-config startup-config

Saves the configuration changes to the startup configuration file.

redistribute

Redistributes routes learned from one routing protocol to another routing protocol domain.

show ip ospf

Displays OSPF information.


area range (OSPF)

To consolidate and summarize routes at an Open Shortest Path First (OSPF) area boundary, use the area range command. To disable this function, use the no form of this command.

area area-id range ip-prefix [not-advertise]

no area area-id range ip-prefix [not-advertise]

Syntax Description

area-id

Identifier for the OSPF area where you want to summarize routes. The area ID can be from 0 to 4294967295 or an IP address.

ip-prefix

IP prefix specified as IP address/subnet mask length (A.B.C.D/LEN).

not-advertise

(Optional) Sets the address range status to DoNotAdvertise. The Type 3 summary LSA is suppressed, and the component networks remain hidden from other networks.


Command Default

Disabled

Command Modes

Command HistoryRouter configuration mode

Release
Modification

5.0(3)N1(1)

This command was introduced.


Usage Guidelines

Use the area range command only with Area Border Routers (ABRs) to consolidate or summarize routes for an area. The ABR advertises that a single summary route is advertised to other areas and condenses routing information at area boundaries.

You can configure OSPF to summarize addresses for many different sets of address ranges by configuring multiple area range commands.

This command requires the LAN Base Services license.

Examples

This example shows how to configure one summary route to be advertised by the ABR to other areas for all hosts on network 192.0.2.0:

switch(config-if)# interface ethernet 1/2
switch(config-if)# ip address 192.0.2.201 255.255.255.0
switch(config-if)# ip ospf area 201
switch(config-if)# exit
switch(config)# router ospf 12
switch(config-router)# area 0 range 192.0.2.0 255.255.0.0
switch(config-router)#
 
   

Related Commands

Command
Description

copy running-config startup-config

Saves the configuration changes to the startup configuration file.

show ip ospf

Displays OSPF information.


area stub (OSPF)

To define an area as an Open Shortest Path First (OSPF) stub area, use the area stub command. To remove the area, use the no form of this command.

area area-id stub [no-summary]

no area area-id stub [no-summary]

Syntax Description

area-id

Identifier for the OSPF stub area. The area ID can be from 0 to 4294967295 or an IP address.

no-summary

(Optional) Prevents an Area Border Router (ABR) from sending summary link advertisements into the stub area.


Command Default

None

Command Modes

Command HistoryRouter configuration mode

Release
Modification

5.0(3)N1(1)

This command was introduced.


Usage Guidelines

Use the area stub command to configure all devices attached to the stub area. Use the area default-cost command on an area border router (ABR) attached to the stub area. The area default-cost command provides the metric for the summary default route generated by the ABR into the stub area.

To further reduce the number of link-state advertisements (LSAs) sent into a stub area, you can configure the no-summary keyword on the ABR to prevent it from sending Summary LSAs (Type 3 LSAs3) into the stub area.

This command requires the LAN Base Services license.

Examples

This example shows how to create stub area 33 in OSPF 209:

switch(config)# router ospf 201
switch(config-router)# area 33 stub
switch(config-router)#
 
   

Related Commands

Command
Description

area default-cost

Specifies a cost for the default summary route sent into a stub area.

copy running-config startup-config

Saves the configuration changes to the startup configuration file.

show ip ospf

Displays OSPF information.


area virtual-link (OSPF)

To define an Open Shortest Path First (OSPF) virtual link, use the area virtual-link command. To remove a virtual link, use the no form of this command.

area area-id virtual-link router-id

no area area-id virtual-link router-id

Syntax Description

area-id

Identifier for the OSPF area assigned to the transit area for the virtual link. The area ID can be from 0 to 4294967295 or an IP address.

router-id

Router ID associated with the virtual link neighbor. Specify as an IP address. The router ID appears in the show ip ospf neighbors display.


Command Default

None

Command Modes

Command HistoryRouter configuration mode

Release
Modification

5.0(3)N1(1)

This command was introduced.


Usage Guidelines

Use the area virtual-link command to establish a virtual link from a remote area to the backbone area. In OSPF, all areas must be connected to a backbone area. If the connection to the backbone is lost, it can be repaired by establishing a virtual link.

Use the area virtual-link command to enter the virtual link configuration mode where you can use the following commands:

authentication [key-chain | message-digest | null]

authentication-key [0 | 3] key

dead-interval seconds

hello-interval seconds

message-digest-key key-id md5 key

retransmit-interval seconds

transmit-delay seconds

See each command for syntax and usage details.

You must configure both sides of a virtual link with the same area ID and the corresponding virtual link neighbor router ID. To see the router ID, use the show ip ospf neighbors command in any mode.


Note You cannot configure a virtual link on a not-so-stubby (NSSA) area.


This command requires the LAN Base Services license.

Examples

This example shows how to establish a virtual link between two devices, A, and B, with default values for all optional parameters:

Device A:
switch(config)# router ospf 1
switch(config-router)# router-id 192.0.2.2
switch(config-router)# area 1 virtual-link 192.0.2.1
switch(config-router-vlink)#
 
   
Device B:
switch(config# router ospf 209
switch(config-router)# router-id 192.0.2.1
switch(config-router)# area 1 virtual-link 192.0.2.2
switch(config-router-vlink)#
 
   

Related Commands

Command
Description

authentication (OSPF virtual link)

Enables authentication for an OSPF virtual link.

authentication-key (OSPF virtual link)

Assigns a password to be used by neighboring routers that are using the simple password authentication of OSPF.

copy running-config startup-config

Saves the configuration changes to the startup configuration file.

dead-interval (OSPF virtual link)

Configures the dead interval for an OSPF virtual link.

hello-interval (OSPF virtual link)

Configures the hello interval for an OSPF virtual link.

message-digest-key (virtual link)

Enables OSPF MD5 authentication in an OSPF virtual link.

retransmit-interval (OSPF virtual link)

Configures the retransmit interval for an OSPF virtual link.

show ip ospf neighbors

Displays OSPF neighbor information.

show ip ospf virtual-link

Displays OSPF virtual link information.

transmit-delay (OSPF virtual link)

Configures the transmit delay for an OSPF virtual link.


authentication (OSPF virtual link)

To specify the authentication type for an Open Shortest Path First (OSPF) virtual link, use the authentication command. To remove the authentication type for a virtual link, use the no form of this command.

authentication [key-chain key-name | message-digest | null]

no authentication

Syntax Description

key-chain key-name

(Optional) Specifies the key-chain to use. The key-name argument can be any alphanumeric string up to 63 characters.

message-digest

(Optional) Specifies to use message-digest authentication.

null

(Optional) Specifies no authentication is used. Disables authentication if configured for an area.


Command Default

Defaults to password authentication if you configure authentication with none of the optional keywords.

Command Modes

Command HistoryOSPF virtual link configuration mode

Release
Modification

5.0(3)N1(1)

This command was introduced.


Usage Guidelines

Use the authentication command in virtual link configuration mode to configure the authentication method used on the virtual link. Use the message-digest keyword to configure MD5 message digest authentication and use the message-digest-key command to complete this authentication configuration. Use the key-chain keyword to configure password authentication using key chains and use the key chain command to complete this authentication configuration. Use the authentication command with no keywords to configure a password for the virtual link, and use the authentication-key command to complete this authentication configuration.

This command requires the LAN Base Services license.

Examples

This example shows how to enable message-digest authentication:

switch(config)# router ospf 22
switch(config-router)# area 99 virtual-link 192.0.2.12
switch(config-router-vlink)# authentication message-digest
switch(config-router-vlink)# message-digest key 4 md5 0 abcd
 
   

Related Commands

Command
Description

area authentication

Enables authentication for an OSPF area.

authentication-key (OSPF virtual link)

Assigns a password to be used by neighboring routers that are using the password authentication of OSPF.

key chain

Creates a key chain for managing authentication keys.

message-digest-key (OSPF virtual link)

Enables OSPF MD5 authentication.


authentication-key (OSPF virtual link)

To assign a password to be used by an Open Shortest Path First (OSPF) virtual link, use the authentication-key command. To remove a previously assigned OSPF password, use the no form of this command.

authentication-key [0 | 3] password

no authentication-key

Syntax Description

0

(Optional) Specifies an unencrypted authentication key.

3

(Optional) Specifies a 3DES encrypted authentication key.

password

Any continuous string of characters that can be entered from the keyboard up to 8 bytes.


Command Default

Unencrypted password

Command Modes

Command HistoryOSPF virtual link configuration mode

Release
Modification

5.0(3)N1(1)

This command was introduced.


Usage Guidelines

Use the authentication-key command to configure the password for password authentication on an OSPF virtual link. All devices on the same virtual link must have the same password to be able to exchange OSPF information.

This command requires the LAN Base Services license.

Examples

This example shows how to enable the authentication key with the string yourpass:

switch(config)# router ospf 22
switch(config-router)# area 99 virtual-link 192.0.2.12
switch(config-router-vlink)# authentication 
switch(config-router-vlink)# authentication-key yourpass

Related Commands

Command
Description

authentication (virtual link)

Enables authentication for an OSPF virtual link.


auto-cost (OSPF)

To control how Open Shortest Path First (OSPF) calculates default metrics for an interface, use the auto-cost command. To assign the default reference bandwidth of 40 Gb/s, use the no form of this command.

auto-cost reference-bandwidth bandwidth [Gbps | Mbps]

no auto-cost reference-bandwidth

Syntax Description

reference-bandwidth bandwidth

Sets the reference bandwidth used to calculate the default metrics for an interface. The range depends on whether you use the Gbps or MBps keywords.

Gbps

(Optional) Specifies the rate in Gbps (bandwidth). The range is from 1 to 4000; the default is 40.

Mbps

(Optional) Specifies the rate in Mbps (bandwidth). The range is from 1 to 4000000; the default is 40000.


Command Default

40 Gb/s. The bandwidth defaults to Gb/s if you do not specify the Gpbs or Mbps keyword.

Command Modes

Command HistoryRouter configuration mode

Release
Modification

5.0(3)N1(1)

This command was introduced.


Usage Guidelines

Use the auto-cost command to set the reference bandwidth used by the OSPF cost-metric calculation.

The value set by the ip ospf cost command overrides the cost that results from the auto-cost command.

This command requires the LAN Base Services license.

Examples

This example shows how to set the reference bandwidth for all local interfaces in an OSPF instance:

switch(config)# router ospf 201
switch(config-router)# auto-cost reference-bandwidth 10
 
   

Related Commands

Command
Description

ip ospf cost

Explicitly specifies the cost of sending a packet on an interface.