Cisco Nexus 6000 Series NX-OS Unicast Routing Command Reference
I Commands
Downloads: This chapterpdf (PDF - 231.0KB) The complete bookPDF (PDF - 4.5MB) | Feedback

I Commands

Table Of Contents

I Commands

ip authentication key-chain eigrp

ip authentication mode eigrp

ip bandwidth eigrp

ip bandwidth-percent eigrp

ip delay eigrp

ip distribute-list eigrp

ip eigrp shutdown

ip hello-interval eigrp

ip hold-time eigrp

ip next-hop-self eigrp

ip offset-list eigrp

ip passive-interface eigrp

ip route

ip router eigrp

ip split-horizon eigrp

ip summary-address eigrp


I Commands


This chapter describes the Cisco NX-OS Enhanced Interior Gateway Routing Protocol (EIGRP) commands that begin with I.

ip authentication key-chain eigrp

To enable authentication for the Enhanced Interior Gateway Routing Protocol (EIGRP) packets and to specify the set of keys that can be used on an interface, use the ip authentication key-chain eigrp command. To prevent authentication, use the no form of this command.

ip authentication key-chain eigrp instance-tag name-of-chain

no ip authentication key-chain eigrp instance-tag name-of-chain

Syntax Description

instance-tag

Name of the EIGRP instance. The instance-tag can be any case-sensitive, alphanumeric string up to 20 characters.

name-of-chain

Group of keys that are valid.


Command Default

No authentication is provided for EIGRP packets.

Command Modes

Command HistoryInterface configuration mode

Release
Modification

5.0(3)N1(1)

This command was introduced.


Usage Guidelines

You must set the authentication mode using the ip authentication mode eigrp command in interface configuration mode. You must separately configure a key chain using the key-chain command to complete the authentication configuration for an interface.

This command requires the LAN Base Services license.

Examples

This example shows how to configure the interface to accept and send any key that belongs to the key-chain trees:

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 1/2
switch(config-if)# no switchport
switch(config-if)# ip authentication key-chain eigrp 209 trees
switch(config-if)#
 
   

Related Commands

Command
Description

ip authentication mode eigrp

Sets the authentication mode for EIGRP on an interface.

key-chain

Creates a set of keys that can be used by an authentication method.

show ip eigrp interfaces

Displays information about EIGRP interfaces.


ip authentication mode eigrp

To specify the type of authentication used in the Enhanced Interior Gateway Routing Protocol (EIGRP) packets, use the ip authentication mode eigrp command. To remove authentication, use the no form of this command.

ip authentication mode eigrp instance-tag md5

no ip authentication mode eigrp instance-tag md5

Syntax Description

instance-tag

Name of the EIGRP instance. The instance-tag can be any case-sensitive, alphanumeric string up to 20 characters.

md5

Specifies Message Digest 5 (MD5) authentication.


Command Default

None

Command Modes

Command HistoryInterface configuration mode

Release
Modification

5.0(3)N1(1)

This command was introduced.


Usage Guidelines

This command requires the LAN Base Services license.

Examples

This example shows how to configure the interface to use MD5 authentication:

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 1/2
switch(config-if)# no switchport
switch(config-if)# ip authentication mode eigrp 209 md5
switch(config-if)#
 
   

Related Commands

Command
Description

authentication mode (EIGRP)

Configures the authentication mode for EIGRP in a VRF.

copy running-config startup-config

Copies the configuration changes to the startup configuration file.

ip authentication key-chain eigrp

Enables authentication for EIGRP and specifies the set of keys that can be used on an interface.

key chain

Creates a set of keys that can be used by an authentication method.

show ip eigrp interfaces

Displays information about EIGRP interfaces.


ip bandwidth eigrp

To configure the bandwidth metric on an Enhanced Interior Gateway Routing Protocol (EIGRP) interface, use the ip bandwidth eigrp command. To restore the default, use the no form of this command.

ip bandwidth eigrp instance-tag bandwidth

no ip bandwidth eigrp

Syntax Description

instance-tag

Name of the EIGRP instance. The instance-tag can be any case-sensitive, alphanumeric string up to 20 characters.

bandwidth

Bandwidth value. The range is from 1 to 2,560,000,000 kilobits.


Command Default

None

Command Modes

Command HistoryInterface configuration mode

Release
Modification

5.0(3)N1(1)

This command was introduced.


Usage Guidelines

This command requires the LAN Base Services license.

Examples

This example shows how to configure EIGRP to use a bandwidth metric of 10000 in autonomous system 209:

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip bandwidth eigrp 209 10000
 
   

Related Commands

Command
Description

ip bandwidth-percent eigrp

Sets the percent of the interface bandwidth that EIGRP can use.

show ip eigrp

Displays EIGRP information.


ip bandwidth-percent eigrp

To configure the percentage of bandwidth that may be used by the Enhanced Interior Gateway Routing Protocol (EIGRP) on an interface, use the ip bandwidth-percent eigrp command. To restore the default, use the no form of this command.

ip bandwidth-percent eigrp instance-tag percent

no ip bandwidth-percent eigrp

Syntax Description

instance-tag

Name of the EIGRP instance. The instance-tag can be any case-sensitive, alphanumeric string up to 20 characters.

percent

Percentage of bandwidth that EIGRP may use.


Command Default

percent: 50

Command Modes

Command HistoryInterface configuration mode

Release
Modification

5.0(3)N1(1)

This command was introduced.


Usage Guidelines

EIGRP uses up to 50 percent of the bandwidth of a link, as defined by the ip bandwidth interface configuration command. Use the ip bandwidth-percent command to change this default percent.

This command requires the LAN Base Services license.

Examples

This example shows how to configure EIGRP to use up to 75 percent of an interface in autonomous system 209:

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip bandwidth-percent eigrp 209 75
switch(config-if)#

Related Commands

Command
Description

ip bandwidth eigrp

Sets the EIGRP bandwidth value for an interface.

show ip eigrp

Displays EIGRP information.


ip delay eigrp

To configure the throughput delay for the Enhanced Interior Gateway Routing Protocol (EIGRP) on an interface, use the ip delay eigrp command. To restore the default, use the no form of this command.

ip delay eigrp instance-tag seconds

no ip delay eigrp instance-tag

Syntax Description

instance-tag

Name of the EIGRP instance. The instance-tag can be any case-sensitive, alphanumeric string up to 20 characters.

seconds

Throughput delay, in tens of microseconds. The range is from 1 to 16777215.


Command Default

100 (10-microsecond units)

Command Modes

Command HistoryInterface configuration mode

Release
Modification

5.0(3)N1(1)

This command was introduced.


Usage Guidelines

You configure the throughput delay on an interface in 10-microsecond units. For example, if you set the ip delay eigrp command to 100, the throughput delay is 1000 microseconds.

This command requires the LAN Base Services license.

Examples

This example shows how to set the delay to 400 microseconds for the interface:

switch(config)# router eigrp 1
switch(config-router)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip delay eigrp 1 40
 
   

Related Commands

Command
Description

ip hello-interval eigrp

Configures the hello interval on an interface for the EIGRP routing process that is designated by an autonomous system number.

show ip eigrp

Displays EIGRP information.


ip distribute-list eigrp

To configure a distribution list for the Enhanced Interior Gateway Routing Protocol (EIGRP) on an interface, use the ip distribute-list eigrp command. To restore the default, use the no form of this command.

ip distribute-list eigrp instance-tag {prefix-list list-name | route-map map-name} {in | out}

no ip distribute-list eigrp instance-tag {prefix-list list-name | route-map map-name} {in | out}

Syntax Description

instance-tag

Name of the EIGRP instance. The instance-tag can be any case-sensitive, alphanumeric string up to 20 characters.

prefix-list list-name

Specifies the name of an IP prefix list to filter EIGRP routes.

route-map map-name

Specifies the name of a route map to filter EIGRP routes.

in

Applies the route policy to incoming routes.

out

Applies the route policy to outgoing routes.


Command Default

None

Command Modes

Command HistoryInterface configuration mode

Release
Modification

5.0(3)N1(1)

This command was introduced.


Usage Guidelines

Use the ip distribute-list eigrp command to configure a route filter policy on an interface. You must configure the named route map or prefix list to complete this configuration.

This command requires the LAN Base Services license.

Examples

This example shows how to configure a route map for all EIGRP routes coming into the interface:

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip distribute-list eigrp 209 route-map InputFilter in
switch(config-if)#
 
   

Related Commands

Command
Description

prefix-list

Configures a prefix list.

route-map

Configures a route map.

show ip eigrp

Displays EIGRP information


ip eigrp shutdown

To shut down the Enhanced Interior Gateway Routing Protocol (EIGRP) on an interface, use the ip eigrp shutdown command. To restore the default, use the no form of this command.

ip eigrp instance-tag shutdown

no ip eigrp instance-tag shutdown

Syntax Description

instance-tag

Name of the EIGRP instance. The instance-tag can be any case-sensitive, alphanumeric string up to 20 characters.


Command Default

None

Command Modes

Command HistoryInterface configuration mode

Release
Modification

5.0(3)N1(1)

This command was introduced.


Usage Guidelines

Use the ip eigrp shutdown command to shut down the interface for EIGRP and prevent EIGRP adjacency for the interface for maintenance purposes. The network address for the interface does not show up in the EIGRP topology table.

Use the ip passive-interface eigrp command to prevent EIGRP adjacency but keep the network address in the topology table.

This command requires the LAN Base Services license.

Examples

This example shows how to disable EIGRP on an interface:

switch(config)# router eigrp 201
switch(config-router)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip eigrp 201 shutdown

Related Commands

Command
Description

ip passive-interface eigrp

Configures an instance of EIGRP.

router eigrp

Configures an instance of EIGRP.


ip hello-interval eigrp

To configure the Enhanced Interior Gateway Routing Protocol (EIGRP) hello interval for an interface, use the ip hello-interval eigrp command. To restore the default, use the no form of this command.

ip hello-interval eigrp instance-tag seconds

no ip hello-interval eigrp instance-tag

Syntax Description

instance-tag

Name of the EIGRP instance. The instance-tag can be any case-sensitive, alphanumeric string up to 20 characters.

seconds

Hello interval (in seconds). The range is from 1 to 65535.


Command Default

5 seconds

Command Modes

Command HistoryInterface configuration mode

Release
Modification

5.0(3)N1(1)

This command was introduced.


Usage Guidelines

This command requires the LAN Base Services license.

Examples

This example shows how to set the hello interval to 10 seconds for the interface:

switch(config)# router eigrp 1
switch(config-router)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip hello-interval eigrp 1 10
switch(config-if)# 
 
   

Related Commands

Command
Description

copy running-config startup-config

Saves the configuration changes to the startup configuration file.

show ip eigrp

Displays EIGRP information.


ip hold-time eigrp

To configure the hold time for an Enhanced Interior Gateway Routing Protocol (EIGRP) interface, use the ip hold-time eigrp command. To restore the default, use the no form of this command.

ip hold-time eigrp instance-tag seconds

no ip hold-time eigrp instance-tag

Syntax Description

instance-tag

Name of the EIGRP instance. The instance-tag can be any case-sensitive, alphanumeric string up to 20 characters.

seconds

Hold time (in seconds). The range is from 1 to 65535.


Command Default

15 seconds

Command Modes

Command HistoryInterface configuration mode

Release
Modification

5.0(3)N1(1)

This command was introduced.


Usage Guidelines

Use the ip hold-time eigrp command to increase the default hold time on very congested and large networks.

We recommend that you configure the hold time to be at least three times the hello interval. If a router does not receive a hello packet within the specified hold time, routes through this router are considered unavailable.

Increasing the hold time delays route convergence across the network.

This command requires the LAN Base Services license.

Examples

This example shows how to set the hold time to 40 seconds for the interface:

switch(config)# router eigrp 209 
switch(config-router)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip hold-time eigrp 209 40
 
   

Related Commands

Command
Description

copy running-config startup-config

Saves the configuration changes to the startup configuration file.

ip hello-interval eigrp

Configures the hello interval on an interface for the EIGRP routing process designated by an autonomous system number.

show ip eigrp

Displays EIGRP information.


ip next-hop-self eigrp

To instruct the Enhanced Interior Gateway Routing Protocol (EIGRP) process to use the local IP address as the next-hop address when advertising these routes, use the ip next-hop-self eigrp command. To use the received next-hop value, use the no form of this command.

ip next-hop-self eigrp instance-tag

no ip next-hop-self eigrp instance-tag

Syntax Description

instance-tag

Name of the EIGRP instance. The instance-tag can be any case-sensitive, alphanumeric string up to 20 characters.


Command Default

EIGRP always sets the IP next-hop value to be itself.

Command Modes

Command HistoryInterface configuration mode

Release
Modification

5.0(3)N1(1)

This command was introduced.


Usage Guidelines

EIGRP, by default, sets the IP next-hop value to be itself for routes that it is advertising, even when advertising those routes on the same interface from which the router learned them. To change this default, you must use the no ip next-hop-self eigrp command to instruct EIGRP to use the received next-hop value when advertising these routes.

Examples

This example shows how to change the default IP next-hop value and instruct EIGRP to use the received next-hop value:

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# no ip next-hop-self eigrp 209
 
   

Related Commands

Command
Description

copy running-config startup-config

Saves the configuration changes to the startup configuration file.

show ip eigrp

Displays EIGRP information.


ip offset-list eigrp

To configure an offset list for the Enhanced Interior Gateway Routing Protocol (EIGRP) on an interface, use the ip offset-list eigrp command. To restore the default, use the no form of this command.

ip offset-list eigrp instance-tag {prefix-list list-name | route-map map-name} {in | out} offset

no ip offset-list eigrp instance-tag {prefix-list list-name | route-map map-name} {in | out} offset

Syntax Description

instance-tag

Name of the EIGRP instance. The instance-tag can be any case-sensitive, alphanumeric string up to 20 characters.

prefix-list list-name

Specifies the name of an IP prefix list to filter EIGRP routes.

route-map map-name

Specifies the name of a route map to filter EIGRP routes.

in

Applies the route policy to incoming routes.

out

Applies the route policy to outgoing routes.

offset

Value to add to the EIGRP metric. The range is from 0 to 2147483647.


Command Default

None

Command Modes

Command HistoryInterface configuration mode

Release
Modification

5.0(3)N1(1)

This command was introduced.


Usage Guidelines

Cisco NX-OS adds the configured offset value to any routes that match the configure prefix list or route map. You must configure the named route map or prefix list to complete this configuration.

This command requires the LAN Base Services license.

Examples

This example shows how to configure an offset list filter to add 20 to the metric for EIGRP routes coming into the interface that match the route map OffsetFilter:

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip offset-list eigrp 209 route-map OffsetFilter in 20
switch(config-if)#

Related Commands

Command
Description

prefix-list

Configures a prefix list.

route-map

Configures a route map.

show ip eigrp

Displays EIGRP information.


ip passive-interface eigrp

To suppress all routing updates on an Enhanced Interior Gateway Routing Protocol (EIGRP) interface, use the ip passive-interface eigrp command. To reenable the sending of routing updates, use the no form of this command.

ip passive-interface eigrp instance-tag

no ip passive-interface eigrp instance-tag

Syntax Description

instance-tag

Name of the EIGRP instance. The name can be any case-sensitive, alphanumeric string up to 20 characters.


Command Default

Routing updates are sent on the interface.

Command Modes

Command HistoryInterface configuration mode

Release
Modification

5.0(3)N1(1)

This command was introduced.


Usage Guidelines

Use the ip passive-interface eigrp command to stop all routing updates on an interface and suppress the formation of EIGRP adjacencies. The network address for the interface remains in the EIGRP topology table.

This command requires the LAN Base Services license.

Examples

This example shows how to stop EIGRP routing updates on ethernet 2/1:

switch(config)# router eigrp 201
switch(config-router)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip passive-interface eigrp 201
switch(config-if)#
 
   

Related Commands

Command
Description

copy running-config startup-config

Saves the configuration in the startup configuration file.

no switchport

Configures an interface as a Layer 3 routed interface.

show ip eigrp interfaces

Displays information about EIGRP interfaces.


ip route

To configure a static route, use the ip route command. To remove the static route, use the no form of this command.

ip route ip-prefix/mask {[interface] next-hop} [preference] [tag id]

no ip route ip-prefix/mask {[interface] next-hop} [preference] [tag id]

Syntax Description

ip-prefix/mask

IP prefix and prefix mask. The format is x.x.x.x/length. The length is 1 to 32.

interface

(Optional) Interface on which all packets are sent to reach this route. Use ? to display a list of supported interfaces.

next-hop

IP address of the next hop that can be used to reach that network. You can specify an IP address and an interface type and interface number. The format is x.x.x.x/length. The length is 1 to 32.

preference

(Optional) Route preference that is used as the administrative distance to this route. The range is from 1 to 255. The default is 1.

tag id

(Optional) Assigns a route tag that can be used to match against in a route map. The range is from 0 to 4294967295. The default is 0.


Command Default

None

Command Modes

Command HistoryGlobal configuration mode

Release
Modification

5.0(3)N1(1)

This command was introduced.


Usage Guidelines

Static routes have a default administrative distance of 1. If you want a dynamic routing protocol to take precidence over a static route, you must configure the static route preference argument to be greater than the administrative distance of the dynamic routing protocol. For example, routes derived with the Enhanced Interior Gateway Routing Protocol (EIGRP) have a default administrative distance of 100. To have a static route that would be overridden by an EIGRP dynamic route, you should specify an administrative distance greater than 100.

Examples

This example shows how to create a static route for destinations with the IP address prefix 192.168.1.1/32, reachable through the next-hop address 10.0.0.2:

switch(config)# ip route 192.168.1.1/32 10.0.0.2
 
   

This example shows how to assign a tag to the previous example so that you can configure a route map that can match on this static route:

switch(config)# ip route 192.168.1.1/32 10.0.0.2 tag 5
 
   

This example shows how to choose a preference of 110. In this case, packets for prefix 10.0.0.0 are routed to a router at 172.31.3.4 if dynamic route information with an administrative distance less than 110 is not available.

switch# configure terminal
switch(config)# ip route 10.0.0.0/8 172.31.3.4 110
switch(config)#
 
   

Related Commands

Command
Description

show vrf

Displays the VRF configuration information.


ip router eigrp

To specify the Enhanced Interior Gateway Routing Protocol (EIGRP) instance for an interface, use the ip router eigrp command. To return to the default, use the no form of this command.

ip router eigrp instance-tag

no ip router eigrp instance-tag

Syntax Description

instance-tag

Name of the EIGRP instance. The instance-tag can be any case-sensitive, alphanumeric string up to 20 characters.


Command Default

None

Command Modes

Command HistoryInterface configuration mode

Release
Modification

5.0(3)N1(1)

This command was introduced.


Usage Guidelines

Before you use this command, make sure that you enable EIGRP on the switch.

This command requires the LAN Base Services license.

Examples

This example shows how to set the EIGRP instance for an interface:

switch(config)# interface ethernet 1/2
switch(config-if)# no switchport
switch(config-if)# ip router eigrp Base 
switch(config-if)#
 
   

Related Commands

Command
Description

copy running-config startup-config

Saves the configuration changes in the startup configuration file.

feature eigrp

Enables EIGRP on the switch.

show ip eigrp interfaces

Displays information about EIGRP interfaces.


ip split-horizon eigrp

To enable split horizon for an Enhanced Interior Gateway Routing Protocol (EIGRP) process, use the ip split-horizon eigrp command. To disable split horizon, use the no form of this command.

ip split-horizon eigrp instance-tag

no ip split-horizon eigrp instance-tag

Syntax Description

instance-tag

Name of the EIGRP instance. The instance-tag can be any case-sensitive, alphanumeric string up to 20 characters.


Command Default

Enabled

Command Modes

Command HistoryInterface configuration mode

Release
Modification

5.0(3)N1(1)

This command was introduced.


Usage Guidelines

Use the no ip split-horizon eigrp command to disable split horizon on an interface.

This command requires the LAN Base Services license.

Examples

This example shows how to disable split horizon an an Ethernet link:

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# no ip split-horizon eigrp 209
switch(config-if)#
 
   

Related Commands

Command
Description

copy running-config startup-config

Saves the configuration changes to the startup configuration file.

show ip eigrp

Displays EIGRP information.


ip summary-address eigrp

To configure a summary aggregate address for the specified Enhanced Interior Gateway Routing Protocol (EIGRP) interface, use the ip summary-address eigrp command. To disable a configuration, use the no form of this command.

ip summary-address eigrp instance-tag {ip-address/length | ip-address mask} [admin-distance | leak-map map-name]

no ip summary-address eigrp instance-tag {ip-address/length | ip-address mask}

Syntax Description

instance-tag

Name of the EIGRP instance. The instance-tag can be any case-sensitive, alphanumeric string up to 20 characters.

ip-address/length

Summary IP prefix and prefix length to apply to an interface in four-part, dotted-decimal notation. For example, /8 indicates that the first eight bits in the IP prefix are network bits. If length is used, the slash is required.

ip-address

Summary IP address to apply to an interface in four-part, dotted-decimal notation.

mask

IP address mask.

admin-distance

(Optional) Administrative distance. The range is from 1 to 255.

leak-map map-name

(Optional) Specifies the leak map.


Command Default

An administrative distance of 5 is applied to EIGRP summary routes.
No summary addresses are predefined.

Command Modes

Command HistoryInterface configuration mode

Release
Modification

5.0(3)N1(1)

This command was introduced.


Usage Guidelines

Use the ip summary-address eigrp command to configure interface-level address summarization. EIGRP summary routes are given an administrative distance of 5.

This command requires the LAN Base Services license.

Examples

This example shows how to configure an administrative distance of 95 on an EIGRP interface for the 192.168.0.0/16 summary address:

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip summary-address eigrp 209 192.168.0.0/16 95
switch(config-if)#

Related Commands

Command
Description

copy running-config startup-config

Saves the configuration changes to the startup configuration file.

show ip eigrp interfaces

Displays EIGRP interface-related information.