Cisco Nexus 1000V Port Profile Configuration Guide, Release 4.2(1) SV1(4)
Verifying the Port Profile Configuration
Downloads: This chapterpdf (PDF - 124.0KB) The complete bookPDF (PDF - 2.04MB) | Feedback

Verifying the Port Profile Configuration

Table Of Contents

Verifying the Port Profile Configuration

Verifying the Port Profile Configuration

Feature History for Port Profile Verification


Verifying the Port Profile Configuration


This chapter describes the commands used to verify port profile configurations and includes the following sections:

Verifying the Port Profile Configuration

Feature History for Port Profile Verification

Verifying the Port Profile Configuration

You can use the following commands to verify the port profile configuration.

Command
Purpose

show port-profile [brief | expand-interface | usage] [name profile-name]

Displays the port profile configuration.

See Example 7-1.

See Example 7-2.

See Example 7-3.

See Example 7-5.

See Example 7-6

show port-profile-role [name port-profile-role-name]

Displays the port profile role configuration, including role names, descriptions, assigned users, and assigned groups.

See Example 7-9.

show running-config port-profile [profile-name]

Displays the port profile configuration.

See Example 7-8.

show port-profile-role users

Displays available users and groups.

See Example 7-10.

show port-profile sync-status [interface if-name]

Displays interfaces that are out of sync with the port profile.

See Example 7-7.

show port-profile virtual usage [name profile-name]

Displays the port profile usage by interface.

See Example 7-4.

show running-config port-profile [prof-name]

Displays the port profile configuration, including interface assignments. See Example 7-8.


For detailed information about the command output, see the Cisco Nexus 1000V Command Reference, Release 4.2(1)SV1(4).

EXAMPLES

Example 7-1 show port-profile

n1000v# show port-profile
port-profile UpLinkProfile1
  description:
  type: vethernet
  status: disabled
  capability l3control: no
  pinning control-vlan: -
  pinning packet-vlan: -
  system vlans: none
  port-group:
  max ports: 32
  inherit:
  config attributes:
    channel-group auto mode on mac-pinning
  evaluated config attributes:
    channel-group auto mode on mac-pinning
  assigned interfaces:
port-profile UpLinkProfile2
  description:
  type: vethernet
  status: disabled
  capability l3control: no
  pinning control-vlan: -
  pinning packet-vlan: -
  system vlans: none
  port-group:
  max ports: 32
  inherit:
  config attributes:
    channel-group auto mode on sub-group cdp
  evaluated config attributes:
    channel-group auto mode on sub-group cdp
  assigned interfaces:
port-profile UpLinkProfile3
  description:
  type: vethernet
  status: disabled
  capability l3control: no
  pinning control-vlan: -
  pinning packet-vlan: -
  system vlans: none
  port-group:
  max ports: 32
  inherit:
  config attributes:
    channel-group auto mode on sub-group manual
  evaluated config attributes:
    channel-group auto mode on sub-group manual
  assigned interfaces:n1000v#

Example 7-2 show port-profile name UpLinkProfile

n1000v# show port-profile name UpLinkProfile3
port-profile UpLinkProfile3
  description:
  type: vethernet
  status: disabled
  capability l3control: no
  pinning control-vlan: -
  pinning packet-vlan: -
  system vlans: none
  port-group:
  max ports: 32
  inherit:
  config attributes:
    channel-group auto mode on sub-group manual
  evaluated config attributes:
    channel-group auto mode on sub-group manual
  assigned interfaces:
n1000v#

Example 7-3 show port-profile brief

n1000v# show port-profile brief
--------------------------------------------------------------------------------
Port                                    Profile  Remote Conf  Eval  Child Child
Profile                                 State    Mgmt   Items Items Intfs Profs
--------------------------------------------------------------------------------
UplinkProfile1                          enabled  vmware     3     3     1     0
UplinkProfile2                          enabled  vmware     3     3     2     0
Ubuntu-Profile                          enabled  vmware     3     3     1     0
n1000v#

Example 7-4 show port-profile virtual usage

n1000v# show port-profile virtual usage
-------------------------------------------------------------------------------
Port Profile               Port        Adapter        Owner
-------------------------------------------------------------------------------
n1kv-uplink0               Po1
                           Eth3/2      vmnic1         localhost.
                           Eth3/3      vmnic2         localhost.
vlan1767                   Veth7       Net Adapter 1  all-tool-7
                           Veth8       Net Adapter 1  all-tool-8
aipc1765                   Veth4       Net Adapter 1  bl-h-s
inband1766                 Veth6       Net Adapter 3  bl-h-s
mgmt1764                   Veth5       Net Adapter 2  bl-h-s
vpc-mac-uplink             Po7
                           Eth5/2      vmnic1         localhost.
                           Eth5/3      vmnic2         localhost.
ch-vpc-mac-uplink          Po2
                           Po3
                           Eth4/2      vmnic1         VDANIKLNCOS
                           Eth4/3      vmnic2         VDANIKLNCOS
ch-aipc1765                Veth1       Net Adapter 1  bl-h-p
ch-mgmt1764                Veth2       Net Adapter 2  bl-h-p
ch-inband1766              Veth3       Net Adapter 3  bl-h-p
n1000v#

Example 7-5 show port-profile expand-interface name UplinkProfile1

n1000v# show port-profile expand-interface name UplinkProfile1
port-profile UplinkProfile1
Ethernet2/2
    switchport mode trunk
    switchport trunk allowed vlan 110-119
    no shutdown
n1000v#

Example 7-6 show port-profile expand-interface

n1000v# show port-profile expand-interface
port-profile UplinkProfile1
Ethernet2/2
    switchport mode trunk
    switchport trunk allowed vlan 110-119
    no shutdown
 
   
port-profile UplinkProfile2
Ethernet2/3
    switchport mode trunk
    switchport trunk allowed vlan 117
    no shutdown
Ethernet2/4
    switchport mode trunk
    switchport trunk allowed vlan 117
    no shutdown
 
   
port-profile Ubuntu-Profile
Vethernet439
    switchport mode access
    switchport access vlan 118
    no shutdown
n1000v#

Example 7-7 show port-profile sync-status

n1000v# show port-profile sync-status interface ethernet 3/2

Ethernet3/2

port-profile: uplink

interface status: quarantine

sync status: out of sync

cached commands:

errors:

command cache overrun

recovery steps:

bring interface online

n1000v#

Example 7-8 show running-config port-profile

n1000v# show running-config port-profile
port-profile type ethernet UplinkProfile1
  description "Profile for critical system ports"
  vmware port-group
  switchport mode access
  switchport access vlan 113
  switchport trunk native vlan 113
  channel-group auto mode on
  no shutdown
port-profile type vethernet UplinkProfile2
  vmware port-group
  vmware max-ports 5
  switchport mode trunk
  switchport trunk native vlan 112
  channel-group auto mode on sub-group cdp
  no shutdown
n1000v#

Example 7-9 show port-profile-role

n1000v# show port-profile-role name adminUser

 
   
Name: adminUser
Description: adminOnly
Users:
    hdbaar (user)
Assigned port-profiles:
    allaccess2
n1000v# 

Example 7-10 show port-profile-role users

switch# show port-profile-role users

Groups:

Administrators

TestGroupB

Users:

dbaar

fgreen

suchen

mariofr

switch#

Feature History for Port Profile Verification

This section provides the feature history for port profile verification.

Feature Name
Releases
Feature Information

show port-profile-role users

4.2(1)SV1(4)

This command output shows the available users and groups.

show port-profile-role

4.2(1)SV1(4)

This command output shows the configuration for port profile roles.

show running-config port-profile

4.0(4)SV1(2)

This command output shows the configuration for port profiles.

show running-config command

4.0(4)SV1(2)

This command output has the following changes:

Shows the port profile type (Ethernet or vEthernet).

Optionally, you can display running configurations for all port profiles or a specific port profile.

show port-profile name command

4.0(4)SV1(2)

This command output shows the port profile type, pinning, and channel-group configuration. The uplink capability is removed from the output of this command since port profiles used as uplinks are now configured as Ethernet type instead.

Port Profile verification

4.0(4)SV1(1)

This feature was introduced.