Cisco Nexus Virtual Services Appliance Software Installation and Upgrade Guide, Release 4.2(1)SP1(5.1)
Installing Cisco Nexus Virtual Services Appliance
Downloads: This chapterpdf (PDF - 792.0KB) The complete bookPDF (PDF - 930.0KB) | Feedback

Table of Contents

Cisco Nexus Virtual Services Appliance Software Installation

Information About Software Install

Prerequisites

Guidelines and Limitations

Cisco Host Upgrade Utility Information

Verifying the CIMC Software Version

Gathering Information About the Management Software

Administrator Credentials

HA Redundancy Role

HA Redundancy States

Domain ID

Network Uplinks

VLANs

Management VLAN

Control VLAN

Setting up the Primary Cisco Nexus Virtual Services Appliance

Setting up the Secondary Cisco Nexus Virtual Services Appliance

Example for Network Uplink Configuration

Verifying the Cisco Nexus Virtual Services Appliance Configuration

Getting Started With Cisco Nexus Virtual Services Appliance

Feature History for Software Installation

Cisco Nexus Virtual Services Appliance Software Installation

This chapter describes how to install the Cisco Nexus Virtual Services Appliance software, and includes the following sections:


NoteFor information about upgrading Cisco Nexus 1000V software on a VSB, see theCisco Nexus 1000V Software Installation and Upgrade Guide, Release 4.2(1)SV1(5.2).


For an overview of the Cisco Nexus Virtual Services Appliance product family and procedures for configuring the software after it is installed, see the Cisco Nexus Virtual Services Appliance Software Configuration Guide, Release 4.2(1)SP1(5.1) .

Information About Software Install

Cisco Nexus Virtual Services Appliance software is pre installed as an ISO image. Use this procedure to install the Cisco Nexus Virtual Services Appliance software. The installation involves the following steps:


Step 1 Verify that you have the correct Cisco Integrated Management Controller (CIMC) software installed. See Verifying the CIMC Software Version.

Step 2 Gather information about Management Software. See Gathering Information About the Management Software.

Step 3 Set up primary Cisco Nexus 1010 or Cisco Nexus 1010-X. See Setting up the Primary Cisco Nexus Virtual Services Appliance

Step 4 Set up the secondary Cisco Nexus 1010 or Cisco Nexus 1010-X. See Setting up the Secondary Cisco Nexus Virtual Services Appliance.

Prerequisites

Before installing Cisco Nexus Virtual Services Appliance Release 4.2(1)SP1(5.1), you must know or do the following:

  • You must have the latest firmware release.

NoteIt is a recommended Cisco best practice to upgrade the firmware using the Cisco Host Upgrade Utility. Failing to do so might result in network setup failure and/or system reboots. When using the HUU upgrade menu, choose the option to upgrade the CIMC, BIOS, and all other components of the hardware. For information on the Cisco Host Upgrade Utility, seeCisco Host Upgrade Utility Information.


  • You must have the following Cisco Integrated Management Controller (CIMC) software installed:

Version 1.4(3s)4 for the Cisco Nexus 1010 product family.


Note • For firmware releases prior to version 1.4(3), the Cisco Host Upgrade Utility does not support Cisco Nexus 1010 and Cisco Nexus 1010-X. In such cases, use the Cisco Nexus Virtual Services Appliance CIMC GUI to manually update to CIMC version 1.4(3), and then use the Cisco Host Upgrade Utility to upgrade to firmware version 1.4(3s)4.

Upgrade to the latest CIMC version using the manual procedure in the Cisco UCS C-Series Servers Integrated Management Controller CLI Configuration Guide, Release 1.4.

Upgrade the BIOS firmware version using the manual procedure in the Cisco UCS C-Series Rack-Mount Server BIOS Upgrade Guide.

Guidelines and Limitations

Follow these guidelines and limitations when setting up the Cisco Nexus Virtual Services Appliance product family:

  • The domain ID must be unique within the VLAN.
  • If other Cisco Nexus Virtual Services Appliances or Cisco Nexus 1000Vs are in the same VLAN, then the domain ID must also be unique across all of them.
  • When setting up the software, you configure the uplink type for your system. Once you configure an uplink type, the only way to modify it is to reload the software.
  • The HA standalone role is not supported for the Cisco Nexus Virtual Services Appliance.
  • Cisco Nexus Virtual Services Appliance is not supported in the non HA mode.
  • It is a recommended Cisco best practice to configure a primary Cisco Nexus Virtual Services Appliance with a secondary backup. Although you can configure a primary Cisco Nexus Virtual Services Appliance without a secondary backup, this configuration in a production environment is not supported.
  • It is recommended to configure the same domain ID, uplink type, control VLAN, management VLAN, control uplink, management uplink for both primary and secondary Cisco Nexus Virtual Services Appliances.
  • The pairing of the Cisco Nexus Virtual Services Appliance must match the hardware platform.You cannot pair a Cisco Nexus 1010 with Cisco Nexus 1010-X.

Cisco Host Upgrade Utility Information

The Cisco Host Upgrade Utility (HUU) is a tool that you can use to upgrade the firmware on one or multiple Cisco UCS C-Series servers. The HUU detects the current version of the following components you have already installed, and guides you to upgrade them to the latest version:

  • Cisco Integrated Management Controller (CIMC)
  • System BIOS
  • LAN on motherboard (LOM)
  • RAID controllers
  • Cisco UCS P81E Virtual Interface Card (VIC)
  • Cisco UCS VIC 1225
  • Cisco UCS VIC 1225-T
  • Network adapters

You can obtain information about the minimum required version of the Cisco HUU, and how to download the HUU iso from the following sources:

You must use the instructions provided in the HUU documentation to upgrade the firmware before you install the Cisco Nexus Virtual Services Appliance 4.2(1)SP1(5.1).


Caution You must ensure to use the appropriate HUU version to upgrade your firmware.

Verifying the CIMC Software Version

Use this procedure to verify that you have CIMC software Version 1.2.1(b) or higher installed on your Cisco Nexus Virtual Services Appliance.

BEFORE YOU BEGIN

Before beginning this procedure, you must know or do the following:

  • You must have CIMC software Version 1.2.1(b) or higher installed.
  • If CIMC software Version 1.2.1(b) or higher is installed, you will see the product ID N1K-C1010 on Cisco Nexus 1010 or the product ID N1K-C1010-X on Cisco Nexus 1010-X in the output of the show hardware command. This procedure includes steps for this verification.
  • You are logged in to the Cisco Nexus Virtual Services Appliance from the CLI or a Web browser.

Step 1 From the Cisco Nexus Virtual Services Appliance do one of the following to display the product ID (PID):

  • From the CLI, view the output of the show hardware command.
    Look in the Switch Hardware ID information for the PID.
  • From a WEB browser, open the Server Summary window and view the server properties. See Figure 2-1 for an example.
Example:
switch# show hardware
unset
Software
loader: version unset
kickstart: version unset
system: version unset
kickstart image file is: unset
kickstart compile time: unset [unset]
system image file is: unset
system compile time: unset [unset]
 
 
Hardware
cisco unset ("unset")
unset with unset unset of memory.
Processor Board ID unset
 
Device name: unset
bootflash: unset kB
Disk Storage capacity for VM virtual disks: 345945 MB
Number of physical 1Gbps ethernet ports: 6
Number of CPU Cores: 16
CPU Cores details:
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
 
 
Kernel uptime is unset day(s), unset hour(s), unset minute(s), unset second(s)
 
 
plugin
Core Plugin, Ethernet Plugin, Virtualization Plugin
--------------------------------
Switch hardware ID information
--------------------------------
 
Switch is booted up
Switch type is : Nexus 1110-S (Virtual Services Appliance) 2 slot Chassis
Model number is Nexus 1110-S
PID-VID-SN: N1K-C1110-S-2.0-1846886525134693056
 
--------------------------------
Chassis has 2 Module slots
--------------------------------
 
Module1 ok
Module type is : Cisco Virtual Services Appliance
0 submodules are present
Model number is Nexus 1110-S
H/W version is 2.0
UUID is 0F823778-D54A-4970-E999-2077C67F0133
Manufacture date is 02/22/2012
Serial number is
 
Module2 ok
Module type is : Cisco Virtual Services Appliance
0 submodules are present
Model number is Nexus 1110-S
H/W version is 2.0
UUID is 68143FE5-207B-4989-F297-0937998C9424
Manufacture date is 02/22/2012
Serial number is QCI1410A4LP
 

Figure 2-1 CIMC Window with Product ID (PID)

 

 

Step 2 Do one of the following:

  • If the PID displayed is N1K-C1010 on Cisco Nexus 1010 or N1K-C1010-X on Cisco Nexus 1010-X, you can proceed with the install or upgrade to Cisco Nexus Virtual Services Appliance Release 4.2(1)SP1(5.1).
  • If the PID displayed is not N1K-C1010 on Cisco Nexus 1010 or N1K-C1010-X on Cisco Nexus 1010-X, do not install or upgrade to Release 4.2(1)SP1(5.1). Instead you must replace the Cisco Nexus Virtual Services Appliance using the RMA process. See Replacing a Cisco Nexus Virtual Services Appliance.

Gathering Information About the Management Software

Before you begin the installation, you will need the following information for your Cisco Nexus Virtual Services Appliance:

Administrator Credentials

When you set up the system software, you are required to create an administrator password. Table 2-1 lists password strength guidelines:

 

Table 2-1 Guidelines for strong passwords

Strong passwords have:
Strong passwords do NOT have:
  • At least eight characters
  • Uppercase letters
  • Lowercase letters
  • Numbers
  • Special characters
  • Consecutive characters, such as “abcd”
  • Repeating characters, such as “aaabbb”
  • Dictionary words
  • Proper names

HA Redundancy Role

The Cisco Nexus Virtual Services Appliance product family is provided in redundant pairs for high availability. When setting up the device, you configure a high availability role—primary or secondary. Table 2-2 describes these roles.


NoteThe HA standalone role is not supported for the Cisco Nexus Virtual Services Appliance product family. Cisco Nexus Virtual Services Appliance is not supported in a non HA mode.


 

Table 2-2 HA Redundancy Roles

Role
Description

Primary

  • The primary role coordinates the active/standby redundancy state with the secondary Cisco Nexus Virtual Services Appliance.
  • The primary role takes precedence during bootup when negotiating active/standby redundancy state. That is, if the secondary Cisco Nexus Virtual Services Appliance is not in the active state at bootup, the primary Cisco Nexus Virtual Services Appliance takes the active redundancy state.
  • You assign the primary role to the first Cisco Nexus Virtual Services Appliance that you install in a dual system.

Secondary

  • The secondary role coordinates the active/standby state with the primary Cisco Nexus Virtual Services Appliance.
  • You assign the secondary role to the second Cisco Nexus Virtual Services Appliance that you install in a dual system.

HA Redundancy States

Table 2-3 describes the HA redundancy states.

 

Table 2-3 HA Redundancy States

Redundancy State
Description

Active

Controls the system and is visible to the outside world.

The active system is remotely accessed through the network after initial setup.

The user interface for managing the Cisco Nexus Virtual Services Appliance is only available through the active system.

Standby

Synchronizes its configuration with that of the active Cisco Nexus Virtual Services Appliance so that it is continuously ready to take over in case of a failure or manual switchover.

You cannot use Telnet or Secure Shell (SSH) protocols to communicate with the standby Cisco Nexus Virtual Services Appliance.

The standby Cisco Nexus Virtual Services Appliance is not network addressable and is accessed through the serial port.

The user interface for managing the Cisco Nexus Virtual Services Appliance is not available through the standby system.

Domain ID

The primary and secondary Cisco Nexus Virtual Services Appliances use the domain ID to identify each other. The Cisco Nexus Virtual Services Appliances must be in the same switching domain, and share the same management IP address.

Network Uplinks

Cisco Nexus Virtual Services Appliance product family supports two types of network uplink configurations to connect to the network.

  • Flexible Network Uplink: Flexible network configuration offers complete flexibility to connect the Cisco Nexus Virtual Services Appliance product family to the network and allows you to achieve a maximum of six uplinks.
  • Static Network Uplink :In a static network configuration, the Cisco Nexus Virtual Services Appliance product family is connected to the network using four fixed network uplink configurations. See Network Uplink Types.

As a result you can connect your system to the network using one of the following five supported uplink types.

  • One uplink
  • Two uplinks with common management and control traffic
  • Two uplinks with common control and data traffic
  • Three uplinks
  • Flexible network uplink

Note Once you configure an uplink type, the only way to modify it is to reload the software.


See the Cisco Nexus Virtual Services Appliance Software Configuration Guide, Release 4.2(1)SP1(5.1) for more information about network uplink types.

During the installation of Cisco Nexus Virtual Services Appliance product family you can setup the flexible network uplink type or the static network uplink uplink type. If you modify the uplink type, a reload is required each time the uplink type is modified for it to take effect.

See the Cisco Nexus Virtual Services Appliance Software Configuration Guide, Release 4.2(1)SP1(5.1) for information about migrating the network uplink types.

Table 2-4 Table 2-4 shows the four supported network uplink types and the ports that carry each type of VLAN traffic.

Table 2-4 Network Uplink Types

Uplink type
Management VLAN
Control VLAN
Data VLAN

1

ports 1 and 2

ports 1 and 2

ports 1 and 2

2

ports 1 and 2

ports 1 and 2

ports 3-6

3

ports 1-2

ports 3-6

ports 3-6

4

ports 1-2

ports 3-4

ports 5-6

Flexible

There is no traffic segregation based on traffic class

VLANs

Control, and management VLANs are used by the Cisco Nexus Virtual Services Appliance product family for management and communication with its virtual service blades. These VLANs are added as a part of the initial setup of the management software. Control and packet VLANs are also added to each virtual service blade when it is created. The management VLAN is inherited from the Cisco Nexus Virtual Services Appliance product family by each virtual service blade.

If you modify a control, packet, or management VLAN on the Cisco Nexus Virtual Services Appliance product family , the change is effective immediately. A reload is required to effect the change of control and management VLAN on Cisco Nexus Virtual Services Appliance. However, for service continuity, you must configure the same control and packet VLANs on the hosted VSMs. Otherwise the Cisco Nexus Virtual Services Appliance loses communication with its VSMs.

This section includes the following additional topics:

Management VLAN

The management VLAN is the VLAN that forwards traffic for the management port of the Cisco Nexus Virtual Services Appliance. If your virtual service blade uses the management class of traffic, it inherits the management VLAN from the Cisco Nexus Virtual Services Appliance.

The management VLAN is used by the outside world to reach the Cisco Nexus Virtual Services Appliance management 0 interface.

The Cisco Nexus Virtual Services Appliance and its hosted Cisco Nexus 1000 VSMs share the same management VLAN in static topology. Unlike the control and packet VLANs which are set when a VSB is created, the management VLAN is inherited. In a static topology, the management VLAN on a VSB cannot be changed. Since the management VLAN is inherited from the Cisco Nexus Virtual Services Appliance, if you change management VLAN for Cisco Nexus Virtual Services Appliance, then the change is applied to both the Cisco Nexus Virtual Services Appliance and all of its hosted Cisco Nexus 1000 VSMs in next reload.

However, this constraint does not exist in flexible topology and the management VLAN of a VSB can be different from the Cisco Nexus Virtual Services Appliance host.

Control VLAN

The control VLAN is a Layer 2 interface used for communication between the redundant Cisco Nexus Virtual Services Appliances. This interface handles low-level control packets such as heartbeats as well as any configuration data that needs to be exchanged between the Cisco Nexus 1010s.

Setting up the Primary Cisco Nexus Virtual Services Appliance

You can use this procedure to set up the management software for the following:

  • The primary Cisco Nexus Virtual Services Appliance in a redundant HA pair

It is a recommended Cisco best practice to configure a primary Cisco Nexus Virtual Services Appliance with a secondary backup. Although you can configure a primary Cisco Nexus Virtual Services Appliance without a secondary backup, this configuration in a production environment is not supported.

BEFORE YOU BEGIN

  • You have the following information available for this Cisco Nexus Virtual Services Appliance:

Administrator password

HA role (primary or secondary)
If you do not specify an HA role, then the role is configured as primary.

Network uplink type

Control VLAN ID

Domain ID

Management VLAN ID

Management 0 IP address
This is the IP address of the management interface that appears as the mgmt0 port on the appliance.

Default gateway IP address

SSH service key type and number of key bits

DETAILED STEPS


Step 1 Use one of the following methods to log in to the Cisco Nexus Virtual Services Appliance.

The setup wizard starts automatically.

  • Login from a terminal server:
Example:
telnet 172.25.182.99 2005
Trying 172.25.182.99...
Connected to 172.25.182.99.
Escape character is '^]'
switch#
 
---- System Admin Account Setup ----
Enter the password for "admin":
Confirm the password for "admin":
 
  • Login from a serial over LAN connection through CIMC:
Example:
ssh admin@172.25.182.230
admin@172.25.182.230's password:
switch# connect host
CISCO Serial Over LAN:
Close Network Connection to Exit
 
---- System Admin Account Setup ----
Enter the password for "admin":
Confirm the password for "admin":
 

Step 2 When asked, enter and confirm the Administrator password.

Example:

---- System Admin Account Setup ----
Enter the password for "admin":
Confirm the password for "admin":

Step 3 When asked, enter the HA role. If you do not specify a role, then primary is assigned.

Example:

Enter HA role[primary/secondary]: primary


Note The HA standalone role is not supported for the Cisco Nexus Virtual Services Appliance product family. Cisco Nexus Virtual Services Appliance is not supported in a non HA mode


Step 4 When asked, enter the uplink type.To specify static network uplink, enter a value from 1-4. To specify flexible network uplink, enter the value 5.


Note Once you configure an uplink type, the only way to modify it is to reload the software.


Example:
Enter network-uplink type <1-5>:
1. Ports 1-2 carry all management, control and data vlans
2. Ports 1-2 management and control, ports 3-6 data
3. Ports 1-2 management, ports 3-6 control and data
4. Ports 1-2 management, ports 3-4 control, ports 5-6 data
5. Flexible
5
 

Step 5 When asked, enter the VLAN ID for the control VLAN.

Example:

Enter control vlan <1-3967, 4048-4093>: 1481
 

Step 6 When asked, enter control uplink.

Example:

Enter control uplink <1-6>: 1
 

Step 7 When asked, enter the domain ID.

Example:

Enter the domain id<1-4095>: 121
 

Step 8 When asked, enter the VLAN ID for the management VLAN.

Example:

Enter management vlan<1-3967,4048-4093>: 1490
 

Step 9 When asked, enter management uplink.

Example:

Enter management uplink <1-6>: 1
 

Step 10 When you have completed this process, the Cisco Nexus Virtual Services Appliance software saves the configuration and automatically reboots to configure the network uplinks.

The new configuration is saved into nonvolatile storage, after which the running and the startup copies of the configuration are identical.

Saving boot configuration. Please wait...
 
[########################################] 100%
System is going to reboot to configure network uplinks
 

After reboot, the default static or flexible topology will be configured. See Figure 2-2 for default flexible network uplink configuration. For more information, see the Cisco Nexus Virtual Services Appliance Software Configuration Guide, Release 4.2(1)SP1(5.1) .

Figure 2-2 Default Flexible Network Uplink Configuration without vPC /VSS

 
 

Figure 2-3 Default Flexible Network Uplink Configuration with vPC /VSS

Step 11 When asked if you want to enter the basic configuration dialog, respond yes .

Example:
Would you like to enter the basic configuration dialog (yes/no): yes
 
---- Basic System Configuration Dialog ----
 
This setup utility will guide you through the basic configuration of
the system. Setup configures only enough connectivity for management
of the system.
 
*Note: setup is mainly used for configuring the system initially,
when no configuration is present. So setup always assumes system
defaults and not the current system configuration values.
 
Press Enter at anytime to skip a dialog. Use ctrl-c at anytime
to skip the remaining dialogs.
 

Step 12 When asked to create another Login account, answer no .

Example:

Create another login account (yes/no) [n]: no
 

Step 13 When asked to configure a read-only SNMP community string, answer no .

Example:

Configure read-only SNMP community string (yes/no) [n]: no
 

Step 14 When asked to configure a read-write SNMP community string, answer no .

Example:
Configure read-write SNMP community string (yes/no) [n]:
 

Step 15 Enter a name for the appliance.

Example:
Enter the VSA name : N1010
 

Step 16 When asked to configure out-of-band management, answer yes and then enter the management 0 IPv4/IPv6 address.

This is the IP address of the management interface that appears as the mgmt0 port on the appliance.

Example:
Continue with Out-of-band (mgmt0) management configuration? [yes/no] [y]: yes
Mgmt0 IP address type V4/V6? (V4): V4
Mgmt0 IPv4 address: 45.45.45.3
Mgmt0 IPv4 netmask :255.255.255.0

 

Step 17 When asked to configure the default gateway, answer yes .

Example:
Configure the default-gateway: (yes/no) [y]: yes
IPv4 address of the default gateway: 45.45.45.1
 

Step 18 When asked to configure advanced IP options, answer no .

Example:
Configure Advanced IP options (yes/no)? [n]: no
 

Step 19 When asked to enable the Telnet service, answer no .

Example:
Enable the telnet service? (yes/no) [y]: no
 

Step 20 When asked to enable the SSH service, answer yes and then enter the key type and number of key bits.

Example:
Enable the ssh service? (yes/no) [y]: yes
Type of ssh key you would like to generate (dsa/rsa) : rsa
Number of key bits <768-2048> : 1024
 

Step 21 When asked to enable the HTTP server, answer yes

Step 22 When asked to configure the NTP server, answer no .

The configuration is summarized.

Example:
Configure NTP server? (yes/no) [n]: no
The following configuration will be applied:
interface mgmt0
ip address 45.45.45.3 255.255.255.0
no shutdown
vrf context management
ip route 0.0.0.0/0 45.45.45.1
no telnet server enable
ssh key rsa 1024 force
ssh server enable
feature http-server

Step 23 Do one of the following:

  • If you do not want to edit the configuration answer no and continue with the next step.
  • If you want to edit the configuration, answer yes and return to Step 12 to revisit each command.
Example:
Would you like to edit the configuration? (yes/no) [n]:no
 

Step 24 When asked to use and save this configuration, answer yes .


Caution If you do not save the configuration now, then none of your changes are part of the configuration the next time the switch is rebooted. Enter yes to save the new configuration. This ensures that the kickstart and system images are also automatically configured.

Example:
Use this configuration and save it? (yes/no) [y]: yes
[########################################] 100%
 

The new configuration is saved into nonvolatile storage, after which the running and the startup copies of the configuration are identical.


Note You can use the setup routine to update the configuration done in Step 12 through Step 24 at any time by entering the setup command in EXEC mode. Once setup begins, press Enter to skip a command. Use ctrl-c to skip the remaining commands.


Step 25 You have completed this procedure. You can verify the configuration using the following command:

show running configuration

N1010# sh run
 
!Command: show running-config
!Time: Thu Feb 27 02:57:25 2014
 
version 4.2(1)SP1(5.1)
no feature telnet
 
username admin password 5 $1$BzSSk6qR$m.FMEvkOXzutuLwrmVeUe/ role network-admin
 
banner motd #Cisco VSA#
 
ip domain-lookup
ip domain-lookup
hostname N1010
snmp-server user admin network-admin auth md5 0xb64ad6879970f0e57600c443287a79f0
priv 0xb64ad6879970f0e57600c443287a79f0 localizedkey
 
vrf context management
ip route 0.0.0.0/0 45.45.45.1
vlan 1,1481,1490
port-channel load-balance ethernet source-mac
port-profile default max-ports 32
 
vdc N1010 id 1
limit-resource vlan minimum 16 maximum 2049
limit-resource monitor-session minimum 0 maximum 2
limit-resource vrf minimum 16 maximum 8192
limit-resource port-channel minimum 0 maximum 768
limit-resource u4route-mem minimum 32 maximum 32
limit-resource u6route-mem minimum 16 maximum 16
limit-resource m4route-mem minimum 58 maximum 58
limit-resource m6route-mem minimum 8 maximum 8
network-uplink type 5
interface GigabitEthernet1
interface GigabitEthernet2
interface GigabitEthernet3
interface GigabitEthernet4
interface GigabitEthernet5
interface GigabitEthernet6
svs-domain
control uplink GigabitEthernet1
management uplink GigabitEthernet1
 
 
interface mgmt0
ip address 45.45.45.3/24
 
interface control0
line console
svs-domain
domain id 121
control vlan 1481
management vlan 1490
svs mode L2
N1010
 


 

Setting up the Secondary Cisco Nexus Virtual Services Appliance

You can use this procedure to set up the management software for the secondary Cisco Nexus Virtual Services Appliance in a redundant pair.

It is recommended to configure the same domain ID, uplink type, control VLAN, management VLAN, control uplink, management uplink for both primary and secondary Cisco Nexus Virtual Services Appliances.

DETAILED STEPS


Step 1 When asked, enter and confirm the Administrator password.

Example:

---- System Admin Account Setup ----
Enter the password for "admin":
Confirm the password for "admin":

Step 2 When asked, enter the HA role.

Example:

Enter HA role[primary/secondary]: secondary

 

Step 3 When asked, enter the uplink type.


Note Once you configure an uplink type, the only way to modify it is to reload the software.


Example:
Enter network-uplink type <1-5>:
1. Ports 1-2 carry all management, control and data vlans
2. Ports 1-2 management and control, ports 3-6 data
3. Ports 1-2 management, ports 3-6 control and data
4. Ports 1-2 management, ports 3-4 control, ports 5-6 data
5. Flexible
5

 

Step 4 When asked, enter the VLAN ID for the control VLAN.

Example:

Enter control vlan <1-3967, 4048-4093>: 347
 

Step 5 When asked, enter control uplink type.

Example:

Enter control uplink <1-6>: 1
 

Step 6 When asked, enter the domain ID.

Example:

Enter the domain id<1-4095>: 3477
 

Step 7 When asked, enter the VLAN ID for the management VLAN.

Example:

Enter management vlan<1-3967,4048-4093>: 180
 

Step 8 When asked, enter management uplink type.

Example:

Enter management uplink <1-6>: 2
 

The following things occur on the switch:

  • The new configuration is saved into nonvolatile storage, after which the running and the startup copies of the configuration are identical.
  • The system reboots to configure the network uplinks.
  • The system restarts and synchronizes its configuration with the primary Cisco Nexus 1000V.
Example:
Saving boot configuration. Please wait...
 
[########################################] 100%
 
System is going to reboot to configure network uplinks
HA mode set to secondary. Rebooting now...
 

Step 9 You have completed this procedure. You can verify the configuration using the following command:

show running configuration .

Example for Network Uplink Configuration

The following example shows how to configure flexible network uplink configuration during installation:

---- System Admin Account Setup ----
Enter the password for "admin":
Confirm the password for "admin":
Enter HA role[primary/secondary]: secondary
_
Enter network-uplink type <1-5>:
1. Ports 1-2 carry all management, control and data vlans
2. Ports 1-2 management and control, ports 3-6 data
3. Ports 1-2 management, ports 3-6 control and data
4. Ports 1-2 management, ports 3-4 control, ports 5-6 data
5. Flexible
5
_
Enter control vlan <1-3967, 4048-4093>: 347
Enter control uplink <1-6>: 1
_
Enter the domain id<1-4095>: 3477
_
Enter management vlan <1-3967, 4048-4093>: 180
Enter management uplink <1-6>: 2
_
Saving boot configuration. Please wait...
[########################################] 100%
System is going to reboot to configure network uplinks

 

The following example shows how to configure static network uplink configuration during installation:

---- System Admin Account Setup ----
Enter the password for "admin":
Confirm the password for "admin":
Enter HA role[primary/secondary]: secondary
_
Enter network-uplink type <1-5>:
1. Ports 1-2 carry all management, control and data vlans
2. Ports 1-2 management and control, ports 3-6 data
3. Ports 1-2 management, ports 3-6 control and data
4. Ports 1-2 management, ports 3-4 control, ports 5-6 data
5. Flexible
1
_
Enter control vlan <1-3967, 4048-4093>: 300
_
Enter the domain id<1-4095>: 300
_
Enter management vlan <1-3967, 4048-4093>: 233
_
Saving boot configuration. Please wait...
[########################################] 100%
System is going to reboot to configure network uplinks

 

Verifying the Cisco Nexus Virtual Services Appliance Configuration

To verify the Cisco Nexus Virtual Services Appliance configuration, use the following commands:

 

Command
Purpose

show running-configuration

Displays the Cisco Nexus Virtual Services Appliance running configuration.

See Example 2-1 on page 2-19 .

show system redundancy status

Displays the redundancy state (active or standby) and the redundancy role (primary or secondary) for the Cisco Nexus Virtual Services Appliances.

See Example 2-2 on page 2-21 .

show svs domain

Displays the domain information for the Cisco Nexus Virtual Services Appliance:

See Example 2-3 on page 2-21 .

show network cdp neighbors

Displays uplink connectivity for the active or standby Cisco Nexus Virtual Services Appliance.

See Example 2-4 on page 2-21 .

Example 2-1 Setup Configuration

This example shows how to display and verify the Cisco Nexus Virtual Services Appliance setup configuration:

show running-config
!Command: show running-config
!Time: Mon Sep 10 21:31:34 2012
 
version 4.2(1)SP1(5.1)
feature telnet
 
username admin password 5 $1$8oEF.umL$mRRZTm3.sWL2ED5KZydz61 role network-admin
 
banner motd #Cisco VSA#
 
ip domain-lookup
ip domain-lookup
hostname N1110-S
snmp-server user admin network-admin auth md5 0xb64ad6879970f0e57600c443287a79f0 priv 0xb64ad6879970f0e57600c443287a79f0 localizedkey
snmp-server community public group network-admin
 
vrf context management
ip route 0.0.0.0/0 10.78.109.97
vlan 1,1352,1360
port-channel load-balance ethernet source-mac
port-profile default max-ports 32
 
vdc N1110-S id 1
limit-resource vlan minimum 16 maximum 2049
limit-resource monitor-session minimum 0 maximum 2
limit-resource vrf minimum 16 maximum 8192
limit-resource port-channel minimum 0 maximum 768
limit-resource u4route-mem minimum 32 maximum 32
limit-resource u6route-mem minimum 16 maximum 16
limit-resource m4route-mem minimum 58 maximum 58
limit-resource m6route-mem minimum 8 maximum 8
network-uplink type 4
interface GigabitEthernet1
interface GigabitEthernet2
interface GigabitEthernet3
interface GigabitEthernet4
interface GigabitEthernet5
interface GigabitEthernet6
interface PortChannel1
interface PortChannel2
interface PortChannel3
virtual-service-blade VSM1
virtual-service-blade-type name VSM-1.1
interface control vlan 1361
interface packet vlan 1362
ramsize 2048
disksize 3
numcpu 1
cookie 1555871292
no shutdown
interface VsbEthernet1/1
interface VsbEthernet1/2
interface VsbEthernet1/3
virtual-service-blade NAMC-1
virtual-service-blade-type name NAM-1.1
interface data vlan 1352
ramsize 2048
disksize 53
numcpu 2
cookie 753232953
no shutdown secondary
interface VsbEthernet2/1
virtual-service-blade DCNM61
virtual-service-blade-type name DCNM-VSB-6.1
interface eth1 vlan 0
ramsize 8192
disksize 80
numcpu 2
cookie 969732378
no shutdown primary
interface VsbEthernet3/1
virtual-service-blade VSG12
virtual-service-blade-type name VSG-1.2
interface data vlan 1365
interface ha vlan 1364
ramsize 2048
disksize 3
numcpu 1
cookie 2051820775
no shutdown primary
no shutdown secondary
interface VsbEthernet4/1
interface VsbEthernet4/2
interface VsbEthernet4/3
virtual-service-blade VSM-OVA
virtual-service-blade-type name VSM-1.2
interface control vlan 1364
interface packet vlan 1366
ramsize 2048
disksize 3
numcpu 1
cookie 448734513
no shutdown primary
no shutdown secondary
interface VsbEthernet5/1
interface VsbEthernet5/2
interface VsbEthernet5/3
virtual-service-blade VSG-OVA
virtual-service-blade-type name VSG-1.2
interface data vlan 1356
interface ha vlan 1355
ramsize 2048
disksize 3
numcpu 1
cookie 2105102293
no shutdown
interface VsbEthernet6/1
interface VsbEthernet6/2
interface VsbEthernet6/3
 
 
interface mgmt0
ip address 10.78.109.100/28
 
interface control0
line console
boot kickstart bootflash:/nexus-1010-kickstart-mz.4.2.1.SP1.5.1.bin
boot system bootflash:/nexus-1010-mz.4.2.1.SP1.5.1.bin
boot kickstart bootflash:/nexus-1010-kickstart-mz.4.2.1.SP1.5.1.bin
boot system bootflash:/nexus-1010-mz.4.2.1.SP1.5.1.bin
svs-domain
domain id 2222
control vlan 1360
management vlan 1352
svs mode L2
 

Example 2-2 Redundancy Status

switch# show system redundancy status
Redundancy role
---------------
administrative: primary
operational: primary
Redundancy mode
---------------
administrative: HA
operational: None
This supervisor (sup-1)
-----------------------
Redundancy state: Active
Supervisor state: Active
Internal state: Active with no standby
Other supervisor (sup-2)
------------------------
Redundancy state: Not present
---- ----
switch#
 

Example 2-3 Domain

switch# show svs domain
SVS domain config:
Domain id: 3555
Control vlan: 305
Management vlan: 233
L2/L3 Control mode: L2
L3 control interface: NA
Status: Config not pushed to VC.
switch#

Example 2-4 CDP neighbors (standby)

switch# show network cdp neighbors
….
Device-ID Local Intrfce Hldtme Capability Platform Port ID
 
sfish-cat3k-K5-stack2 eth2 166 R T B S I r cisco WS-C375 GigabitEthernet1/0/23
switch#
 

Getting Started With Cisco Nexus Virtual Services Appliance

After you complete the software installation, you can configure the Cisco Nexus Virtual Services Appliance product family. See the Cisco Nexus Virtual Services Appliance Software Configuration Guide, Release 4.2(1)SP1(5.1) for more information

The following are the basic steps in the software configuration process.


Step 1 Configuring port channels for flexible network uplink. Use this procedure to configure port channels after you set up the flexible network uplink type.

Step 2 Setting up remote management. Use this procedure to set up remote management in your startup configuration for use in recovering an unreachable Cisco Nexus Virtual Services Appliance.

Step 3 Do one of the following to add a service blades to the new Cisco Nexus Virtual Services Appliance :

  • Create a new virtual service blade.
  • Migrate an existing VSM from a VM to the Cisco Nexus Virtual Services Appliance.


 

Feature History for Software Installation

This section provides the software installation and upgrade release history.

 

Feature Name
Releases
Feature Information

Flexible Network Uplink

4.2(1)SP1(4)

This feature was introduced.

Cisco Nexus 1010-X

4.2(1)SP1(3)

This hardware was introduced.

Software upgrade

4.2(1)SP1(2)

This feature was introduced.