Cisco Nexus 1000V Interface Configuration Guide, Release 4.0(4)SV1(3)
Configuring Port Channels
Downloads: This chapterpdf (PDF - 398.0KB) The complete bookPDF (PDF - 2.71MB) | Feedback

Configuring Port Channels

Table Of Contents

Configuring Port Channels

Information About Port Channels

Port Channels

Compatibility Checks

Load Balancing Using Port Channels

LACP

Port Channel Modes

LACP ID Parameters

LACP Marker Responders

LACP-Enabled and Static Port Channels Differences

vPC Host Mode

Subgroup Creation Using CDP or Manual Method

Interface Assignment Using Static Pinning

High Availability

Prerequisites for Port Channels

Guidelines and Limitations

Default Settings

Configuring Port Channels

Configuring a Port Channel that Connects to a Single Upstream Switch

Configuring a Port Channel that Connects to Multiple Upstream Switches

Manually Configuring Subgroups

Configuring Static Pinning

Removing the Port Channel and Group

Adding a Layer 2 Port to a Channel Group

Removing a Port from a Channel Group

Shutting Down and Restarting a Port Channel Interface

Configuring a Port Channel Description

Configuring an LACP Port Channel

Configuring the Speed and Duplex Settings for a Port Channel Interface

Configuring Port Channel Load Balancing

Restoring the Default Load-Balancing Method

Verifying the Port Channel Configuration

Monitoring the Port Channel Configuration

Configuration Example for Port Channels

Additional References

Related Documents

Standards

Feature History for Port Channels


Configuring Port Channels


This chapter describes how to configure port channels and includes the following topics:

Information About Port Channels

High Availability

Prerequisites for Port Channels

Guidelines and Limitations

Configuring Port Channels

Verifying the Port Channel Configuration

Monitoring the Port Channel Configuration

Configuration Example for Port Channels

Additional References

Additional References

Feature History for Port Channels

Information About Port Channels

A port channel is an aggregation of multiple physical interfaces that creates a logical interface. You can bundle up to eight individual active links into a port channel to provide increased bandwidth and redundancy. Port channeling also load balances traffic across these physical interfaces. The port channel stays operational as long as at least one physical interface within the port channel is operational.

You can use static port channels, with no associated aggregation protocol, for a simplified configuration.

This section includes the following topics:

Port Channels

Compatibility Checks

Load Balancing Using Port Channels

LACP

vPC Host Mode

Port Channels

A port channel bundles physical links into a channel group to create a single logical link that provides the aggregate bandwidth of up to eight physical links. If a member port within a port channel fails, the traffic previously carried over the failed link switches to the remaining member ports within the port channel.

You can bundle up to eight ports into a static port channel without using any aggregation protocol.


Note The device does not support Port Aggregation Protocol (PAgP) for port channels.


Each port can be in only one port channel. All the ports in a port channel must be compatible; they must use the same speed and duplex mode (see the "Compatibility Checks" section). When you run static port channels with no aggregation protocol, the physical links are all in the on channel mode.

You can create port channels directly by creating the port channel interface, or you can create a channel group that acts to aggregate individual ports into a bundle. When you associate an interface with a channel group, the software creates a matching port channel automatically if the port channel does not already exist. In this instance, the port channel assumes the Layer 2 configuration of the first interface. You can also create the port channel first. In this instance, the Cisco Nexus 1000V creates an empty channel group with the same channel number as the port channel and takes the default Layer 2 configuration, as well as the compatibility configuration (see the "Compatibility Checks" section).


Note The port channel is operationally up when at least one of the member ports is up and is in the channeling state. The port channel is operationally down when all member ports are operationally down.


Compatibility Checks

When you add an interface to a port channel group, the following compatibility checks are made before allowing the interface to participate in the port channel:

Network layer

(Link) speed capability

Speed configuration

Duplex capability

Duplex configuration

Port mode

Access VLAN

Trunk native VLAN

Tagged or untagged

Allowed VLAN list

MTU size

SPAN—cannot be a SPAN source or a destination port

Storm control

To view the full list of compatibility checks performed by the Cisco Nexus 1000V, use the show port-channel compatibility-parameters.

You can only add interfaces configured with the channel mode set to on to static port channels. You can configure these attributes on an individual member port. If you configure a member port with an incompatible attribute, the Cisco Nexus 1000V suspends that port in the port channel.

Alternatively, you can force ports with incompatible parameters to join the port channel if the following parameters are the same:

(Link) speed capability

Speed configuration

Duplex capability

Duplex configuration

When the interface joins a port channel, some of its individual parameters are removed and replaced with the values on the port channel as follows:

Bandwidth

Delay

Extended Authentication Protocol over UDP

VRF

IP address (v4 and v6)

MAC address

Spanning Tree Protocol

NAC

Service policy

Quality of Service (QoS)

Access control lists (ACLs)

The following interface parameters remain unaffected when the interface joins or leaves a port channel:

Description

CDP

MDIX

Rate mode

Shutdown

SNMP trap


Note When you delete the port channel, the software sets all member interfaces as if they were removed from the port channel.


Load Balancing Using Port Channels

The Cisco Nexus 1000V load balances traffic across all operational interfaces in a port channel by hashing the addresses in the frame to a numerical value that selects one of the links in the channel. Port channels provide load balancing by default. Port channel load balancing uses MAC addresses, IP addresses, or Layer 4 port numbers to select the link. Port channel load balancing uses either source or destination addresses or ports, or both source and destination addresses or ports.

You can configure the load balancing mode to apply to all port channels that are configured on the entire device or on specified modules. The per-module configuration takes precedence over the load-balancing configuration for the entire device. You can configure one load balancing mode for the entire device, a different mode for specified modules, and another mode for the other specified modules. You cannot configure the load balancing method per port channel.

You can configure the type of load balancing algorithm used. You can choose the load balancing algorithm that determines which member port to select for egress traffic by looking at the fields in the frame.


Note The default load balancing method uses source MAC addresses.


You can configure one of the following methods to load balance across the port channel:

Destination MAC address

Source MAC address

Source and Destination MAC address

Destination IP address and VLAN

Source IP address and VLAN

Source and destination IP address and VLAN

Destination TCP/UDP port number

Source TCP/UDP port number

Source and destination TCP/UDP port number

Destination IP address and TCP/UDP port number

Source IP address and TCP/UDP port number

Source and destination IP address and TCP/UDP port number

Destination IP address, TCP/UDP port number, and VLAN

Source IP address, TCP/UDP port number, and VLAN

Source and destination IP address, TCP/UDP port number, and VLAN

Destination IP address

Source IP address

Source and Destination IP address

VLAN only

Source Virtual Port ID

When you configure source IP address load balancing, the source MAC address is used to balance the traffic load. When you configure the destination MAC address load balancing method, the traffic load is balanced using the destination MAC address.

The load balancing methods that use port channels do not apply to multicast traffic. Regardless of the method configured, multicast traffic uses the following methods for load balancing with port channels:

Multicast traffic with Layer 4 information—Source IP address, source port, destination IP address, and destination port

Multicast traffic without Layer 4 information—Source IP address and destination IP address

Non-IP multicast traffic—Source MAC address and destination MAC address

To configure port channel load balancing, see the "Configuring Port Channel Load Balancing" procedure.

LACP

Link Aggregation Control Protocol (LACP) lets you configure up to 16 interfaces into a port channel. A maximum of eight interfaces can be active, and a maximum of eight interfaces can be placed in a standby state. Figure 5-1 shows how individual links can be combined into LACP port channels and channel groups as well as function as individual links.

On the Cisco Nexus 1000V, LACP is enabled globally by default.


Note When you delete the port channel, the associated channel group is automatically deleted. All member interfaces revert to their original configuration.


This section includes the following topics:

Port Channel Modes

LACP ID Parameters

LACP Marker Responders

LACP-Enabled and Static Port Channels Differences

Figure 5-1 Individual Links Combined into a Port Channel

Port Channel Modes

Individual interfaces in port channels are configured with channel modes. When you run static port channels with no aggregation protocol, the channel mode is always set to on.

You enable LACP for each channel by setting the channel mode for each interface to active or passive. You can configure either channel mode for individual links in the LACP channel group when you are adding the links to the channel group.

Table 5-1 describes the channel modes.

Table 5-1 Channel Modes for Individual Links in a Port Channel

Channel Mode
Description

passive

LACP mode that places a port into a passive negotiating state in which the port responds to LACP packets that it receives but does not initiate LACP negotiation.

active

LACP mode that places a port into an active negotiating state in which the port initiates negotiations with other ports by sending LACP packets.

on

All static port channels (that are not running LACP) remain in this mode. If you attempt to change the channel mode to active or passive before enabling LACP, the device displays an error message.

You enable LACP on each channel by configuring the interface in that channel for the channel mode as either active or passive. When an LACP attempts to negotiate with an interface in the on state, it does not receive any LACP packets and becomes an individual link with that interface; it does not join the LACP channel group.

The default port channel mode is on.


Both the passive and active modes allow LACP to negotiate between ports to determine if they can form a port channel based on criteria such as the port speed and the trunking state.The passive mode is useful when you do not know whether the remote system, or partner, supports LACP.

Ports can form an LACP port channel when they are in different LACP modes if the modes are compatible as in the following examples:

A port in active mode can form a port channel successfully with another port that is in active mode.

A port in active mode can form a port channel with another port in passive mode.

A port in passive mode cannot form a port channel with another port that is also in passive mode, because neither port will initiate negotiation.

A port in on mode is not running LACP and cannot form a port channel with another port that is in active or passive mode.

LACP ID Parameters

This section describes the LACP parameters in the following topics:

LACP System Priority

LACP Port Priority

LACP Administrative Key

LACP System Priority

Each system that runs LACP has an LACP system priority value. You can accept the default value of 32768 for this parameter, or you can configure a value between 1 and 65535. LACP uses the system priority with the MAC address to form the system ID and also uses the system priority during negotiation with other devices. A higher system priority value means a lower priority.


Note The LACP system ID is the combination of the LACP system priority value and the MAC address.


LACP Port Priority

Each port that is configured to use LACP has an LACP port priority. You can accept the default value of 32768 for the LACP port priority, or you can configure a value between 1 and 65535. LACP uses the port priority with the port number to form the port identifier.

LACP uses the port priority to decide which ports should be put in standby mode when there is a limitation that prevents all compatible ports from aggregating and which ports should be put into active mode. A higher port priority value means a lower priority for LACP. You can configure the port priority so that specified ports have a lower priority for LACP and are most likely to be chosen as active links, rather than hot-standby links.

LACP Administrative Key

LACP automatically configures an administrative key value that is equal to the channel-group number on each port configured to use LACP. The administrative key defines the ability of a port to aggregate with other ports. A port's ability to aggregate with other ports is determined by these factors:

Port physical characteristics, such as the data rate and the duplex capability

Configuration restrictions that you establish

LACP Marker Responders

You can dynamically redistribute the data traffic by using port channels. This redistribution may result from a removed or added link or a change in the load-balancing scheme. Traffic redistribution that occurs in the middle of a traffic flow can cause misordered frames.

LACP uses the Marker Protocol to ensure that frames are not duplicated or reordered due to this redistribution. The Marker Protocol detects when all the frames of a given traffic flow are successfully received at the remote end. LACP sends Marker PDUs on each of the port-channel links. The remote system responds to the Marker PDU once it receives all the frames received on this link prior to the Marker PDU. The remote system then sends a Marker Responder. Once the Marker Responders are received by the local system on all member links of the port channel, the local system can redistribute the frames in the traffic flow with no chance of misordering. The software supports only Marker Responders.

LACP-Enabled and Static Port Channels Differences

Table 5-2 summarizes the major differences between port channels with LACP enabled and static port channels.

Table 5-2 Port Channels with LACP Enabled and Static Port Channels 

Configurations
Port Channels with LACP Enabled
Static Port Channels

Protocol applied

Enable globally

Not applicable

Channel mode of links

Can be either:

Active

Passive

Can only be On

Maximum number of links in channel

16

8


vPC Host Mode

Virtual port channel in host mode (vPC-HM) allows member ports in a port channel to connect to multiple upstream switches. With vPC-HM, ports are grouped into subgroups (0-31) for traffic separation.

As shown in Figure 5-2, for traffic separation using vPC-HM, member ports 1 and 2 are assigned to subgroup ID 0 and member ports 3 and 4 are assigned to subgroup ID 1.

Figure 5-2 Using vPC-HM to Connect a Port Channel to Multiple Upstream Switches

To configure an interface in vPC-HM, see the "Configuring a Port Channel that Connects to Multiple Upstream Switches" section.

vPC-HM can also be configured on a port profile. For more information, see the Cisco Nexus 1000V Port Profile Configuration Guide, Release 4.0(4)SV1(3).

See the "Subgroup Creation Using CDP or Manual Method" section and the "Interface Assignment Using Static Pinning" section to learn how subgroups are created and how interfaces are assigned.

Subgroup Creation Using CDP or Manual Method

If Cisco Discovery Protocol (CDP) is enabled on the upstream switches, then the subgroups can be automatically created using CDP information. If CDP is not enabled on the upstream switches, then you must manually create subgroups by assigning subgroup IDs to the Ethernet interfaces.

You configure this setting as part of the port channel configuration. For more information, see the "Configuring a Port Channel that Connects to Multiple Upstream Switches" section.

Interface Assignment Using Static Pinning

Static pinning allows you to assign (or pin) a vEthernet interface to a particular subgroup of a vPC-HM. This assignment allows traffic from the vEthernet interface to be forwarded only through the member ports in the subgroup. This feature assumes that you have manually configured subgroup IDs for the port members of the port channel.

To pin a vEthernet interface to a specific port channel subgroup, see the "Configuring Static Pinning" section.

You can also pin vEthernet interfaces to subgroups in port profile configuration mode. For more information, see the Cisco Nexus 1000V Port Profile Configuration Guide, Release 4.0(4)SV1(3).

High Availability

Port channels provide high availability by load balancing traffic across multiple ports. If a physical port fails, the port channel is still operational if there is an active member in the port channel.

Port channels support stateful and stateless restarts. A stateful restart occurs on a supervisor switchover. After the switchover, the Cisco Nexus 1000V applies the runtime configuration after the switchover.

Prerequisites for Port Channels

Port channeling has the following prerequisites:

You are logged into the Cisco Nexus 1000V in EXEC mode.

All ports for a single port channel must meet the compatibility requirements. See the "Compatibility Checks" section for more information about the compatibility requirements.

You can use virtual vPC-HM to configure a port channel even when the physical ports are connected to two different switches.

Guidelines and Limitations

Port channeling has the following guidelines and restrictions:

Port channels across modules are not supported.

Port channels can be formed with multiple upstream links only when they satisfy the compatibility requirements and under the following conditions:

The uplinks from the host are going to the same upstream switch.

The uplinks from the host going to multiple upstream switches are configured with vPC-HM.

You can configure port channels using a port profile. For more information, see the Cisco Nexus 1000V Port Profile Configuration Guide, Release 4.0(4)SV1(3).

You can configure up to 256 port channels,

You can configure multiple port channels on a device.

After you configure a port channel, the configuration that you apply to the port channel interface affects the port channel member ports. The configuration that you apply to the member ports affects only the member port where you apply the configuration.

You must remove the port security information from a port before you can add that port to a port channel. Similarly, you cannot apply the port security configuration to a port that is a member of a channel group.

You can configure ports that belong to a port channel group as PVLAN ports.

All ports in the port channel must be in the same Cisco Nexus 1000V module; you cannot configure port channels across Cisco Nexus 1000V modules.

Any configuration changes that you apply to the port channel is applied to every member interface of that port channel.

Channel member ports cannot be a source or destination SPAN port.

In order to support LACP when inband/AIPC are also carried over the link, you must configure the following commands on the ports connected to the ESX host:

spanning-tree portfast trunk

spanning-tree bpdufilter enable


Note If you have a separate dedicated NIC for control traffic, these settings are not required.


There should be at least two links that connect two switches when inband/AIPC are also carried over the LACP channel.

If you configure LACP and your upstream switch uses the LACP suspend feature, make sure this feature is disabled. For more information, see the documentation for your upstream switch, such as:

Cisco Nexus 7000 Series NX-OS Interfaces Configuration Guide, Release 5.x

Default Settings

The following table lists the default settings for port channels.

Parameters
Default

Port channel

Admin up

LACP

Enabled

Load balancing method for Layer 2 interfaces

Source and destination MAC address

Load balancing per module

Disabled

Channel mode

on


Configuring Port Channels

This section includes the following topics:

Configuring a Port Channel that Connects to a Single Upstream Switch

Configuring a Port Channel that Connects to Multiple Upstream Switches

Configuring Static Pinning

Removing the Port Channel and Group

Adding a Layer 2 Port to a Channel Group

Removing a Port from a Channel Group

Shutting Down and Restarting a Port Channel Interface

Configuring a Port Channel Description

Configuring an LACP Port Channel

Configuring the Speed and Duplex Settings for a Port Channel Interface

Configuring Port Channel Load Balancing

Restoring the Default Load-Balancing Method


Note Be aware that the Cisco Nexus 1000V commands may differ from the Cisco IOS commands.


Configuring a Port Channel that Connects to a Single Upstream Switch

You can use this procedure to configure a port channel whose member ports connect to a single upstream switch.


Note To configure a port channel whose member ports connect to multiple upstream switches, see the "Configuring a Port Channel that Connects to Multiple Upstream Switches" section.


BEFORE YOU BEGIN

Before beginning this procedure, you must know or do the following:

You are logged in to the CLI in EXEC mode.

When you create a port channel, an associated channel group is automatically created.

SUMMARY STEPS

1. config t

2. interface port-channel channel-number

3. show port-channel summary

4. copy running-config startup-config

DETAILED STEPS

 
Command
Purpose

Step 1 

config t

Example:

n1000v# config t

n1000v(config)#

Enters the global configuration mode.

Step 2 

interface port-channel channel-number

Example:

n1000v(config)# interface port-channel 1

n1000v(config-if)#

Enters the interface configuration mode for the specified port channel.

For channel-number, the range is from 1 to 4096. If the channel group does not already exist, it is automatically created as a port channel group whose member ports all connect to the same upstream switch.

Step 3 

show port-channel summary

Example:

n1000v(config-if)# show port-channel summary

(Optional) Displays the port channel configuration.

Step 4 

copy running-config startup-config

Example:

n1000v(config-if)# copy running-config startup-config

(Optional) Saves the running configuration persistently through reboots and restarts by copying it to the startup configuration.

EXAMPLES

The following example shows how to create a port channel:

n1000v# config t 
n1000v(config)# interface port-channel 1
 
   

Configuring a Port Channel that Connects to Multiple Upstream Switches

You can use this procedure to configure a port channel in virtual port channel host mode (vPC-HM).

To configure a port channel whose member ports connect to a single upstream switch, see the "Configuring a Port Channel that Connects to a Single Upstream Switch" section.

BEFORE YOU BEGIN

Before beginning this procedure, you must know or do the following:

You are logged in to the CLI in EXEC mode.

In vPC-HM, the port channel member ports connect to multiple upstream switches, and the traffic must be managed in separate subgroups.

When you create a port channel, an associated channel group is automatically created.

vPC-HM is only supported in port channels configured in the on mode. vPC-HM is not supported for LACP channels that use the active and passive modes.

You need to know whether CDP is configured in the upstream switches. If configured, then CDP creates a subgroup for each upstream switch to manage its traffic separately. If not configured, then you must manually configure subgroups to manage the traffic flow on the separate switches.

If you are using CDP with the default CDP timer (60 seconds), links that advertise that they are in service and then out of service in quick succession can take up to 60 seconds to be returned to service.

If any subgroup has more than one member port, you must configure a port channel for the member ports of each subgroup on the upstream switch.

If vPC-HM is not configured when port channels connect to multiple upstream switches, then the VMs behind the Cisco Nexus 1000V receive duplicate packets from the network for unknown unicast floods, multicast floods, and broadcasts.

The sub-group command used in this procedure overrides any subgroup configuration specified in the port profile inherited by the port channel interface.

You can also configure vPC-HM on the port profile. For more information, see the Cisco Nexus 1000V Port Profile Configuration Guide, Release 4.0(4)SV1(3).

SUMMARY STEPS

1. config t

2. interface port-channel channel-number

3. Do one of the following:

Enter sub-group cdp and proceed to step 8.

Enter sub-group manual and proceed to the next step.

4. exit

5. interface ethernet range

6. sub-group-id number

7. Repeat steps 5. and 6. for each port member connected to an upstream switch that is not configured for CDP.

8. show port-channel summary

9. show running-config interface ethernet range

10. copy running-config startup-config

DETAILED STEPS

 
Command
Purpose

Step 1 

config t

Example:

n1000v# config t

n1000v(config)#

Enters global configuration mode.

Step 2 

interface port-channel channel-number

Example:

n1000v(config)# interface port-channel 12

n1000v(config-if)#

Enters interface configuration mode for the specified port channel (from 1 to 4096).

If the channel group does not already exist, it is automatically created as a port channel group whose member ports all connect to the same upstream switch.

Step 3 

sub-group { cdp | manual }

Example:

n1000v(config-if)# sub-group cdp

Example:

n1000v(config-if)# sub-group manual

Identifies the port channel as being in host mode and indicates whether traffic flow is managed by CDP or manually created subgroups. You must manually configure subgroups if CDP is not configured on the upstream switches.

Note These commands override any subgroup configuration specified in the port-profile inherited by the port channel interface.

Step 4 

show port-channel summary

Example:

n1000v(config-if)# show port-channel summary

(Optional) Displays the port channel configuration.

Step 5 

show running-config interface ethernet range

Example:

n1000v(config-if)# show running-config interface ethernet 3/2-3

(Optional) Displays the subgroup ID configuration.

Step 6 

copy running-config startup-config

Example:

n1000v(config-if)# copy running-config startup-config

(Optional) Saves the running configuration persistently through reboots and restarts by copying it to the startup configuration.

Manually Configuring Subgroups

You can use this procedure to manually configure port channel subgroups to manage the traffic flow on multiple upstream switches. This is required for a port channel that connects to multiple upstream switches where CDP is not configured.

BEFORE YOU BEGIN

Before beginning this procedure, you must know or do the following:

You are logged in to the CLI in EXEC mode.

You have already configured the port profile for the port channel using the "Configuring a Port Channel that Connects to Multiple Upstream Switches" procedure.

You know the interface range and the subgroup IDs (0-31) for traffic to the upstream switches.

SUMMARY STEPS

1. config t

2. interface ethernet range

3. sub-group-id number

4. Repeat steps 2 and 3 for each port connected to an upstream switch where CDP is not configured.

5. show interface ethernet range

6. copy running-config startup-config

DETAILED STEPS

 
Command
Description

Step 1 

config t

Example:

n1000v# config t

n1000v(config)#

Enters global configuration mode.

Step 2 

interface ethernet range

Example:

n1000v(config)# interface ethernet3/2-3

n1000v(config-if)#

Enters interface configuration mode for the specified interface range.

Step 3 

sub-group id number

Example:

n1000v(config-if)# sub-group-id 0

n1000v(config-if)#

Manually configures a subgroup (from 0 to 31) to manage traffic for the upstream switch.

Step 4 

Repeat Step 2 and Step 3 for each port connected to an upstream switch where CDP is not configured.

Step 5 

show interface ethernet range

Example:

n1000v(config-if)# show interface ethernet 3/2-3

(Optional) Displays the configuration for verification.

Step 6 

copy running-config startup-config

Example:

n1000v(config-if)# copy running-config startup-config

(Optional) Saves the running configuration persistently through reboots and restarts by copying it to the startup configuration.

This example shows how to manually configure port channel subgroups for a host in module 3 which has four physical ports. The upstream switches do not support CDP. Ethernet ports 3/2 and 3/3 connect to one upstream switch and the Ethernet ports 3/4 and 3/5 connect to another.

n1000v# conf t
n1000v(config)# int eth3/2
n1000v(config-if)# sub-group-id 0
n1000v(config-if)# int eth3/3
n1000v(config-if)# sub-group-id 0
n1000v(config-if)# int eth3/4
n1000v(config-if)# sub-group-id 1
n1000v(config-if)# int eth3/5
n1000v(config-if)# sub-group-id 1
n1000v(config-if)# show running-config interface 
. . .
interface Ethernet3/2
  inherit port-profile system-uplink-pvlan
  sub-group-id 0
interface Ethernet3/3
  inherit port-profile system-uplink-pvlan
  sub-group-id 0
interface Ethernet3/4
  inherit port-profile system-uplink-pvlan
  sub-group-id 1
interface Ethernet3/5
  inherit port-profile system-uplink-pvlan
  sub-group-id 1

Configuring Static Pinning

You can use this procedure to configure static pinning on a vEthernet interface.


Note You can also configure static pinning on a port profile. For information, see the Cisco Nexus 1000V Port Profile Configuration Guide, Release 4.0(4)SV1(3).


BEFORE YOU BEGIN

Before beginning this procedure, you must know or do the following:

You are logged in to the CLI in EXEC mode.

SUMMARY STEPS

1. config t

2. interface vethernet interface-number

3. pinning id sub-group_id

4. show running-config interface vethernet interface-number

5. module vem module_number execute vemcmd show pinning

6. copy running-config startup-config

DETAILED STEPS

 
Command
Description

Step 1 

config t

Example:

n1000v# config t

n1000v(config)#

Enters global configuration mode.

Step 2 

interface vethernet interface-number

Example:

n1000v(config)# interface vethernet 1

n1000v(config-if)#

Enters interface configuration mode for the specified interface (from 1 to 1048575).

Step 3 

pinning id sub-group_id

Example:

n1000v(config-if)# pinning id 0

Assigns (or pins) a vEthernet interface to a specific port channel subgroup (from 0 to 31).

Step 4 

show running-config interface vethernet interface-number

Example:

n1000v(config-if)# show running-config interface vethernet 1

(Optional) Displays the pinning configuration of the specified interface.

Step 5 

module vem module_number execute vemcmd show pinning

Example:

n1000v(config-if)# module vem 3 execute vemcmd 
show pinning

(Optional) Displays the pinning configuration on the specified VEM.

Step 6 

copy running-config startup-config

Example:

n1000v(config-if)# copy running-config startup-config

(Optional) Saves the running configuration persistently through reboots and restarts by copying it to the startup configuration.

 
   

EXAMPLES

The following example shows how to pin subgroup ID 0 to vEthernet interface 1:

n1000v(config)# config t
n1000v(config)# interface vethernet 1
n1000v(config-if)# pinning id 0
n1000v(config-if)# show running-config interface vethernet 1
version 4.0(4)SV1(2)
 
   
interface Vethernet3
  service-policy type qos input policy1
  pinning id 0
 
   

n1000v(config-if)# exit

n1000v(config)# exit
n1000v# module vem 3 execute vemcmd show pinning
  LTL    IfIndex  PC_LTL  VSM_SGID  VEM_SGID  Eff_SGID
   48   1b040000     304         0         0         0
 
   
n1000v(config-if)# copy running-config startup-config
 
   
 
   

Removing the Port Channel and Group

You can use this procedure to remove a port channel and delete the associated channel group.

BEFORE YOU BEGIN

Before beginning this procedure, you must know or do the following:

You are logged in to the CLI in EXEC mode.

For details about how the interface configuration changes when you delete a port channel, see the "Compatibility Checks" section.

SUMMARY STEPS

1. config t

2. no channel-group channel-number

3. no interface port-channel channel-number

DETAILED STEPS

 
Command
Purpose

Step 1 

config t

Example:

n1000v# config t

n1000v(config)#

Enters global configuration mode.

Step 2 

no channel-group channel-number

Example:

n1000v(config)# no channel-group port-channel 1

Removes the channel group configuration from an interface.

Step 3 

no interface port-channel channel-number

Example:

n1000v(config)# no interface port-channel 1

Removes the port channel and deletes the associated channel group.

Adding a Layer 2 Port to a Channel Group

You can use this procedure to add a Layer 2 port to a channel group.

BEFORE YOU BEGIN

Before beginning this procedure, you must know or do the following:

You are logged in to the CLI in EXEC mode.

All Layer 2 member ports must run in full-duplex mode and at the same speed.

If the port channel does not yet exist, it is automatically created when you create the channel group.


Note If you cannot add a particular interface to a particular port channel, an error message signals a compatibility problem.


SUMMARY STEPS

1. config t

2. interface ethernet slot/port

3. switchport mode trunk

4. switchport trunk {allowed vlan vlan-id | native vlan-id}

5. channel-group channel-number [mode {on | active | passive}]

6. show interface type slot/port

7. copy running-config startup-config

DETAILED STEPS

 
Command
Purpose

Step 1 

config t

Example:

n1000v# config t

n1000v(config)#

Enters global configuration mode.

Step 2 

interface ethernet slot/port

Example:

n1000v(config)# interface ethernet 1/4

n1000v(config-if)

Enters interface configuration mode for the specified interface.

Step 3 

switchport mode trunk

Example:

n1000v(config-if)# switchport mode trunk

(Optional) Configures the interface as a trunk port.

Step 4 

switchport trunk {allowed vlan vlan-id | native vlan-id}

Example:

n1000v(config-if)# switchport trunk native 3

(Optional) Configures necessary parameters for a trunk port.

Step 5 

channel-group channel-number [mode {on | active | passive}]

Example:

n1000v(config-if)# channel-group 5

Configures the port in a channel group and sets the mode.

channel number—The channel-number range is from 1 to 4096. The port channel associated with this channel group is automatically created if the port channel does not already exist.

mode—All static port channel interfaces are set to mode on.

Step 6 

show interface type slot/port

Example:

n1000v(config-if)# show interface port channel 5

(Optional) Displays interface information.

Step 7 

copy running-config startup-config

Example:

n1000v(config)# copy running-config startup-config

(Optional) Saves the running configuration persistently through reboots and restarts by copying it to the startup configuration.

EXAMPLES

The following example shows how to add the Ethernet interface 1/4 to channel group 5:

n1000v# config t 
n1000v(config)# interface ethernet 1/4
n1000v(config-if)# switchport
n1000v(config-if)# channel-group 5 

Removing a Port from a Channel Group

You can use this procedure to remove a port from a channel group and return the port to its original configuration.

BEFORE YOU BEGIN

Before beginning this procedure, you must know or do the following:

You are logged in to the CLI in EXEC mode.

SUMMARY STEPS

1. config t

2. no channel-group

DETAILED STEPS

 
Command
Purpose

Step 1 

config t

Example:

n1000v# config t

n1000v(config)#

Enters global configuration mode.

Step 2 

no channel-group

Example:

n1000v(config)# no channel-group

Removes the port from the channel group and returns it to its original configuration.

Shutting Down and Restarting a Port Channel Interface

You can use this procedure to shut down and restart a port channel interface.

BEFORE YOU BEGIN

Before beginning this procedure, you must know or do the following:

You are logged in to the CLI in EXEC mode.

When you shut down a port channel interface, no traffic passes, and the interface is administratively down.

SUMMARY STEPS

1. config t

2. interface port-channel channel-number

3. shutdown | no shutdown

4. show interface port-channel channel-number

5. copy running-config startup-config

DETAILED STEPS

 
Command
Purpose

Step 1 

config t

Example:

n1000v# config t

n1000v(config)#

Enters global configuration mode.

Step 2 

interface port-channel channel-number

Example:

n1000v(config)# interface port-channel 2

n1000v(config-if)

Enters interface configuration mode for the specified port channel interface.

Step 3 

shutdown

Example:

n1000v(config-if)# shutdown

Shuts down the interface. No traffic passes and the interface displays as administratively down. The default is no shutdown.

no shutdown

Example:

n1000v(config-if)# no shutdown

Brings the interface back up. The interface displays as administratively up. If there are no operational problems, traffic passes. The default is no shutdown.

Step 4 

show interface port-channel channel-number

Example:

n1000v(config-if)# show interface port-channel 2

(Optional) Displays interface information for the specified port channel.

Step 5 

copy running-config startup-config

Example:

n1000v(config-if)# copy running-config startup-config

(Optional) Saves the running configuration persistently through reboots and restarts by copying it to the startup configuration.

EXAMPLES

The following example shows how to bring up the interface for port channel 2:

n1000v# config t 
n1000v(config)# interface port-channel 2
n1000v(config-if)# no shutdown

Configuring a Port Channel Description

You can use this procedure to configure a description for a port channel.

BEFORE YOU BEGIN

Before beginning this procedure, you must know or do the following:

You are logged in to the CLI in EXEC mode.

SUMMARY STEPS

1. config t

2. interface port-channel channel-number

3. description string

4. show interface port-channel channel-number

5. copy running-config startup-config

DETAILED STEPS

 
Command
Purpose

Step 1 

config t

Example:

n1000v# config t

n1000v(config)#

Enters global configuration mode.

Step 2 

interface port-channel channel-number

Example:

n1000v(config)# interface port-channel 2

n1000v(config-if)

Places you into interface configuration mode for the specified port channel interface.

For channel number, the range is from 1 to 4096. The port channel associated with this channel group is automatically created if the port channel does not already exist.

Step 3 

description string

Example:

n1000v(config-if)# description engineering

Adds a description to the port channel interface.

For string, the description can be up to 80 alphanumeric characters.

Note You do not need to use quotations around descriptions that include spaces.

Step 4 

show interface port-channel channel-number

Example:

n1000v(config-if)# show interface port-channel 2

(Optional) Displays interface information for the specified port channel.

Step 5 

copy running-config startup-config

Example:

n1000v(config-if)# copy running-config startup-config

(Optional) Saves the running configuration persistently through reboots and restarts by copying it to the startup configuration.

EXAMPLES

The following example shows how to add a description to port channel 2:

n1000v# config t 
n1000v(config)# interface port-channel 2
n1000v(config-if)# description engineering

Configuring an LACP Port Channel

You can use this procedure to configure the following requirements for LACP:

The individual port channel links so that they are allowed to operate with LACP.

A system uplink port profile for LACP.

BEFORE YOU BEGIN

Before beginning this procedure, you must know or do the following:

You are logged in to the CLI in EXEC mode.

The default port channel mode is on.

When you configure port channels with no associated aggregation protocol, all interfaces on both sides of the link remain in the on channel mode.

The LACP mode for individual links in an LACP port channel indicates that the link is allowed to operate with LACP.

The port profile configuration adds a native VLAN to the port channel and adds that VLAN to the system VLAN list.

SUMMARY STEPS

1. config t

2. interface interface

3. channel-group number mode {active | on | passive}

4. port-profile [type {ethernet | vethernet}] name

5. vmware port-group [pg_name]

6. switchport mode {access | private-vlan {host | promiscuous} | trunk}

7. switchport trunk allowed vlan vlan-id-list

8. channel-group auto [mode {on | active | passive}] mac-pinning

9. system vlan vlan-id-list

10. state enabled

11. show port-channel summary

12. copy running-config startup-config

DETAILED STEPS

 
Command
Purpose

Step 1 

config t

Example:

n1000v# config t

n1000v(config)#

Enters global configuration mode.

Step 2 

interface interface

Example 1:

n1000v(config)# interface ethernet 1/4

n1000v(config-if)#

Specifies the interface that you are configuring and places you in interface configuration mode.

For an Ethernet port, use ethernet slot/port, where slot is the module slot number and port is the port number.

For a vEthernet port, use vethernet interface-number, where interface-number is a number from 1 to 1048575.

Step 3 

channel-group number mode {active | on | passive}

Example:

n1000v(config-if)# channel-group 5 mode active

Specifies the port mode as active or passive for the specified link.

When you run port channels with no associated aggregation protocol, the port-channel mode is always on.

The default port channel mode is on.

Step 4 

port-profile [type {ethernet | vethernet}] 
name
 
        
Example:
n1000v(config-if)# port-profile type 
ethernet system-uplink
n1000v(config-port-prof)#

Enters port profile configuration mode for the named port profile.

name—Specifies the port profile name, which can be up to 80 characters and must be unique for each port profile on the Cisco Nexus 1000V.

type—(Optional) Specifies the port profile as an Ethernet or vEthernet type. Once configured, this setting cannot be changed. The default is the vEthernet type.

Defining a port profile as an Ethernet type allows the port profile to be used for physical (Ethernet) ports. In the vCenter Server, the corresponding port group can be selected and assigned to physical ports (PNICs).

Note If a port profile is configured as an Ethernet type, then it cannot be used to configure VMware virtual ports.

Step 5 

vmware port-group [pg_name]

Example:

n1000v(config-port-prof)# vmware port-group lacp

n1000v(config-port-prof)#

Designates the port profile as a VMware port group.

The port profile is mapped to a VMware port group of the same name unless you specify a name here. When you connect the VSM to vCenter Server, the port group is distributed to the virtual switch on the vCenter Server.

Step 6 

switchport mode {access | private-vlan {host | promiscuous} | trunk}

Example:

n1000v(config-port-prof)# switchport mode trunk

n1000v(config-port-prof)#

Designates how the interfaces are to be used.

Allowable port modes:

access

private-vlan

host

promiscuous

trunk

A trunk port transmits untagged packets for the native VLAN and transmits encapsulated, tagged packets for all other VLANs.

Step 7 

switchport trunk allowed vlan vlan-id-list

Example:

n1000v(config-port-prof)# switchport trunk allowed vlan 1-100

n1000v(config-port-prof)#

Designates the port profile as trunking and defines VLAN access to it as follows:

allowed-vlans—Defines VLAN IDs that are allowed on the port.

add—Lists VLAN IDs to add to the list of those allowed on the port.

except—Lists VLAN IDs that are not allowed on the port.

remove—Lists VLAN IDs whose access is to be removed from the port.

all—Indicates that all VLAN IDs are allowed on the port, unless exceptions are also specified.

none—Indicates that no VLAN IDs are allowed on the port.

If you do not configure allowed VLANs, then the default VLAN 1 is used as the allowed VLAN.

Step 8 

channel-group auto [mode {on | active | 
passive}] mac-pinning

Example:

n1000v(config-port-prof)# channel-group auto mode active

n1000v(config-port-prof)#

Defines a port channel group in which a unique port channel is created and automatically assigned when the port profile is assigned to the first interface.

Each additional interface that belongs to the same module is added to the same port channel. In VMware environments, a different port channel is created for each module.

mode—Sets the port channel mode to on, active, or passive (active and passive use LACP).

mac-pinning—If the upstream switch does not support port channels, this designates that one subgroup per Ethernet member port must be automatically assigned,

Step 9 

system vlan vlan-id-list

Example:

n1000v(config-port-prof)# system vlan 1,10,20

n1000v(config-port-prof)#

Adds system VLANs to this port profile.

Step 10 

state enabled

Example:

n1000v(config-port-prof)# state enabled

n1000v(config-port-prof)#

Enables the port profile and applies its configuration to the assigned ports. If the port profile is a VMware port group, the port group will be created in the vswitch on vCenter Server.

Step 11 

show port-channel summary

Example:

n1000v(config-if)# show port-channel summary

(Optional) Displays summary information about the port channels.

Step 12 

copy running-config startup-config

Example:

n1000v(config-if)# copy running-config startup-config

(Optional) Saves the running configuration persistently through reboots and restarts by copying it to the startup configuration.

EXAMPLE CONFIGURATION

The following example shows how to set the LACP-enabled interface to the active port channel mode for Ethernet interface 1/4 in channel group 5; and then configure an LACP port profile.

config t 
interface ethernet 1/4
channel-group 5 mode active
port-profile type ethernet system-uplink
vmware port-group lacp
switchport mode trunk
switchport trunk allowed vlan 1-100
channel-group auto mode active
system vlan 1,10,20
state enabled
show port-channel summary
copy running-config startup-config

Configuring the Speed and Duplex Settings for a Port Channel Interface

You can use this procedure to configure the speed and duplex settings for a port channel interface.

BEFORE YOU BEGIN

Before beginning this procedure, you must know or do the following:

You are logged in to the CLI in EXEC mode.

SUMMARY STEPS

1. config t

2. interface port-channel channel-number

3. speed {10 | 100 | 1000 | auto}

4. duplex {auto | full | half}

5. show interface port-channel channel-number

6. copy running-config startup-config

DETAILED STEPS

 
Command
Purpose

Step 1 

config t

Example:

n1000v# config t

n1000v(config)#

Enters global configuration mode.

Step 2 

interface port-channel channel-number

Example:

n1000v(config)# interface port-channel 2

n1000v(config-if)

Specifies the port channel interface that you want to configure and enters the interface mode.

Step 3 

speed {10 | 100 | 1000 | auto}

Example:

n1000v(config-if)# speed auto

Sets the speed for the port channel interface. The default is auto for auto negotiation.

Step 4 

duplex {auto | full | half}

Example:

n1000v(config-if)# speed auto

Sets the duplex mode for the port channel interface. The default is auto for auto negotiation.

Step 5 

show interface port-channel channel-number

Example:

n1000v(config-if)# show interface port-channel 2

(Optional) Displays interface information for the specified port channel.

Step 6 

copy running-config startup-config

Example:

n1000v(config-if)# copy running-config startup-config

(Optional) Saves the running configuration persistently through reboots and restarts by copying it to the startup configuration.

EXAMPLES

The following example shows how to set port channel 2 to 100 Mbps:

n1000v# config t 
n1000v(config)# interface port channel 2
n1000v(config-if)# speed 100

Configuring Port Channel Load Balancing

You can use this procedure to configure port channel load balancing.

BEFORE YOU BEGIN

Before beginning this procedure, you must know or do the following:

You are logged in to the CLI in EXEC mode.

You can configure port channel load balancing for the entire device or for a single module.

Module-based load balancing takes precedence over device-based load balancing.

The default load balancing method is the source MAC address.

For more information about port channel load balance, see the "Load Balancing Using Port Channels" section.

SUMMARY STEPS

1. config t

2. port-channel load-balance ethernet {dest-ip-port | dest-ip-port-vlan | destination-ip-vlan | destination-mac | destination-port | source-dest-ip-port | source-dest-ip-port-vlan | source-dest-ip-vlan | source-dest-mac | source-dest-port | source-ip-port | source-ip-port-vlan | source-ip-vlan | source-mac | source-port | source-virtual-port-id | vlan-only}

3. show port-channel load-balance

4. copy running-config startup-config

DETAILED STEPS

 
Command
Purpose

Step 1 

config t

Example:

n1000v# config t

n1000v(config)#

Enters global configuration mode.

Step 2 

port-channel load-balance ethernet {dest-ip-port | dest-ip-port-vlan | destination-ip-vlan | destination-mac | destination-port | source-dest-ip-port | source-dest-ip-port-vlan | source-dest-ip-vlan | source-dest-mac | source-dest-port | source-ip-port | source-ip-port-vlan | source-ip-vlan | source-mac | source-port | source-virtual-port-id | vlan-only}

Example:

n1000v(config)# port-channel load-balance ethernet source-destination-mac

Configures the load balance method for the device or module. The range depends on the device.

The default load balancing method uses the source MAC address.

Step 3 

show port-channel load-balance

Example:

n1000v(config)# show port-channel load-balance

(Optional) Displays the port channel load-balancing method.

Step 4 

copy running-config startup-config

Example:

n1000v(config)# copy running-config startup-config

(Optional) Saves the running configuration persistently through reboots and restarts by copying it to the startup configuration.

EXAMPLES

The following example shows how to configure the source IP load-balancing method for port channels on module 5:

n1000v# config t 
n1000v(config)# port-channel load-balance ethernet source-ip module 5

Restoring the Default Load-Balancing Method

You can use this procedure to restore the default load-balancing method.

BEFORE YOU BEGIN

Before beginning this procedure, you must know or do the following:

You are logged in to the CLI in EXEC mode.

SUMMARY STEPS

1. config t

2. no port-channel load-balance ethernet

3. show port-channel load-balance

4. copy running-config startup-config

DETAILED STEPS

 
Command
Purpose

Step 1 

config t

Example:

n1000v# config t

n1000v(config)#

Enters global configuration mode.

Step 2 

no port-channel load-balance ethernet

Example:

n1000v(config)# no port-channel load-balance ethernet

Restores the default load-balancing method, which is the source MAC address.

Step 3 

show port-channel load-balance

Example:

n1000v(config)# show port-channel load-balance

(Optional) Displays the port channel load-balancing method.

Step 4 

copy running-config startup-config

Example:

n1000v(config)# copy running-config startup-config

(Optional) Saves the running configuration persistently through reboots and restarts by copying it to the startup configuration.

Verifying the Port Channel Configuration

To display the port channel configuration, perform the following tasks

Command
Purpose

show interface port-channel channel-number

Displays the status of a port channel interface.

show port-channel compatibility-parameters

Displays the parameters that must be the same among the member ports in order to join a port channel.

show port-channel database [interface port-channel channel-number]

Displays the aggregation state for one or more port channel interfaces.

show port-channel load-balance

Displays the type of load balancing in use for port channels.

show port-channel summary

Displays a summary for the port channel interfaces.

show port-channel traffic

Displays the traffic statistics for port channels.

show port-channel usage

Displays the range of used and unused channel numbers.

show running-config interface ethernet port/slot

Displays information about the running configuration of the specified Ethernet interface.

show running-config interface port-channel channel-number

Displays information on the running configuration of the port channel.

show running-config interface vethernet interface-number

Displays information about the running configuration of the specified vEthernet interface.


For more information about the command output, see the Cisco Nexus 1000V Command Reference, Release 4.0(4)SV1(3).

Monitoring the Port Channel Configuration

You can display port channel interface configuration information.

Command
Purpose

clear counters interface port-channel channel-number

Clears the counters.

show interface counters [module module]

Displays input and output octets unicast packets, multicast packets, and broadcast packets.

show interface counters detailed [all]

Displays input packets, bytes, and multicast and output packets and bytes.

show interface counters errors [module module]

Displays information on the number of error packets.


Configuration Example for Port Channels

The following example shows how to create a port channel and add two Layer 2 interfaces to that port channel:

config t 
interface port-channel 5
interface ethernet 1/4
switchport
channel-group 5 mode active
interface ethernet 1/7
switchport
channel-group 5 mode 
 
   

Additional References

For additional information related to implementing port channels, see the following sections:

Related Documents

Standards

Related Documents

Related Topic
Document Title

Configuring Layer 2 interface

Chapter 3 "Configuring Layer 2 Interfaces"

System management

Cisco Nexus 1000V System Management Configuration Guide, Release 4.0(4)SV1(3)

Release Notes

Cisco Nexus 1000V Release Notes, Release 4.0(4)SV1(3)

Complete command syntax, command modes, command history, defaults, usage guidelines, and examples

Cisco Nexus 1000V Command Reference, Release 4.0(4)SV1(3)


Standards

Standards
Title

IEEE 802.3ad

Link Aggregation


Feature History for Port Channels

This section provides the feature history for port channels.

Feature Name
Releases
Feature Information

vPC-Host Mode

4.0(4)SV1(2)

Support for manual creation of subgroups.

Static Pinning

4.0(4)SV1(2)

Support for attaching (or pinning) a vEthernet interface to a specific port channel subgroup.

Port Channels

4.0(4)SV1(1)

This feature was introduced.