Guest

Cisco Nexus 1000V Switch for VMware vSphere

Cisco Nexus 1000V and VMware Compatibility Information, Release 4.0(4)SV1(1)

  • Viewing Options

  • PDF (206.0 KB)
  • Feedback
Cisco Nexus 1000V and VMware Compatibility Information, Release 4.0(4)SV1(1)

Table Of Contents

Cisco Nexus 1000V and VMware Compatibility Information, Release 4.0(4)SV1(1)

Cisco Nexus 1000V and VMware Compatibility

VMware Versions Compatible with Cisco Nexus 1000V Release 4.0(4)SV1(1)

Identifying the ESX/ESXi Platform Build Number

vSphere CLI

Server Compatibility


Cisco Nexus 1000V and VMware Compatibility Information, Release 4.0(4)SV1(1)


Published: S eptember 22, 2010

This document describes the Cisco Nexus 1000V and VMware compatibility information and contains the following topics:

Cisco Nexus 1000V and VMware Compatibility

VMware Versions Compatible with Cisco Nexus 1000V Release 4.0(4)SV1(1)

Identifying the ESX/ESXi Platform Build Number

vSphere CLI

Server Compatibility

Cisco Nexus 1000V and VMware Compatibility

Table 1 lists the VMware releases and ESX platforms and builds that are compatible with Cisco Nexus 1000V product releases.

Table 1 Cisco Nexus 1000V and VMware Compatibility Matrix 

 
Minimum Required Version
VMware Software Version
Host Build 1
VIB Version 2
VEM Bundle
vCenter Server
Update Manager
vSphere CLI

ESX40.P06

ESX/ESXi400-201005401-SG

256968

cross_cisco-vem-v100-4.0.4.1.1.32-1.13.7.vib

VEM400-201005001-BG

208111

282702

198790

ESX40.P05

ESX400/ESXi400-201003001

244038

cross_cisco-vem-v100-4.0.4.1.1.32-1.12.18.vib

VEM400-201003001-BG

208111

282702

198790

ESX40.P04

ESX400/ESXi400-201002001

236512

cross_cisco-vem-v100-4.0.4.1.1.31-1.11.11.vib

VEM400-201002001-BG

208111

282702

198790

ESX40.P03

ESX400/ESXi400-200912001

219382

cross_cisco-vem-v100-4.0.4.1.1.30-1.10.13.vib

VEM400-200912001-BG

208111

282702

198790

ESX40.U1

ESX/ESXi-4.0.0-update01

208167

cross_cisco-vem-v100-4.0.4.1.1.30-1.9.vib

VEM400-200911014-BG

208111

282702

198790

ESX40.P02

ESX/ESXi400-VEM-200909001

193498

cross_cisco-vem-v100-4.0.4.1.1.28-0.7.3.vib

VEM400-200909001-BG

208111

162871

198790

ESX40.EP01

ESX/ESXi400-VEM-200907001

181792

cross_cisco-vem-v100-4.0.4.1.1.28-0.6.2.vib

VEM400-200907001-BG

162856

162871

161974

ESX4.0 P01

Esx/ESXi400-VEM-200906001

175625

cross_cisco-vem-v100-4.0.4.1.1.27-0.4.2.vib

VEM400-200904001-BG

162856

162871

161974

ESX/ESXi 4.0 GA

164009
171294

cross_cisco-vem-v100-4.0.4.1.1.27-0.4.2.vib

VEM400-200904001-BG

162856

162871

161974

1 VIB files are available at http://www.vmware.com/patch/download

2 After installing VMware patches, verify the ESX software build number on the ESX server console.


VMware Versions Compatible with Cisco Nexus 1000V Release 4.0(4)SV1(1)

Table 2 lists the VMware versions that are compatible with Cisco Nexus 1000V Release 4.0(4)SV1(1).

Table 2 VMware Versions Compatible with Cisco Nexus 1000V Release 4.0(4)SV1(1) 

ESX/ESXi
vCenter Server
Update Manager
vSphere CLI
vSphere Client

164009

162856

162871

161974

162856

171294

208156

231675

198790

208156

175625

       

181792

       

193498

       

208167

       

219382

       

236512

       

244038

       

256968

       

Identifying the ESX/ESXi Platform Build Number

To obtain the build number for the ESX platform in use that corresponds to your VMware software release, type the following command at the shell prompt:

[root@hostname ~] # rpm -qa | grep vmkernel | awk -F. '{print $5}'
236512

To obtain the build number for the ESXi platform in use that corresponds to your VMware software release, type the following command at the vCLI host prompt:

~ # vmware -v
VMware ESXi 4.0.0 build-236512

vSphere CLI

You can use any one of the following minimum vSphere CLI versions to install the Cisco Nexus 1000V virtual Ethernet module (VEM) software:

vCLI—VMware-vSphere-CLI-4.0.0-161974.exe

http://www.vmware.com/support/developer/vcli/

vMA—vMA-4.0.0-161993.zip

http://www.vmware.com/support/developer/vima/

Server Compatibility

The servers running the Cisco Nexus 1000V VSM and VEM must be in the VMware Hardware Compatibility List (HCL). This is a requirement for running the ESX 4.0 software, VMware vSphere 4.0 Enterprise Plus.

The Cisco Nexus 1000V is compatible with any upstream physical access layer switch that is Ethernet standard compliant, including Catalyst 6500 series switches, Cisco Nexus switches, and switches from other network vendors.