Cisco MDS 9000 Family Data Mobility Manager Configuration Guide, Release 5.x
Getting Started
Downloads: This chapterpdf (PDF - 212.0KB) The complete bookPDF (PDF - 4.75MB) | Feedback

Configuring DMM Software

Table Of Contents

Configuring DMM Software

Information About Configuring DMM Software

Installing Cisco MDS DMM Software

DMM Management Installation and Configuration Tools

DMM CLI

DMM GUI (DCNM-SAN)

Installing DCNM for SAN

Configuring SSH on the Switch

Licensing Requirements for Cisco MDS DMM Software

Prerequisites for Cisco MDS DMM Software

Guidelines and Limitations

Configuring Cisco MDS DMM Using CLI

Enabling Cisco MDS DMM with the CLI

Configuring the Migration Rate Using the CLI

Configuring IP Connectivity

Configuring IP Connectivity for MSM-18/4 Module

Configuring IP Connectivity for MDS 9222i Switches

Configuring Cisco MDS DMM Using the DCNM for SAN GUI

Enabling Cisco MDS DMM with DCNM for SAN

Configuring Migration Rate Using DCNM for SAN

Using the Cisco MDS DMM Pre-Configuration Wizard

Configuring MDS Modules for DMM

Filed Descriptions for DMM CLI Software

LUN Discover

Feature History for DMM Software


Configuring DMM Software


This chapter describes how to install and configure the Cisco MDS DMM software.

Information About Configuring DMM Software

Licensing Requirements for Cisco MDS DMM Software

Prerequisites for Cisco MDS DMM Software

Guidelines and Limitations

Configuring Cisco MDS DMM Using CLI

Configuring Cisco MDS DMM Using CLI

Configuring Cisco MDS DMM Using the DCNM for SAN GUI

Filed Descriptions for DMM CLI Software

Feature History for DMM Software

Information About Configuring DMM Software

This chapter describes how to install and configure the Cisco MDS DMM software.

The required tasks are described in the following sections:

Installing Cisco MDS DMM Software

DMM Management Installation and Configuration Tools

Installing Cisco MDS DMM Software

The Cisco MDS DMM feature runs on the MSM-18/4 module or the MDS 9222i switch.


Note Cisco MDS NX-OS Release 5.0(1), no longer supports the Storage Services Module (SSM) (DS-X9032-SSM).

Cisco DCNM for SAN Release 5.0(1) does support the SSM and can be used to configure an SSM running SAN-OS Release 3.x or NX-OS Release 4.x software.


The DMM software package is included in the SSI image as a part of the SAN-OS or NX-OS.

For information on how to install the MSM-18/4 module or the MDS 9222i switch image, refer to Cisco MDS 9000 Family Storage Services Interface Image Installation and Upgrade Guide.

DMM Management Installation and Configuration Tools

Cisco MDS DMM supports a CLI tool and a GUI tool for configuring and managing data migrations. The tools are described in these sections:

DMM CLI

DMM GUI (DCNM-SAN)

DMM CLI

The Cisco MDS DMM feature uses the CLI on the Cisco MDS 9000 Family switches, including the MDS 9222i switch and MSM-18/4 module.

No DMM-specific tasks are required to install or configure the CLI.

DMM GUI (DCNM-SAN)

The Cisco MDS 9000 DCNM-SAN, a Java-based GUI, manages Cisco MDS 9000 Family switches using SNMP. The GUI for the Cisco MDS DMM is integrated into DCNM-SAN.

To use the DMM GUI, complete the following tasks:

Installing DCNM for SAN

Configuring SSH on the Switch

Installing DCNM for SAN

The Cisco MDS DMM software is bundled into the DCNM for SAN software package.

For information about installing DCNM for SAN software, refer to the Cisco DCNM for SAN Fundamentals Configuration Guide.

Configuring SSH on the Switch

The Cisco MDS DMM communicates with the MSM-18/4 module or MDS 9222i switch using a secure shell protocol (SSH) connection. Before using the Cisco MDS DMM, you need to enable SSH on the switch that hosts the MSM-18/4 module or MDS 9222i switch.

For information about configuring SSH, see the SSH chapter of the Cisco DCNM for SAN Security Configuration Guide and the Cisco MDS 9000 Family NX-OS Security Configuration Guide.

Licensing Requirements for Cisco MDS DMM Software

Table 2-1 lists the Cisco MDS DMM licenses that are available.

Table 2-1 Cisco MDS DMM Licenses 

Part Number
Description
Applicable Product

M95DMM184K9

Cisco Data Mobility Manager (DMM) permanent license for MSM-18/4 module

MDS 9500 Series with MSM-18/4 module

M95DMM184TSK9

Cisco Data Mobility Manager (DMM) time-based license for MSM-18/4 module (for 180 days)

MDS 9500 Series with MSM-18/4 module

M92DMM184K9

Cisco Data Mobility Manager (DMM) permanent license for MSM-18/4 module

MDS 9200 Series with MSM-18/4 module

M92DMM184TSK9

Cisco Data Mobility Manager (DMM) time-based license for MSM-18/4 module (for 180 days)

MDS 9200 Series with MSM-18/4 module

M9222iDMMK9

Cisco Data Mobility Manager (DMM) permanent license for fixed slot

MDS 9222i Switch only

M9222IDMMTSK9

Cisco Data Mobility Manager (DMM) time-based license (for 180 days) for fixed slot

MDS 9222i Switch only

M95DMMS1K9

Cisco Data Mobility (DMM) permanent license for one MSM-18/4 module or MDS 9222i switch

MDS 9500 Series with MSM-18/4 module or MDS 9222i switch

M95DMMTS1K9

Cisco Data Mobility (DMM) time-based license for one MSM-18/4 module or MDS 9222i switch (for 180 days)

MDS 9500 Series with MSM-18/4 module or MDS 9222i switch

M92DMMS1K9

Cisco Data Mobility (DMM) permanent license for one MSM-18/4 module or MDS 9222i switch

MDS 9200 Series with MSM-18/4 module or MDS 9222i switch

M92DMMTS1K9

Cisco Data Mobility (DMM) time-based license for one MSM-18/4 module or MDS 9222i switch (for 180 days)

MDS 9200 Series with MSM-18/4 module or MDS 9222i switch


You may purchase a DMM license for an MSM-18/4 module or MDS 9222i switch in a fabric that does not have a DCNM for SAN license. In this configuration, you can open multiple fabrics in DCNM-SAN and use the DMM functionality. Full DCNM-SAN functionality is not available. For example, performance manager, desktop client remote login, and web client fabric reporting are not available without a DCNM for SAN license.


Note If the DMM license for an MSM-18/4 module or MDS 9222i switch expires, all scheduled and in-progress jobs will continue to execute. You cannot create new jobs with an expired license.


For more information about installing or upgrading software licenses, refer to Cisco MDS 9000 Family NX-OS Licensing Guide.

Prerequisites for Cisco MDS DMM Software

You can use the Cisco MDS DMM software without a license for a period of 120 days.

Guidelines and Limitations

When planning and configuring data migration using Cisco MDS DMM, follow these guidelines:

The MSM-18/4 module or the MDS 9222i switch should be installed in the same MDS switch as the existing storage device and the new storage device should be connected to the same switch. Data migration causes increased Inter-Switch Link (ISL) traffic if the existing storage or new storage devices are connected to different switches than the MSM-18/4 module or the MDS 9222i switch.

Cisco MDS DMM supports 16 simultaneous jobs on each MSM-18/4 module or MDS 9222i switch.

The same initiator and target port pair should not be added into more than one migration job simultaneously.

When using multipath ports, the server must not send simultaneous I/O write requests to the same LUN from both multipath ports. The first I/O request must be acknowledged as completed before initiating the second I/O request.

DMM is not compatible with LUN zoning.

DMM is not compatible with inter-VSAN routing (IVR). The server and storage ports must be included in the same VSAN.

DMM does not support migrations between VSANs (IVR). The DMM member ports, Initiators, Existing Storage (ES), and New Storage (NS) targets within the same VSAN should also not be configured as part of an IVR zone set.

DMM is not compatible with SAN device virtualization (SDV). The server and storage ports cannot be virtual devices, or physical devices associated with a virtual device.

For assistance on DMM and FC/IP write acceleration, contact Cisco support.

DMM does not support migration to a smaller destination LUN.

SME does not support any FCoE connected devices including devices connected through the MDS FCoE linecard (DX-X9708-K9).

In Cisco MDS NX-OS Release 5.2(x), you cannot install a FCoE module in a switch that is running DMM, SME, or IOA.

Configuring Cisco MDS DMM Using CLI

When a migration job is created, you can configure the migration rate as fast, medium, or slow. Use the CLI to configure the values for these rates, as described in the following sections:

Enabling Cisco MDS DMM with the CLI

Configuring the Migration Rate Using the CLI

Configuring IP Connectivity

Enabling Cisco MDS DMM with the CLI

Prerequisites

Although Cisco MDS NX-OS Release 5.0(1a) no longer supports the SSM, the ssm enable command remains in Release 5.0(1a). Use the ssm enable command to enable the DMM feature on an MSM-18/4 module or on an MDS 9222i switch.

Detailed Steps

To enable DMM on an MSM-18/4 module or MDS 9222i switch and to provision ports to use the DMM feature, perform these tasks:

 
Command
Purpose

Step 1 

switch# configure terminal

Enters configuration mode.

Step 2 

switch(config)# ssm enable feature dmm module slot

Enables DMM on the MSM-18/4 module or MDS 9222i switch in the specified slot.

switch(config)# no ssm enable feature dmm module slot

Disables DMM on the MSM-18/4 module or MDS 9222i switch in the specified slot.

Step 3 

switch(config)# ssm enable feature dmm interface slot/port - port

Enables DMM for the interface in the specified slot and port range.

Configuring the Migration Rate Using the CLI

Detailed Steps

To configure the values associated with the fast, medium, and slow migration rates, follow these steps:

 
Command
Purpose

Step 1 

switch# config t

Enters the configuration mode.

Step 2 

switch(config)# dmm module module-id rate_of_migration fast rate medium rate slow rate

Sets the migration rate for the specified MSM-18/4 module or MDS 9222i switch. The migration rate has a range of 1 to 200 and the units are megabytes per second (MB/s).

The default values for migration rate are as follows:

Slow: 10 MB/s

Medium: 25 MB/s

Fast: 60 MB/s

Examples

The following example sets the fast migration rate to 100 MB/s for the MSM-18/4 module or the MDS 9222i switch in slot 4:

switch(config)# dmm module 4 rate_of_migration fast 100 medium 25 slow 10

Configuring IP Connectivity

This section covers the configuration of IP connectivity for the following modules:

Configuring IP Connectivity for MSM-18/4 Module

Configuring IP Connectivity for MDS 9222i Switches

Configuring IP Connectivity for MSM-18/4 Module

The MSM-18/4 module and the supervisor module in an MDS switch communicate over VSAN 1 using IP. You need to configure an IP subnetwork for VSAN 1 on the MDS switch.

The MSM-18/4 modules communicate with their peer MSM-18/4 modules using the management IP network.

The zone created for the IPFC interfaces must be added to the existing zone set in VSAN 1 and the zone set must be re-activated to include the new zone. If a zone set does not exist in VSAN 1, create a zone set. Add the zone to the zone set and activate the zone set.

Each DMM-enabled MSM-18/4 module on the management IP network must have a unique subnetwork address configured for VSAN 1.

Configuring IP over Fibre Channel (IPFC) for an MSM-18/4 module consists of the following tasks:

Create the VSAN 1 interface and configure an IP address for this interface.

The IP subnet can use a private address space because these addresses will not be advertised. As noted, the subnet number needs to be unique for each MSM-18/4 module enabled MDS switch that is connected to the same management IP subnetwork.

Create a CPP interface (with an IP address) on each MSM-18/4 module on the switch.

CPP IP addresses need to be in the same subnet as the VSAN 1 interface.

Configure zoning.

The CPP interfaces and the VSAN 1 interface need to be zoned together.

Enable IPv4 routing.

Configure the default gateway for each CPP interface.

Configure the default gateway for the CPP interface to point to the VSAN 1 IP address, so that all IP traffic from the CPP interface is routed to the management interface.

For additional information about creating and activating a zone set, refer to the Cisco DCNM for SAN Security Configuration Guide and the Cisco MDS 9000 Family NX-OS Security Configuration Guide.


Note Beginning with Cisco MDS NX-OS Release 4.2(1) the default gateway for the CPP interface can be configured on DCNM for SAN. For more information, refer to the Cisco DCNM for SAN IP Services Configuration Guide.


Configure static routes as required to access the peer MSM-18/4 modules.

Configure static routes in the switch to each MSM-18/4 enabled peer module to enable routing of packets between peer MSM-18/4 modules.

Figure 2-1 IP Configuration

The following example is based on the configuration and subnetwork numbers. (See Figure 2-1.)

The example shows the configuration for MDS 9222i switch1:

Create VSAN 1 and configure it with an IP address:

switch# configure terminal
switch(config)# interface vsan 1
switch(config-if)# ip address 10.10.1.1 255.255.255.0
switch(config-if)# no shutdown
switch(config-if)# exit
 
   

Create the CPP IPFC interface, and configure an IP address:

switch(config)# interface cpp 8/1/1
switch(config-if)# ip address 10.10.1.6 255.255.255.0
switch(config-if)# no shutdown
switch(config-if)# exit
 
   

Configure a new zone to include the pWWN of the CPP interface on the MSM-18/4 module and the VSAN 1 interface on the supervisor:

switch(config)# zone name DMM_IP_MGMT vsan 1 
switch(config-zone)# member pwwn 22:00:00:20:37:39:15:09
switch(config-zone)# member pwwn 21:00:00:e0:8b:05:76:28
switch(config-zone)# exit
 
   

Enable IPv4 routing:

switch(config)# ip routing
 
   

Configure the default gateway for the MSM-18/4 modules:

switch(config)# ip default-gateway 10.10.1.1 interface cpp 8/1/1
 
   

Configure static route to access the peer MSM-18/4 modules:

switch(config)# ip route 10.10.2.0 255.255.255.0 172.22.43.95
 
   

You can also create a host specific route to point to the IPFC interface on the peer:

ip route 10.10.2.1 255.255.255.255 172.22.43.95
 
   

The following example shows the configuration for MDS 9222i switch2 (Figure 2-1):

switch# configure terminal
switch(config)# interface vsan 1
switch(config-if)# ip address 10.10.2.1 255.255.255.0
switch(config-if)# no shutdown
switch(config-if)# exit
 
   
switch(config)# interface cpp 4/1/1
switch(config-if)# ip address 10.10.2.7 255.255.255.0
switch(config-if)# no shutdown
switch(config-if)# exit
 
   
switch(config)# zone name DMM_IP_MGMT vsan 1 
switch(config-zone)# member pwwn 22:00:00:20:25:19:25:11
switch(config-zone)# member pwwn 21:00:00:c0:7d:76:04:15
switch(config-zone)# exit
 
   
switch(config)# ip routing
 
   
switch(config)# ip default-gateway 10.10.2.1 interface cpp 4/1/1
 
   
switch(config)# ip route 10.10.1.0 255.255.255.0 172.22.43.94

For additional information about configuring IPFC, refer to the Cisco DCNM for SAN IP Services Configuration Guide and the Cisco MDS 9000 Family NX-OS IP Services Configuration Guide.

Configuring IP Connectivity for MDS 9222i Switches

Configuring IPFC for an MDS 9222i switch (without an MSM-18/4 module in slot 2) includes the following tasks:

Create the VSAN 1 interface and configure an IP address for this interface.

switch# configure terminal
switch(config)# interface vsan 1
switch(config-if)# no shutdown
switch(config-if)# ip address 10.1.1.1 255.255.255.0
switch(config-if)# exit
 
   

A CPP IPFC interface does not need to be created for this module.

Use the show interface command to verify if the VSAN 1 interface is online.

switch# show interface vsan 1
vsan1 is up, line protocol is up
WWPN is 10:00:00:0d:ec:39:08:01, FCID is 0x33000d
Internet address is 10.1.1.1/24
 
   

A VSAN is online only if there is at least one other device logged into the VSAN.

If VSAN 1 does not have any other devices except the VSAN 1 interface, VSAN 1 will be offline and the following outputs are displayed for the show and ping commands:

switch# show interface vsan 1
vsan1 is up, line protocol is down (port down)
WWPN is 10:00:00:0d:ec:4a:ba:01, FCID not assigned
Internet address is 10.1.3.1/24
MTU 1500 bytes, BW 1000000 Kbit
0 packets input, 0 bytes, 0 errors, 0 multicast
0 packets output, 0 bytes, 0 errors, 0 dropped 
switch# show fcns database vsan 1 
There are no entries in the database
 
   
switch# show flogi database vsan 1
No flogi sessions found.
switch# ping 10.1.3.1
interface is down
 
   

To bring VSAN 1 to the online status, configure another device to log into VSAN 1.

switch# configure terminal
switch(config)# vsan database
switch(config-vsan-db)# interface fc1/4
switch(config-if)# terminal monitor
switch(config-if)# no shutdown
 
   

Use the show interface and ping commands to view the status and the information of VSAN 1.

switch# show interface vsan 1
vsan1 is up, line protocol is up
WWPN is 10:00:00:0d:ec:4a:ba:01, FCID is 0x1e0003
Internet address is 10.1.3.1/24
MTU 1500 bytes, BW 1000000 Kbit
0 packets input, 0 bytes, 0 errors, 0 multicast
6 packets output, 384 bytes, 0 errors, 0 dropped 
 
   
switch# ping 10.1.3.1
PING 10.1.3.1 (10.1.3.1) 56(84) bytes of data.
64 bytes from 10.1.3.1: icmp_seq=1 ttl=64 time=0.075 ms
64 bytes from 10.1.3.1: icmp_seq=2 ttl=64 time=0.073 ms

Configuring Cisco MDS DMM Using the DCNM for SAN GUI

When a migration job is created, you can configure the migration rate as fast, medium, or slow. Use the DCNM-SAN GUI to configure the values for these rates, as described in the following sections:

Enabling Cisco MDS DMM with DCNM for SAN

Configuring Migration Rate Using DCNM for SAN

Using the Cisco MDS DMM Pre-Configuration Wizard

Configuring MDS Modules for DMM

Enabling Cisco MDS DMM with DCNM for SAN

Detailed Steps

To enable Cisco MDS DMM for the MSM-18/4 module or MDS 9222i switch using DCNM-SAN, and to provision ports to use the DMM service, follow these steps:


Step 1 Expand Intelligent Features and then double-click the Data Mobility Manager folder in the Physical Attributes pane.

Choose an SSM or MSM to provision DMM.

a. For SSM, click the SSM tab.

You see the set of configured services in the Information pane.

b. For MSM, click the MSM tab.

You see the set of configured services in the Information pane.

Step 2 Click the Create Row icon (third button in the tool bar, directly above the SSM or the MSM tab).

You see the Create SSM dialog box.

Step 3 Select the switch and SSM module where you want to enable DMM.

Step 4 The Use All Ports on Module check box is checked by default. DMM does not support provisioning a subset of the ports on the card to use this service.

Step 5 From the feature drop-down list, select dmm.

Step 6 Click Create to enable the DMM service.


Configuring Migration Rate Using DCNM for SAN

Detailed Steps

To configure the values to associate with the fast, medium, and slow migration rates, follow these steps:


Step 1 Expand Intelligent Features and then double-click the Data Mobility Manager folder in the Physical Attributes pane.

You see the SSM or MSM services in the Information pane.

Step 2 Click the DMM Rate tab.

You see the set of configured services in the Information pane.

Step 3 Click in the table cell that you are configuring (Fast, Medium, or Slow).

Step 4 Enter the new value for the migration rate. The units are MB/s.

Step 5 Click the Save button to save the configuration values.



Note While configuring DMM with two hosts accessing the same storage port on a per-job basis, the rate limit that gets applied will be the lower configured rate because the configured rate is the total bandwidth per existing storage port and not per job. Hosts with active sessions will have this bandwidth shared between them.


Using the Cisco MDS DMM Pre-Configuration Wizard

Although Cisco NX-OS Release 5.0(1a) does not support the SSM, DCNM for SAN Release 5.0(1a) can be used to used to configure an SSM running on the SAN-OS Release 3.x or NX-OS Release 4.x software.The DMM Pre-Configuration Wizard performs the following steps so that the DMM-capable module is ready to run the DMM jobs:

1. Configures SSH by doing the following:

Enables SSH.

Creates key.

2. Configures IP connectivity:

Creates the VSAN 1 interface and configures IP.

Creates the CPP IPFC interface and configures IP.

3. Enables IPv4 routing.

4. Configures the IP default gateway for the MSM-18/4 module or the MDS 9222i switch.

5. Configures static route-to-peer MSM-18/4 module or the MDS 9222i switch (dual fabric only).

6. Configures a zone to include the pWWN of the MSM-18/4 modules or MDS 9222i switches and the supervisor module.

7. Enables the DMM feature.

In the DMM Pre-Configuration Wizard, when you click Next at each step, the configuration listed for that step will be preformed. For most steps, the Back button is disabled in the wizard. However, if an error occurs at any step, you are prevented from moving to the next step until you modify the data and click Next again successfully.

If you click Cancel, the wizard exits at the step without undoing any of the settings performed by the previous steps. The Back option will not be available for the steps in this wizard.

To use the DMM Pre-Configuration Wizard, launch the DCNM-SAN GUI after selecting the required fabric.


Note Before you use the DMM Pre-Configuration Wizard, install the DMM package with the SSI image in the switch. SSH is enabled by the DMM pre-configuration setup.


To display the DMM Pre-Configuration Wizard, from the DCNM-SAN menu, choose Tools > Data Mobility Manager>Pre-configuration.

Configuring MDS Modules for DMM

Restrictions

Zoning is not required for the MDS 9222i switch fixed slot because it is also a supervisor and does not need to be zoned with the supervisor's VSAN 1 WWN to allow communication.

If the VSAN 1 IP address is already configured for the switch, then the switch does not appear in the drop-down list.

If all the switches already have their VSAN 1 IP address configured, then a message is displayed. Once you click Next, the IPv4 routing is configured.

Detailed Steps

To configure MDS modules for DMM, in the DMM Pre-Configuration Wizard screen follow these steps:


Step 1 Select the DMM-capable modules that you want to configure and click Next.

The Modules for Set Up screen displays only the switch and modules that do not have the DMM feature enabled. The switch must be running Cisco NX-OS Release 4.2 or later. This wizard cannot be used to edit existing configurations.

Step 2 The Enable Secure Shell (SSH) screen displays a list of DMM switches.

The table indicates if SSH is enabled and if the key already exists.

a. Click Next.

The SSH key is created if the key does not exist already. SSH is enabled. The SSH key is created for protocol RSA with a numbits value of 1024.


Note If SSH is already enabled on all the switches, then the "No action necessary" message is displayed. Click Next to continue.


Step 3 Select a switch from the drop-down list to configure the IP address and mask for the VSAN 1 interface.

a. Click Add.

The switch moves from the drop-down list to the table. One entry can be added for each switch.

b. Click Next.

The IP address is created and the IPv4 routing is enabled for all the switches that are selected.

If you do not add a VSAN 1 IP address for all the switches in the list and click Next, an error message is displayed.

Step 4 Select a switch module from the drop-down list and specify the CPP IP address and mask.

The Configure Module IP connectivity screen sets the IP address for CPP and configures the default gateway for the CPP interface to point to the VSAN 1 IP address. All IP traffic from the CPP interface is routed to the management interface.

a. Click Add to move the switch module from the drop-down list to the table.

The CPP IP address must be in the same subnet as the VSAN 1 IP address or an error message is displayed. Only one entry can be added for each switch module.

b. Click View necessary gateways.

The Necessary Default Gateways screen is displayed. The Necessary Default Gateways screen shows the VSAN 1 IP address that will be used to configure the default gateways for each of the switch modules. It also shows if a default gateway already exists.

c. Click Close to return to the Configure Module IP connectivity screen.

d. Click Next in the Configure Module IP connectivity screen.

The IP address is created and the gateway is configured.


Note The valid mask values are 8, 16, 24, or 32.

If the CPP IP address is already configured for the switch module, then the module does not appear in the drop-down list.

The MDS 9222i switch is not displayed in the drop-down list because it is not necessary to set a separate CPP IP address or default gateway for the MDS 9222i fixed slot.

If all of the switch modules already have their CPP IP addresses configured, then a message is displayed. Click Next. The necessary default gateways are configured.


Step 5 In the Configure Route to Peer screen, select a switch module and peer switch module from the drop-down lists.

This screen configures static routes in the switch to each DMM-enabled peer node to enable routing of packets between the peer MSM-18/4 modules or MDS 9222i switches.

a. Click Add.

The selected switch module and peer switch modules are displayed in the Switch, Module table area.

b. Click Next.

The appropriate routes are created. The routes are created on the local management interface to the peer subnet through this peer management interface.


Note This step is optional and does not need to be performed if you do not need multiple fabric job support. However, if you require multiple fabric job support, check the Multiple Fabric Job Support check box. The other fields are enabled only when this box is selected.

If creating routes fails due to a conflict, an error message is displayed.


Step 6 In the Zoning screen, click Create/Activate Zones.

The wizard goes through the fabrics to create the zones.

Before creating the zones, the wizard checks if the active and local zone databases match. If there is a mismatch, an input dialog box is displayed. You will be prompted to copy the active zone database to the local zone database. If you click Yes, the zones are created on the principal switch for the fabric. If you click No, the zone creation is skipped for the zone mismatched fabric. After the zone creation is completed, a pop-up dialog box is displayed that specifies if the zone creation process was successful or if it failed.

If there is an error during zone creation, the Create/Activate Zones button is enabled. Click Create/Activate Zones again to create the zones that failed previously. Only the zones that failed previously will be created to avoid any duplicate entries in the zones database.

Once all the zones are created successfully on all the fabrics, the Create/Activate Zones button is disabled and the Status button is enabled.

(Optional) If you want to do the zoning yourself, follow these steps:

a. Click Next without clicking Create/Activate Zones.

A warning message is displayed stating that the Zones are not created, and asks if you want to continue to the next step without creating zones.

b. Click Yes to continue.

The Status button allows you to verify that the zones were added to the active zone database.


Note Zoning is not required for the MDS 9222i switch fixed slot because it is also a supervisor and does not need to be zoned with the supervisor's VSAN 1 WWN to allow communication.


The Zoning screen creates a zone to include the VSAN 1 WWN and the module WWN for each of the selected module.

The Zone Creation Status screen shows all the zones in the active zone database.

Step 7 Click Finish to complete the DMM Pre-Configuration Wizard setup.


Note The DMM Pre-Configuration Wizard enables the DMM functionality for all the ports and nodes on the modules selected.


A message appears that shows the status of the setup as success or as a failure. If successful, the Finish button is disabled and the Cancel button changes to Close.

Click Close to close the DMM Pre-Configuration Wizard.

Filed Descriptions for DMM CLI Software

LUN Discover

Field
Description

StartDiscovery

If Local, then only the directly attached SCSI target devices/ports and LUNs associated with them on all VSANs will be discovered. If Remote, then all SCSI target devices/ports and LUNs associated with them on all VSANs in the whole fabric, except the directly attached ones, will be discovered.

Type

Selecting targets results in only targets being discovered, without the NS results in both targets and LUNs being discovered.

OS

Specifies the operating system on which the LUNs need to be discovered.

Status

Indicates the outcome of the LUN discovery on the local switch. Contains the status of the most recent discovery.

inProgress(1)—Indicates that the discovery is still in progress.

completed(2)—Indicates that the discovery is complete.

failure(3)— Indicates that the discovery encountered a failure.

CompleteTime

When the last discovery was completed. The value will be zero or N/A, if discovery has not been performed since the last system restart.


Feature History for DMM Software

Table 2-2 lists the release history for this feature.

Table 2-2 Feature History for DMM Software 

Feature Name
Releases
Feature Information

DMM Pre-Configuration Wizard

5.0(1a)

In Release 5.0(1a), steps were added to configure the MDS modules using the DMM Pre-Configuration Wizard.

This Wizard allows you to configure the MDS modules for DMM.

CPP and default gateway

4.2(1)

In Release 4.2(1), a note was added about configuring the CPP interface default gateway on the DCNM-SAN.