Guest

Cisco Industrial Ethernet 2000U Series Switches

Parallel Redundancy Protocol Software Configuration Guide for IE 2000U Series Switches

  • Viewing Options

  • PDF (143.6 KB)
  • Feedback

Table Of Contents

Parallel Redundancy Protocol Software Configuration Guide for IE 2000U Series Switches

Information About PRP

Role of the Switch

Key Terms

Prerequisites

Guidelines and Limitations

Default Settings

Upgrade Procedure

Configuring PRP

Creating a PRP Channel and Group

General Usage Precision Time Protocol (PTP) Enable on LAN A Channel

Disabling the PRP Channel and Group

Verifying Configuration

Related Documents

Feature History


Parallel Redundancy Protocol Software Configuration Guide for IE 2000U Series Switches


Published: January 23, 2013
OL-31424-01

This chapter provides details about configuring the Parallel Redundancy Protocol (PRP) on the
Cisco Industrial Ethernet 2000 Series Switches (IE 2000U) for operation within a Utility Substation Automation network.


Note Not all versions of IE 2000U support the PRP feature. Refer to "Feature History" section


This chapter includes the following sections:

Information About PRP

Prerequisites

Guidelines and Limitations

Default Settings

Upgrade Procedure

Configuring PRP

Verifying Configuration

Related Documents

Feature History

Information About PRP

PRP allows a data communication network to prevent data transmission failures by providing network nodes two alternate paths for the traffic to reach its destination. Two local area networks (LANs) provide alternate paths for the traffic over independent LAN segments. However, the two LANs must share a similar topology.

Role of the Switch

An IE 2000U operating with PRP has a Gigabit Ethernet port connection to each of the two LANs. The switch sends two packets simultaneously to each LAN through the two different ports to its destination node. When the destination node receives the first packet successfully, it discards the second packet if it also arrives successfully as well. Each packet sent includes an incremented sequence number that helps the destination node distinguish between duplicate packets.

Key Terms

The following terms are relevant when you configure PRP on the switch:

PRP channel- A logical interface that aggregates PRP groups (access, trunk or routed) into a single link. The PRP channel remains up as long as both of its member ports remains up and send traffic. When both member ports are down, the channel is down. Only the up and down states of the ports can trigger different redundancy behavior or SAN traffic routing decisions.

Within each channel group, the lowest number Gigabit Ethernet interface (Gi0/1), will always be the primary port and the higher number Gigabit Ethernet (Gi0/2) interface is the secondary port.

Each channel contains two Layer 2 or Layer 3 Gigabit Ethernet interfaces.

PRP group-A group is composed of two ports, one of which represents LAN A and the other LAN B. PRP group 1 always contains the Gi0/1 and Gi0/2 interfaces.

Prerequisites

Must have FPGA version 3.6 to support PRP.

Guidelines and Limitations

PRP traffic load cannot exceed 90% bandwidth of the Gigabit Ethernet and Fast Ethernet interface channels.

PRP does not support third-party systems.

Up to 2 PRP channels are supported on the IE 2000U 16-port switches with the exception of the IE-2000U-16TC-GP, which supports only one PRP channel.

You can configure PRP on Gigabit Ethernet and Fast Ethernet uplink interfaces.

A PRP channel must have two active ports configured within a channel to remain active and maintain redundancy.

Both interfaces within a channel group must have the same configuration.

For Layer 3, you must configure the IP address on the PRP channel interface.

Precision Time Protocol (PTP), when enabled, traverses PRP within LAN A only.

Load-balancing is not supported.

LLDP and CDP must be disabled on a system level.

Default Settings

None.

Upgrade Procedure

To upgrade your IE 2000U software, follow these steps:

1. Copy image to flash, for example: copy scp: flash: or copy tftp:flash:

2. Configure auto boot: no boot manual

3. Save the configuration: copy r s

4. Archive download-sw: /force-reload flash:ie2000u-ipserviceslmk9-tar.150-2.0.5.EK.tar

5. Wait until extract completes.

6. System reloads and automatically upgrades the FPGA.

7. System reloads automatically.

Configuring PRP

This section includes the following topics:

Creating a PRP Channel and Group

General Usage Precision Time Protocol (PTP) Enable on LAN A Channel

Disabling the PRP Channel and Group

Creating a PRP Channel and Group

To create and enable a PRP channel and group on the switch, follow the steps in this section.

BEFORE YOU BEGIN

Review the Prerequisites and Guidelines and Limitations sections.

DETAILED STEPS

 
Command
Purpose

Step 1 

configure terminal

Enters the global configuration mode.

Step 2 

[no] interface range {GigabitEthernet0/1-2 | FastEthernet0/17-18}

Assigns either two Gigabit Ethernet interfaces or two Fast Ethernet interfaces to the PRP channel group.

Note You must apply the Gi0/1 interface before the Gi0/2 interface. So, we recommend using the interface range command. Similarly, you must apply the FE0/17 interface before the FE0/18 interface.

Note A PRP channel must be composed of two Gigabit Ethernet interfaces or two Fast Ethernet interfaces. You cannot configure a mix interface types.

The no form of this command shutdowns PRP on the defined interface.

Step 3 

[no] switchport

For Layer 3 traffic, enter no switchport.

(Optional) For Layer 2 traffic, enter switchport. (Default).

Step 4 

switchport mode access vlan

(Optional) Creates a VLAN for the Gi0/1-2 interfaces.

Note Only required for Layer 2 traffic.

Step 5 

prp-channel-group prp-channel group

Enters a sub-interface mode and creates a PRP channel group.

prp-channel group-Value of 1 or 2.

You must assign two interfaces to a channel group.

The no form of this command is not supported.

Step 6 

no ptp enable

Disables Precision Time Protocol (PTP) on the switch.

Step 7 

no keepalive

Disables loop detection for the redundancy channel.

Step 8 

no shutdown

Brings up the PRP channel.

EXAMPLE

This example shows how to create a PRP channel on the switch, create a PRP channel group, and assign two ports to that group.

router# configure terminal
router(config)# interface range GigabitEthernet0/1-2
router(config-if)# prp-channel-group 1
router(config-if)# no ptp enable
router(config-if)# no keepalive
router(config-if)# no shutdown
 
 

This example shows how to create a PRP channel on the switch with a VLAN ID of 2.

router# configure terminal
router(config)# interface range GigabitEthernet0/1-2
router(config-if)# switchport
router(config-if)# switchport mode access vlan 2
router(config-if)# prp-channel-group 1
router(config-if)# no ptp enable
router(config-if)# no keepalive
router(config-if)# no shutdown
 
 

This example shows how to create a PRP channel on a switch configured with Layer 3.

router# configure terminal
router(config)# interface range GigabitEthernet0/1-2
router(config-if)# no switchport
router(config-if)# prp-channel-group 1
router(config-if)# no ptp enable
router(config-if)# no keepalive
router(config-if)# no shutdown
router(config-if)# exit
router(config)# interface prp-channel 1
router(config)# ip address 192.0.0.2 255.255.255.0

General Usage Precision Time Protocol (PTP) Enable on LAN A Channel

PTP traffic traverses PRP within LAN A only.

 
Command
Purpose

Step 1 

configure terminal

Enters the global configuration mode.

Step 2 

interface range {gi0/1-2 | fe0/17-18}

Specifies the two Gigabit Ethernet interfaces in the PRP channel that you want to modify and enters interface mode.

Step 3 

ptp enable

Enables PTP on the interface.

Step 4 

exit

Exits interface mode

Disabling the PRP Channel and Group

 
Command
Purpose

Step 1 

configure terminal

Enters the global configuration mode.

Step 2 

no interface prp-channel prp-channel-number

Disables the PRP channel.

prp-channel number-Value of 1 or 2.

Step 3 

exit

Exits the interface mode.

Verifying Configuration

Command
Purpose

show prp statistics {egressPacketStatistics | pauseFrameStatistics | nodeTableStatistics | ingressPacketStatistics | ptpPacketStatistics}

Displays statistics for PRP components.

show prp control {prpProfile | ptpLanOption | supervisionFrameOption | supervisionFrameTime | supervisionFrameLeifCheckInternal | supervisionFrameRedboxMacaddress | pauseFrameTime }

Displays PRP control information.

show prp channel {1 | 2} [detail | status | summary] | detail | status | summary] }

Displays configuration details for a specified PRP channel.

show control

Displays PRP control information VDAN table and supervision frame information.

show statistics

Displays ingress, egress, node table, and pause frame statistics.


Related Documents

Refer to IEC 62439-3 on Parallel Redundancy Protocol.

Cisco CGS 2520 Switch Software Configuration Guide for IOS Release 15.0(2)SE for configuration details for the Precision Time Protocol.

Feature History

Feature Name
Release
Feature Information

Parallel Redundancy Protocol

Cisco IOS Release 15.0(2)EK

Initial support on the following IE 2000U platforms:

IE-2000U-8TC-G

IE-2000U-16TC-G

IE-2000U-16TC-GP

IE-2000U-16TC-G-X