Cisco Catalyst Switch Module 3110 and 3012 for IBM BladeCenter Command Reference, Release 12.2(58)SE
Index
Downloads: This chapterpdf (PDF - 710.0KB) The complete bookPDF (PDF - 9.08MB) | Feedback

Index

Table Of Contents

A - B - C - D - E - F - G - H - I - L - M - N - O - P - Q - R - S - T - U - V -

Index

A

aaa accounting dot1x command 2-1

aaa authentication dot1x command 2-3

aaa authorization network command 2-5, 2-24, 2-30, 2-32, 2-34, 2-36, 2-38, 2-145, 2-312, B-7, B-32

AAA methods 2-3

access control entries

See ACEs

access control lists

See ACLs

access groups

IP 2-195

access list, IPv6 2-269

access map configuration mode 2-338

access mode 2-781

access ports 2-781

ACEs 2-129, 2-415

ACLs

deny 2-127

for non-IP protocols 2-316

IP 2-195

matching 2-338

on Layer 2 interfaces 2-195

permit 2-413

action command 2-6

aggregate-port learner 2-402

allowed VLANs 2-801

archive copy-sw command 2-8

archive download-sw command 2-11

archive tar command 2-15

archive upload-sw command 2-18

arp (boot loader) command A-2

arp access-list command 2-20

authentication command disable-port ignore 2-23

authentication control-direction command 2-24

authentication event command 2-26

authentication failed VLAN

See dot1x auth-fail vlan

authentication fallback command 2-30

authentication host-mode command 2-32

authentication mac-move permit command 2-34

authentication open command 2-36

authentication order command 2-38

authentication periodic command 2-40

authentication port-control command 2-42

authentication priority command 2-44

authentication timer command 2-46

authentication violation command 2-48

auth-fail max-attempts

See dot1x auth-fail max-attempts

auth-fail vlan

See dot1x auth-fail vlan

auth open command 2-36

auth order command 2-38

authorization state of controlled port 2-162

auth timer command 2-46

autonegotiation of duplex mode 2-172

auto qos classify command 2-50

auto qos trust command 2-53

auto qos video command 2-56

auto qos voip command 2-59

B

BackboneFast, for STP 2-703

backup interfaces

configuring 2-775

boot (boot loader) command A-3

boot auto-copy-sw command 2-66

boot auto-download-sw command 2-68

boot config-file command 2-71

boot enable-break command 2-72

boot helper command 2-73

boot helper-config file command 2-74

booting

Cisco IOS image 2-77

interrupting 2-72

manually 2-75

boot loader

accessing A-1

booting

Cisco IOS image A-3

helper image 2-73

directories

creating A-19

displaying a list of A-8

removing A-23

displaying

available commands A-13

memory heap utilization A-14

version A-30

environment variables

described A-24

displaying settings A-24

location of A-25

setting A-24

unsetting A-28

files

copying A-6

deleting A-7

displaying a list of A-8

displaying the contents of A-5, A-20, A-27

renaming A-21

file system

formatting A-11

initializing flash A-10

running a consistency check A-12

prompt A-1

resetting the system A-22

boot manual command 2-75

boot private-config-file command 2-76

boot system command 2-77

BPDU filtering, for spanning tree 2-704, 2-738

BPDU guard, for spanning tree 2-706, 2-738

broadcast storm control 2-759

C

cat (boot loader) command A-5

CDP, enabling protocol tunneling for 2-295

channel-group command 2-79

channel-protocol command 2-83

Cisco IP camera

auto-QoS configuration 2-56

Cisco SoftPhone

auto-QoS configuration 2-59

trusting packets sent from 2-379

Cisco Telepresence System

auto-QoS configuration 2-56

CISP

See Client Information Signalling Protocol

cisp

debug platform cisp command B-32

cisp enable command 2-84

class command 2-85

class-map command 2-88

class maps

creating 2-88

defining the match criteria 2-340

class of service

See CoS

clear dot1x command 2-90

clear eap command 2-91

clear errdisable interface 2-92

clear ip arp inspection log command 2-93

clear ip arp inspection statistics command 2-94

clear ipc command 2-99

clear ip dhcp snooping database command 2-95, 2-97

clear ipv6 dhcp conflict command 2-100

clear l2protocol-tunnel counters command 2-101

clear lacp command 2-102

clear logging command 2-103

clear mac address-table command 2-104, 2-105

clear nmsp statistics command 2-106

clear pagp command 2-107

clear port-security command 2-108

clear psp counter 2-110

clear psp counter command 2-110

clear spanning-tree counters command 2-111

clear spanning-tree detected-protocols command 2-112

clear vmps statistics command 2-113

clear vtp counters command 2-114

Client Information Signalling Protocol 2-84, 2-145, B-7, B-32

command modes defined 1-2

configuration files

password recovery disable considerations A-1

specifying the name 2-71, 2-76

configuring multiple interfaces 2-191

config-vlan mode

commands 2-825

entering 2-824

copy (boot loader) command A-6

copy logging onboard command 2-115

CoS

assigning default value to incoming packets 2-349

assigning to Layer 2 protocol packets 2-298

overriding the incoming value 2-349

CoS-to-DSCP map 2-353

crashinfo files 2-182

critical VLAN 2-27

D

debug authentication B-2

debug auto qos command B-4

debug backup command B-6

debug cisp command B-7

debug dot1x command B-8

debug dtp command B-9

debug eap command B-10

debug etherchannel command B-11

debug fastethernet command B-12

debug interface command B-15

debug ip dhcp snooping command B-13

debug ip igmp filter command B-16

debug ip igmp max-groups command B-17

debug ip igmp snooping command B-18

debug ip verify source packet command B-14

debug lacp command B-19

debug lldp packets command B-20

debug mac-notification command B-21

debug matm command B-22

debug matm move update command B-23

debug monitor command B-24

debug mvrdbg command B-25

debug nmsp command B-26

debug nvram command B-27

debug pagp command B-28

debug platform acl command B-29

debug platform backup interface command B-31

debug platform cisp command B-32

debug platform cli-redirection main command B-33

debug platform configuration command B-34

debug platform cpu-queues command B-35

debug platform device-manager command B-37

debug platform dot1x command B-38

debug platform etherchannel command B-39

debug platform fallback-bridging command B-40

debug platform forw-tcam command B-41

debug platform ip arp inspection command B-42

debug platform ipc command B-51

debug platform ip dhcp command B-43

debug platform ip igmp snooping command B-44

debug platform ip multicast command B-46

debug platform ip unicast command B-48

debug platform ip wccp command B-50

debug platform led command B-52

debug platform matm command B-53

debug platform messaging application command B-54

debug platform phy command B-56

debug platform pm command B-58

debug platform port-asic command B-60

debug platform port-security command B-61

debug platform qos-acl-tcam command B-62

debug platform remote-commands command B-63

debug platform resource-manager command B-64

debug platform snmp command B-65

debug platform span command B-66

debug platform stack-manager command B-67

debug platform supervisor-asic command B-68

debug platform sw-bridge command B-69

debug platform tcam command B-70

debug platform udld command B-73

debug platform vlan command B-74

debug pm command B-75

debug port-security command B-77

debug qos-manager command B-78

debug spanning-tree backbonefast command B-81

debug spanning-tree bpdu command B-82

debug spanning-tree bpdu-opt command B-83

debug spanning-tree command B-79

debug spanning-tree mstp command B-84

debug spanning-tree switch command B-86

debug spanning-tree uplinkfast command B-88

debug sw-vlan command B-89

debug sw-vlan ifs command B-91

debug sw-vlan notification command B-92

debug sw-vlan vtp command B-94

debug udld command B-96

debug vqpc command B-98

define interface-range command 2-117

delete (boot loader) command A-7

delete command 2-119

deny (ARP access-list configuration) command 2-120

deny (IPv6) command 2-122

deny command 2-127

detect mechanism, causes 2-175

DHCP snooping

accepting untrusted packets from edge switch 2-227

enabling

on a VLAN 2-233

option 82 2-225, 2-227

trust on an interface 2-231

error recovery timer 2-179

rate limiting 2-230

DHCP snooping binding database

binding file, configuring 2-223

bindings

adding 2-221

deleting 2-221

clearing database agent statistics 2-95, 2-97

database agent, configuring 2-223

renewing 2-445

dir (boot loader) command A-8

directories, deleting 2-119

domain name, VTP 2-840

dot1x auth-fail max-attempts 2-139

dot1x auth-fail vlan 2-141

dot1x command 2-137

dot1x control-direction command 2-143

dot1x credentials (global configuration) command 2-145

dot1x critical global configuration command 2-146

dot1x critical interface configuration command 2-148

dot1x default command 2-150

dot1x fallback command 2-151

dot1x guest-vlan command 2-152

dot1x host-mode command 2-154

dot1x initialize command 2-155

dot1x mac-auth-bypass command 2-156

dot1x max-reauth-req command 2-158

dot1x max-req command 2-160

dot1x pae command 2-161

dot1x port-control command 2-162

dot1x re-authenticate command 2-164

dot1x reauthentication command 2-165

dot1x supplicant force-multicast command 2-166

dot1x timeout command 2-167

dot1x violation-mode command 2-170

dropping packets, with ACL matches 2-6

drop threshold, Layer 2 protocol tunneling 2-295

DSCP-to-CoS map 2-353

DSCP-to-DSCP-mutation map 2-353

DTP 2-782

DTP flap

error detection for 2-175

error recovery timer 2-179

DTP negotiation 2-786

dual IPv4 and IPv6 templates 2-408

duplex command 2-172

dynamic-access ports

configuring 2-771

restrictions 2-772

dynamic ARP inspection

ARP ACLs

apply to a VLAN 2-203

define 2-20

deny packets 2-120

permit packets 2-406

clear

log buffer 2-93

statistics 2-94

enable per VLAN 2-213

error detection for 2-175

error recovery timer 2-179

log buffer

clear 2-93

configure 2-207

rate-limit incoming ARP packets 2-205

statistics

clear 2-94

trusted interface state 2-209

type of packet logged 2-214

validation checks 2-211

dynamic auto VLAN membership mode 2-781

dynamic desirable VLAN membership mode 2-781

Dynamic Host Configuration Protocol (DHCP)

See DHCP snooping

Dynamic Trunking Protocol

See DTP

E

EAP-request/identity frame

maximum number to send 2-160

response time before retransmitting 2-167

encapsulation methods 2-801

epm access-control open 2-174

errdisable detect cause command 2-175

errdisable detect cause small-frame comand 2-177

errdisable recovery cause small-frame 2-181

errdisable recovery command 2-179

error disable detection 2-175

EtherChannel

assigning Ethernet interface to channel group 2-79

creating port-channel logical interface 2-189

debug EtherChannel/PAgP, display B-11

debug platform-specific events, display B-39

enabling Layer 2 protocol tunneling for

LACP 2-296

PAgP 2-296

UDLD 2-296

EtherChannel (continued)

LACP

clearing channel-group information 2-102, 2-103

debug messages, display B-19

modes 2-79

port priority for hot-standby ports 2-299

restricting a protocol 2-83

system priority 2-301

load-distribution methods 2-424

PAgP

aggregate-port learner 2-402

clearing channel-group information 2-107

debug messages, display B-28

error detection for 2-175

error recovery timer 2-179

learn method 2-402

modes 2-79

physical-port learner 2-402

priority of interface for transmitted traffic 2-404

Ethernet Management port, debugging B-12

exception crashinfo command 2-182, 2-187

extended-range VLANs

and allowed VLAN list 2-801

and pruning-eligible list 2-801

configuring 2-824

extended system ID for STP 2-712

F

fallback profile command 2-183

fan information, displaying 2-518

file name, VTP 2-840

files, deleting 2-119

flash_init (boot loader) command A-10

flexible authentication ordering 2-38

Flex Links

configuring 2-775

flowcontrol command 2-185

format (boot loader) command A-11

forwarding packets, with ACL matches 2-6

forwarding results, display C-9

frame forwarding information, displaying C-9

front-end controller counter and status information C-11

fsck (boot loader) command A-12

G

global configuration mode 1-2, 1-4

H

health monitoring diagnostic tests 2-130

help (boot loader) command A-13

hierarchical policy maps 2-422

host connection, port configuration 2-780

host ports, private VLANs 2-784

I

IEEE 802.1Q trunk ports and native VLANs 2-831

IEEE 802.1Q tunnel ports

configuring 2-781

limitations 2-782

IEEE 802.1x

and switchport modes 2-782

violation error recovery 2-179

See also port-based authentication

IGMP filters

applying 2-236

debug messages, display B-16

IGMP groups, setting maximum 2-238

IGMP maximum groups, debugging B-17

IGMP profiles

creating 2-240

IGMP snooping

adding ports as a static member of a group 2-256

enabling 2-242

enabling the configurable-leave timer 2-244

enabling the Immediate-Leave feature 2-253

flooding query count 2-250

interface topology change notification behavior 2-252

querier 2-246

query solicitation 2-250

report suppression 2-248

switch topology change notification behavior 2-250

images

See software images

Immediate-Leave processing

IGMP 2-253

IPv6 2-291

MVR 2-389

interface configuration mode 1-2, 1-4

interface port-channel command 2-189

interface range command 2-191

interface-range macros 2-117

interfaces

assigning Ethernet interface to channel group 2-79

configuring 2-172

configuring multiple 2-191

creating port-channel logical 2-189

debug messages, display B-15

disabling 2-689

restarting 2-689

interface speed, configuring 2-749

interface vlan command 2-193

Internet Group Management Protocol

See IGMP

ip access-group command 2-195

ip address command 2-198

IP addresses, setting 2-198

IP address matching 2-338

ip admission command 2-200

ip admission name proxy http command 2-201

ip arp inspection filter vlan command 2-203

ip arp inspection limit command 2-205

ip arp inspection log-buffer command 2-207

ip arp inspection trust command 2-209

ip arp inspection validate command 2-211

ip arp inspection vlan command 2-213

ip arp inspection vlan logging command 2-214

ip device tracking command 2-216

ip device tracking probe command 2-218

IP DHCP snooping

See DHCP snooping

ip dhcp snooping binding command 2-221

ip dhcp snooping command 2-220

ip dhcp snooping database command 2-223

ip dhcp snooping information option allow-untrusted command 2-227

ip dhcp snooping information option command 2-225

ip dhcp snooping information option format remote-id command 2-229

ip dhcp snooping limit rate command 2-230

ip dhcp snooping trust command 2-231

ip dhcp snooping verify command 2-232

ip dhcp snooping vlan command 2-233

ip dhcp snooping vlan information option format-type circuit-id string command 2-234

ip igmp filter command 2-236

ip igmp max-groups command 2-238, 2-263, 2-265

ip igmp profile command 2-240

ip igmp snooping command 2-242

ip igmp snooping last-member-query-interval command 2-244

ip igmp snooping querier command 2-246

ip igmp snooping report-suppression command 2-248

ip igmp snooping tcn command 2-250

ip igmp snooping tcn flood command 2-252

ip igmp snooping vlan immediate-leave command 2-253

ip igmp snooping vlan mrouter command 2-254

ip igmp snooping vlan static command 2-256

IP multicast addresses 2-386

IP phones

auto-QoS configuration 2-59

trusting packets sent from 2-379

IP-precedence-to-DSCP map 2-353

ip snap forwarding command 2-258

ip source binding command 2-259

IP source guard

disabling 2-267

enabling 2-267

static IP source bindings 2-259

ip ssh command 2-261

IPv6 access list, deny conditions 2-122

ipv6 access-list command 2-269

ipv6 address dhcp command 2-271

ipv6 dhcp client request vendor command 2-272

ipv6 dhcp ping packets command 2-273

ipv6 dhcp pool command 2-275

ipv6 dhcp server command 2-277

ipv6 mld snooping command 2-279

ipv6 mld snooping last-listener-query count command 2-281

ipv6 mld snooping last-listener-query-interval command 2-283

ipv6 mld snooping listener-message-suppression command 2-285

ipv6 mld snooping robustness-variable command 2-287

ipv6 mld snooping tcn command 2-289

ipv6 mld snooping vlan command 2-291

ipv6 traffic-filter command 2-293

ip verify source command 2-267

L

l2protocol-tunnel command 2-295

l2protocol-tunnel cos command 2-298

LACP

See EtherChannel

lacp port-priority command 2-299

lacp system-priority command 2-301

Layer 2 mode, enabling 2-769

Layer 2 protocol-tunnel

error detection for 2-175

error recovery timer 2-179

Layer 2 protocol tunnel counters 2-101

Layer 2 protocol tunneling error recovery 2-296

Layer 2 traceroute

IP addresses 2-815

MAC addresses 2-812

Layer 3 mode, enabling 2-769

line configuration mode 1-3, 1-5

Link Aggregation Control Protocol

See EtherChannel

link flap

error detection for 2-175

error recovery timer 2-179

link state group command 2-303

link state track command 2-305

load-distribution methods for EtherChannel 2-424

location (global configuration) command 2-306

location (interface configuration) command 2-308

logging file command 2-310

logical interface 2-189

loopback error

detection for 2-175

recovery timer 2-179

loop guard, for spanning tree 2-714, 2-718

M

mab request format attribute 32 command 2-312

mac access-group command 2-314

MAC access list configuration mode 2-316

mac access-list extended command 2-316

MAC access lists 2-127

MAC addresses

disabling MAC address learning per VLAN 2-319

dynamic

aging time 2-318

deleting 2-104

enabling MAC address notification 2-323

enabling MAC address-table move update 2-321

matching 2-338

persistent stack 2-757

static

adding and removing 2-325

dropping on an interface 2-326

MAC address notification, debugging B-21

mac address-table aging-time 2-314, 2-338

mac address-table aging-time command 2-318

mac address-table learning command 2-319

mac address-table move update command 2-321

mac address-table notification command 2-323

mac address-table static command 2-325

mac address-table static drop command 2-326

macro apply command 2-328

macro description command 2-331

macro global command 2-332

macro global description command 2-335

macro name command 2-336

macros

adding a description 2-331

adding a global description 2-335

applying 2-332

creating 2-336

interface range 2-117, 2-191

specifying parameter values 2-332

tracing 2-332

maps

QoS

defining 2-353

VLAN

creating 2-829

defining 2-338

match (access-map configuration) command 2-338

match (class-map configuration) command 2-340

maximum transmission unit

See MTU

mdix auto command 2-343

memory (boot loader) command A-14

mgmt_clr (boot loader) command A-16

mgmt_init (boot loader) command A-17, A-18

mkdir (boot loader) command A-19

MLD snooping

configuring 2-285, 2-287

configuring queries 2-281, 2-283

configuring topology change notification 2-289

enabling 2-279

enabling on a VLAN 2-291

mls qos aggregate-policer command 2-347

mls qos command 2-345

mls qos cos command 2-349

mls qos dscp-mutation command 2-351

mls qos map command 2-353

mls qos queue-set output buffers command 2-357

mls qos queue-set output threshold command 2-359

mls qos rewrite ip dscp command 2-361

mls qos srr-queue input bandwidth command 2-363

mls qos srr-queue input buffers command 2-365

mls qos-srr-queue input cos-map command 2-367

mls qos srr-queue input dscp-map command 2-369

mls qos srr-queue input priority-queue command 2-371

mls qos srr-queue input threshold command 2-373

mls qos-srr-queue output cos-map command 2-375

mls qos srr-queue output dscp-map command 2-377

mls qos trust command 2-379

mls qos vlan-based command 2-381

mode, MVR 2-386

modes, commands 1-2

monitor session command 2-382

more (boot loader) command A-20

MSTP

interoperability 2-112

link type 2-716

MST region

aborting changes 2-722

applying changes 2-722

configuration name 2-722

configuration revision number 2-722

current or pending display 2-722

MST configuration mode 2-722

VLANs-to-instance mapping 2-722

path cost 2-724

protocol mode 2-720

restart protocol migration process 2-112

root port

loop guard 2-714

preventing from becoming designated 2-714

restricting which can be root 2-714

root guard 2-714

root switch

affects of extended system ID 2-712

hello-time 2-727, 2-734

interval between BDPU messages 2-728

interval between hello BPDU messages 2-727, 2-734

max-age 2-728

maximum hop count before discarding BPDU 2-729

port priority for selection of 2-730

primary or secondary 2-734

switch priority 2-733

state changes

blocking to forwarding state 2-741

enabling BPDU filtering 2-704, 2-738

enabling BPDU guard 2-706, 2-738

enabling Port Fast 2-738, 2-741

forward-delay time 2-726

length of listening and learning states 2-726

rapid transition to forwarding 2-716

shutting down Port Fast-enabled ports 2-738

MTU

configuring size 2-809

Multicase Listener Discovery

See MLD

multicast group address, MVR 2-389

multicast groups, MVR 2-387

multicast router learning method 2-254

multicast router ports, configuring 2-254

multicast router ports, IPv6 2-291

multicast storm control 2-759

multicast VLAN, MVR 2-386

multicast VLAN registration

See MVR

multiple hosts on authorized port 2-154

Multiple Spanning Tree Protocol

See MSTP

MVR

configuring 2-386

configuring interfaces 2-389

debug messages, display B-25

mvr (global configuration) command 2-386

mvr (interface configuration) command 2-389

mvr vlan group command 2-390

N

native VLANs 2-801

native VLAN tagging 2-831

network-policy (global configuration) command 2-392

network-policy command 2-391

network-policy profile (network-policy configuration) command 2-393

nmsp attachment suppress command 2-396

nmsp command 2-395

no authentication logging verbose 2-397

no dot1x logging verbose 2-398

no mab logging verbose 2-399

nonegotiate

DTP messaging 2-786

non-IP protocols

denying 2-127

forwarding 2-413

non-IP traffic access lists 2-316

non-IP traffic forwarding

denying 2-127

permitting 2-413

non-stop forwarding 2-400

normal-range VLANs 2-824

no vlan command 2-824

nsf command 2-400

O

online diagnostics

configuring health monitoring diagnostic tests 2-130

enabling

scheduling 2-132

syslog messages 2-130

global configuration mode

clearing health monitoring diagnostic test schedule 2-130

clearing test-based testing schedule 2-132

setting health monitoring diagnostic testing 2-130

setting test-based testing 2-132

setting up health monitoring diagnostic test schedule 2-130

setting up test-based testing 2-132

removing scheduling 2-132

scheduled switchover

disabling 2-132

enabling 2-132

setting test interval 2-132

specifying health monitoring diagnostic tests 2-130

starting testing 2-134

P

PAgP

See EtherChannel

pagp learn-method command 2-402

pagp port-priority command 2-404

password, VTP 2-841

permit (ARP access-list configuration) command 2-406

permit (IPv6) command 2-408

permit (MAC access-list configuration) command 2-413

per-VLAN spanning-tree plus

See STP

physical-port learner 2-402

PIM-DVMRP, as multicast router learning method 2-254

platform chassis-management command 2-416

police aggregate command 2-419

police command 2-417

policed-DSCP map 2-353

policy-map command 2-421

policy maps

creating 2-421

hierarchical 2-422

policers

for a single class 2-417

for multiple classes 2-347, 2-419

policed-DSCP map 2-353

traffic classification

defining the class 2-85

defining trust states 2-817

Port Aggregation Protocol

See EtherChannel

port-based authentication

AAA method list 2-3

configuring violation modes 2-170

debug messages, display B-8

enabling guest VLAN supplicant 2-140, 2-151

enabling IEEE 802.1x

globally 2-137

per interface 2-162

port-based authentication (continued)

guest VLAN 2-152

host modes 2-154

IEEE 802.1x AAA accounting methods 2-1

initialize an interface 2-155

MAC authentication bypass 2-156

manual control of authorization state 2-162

multiple hosts on authorized port 2-154

PAE as authenticator 2-161

periodic re-authentication

enabling 2-165

time between attempts 2-167

port-based authentication (continued)

quiet period between failed authentication exchanges 2-167

re-authenticating IEEE 802.1x-enabled ports 2-164

resetting configurable IEEE 802.1x parameters 2-150

switch-to-authentication server retransmission time 2-167

switch-to-client frame-retransmission number2-158to 2-160

switch-to-client retransmission time 2-167

port-channel load-balance command 2-424

Port Fast, for spanning tree 2-741

port ranges, defining 2-115, 2-117

ports, debugging B-75

ports, protected 2-799

port security

aging 2-793

debug messages, display B-77

enabling 2-788

violation error recovery 2-179

port trust states for QoS 2-379

port types, MVR 2-389

power information, displaying 2-518

priority-queue command 2-426

priority value, stack member 2-764

private-vlan command 2-428

private-vlan mapping command 2-431

private VLANs

association 2-797

configuring 2-428

configuring ports 2-784

host ports 2-784

mapping

configuring 2-797

promiscuous ports 2-784

privileged EXEC mode 1-2, 1-3

promiscuous ports, private VLANs 2-784

pruning

VLANs 2-801

VTP

enabling 2-841

pruning-eligible VLAN list 2-803

psp 2-433

psp command 2-433

PVST+

See STP

Q

QoS

auto-QoS

configuring 2-59

debug messages, display B-4

auto-QoS trust

configuring 2-53

auto-QoS video

configuring 2-56

class maps

creating 2-88

defining the match criteria 2-340

defining the CoS value for an incoming packet 2-349

DSCP transparency 2-361

DSCP trusted ports

applying DSCP-to-DSCP-mutation map to 2-351

defining DSCP-to-DSCP-mutation map 2-353

QoS (continued)

egress queues

allocating buffers 2-357

defining the CoS output queue threshold map 2-375

defining the DSCP output queue threshold map 2-377

enabling bandwidth shaping and scheduling 2-753

enabling bandwidth sharing and scheduling 2-755

limiting the maximum output on a port 2-751

mapping a port to a queue-set 2-434

mapping CoS values to a queue and threshold 2-375

mapping DSCP values to a queue and threshold 2-377

setting maximum and reserved memory allocations 2-359

setting WTD thresholds 2-359

enabling 2-345

ingress queues

allocating buffers 2-365

assigning SRR scheduling weights 2-363

defining the CoS input queue threshold map 2-367

defining the DSCP input queue threshold map 2-369

enabling the priority queue 2-371

mapping CoS values to a queue and threshold 2-367

mapping DSCP values to a queue and threshold 2-369

setting WTD thresholds 2-373

maps

defining 2-353, 2-367, 2-369, 2-375, 2-377

policy maps

applying an aggregate policer 2-419

creating 2-421

defining policers 2-347, 2-417

hierarchical 2-422

policed-DSCP map 2-353

traffic classifications 2-85

trust states 2-817

port trust states 2-379

queues, enabling the expedite 2-426

trusted boundary for IP phones 2-379

VLAN-based 2-381

quality of service

See QoS

querytime, MVR 2-386

queue-set command 2-434

R

radius-server dead-criteria command 2-435

radius-server host command 2-437

rapid per-VLAN spanning-tree plus

See STP

rapid PVST+

See STP

re-authenticating IEEE 802.1x-enabled ports 2-164

re-authentication

periodic 2-165

time between attempts 2-167

receiver ports, MVR 2-389

receiving flow-control packets 2-185

recovery mechanism

causes 2-179

display 2-92

timer interval 2-179

reload command 2-439

remote command 2-441

remote-span command 2-443

Remote Switched Port Analyzer

See RSPAN

rename (boot loader) command A-21

renew ip dhcp snooping database command 2-445

reset (boot loader) command A-22

restricted VLAN

See dot1x auth-fail vlan

rmdir (boot loader) command A-23

rmon collection stats command 2-449

root guard, for spanning tree 2-714

routed ports

IP addresses on 2-199

number supported 2-199

RSPAN

configuring 2-382

filter RSPAN traffic 2-382

remote-span command 2-443

sessions

add interfaces to 2-382

start new 2-382

S

scheduled switchover

disabling 2-132

enabling 2-132

sdm prefer command 2-450

SDM templates

displaying 2-652

secure ports, limitations 2-790

sending flow-control packets 2-185

service password-recovery command 2-454

service-policy command 2-456

set (boot loader) command A-24

set command 2-460

setup command 2-462

setup express command 2-465

show access-lists command 2-467

show archive status command 2-470

show arp access-list command 2-471

show authentication command 2-472

show auto qos command 2-476

show boot command 2-480

show cable-diagnostics tdr command 2-483

show cisp command 2-485

show class-map command 2-486

show controllers cpu-interface command 2-487

show controllers ethernet-controller command 2-489

show controllers ethernet-controller fastethernet command 2-496

show controllers tcam command 2-499

show controller utilization command 2-501

show dot1q-tunnel command 2-508

show dot1x command 2-509

show dtp 2-513

show eap command 2-515

show env command 2-518

show errdisable detect command 2-520

show errdisable flap-values command 2-522

show errdisable recovery command 2-523

show etherchannel command 2-525

show fallback profile command 2-528

show flowcontrol command 2-529

show idprom command 2-531

show interfaces command 2-533

show interfaces counters command 2-544

show inventory command 2-546

show ip arp inspection command 2-547

show ipc command 2-571

show ip dhcp snooping binding command 2-552

show ip dhcp snooping command 2-551

show ip dhcp snooping database command 2-554, 2-556

show ip igmp profile command 2-559

show ip igmp snooping address command 2-579

show ip igmp snooping command 2-560, 2-577

show ip igmp snooping groups command 2-563

show ip igmp snooping mrouter command 2-565, 2-581

show ip igmp snooping querier command 2-566

show ip source binding command 2-568

show ipv6 access-list command 2-574

show ipv6 dhcp conflict command 2-576

show ipv6 route updated 2-585

show ip verify source command 2-569

show l2protocol-tunnel command 2-587

show lacp command 2-589

show link state group command 2-593

show location command 2-595

show logging command 2-597

show mac address-table address command 2-605

show mac address-table command 2-603

show mac address-table count command 2-608

show mac address-table dynamic command 2-609

show mac address-table interface command 2-611

show mac address-table learning command 2-612

show mac address-table move update command 2-613

show mac address-table notification command 2-105, 2-614, B-23

show mac address-table vlan command 2-618

show mls qos aggregate-policer command 2-621

show mls qos command 2-620

show mls qos input-queue command 2-622

show mls qos interface command 2-623

show mls qos maps command 2-626

show mls qos queue-set command 2-629

show mls qos vlan command 2-630

show monitor command 2-631

show network-policy profile command 2-638

show nmsp command 2-639

show pagp command 2-642

show parser macro command 2-644

show platform acl command C-2

show platform backup interface command C-3

show platform chassis command C-4

show platform configuration command C-6

show platform dl command C-7

show platform etherchannel command C-8

show platform forward command C-9

show platform frontend-controller command C-11

show platform igmp snooping command C-12

show platform ipc trace command C-19

show platform ip multicast command C-13

show platform ip unicast command C-14

show platform ipv6 unicast command C-20

show platform ip wccp command C-18

show platform layer4op command C-22

show platform mac-address-table command C-23

show platform messaging command C-24

show platform monitor command C-25

show platform mvr table command C-26

show platform pm command C-27

show platform port-asic command C-28

show platform port-security command C-33

show platform qos command C-34

show platform resource-manager command C-35

show platform snmp counters command C-37

show platform spanning-tree command C-38

show platform stack-manager command C-40

show platform stp-instance command C-39

show platform summary command C-44

show platform tb command C-45

show platform tcam command C-47

show platform vlan command C-50

show policy-map command 2-647

show port security command 2-648

show psp config 2-650

show psp config command 2-650

show psp statistics 2-651

show psp statistics command 2-651

show sdm prefer command 2-652

show setup express command 2-655

show spanning-tree command 2-656

show storm-control command 2-662

show switch command 2-664

show system mtu command 2-669

show trust command 2-817

show udld command 2-670

show version command 2-673

show vlan access-map command 2-679

show vlan command 2-675

show vlan filter command 2-680

show vmps command 2-681

show vtp command 2-683

shutdown command 2-689

shutdown threshold, Layer 2 protocol tunneling 2-295

shutdown vlan command 2-690

small violation-rate command 2-691

Smartports macros

See macros

SNMP host, specifying 2-697

SNMP informs, enabling the sending of 2-693

snmp-server enable traps command 2-693

snmp-server host command 2-697

snmp trap mac-notification command 2-701

SNMP traps

enabling MAC address notification trap 2-701

enabling the MAC address notification feature 2-323

enabling the sending of 2-693

SoftPhone

See Cisco SoftPhone

software images

copying 2-8

deleting 2-119

downloading 2-11

upgrading 2-8, 2-11

uploading 2-18

source ports, MVR 2-389

SPAN

configuring 2-382

debug messages, display B-24

filter SPAN traffic 2-382

sessions

add interfaces to 2-382

start new 2-382

spanning-tree backbonefast command 2-703

spanning-tree bpdufilter command 2-704

spanning-tree bpduguard command 2-706

spanning-tree cost command 2-708

spanning-tree etherchannel command 2-710

spanning-tree extend system-id command 2-712

spanning-tree guard command 2-714

spanning-tree link-type command 2-716

spanning-tree loopguard default command 2-718

spanning-tree mode command 2-720

spanning-tree mst configuration command 2-722

spanning-tree mst cost command 2-724

spanning-tree mst forward-time command 2-726

spanning-tree mst hello-time command 2-727

spanning-tree mst max-age command 2-728

spanning-tree mst max-hops command 2-729

spanning-tree mst port-priority command 2-730

spanning-tree mst pre-standard command 2-732

spanning-tree mst priority command 2-733

spanning-tree mst root command 2-734

spanning-tree portfast (global configuration) command 2-738

spanning-tree portfast (interface configuration) command 2-741

spanning-tree port-priority command 2-736

Spanning Tree Protocol

See STP

spanning-tree transmit hold-count command 2-743

spanning-tree uplinkfast command 2-744

spanning-tree vlan command 2-746

speed command 2-749

srr-queue bandwidth limit command 2-751

srr-queue bandwidth shape command 2-753

srr-queue bandwidth share command 2-755

SSH, configuring version 2-261

stack-mac persistent timer command 2-757

stack member

number 2-767

priority value 2-764

provisioning 2-765

reloading 2-439

stacks, switch

disabling a member 2-762

enabling a member 2-762

MAC address 2-757

provisioning a new member 2-765

stacks, switch (continued)

reloading 2-439

stack member number 2-767

stack member priority value 2-764

static-access ports, configuring 2-771

sticky learning, enabling 2-788

storm-control command 2-759

STP

BackboneFast 2-703

counters, clearing 2-111

debug messages, display

BackboneFast events B-81

MSTP B-84

optimized BPDUs handling B-83

spanning-tree activity B-79

switch shim B-86

transmitted and received BPDUs B-82

UplinkFast B-88

detection of indirect link failures 2-703

enabling protocol tunneling for 2-295

EtherChannel misconfiguration 2-710

extended system ID 2-712

path cost 2-708

protocol modes 2-720

root port

accelerating choice of new 2-744

loop guard 2-714

preventing from becoming designated 2-714

restricting which can be root 2-714

root guard 2-714

UplinkFast 2-744

root switch

affects of extended system ID 2-712, 2-747

hello-time 2-746

interval between BDPU messages 2-746

interval between hello BPDU messages 2-746

max-age 2-746

port priority for selection of 2-736

primary or secondary 2-746

switch priority 2-746

state changes

blocking to forwarding state 2-741

enabling BPDU filtering 2-704, 2-738

enabling BPDU guard 2-706, 2-738

enabling Port Fast 2-738, 2-741

enabling timer to recover from error state 2-179

forward-delay time 2-746

length of listening and learning states 2-746

shutting down Port Fast-enabled ports 2-738

VLAN options 2-733, 2-746

SVIs, creating 2-193

SVI status calculation 2-773

Switched Port Analyzer

See SPAN

switching characteristics

modifying 2-769

returning to interfaces 2-769

switchport access command 2-771

switchport autostate exclude command 2-773

switchport backup interface command 2-775

switchport block command 2-778

switchport command 2-769

switchport host command 2-780

switchport mode command 2-781

switchport mode private-vlan command 2-784

switchport nonegotiate command 2-786

switchport port-security aging command 2-793

switchport port-security command 2-788

switchport priority extend command 2-795

switchport private-vlan command 2-797

switchport protected command 2-799

switchport trunk command 2-801

switchport voice detect 2-804

switchport voice vlan command 2-805

switch priority command 2-762, 2-764

switch provision command 2-765

switch renumber command 2-767

system env temperature threshold yellow command 2-807

system message logging, save message to flash 2-310

system mtu command 2-809

system resource templates 2-450

T

tar files, creating, listing, and extracting 2-15

TDR, running 2-811

temperature information, displaying 2-518

templates, system resources 2-450

test cable-diagnostics tdr command 2-811

traceroute mac command 2-812

traceroute mac ip command 2-815

trunking, VLAN mode 2-781

trunk mode 2-781

trunk ports 2-781

trunks, to non-DTP device 2-782

trusted boundary for QoS 2-379

trusted port states for QoS 2-379

type (boot loader) command A-27

U

UDLD

aggressive mode 2-819, 2-821

debug messages, display B-96

enable globally 2-819

enable per interface 2-821

error recovery timer 2-179

message timer 2-819

normal mode 2-819, 2-821

reset a shutdown interface 2-823

udld command 2-819

udld port command 2-821

udld reset command 2-823

unicast storm control 2-759

UniDirectional Link Detection

See UDLD

unknown multicast traffic, preventing 2-778

unknown unicast traffic, preventing 2-778

unset (boot loader) command A-28

upgrading

copying software images 2-8

downloading software images 2-11

UplinkFast, for STP 2-744

user EXEC mode 1-2, 1-3

V

version (boot loader) command A-30

version mismatch mode C-41

vlan (global configuration) command 2-824

vlan access-map command 2-829

VLAN access map configuration mode 2-829

VLAN access maps

actions 2-6

VLAN-based QoS 2-381

VLAN configuration

rules 2-827

saving 2-824

VLAN configuration mode

description 1-4

summary 1-3

vlan dot1q tag native command 2-831

vlan filter command 2-833

VLAN ID range 2-824

VLAN maps

applying 2-833

creating 2-829

defining 2-338

VLAN Query Protocol

See VQP

VLANs

adding 2-824

configuring 2-824

debug messages, display

ISL B-92

VLAN IOS file system error tests B-91

VLAN manager activity B-89

VTP B-94

extended-range 2-824

media types 2-827

normal-range 2-824

private 2-784

configuring 2-428

See also private VLANs

restarting 2-690

saving the configuration 2-824

shutting down 2-690

SNMP traps for VTP 2-695, 2-698

suspending 2-690

VLAN Trunking Protocol

See VTP

VM mode C-41

VMPS

configuring servers 2-838

error recovery timer 2-179

reconfirming dynamic VLAN assignments 2-835

vmps reconfirm (global configuration) command 2-836

vmps reconfirm (privileged EXEC) command 2-835

vmps retry command 2-837

vmps server command 2-838

voice VLAN

configuring 2-804, 2-805

setting port priority 2-795

VQP

and dynamic-access ports 2-772

clearing client statistics 2-113

per-server retry count 2-837

reconfirmation interval 2-836

reconfirming dynamic VLAN assignments 2-835

VTP

changing characteristics 2-840

clearing pruning counters 2-114

configuring

domain name 2-840

file name 2-840

mode 2-840

password 2-841

enabling

pruning 2-841

tunneling for 2-295

Version 2 2-841

enabling per port 2-845

mode 2-840

pruning 2-841

saving the configuration 2-824

vtp (global configuration) command 2-840

vtp interface configuration) command 2-845

vtp primary command 2-846