Next Generation Enterprise MPLS VPN-Based MAN Design and Implementation Guide
Configurations and Logs for Each VPN
Downloads: This chapterpdf (PDF - 386.0KB) The complete bookPDF (PDF - 2.65MB) | Feedback

Configurations and Logs for Each VPN

Table Of Contents

Configurations and Logs for Each VPN

Cisco 7600 as PE

Cisco 12000 as PE

Service Validation

Core Verification

Edge Verification

Baseline MPLS VPN

OSPF Backdoor Link Verifications

QoS

Multicast


Configurations and Logs for Each VPN


This section includes the entire configurations from the Cisco 7600 and Cisco 12000 as PEs.

Cisco 7600 as PE

hostname 7600-DC2-PE3
!
boot system flash disk0:s72033-adventerprisek9_wan-mz.122-18.SXE2.bin
!
ip vrf blue-data
 rd 10:1053
 route-target export 10:105
 route-target import 10:105
 mdt default 239.232.10.1
!
ip vrf blue-voice
 rd 10:1063
 route-target export 10:106
 route-target import 10:106
 mdt default 239.232.10.2
!
ip vrf red-data
 rd 10:1033
 route-target export 10:103
 route-target import 10:103
 mdt default 239.232.10.3
 mdt data 239.232.20.32 0.0.0.15 threshold 1
!
ip vrf red-voice
 rd 10:1043
 route-target export 10:104
 route-target import 10:104
 mdt default 239.232.10.4
 mdt data 239.232.20.48 0.0.0.15 threshold 1
!
ip vrf sitemap
!
ip multicast-routing
ip multicast-routing vrf blue-data
ip multicast-routing vrf blue-voice
ip multicast-routing vrf red-data
ip multicast-routing vrf red-voice
no ip domain-lookup
vtp mode transparent
mpls label protocol ldp
tag-switching tdp router-id Loopback0 force
mls ip multicast replication-mode ingress
mls qos
!
interface Loopback0
 ip address 125.1.125.7 255.255.255.255
 ip pim sparse-mode
!
interface Loopback1
 ip vrf forwarding red-data
 ip address 125.1.125.103 255.255.255.255
!
interface GigabitEthernet1/1
 description To P1 - intf G4/0/0
 ip address 125.1.102.2 255.255.255.252
 ip pim sparse-mode
 wrr-queue bandwidth 5 25 70
 wrr-queue queue-limit 5 25 40
 wrr-queue random-detect min-threshold 1 80 100 100 100 100 100 100 100
 wrr-queue random-detect min-threshold 2 80 100 100 100 100 100 100 100
 wrr-queue random-detect min-threshold 3 50 60 70 80 90 100 100 100
 wrr-queue random-detect max-threshold 1 100 100 100 100 100 100 100 100
 wrr-queue random-detect max-threshold 2 100 100 100 100 100 100 100 100
 wrr-queue random-detect max-threshold 3 60 70 80 90 100 100 100 100
 wrr-queue cos-map 1 1 1
 wrr-queue cos-map 2 1 0
 wrr-queue cos-map 3 1 4
 wrr-queue cos-map 3 2 2
 wrr-queue cos-map 3 3 3
 wrr-queue cos-map 3 4 6
 wrr-queue cos-map 3 5 7
 tag-switching ip
 mls qos trust dscp
!
interface GigabitEthernet1/2
 description To P2 - intf G1/9
 ip address 125.1.102.14 255.255.255.252
 ip pim sparse-mode
 wrr-queue bandwidth 5 25 70
 wrr-queue queue-limit 5 25 40
 wrr-queue random-detect min-threshold 1 80 100 100 100 100 100 100 100
 wrr-queue random-detect min-threshold 2 80 100 100 100 100 100 100 100
 wrr-queue random-detect min-threshold 3 50 60 70 80 90 100 100 100
 wrr-queue random-detect max-threshold 1 100 100 100 100 100 100 100 100
 wrr-queue random-detect max-threshold 2 100 100 100 100 100 100 100 100
 wrr-queue random-detect max-threshold 3 60 70 80 90 100 100 100 100
 wrr-queue cos-map 1 1 1
 wrr-queue cos-map 2 1 0
 wrr-queue cos-map 3 1 4
 wrr-queue cos-map 3 2 2
 wrr-queue cos-map 3 3 3
 wrr-queue cos-map 3 4 6
 wrr-queue cos-map 3 5 7
 tag-switching ip
 mls qos trust dscp
!
interface GigabitEthernet1/3
 description To PE4 - intf TBD
 ip address 125.1.102.21 255.255.255.252
 ip pim sparse-mode
 wrr-queue bandwidth 5 25 70
 wrr-queue queue-limit 5 25 40
 wrr-queue random-detect min-threshold 1 80 100 100 100 100 100 100 100
 wrr-queue random-detect min-threshold 2 80 100 100 100 100 100 100 100
 wrr-queue random-detect min-threshold 3 50 60 70 80 90 100 100 100
 wrr-queue random-detect max-threshold 1 100 100 100 100 100 100 100 100
 wrr-queue random-detect max-threshold 2 100 100 100 100 100 100 100 100
 wrr-queue random-detect max-threshold 3 60 70 80 90 100 100 100 100
 wrr-queue cos-map 1 1 1
 wrr-queue cos-map 2 1 0
 wrr-queue cos-map 3 1 4
 wrr-queue cos-map 3 2 2
 wrr-queue cos-map 3 3 3
 wrr-queue cos-map 3 4 6
 wrr-queue cos-map 3 5 7
 tag-switching ip
 mls qos trust dscp
!
interface GigabitEthernet1/4
 description To DL2 - intf G5/1
 no ip address
 load-interval 30
 wrr-queue bandwidth 5 25 70
 wrr-queue queue-limit 5 25 40
 wrr-queue random-detect min-threshold 1 80 100 100 100 100 100 100 100
 wrr-queue random-detect min-threshold 2 80 100 100 100 100 100 100 100
 wrr-queue random-detect min-threshold 3 50 60 70 80 90 100 100 100
 wrr-queue random-detect max-threshold 1 100 100 100 100 100 100 100 100
 wrr-queue random-detect max-threshold 2 100 100 100 100 100 100 100 100
 wrr-queue random-detect max-threshold 3 60 70 80 90 100 100 100 100
 wrr-queue cos-map 1 1 1
 wrr-queue cos-map 2 1 0
 wrr-queue cos-map 3 1 4
 wrr-queue cos-map 3 2 2
 wrr-queue cos-map 3 3 3
 wrr-queue cos-map 3 4 6
 wrr-queue cos-map 3 5 7
 mls qos trust dscp
!
interface GigabitEthernet1/4.1
 description RED-DATA
 encapsulation dot1Q 161
 ip vrf forwarding red-data
 ip address 125.1.102.33 255.255.255.252
 ip pim sparse-mode
 wrr-queue bandwidth 5 25 70
 wrr-queue queue-limit 5 25 40
 wrr-queue random-detect min-threshold 1 80 100 100 100 100 100 100 100
 wrr-queue random-detect min-threshold 2 80 100 100 100 100 100 100 100
 wrr-queue random-detect min-threshold 3 50 60 70 80 90 100 100 100
 wrr-queue random-detect max-threshold 1 100 100 100 100 100 100 100 100
 wrr-queue random-detect max-threshold 2 100 100 100 100 100 100 100 100
 wrr-queue random-detect max-threshold 3 60 70 80 90 100 100 100 100
 wrr-queue cos-map 1 1 1
 wrr-queue cos-map 2 1 0
 wrr-queue cos-map 3 1 4
 wrr-queue cos-map 3 2 2
 wrr-queue cos-map 3 3 3
 wrr-queue cos-map 3 4 6
 wrr-queue cos-map 3 5 7
!
interface GigabitEthernet1/4.2
 description RED-VOICE
 encapsulation dot1Q 162
 ip vrf forwarding red-voice
 ip address 125.1.102.37 255.255.255.252
 ip pim sparse-mode
 wrr-queue bandwidth 5 25 70
 wrr-queue queue-limit 5 25 40
 wrr-queue random-detect min-threshold 1 80 100 100 100 100 100 100 100
 wrr-queue random-detect min-threshold 2 80 100 100 100 100 100 100 100
 wrr-queue random-detect min-threshold 3 50 60 70 80 90 100 100 100
 wrr-queue random-detect max-threshold 1 100 100 100 100 100 100 100 100
 wrr-queue random-detect max-threshold 2 100 100 100 100 100 100 100 100
 wrr-queue random-detect max-threshold 3 60 70 80 90 100 100 100 100
 wrr-queue cos-map 1 1 1
 wrr-queue cos-map 2 1 0
 wrr-queue cos-map 3 1 4
 wrr-queue cos-map 3 2 2
 wrr-queue cos-map 3 3 3
 wrr-queue cos-map 3 4 6
 wrr-queue cos-map 3 5 7
!
interface GigabitEthernet1/5
 description To DL3 - intf G5/1
 no ip address
 ip pim sparse-mode
 wrr-queue bandwidth 5 25 70
 wrr-queue queue-limit 5 25 40
 wrr-queue random-detect min-threshold 1 80 100 100 100 100 100 100 100
 wrr-queue random-detect min-threshold 2 80 100 100 100 100 100 100 100
 wrr-queue random-detect min-threshold 3 50 60 70 80 90 100 100 100
 wrr-queue random-detect max-threshold 1 100 100 100 100 100 100 100 100
 wrr-queue random-detect max-threshold 2 100 100 100 100 100 100 100 100
 wrr-queue random-detect max-threshold 3 60 70 80 90 100 100 100 100
 wrr-queue cos-map 1 1 1
 wrr-queue cos-map 2 1 0
 wrr-queue cos-map 3 1 4
 wrr-queue cos-map 3 2 2
 wrr-queue cos-map 3 3 3
 wrr-queue cos-map 3 4 6
 wrr-queue cos-map 3 5 7
 mls qos trust dscp
!
interface GigabitEthernet1/5.1
 description BLUE-DATA
 encapsulation dot1Q 163
 ip vrf forwarding blue-data
 ip vrf sitemap SoODL3
 ip address 125.1.102.41 255.255.255.252
 ip pim sparse-mode
 wrr-queue bandwidth 5 25 70
 wrr-queue queue-limit 5 25 40
 wrr-queue random-detect min-threshold 1 80 100 100 100 100 100 100 100
 wrr-queue random-detect min-threshold 2 80 100 100 100 100 100 100 100
 wrr-queue random-detect min-threshold 3 50 60 70 80 90 100 100 100
 wrr-queue random-detect max-threshold 1 100 100 100 100 100 100 100 100
 wrr-queue random-detect max-threshold 2 100 100 100 100 100 100 100 100
 wrr-queue random-detect max-threshold 3 60 70 80 90 100 100 100 100
 wrr-queue cos-map 1 1 1
 wrr-queue cos-map 2 1 0
 wrr-queue cos-map 3 1 4
 wrr-queue cos-map 3 2 2
 wrr-queue cos-map 3 3 3
 wrr-queue cos-map 3 4 6
 wrr-queue cos-map 3 5 7
!
interface GigabitEthernet1/5.2
 description BLUE-VOICE
 encapsulation dot1Q 164
 ip vrf forwarding blue-voice
 ip address 125.1.102.45 255.255.255.252
 ip pim sparse-mode
 wrr-queue bandwidth 5 25 70
 wrr-queue queue-limit 5 25 40
 wrr-queue random-detect min-threshold 1 80 100 100 100 100 100 100 100
 wrr-queue random-detect min-threshold 2 80 100 100 100 100 100 100 100
 wrr-queue random-detect min-threshold 3 50 60 70 80 90 100 100 100
 wrr-queue random-detect max-threshold 1 100 100 100 100 100 100 100 100
 wrr-queue random-detect max-threshold 2 100 100 100 100 100 100 100 100
 wrr-queue random-detect max-threshold 3 60 70 80 90 100 100 100 100
 wrr-queue cos-map 1 1 1
 wrr-queue cos-map 2 1 0
 wrr-queue cos-map 3 1 4
 wrr-queue cos-map 3 2 2
 wrr-queue cos-map 3 3 3
 wrr-queue cos-map 3 4 6
 wrr-queue cos-map 3 5 7
!
interface GigabitEthernet1/6
 description To SS2 - intf G3/1
 ip address 125.1.102.65 255.255.255.252
 wrr-queue cos-map 1 1 1
 wrr-queue cos-map 2 1 0
 wrr-queue cos-map 3 1 4
 wrr-queue cos-map 3 2 2
 wrr-queue cos-map 3 3 3
 wrr-queue cos-map 3 4 6
 wrr-queue cos-map 3 5 7
 tag-switching ip
 mls qos trust dscp
!
interface GigabitEthernet5/2
 ip address 172.26.185.109 255.255.255.0
 media-type rj45
 duplex full
!
router eigrp 1
 variance 2
 network 125.1.125.7 0.0.0.0
 network 125.0.0.0
 maximum-paths 8
 no auto-summary
!
router eigrp 10
 no auto-summary
 !
 address-family ipv4 vrf blue-voice
 variance 2
 redistribute bgp 1 metric 1000000 100 255 1 1500
 network 125.1.2.128 0.0.0.127
 network 125.1.102.44 0.0.0.3
 maximum-paths 8
 no auto-summary
 autonomous-system 11
 exit-address-family
 !
 address-family ipv4 vrf blue-data
 variance 2
 redistribute bgp 1 metric 1000000 100 255 1 1500
 network 125.1.2.0 0.0.0.127
 network 125.1.102.40 0.0.0.3
 maximum-paths 8
 distance eigrp 210 210
 no auto-summary
 autonomous-system 10
 exit-address-family
!
router ospf 1 vrf red-data
 log-adjacency-changes
 area 0 sham-link 125.1.125.103 125.1.125.108
 area 0 sham-link 125.1.125.103 125.1.125.107
 redistribute bgp 1 subnets
 network 125.1.102.32 0.0.0.3 area 0
!
router ospf 2 vrf red-voice
 log-adjacency-changes
 redistribute bgp 1 subnets
 network 125.1.102.36 0.0.0.3 area 0
!
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 network 125.1.125.103 mask 0.0.0.0
 neighbor 125.1.125.15 remote-as 1
 neighbor 125.1.125.15 update-source Loopback0
 neighbor 125.1.125.16 remote-as 1
 neighbor 125.1.125.16 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
 neighbor 125.1.125.15 activate
 neighbor 125.1.125.15 send-community extended
 neighbor 125.1.125.16 activate
 neighbor 125.1.125.16 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf sitemap
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv4 vrf red-voice
 redistribute ospf 2 vrf red-voice match internal external 1 external 2
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv4 vrf red-data
 redistribute connected metric 1
 redistribute ospf 1 vrf red-data match internal external 1 external 2
 maximum-paths ibgp  6
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv4 vrf blue-voice
 redistribute eigrp 11
 maximum-paths ibgp unequal-cost 8
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv4 vrf blue-data
 redistribute eigrp 10
 maximum-paths ibgp unequal-cost 8
 no auto-summary
 no synchronization
 exit-address-family
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.26.185.1
!
no ip http server
ip pim ssm range 1
ip pim vrf blue-data rp-address 1.1.1.11 override
ip pim vrf blue-voice rp-address 2.2.2.11 override
ip pim vrf red-data rp-address 3.3.3.11 override
ip pim vrf red-voice rp-address 4.4.4.11 override
!
ip access-list standard mdtacl
 permit 239.232.10.0 0.0.0.255
 permit 239.232.20.0 0.0.0.255
ip access-list standard orga
 permit 224.2.131.239
 permit 224.2.149.231
 permit 224.2.159.191
 permit 224.2.201.231
 permit 239.193.10.252
!
access-list 1 permit 239.232.0.0 0.0.255.255
!
route-map SoODL3 permit 10
 set extcommunity soo 3:1
!

Cisco 12000 as PE

hostname 12k-DC2-PE4
!
boot-start-marker
boot system flash disk0:c12kprp-k4p-mz.120-31.S.bin
boot-end-marker
!
hw-module slot 2 qos interface queues 8
!
ip vrf blue-data
 rd 10:1054
 route-target export 10:105
 route-target import 10:105
 mdt default 239.232.10.1
 mdt data 239.232.20.0 0.0.0.15 threshold 1
!
ip vrf blue-voice
 rd 10:1064
 route-target export 10:106
 route-target import 10:106
 mdt default 239.232.10.2
 mdt data 239.232.20.16 0.0.0.15 threshold 1
!
ip vrf red-data
 rd 10:1034
 route-target export 10:103
 route-target import 10:103
 mdt default 239.232.10.3
 mdt data 239.232.20.32 0.0.0.15 threshold 1
!
ip vrf red-voice
 rd 10:1044
 route-target export 10:104
 route-target import 10:104
 mdt default 239.232.10.4
 mdt data 239.232.20.48 0.0.0.15 threshold 1
!
ip multicast-routing distributed
ip multicast-routing vrf blue-data distributed
ip multicast-routing vrf blue-voice distributed
ip multicast-routing vrf red-data distributed
ip multicast-routing vrf red-voice distributed
!
class-map match-any realtime
  match mpls experimental  5
class-map match-any realtime-2ce
  match qos-group 5
class-map match-all red-voice
  match vlan  166
class-map match-any bulk-data
  match mpls experimental  1
class-map match-any network-control-2ce
  match qos-group 7
class-map match-any interwork-control
  match mpls experimental  6
class-map match-any network-control
  match mpls experimental  7
class-map match-any bulk-data-2ce
  match qos-group 1
class-map match-any interwork-control-2ce
  match qos-group 6
  match  precedence 6
class-map match-any bus-critical
  match mpls experimental  3
class-map match-any trans-data
  match mpls experimental  2
class-map match-all red-data
  match vlan  165
class-map match-any bus-critical-2ce
  match qos-group 3
class-map match-any trans-data-2ce
  match qos-group 2
class-map match-any video-2ce
  match qos-group 4
class-map match-any video
  match mpls experimental  4
!
policy-map q-core-out
  class realtime
    priority
   police cir percent 30 bc 500 ms conform-action transmit  exceed-action drop
  class network-control
    bandwidth remaining percent 7
    random-detect
    random-detect precedence 7 625 packets 4721 packets 1
  class interwork-control
    bandwidth remaining percent 7
    random-detect
    random-detect precedence 6 625 packets 4721 packets 1
  class bus-critical
    bandwidth remaining percent 14
    random-detect
    random-detect precedence 3 625 packets 4721 packets 1
  class trans-data
    bandwidth remaining percent 14
    random-detect
    random-detect precedence 2 625 packets 4721 packets 1
  class video
    bandwidth remaining percent 14
    random-detect
    random-detect precedence 4 625 packets 4721 packets 1
  class bulk-data
    bandwidth remaining percent 7
    random-detect
    random-detect precedence 1 625 packets 4721 packets 1
  class class-default
    bandwidth remaining percent 36
    random-detect
    random-detect precedence 0 625 packets 4721 packets 1
policy-map q-2ce-out-1
  class network-control-2ce
    bandwidth percent 7
    random-detect discard-class-based
    random-detect discard-class 7 625 packets 4721 packets 1
  class interwork-control-2ce
    bandwidth percent 7
    random-detect discard-class-based
    random-detect discard-class 6 625 packets 4721 packets 1
  class bus-critical-2ce
    bandwidth percent 14
    random-detect discard-class-based
    random-detect discard-class 3 625 packets 4721 packets 1
  class trans-data-2ce
    bandwidth percent 14
    random-detect discard-class-based
    random-detect discard-class 2 625 packets 4721 packets 1
  class video-2ce
    bandwidth percent 14
    random-detect discard-class-based
    random-detect discard-class 4 625 packets 4721 packets 1
  class bulk-data-2ce
    bandwidth percent 7
    random-detect discard-class-based
    random-detect discard-class 1 625 packets 4721 packets 1
  class class-default
    bandwidth percent 36
    random-detect discard-class-based
    random-detect discard-class 0 625 packets 4721 packets 1
policy-map q-2ce-out-2
  class realtime-2ce
    priority
   police cir percent 95 bc 500 ms conform-action transmit  exceed-action drop
  class interwork-control-2ce
    bandwidth percent 3
    random-detect
    random-detect precedence 6 4720 packets 4721 packets 1
  class class-default
    bandwidth percent 2
    random-detect
policy-map q-2ce-out-parent
  class red-data
    shape average percent 60
   service-policy q-2ce-out-1
  class red-voice
    shape average percent 40
   service-policy q-2ce-out-2
policy-map egr-pe-in
  class realtime
   set qos-group 5
   set discard-class 5
  class network-control
   set qos-group 7
   set discard-class 7
  class interwork-control
   set qos-group 6
   set discard-class 6
  class bus-critical
   set qos-group 3
   set discard-class 3
  class trans-data
   set qos-group 2
   set discard-class 2
  class video
   set qos-group 4
   set discard-class 4
  class bulk-data
   set qos-group 1
   set discard-class 1
!
mpls label protocol ldp
tag-switching tdp router-id Loopback0 force
!
interface Loopback0
 ip address 125.1.125.8 255.255.255.255
 no ip directed-broadcast
 ip pim sparse-mode
!
interface Loopback1
 ip vrf forwarding red-data
 ip address 125.1.125.104 255.255.255.255
 no ip directed-broadcast
!
interface GigabitEthernet2/0
 description To DL2 - intf G5/2
 no ip address
 no ip directed-broadcast
 load-interval 30
 negotiation auto
 service-policy output q-2ce-out-parent
!
interface GigabitEthernet2/0.1
 description RED-DATA
 encapsulation dot1Q 165
 ip vrf forwarding red-data
 ip address 125.1.102.49 255.255.255.252
 no ip directed-broadcast
 ip pim sparse-mode
!
interface GigabitEthernet2/0.2
 description RED-VOICE
 encapsulation dot1Q 166
 ip vrf forwarding red-voice
 ip address 125.1.102.53 255.255.255.252
 no ip directed-broadcast
 ip pim sparse-mode
!
interface GigabitEthernet2/1
 description To DL3 - intf G5/2
 no ip address
 no ip directed-broadcast
 negotiation auto
!
interface GigabitEthernet2/1.1
 description BLUE-DATA
 encapsulation dot1Q 167
 ip vrf forwarding blue-data
 ip vrf sitemap SoODL3
 ip address 125.1.102.57 255.255.255.252
 no ip directed-broadcast
 ip pim sparse-mode
 service-policy output q-2ce-out-data
!
interface GigabitEthernet2/1.2
 description BLUE-VOICE
 encapsulation dot1Q 168
 ip vrf forwarding blue-voice
 ip address 125.1.102.61 255.255.255.252
 no ip directed-broadcast
 ip pim sparse-mode
!
interface GigabitEthernet3/0/0
 description To SS2 - intf G3/2
 ip address 125.1.102.69 255.255.255.252
 no ip directed-broadcast
 negotiation auto
 tag-switching ip
 service-policy input egr-pe-in
 service-policy output q-core-out
!
interface GigabitEthernet3/0/1
 description To P2 - intf G1/10
 ip address 125.1.102.18 255.255.255.252
 no ip directed-broadcast
 ip pim sparse-mode
 load-interval 30
 negotiation auto
 tag-switching ip
 service-policy input egr-pe-in
 service-policy output q-core-out
!
interface GigabitEthernet3/0/2
 description To PE3 - intf G1/3
 ip address 125.1.102.22 255.255.255.252
 no ip directed-broadcast
 ip pim sparse-mode
 negotiation auto
 tag-switching ip
 service-policy input egr-pe-in
 service-policy output q-core-out
!
interface GigabitEthernet3/3/0
 description To P1 - intf G4/0/2
 ip address 125.1.102.6 255.255.255.252
 no ip directed-broadcast
 ip pim sparse-mode
 load-interval 30
 negotiation auto
 tag-switching ip
 service-policy input egr-pe-in
 service-policy output q-core-out
!
interface Ethernet2
 description Mgmt
 ip address 172.26.185.108 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!
router eigrp 1
 !
 address-family ipv4
 variance 2
 network 125.1.125.8 0.0.0.0
 network 125.0.0.0
 maximum-paths 8
 exit-address-family
!
router eigrp 10
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv4 vrf blue-voice
 variance 2
 redistribute bgp 1 metric 1000000 100 255 1 1500
 network 125.1.2.128 0.0.0.127
 network 125.1.102.60 0.0.0.3
 maximum-paths 8
 autonomous-system 11
 exit-address-family
 !
 address-family ipv4 vrf blue-data
 variance 2
 redistribute bgp 1 metric 1000000 100 255 1 1500
 network 125.1.2.0 0.0.0.127
 network 125.1.102.56 0.0.0.3
 maximum-paths 8
 distance eigrp 210 210
 autonomous-system 10
 exit-address-family
!
router ospf 1 vrf red-data
 log-adjacency-changes
 area 0 sham-link 125.1.125.104 125.1.125.107
 area 0 sham-link 125.1.125.104 125.1.125.108
 redistribute bgp 1 subnets
 network 125.1.102.48 0.0.0.3 area 0
!
router ospf 2 vrf red-voice
 log-adjacency-changes
 redistribute bgp 1 subnets
 network 125.1.102.52 0.0.0.3 area 0
!
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 neighbor 125.1.125.15 remote-as 1
 neighbor 125.1.125.15 update-source Loopback0
 neighbor 125.1.125.16 remote-as 1
 neighbor 125.1.125.16 update-source Loopback0
 no auto-summary
 !
 address-family ipv4 mdt
 neighbor 125.1.125.15 activate
 neighbor 125.1.125.15 send-community extended
 neighbor 125.1.125.16 activate
 neighbor 125.1.125.16 send-community extended
 exit-address-family
 !
 address-family vpnv4
 neighbor 125.1.125.15 activate
 neighbor 125.1.125.15 send-community extended
 neighbor 125.1.125.16 activate
 neighbor 125.1.125.16 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf red-voice
 redistribute ospf 2 vrf red-voice match internal external 1 external 2
 maximum-paths ibgp unequal-cost 6
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv4 vrf red-data
 redistribute connected metric 1
 redistribute ospf 1 vrf red-data match internal external 1 external 2
 maximum-paths ibgp 2
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv4 vrf blue-voice
 redistribute eigrp 11
 maximum-paths ibgp unequal-cost 8
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv4 vrf blue-data
 redistribute eigrp 10
 maximum-paths ibgp unequal-cost 8
 no auto-summary
 no synchronization
 exit-address-family
 !
ip classless
ip route 0.0.0.0 0.0.0.0 172.26.185.1
!
ip pim ssm range 1
ip pim vrf blue-data rp-address 1.1.1.11 override
ip pim vrf blue-voice rp-address 2.2.2.11 override
ip pim vrf red-data rp-address 3.3.3.11 override
ip pim vrf red-voice rp-address 4.4.4.11 override
!
ip access-list standard mdtacl
 permit 239.232.10.0 0.0.0.255
 permit 239.232.20.0 0.0.0.255
ip access-list standard orga
 permit 224.2.131.239
 permit 224.2.149.231
 permit 224.2.159.191
 permit 224.2.201.231
 permit 239.193.10.252
rx-cos-slot all SLOT_TABLE
!
slot-table-cos SLOT_TABLE
 destination-slot all GE_policy
 multicast GE-multicast
!
cos-queue-group GE-multicast
 precedence 4 queue 4
!
cos-queue-group GE_policy
 precedence 0 random-detect-label 1
 precedence 1 queue 1
 precedence 1 random-detect-label 1
 precedence 2 queue 2
 precedence 2 random-detect-label 1
 precedence 3 queue 3
 precedence 3 random-detect-label 1
 precedence 4 queue 4
 precedence 4 random-detect-label 1
 precedence 5 queue low-latency
 precedence 6 queue 5
 precedence 6 random-detect-label 1
 precedence 7 queue 6
 precedence 7 random-detect-label 1
 random-detect-label 1 625 4721 1
 queue 1 2
 queue 2 4
 queue 3 4
 queue 4 4
 queue 5 2
 queue 6 2
 queue low-latency strict-priority
access-list 1 permit 239.232.0.0 0.0.255.255
route-map SoODL3 permit 10
 set extcommunity soo 3:1

Service Validation

Core Verification

1. Ping tests to show each core device is accessible.

Threre are four core routers, P1....P4. 10 PEs, and two Route Reflectors.

All of these devices should be able to communicate. A good test would be to run ping tests from one of the Route Reflectors. (Notice 125.1.125.1 to .4 are Ps, .5 to .14 are PEs and .15 is RR1 and .16 is RR2).

7200-DC2-RR1#ping 125.1.125.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 125.1.125.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
7200-DC2-RR1#ping 125.1.125.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 125.1.125.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
7200-DC2-RR1#ping 125.1.125.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 125.1.125.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
7200-DC2-RR1#ping 125.1.125.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 125.1.125.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
7200-DC2-RR1#ping 125.1.125.5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 125.1.125.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
7200-DC2-RR1#ping 125.1.125.6

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 125.1.125.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
7200-DC2-RR1#ping 125.1.125.7

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 125.1.125.7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
7200-DC2-RR1#ping 125.1.125.8

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 125.1.125.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
7200-DC2-RR1#ping 125.1.125.9

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 125.1.125.9, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
7200-DC2-RR1#ping 125.1.125.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 125.1.125.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
7200-DC2-RR1#ping 125.1.125.11

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 125.1.125.11, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
7200-DC2-RR1#ping 125.1.125.12

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 125.1.125.12, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
7200-DC2-RR1#ping 125.1.125.13

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 125.1.125.13, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
7200-DC2-RR1#ping 125.1.125.14

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 125.1.125.14, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
7200-DC2-RR1#ping 125.1.125.15

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 125.1.125.15, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
7200-DC2-RR1#ping 125.1.125.16

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 125.1.125.16, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
7200-DC2-RR1#

2. Examine global table to verify no VPN routes exists in the global table:

Notice 125.1.101.x is used for VPN links in DC1. 125.1.102.x is used for VPN links in DC2, 125.1.103.x is used for VPN links in LC, 125.1.104.x for VPN links in MC, and 125.1.105.x for VPN links in SC1 which should not exist in the global table.

7600-LC-P4#sh ip ro 125.1.101.0
% Subnet not in table
7600-LC-P4#

7600-LC-P4#sh ip ro 125.1.104.0
% Subnet not in table
7600-LC-P4#

7600-LC-P4#sh ip ro 125.1.105.0
% Subnet not in table
7600-LC-P4#

Notice that no VRF information is stored on the core routers:


7600-LC-P4#sh ip vrf

7600-LC-P4#

3. Examine LFIBs to ensure that they have labels for all the prefixes.

For example, PE1 to P3 Interface:


7600-LC-P4#   sh mpls forwarding-table 125.1.100.32
Local  Outgoing    Prefix              Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id        switched   interface              
36     33          125.1.100.32/30   0          Gi1/6      125.1.100.89 
       33          125.1.100.32/30   0          Gi1/7      125.1.100.93 
       50          125.1.100.32/30   0          Gi1/2      125.1.100.29 
       50          125.1.100.32/30   0          Gi1/1      125.1.100.25

PE7 to P1 Interface:

7600-LC-P4#   sh mpls forwarding-table 125.1.100.0 
Local  Outgoing    Prefix              Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id        switched   interface              
43     Pop tag     125.1.100.0/30    0          Gi1/6      125.1.100.89 
       Pop tag     125.1.100.0/30    0          Gi1/7      125.1.100.93

Full LFIB table can be viewed using the sh mpls forwarding-table command:


7600-LC-P4#sh mpls forwarding-table 
Local  Outgoing    Prefix              Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id        switched   interface              
16     Pop tag     125.1.125.10/32   26684      Gi1/8      125.1.103.22 
17     Pop tag     125.1.103.4/30    0          Gi1/7      125.1.100.93 
       Pop tag     125.1.103.4/30    0          Gi1/6      125.1.100.89 
       Pop tag     125.1.103.4/30    0          Gi1/8      125.1.103.22 
18     Pop tag     125.1.125.3/32    2437       Gi1/6      125.1.100.89 
       Pop tag     125.1.125.3/32    0          Gi1/7      125.1.100.93 

...................etc.

4. Ping tests to VPN sites and interfaces to verify that the core does not have access to the VPN sites.

Edge Verification

1. Verify VPNv4 peering with PEs and RRs.

2. Verify the VPN site routing table on the distribution layer device; check that these routes get propagated to VRF tables and BGP tables on ingress and egress PEs. Verify that the labels assigned by the ingress PEs are propagated to and used by the egress PEs.

3. Verify that multiple paths are installed in the forwarding table without any routing loops.

4. Verify that you can reach pertinent VPN sites from PEs and that multiple paths are used.

Baseline MPLS VPN

The VRF red-data on PE3 is used as the reference for highlighting the service validation steps, which are useful in troubleshooting as well. The following example examines the reachability to 3.3.3.13/32, which resides in DC1.

1. Verify the route exists in the VRF red-data routing table:

7600-DC2-PE3#sh ip route vrf red-data 3.3.3.13
Routing entry for 3.3.3.13/32
  Known via "bgp 1", distance 200, metric 2, type internal
  Redistributing via ospf 1
  Advertised by ospf 1 subnets
  Last update from 125.1.125.6 00:13:13 ago
  Routing Descriptor Blocks:
  * 125.1.125.5 (Default-IP-Routing-Table), from 125.1.125.15, 00:13:13 ago
      Route metric is 2, traffic share count is 1
      AS Hops 0
    125.1.125.6 (Default-IP-Routing-Table), from 125.1.125.15, 00:13:13 ago
      Route metric is 2, traffic share count is 1
      AS Hops 0

2. Verify that the nex-hop exists in the global routing table:

7600-DC2-PE3#sh ip route 125.1.125.6
Routing entry for 125.1.125.6/32
  Known via "eigrp 1", distance 90, metric 131072, type internal
  Redistributing via eigrp 1
  Last update from 125.1.102.13 on GigabitEthernet1/2, 23:59:59 ago
  Routing Descriptor Blocks:
  * 125.1.102.13, from 125.1.102.13, 23:59:59 ago, via GigabitEthernet1/2
      Route metric is 131072, traffic share count is 1
      Total delay is 5020 microseconds, minimum bandwidth is 1000000 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 2

7600-DC2-PE3#sh ip route 125.1.125.5
Routing entry for 125.1.125.5/32
  Known via "eigrp 1", distance 90, metric 131072, type internal
  Redistributing via eigrp 1
  Last update from 125.1.102.1 on GigabitEthernet1/1, 1d00h ago
  Routing Descriptor Blocks:
  * 125.1.102.1, from 125.1.102.1, 1d00h ago, via GigabitEthernet1/1
      Route metric is 131072, traffic share count is 1
      Total delay is 5020 microseconds, minimum bandwidth is 1000000 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 2

3. Additional verification may include checking the BGP table for the VPN route:

7600-DC2-PE3#sh ip bgp vpnv4 vrf red-data 3.3.3.13
BGP routing table entry for 10:1033:3.3.3.13/32, version 266
Paths: (2 available, best #1, table red-data)
Multipath: iBGP
  Not advertised to any peer
  Local, imported path from 10:1031:3.3.3.13/32
    125.1.125.5 (metric 131072) from 125.1.125.15 (125.1.125.15)
      Origin incomplete, metric 2, localpref 100, valid, internal, multipath, best
      Extended Community: RT:10:103 OSPF DOMAIN ID:0x0005:0x000000010200
        OSPF RT:0.0.0.0:2:0 OSPF ROUTER ID:125.1.101.1:512
      Originator: 125.1.125.5, Cluster list: 125.1.125.15
  Local, imported path from 10:1032:3.3.3.13/32
    125.1.125.6 (metric 131072) from 125.1.125.15 (125.1.125.15)
      Origin incomplete, metric 2, localpref 100, valid, internal, multipath
      Extended Community: RT:10:103 OSPF DOMAIN ID:0x0005:0x000000010200
        OSPF RT:0.0.0.0:2:0 OSPF ROUTER ID:125.1.101.9:512
      Originator: 125.1.125.6, Cluster list: 125.1.125.15

4. Verify that the CEF entry exists for the VRF route (including the dual label stack):

7600-DC2-PE3#sh ip cef vrf red-data 3.3.3.13
3.3.3.13/32, version 34, epoch 0
0 packets, 0 bytes
  tag information set, all rewrites owned
    local tag: VPN-route-head
  via 125.1.125.5, 0 dependencies, recursive
    traffic share 1
    next hop 125.1.102.1, GigabitEthernet1/1 via 125.1.125.5/32 (Default)
    valid adjacency
    tag rewrite with Gi1/1, 125.1.102.1, tags imposed: {62 74}
  via 125.1.125.6, 0 dependencies, recursive
    traffic share 1
    next hop 125.1.102.13, GigabitEthernet1/2 via 125.1.125.6/32 (Default)
    valid adjacency
    tag rewrite with Gi1/2, 125.1.102.13, tags imposed: {16 73}
  0 packets, 0 bytes switched through the prefix
  tmstats: external 0 packets, 0 bytes
           internal 0 packets, 0 bytes

5. The top label information can also be verified by looking at the MPLS forwarding table:

7600-DC2-PE3#sh mpls for 125.1.125.5
Local  Outgoing    Prefix              Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id        switched   interface
89     62          125.1.125.5/32    0          Gi1/1      125.1.102.1
7600-DC2-PE3#sh mpls for 125.1.125.6
Local  Outgoing    Prefix              Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id        switched   interface
47     16          125.1.125.6/32    0          Gi1/2      125.1.102.13

6. The PE-to-PE LSP check can be done by using an LSP ping. A broken LSP can be detected by identifying the break point in the pings (this avoids hop-by-hop troubleshooting):

7600-DC2-PE3#ping mpls ip 125.1.125.5/32 ver
Sending 5, 100-byte MPLS Echos to 125.1.125.5/32,
     timeout is 2 seconds, send interval is 0 msec:

Codes: '!' - success, 'Q' - request not transmitted,
       '.' - timeout, 'U' - unreachable,
       'R' - downstream router but not target,
       'M' - malformed request

Type escape sequence to abort.
!     125.1.100.62, return code 3
!     125.1.100.62, return code 3
!     125.1.100.62, return code 3
!     125.1.100.62, return code 3
!     125.1.100.62, return code 3

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

7. If there is a valid source address present on the PE, a VRF ping can be performed to check the destination address reachability from the PE.

7600-DC2-PE3# ping vrf red-data ip 3.3.3.13

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.13, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

8. If packet drops are being experienced and the source of the drop has been identified, the above steps can be performed. Additionally, the following show commands may be useful:

7600-DC2-PE3#sh cef drop
CEF Drop Statistics
Slot  Encap_fail  Unresolved Unsupported    No_route      No_adj  ChkSum_Err
RP             5           0           0           0           0           0
5              0           0           0           0           0           0
1              0           0           0           0           0           0
6              0           0           0           0           0           0
25             0           0           0           0           0           0
IPv6 CEF Drop Statistics
Slot  Encap_fail  Unresolved Unsupported    No_route      No_adj
RP             0           0           0           0           0

7600-DC2-PE3#sh cef not-cef-switched
CEF Packets passed on to next switching layer
Slot  No_adj No_encap Unsupp'ted Redirect  Receive  Options   Access     Frag
RP         0       0           1        0    54016        0        0        0
5          0       0           0        0        0        0        0        0
1          0       0           0        0        0        0        0        0
6          0       0           0        0        0        0        0        0
25         0       0           0        0        0        0        0        0
IPv6 CEF Packets passed on to next switching layer
Slot  No_adj No_encap Unsupp'ted Redirect  Receive  Options   Access      MTU
RP         0       0           0        0        0        0        0        0

For checking whether the locally originated route is advertised to remote PEs correctly, the following steps may be performed:

1. Toward the CE side, verify that the PE-CE routing protocol is up and the neighbor relationship formed:

7600-DC2-PE3#sh ip ospf nei g1/4.1

Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.12          1   FULL/DR         00:00:32    125.1.102.34    GigabitEthernet1/4.1

2. Verify that the route is in the local VRF table:

7600-DC2-PE3#sh ip route vrf red-data 3.3.3.12
Routing entry for 3.3.3.12/32
  Known via "ospf 1", distance 110, metric 2, type intra area
  Redistributing via bgp 1
  Advertised by bgp 1 match internal external 1 & 2
  Last update from 125.1.102.34 on GigabitEthernet1/4.1, 00:27:03 ago
  Routing Descriptor Blocks:
  * 125.1.102.34, from 3.3.3.12, 00:27:03 ago, via GigabitEthernet1/4.1
      Route metric is 2, traffic share count is 1

3. Because you are redistributing the OSPF-learned routes into BGP, ensure that the route exists in the BGP table and is marked for advertisement:

7600-DC2-PE3#sh ip bgp vpnv4 vrf red-data 3.3.3.12
BGP routing table entry for 10:1033:3.3.3.12/32, version 16756
Paths: (2 available, best #2, table red-data)
Multipath: iBGP
  Advertised to update-groups:
     1
  Local, imported path from 10:1034:3.3.3.12/32
    125.1.125.8 (metric 130816) from 125.1.125.15 (125.1.125.15)
      Origin incomplete, metric 2, localpref 100, valid, internal
      Extended Community: RT:10:103 OSPF DOMAIN ID:0x0005:0x000000010200
        OSPF RT:0.0.0.0:2:0 OSPF ROUTER ID:125.1.125.104:0
      Originator: 125.1.125.8, Cluster list: 125.1.125.15
  Local
    125.1.102.34 from 0.0.0.0 (125.1.125.7)
      Origin incomplete, metric 2, localpref 100, weight 32768, valid, sourced, best
      Extended Community: RT:10:103 OSPF DOMAIN ID:0x0005:0x000000010200
        OSPF RT:0.0.0.0:2:0 OSPF ROUTER ID:125.1.125.103:512

OSPF Backdoor Link Verifications

Traceroute results from DL2 to DL6 demonstrate that without the backdoor link, traffic flows over an MPLS network:

DL2-DC2-RED#traceroute vrf red-data 1.1.1.16

Type escape sequence to abort.
Tracing the route to 1.1.1.16

  1 125.1.102.49 0 msec
    125.1.102.33 0 msec
    125.1.102.49 0 msec
  2 125.1.102.1 [MPLS: Labels 52/76 Exp 0] 4 msec
    125.1.102.17 [MPLS: Labels 63/76 Exp 0] 0 msec
    125.1.102.1 [MPLS: Labels 52/76 Exp 0] 0 msec
  3 125.1.104.9 [MPLS: Label 76 Exp 0] 0 msec
    125.1.104.1 [MPLS: Label 76 Exp 0] 0 msec
    125.1.104.9 [MPLS: Label 76 Exp 0] 0 msec
  4 125.1.104.2 4 msec
    125.1.104.10 0 msec * 
DL2-DC2-RED#

Traceroute from DL2 to DL1 demonstrates that without the backdoor link, traffic flows over an MPLS network:

DL2-DC2-RED# traceroute vrf red-data 1.1.1.1 

Type escape sequence to abort.
Tracing the route to 1.1.1.1

  1 125.1.102.49 0 msec
    125.1.102.33 0 msec
    125.1.102.49 4 msec
  2 125.1.102.13 [MPLS: Labels 54/20 Exp 0] 0 msec
    125.1.102.17 [MPLS: Labels 54/20 Exp 0] 0 msec
    125.1.102.13 [MPLS: Labels 54/20 Exp 0] 0 msec
  3 125.1.101.9 [MPLS: Label 20 Exp 0] 0 msec 0 msec 0 msec
  4 125.1.101.10 4 msec *  0 msec

		DL2-DC2-RED#sh ip ro vrf red-data

Routing Table: red-data

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 3 subnets
O IA    1.1.1.1 [110/3] via 125.1.102.49, 01:29:09, GigabitEthernet5/2.1
                [110/3] via 125.1.102.33, 01:29:09, GigabitEthernet5/1.1
O IA    1.1.1.16 [110/3] via 125.1.102.49, 01:29:09, GigabitEthernet5/2.1
                 [110/3] via 125.1.102.33, 01:29:09, GigabitEthernet5/1.1

Traceroute from DL1 to DL6 demonstrates that without the backdoor link, traffic flows over an MPLS network:

DL1-DC1-RED#traceroute vrf red-data 1.1.1.16

Type escape sequence to abort.
Tracing the route to 1.1.1.16

  1 125.1.101.1 0 msec
    125.1.101.9 4 msec
    125.1.101.1 0 msec
  2 125.1.100.73 [MPLS: Labels 32/76 Exp 0] 0 msec
    125.1.100.57 [MPLS: Labels 52/76 Exp 0] 0 msec
    125.1.100.73 [MPLS: Labels 32/76 Exp 0] 0 msec
  3 125.1.104.1 [MPLS: Label 76 Exp 0] 0 msec
    125.1.100.38 [MPLS: Labels 24/76 Exp 0] 4 msec
    125.1.104.1 [MPLS: Label 76 Exp 0] 0 msec
  4 125.1.104.1 [MPLS: Label 76 Exp 0] 0 msec
    125.1.104.2 0 msec
    125.1.104.1 [MPLS: Label 76 Exp 0] 0 msec
		
DL6-MC-RED#  sh ip ro (all the routes except for C and all the remote VPN sites are IA, 
125.1.141.0/24- .148 are E):

Gateway of last resort is 172.26.185.1 to network 0.0.0.0

     1.0.0.0/32 is subnetted, 3 subnets
O IA    1.1.1.1 [110/3] via 125.1.104.9, 1d04h, GigabitEthernet2/2
                [110/3] via 125.1.104.1, 1d04h, GigabitEthernet2/1
C       1.1.1.16 is directly connected, Loopback0
O IA    1.1.1.23 [110/3] via 125.1.104.1, 2d01h, GigabitEthernet2/1
                 [110/3] via 125.1.104.9, 2d01h, GigabitEthernet2/2
     100.0.0.0/30 is subnetted, 2560 subnets
O IA    100.1.37.64 [110/5] via 125.1.104.9, 02:59:39, GigabitEthernet2/2
                    [110/5] via 125.1.104.1, 02:59:39, GigabitEthernet2/1


                       [110/20] via 125.1.104.1, 01:49:03, GigabitEthernet2/1
O E2    125.1.147.0/24 [110/20] via 125.1.104.9, 01:49:03, GigabitEthernet2/2
                       [110/20] via 125.1.104.1, 01:49:03, GigabitEthernet2/1
O E2    125.1.141.0/24 [110/20] via 125.1.104.9, 01:49:03, GigabitEthernet2/2
                       [110/20] via 125.1.104.1, 01:49:03, GigabitEthernet2/1
O E2    125.1.142.0/24 [110/20] via 125.1.104.9, 01:49:03, GigabitEthernet2/2
                       [110/20] via 125.1.104.1, 01:49:03, GigabitEthernet2/1
     12.0.0.0/27 is subnetted, 2 subnets
O IA    12.0.13.0 [110/4] via 125.1.104.9, 03:01:50, GigabitEthernet2/2
                  [110/4] via 125.1.104.1, 03:01:50, GigabitEthernet2/1
O IA    12.0.9.0 [110/4] via 125.1.104.1, 03:01:56, GigabitEthernet2/1
                 [110/4] via 125.1.104.9, 03:01:56, GigabitEthernet2/2

With the backdoor link, but without enabling OSPF sham-link:

Traceroute from DL2 to DL6 shows traffic flowing over the backdoor link:

DL2-DC2-RED#traceroute vrf red-data 1.1.1.16
Type escape sequence to abort.
Tracing the route to 1.1.1.16
  1 125.1.99.2 0 msec 0 msec 4 msec
  2 125.1.99.5 0 msec *  0 msec
DL2-DC2-RED#

Traceroute from DL6 to DL2 shows traffic flowing over the backdoor link:

DL6-MC-RED#traceroute 1.1.1.23

Type escape sequence to abort.
Tracing the route to 1.1.1.23

  1 125.1.99.6 0 msec 0 msec 0 msec
  2 125.1.99.1 0 msec *  0 msec
DL6-MC-RED#

Traceroute from DL2 to DL1m shows traffic flowing over the MPLS VPN network:

DL2-DC2-RED#traceroute vrf red-data 1.1.1.1 
Type escape sequence to abort.
Tracing the route to 1.1.1.1

  1 125.1.102.49 0 msec
    125.1.102.33 0 msec
    125.1.102.49 0 msec
  2 125.1.102.13 [MPLS: Labels 26/68 Exp 0] 0 msec
    125.1.102.17 [MPLS: Labels 26/68 Exp 0] 0 msec
    125.1.102.13 [MPLS: Labels 26/68 Exp 0] 0 msec
  3 125.1.101.9 [MPLS: Label 68 Exp 0] 4 msec 0 msec 0 msec
4 125.1.101.10 0 msec *  0 msec

Traceroute from DL1 to DL6 shows traffic flowing over the MPLS VPN network:

DL1-DC1-RED# traceroute vrf red-data 1.1.1.16

Type escape sequence to abort.
Tracing the route to 1.1.1.16

  1 125.1.101.1 0 msec
    125.1.101.9 0 msec
    125.1.101.1 4 msec
  2 125.1.100.69 [MPLS: Labels 59/73 Exp 0] 0 msec
    125.1.100.61 [MPLS: Labels 63/76 Exp 0] 0 msec
    125.1.100.69 [MPLS: Labels 59/73 Exp 0] 0 msec
  3 125.1.104.1 [MPLS: Label 76 Exp 0] 0 msec
    125.1.104.9 [MPLS: Label 73 Exp 0] 0 msec
    125.1.104.1 [MPLS: Label 76 Exp 0] 4 msec
  4 125.1.104.10 0 msec
    125.1.104.2 0 msec *

Traceroute from the backdoor link router to DL1, DL2 and DL6:


3600-bd-red#traceroute 1.1.1.1

Type escape sequence to abort.
Tracing the route to 1.1.1.1

  1 125.1.99.5 0 msec
    125.1.99.1 0 msec
    125.1.99.5 0 msec
  2 125.1.102.49 4 msec
    125.1.104.9 0 msec
    125.1.102.49 0 msec
  3 125.1.100.37 [MPLS: Labels 47/73 Exp 0] 4 msec
    125.1.102.17 [MPLS: Labels 26/68 Exp 0] 0 msec
    125.1.100.37 [MPLS: Labels 47/73 Exp 0] 4 msec
  4 125.1.101.9 [MPLS: Label 68 Exp 0] 0 msec
    125.1.100.74 [MPLS: Labels 23/73 Exp 0] 0 msec
    125.1.101.9 [MPLS: Label 68 Exp 0] 0 msec
  5 125.1.101.1 [MPLS: Label 73 Exp 0] 0 msec
    125.1.101.10 4 msec
    125.1.101.1 [MPLS: Label 73 Exp 0] 0 msec

3600-bd-red#traceroute 1.1.1.23

Type escape sequence to abort.
Tracing the route to 1.1.1.23

  1 125.1.99.1 0 msec *  0 msec

3600-bd-red#traceroute 1.1.1.16

Type escape sequence to abort.
Tracing the route to 1.1.1.16

  1 125.1.99.5 0 msec *  0 msec
3600-bd-red#

With the backdoor link between Data Center 2 (DL2) and Medium Campus (DL6), but OSPF sham-link configured on the relevant PEs; in this case, between PE3, PE4 and PE7, PE8 pairs:

Traceroute from DL2 to DL6 shows traffic flowing over the MPLS network:
DL2-DC2-RED#traceroute vrf red-data 1.1.1.16

Type escape sequence to abort.
Tracing the route to 1.1.1.16

  1 125.1.102.33 0 msec
    125.1.102.49 0 msec
    125.1.102.33 0 msec
  2 125.1.102.5 [MPLS: Labels 63/76 Exp 0] 0 msec
    125.1.102.1 [MPLS: Labels 63/76 Exp 0] 0 msec
    125.1.102.5 [MPLS: Labels 63/76 Exp 0] 0 msec
  3 125.1.104.1 [MPLS: Label 76 Exp 0] 4 msec 0 msec 0 msec
  4 125.1.104.2 0 msec *  0 msec

Traceroute from DL6 to DL2 shows traffic flowing over the MPLS VPN network:

DL6-MC-RED#traceroute 1.1.1.23

Type escape sequence to abort.
Tracing the route to 1.1.1.23

  1 125.1.104.1 0 msec
    125.1.104.9 0 msec
    125.1.104.1 0 msec
  2 125.1.100.37 [MPLS: Labels 50/88 Exp 0] 4 msec
    125.1.100.33 [MPLS: Labels 37/88 Exp 0] 0 msec
    125.1.100.37 [MPLS: Labels 50/88 Exp 0] 0 msec
  3 125.1.102.33 [MPLS: Label 88 Exp 0] 0 msec 0 msec 0 msec
  4 125.1.102.34 0 msec *  0 msec

QoS

Because only queueing was implemented on the Cisco 7600 PEs, the verification involves checking to see whether DSCP is being trusted as configured and whether priority for real-time traffic is maintained in case of congestion.

Oversubscribing the PE to CE egress link:

7600-DC2-PE3#sh queueing int g1/4
Interface GigabitEthernet1/4 queueing strategy:  Weighted Round-Robin
  Port QoS is enabled
  Trust state: trust DSCP
  Extend trust state: not trusted [COS = 0]
  Default COS is 0
    Queueing Mode In Tx direction: mode-cos
    Transmit queues [type = 1p3q8t]:
    Queue Id    Scheduling  Num of thresholds
    -----------------------------------------
       01         WRR                 08
       02         WRR                 08
       03         WRR                 08
       04         Priority            01

    WRR bandwidth ratios:    5[queue 1]  25[queue 2]  70[queue 3]
    queue-limit ratios:      5[queue 1]  25[queue 2]  40[queue 3]

    queue tail-drop-thresholds
    --------------------------
    1     70[1] 100[2] 100[3] 100[4] 100[5] 100[6] 100[7] 100[8]
    2     70[1] 100[2] 100[3] 100[4] 100[5] 100[6] 100[7] 100[8]
    3     100[1] 100[2] 100[3] 100[4] 100[5] 100[6] 100[7] 100[8]

    queue random-detect-min-thresholds
    ----------------------------------
      1    80[1] 100[2] 100[3] 100[4] 100[5] 100[6] 100[7] 100[8]
      2    80[1] 100[2] 100[3] 100[4] 100[5] 100[6] 100[7] 100[8]
      3    50[1] 60[2] 70[3] 80[4] 90[5] 100[6] 100[7] 100[8]

    queue random-detect-max-thresholds
    ----------------------------------
      1    100[1] 100[2] 100[3] 100[4] 100[5] 100[6] 100[7] 100[8]
      2    100[1] 100[2] 100[3] 100[4] 100[5] 100[6] 100[7] 100[8]
      3    60[1] 70[2] 80[3] 90[4] 100[5] 100[6] 100[7] 100[8]

    WRED disabled queues:

    queue thresh cos-map
    ---------------------------------------
    1     1      1
    1     2
    1     3
    1     4
    1     5
    1     6
    1     7
    1     8
    2     1      0
    2     2
    2     3
    2     4
    2     5
    2     6
    2     7
    2     8
    3     1      4
    3     2      2
    3     3      3
    3     4      6
    3     5      7
    3     6
    3     7
    3     8
    4     1      5

    Queueing Mode In Rx direction: mode-cos
    Receive queues [type = 2q8t]:
    Queue Id    Scheduling  Num of thresholds
    -----------------------------------------
       01         WRR                 08
       02         WRR                 08

    WRR bandwidth ratios:  100[queue 1]   0[queue 2]
    queue-limit ratios:    100[queue 1]   0[queue 2]

    queue tail-drop-thresholds
    --------------------------
    1     100[1] 100[2] 100[3] 100[4] 100[5] 100[6] 100[7] 100[8]
    2     100[1] 100[2] 100[3] 100[4] 100[5] 100[6] 100[7] 100[8]

    queue thresh cos-map
    ---------------------------------------
    1     1      0 1 2 3 4 5 6 7
    1     2
    1     3
    1     4
    1     5
    1     6
    1     7
    1     8
    2     1
    2     2
    2     3
    2     4
    2     5
    2     6
    2     7
    2     8


  Packets dropped on Transmit:

    queue     dropped  [cos-map]
    ---------------------------------------------
    1            11686  [1 ]
    2                0  [0 ]
    3                0  [4 2 3 6 7 ]
    4                0  [5 ]

  Packets dropped on Receive:

    queue     dropped  [cos-map]
    ---------------------------------------------
    1                0  [0 1 2 3 4 5 6 7 ]
    2                0  []

Multicast

The multicast service can be verified by performing the following steps. PE3 is the PE closest to the source, and PE8 is the PE closest to the test receiver.

1. Verify the BGP updates:

		sh ip pim mdt bgp

7600-DC2-PE3#sh ip pim mdt bgp
Peer (Route Distinguisher + IPv4)                                  Next Hop
  MDT group 239.232.10.4
   2:10:1041:125.1.125.5                                           125.1.125.5
   2:10:1042:125.1.125.6                                           125.1.125.6
   2:10:1044:125.1.125.8                                           125.1.125.8
  MDT group 239.232.10.1
   2:10:1054:125.1.125.8                                           125.1.125.8
   2:10:1055:125.1.125.9                                           125.1.125.9
   2:10:1056:125.1.125.10                                          125.1.125.10
   2:10:105:125.1.125.13                                           125.1.125.13
  MDT group 239.232.10.3
   2:10:1031:125.1.125.5                                           125.1.125.5
   2:10:1032:125.1.125.6                                           125.1.125.6
   2:10:1034:125.1.125.8                                           125.1.125.8
   2:10:1037:125.1.125.11                                          125.1.125.11
   2:10:1038:125.1.125.12                                          125.1.125.12
  MDT group 239.232.10.2
   2:10:1064:125.1.125.8                                           125.1.125.8
   2:10:1065:125.1.125.9                                           125.1.125.9
   2:10:1066:125.1.125.10                                          125.1.125.10
   2:10:106:125.1.125.13                                           125.1.125.13
		
		sh ip bgp vpnv4 all

7600-DC2-PE3#sh ip bgp vpnv4 all
BGP table version is 32649, local router ID is 125.1.125.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

<snip>

Route Distinguisher: 2:10:105
* i125.1.125.13/32  125.1.125.13             0    100      0 ?
*>i                 125.1.125.13             0    100      0 ?
Route Distinguisher: 2:10:106
* i125.1.125.13/32  125.1.125.13             0    100      0 ?
*>i                 125.1.125.13             0    100      0 ?
Route Distinguisher: 2:10:1031
* i125.1.125.5/32   125.1.125.5              0    100      0 ?
*>i                 125.1.125.5              0    100      0 ?
Route Distinguisher: 2:10:1032
* i125.1.125.6/32   125.1.125.6              0    100      0 ?
*>i                 125.1.125.6              0    100      0 ?
Route Distinguisher: 2:10:1033
*> 125.1.125.7/32   0.0.0.0                                0 ?
Route Distinguisher: 2:10:1034
* i125.1.125.8/32   125.1.125.8              0    100      0 ?
*>i                 125.1.125.8              0    100      0 ?
Route Distinguisher: 2:10:1037
* i125.1.125.11/32  125.1.125.11             0    100      0 ?
*>i                 125.1.125.11             0    100      0 ?
Route Distinguisher: 2:10:1038
* i125.1.125.12/32  125.1.125.12             0    100      0 ?
*>i                 125.1.125.12             0    100      0 ?
Route Distinguisher: 2:10:1041
* i125.1.125.5/32   125.1.125.5              0    100      0 ?
*>i                 125.1.125.5              0    100      0 ?
Route Distinguisher: 2:10:1042
* i125.1.125.6/32   125.1.125.6              0    100      0 ?
*>i                 125.1.125.6              0    100      0 ?
Route Distinguisher: 2:10:1043
*> 125.1.125.7/32   0.0.0.0                                0 ?
Route Distinguisher: 2:10:1044
* i125.1.125.8/32   125.1.125.8              0    100      0 ?
*>i                 125.1.125.8              0    100      0 ?
Route Distinguisher: 2:10:1053
*> 125.1.125.7/32   0.0.0.0                                0 ?
Route Distinguisher: 2:10:1054
   Network          Next Hop            Metric LocPrf Weight Path
* i125.1.125.8/32   125.1.125.8              0    100      0 ?
*>i                 125.1.125.8              0    100      0 ?
Route Distinguisher: 2:10:1055
* i125.1.125.9/32   125.1.125.9              0    100      0 ?
*>i                 125.1.125.9              0    100      0 ?
Route Distinguisher: 2:10:1056
* i125.1.125.10/32  125.1.125.10             0    100      0 ?
*>i                 125.1.125.10             0    100      0 ?
Route Distinguisher: 2:10:1063
*> 125.1.125.7/32   0.0.0.0                                0 ?
Route Distinguisher: 2:10:1064
* i125.1.125.8/32   125.1.125.8              0    100      0 ?
*>i                 125.1.125.8              0    100      0 ?
Route Distinguisher: 2:10:1065
* i125.1.125.9/32   125.1.125.9              0    100      0 ?
*>i                 125.1.125.9              0    100      0 ?
Route Distinguisher: 2:10:1066
* i125.1.125.10/32  125.1.125.10             0    100      0 ?
*>i                 125.1.125.10             0    100      0 ?


2. Verify the global mroute table:

sh ip mroute <>

7600-DC2-PE3# sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(125.1.125.7, 239.232.10.1), 3d14h/00:03:21, flags: sTZ
  Incoming interface: Loopback0, RPF nbr 0.0.0.0, RPF-MFD
  Outgoing interface list:
    GigabitEthernet1/2, Forward/Sparse, 3d14h/00:02:37, H
    GigabitEthernet1/3, Forward/Sparse, 3d14h/00:02:49, H

(125.1.125.8, 239.232.10.1), 3d14h/00:02:51, flags: sTIZ
  Incoming interface: GigabitEthernet1/3, RPF nbr 125.1.102.22, RPF-MFD
  Outgoing interface list:
    MVRF blue-data, Forward/Sparse, 3d14h/00:02:40, H

(125.1.125.9, 239.232.10.1), 3d14h/00:02:51, flags: sTIZ
  Incoming interface: GigabitEthernet1/2, RPF nbr 125.1.102.13, RPF-MFD
  Outgoing interface list:
    MVRF blue-data, Forward/Sparse, 3d14h/00:00:50, H

(125.1.125.10, 239.232.10.1), 1d04h/00:02:51, flags: sTIZ
  Incoming interface: GigabitEthernet1/2, RPF nbr 125.1.102.13, RPF-MFD
  Outgoing interface list:
    MVRF blue-data, Forward/Sparse, 05:00:10/00:02:55, H

(125.1.125.13, 239.232.10.1), 3d14h/00:02:51, flags: sTIZ
  Incoming interface: GigabitEthernet1/1, RPF nbr 125.1.102.1, RPF-MFD
  Outgoing interface list:
    MVRF blue-data, Forward/Sparse, 3d14h/00:02:40, H

(125.1.125.7, 239.232.10.2), 3d14h/00:03:21, flags: sTZ
  Incoming interface: Loopback0, RPF nbr 0.0.0.0, RPF-MFD
  Outgoing interface list:
    GigabitEthernet1/2, Forward/Sparse, 3d14h/00:02:49, H
    GigabitEthernet1/3, Forward/Sparse, 3d14h/00:02:50, H

(125.1.125.8, 239.232.10.2), 3d14h/00:02:51, flags: sTIZ
  Incoming interface: GigabitEthernet1/3, RPF nbr 125.1.102.22, RPF-MFD
  Outgoing interface list:
    MVRF blue-voice, Forward/Sparse, 3d14h/00:02:40, H

(125.1.125.9, 239.232.10.2), 3d14h/00:02:51, flags: sTIZ
  Incoming interface: GigabitEthernet1/2, RPF nbr 125.1.102.13, RPF-MFD
  Outgoing interface list:
    MVRF blue-voice, Forward/Sparse, 3d14h/00:00:50, H

(125.1.125.10, 239.232.10.2), 1d04h/00:02:51, flags: sTIZ
  Incoming interface: GigabitEthernet1/2, RPF nbr 125.1.102.13, RPF-MFD
  Outgoing interface list:
    MVRF blue-voice, Forward/Sparse, 05:00:07/00:02:58, H

(125.1.125.13, 239.232.10.2), 3d14h/00:02:50, flags: sTIZ
  Incoming interface: GigabitEthernet1/1, RPF nbr 125.1.102.1, RPF-MFD
  Outgoing interface list:
    MVRF blue-voice, Forward/Sparse, 3d14h/00:02:39, H

(125.1.125.5, 239.232.10.3), 3d14h/00:02:50, flags: sTIZ
  Incoming interface: GigabitEthernet1/1, RPF nbr 125.1.102.1, RPF-MFD
  Outgoing interface list:
    MVRF red-data, Forward/Sparse, 3d14h/00:00:49, H

(125.1.125.6, 239.232.10.3), 3d14h/00:02:50, flags: sTIZ
  Incoming interface: GigabitEthernet1/2, RPF nbr 125.1.102.13, RPF-MFD
  Outgoing interface list:
    MVRF red-data, Forward/Sparse, 3d14h/00:00:49, H

(125.1.125.7, 239.232.10.3), 3d14h/00:03:20, flags: sTZ
  Incoming interface: Loopback0, RPF nbr 0.0.0.0, RPF-MFD
  Outgoing interface list:
    GigabitEthernet1/2, Forward/Sparse, 3d14h/00:02:44, H
    GigabitEthernet1/1, Forward/Sparse, 3d14h/00:02:45, H
    GigabitEthernet1/3, Forward/Sparse, 3d14h/00:03:04, H

(125.1.125.8, 239.232.10.3), 3d14h/00:02:50, flags: sTIZ
  Incoming interface: GigabitEthernet1/3, RPF nbr 125.1.102.22, RPF-MFD
  Outgoing interface list:
    MVRF red-data, Forward/Sparse, 3d14h/00:02:39, H

(125.1.125.11, 239.232.10.3), 3d14h/00:02:50, flags: sTIZ
  Incoming interface: GigabitEthernet1/1, RPF nbr 125.1.102.1, RPF-MFD
  Outgoing interface list:
    MVRF red-data, Forward/Sparse, 3d14h/00:01:20, H

(125.1.125.12, 239.232.10.3), 3d14h/00:02:50, flags: sTIZ
  Incoming interface: GigabitEthernet1/2, RPF nbr 125.1.102.13, RPF-MFD
  Outgoing interface list:
    MVRF red-data, Forward/Sparse, 3d14h/00:00:49, H

(125.1.125.5, 239.232.10.4), 3d14h/00:02:50, flags: sTIZ
  Incoming interface: GigabitEthernet1/1, RPF nbr 125.1.102.1, RPF-MFD
  Outgoing interface list:
    MVRF red-voice, Forward/Sparse, 3d14h/00:00:49, H

(125.1.125.6, 239.232.10.4), 3d14h/00:02:50, flags: sTIZ
  Incoming interface: GigabitEthernet1/2, RPF nbr 125.1.102.13, RPF-MFD
  Outgoing interface list:
    MVRF red-voice, Forward/Sparse, 3d14h/00:00:49, H

(125.1.125.7, 239.232.10.4), 3d14h/00:03:27, flags: sTZ
  Incoming interface: Loopback0, RPF nbr 0.0.0.0, RPF-MFD
  Outgoing interface list:
    GigabitEthernet1/2, Forward/Sparse, 3d14h/00:03:27, H
    GigabitEthernet1/1, Forward/Sparse, 3d14h/00:03:02, H
    GigabitEthernet1/3, Forward/Sparse, 3d14h/00:03:10, H

(125.1.125.8, 239.232.10.4), 3d14h/00:02:50, flags: sTIZ
  Incoming interface: GigabitEthernet1/3, RPF nbr 125.1.102.22, RPF-MFD
  Outgoing interface list:
    MVRF red-voice, Forward/Sparse, 3d14h/00:02:38, H

(125.1.125.7, 239.232.20.32), 00:02:29/00:03:20, flags: sT
  Incoming interface: Loopback0, RPF nbr 0.0.0.0, RPF-MFD
  Outgoing interface list:
    GigabitEthernet1/2, Forward/Sparse, 00:02:29/00:02:56, H

(125.1.125.8, 239.232.20.32), 00:03:47/00:02:12, flags: sPT
  Incoming interface: GigabitEthernet1/3, RPF nbr 125.1.102.22, RPF-MFD
  Outgoing interface list: Null

(*, 224.0.1.40), 3d14h/00:02:09, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback0, Forward/Sparse, 3d14h/00:02:09

3. Verify the mroutes in the VRF (on the receiving router):

		7600-MC-PE8#sh ip mroute vrf red-data
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.232.10.1), 02:57:22/00:03:13, RP 3.3.3.11, flags: S
  Incoming interface: Tunnel0, RPF nbr 125.1.125.7, RPF-MFD
  Outgoing interface list:
    GigabitEthernet1/3, Forward/Sparse, 02:57:22/00:03:13, H

(125.1.2.66, 224.232.10.1), 02:57:22/00:03:23, flags: TY
  Incoming interface: Tunnel0, RPF nbr 125.1.125.7, RPF-MFD, MDT:[125.1.125.7,23
9.232.20.32]/00:02:44
  Outgoing interface list:
    GigabitEthernet1/3, Forward/Sparse, 02:57:22/00:03:13, H

(*, 224.0.1.40), 3d17h/00:03:10, RP 3.3.3.11, flags: SJCL
  Incoming interface: Tunnel0, RPF nbr 125.1.125.7
  Outgoing interface list:
    GigabitEthernet1/3, Forward/Sparse, 3d17h/00:03:10

(*, 239.255.255.250), 02:57:22/00:03:02, RP 3.3.3.11, flags: S
  Incoming interface: Tunnel0, RPF nbr 125.1.125.7, RPF-MFD
  Outgoing interface list:
    GigabitEthernet1/3, Forward/Sparse, 02:57:22/00:03:02, H										

4. Verify the PIM neighbors in the global table:

sh ip pim nei

7600-DC2-PE3#sh ip pim nei
PIM Neighbor Table
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
125.1.102.1       GigabitEthernet1/1       3d14h/00:01:17    v2    1 /
125.1.102.13      GigabitEthernet1/2       3d14h/00:01:23    v2    1 / S
125.1.102.22      GigabitEthernet1/3       3d14h/00:01:26    v2    1 / DR

5.			Verify the PIM neighbors with the VPN
	sh ip pim vrf <> nei

7600-DC2-PE3#sh ip pim vrf red-data nei
PIM Neighbor Table
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
125.1.102.34      GigabitEthernet1/4.1     3d14h/00:01:30    v2    1 / DR S
125.1.125.11      Tunnel1                  3d14h/00:01:17    v2    1 / S
125.1.125.5       Tunnel1                  3d14h/00:01:16    v2    1 / S
125.1.125.6       Tunnel1                  3d14h/00:01:37    v2    1 / S
125.1.125.12      Tunnel1                  3d14h/00:01:34    v2    1 / DR S
125.1.125.8       Tunnel1                  3d14h/00:01:17    v2    1 /