V3PN: Redundancy and Load Sharing Design Guide
Large Branch—Inverse Multiplexing over ATM (IMA)
Downloads: This chapterpdf (PDF - 370.0KB) The complete bookPDF (PDF - 5.2MB) | Feedback

Large Branch—Inverse Multiplexing over ATM (IMA)

Table Of Contents

Large Branch—Inverse Multiplexing over ATM (IMA)

Topology

Implementation and Configuration

Head-end Router

Remote Router

Performance

Summary


Large Branch—Inverse Multiplexing over ATM (IMA)


This configuration is similar to Chapter 10, "Large Branch—Multilink PPP." This chapter substitutes the previous solution of Multilink PPP (over two serial T1 links) with Inverse Multiplexing over ATM (IMA) using a bundle of two ATM circuits, and shows only the relevant configuration portions and performance results.

This chapter includes the following sections:

Topology

Implementation and Configuration

Performance

Summary

Topology

The topology is identical to the previous section with the exception of replacing the Multilink PPP configured dual serial links with IMA adapters. (See Figure 11-1.)

Figure 11-1 Large Branch—ATM (IMA)

Implementation and Configuration

This section describes the configuration of the components of the inverse multiplexing over ATM (ATA) solution.

Head-end Router

Following is the head-end router configuration:

!
hostname vpn-jk2-3725-4
!
interface ATM2/0
 description ATM2/0
 no ip address
 no atm ilmi-keepalive
 ima-group 0
 clock source internal
 no scrambling-payload
!
interface ATM2/1
 description ATM2/1
 no ip address
 no atm ilmi-keepalive
 ima-group 0
 clock source internal
 no scrambling-payload
!
interface ATM2/2
 no ip address
 shutdown
 no atm ilmi-keepalive
 clock source internal
 no scrambling-payload
!
interface ATM2/3
 no ip address
 shutdown
 no atm ilmi-keepalive
 clock source internal
 no scrambling-payload
!
interface ATM2/IMA0
 description ATM2/IMA0
 no ip address
 ip route-cache flow
 load-interval 30
 no atm ilmi-keepalive
 ima active-links-minimum 2
 ima clock-mode common 0
 ima differential-delay-maximum 26											# Default value is 25ms, 26 used so it will
!											# show in the configuration
interface ATM2/IMA0.1 point-to-point
 description ATM2/IMA0.1
 bandwidth 3072
 ip address 192.168.193.13 255.255.255.252
 crypto map DYNO-MAP										# Same dynamic crypto map/tunnel interface as MLPPP
 pvc YELLOW 0/100 
  vbr-nrt 3072 3072										# Highest value supported.
  oam-pvc manage
  oam retry 5 5 5
  service-policy output V3PN_Branch												# Same as MLPPP
 !
!
ip route 0.0.0.0 0.0.0.0 ATM2/IMA0.1 250
ip route 10.0.80.0 255.255.255.128 Tunnel0 237

. . .

end

Remote Router

Following is the remote router configuration:

!
hostname vpn-jk2-3725-3
!
interface ATM2/0
 description ATM2/0
 no ip address
 no atm ilmi-keepalive
 ima-group 0
 no scrambling-payload
!
interface ATM2/1
 description ATM2/1
 no ip address
 no atm ilmi-keepalive
 ima-group 0
 no scrambling-payload
!
interface ATM2/2
 no ip address
 shutdown
 no atm ilmi-keepalive
 no scrambling-payload
!
interface ATM2/3
 no ip address
 shutdown
 no atm ilmi-keepalive
 no scrambling-payload
!
interface ATM2/IMA0
 description ATM2/IMA0
 no ip address
 ip route-cache flow
 load-interval 30
 no atm ilmi-keepalive
 ima active-links-minimum 2
 ima clock-mode common 0
 ima differential-delay-maximum 26
!
interface ATM2/IMA0.1 point-to-point
 description ATM2/IMA0.1
 bandwidth 3072
 ip address 192.168.193.14 255.255.255.252
 crypto map PRIMARY_LINK
 pvc YELLOW 0/100 
  vbr-nrt 3072 3072
  oam-pvc manage
  oam retry 5 5 5
  service-policy output V3PN_Branch
 !
!
ip route 0.0.0.0 0.0.0.0 ATM2/IMA0.1 250
ip route 10.3.0.0 255.255.255.128 Tunnel0 237

end

Performance

The performance results shown in Table 11-1 were produced using similar traffic profiles and QoS policies as described in Chapter 10, "Large Branch—Multilink PPP."

Table 11-1 3725 ATM IMA Performance

Cisco 3725
ATM/ATA
2 links 3072 Kbps total
Voice
milliseconds
Number data
CPU
Jitter
(goal <8)
Latency
)goal< 50)
G.729
Calls
Mbps
in/out

Default WRED

5.4

16.7

15

2.9M

22%

Tuned WRED

5.3

14.1

15

2.9M

23%

Voice + Video

Tuned WRED

4.7

14.4

9

3.9M

19%


Because the amount of raw bandwidth was slightly higher in the IMA configuration, one additional voice call was added in the IMA voice and video test. The Chariot test for the IMA testing included proportionally more flows of the same applications as well.

In the PVC configuration for the IMA subinterface, the vbr-nrt parameter was configured at the highest configurable value, 3072 kbps, while the Multilink PPP interfaces were clocked individually at 1,300,000. This difference accounts for the slightly higher throughput of data in the test results. However recall that the ATM cell tax is appreciable higher than the overhead associated with Multilink PPP, so that the gain in bandwidth is offset to some extent.

It should be noted that although the voice latency in these tests was well within the goal of being less than 50 ms, it was higher than the Multilink PPP values. However overall CPU averaged lower.

Summary

These performance results along with the Multilink PPP results demonstrate the viability of V3PN with data rates above E1.