Campus 3.0 Virtual Switching System Design Guide
VSS-Enabled Campus Best Practice Configuration Example
Downloads: This chapterpdf (PDF - 500.0KB) The complete bookPDF (PDF - 6.27MB) | Feedback

VSS-Enabled Campus Best Practice Configuration Example

Table Of Contents

VSS-Enabled Campus Best Practice Configuration Example

End-to-End Device Configurations

VSS Specific

Layer-2 Domain

Layer-3 Domain

EIGRP MEC

EIGRP ECMP

OSPF MEC

OSPF ECMP


VSS-Enabled Campus Best Practice Configuration Example


Figure A-1 illustrates the baseline best practice configuration required to set up basic VSS enabled network. The circle indicates the essential steps required to create the VSS systems from standalone. The red text highlights the important CLI information with VSS configuration. Comments are provided in blue italic font.

Figure A-1 Overall VSS-Enabled Campus Best Practice Configuration Summary

End-to-End Device Configurations

The end-to-end devices configuration is categorized into three major sections. Each section configuration contains specific CLI which is a required as part of best practice configuration and corresponding explanation.

VSS and L2 Domain- Includes above base configuration as well as L2 domain configuration

Access-layer- Sample L2 domain configuration

L3 Domain - Includes global L3 configuration for VSS and core routers. Then separate section for specifics topologies (ECMP and MEC) for EIGRP and OSPF. In addition, the core devices configuration shown below are standalone router/devices.

VSS Specific

VSS Global Configuration

switch virtual domain 10 ! Must configure unique domain ID
 switch mode virtual
 switch 1 priority 110 ! Not needed, helps in operational mgmt
 switch 2 priority 100 ! Not needed, helps in operational mgmt
 dual-active exclude interface GigabitEthernet1/5/3 ! Connectivity to VSS during dual 
active
mac-address use-virtual ! Required for consistent MAC address
dual-active detection pagp trust channel-group 202 ! Enhanced PAgP based dual active 
detection

redundancy ! Default SSO Enabled
 main-cpu 
  auto-sync running-config 
 mode sso 

Switch 1

interface Port-channel1 ! Unique port-channel number for SW 1
 description VSL Link from Switch 1 
 no switchport 
 no ip address 
switch virtual link 1 ! Defines switch ID for SW 1
 mls qos trust cos 
 no mls qos channel-consistency 

interface ten 1/5/4 
channel-group 1 mode on ! EC mode is ON - EtherChannel Managemeent Protocol off
interface ten 1/1/1 
channel-group 1 mode on 

Switch 2

interface Port-channel2 ! Unique port-channel number for SW 1
 description VSL Link from Switch 2 
 no switchport 
 no ip address 
switch virtual link 2 ! Defines switch ID for SW 2
 mls qos trust cos 
 no mls qos channel-consistency

interface ten 2/5/4 
channel-group 2 mode on ! EC mode is ON - EtherChannel Managemeent Protocoloff
interface ten 2/1/1 
channel-group 2 mode on

Layer-2 Domain

VSS

udld enable  
vtp domain campus-test  
vtp mode transparent  
   
spanning-tree mode rapid-pvst  
no spanning-tree optimize bpdu transmission  
spanning-tree extend system-id  
spanning-tree vlan 2-999 priority 24576 !  STP Root
   
port-channel load-balance src-dst-mixed-ip-port !  Enhanced hash algorithem
   
   
vlan 400 !  VLANs spanning multiple access-layer SWs
 name L2_ Spaned_VLAN _400  
   
vlan 450  
 name L2_ Spaned_VLAN _450  
   
vlan 500  
 name L2_ Spaned_VLAN _500  
   
vlan 550  
 name L2_ Spaned_VLAN _550  
   
vlan 600  
 name L2_ Spaned_VLAN _600  
   
vlan 650  
 name L2_Spaned_VLAN_650  
   
vlan 900  
 name NetMgmt_VLAN_900  
   
vlan 999   
 name Unused_Port_VLAN_999  
   
vlan 2  
 name cr7-3750-Stack-Data-VLAN  
!  
vlan 102  
 name cr7-3750-Stack-Voice-VLAN  
   
interface Vlan2 ! Sample VLAN interface configuration
 ip address 10.120.2.1 255.255.255.0  
 no ip redirects  
 no ip unreachables  
 ip flow ingress  
 ip pim sparse-mode  
 logging event link-status  
 hold-queue 150 in  
 hold-queue 150 out  
!  

VSS—Multi-Chassis EtherChannel

PAgP

interface GigabitEthernet1/8/23  !  Interface on SW 1
 description Access Switch Facing Interface   
 switchport   
 switchport trunk encapsulation dot1q   
 switchport trunk native vlan 202   
switchport mode dynamic desirable ! Trunk mod dynamic and desirable
 switchport trunk allowed vlan 2,102,400,450,500,550,600,650,900 !  Only allow need VLANs 
for a given trunk
logging event link-status !  Logging for link status
logging event trunk-status !  Logging for trunk status
logging event bundle-status !  Logging for port-channel status
 load-interval 30  
 mls qos trust dscp  
channel-protocol pagp   
channel-group 202 mode desirable !  Define Port-channel, PAgP mode desirable 
   
   
interface GigabitEthernet2/8/23  !  Interface on SW 2
 description Access Switch Facing Interface 
 switchport   
 switchport trunk encapsulation dot1q   
 switchport trunk native vlan 202   
switchport mode dynamic desirable  
 switchport trunk allowed vlan 2,102,400,450,500,550,600,650,900  
 logging event link-status  
 logging event trunk-status  
 logging event bundle-status  
 load-interval 30  
 mls qos trust dscp  
 load-interval 30  
channel-protocol pagp   
channel-group 202 mode desirable    
   
interface Port-channel202  !  Automatically created by defining at interfaces
 description Access Switch MEC
 switchport  
 switchport trunk encapsulation dot1q  
 switchport trunk native vlan 202  
 switchport trunk allowed vlan 2,102,400,450,500,550,600,650,900  
logging event link-status  
logging event spanning-tree status ! STP logging enabled on port-channel 
 load-interval 30  
 mls qos trust dscp  
 spanning-tree portfast ! Optional - helps during initialization
 hold-queue 2000 out 

LACP

LACP Sample Configuration

interface GigabitEthernet1/8/23  
 description Access Switch Facing Interface
 switchport  
 switchport trunk encapsulation dot1q  
 switchport trunk native vlan 202  
switchport mode dynamic desirable  
 switchport trunk allowed vlan 2,102,400,450,500,550,600,650,900  
logging event link-status  
logging event trunk-status  
logging event bundle-status  
 load-interval 30  
 mls qos trust dscp  
 channel-protocol lacp  
 channel-group 202 mode active  
 hold-queue 2000 out  
   
interface GigabitEthernet2/8/23  
 description Access Switch Facing Interface
 switchport  
 switchport trunk encapsulation dot1q  
 switchport trunk native vlan 202  
switchport mode dynamic desirable  
 switchport trunk allowed vlan 2,102,400,450,500,550,600,650,900  
logging event link-status  
logging event trunk-status  
logging event bundle-status  
 load-interval 30  
 mls qos trust dscp  
 channel-protocol lacp  
 channel-group 202 mode active  
 hold-queue 2000 out  
 
interface Port-channel202 !  Automatically created by defining at interfaces
 description Access Switch MEC
 switchport 
 switchport trunk encapsulation dot1q 
 switchport trunk native vlan 202 
 switchport trunk allowed vlan 2,102,400,450,500,550,600,650,900 
logging event link-status 
logging event spanning-tree status 
 load-interval 30 
 mls qos trust dscp 
 spanning-tree portfast ! Optional - helps during initialization
 hold-queue 2000 out 
  

Access-Layer Switch

Sample Configuration (Platform Specific Configuration Varies)

interface GigabitEthernet0/27 
 description Uplink to VSS Switch Gig 1/8/24  
 switchport trunk encapsulation dot1q 
 switchport trunk native vlan 203 
switchport mode dynamic desirable  
 switchport trunk allowed vlan 3,103,400,450,500,550,600,650,900 
 logging event link-status  
 logging event trunk-status  
 logging event bundle-status  
 carrier-delay msec 0 
 srr-queue bandwidth share 1 70 25 5 
 srr-queue bandwidth shape  3  0  0  0  
 priority-queue out  
 mls qos trust dscp 
channel-protocol pagp  
channel-group 1 mode desirable   
 
interface GigabitEthernet0/28 
 description Uplink to VSS Switch Gig 2/8/24 
 switchport trunk encapsulation dot1q 
 switchport trunk native vlan 203 
 switchport trunk allowed vlan 3,103,400,450,500,550,600,650,900 
 switchport mode dynamic desirable 
 logging event link-status  
 logging event trunk-status  
 logging event bundle-status  
 carrier-delay msec 0 
 srr-queue bandwidth share 1 70 25 5 
 srr-queue bandwidth shape  3  0  0  0  
 priority-queue out  
 mls qos trust dscp 
channel-protocol pagp  
channel-group 1 mode desirable   
 
 
interface Port-channel1 !  Automatically created by defining at interfaces
 description EC Uplink to VSS  
 switchport trunk encapsulation dot1q 
 switchport trunk native vlan 203 
 switchport trunk allowed vlan 3,103,400,450,500,550,600,650,900 
 switchport mode dynamic desirable 
logging event link-status 
logging event spanning-tree status 
 carrier-delay msec 0 
 spanning-tree portfast ! Optional - helps during initialization


Layer-3 Domain

The Layer 3 domain represents VSS interconnection to the core-layer. The core-layer devices configuration shown below are standalone router/switch.

Global Configuration

mls ip cef load-sharing <option> !  Apply Campus Best Practices

Multicast

VSS

ip multicast-routing   
ip pim rp-address 10.122.100.1 GOOD-IPMC override !  RP mapping with filter
   
ip access-list standard GOOD-IPMC  
 permit 224.0.1.39  
 permit 224.0.1.40  
 permit 239.192.240.0 0.0.3.255  
 permit 239.192.248.0 0.0.3.255  
   

Core 1 Standalone Router (No VSS)

Core RP ANYCAST - Primary

ip multicast-routing   
   
interface Loopback0  
 description MSDP PEER INT !  MSDP Loopback
 ip address 10.122.10.1 255.255.255.255  
  
interface Loopback1  
 description ANYCAST RP ADDRESS (PRIMARY) !  Anycast RP Primary 
 ip address 10.122.100.1 255.255.255.255  
  
interface Loopback2  
 description Garbage-CAN RP  
 ip address 2.2.2.2 255.255.255.255  
  
interface Port-channel1 !  Core 1- Core2 L3 for MSDP
 description Channel to Peer Core Node  
 dampening  
 ip address 10.122.0.18 255.255.255.254  
 ip pim sparse-mode 
 load-interval 30  
 carrier-delay msec 0  
 mls qos trust dscp  
   
ip access-list standard GOOD-IPMC  
 permit 224.0.1.39  
 permit 224.0.1.40  
 permit 239.192.240.0 0.0.3.255  
 permit 239.192.248.0 0.0.3.255  
   
ip msdp peer 10.122.10.2 connect -source Loopback0 ! MSDP Configuration
ip msdp description 10.122.10.2 ANYCAST-PEER-6k-core-2 
ip msdp cache -sa-state 
ip msdp originator-id Loopback0 
 

Core 2 Standalone Router (No VSS)

ip multicast-routing   
   
interface Loopback0  
 description MSDP PEER INT  
 ip address 10.122.10.2 255.255.255.255  
  
interface Loopback1  
 description ANYCAST RP ADDRESS   
 ip address 10.122.100.1 255.255.255.255 ! Secondary ANYCAST RP
 delay 600 
  
interface Loopback2  
 description Garbage-CAN RP  
 ip address 2.2.2.2 255.255.255.255  
   
interface Port-channel1  
 description Channel to Peer Core node  
 dampening  
 ip address 10.122.0.19 255.255.255.254  
 ip pim sparse-mode  
 load-interval 30  
 carrier-delay msec 0  
 mls qos trust dscp  
   
ip pim rp-address 10.122.100.1 GOOD-IPMC override  
ip access-list standard GOOD-IPMC  
 permit 224.0.1.39  
 permit 224.0.1.40  
 permit 239.192.240.0 0.0.3.255  
 permit 239.192.248.0 0.0.3.255  
   
ip msdp peer 10.122.10.1 connect-source Loopback0  
ip msdp description 10.122.10.1 ANYCAST-PEER-6k-core-1  
ip msdp cache-sa-state  
ip msdp originator-id Loopback0  

EIGRP MEC

VSS

router eigrp 100  
 passive-interface default  
 no passive-interface Port-channel200  
 no passive-interface Port-channel201  
 network 10.0.0.0  
eigrp log-neighbor-warnings  
eigrp log-neighbor-changes  
 no auto-summary  
 eigrp router-id 10.122.102.1  
 eigrp event-log-size 3000  
 nsf !  Enable NSF Capability
 
interface Port-channel200 !  Create L3 MEC Interface first
 description 20 Gig MEC to CORE-1 (cr2-6500-1 4/1-4/3) 
 no switchport  
 dampening  
 ip address 10.122.0.26 255.255.255.254  
 ip flow ingress  
 ip pim sparse-mode  
 ip summary-address eigrp 100 10.125.0.0 255.255.0.0 5 !  Summarization for Access-subnets
 ip summary-address eigrp 100 10.120.0.0 255.255.0.0 5  
 logging event link-status  
 load-interval 30  
 carrier-delay msec 0  
 mls qos trust dscp  
 hold-queue 2000 in  
 hold-queue 2000 out  
!  
interface Port-channel201  
 description 20 Gig to CORE-2 (cr2-6500-1 4/1-4/3) 
 no switchport  
 dampening  
 ip address 10.122.0.21 255.255.255.254  
 ip flow ingress  
 ip pim sparse-mode  
 ip summary-address eigrp 100 10.125.0.0 255.255.0.0 5  
 ip summary-address eigrp 100 10.120.0.0 255.255.0.0 5  
 logging event link-status  
 load-interval 30  
 carrier-delay msec 0  
 mls qos trust dscp  
 hold-queue 2000 in  
 hold-queue 2000 out  
   
interface TenGigabitEthernet1/2/1 
 description 10 GigE to Core 1 
 no switchport 
 no ip address 
 logging event link-status 
 logging event bundle-status 
 load-interval 30 
 carrier-delay msec 0 
 mls qos trust dscp 
 channel-protocol pagp 
 channel-group 200 mode desirable 
 hold-queue 2000 in 
 hold-queue 2000 out 
! 
interface TenGigabitEthernet1/2/2 
 description 10 GigE to Core 2 
 no switchport 
 no ip address 
 logging event link-status 
 logging event bundle-status 
 load-interval 30 
 carrier-delay msec 0 
 mls qos trust dscp 
 channel-protocol pagp 
 channel-group 201 mode desirable 
 hold-queue 2000 in 
 hold-queue 2000 out 
 
interface TenGigabitEthernet2/2/1 
 description to core 1 
 no switchport 
 no ip address 
 logging event link-status 
 logging event bundle-status 
 logging event spanning-tree status 
 load-interval 30 
 mls qos trust dscp 
 channel-protocol pagp 
 channel-group 200 mode desirable 
 hold-queue 2000 in 
 hold-queue 2000 out 
 
interface TenGigabitEthernet2/2/2 
 description 10 GigE to Core 2 
 no switchport 
 no ip address 
 logging event link-status 
 logging event bundle-status 
 load-interval 30 
 mls qos trust dscp 
 channel-protocol pagp 
 channel-group 201 mode desirable 
 hold-queue 2000 in 
 hold-queue 2000 out 
 

Core 1 Standalone Router (No VSS)

router eigrp 100  
 passive-interface default  
 no passive-interface Port-channel1  
 no passive-interface Port-channel20  
 no passive-interface Port-channel221  
 network 10.0.0.0  
 no auto-summary  
eigrp log-neighbor-warnings  
eigrp log-neighbor-changes  
eigrp event-log-size 3000  
   
interface Port-channel20  
 description 20 Gig MEC to VSS 1/2/1 2/2/1  
 dampening  
 ip address 10.122.0.27 255.255.255.254  
 ip flow ingress  
 ip pim sparse-mode  
 logging event link-status  
 load-interval 30  
 carrier-delay msec 0  
 mls qos trust dscp  
 hold-queue 2000 in  
 hold-queue 2000 out  
   

Core 2 Standalone Router (No VSS)

router eigrp 100  
 passive-interface default  
 no passive-interface Port-channel1  
 no passive-interface Port-channel20  
 no passive-interface Port-channel221  
 network 10.0.0.0  
 no auto-summary  
eigrp log-neighbor-warnings  
eigrp log-neighbor-changes  
eigrp event-log-size 3000  
  
interface Port-channel21  
 description 20 Gig to VSS 1/2/2-2/2/2  
 dampening  
 ip address 10.122.0.20 255.255.255.254  
 ip flow ingress  
 ip pim sparse-mode  
 logging event link-status  
 load-interval 30  
 carrier-delay msec 0  
 mls qos trust dscp  
 hold-queue 2000 in  
 hold-queue 2000 out  

EIGRP ECMP

VSS

router eigrp 100  
 passive-interface default  
 no passive-interface TenGigabitEthernet1/2/1  
 no passive-interface TenGigabitEthernet1/2/2  
 no passive-interface TenGigabitEthernet2/2/1  
 no passive-interface TenGigabitEthernet2/2/2  
 network 10.0.0.0  
 no auto-summary  
 eigrp router-id 10.122.102.1  
 eigrp log-neighbor-warnings  
 eigrp log-neighbor-changes  
 eigrp event-log-size 3000  
 nsf !  Enable NSF Capability
   
interface TenGigabitEthernet1/2/1  
 description 10 GigE to Core 1  
 no switchport  
 dampening  
 ip address 10.122.0.26 255.255.255.254  
 ip flow ingress  
 ip pim sparse-mode  
 ip summary-address eigrp 100 10.120.0.0 255.255.0.0 5  
 logging event link-status  
 load-interval 30  
 carrier-delay msec 0  
 mls qos trust dscp  
 hold-queue 2000 in  
 hold-queue 2000 out  
!  
interface TenGigabitEthernet1/2/2  
 description 10 GigE to Core 2  
 no switchport  
 dampening  
 ip address 10.122.0.23 255.255.255.254  
 ip flow ingress  
 ip pim sparse-mode  
 ip summary-address eigrp 100 10.120.0.0 255.255.0.0 5  
 logging event link-status  
 load-interval 30  
 carrier-delay msec 0  
 mls qos trust dscp  
 hold-queue 2000 in  
 hold-queue 2000 out  
   
interface TenGigabitEthernet2/2/1  
 description to Core 1 
 no switchport  
 dampening  
 ip address 10.122.0.32 255.255.255.254  
 ip flow ingress  
 ip pim sparse-mode  
 ip summary-address eigrp 100 10.120.0.0 255.255.0.0 5  
 logging event link-status  
 load-interval 30  
 mls qos trust dscp  
 hold-queue 2000 in  
 hold-queue 2000 out  
!  
interface TenGigabitEthernet2/2/2  
 description 10 GigE to Core 2  
 no switchport  
 dampening  
 ip address 10.122.0.20 255.255.255.254  
 ip flow ingress  
 ip pim sparse-mode  
 ip summary-address eigrp 100 10.120.0.0 255.255.0.0 5  
 logging event link-status  
 load-interval 30  
 mls qos trust dscp  
 hold-queue 2000 in  
 hold-queue 2000 out  
   

Core 1 Standalone Router (No VSS)

router eigrp 100  
 passive-interface default  
 no passive-interface TenGigabitEthernet4/1  
 no passive-interface TenGigabitEthernet4/3  
 network 10.0.0.0  
 no auto-summary  
eigrp log-neighbor-warnings  
eigrp log-neighbor-changes  
eigrp event-log-size 3000  
  
interface TenGigabitEthernet4/1  
 description To VSS Ten1/2/1  
 dampening  
 ip address 10.122.0.27 255.255.255.254  
 ip flow ingress  
 ip pim sparse-mode  
 logging event link-status  
 load-interval 30  
 carrier-delay msec 0  
 mls qos trust dscp  
 hold-queue 2000 in  
 hold-queue 2000 out  
   
interface TenGigabitEthernet4/3  
 description To VSS Ten2/2/1  
 dampening  
 ip address 10.122.0.33 255.255.255.254  
 ip flow ingress  
 ip pim sparse-mode  
 logging event link-status  
 logging event bundle-status  
 load-interval 30  
 carrier-delay msec 0  
 mls qos trust dscp  
 hold-queue 2000 in  
 hold-queue 2000 out  
   

Core 2 Standalone Router (No VSS)

router eigrp 100  
 passive-interface default  
 no passive-interface TenGigabitEthernet4/1  
 no passive-interface TenGigabitEthernet4/3  
 network 10.0.0.0  
 no auto-summary  
eigrp log-neighbor-warnings  
eigrp log-neighbor-changes  
eigrp event-log-size 3000  
   
interface TenGigabitEthernet4/1  
 description To VSS Ten 1/2/2  
 dampening  
 ip address 10.122.0.22 255.255.255.254  
 ip flow ingress  
 ip pim sparse-mode  
 logging event link-status  
 load-interval 30  
 carrier-delay msec 0  
 mls qos trust dscp  
 hold-queue 2000 in  
 hold-queue 2000 out  
   
interface TenGigabitEthernet4/3  
 description To VSS Ten 2/2/2  
 dampening  
 ip address 10.122.0.21 255.255.255.254  
 ip flow ingress  
 ip pim sparse-mode  
 logging event link-status  
 load-interval 30  
 carrier-delay msec 0  
 mls qos trust dscp  
 hold-queue 2000 in  
 hold-queue 2000 out  

OSPF MEC

VSS

router ospf 100  
 router-id 10.122.0.235  
 log-adjacency-changes detail  
 auto-cost reference-bandwidth 20000 !  Optional
 nsf !  Enable NSF Capability
 area 120 stub no-summary  
 area 120 range 10.120.0.0 255.255.0.0 cost 10  
 area 120 range 10.125.0.0 255.255.0.0 cost 10  
 passive-interface default  
 no passive-interface Port-channel200  
 no passive-interface Port-channel201  
 network 10.120.0.0 0.0.255.255 area 120  
 network 10.122.0.0 0.0.255.255 area 0  
 network 10.125.0.0 0.0.255.255 area 120  
   
   
interface Port-channel200  
 description 20 Gig MEC to VSS (cr2-6500-1 4/1-4/3) 
 no switchport  
 dampening  
 ip address 10.122.0.26 255.255.255.254  
 ip flow ingress  
 ip pim sparse-mode  
 ip ospf network point-to-point  
 logging event link-status  
 load-interval 30  
 carrier-delay msec 0  
 mls qos trust dscp  
 hold-queue 2000 in  
 hold-queue 2000 out  
!  
interface Port-channel201  
 description 20 Gig to VSS (cr2-6500-1 4/1-4/3) 
 no switchport  
 dampening  
 ip address 10.122.0.21 255.255.255.254  
 ip flow ingress  
 ip pim sparse-mode  
 ip ospf network point-to-point  
 logging event link-status  
 load-interval 30  
 carrier-delay msec 0  
 mls qos trust dscp  
 hold-queue 2000 in  
 hold-queue 2000 out  
   

Core 1 Standalone Router No VSS)

router ospf 100  
 router-id 10.254.254.7  
 log-adjacency-changes detail ! Helps in NSF Restart Activities
 auto-cost reference-bandwidth 20000 !  Optional
 passive-interface default  
 no passive-interface Port-channel1  
 no passive-interface Port-channel20  
 network 10.122.0.0 0.0.255.255 area 0  
   
interface Port-channel20  
 description 20 Gig MEC to VSS 1/2/1 2/2/1  
 dampening  
 ip address 10.122.0.27 255.255.255.254  
 ip flow ingress  
 ip pim sparse-mode  
 ip ospf network point-to-point  
 logging event link-status  
 load-interval 30  
 carrier-delay msec 0  
 mls qos trust dscp  
 hold-queue 2000 in  
 hold-queue 2000 out  

Core 2 Standalone Router (No VSS)

router ospf 100  
 router-id 10.254.254.7  
 log-adjacency-changes detail  
 auto-cost reference-bandwidth 20000 !  Optional
 passive-interface default  
 no passive-interface Port-channel1  
 no passive-interface Port-channel20  
 network 10.122.0.0 0.0.255.255 area 0  
   
interface Port-channel21  
 description 20 Gig to VSS 1/2/2-2/2/2  
 dampening  
 ip address 10.122.0.20 255.255.255.254  
 ip flow ingress  
 ip pim sparse-mode  
 ip ospf network point-to-point  
 logging event link-status  
 load-interval 30  
 carrier-delay msec 0  
 mls qos trust dscp  
 hold-queue 2000 in  
 hold-queue 2000 out  

OSPF ECMP

VSS

router ospf 100  
 router-id 10.122.0.235  
 log-adjacency-changes detail  
 auto-cost reference-bandwidth 20000 !  Optional
 nsf !  Enable NSF Capability
 area 120 stub no-summary  
 area 120 range 10.120.0.0 255.255.0.0 cost 10  
 area 120 range 10.125.0.0 255.255.0.0 cost 10  
 passive-interface default  
 no passive-interface TenGigabitEthernet1/2/1  
 no passive-interface TenGigabitEthernet1/2/2  
 no passive-interface TenGigabitEthernet2/2/1  
 no passive-interface TenGigabitEthernet2/2/2  
 network 10.120.0.0 0.0.255.255 area 120  
 network 10.122.0.0 0.0.255.255 area 0  
 network 10.125.0.0 0.0.255.255 area 120  
   
   
interface TenGigabitEthernet1/2/1  
 description 10 GigE to Core 1  
 no switchport  
 dampening  
 ip address 10.122.0.26 255.255.255.254  
 ip flow ingress  
 ip pim sparse-mode  
 ip ospf network point-to-point  
 logging event link-status  
 load-interval 30  
 carrier-delay msec 0  
 mls qos trust dscp  
 hold-queue 2000 in  
 hold-queue 2000 out  
!  
interface TenGigabitEthernet1/2/2  
 description 10 GigE to Core 2  
 no switchport  
 dampening  
 ip address 10.122.0.23 255.255.255.254  
 ip flow ingress  
 ip pim sparse-mode  
 ip ospf network point-to-point  
 logging event link-status  
 load-interval 30  
 carrier-delay msec 0  
 mls qos trust dscp  
 hold-queue 2000 in  
 hold-queue 2000 out  
!  
   
   
interface TenGigabitEthernet2/2/1  
 description to Core 1  
 no switchport  
 dampening  
 ip address 10.122.0.32 255.255.255.254  
 ip flow ingress  
 ip pim sparse-mode  
 ip ospf network point-to-point  
 logging event link-status  
 load-interval 30  
 mls qos trust dscp  
 hold-queue 2000 in  
 hold-queue 2000 out  
!  
interface TenGigabitEthernet2/2/2  
 description 10 GigE to Core 2  
 no switchport  
 dampening  
 ip address 10.122.0.20 255.255.255.254  
 ip flow ingress  
 ip pim sparse-mode  
 ip ospf network point-to-point  
 logging event link-status  
 load-interval 30  
 mls qos trust dscp  
 hold-queue 2000 in  
 hold-queue 2000 out  

Core 1 Standalone Router (No VSS)

router ospf 100  
 router-id 10.254.254.7  
 log-adjacency-changes detail  
 auto-cost reference-bandwidth 20000 !  Optional
 passive-interface default  
 no passive-interface GigabitEthernet2/5  
 no passive-interface TenGigabitEthernet4/1  
 no passive-interface TenGigabitEthernet4/3  
 no passive-interface Port-channel1  
 network 10.122.0.0 0.0.255.255 area 0  
   
   
interface TenGigabitEthernet4/1  
 description To VSS Ten1/2/1  
 dampening  
 ip address 10.122.0.27 255.255.255.254  
 ip flow ingress  
 ip pim sparse-mode  
 ip ospf network point-to-point  
 logging event link-status  
 load-interval 30  
 carrier-delay msec 0  
 mls qos trust dscp  
 hold-queue 2000 in  
 hold-queue 2000 out  
!  
!  
interface TenGigabitEthernet4/3  
 description To VSS Ten2/2/1  
 dampening  
 ip address 10.122.0.33 255.255.255.254  
 ip flow ingress  
 ip pim sparse-mode  
 ip ospf network point-to-point  
 logging event link-status  
 load-interval 30  
 carrier-delay msec 0  
 mls qos trust dscp  
 hold-queue 2000 in  
 hold-queue 2000 out  

Core 2 Standalone Router (No VSS)

router ospf 100  
 router-id 10.254.254.7  
 log-adjacency-changes detail  
 auto-cost reference-bandwidth 20000 !  Optional
 passive-interface default  
 no passive-interface GigabitEthernet2/5  
 no passive-interface TenGigabitEthernet4/1  
 no passive-interface TenGigabitEthernet4/3  
 no passive-interface Port-channel1  
 network 10.122.0.0 0.0.255.255 area 0  
   
   
interface TenGigabitEthernet4/1  
 description To VSS Ten 1/2/2  
 dampening  
 ip address 10.122.0.22 255.255.255.254  
 ip flow ingress  
 ip pim sparse-mode  
 ip ospf network point-to-point  
 logging event link-status  
 load-interval 30  
 carrier-delay msec 0  
 mls qos trust dscp  
 hold-queue 2000 in  
 hold-queue 2000 out  
!  
!  
interface TenGigabitEthernet4/3  
 description To VSS Ten 2/2/2  
 dampening  
 ip address 10.122.0.21 255.255.255.254  
 ip flow ingress  
 ip pim sparse-mode  
 ip ospf network point-to-point  
 logging event link-status  
 load-interval 30  
 carrier-delay msec 0  
 mls qos trust dscp  
 hold-queue 2000 in  
 hold-queue 2000 out