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Starting Interface Configuration 
(ASA 5510 and Higher)

This chapter includes tasks for starting your interface configuration for the ASA 5510 and higher, 
including configuring Ethernet settings, redundant interfaces, and EtherChannels.

Note This chapter only applies to the ASA 5500 series appliances; for the ASASM, starting interface 
configuration consists of configuring switch ports and VLANs on the switch, and then assigning VLANs 
to the ASASM according to Chapter 2, “Configuring the Switch for Use with the 
ASA Services Module.” To complete your interface configuration, see Chapter 13, “Completing 
Interface Configuration (Routed Mode),” or Chapter 14, “Completing Interface Configuration 
(Transparent Mode, 8.4 and Later).” 

For ASA 5505 configuration, see Chapter 12, “Starting Interface Configuration (ASA 5505).”

For multiple context mode, complete all tasks in this section in the system execution space. If you are 
not already in the system execution space, in the Configuration > Device List pane, double-click System 
under the active device IP address.

For ASA cluster interfaces, which have special requirements, see Chapter 10, “Configuring a Cluster of 
ASAs.”

This chapter includes the following sections:

• Information About Starting ASA 5510 and Higher Interface Configuration, page 11-2

• Licensing Requirements for ASA 5510 and Higher Interfaces, page 11-10

• Guidelines and Limitations, page 11-12

• Default Settings, page 11-14

• Starting Interface Configuration (ASA 5510 and Higher), page 11-14

• Monitoring Interfaces, page 11-40

• Where to Go Next, page 11-43

• Feature History for ASA 5510 and Higher Interfaces, page 11-44
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Information About Starting ASA 5510 and Higher Interface 
Configuration

This section includes the following topics:

• Auto-MDI/MDIX Feature, page 11-2

• Interfaces in Transparent Mode, page 11-2

• Management Interface, page 11-2

• Redundant Interfaces, page 11-5

• EtherChannels, page 11-5

• Controlling Fragmentation with the Maximum Transmission Unit and TCP Maximum Segment 
Size, page 11-8

Auto-MDI/MDIX Feature
For RJ-45 interfaces on the ASA 5500 series, the default auto-negotiation setting also includes the 
Auto-MDI/MDIX feature. Auto-MDI/MDIX eliminates the need for crossover cabling by performing an 
internal crossover when a straight cable is detected during the auto-negotiation phase. Either the speed 
or duplex must be set to auto-negotiate to enable Auto-MDI/MDIX for the interface. If you explicitly set 
both the speed and duplex to a fixed value, thus disabling auto-negotiation for both settings, then 
Auto-MDI/MDIX is also disabled. For Gigabit Ethernet, when the speed and duplex are set to 1000 and 
full, then the interface always auto-negotiates; therefore Auto-MDI/MDIX is always enabled and you 
cannot disable it.

Interfaces in Transparent Mode
Interfaces in transparent mode belong to a “bridge group,” one bridge group for each network. You can 
have up to eight bridge groups of four interfaces each per context or in single mode. For more 
information about bridge groups, see the “Bridge Groups in Transparent Mode” section on page 14-2.

Management Interface
• Management Interface Overview, page 11-2

• Management Slot/Port Interface, page 11-3

• Using Any Interface for Management-Only Traffic, page 11-3

• Management Interface for Transparent Mode, page 11-4

• No Support for Redundant Management Interfaces, page 11-4

• Management 0/0 Interface on the ASA 5512-X through ASA 5555-X, page 11-4

Management Interface Overview

You can manage the ASA by connecting to:

• Any through-traffic interface
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• A dedicated Management Slot/Port interface (if available for your model)

You may need to configure management access to the interface according to Chapter 45, “Configuring 
Management Access.”

Management Slot/Port Interface

Table 11-1 shows the Management interfaces per model.-

Note If you installed an IPS module, then the IPS module management interface(s) provides management 
access for the IPS module only. For the ASA 5512-X through ASA 5555-X, the IPS SSP software 
module uses the same physical Management 0/0 interface as the ASA.

Using Any Interface for Management-Only Traffic

You can use any interface as a dedicated management-only interface by configuring it for management 
traffic, including an EtherChannel interface.

Table 11-1 Management Interfaces Per Model

Model
Configurable for 
Through Traffic1

1. By default, the Management 0/0 interface is configured for management-only traffic. For supported models in routed mode, you can remove the limitation 
and pass through traffic. If your model includes additional Management interfaces, you can use them for through traffic as well. The Management 
interfaces might not be optimized for through-traffic, however.

Management 0/02

2. The Management 0/0 interface is configured for ASDM access as part of the default factory configuration. See the “Factory Default Configurations” 
section on page 3-19 for more information.

Management 0/1 Management 1/0 Management 1/1

ASA 5505 N/A No No No No

ASA 5510 Yes Yes No No No

ASA 5520 Yes Yes No No No

ASA 5540 Yes Yes No No No

ASA 5550 Yes Yes No No No

ASA 5580 Yes Yes Yes No No

ASA 5512-X No Yes No No No

ASA 5515-X No Yes No No No

ASA 5525-X No Yes No No No

ASA 5545-X No Yes No No No

ASA 5555-X No Yes No No No

ASA 5585-X Yes Yes Yes Yes3

3. If you installed an SSP in slot 1, then Management 1/0 and 1/1 provide management access to the SSP in slot 1 only.

Yes3

ASASM N/A No No No No
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Management Interface for Transparent Mode

In transparent firewall mode, in addition to the maximum allowed through-traffic interfaces, you can also 
use the Management interface (either the physical interface, a subinterface (if supported for your model), 
or an EtherChannel interface comprised of Management interfaces (if you have multiple Management 
interfaces)) as a separate management interface. You cannot use any other interface types as management 
interfaces.

If your model does not include a Management interface, you must manage the transparent firewall from 
a data interface.

In multiple context mode, you cannot share any interfaces, including the Management interface, across 
contexts. To provide management per context, you can create subinterfaces of the Management interface 
and allocate a Management subinterface to each context. Note that the ASA 5512-X through ASA 
5555-X do not allow subinterfaces on the Management interface, so for per-context management, you 
must connect to a data interface.

For 8.4(1) and later, the management interface is not part of a normal bridge group. Note that for 
operational purposes, it is part of a non-configurable bridge group.

Note In transparent firewall mode, the management interface updates the MAC address table in the same 
manner as a data interface; therefore you should not connect both a management and a data interface to 
the same switch unless you configure one of the switch ports as a routed port (by default Cisco Catalyst 
switches share a MAC address for all VLAN switch ports). Otherwise, if traffic arrives on the 
management interface from the physically-connected switch, then the ASA updates the MAC address 
table to use the management interface to access the switch, instead of the data interface. This action 
causes a temporary traffic interruption; the ASA will not re-update the MAC address table for packets 
from the switch to the data interface for at least 30 seconds for security reasons.

No Support for Redundant Management Interfaces

Redundant interfaces do not support Management slot/port interfaces as members. You also cannot set 
a redundant interface comprised of non-Management interfaces as management-only.

Management 0/0 Interface on the ASA 5512-X through ASA 5555-X

The Management 0/0 interface on the ASA 5512-X through ASA 5555-X has the following 
characteristics:

• No through traffic support

• No subinterface support

• No priority queue support

• No multicast MAC support

• The IPS SSP software module shares the Management 0/0 interface. Separate MAC addresses and 
IP addresses are supported for the ASA and IPS module. You must perform configuration of the IPS 
IP address within the IPS operating system. However, physical characteristics (such as enabling the 
interface) are configured on the ASA.
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Redundant Interfaces
A logical redundant interface consists of a pair of physical interfaces: an active and a standby interface. 
When the active interface fails, the standby interface becomes active and starts passing traffic. You can 
configure a redundant interface to increase the ASA reliability. This feature is separate from device-level 
failover, but you can configure redundant interfaces as well as device-level failover if desired.

Redundant Interface MAC Address

The redundant interface uses the MAC address of the first physical interface that you add. If you change 
the order of the member interfaces in the configuration, then the MAC address changes to match the 
MAC address of the interface that is now listed first. Alternatively, you can assign a MAC address to the 
redundant interface, which is used regardless of the member interface MAC addresses (see the 
“Configuring the MAC Address, MTU, and TCP MSS” section on page 13-13 or the “Configuring 
Multiple Contexts” section on page 8-15). When the active interface fails over to the standby, the same 
MAC address is maintained so that traffic is not disrupted.

EtherChannels
An 802.3ad EtherChannel is a logical interface (called a port-channel interface) consisting of a bundle 
of individual Ethernet links (a channel group) so that you increase the bandwidth for a single network. 
A port channel interface is used in the same way as a physical interface when you configure 
interface-related features.

You can configure up to 48 EtherChannels.

This section includes the following topics:

• Channel Group Interfaces, page 11-5

• Connecting to an EtherChannel on Another Device, page 11-5

• Link Aggregation Control Protocol, page 11-6

• Load Balancing, page 11-7

• EtherChannel MAC Address, page 11-8

Channel Group Interfaces

Each channel group can have eight active interfaces. Note that you can assign up to 16 interfaces to a 
channel group. While only eight interfaces can be active, the remaining interfaces can act as standby 
links in case of interface failure. 

All interfaces in the channel group must be the same type and speed. The first interface added to the 
channel group determines the correct type and speed.

The EtherChannel aggregates the traffic across all the available active interfaces in the channel. The port 
is selected using a proprietary hash algorithm, based on source or destination MAC addresses, IP 
addresses, TCP and UDP port numbers and vlan numbers.

Connecting to an EtherChannel on Another Device

The device to which you connect the ASA EtherChannel must also support 802.3ad EtherChannels; for 
example, you can connect to the Catalyst 6500 switch.
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When the switch is part of a Virtual Switching System (VSS), then you can connect ASA interfaces 
within the same EtherChannel to separate switches in the VSS. The switch interfaces are members of the 
same EtherChannel port-channel interface, because the separate switches act like a single switch (see 
Figure 11-1).

Figure 11-1 Connecting to a VSS

If you use the ASA in an Active/Standby failover deployment, then you need to create separate 
EtherChannels on the switches in the VSS, one for each ASA (see Figure 11-1). On each ASA, a single 
EtherChannel connects to both switches. Even if you could group all switch interfaces into a single 
EtherChannel connecting to both ASAs (in this case, the EtherChannel will not be established because 
of the separate ASA system IDs), a single EtherChannel would not be desirable because you do not want 
traffic sent to the standby ASA.

Figure 11-2 Active/Standby Failover and VSS

Link Aggregation Control Protocol

The Link Aggregation Control Protocol (LACP) aggregates interfaces by exchanging the Link 
Aggregation Control Protocol Data Units (LACPDUs) between two network devices.
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You can configure each physical interface in an EtherChannel to be:

• Active—Sends and receives LACP updates. An active EtherChannel can establish connectivity with 
either an active or a passive EtherChannel. You should use the active mode unless you need to 
minimize the amount of LACP traffic.

• Passive—Receives LACP updates. A passive EtherChannel can only establish connectivity with an 
active EtherChannel.

• On—The EtherChannel is always on, and LACP is not used. An “on” EtherChannel can only 
establish a connection with another “on” EtherChannel.

LACP coordinates the automatic addition and deletion of links to the EtherChannel without user 
intervention. It also handles misconfigurations and checks that both ends of member interfaces are 
connected to the correct channel group. “On” mode cannot use standby interfaces in the channel group 
when an interface goes down, and the connectivity and configurations are not checked.

Load Balancing

The ASA distributes packets to the interfaces in the EtherChannel by hashing the source and destination 
IP address of the packet (this criteria is configurable; see the “Customizing the EtherChannel” section 
on page 11-33). The hash result is a 3-bit value (0 to 7).

The eight hash result values are distributed in a round robin fashion between the channel group 
interfaces, starting with the interface with the lowest ID (slot/port). For example, all packets with a hash 
result of 0 go to GigabitEthernet 0/0, packets with a hash result of 1 go to GigabitEthernet 0/1, packets 
with a hash result of 2 go to GigabitEthernet 0/2, and so on.

Because there are eight hash result values regardless of how many active interfaces are in the 
EtherChannel, packets might not be distributed evenly depending on the number of active interfaces.

Table 11-2 shows the load balancing amounts per interface for each number of active interfaces. The 
active interfaces in bold have even distribution.

If an active interface goes down and is not replaced by a standby interface, then traffic is rebalanced 
between the remaining links. The failure is masked from both Spanning Tree at Layer 2 and the routing 
table at Layer 3, so the switchover is transparent to other network devices.

Table 11-2 Load Distribution per Interface

# of Active 
Interfaces

% Distribution Per Interface

1 2 3 4 5 6 7 8

1 100% — — — — — — —

2 50% 50% — — — — — —

3 37.5% 37.5% 25% — — — — —

4 25% 25% 25% 25% — — — —

5 25% 25% 25% 12.5% 12.5% — — —

6 25% 25% 12.5% 12.5% 12.5% 12.5% — —

7 25% 12.5% 12.5% 12.5% 12.5% 12.5% 12.5% —

8 12.5% 12.5% 12.5% 12.5% 12.5% 12.5% 12.5% 12.5%
11-7
Cisco ASA Series General Operations ASDM Configuration Guide

 



 

Chapter 11      Starting Interface Configuration (ASA 5510 and Higher)
  Information About Starting ASA 5510 and Higher Interface Configuration
EtherChannel MAC Address

All interfaces that are part of the channel group share the same MAC address. This feature makes the 
EtherChannel transparent to network applications and users, because they only see the one logical 
connection; they have no knowledge of the individual links.

The port-channel interface uses the lowest numbered channel group interface MAC address as the 
port-channel MAC address. Alternatively you can manually configure a MAC address for the 
port-channel interface. In multiple context mode, you can automatically assign unique MAC addresses 
to interfaces, including an EtherChannel port interface. We recommend manually, or in multiple context 
mode, automatically configuring a unique MAC address in case the group channel interface membership 
changes. If you remove the interface that was providing the port-channel MAC address, then the 
port-channel MAC address changes to the next lowest numbered interface, thus causing traffic 
disruption.

Controlling Fragmentation with the Maximum Transmission Unit and TCP 
Maximum Segment Size

• MTU Overview, page 11-8

• Default MTU, page 11-8

• Path MTU Discovery, page 11-9

• Setting the MTU and Jumbo Frames, page 11-9

• TCP Maximum Segment Size Overview, page 11-9

• Default TCP MSS, page 11-9

• Setting the TCP MSS for VPN and Non-VPN Traffic, page 11-9

MTU Overview

The maximum transmission unit (MTU) specifies the maximum frame payload size (without Ethernet 
headers) that the ASA can transmit on a given Ethernet interface. If an outgoing IP packet is larger than 
the specified MTU, it is fragmented into 2 or more frames. Fragments are reassembled at the destination 
(and sometimes at intermediate hops), and fragmentation can cause performance degradation. Therefore, 
your IP packets should fit within the MTU size to avoid fragmentation.

Note The ASA can receive frames larger than the configured MTU as long as there is room in memory. See 
the “Enabling Jumbo Frame Support (Supported Models)” section on page 11-39 to increase memory for 
larger frames.

Default MTU

The default MTU on the ASA is 1500 bytes. This value does not include the 18 or more bytes for the 
Ethernet header, CRC, VLAN tagging, and so on.
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Path MTU Discovery

The ASA supports Path MTU Discovery (as defined in RFC 1191), which lets all devices in a network 
path between two hosts coordinate the MTU so they can standardize on the lowest MTU in the path.

Setting the MTU and Jumbo Frames

See the “Configuring the MAC Address, MTU, and TCP MSS” section on page 13-13. For multiple 
context mode, set the MTU within each context.

See the “Enabling Jumbo Frame Support (Supported Models)” section on page 11-39. For multiple 
context mode, set the jumbo frame support in the system execution space.

See the following guidelines:

• Matching MTUs on the traffic path—We recommend that you set the MTU on all ASA interfaces 
and other device interfaces along the traffic path to be the same. Matching MTUs prevents 
intermediate devices from fragmenting the packets.

• Accommodating jumbo frames—If your model supports jumbo frames, you can set the MTU up to 
9216 bytes.

TCP Maximum Segment Size Overview

The TCP maximum segment size (TCP MSS) is the size of the TCP payload before any TCP headers are 
added. UDP packets are not affected. The client and the server exchange TCP MSS values during the 
three-way handshake when establishing the connection.

You can set the TCP MSS on the ASA. If either endpoint of a connection requests a TCP MSS that is 
larger than the value set on the ASA, the ASA overwrites the TCP MSS in the request packet with the 
ASA maximum. If the host or server does not request a TCP MSS, then the ASA assumes the RFC 
793-default value of 536 bytes, but does not modify the packet. You can also configure the minimum 
TCP MSS; if a host or server requests a very small TCP MSS, the ASA can adjust the value up. By 
default, the minimum TCP MSS is not enabled.

For example, you configure the default MTU of 1500 bytes. A host requests an MSS of 1700. If the ASA 
maximum TCP MSS is 1380, then the ASA changes the MSS value in the TCP request packet to 1380. 
The server then sends 1380-byte packets.

Default TCP MSS

By default, the maximum TCP MSS on the ASA is 1380 bytes. This default accommodates VPN 
connections where the headers can add up to 120 bytes; this value fits within the default MTU of 1500 
bytes.

Setting the TCP MSS for VPN and Non-VPN Traffic

See the “Configuring the MAC Address, MTU, and TCP MSS” section on page 13-13. For multiple 
context mode, set the TCP MSS within each context.
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See the following guidelines:

• Non-VPN traffic—If you do not use VPN and do not need extra space for headers, then you should 
disable the TCP MSS limit and accept the value established between connection endpoints. Because 
connection endpoints typically derive the TCP MSS from the MTU, non-VPN packets usually fit 
this TCP MSS.

• VPN traffic—Set the maximum TCP MSS to the MTU - 120. For example, if you use jumbo frames 
and set the MTU to a higher value, then you need to set the TCP MSS to accommodate the new 
MTU.

Licensing Requirements for ASA 5510 and Higher Interfaces

Model License Requirement

ASA 5510 VLANs1:

Base License: 50

Security Plus License: 100

Interface Speed:

Base License—All interfaces Fast Ethernet.

Security Plus License—Ethernet 0/0 and 0/1: Gigabit Ethernet; all others Fast Ethernet.

Interfaces of all types2:

Base License: 364

Security Plus License: 564

ASA 5520 VLANs1:

Base License: 150.

Interfaces of all types2:

Base License: 764

ASA 5540 VLANs1:

Base License: 200

Interfaces of all types2:

Base License: 964

ASA 5550 VLANs1:

Base License: 400

Interfaces of all types2:

Base License: 1764

ASA 5580 VLANs1:

Base License: 1024

Interfaces of all types2:

Base License: 4612
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ASA 5512-X VLANs1:

Base License: 50

Security Plus License: 100

Interfaces of all types2:

Base License: 716

Security Plus License: 916

ASA 5515-X VLANs1:

Base License: 100

Interfaces of all types2:

Base License: 916

ASA 5525-X VLANs1:

Base License: 200

Interfaces of all types2:

Base License: 1316

ASA 5545-X VLANs1:

Base License: 300

Interfaces of all types2:

Base License: 1716

ASA 5555-X VLANs1:

Base License: 500

Interfaces of all types2:

Base License: 2516

ASA 5585-X VLANs1:

Base and Security Plus License: 1024

Interface Speed for SSP-10 and SSP-20:

Base License—1-Gigabit Ethernet for fiber interfaces

10 GE I/O License (Security Plus)—10-Gigabit Ethernet for fiber interfaces

(SSP-40 and SSP-60 support 10-Gigabit Ethernet by default.)

Interfaces of all types2:

Base and Security Plus License: 4612

1. For an interface to count against the VLAN limit, you must assign a VLAN to it.

2. The maximum number of combined interfaces; for example, VLANs, physical, redundant, bridge group, and EtherChannel interfaces. Every interface 
defined in the configuration counts against this limit.

Model License Requirement
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Guidelines and Limitations
This section includes the guidelines and limitations for this feature.

Context Mode Guidelines

In multiple context mode, configure the physical interfaces in the system execution space according to 
the “Starting Interface Configuration (ASA 5510 and Higher)” section on page 11-14. Then, configure 
the logical interface parameters in the context execution space according to Chapter 13, “Completing 
Interface Configuration (Routed Mode),” or Chapter 14, “Completing Interface Configuration 
(Transparent Mode, 8.4 and Later).”

Firewall Mode Guidelines

• For transparent mode, you can configure up to eight bridge groups per context or for a single mode 
device.

• Each bridge group can include up to four interfaces.

• For multiple context, transparent mode, each context must use different interfaces; you cannot share 
an interface across contexts.

Failover Guidelines

• When you use a redundant or EtherChannel interface as a failover link, it must be pre-configured on 
both units in the failover pair; you cannot configure it on the primary unit and expect it to replicate 
to the secondary unit because the failover link itself is required for replication.

• If you use a redundant or EtherChannel interface for the state link, no special configuration is 
required; the configuration can replicate from the primary unit as normal.

• You can monitor redundant or EtherChannel interfaces for failover. When an active member 
interface fails over to a standby interface, this activity does not cause the redundant or EtherChannel 
interface to appear to be failed when being monitored for device-level failover. Only when all 
physical interfaces fail does the redundant or EtherChannel interface appear to be failed (for an 
EtherChannel interface, the number of member interfaces allowed to fail is configurable).

• If you use an EtherChannel interface for a failover or state link, then to prevent out-of-order packets, 
only one interface in the EtherChannel is used. If that interface fails, then the next interface in the 
EtherChannel is used. You cannot alter the EtherChannel configuration while it is in use as a failover 
link. To alter the configuration, you need to either shut down the EtherChannel while you make 
changes, or temporarily disable failover; either action prevents failover from occurring for the 
duration.

• Although you can configure the failover and failover state links on a port channel link, this port 
channel cannot be shared with other firewall traffic.

Clustering Guidelines

• When you use a redundant or EtherChannel interface as the cluster control link, it must be 
pre-configured on all units in the cluster; you cannot configure it on the primary unit and expect it 
to replicate to member units because the cluster control link itself is required for replication.

• To configure a spanned EtherChannel, see the “Configuring Spanned EtherChannels” section on 
page 10-43.

• To configure an individual cluster interface, see the “Configuring Individual Interfaces 
(Recommended for the Management Interface)” section on page 10-38.
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Redundant Interface Guidelines

• You can configure up to 8 redundant interface pairs.

• All ASA configuration refers to the logical redundant interface instead of the member physical 
interfaces.

• You cannot use a redundant interface as part of an EtherChannel, nor can you use an EtherChannel 
as part of a redundant interface. You cannot use the same physical interfaces in a redundant interface 
and an EtherChannel interface. You can, however, configure both types on the ASA if they do not 
use the same physical interfaces.

• If you shut down the active interface, then the standby interface becomes active.

• Redundant interfaces do not support Management slot/port interfaces as members. You also cannot 
set a redundant interface comprised of non-Management interfaces as management-only.

• For failover guidelines, see the “Failover Guidelines” section on page 11-12.

• For clustering guidelines, see the “Clustering Guidelines” section on page 11-12.

EtherChannel Guidelines

• You can configure up to 48 EtherChannels.

• Each channel group can have eight active interfaces. Note that you can assign up to 16 interfaces to 
a channel group. While only eight interfaces can be active, the remaining interfaces can act as 
standby links in case of interface failure. 

• All interfaces in the channel group must be the same type and speed. The first interface added to the 
channel group determines the correct type and speed.

• The device to which you connect the ASA EtherChannel must also support 802.3ad EtherChannels; 
for example, you can connect to the Catalyst 6500 switch.

• The ASA does not support LACPDUs that are VLAN-tagged. If you enable native VLAN tagging 
on the neighboring switch using the Cisco IOS vlan dot1Q tag native command, then the ASA will 
drop the tagged LACPDUs. Be sure to disable native VLAN tagging on the neighboring switch. In 
multiple context mode, these messages are not included in a packet capture, so you cannot diagnose 
the issue effectively.

• The ASA does not support connecting an EtherChannel to a switch stack. If the ASA EtherChannel 
is connected cross stack, and if the Master switch is powered down, then the EtherChannel 
connected to the remaining switch will not come up.

• All ASA configuration refers to the logical EtherChannel interface instead of the member physical 
interfaces.

• You cannot use a redundant interface as part of an EtherChannel, nor can you use an EtherChannel 
as part of a redundant interface. You cannot use the same physical interfaces in a redundant interface 
and an EtherChannel interface. You can, however, configure both types on the ASA if they do not 
use the same physical interfaces.

• You cannot use interfaces on the 4GE SSM, including the integrated 4GE SSM in slot 1 on the ASA 
5550, as part of an EtherChannel.

• For failover guidelines, see the “Failover Guidelines” section on page 11-12.

• For clustering guidelines, see the “Clustering Guidelines” section on page 11-12.
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Default Settings
This section lists default settings for interfaces if you do not have a factory default configuration. For 
information about the factory default configurations, see the “Factory Default Configurations” section 
on page 3-19.

Default State of Interfaces

The default state of an interface depends on the type and the context mode.

In multiple context mode, all allocated interfaces are enabled by default, no matter what the state of the 
interface is in the system execution space. However, for traffic to pass through the interface, the interface 
also has to be enabled in the system execution space. If you shut down an interface in the system 
execution space, then that interface is down in all contexts that share it.

In single mode or in the system execution space, interfaces have the following default states:

• Physical interfaces—Disabled.

• Redundant Interfaces—Enabled. However, for traffic to pass through the redundant interface, the 
member physical interfaces must also be enabled.

• Subinterfaces—Enabled. However, for traffic to pass through the subinterface, the physical interface 
must also be enabled.

• EtherChannel port-channel interfaces—Enabled. However, for traffic to pass through the 
EtherChannel, the channel group physical interfaces must also be enabled.

Default Speed and Duplex

• By default, the speed and duplex for copper (RJ-45) interfaces are set to auto-negotiate.

• The fiber interface for the ASA 5550 (slot 1) and the 4GE SSM has a fixed speed and does not 
support duplex, but you can set the interface to negotiate link parameters (the default) or not to 
negotiate.

• For fiber interfaces for the ASA 5580 and 5585-X, the speed is set for automatic link negotiation.

Default Connector Type

The ASA 5550 (slot 1) and the 4GE SSM for the ASA 5510 and higher ASA include two connector 
types: copper RJ-45 and fiber SFP. RJ-45 is the default. You can configure the ASA to use the fiber SFP 
connectors.

Default MAC Addresses

By default, the physical interface uses the burned-in MAC address, and all subinterfaces of a physical 
interface use the same burned-in MAC address.

Starting Interface Configuration (ASA 5510 and Higher)
This section includes the following topics:

• Task Flow for Starting Interface Configuration, page 11-15

• Converting In-Use Interfaces to a Redundant or EtherChannel Interface, page 11-16

• Enabling the Physical Interface and Configuring Ethernet Parameters, page 11-25

• Configuring a Redundant Interface, page 11-27
11-14
Cisco ASA Series General Operations ASDM Configuration Guide

 



 

Chapter 11      Starting Interface Configuration (ASA 5510 and Higher)
  Starting Interface Configuration (ASA 5510 and Higher)
• Configuring an EtherChannel, page 11-30

• Configuring VLAN Subinterfaces and 802.1Q Trunking, page 11-36

• Enabling Jumbo Frame Support (Supported Models), page 11-39

Task Flow for Starting Interface Configuration

Note If you have an existing configuration, and want to convert interfaces that are in use to a redundant or 
EtherChannel interface, perform your configuration offline using the CLI to minimize disruption. See 
the “Converting In-Use Interfaces to a Redundant or EtherChannel Interface” section on page 11-16.

To start configuring interfaces, perform the following steps:

Step 1 (Multiple context mode) Complete all tasks in this section in the system execution space. If you are not 
already in the System configuration mode, in the Configuration > Device List pane, double-click System 
under the active device IP address.

Step 2 Enable the physical interface, and optionally change Ethernet parameters. See the “Enabling the Physical 
Interface and Configuring Ethernet Parameters” section on page 11-25.

Physical interfaces are disabled by default.

Step 3 (Optional) Configure redundant interface pairs. See the “Configuring a Redundant Interface” section on 
page 11-27.

A logical redundant interface pairs an active and a standby physical interface. When the active interface 
fails, the standby interface becomes active and starts passing traffic.

Step 4 (Optional) Configure an EtherChannel. See the “Configuring an EtherChannel” section on page 11-30.

An EtherChannel groups multiple Ethernet interfaces into a single logical interface.

Note You cannot use interfaces on the 4GE SSM, including the integrated 4GE SSM in slot 1 on the 
ASA 5550, as part of an EtherChannel.

Step 5 (Optional) Configure VLAN subinterfaces. See the “Configuring VLAN Subinterfaces and 802.1Q 
Trunking” section on page 11-36.

Step 6 (Optional) Enable jumbo frame support on the ASA 5580 and 5585-X according to the “Enabling Jumbo 
Frame Support (Supported Models)” section on page 11-39.

Step 7 (Multiple context mode only) To complete the configuration of interfaces in the system execution space, 
perform the following tasks that are documented in Chapter 8, “Configuring Multiple Context Mode”:

• To assign interfaces to contexts, see the “Configuring a Security Context” section on page 8-20.

• (Optional) To automatically assign unique MAC addresses to context interfaces, see the 
“Automatically Assigning MAC Addresses to Context Interfaces” section on page 8-24.

The MAC address is used to classify packets within a context. If you share an interface, but do not have 
unique MAC addresses for the interface in each context, then the destination IP address is used to 
classify packets. Alternatively, you can manually assign MAC addresses within the context according to 
the “Configuring the MAC Address, MTU, and TCP MSS” section on page 13-13.
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Step 8 Complete the interface configuration according to Chapter 13, “Completing Interface Configuration 
(Routed Mode),” or Chapter 14, “Completing Interface Configuration (Transparent Mode, 8.4 and 
Later).”

Converting In-Use Interfaces to a Redundant or EtherChannel Interface
If you have an existing configuration and want to take advantage of the redundant or EtherChannel 
interface feature for interfaces that are currently in use, you will have some amount of downtime when 
you convert to the logical interfaces.

This section provides an overview of how to convert your existing interfaces to a redundant or 
EtherChannel interface with minimal downtime. See the “Configuring a Redundant Interface” section 
on page 11-27 and the “Configuring an EtherChannel” section on page 11-30 fore more information.

• Detailed Steps (Single Mode), page 11-16

• Detailed Steps (Multiple Mode), page 11-21

Detailed Steps (Single Mode)

We recommend that you update your configuration offline as a text file, and reimport the whole 
configuration for the following reasons:

• Because you cannot add a named interface as a member of a redundant or EtherChannel interface, 
you must remove the name from the interface. When you remove the name from the interface, any 
command that referred to that name is deleted. Because commands that refer to interface names are 
widespread throughout the configuration and affect multiple features, removing a name from an 
in-use interface at the CLI or in ASDM would cause significant damage to your configuration, not 
to mention significant downtime while you reconfigure all your features around a new interface 
name.

• Changing your configuration offline lets you use the same interface names for your new logical 
interfaces, so you do not need to touch the feature configurations that refer to interface names. You 
only need to change the interface configuration.

• Clearing the running configuration and immediately applying a new configuration will minimize the 
downtime of your interfaces. You will not be waiting to configure the interfaces in real time.

Step 1 Connect to the ASA; if you are using failover, connect to the active ASA.

Step 2 If you are using failover, disable failover by choosing Configuration > Device Management > High 
Availability > Failover and unchecking the Enable failover check box. Click Apply, and continue at 
the warning.

Step 3 Copy the running configuration by choosing Tools > Backup Configurations and backing up the 
running configuration to your local computer. You can then expand the zip file and edit the 
running-config.cfg file with a text editor.

Be sure to save an extra copy of the old configuration in case you make an error when you edit it.

Step 4 For each in-use interface that you want to add to a redundant or EtherChannel interface, cut and paste 
all commands under the interface command to the end of the interface configuration section for use in 
creating your new logical interfaces. The only exceptions are the following commands, which should 
stay with the physical interface configuration:

• media-type
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• speed

• duplex

• flowcontrol

Note You can only add physical interfaces to an EtherChannel or redundant interface; you cannot have 
VLANs configured for the physical interfaces.

Be sure to match the above values for all interfaces in a given EtherChannel or redundant 
interface. Note that the duplex setting for an EtherChannel interface must be Full or Auto.

For example, you have the following interface configuration. The bolded commands are the ones we 
want to use with three new EtherChannel interfaces, and that you should cut and paste to the end of the 
interface section.

interface GigabitEthernet0/0
 nameif outside
 security-level 0
 ip address 10.86.194.225 255.255.255.0
no shutdown

!
interface GigabitEthernet0/1
 nameif inside
 security-level 100
 ip address 192.168.1.3 255.255.255.0
no shutdown

!
interface GigabitEthernet0/2
shutdown
no nameif

 no security-level
 no ip address
!
interface GigabitEthernet0/3
shutdown
no nameif

 no security-level
 no ip address
!
interface GigabitEthernet0/4
shutdown
no nameif

 no security-level
 no ip address
!
interface GigabitEthernet0/5
shutdown
no nameif

 no security-level
 no ip address
!
interface Management0/0
nameif mgmt
security-level 100
ip address 10.1.1.5 255.255.255.0
no shutdown

!
interface Management0/1
 shutdown
 no nameif
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 no security-level
 no ip address

Step 5 Above each pasted command section, create your new logical interfaces by entering one of the following 
commands:

• interface redundant number [1-8]

• interface port-channel channel_id [1-48]

For example:

...

interface port-channel 1
nameif outside

 security-level 0
 ip address 10.86.194.225 255.255.255.0
no shutdown

!
interface port-channel 2
nameif inside

 security-level 100
 ip address 192.168.1.3 255.255.255.0
no shutdown

!
interface port-channel 3
nameif mgmt
security-level 100
ip address 10.1.1.5 255.255.255.0
no shutdown

Step 6 Assign the physical interfaces to the new logical interfaces:

• Redundant interface—Enter the following commands under the new interface redundant 
command:

member-interface physical_interface1
member-interface physical_interface2

Where the physical interfaces are any two interfaces of the same type (either formerly in use or 
unused). You cannot assign a Management interface to a redundant interface.

For example, to take advantage of existing cabling, you would continue to use the formerly in-use 
interfaces in their old roles as part of the inside and outside redundant interfaces:

interface redundant 1
nameif outside

 security-level 0
 ip address 10.86.194.225 255.255.255.0
member-interface GigabitEthernet0/0
member-interface GigabitEthernet0/2

interface redundant 2
nameif inside

 security-level 100
 ip address 192.168.1.3 255.255.255.0
member-interface GigabitEthernet0/1
member-interface GigabitEthernet0/3

• EtherChannel interface—Enter the following command under each interface you want to add to the 
EtherChannel (either formerly in use or unused). You can assign up to 16 interfaces per 
EtherChannel, although only eight can be active; the others are in a standby state in case of failure.

channel-group channel_id mode active
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For example, to take advantage of existing cabling, you would continue to use the formerly in-use 
interfaces in their old roles as part of the inside and outside EtherChannel interfaces:

interface GigabitEthernet0/0
channel-group 1 mode active
no shutdown

!
interface GigabitEthernet0/1
channel-group 2 mode active
no shutdown

!
interface GigabitEthernet0/2
channel-group 1 mode active
shutdown
no nameif

 no security-level
 no ip address
!
interface GigabitEthernet0/3
channel-group 1 mode active
shutdown
no nameif

 no security-level
 no ip address
!
interface GigabitEthernet0/4
channel-group 2 mode active
shutdown
no nameif

 no security-level
 no ip address
!
interface GigabitEthernet0/5
channel-group 2 mode active
shutdown
no nameif

 no security-level
 no ip address
!
interface Management0/0
channel-group 3 mode active
no shutdown

!
interface Management0/1
channel-group 3 mode active
shutdown

 no nameif
 no security-level
 no ip address

...

Step 7 Enable each formerly unused interface that is now part of a logical interface by adding no in front of the 
shutdown command.

For example, your final EtherChannel configuration is:

interface GigabitEthernet0/0
channel-group 1 mode active
no shutdown

!
interface GigabitEthernet0/1
channel-group 2 mode active
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no shutdown
!
interface GigabitEthernet0/2
channel-group 1 mode active
no shutdown
no nameif

 no security-level
 no ip address
!
interface GigabitEthernet0/3
channel-group 1 mode active
no shutdown
no nameif

 no security-level
 no ip address
!
interface GigabitEthernet0/4
channel-group 2 mode active
no shutdown
no nameif

 no security-level
 no ip address
!
interface GigabitEthernet0/5
channel-group 2 mode active
no shutdown
no nameif

 no security-level
 no ip address
!
interface Management0/0
channel-group 3 mode active
no shutdown

!
interface Management0/1
channel-group 3 mode active
no shutdown
no nameif

 no security-level
 no ip address
!
interface port-channel 1
nameif outside

 security-level 0
 ip address 10.86.194.225 255.255.255.0 
!
interface port-channel 2
nameif inside

 security-level 100
 ip address 192.168.1.3 255.255.255.0 
!
interface port-channel 3
nameif mgmt
security-level 100
ip address 10.1.1.5 255.255.255.0

Note Other optional EtherChannel parameters can be configured after you import the new 
configuration. See the “Configuring an EtherChannel” section on page 11-30.

Step 8 Save the entire new configuration, including the altered interface section.
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Step 9 Re-zip the backup folder with the altered configuration.

Step 10 Choose Tools > Restore Configurations, and choose the altered configuration zip file. Be sure to 
replace the existing running configuration; do not merge them. See the “Restoring Configurations” 
section on page 46-25 for more information.

Step 11 Reenable failover by choosing Configuration > Device Management > High Availability > Failover, 
and checking the Enable failover check box. Click Apply, and click No when prompted if you want to 
configure basic failover settings.

Detailed Steps (Multiple Mode)

We recommend that you update your system and context configurations offline as text files, and reimport 
them for the following reasons:

• Because you cannot add an allocated interface as a member of a redundant or EtherChannel 
interface, you must deallocate the interface from any contexts. When you deallocate the interface, 
any context command that referred to that interface is deleted. Because commands that refer to 
interfaces are widespread throughout the configuration and affect multiple features, removing an 
allocation from an in-use interface at the CLI or in ASDM would cause significant damage to your 
configuration, not to mention significant downtime while you reconfigure all your features around 
a new interface.

• Changing your configuration offline lets you use the same interface names for your new logical 
interfaces, so you do not need to touch the feature configurations that refer to interface names. You 
only need to change the interface configuration.

• Clearing the running system configuration and immediately applying a new configuration will 
minimize the downtime of your interfaces. You will not be waiting to configure the interfaces in real 
time.

Step 1 Connect to the ASA, and change to the system; if you are using failover, connect to the active ASA.

Step 2 If you are using failover, disable failover by choosing Configuration > Device Management > High 
Availability > Failover and unchecking the Enable failover check box. Click Apply, and continue at 
the warning.

Step 3 In the system, copy the running configuration by choosing File > Show Running Configuration in New 
Window and copying the display output to a text editor.

Be sure to save an extra copy of the old configuration in case you make an error when you edit it.

For example, you have the following interface configuration and allocation in the system configuration, 
with shared interfaces between two contexts.

System
interface GigabitEthernet0/0

no shutdown
interface GigabitEthernet0/1

no shutdown
interface GigabitEthernet0/2

shutdown
interface GigabitEthernet0/3

shutdown
interface GigabitEthernet0/4

shutdown
interface GigabitEthernet0/5

shutdown
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interface Management0/0
no shutdown

interface Management1/0
shutdown

!
context customerA

allocate-interface gigabitethernet0/0 int1
allocate-interface gigabitethernet0/1 int2
allocate-interface management0/0 mgmt

context customerB
allocate-interface gigabitethernet0/0
allocate-interface gigabitethernet0/1
allocate-interface management0/0

Step 4 Get copies of all context configurations that will use the new EtherChannel or redundant interface.See 
the “Backing Up and Restoring Configurations or Other Files” section on page 46-21.

For example, you download the following context configurations (interface configuration shown):

CustomerA Context
interface int1
 nameif outside
 security-level 0
 ip address 10.86.194.225 255.255.255.0
!
interface int2
 nameif inside
 security-level 100
 ip address 192.168.1.3 255.255.255.0
no shutdown

!
interface mgmt
nameif mgmt
security-level 100
ip address 10.1.1.5 255.255.255.0
management-only

CustomerB Context
interface GigabitEthernet0/0
 nameif outside
 security-level 0
 ip address 10.20.15.5 255.255.255.0
!
interface GigabitEthernet0/1
 nameif inside
 security-level 100
 ip address 192.168.6.78 255.255.255.0 
!
interface Management0/0
nameif mgmt
security-level 100
ip address 10.8.1.8 255.255.255.0
management-only

Step 5 In the system configuration, create the new logical interfaces according to the “Configuring a Redundant 
Interface” section on page 11-27 or the “Configuring an EtherChannel” section on page 11-30. Be sure 
to enter the no shutdown command on any additional physical interfaces you want to use as part of the 
logical interface.
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Note You can only add physical interfaces to an EtherChannel or redundant interface; you cannot have 
VLANs configured for the physical interfaces.

Be sure to match physical interface parameters such as speed and duplex for all interfaces in a 
given EtherChannel or redundant interface. Note that the duplex setting for an EtherChannel 
interface must be Full or Auto.

For example, the new configuration is:

System
interface GigabitEthernet0/0
channel-group 1 mode active
no shutdown

!
interface GigabitEthernet0/1
channel-group 2 mode active
no shutdown

!
interface GigabitEthernet0/2
channel-group 1 mode active
no shutdown

!
interface GigabitEthernet0/3
channel-group 1 mode active
no shutdown

!
interface GigabitEthernet0/4
channel-group 2 mode active
no shutdown

!
interface GigabitEthernet0/5
channel-group 2 mode active
no shutdown

!
interface Management0/0
channel-group 3 mode active
no shutdown

!
interface Management0/1
channel-group 3 mode active
no shutdown

!
interface port-channel 1
interface port-channel 2
interface port-channel 3

Step 6 Change the interface allocation per context to use the new EtherChannel or redundant interfaces. See the 
“Configuring a Security Context” section on page 8-20.

For example, to take advantage of existing cabling, you would continue to use the formerly in-use 
interfaces in their old roles as part of the inside and outside redundant interfaces:

context customerA
allocate-interface port-channel1 int1
allocate-interface port-channel2 int2
allocate-interface port-channel3 mgmt

context customerB
allocate-interface port-channel1
allocate-interface port-channel2
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allocate-interface port-channel3

Note You might want to take this opportunity to assign mapped names to interfaces if you have not 
done so already. For example, the configuration for customerA does not need to be altered at all; 
it just needs to be reapplied on the ASA. The customerB configuration, however, needs to have 
all of the interface IDs changed; if you assign mapped names for customerB, you still have to 
change the interface IDs in the context configuration, but mapped names might help future 
interface changes.

Step 7 For contexts that do not use mapped names, change the context configuration to use the new 
EtherChannel or redundant interface ID. (Contexts that use mapped interface names do not require any 
alteration.)

For example:

CustomerB Context
interface port-channel1
 nameif outside
 security-level 0
 ip address 10.20.15.5 255.255.255.0 
!
interface port-channel2
 nameif inside
 security-level 100
 ip address 192.168.6.78 255.255.255.0 
!
interface port-channel3
nameif mgmt
security-level 100
ip address 10.8.1.8 255.255.255.0
management-only

Step 8 Copy the new context configuration files over the old ones. For example, for contexts in flash memory, 
in the system choose Tools > File Management, then choose File Transfer > Between Local PC and 
Flash. This tool lets you choose each configuration file and copy it to your local computer. This change 
only affects the startup configuration; the running configuration is still using the old context 
configuration.

Step 9 Copy the entire new system configuration to the clipboard, including the altered interface section.

Step 10 In ASDM, choose Tools > Command Line Interface, and click the Multiple Line radio button.

Step 11 Enter clear configure all as the first line, paste the new configuration after it, and click Send. The clear 
command clears the running configuration (both system and contexts), before applying the new 
configuration.

Traffic through the ASA stops at this point. All of the new context configurations now reload. When they 
are finished reloading, traffic through the ASA resumes.

Step 12 Close the Command Line Interface dialog box, and choose File > Refresh ASDM with the Running 
Configuration.

Step 13 Reenable failover by choosing Configuration > Device Management > High Availability > Failover, 
and checking the Enable failover check box. Click Apply, and click No when prompted if you want to 
configure basic failover settings.
11-24
Cisco ASA Series General Operations ASDM Configuration Guide

 



 

Chapter 11      Starting Interface Configuration (ASA 5510 and Higher)
  Starting Interface Configuration (ASA 5510 and Higher)
Enabling the Physical Interface and Configuring Ethernet Parameters
This section describes how to:

• Enable the physical interface

• Set a specific speed and duplex (if available)

• Enable pause frames for flow control

Prerequisites

For multiple context mode, complete this procedure in the system execution space. If you are not already 
in the System configuration mode, in the Configuration > Device List pane, double-click System under 
the active device IP address.

Detailed Steps

Step 1 Depending on your context mode:

• For single mode, choose the Configuration > Device Setup > Interfaces pane.

• For multiple mode in the System execution space, choose the Configuration > Context 
Management > Interfaces pane.

By default, all physical interfaces are listed.

Step 2 Click a physical interface that you want to configure, and click Edit.

The Edit Interface dialog box appears.

Note In single mode, this procedure only covers a subset of the parameters on the Edit Interface dialog 
box; to configure other parameters, see Chapter 13, “Completing Interface Configuration 
(Routed Mode),” or Chapter 14, “Completing Interface Configuration (Transparent Mode, 8.4 
and Later).” Note that in multiple context mode, before you complete your interface 
configuration, you need to allocate interfaces to contexts. See the “Configuring Multiple 
Contexts” section on page 8-15.
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Step 3 To enable the interface, check the Enable Interface check box.

Step 4 To add a description, enter text in the Description field.

The description can be up to 240 characters on a single line, without carriage returns. In the case of a 
failover or state link, the description is fixed as “LAN Failover Interface,” “STATE Failover Interface,” 
or “LAN/STATE Failover Interface,” for example. You cannot edit this description. The fixed description 
overwrites any description you enter here if you make this interface a failover or state link.

Step 5 (Optional) To set the media type, duplex, speed, and enable pause frames for flow control, click 
Configure Hardware Properties.

a. For slot 1 on the ASA 5550 ASA or the 4GE SSM, you can choose either RJ-45 or SFP from the 
Media Type drop-down list.

RJ-45 is the default.

b. To set the duplex for RJ-45 interfaces, choose Full, Half, or Auto, depending on the interface type, 
from the Duplex drop-down list.

Note The duplex setting for an EtherChannel interface must be Full or Auto.

c. To set the speed, choose a value from the Speed drop-down list.

The speeds available depend on the interface type. For SFP interfaces, you can set the speed to 
Negotiate or Nonegotiate. Negotiate (the default) enables link negotiation, which exchanges 
flow-control parameters and remote fault information. Nonegotiate does not negotiate link 
parameters. For RJ-45 interfaces on the ASA 5500 series ASA, the default auto-negotiation setting 
also includes the Auto-MDI/MDIX feature. See the “Auto-MDI/MDIX Feature” section on 
page 11-2.

d. To enable pause (XOFF) frames for flow control on 1-Gigabit and 10-Gigabit Ethernet interfaces, 
check the Enable Pause Frame check box.

If you have a traffic burst, dropped packets can occur if the burst exceeds the buffering capacity of 
the FIFO buffer on the NIC and the receive ring buffers. Enabling pause frames for flow control can 
alleviate this issue. Pause (XOFF) and XON frames are generated automatically by the NIC 
hardware based on the FIFO buffer usage. A pause frame is sent when the buffer usage exceeds the 
high-water mark. The default high_water value is 128 KB (10 GigabitEthernet) and 24 KB 
(1 GigabitEthernet); you can set it between 0 and 511 (10 GigabitEthernet) or 0 and 47 KB 
(1 GigabitEthernet). After a pause is sent, an XON frame can be sent when the buffer usage is 
reduced below the low-water mark. By default, the low_water value is 64 KB (10 GigabitEthernet) 
and 16 KB (1 GigabitEthernet); you can set it between 0 and 511 (10 GigabitEthernet) or 0 and 
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47 KB (1 GigabitEthernet). The link partner can resume traffic after receiving an XON, or after the 
XOFF expires, as controlled by the timer value in the pause frame. The default pause_time value is 
26624; you can set it between 0 and 65535. If the buffer usage is consistently above the high-water 
mark, pause frames are sent repeatedly, controlled by the pause refresh threshold value.

To change the default values for the Low Watermark, High Watermark, and Pause Time, uncheck 
the Use Default Values check box.

Note Only flow control frames defined in 802.3x are supported. Priority-based flow control is not 
supported.

e. Click OK to accept the Hardware Properties changes.

Step 6 Click OK to accept the Interface changes.

What to Do Next

Optional Tasks:

• Configure redundant interface pairs. See the “Configuring a Redundant Interface” section on 
page 11-27.

• Configure an EtherChannel. See the “Configuring an EtherChannel” section on page 11-30.

• Configure VLAN subinterfaces. See the “Configuring VLAN Subinterfaces and 802.1Q Trunking” 
section on page 11-36.

Required Tasks:

• For multiple context mode, assign interfaces to contexts and automatically assign unique MAC 
addresses to context interfaces. See the “Configuring Multiple Contexts” section on page 8-15.

• For single context mode, complete the interface configuration. See Chapter 13, “Completing 
Interface Configuration (Routed Mode),” or Chapter 14, “Completing Interface Configuration 
(Transparent Mode, 8.4 and Later).”

Configuring a Redundant Interface
A logical redundant interface consists of a pair of physical interfaces: an active and a standby interface. 
When the active interface fails, the standby interface becomes active and starts passing traffic. You can 
configure a redundant interface to increase the ASA reliability. This feature is separate from device-level 
failover, but you can configure redundant interfaces as well as failover if desired.

This section describes how to configure redundant interfaces and includes the following topics:

• Configuring a Redundant Interface, page 11-27

• Changing the Active Interface, page 11-30

Configuring a Redundant Interface

This section describes how to create a redundant interface. By default, redundant interfaces are enabled.
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Guidelines and Limitations

• You can configure up to 8 redundant interface pairs.

• Redundant interface delay values are configurable, but by default the ASA inherits the default delay 
values based on the physical type of its member interfaces.

• See also the “Redundant Interface Guidelines” section on page 11-13.

Prerequisites

• Both member interfaces must be of the same physical type. For example, both must be Ethernet.

• You cannot add a physical interface to the redundant interface if you configured a name for it. You 
must first remove the name in the Configuration > Device Setup > Interfaces pane.

• For multiple context mode, complete this procedure in the system execution space. If you are not 
already in the System configuration mode, in the Configuration > Device List pane, double-click 
System under the active device IP address.

Caution If you are using a physical interface already in your configuration, removing the name will clear any 
configuration that refers to the interface.

Detailed Steps

Step 1 Depending on your context mode:

• For single mode, choose the Configuration > Device Setup > Interfaces pane.

• For multiple mode in the System execution space, choose the Configuration > Context 
Management > Interfaces pane.

Step 2 Choose Add > Redundant Interface.

The Add Redundant Interface dialog box appears.
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Note In single mode, this procedure only covers a subset of the parameters on the Edit Redundant 
Interface dialog box; to configure other parameters, see Chapter 13, “Completing Interface 
Configuration (Routed Mode),” or Chapter 14, “Completing Interface Configuration 
(Transparent Mode, 8.4 and Later).” Note that in multiple context mode, before you complete 
your interface configuration, you need to allocate interfaces to contexts. See the “Configuring 
Multiple Contexts” section on page 8-15.

Step 3 In the Redundant ID field, enter an integer between 1 and 8.

Step 4 From the Primary Interface drop-down list, choose the physical interface you want to be primary.

Be sure to pick an interface that does not have a subinterface and that has not already been allocated to 
a context. Redundant interfaces do not support Management slot/port interfaces as members.

Step 5 From the Secondary Interface drop-down list, choose the physical interface you want to be secondary.

Step 6 If the interface is not already enabled, check the Enable Interface check box.

The interface is enabled by default. To disable it, uncheck the check box.

Step 7 To add a description, enter text in the Description field.

The description can be up to 240 characters on a single line, without carriage returns. For multiple 
context mode, the system description is independent of the context description. In the case of a failover 
or state link, the description is fixed as “LAN Failover Interface,” “STATE Failover Interface,” or 
“LAN/STATE Failover Interface,” for example. You cannot edit this description. The fixed description 
overwrites any description you enter here if you make this interface a failover or state link.

Step 8 Click OK.

You return to the Interfaces pane. The member interfaces now show a lock to the left of the interface ID 
showing that only basic parameters can be configured for it. The redundant interface is added to the 
table.
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What to Do Next

Optional Task:

• Configure VLAN subinterfaces. See the “Configuring VLAN Subinterfaces and 802.1Q Trunking” 
section on page 11-36.

Required Tasks:

• For multiple context mode, assign interfaces to contexts and automatically assign unique MAC 
addresses to context interfaces. See the “Configuring Multiple Contexts” section on page 8-15.

• For single context mode, complete the interface configuration. See the Chapter 13, “Completing 
Interface Configuration (Routed Mode),” or Chapter 14, “Completing Interface Configuration 
(Transparent Mode, 8.4 and Later).”

Changing the Active Interface

By default, the active interface is the first interface listed in the configuration, if it is available. To view 
which interface is active, enter the following command in the Tools > Command Line Interface tool:

show interface redundantnumber detail | grep Member

For example:

show interface redundant1 detail | grep Member
Members GigabitEthernet0/3(Active), GigabitEthernet0/2

To change the active interface, enter the following command:

redundant-interface redundantnumber active-member physical_interface

where the redundantnumber argument is the redundant interface ID, such as redundant1.

The physical_interface is the member interface ID that you want to be active.

Configuring an EtherChannel
This section describes how to create an EtherChannel port-channel interface, assign interfaces to the 
EtherChannel, and customize the EtherChannel. 

This section includes the following topics:

• Adding Interfaces to the EtherChannel, page 11-31

• Customizing the EtherChannel, page 11-33
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Adding Interfaces to the EtherChannel

This section describes how to create an EtherChannel port-channel interface and assign interfaces to the 
EtherChannel. By default, port-channel interfaces are enabled.

Guidelines and Limitations

• You can configure up to 48 EtherChannels.

• Each channel group can have eight active interfaces. Note that you can assign up to 16 interfaces to 
a channel group. While only eight interfaces can be active, the remaining interfaces can act as 
standby links in case of interface failure.

• You cannot use interfaces on the 4GE SSM, including the integrated 4GE SSM in slot 1 on the ASA 
5550, as part of an EtherChannel.

• To configure a spanned EtherChannel for clustering, see the “Configuring Spanned EtherChannels” 
section on page 10-43 instead of this procedure.

• See also the “EtherChannel Guidelines” section on page 11-13.

Prerequisites

• All interfaces in the channel group must be the same type, speed, and duplex. Half duplex is not 
supported.

• You cannot add a physical interface to the channel group if you configured a name for it. You must 
first remove the name in the Configuration > Device Setup > Interfaces pane.

• For multiple context mode, complete this procedure in the system execution space. If you are not 
already in the System configuration mode, in the Configuration > Device List pane, double-click 
System under the active device IP address.

Caution If you are using a physical interface already in your configuration, removing the name will clear any 
configuration that refers to the interface.

Detailed Steps

Step 1 Depending on your context mode:

• For single mode, choose the Configuration > Device Setup > Interfaces pane.

• For multiple mode in the System execution space, choose the Configuration > Context 
Management > Interfaces pane.

Step 2 Choose Add > EtherChannel Interface.

The Add EtherChannel Interface dialog box appears.
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Note In single mode, this procedure only covers a subset of the parameters on the Edit EtherChannel 
Interface dialog box; to configure other parameters, see Chapter 13, “Completing Interface 
Configuration (Routed Mode),” or Chapter 14, “Completing Interface Configuration 
(Transparent Mode, 8.4 and Later).” Note that in multiple context mode, before you complete 
your interface configuration, you need to allocate interfaces to contexts. See the “Configuring 
Multiple Contexts” section on page 8-15.

Step 3 In the Port Channel ID field, enter a number between 1 and 48.

Step 4 In the Available Physical Interface area, click an interface and then click Add >> to move it to the 
Members in Group area.

In transparent mode, if you create a channel group with multiple Management interfaces, then you can 
use this EtherChannel as the management-only interface.

Note If you want to set the EtherChannel mode to On, then you must include only one interface 
initially. After you complete this procedure, edit the member interface, and set the mode to On. 
Apply your changes, then edit the EtherChannel to add more member interfaces.

Step 5 Repeat for each interface you want to add to the channel group.

Make sure all interfaces are the same type and speed. The first interface you add determines the type and 
speed of the EtherChannel. Any non-matching interfaces you add will be put into a suspended state. 
ASDM does not prevent you from adding non-matching interfaces.

Step 6 Click OK.
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You return to the Interfaces pane. The member interfaces now show a lock to the left of the interface ID 
showing that only basic parameters can be configured for it. The EtherChannel interface is added to the 
table.

Step 7 Click Apply. All member interfaces are enabled automatically.

What to Do Next

Optional Tasks:

• Customize the EtherChannel interface. See the “Customizing the EtherChannel” section on 
page 11-33.

• Configure VLAN subinterfaces. See the “Configuring VLAN Subinterfaces and 802.1Q Trunking” 
section on page 11-36.

Required Tasks:

• For multiple context mode, assign interfaces to contexts and automatically assign unique MAC 
addresses to context interfaces. See the “Configuring Multiple Contexts” section on page 8-15.

• For single context mode, complete the interface configuration. See the Chapter 13, “Completing 
Interface Configuration (Routed Mode),” or Chapter 14, “Completing Interface Configuration 
(Transparent Mode, 8.4 and Later).”

Customizing the EtherChannel

This section describes how to set the maximum number of interfaces in the EtherChannel, the minimum 
number of operating interfaces for the EtherChannel to be active, the load balancing algorithm, and other 
optional parameters.

Detailed Steps

Step 1 Depending on your context mode:

• For single mode, choose the Configuration > Device Setup > Interfaces pane.

• For multiple mode in the System execution space, choose the Configuration > Context 
Management > Interfaces pane.

Step 2 Click the port-channel interface you want to customize, and click Edit.

The Edit Interface dialog box appears.

Step 3 To override the media type, duplex, speed, and pause frames for flow control for all member interfaces, 
click Configure Hardware Properties. This method provides a shortcut to set these parameters because 
these parameters must match for all interfaces in the channel group.
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a. For slot 1 on the ASA 5550 ASA or the 4GE SSM, you can choose either RJ-45 or SFP from the 
Media Type drop-down list.

RJ-45 is the default.

b. To set the duplex for RJ-45 interfaces, choose Full or Auto, depending on the interface type, from 
the Duplex drop-down list. Half is not supported for the EtherChannel.

c. To set the speed, choose a value from the Speed drop-down list.

The speeds available depend on the interface type. For SFP interfaces, you can set the speed to 
Negotiate or Nonegotiate. Negotiate (the default) enables link negotiation, which exchanges 
flow-control parameters and remote fault information. Nonegotiate does not negotiate link 
parameters. For RJ-45 interfaces on the ASA 5500 series ASA, the default auto-negotiation setting 
also includes the Auto-MDI/MDIX feature. See the “Auto-MDI/MDIX Feature” section on 
page 11-2.

d. To enable pause (XOFF) frames for flow control on 1-Gigabit and 10-Gigabit Ethernet interfaces, 
check the Enable Pause Frame check box.

If you have a traffic burst, dropped packets can occur if the burst exceeds the buffering capacity of 
the FIFO buffer on the NIC and the receive ring buffers. Enabling pause frames for flow control can 
alleviate this issue. Pause (XOFF) and XON frames are generated automatically by the NIC 
hardware based on the FIFO buffer usage. A pause frame is sent when the buffer usage exceeds the 
High Watermark. The default value is 128 KB; you can set it between 0 and 511. After a pause is 
sent, an XON frame can be sent when the buffer usage is reduced below the Low Watermark. By 
default, the value is 64 KB; you can set it between 0 and 511. The link partner can resume traffic 
after receiving an XON, or after the XOFF expires, as controlled by the Pause Time value in the 
pause frame. The default value is 26624; you can set it between 0 and 65535. If the buffer usage is 
consistently above the High Watermark, pause frames are sent repeatedly, controlled by the pause 
refresh threshold value.

To change the default values for the Low Watermark, High Watermark, and Pause Time, uncheck 
the Use Default Values check box.

Note Only flow control frames defined in 802.3x are supported. Priority-based flow control is not 
supported.

e. Click OK to accept the Hardware Properties changes.

Step 4 To customize the EtherChannel, click the Advanced tab.
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a. In the EtherChannel area, from the Minimum drop-down list, choose the minimum number of active 
interfaces required for the EtherChannel to be active, between 1 and 8. The default is 1.

b. From the Maximum drop-down list, choose the maximum number of active interfaces allowed in the 
EtherChannel, between 1 and 8. The default is 8.

c. From the Load Balance drop-down list, select the criteria used to load balance the packets across the 
group channel interfaces. By default, the ASA balances the packet load on interfaces according to 
the source and destination IP address of the packet. If you want to change the properties on which 
the packet is categorized, choose a different set of criteria. For example, if your traffic is biased 
heavily towards the same source and destination IP addresses, then the traffic assignment to 
interfaces in the EtherChannel will be unbalanced. Changing to a different algorithm can result in 
more evenly distributed traffic. For more information about load balancing, see the “Load 
Balancing” section on page 11-7.

Step 5 Click OK.

You return to the Interfaces pane.

Step 6 To set the mode and priority for a physical interface in the channel group:

a. Click the physical interface in the Interfaces table, and click Edit.

The Edit Interface dialog box appears.

b. Click the Advanced tab.

c. In the EtherChannel area, from the Mode drop down list, choose Active, Passive, or On. We 
recommend using Active mode (the default). For information about active, passive, and on modes, 
see the “Link Aggregation Control Protocol” section on page 11-6. 

d. In the LACP Port Priority field, set the port priority between 1 and 65535. The default is 32768. The 
higher the number, the lower the priority. The ASA uses this setting to decide which interfaces are 
active and which are standby if you assign more interfaces than can be used. If the port priority 
setting is the same for all interfaces, then the priority is determined by the interface ID (slot/port). 
The lowest interface ID is the highest priority. For example, GigabitEthernet 0/0 is a higher priority 
than GigabitEthernet 0/1.

If you want to prioritize an interface to be active even though it has a higher interface ID, then set 
this command to have a lower value. For example, to make GigabitEthernet 1/3 active before 
GigabitEthernet 0/7, then make the priority value be 12345 on the 1/3 interface vs. the default 32768 
on the 0/7 interface.

If the device at the other end of the EtherChannel has conflicting port priorities, the system priority 
is used to determine which port priorities to use. See Step 9 to set the system priority.

Step 7 Click OK.

You return to the Interfaces pane.
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Step 8 Click Apply.

Step 9 To set the LACP system priority, perform the following steps. If the device at the other end of the 
EtherChannel has conflicting port priorities, the system priority is used to determine which port 
priorities to use. See Step 6d for more information.

a. Depending on your context mode:

• For single mode, choose the Configuration > Device Setup > EtherChannel pane.

• For multiple mode in the System execution space, choose the Configuration > Context 
Management > EtherChannel pane.

b. In the LACP System Priority field, enter a priority between 1 and 65535.

The default is 32768.

What to Do Next

Optional Task:

• Configure VLAN subinterfaces. See the “Configuring VLAN Subinterfaces and 802.1Q Trunking” 
section on page 11-36.

Required Tasks:

• For multiple context mode, assign interfaces to contexts and automatically assign unique MAC 
addresses to context interfaces. See the “Configuring Multiple Contexts” section on page 8-15.

• For single context mode, complete the interface configuration. See the Chapter 13, “Completing 
Interface Configuration (Routed Mode),” or Chapter 14, “Completing Interface Configuration 
(Transparent Mode, 8.4 and Later).”

Configuring VLAN Subinterfaces and 802.1Q Trunking
Subinterfaces let you divide a physical, redundant, or EtherChannel interface into multiple logical 
interfaces that are tagged with different VLAN IDs. An interface with one or more VLAN subinterfaces 
is automatically configured as an 802.1Q trunk. Because VLANs allow you to keep traffic separate on a 
given physical interface, you can increase the number of interfaces available to your network without 
adding additional physical interfaces or ASAs. This feature is particularly useful in multiple context 
mode so that you can assign unique interfaces to each context.

Guidelines and Limitations

• Maximum subinterfaces—To determine how many VLAN subinterfaces are allowed for your 
platform, see the “Licensing Requirements for ASA 5510 and Higher Interfaces” section on 
page 11-10.

• Preventing untagged packets on the physical interface—If you use subinterfaces, you typically do 
not also want the physical interface to pass traffic, because the physical interface passes untagged 
packets. This property is also true for the active physical interface in a redundant interface pair. 
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Because the physical or redundant interface must be enabled for the subinterface to pass traffic, 
ensure that the physical or redundant interface does not pass traffic by not configuring a name for 
the interface. If you want to let the physical or redundant interface pass untagged packets, you can 
configure the name as usual. See Chapter 13, “Completing Interface Configuration (Routed Mode),” 
or Chapter 14, “Completing Interface Configuration (Transparent Mode, 8.4 and Later),” for more 
information about completing the interface configuration.

• (ASA 5512-X through ASA 5555-X) You cannot configure subinterfaces on the Management 0/0 
interface.

Prerequisites

For multiple context mode, complete this procedure in the system execution space. If you are not already 
in the System configuration mode, in the Configuration > Device List pane, double-click System under 
the active device IP address.

Detailed Steps

Step 1 Depending on your context mode:

• For single mode, choose the Configuration > Device Setup > Interfaces pane.

• For multiple mode in the System execution space, choose the Configuration > Context 
Management > Interfaces pane.

Step 2 Choose Add > Interface.

The Add Interface dialog box appears.
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Note In single mode, this procedure only covers a subset of the parameters on the Edit Interface dialog 
box; to configure other parameters, see Chapter 13, “Completing Interface Configuration 
(Routed Mode),” or Chapter 14, “Completing Interface Configuration (Transparent Mode, 8.4 
and Later).” Note that in multiple context mode, before you complete your interface 
configuration, you need to allocate interfaces to contexts. See the “Configuring Multiple 
Contexts” section on page 8-15.

Step 3 From the Hardware Port drop-down list, choose the physical, redundant, or port-channel interface to 
which you want to add the subinterface.

Step 4 If the interface is not already enabled, check the Enable Interface check box.

The interface is enabled by default. To disable it, uncheck the check box.

Step 5 In the VLAN ID field, enter the VLAN ID between 1 and 4095.

Some VLAN IDs might be reserved on connected switches, so check the switch documentation for more 
information. For multiple context mode, you can only set the VLAN in the system configuration.

Step 6 In the Subinterface ID field, enter the subinterface ID as an integer between 1 and 4294967293.

The number of subinterfaces allowed depends on your platform. You cannot change the ID after you set 
it.

Step 7 (Optional) In the Description field, enter a description for this interface.

The description can be up to 240 characters on a single line, without carriage returns. For multiple 
context mode, the system description is independent of the context description. In the case of a failover 
or state link, the description is fixed as “LAN Failover Interface,” “STATE Failover Interface,” or 
“LAN/STATE Failover Interface,” for example. You cannot edit this description. The fixed description 
overwrites any description you enter here if you make this interface a failover or state link.

Step 8 Click OK.
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You return to the Interfaces pane.

What to Do Next

(Optional) Enable jumbo frame support according to the “Enabling Jumbo Frame Support (Supported 
Models)” section on page 11-39.

Enabling Jumbo Frame Support (Supported Models)
A jumbo frame is an Ethernet packet larger than the standard maximum of 1518 bytes (including Layer 2 
header and FCS), up to 9216 bytes. You can enable support for jumbo frames for all interfaces by 
increasing the amount of memory to process Ethernet frames. Assigning more memory for jumbo frames 
might limit the maximum use of other features, such as ACLs. See the “Controlling Fragmentation with 
the Maximum Transmission Unit and TCP Maximum Segment Size” section on page 11-8 for more 
information.

Supported models include:

• ASA 5512-X

• ASA 5515-X

• ASA 5525-X

• ASA 5545-X

• ASA 5555-X

• ASA 5580

• ASA 5585-X

Prerequisites

• In multiple context mode, set this option in the system execution space.

• Changes in this setting require you to reload the ASA.

• Be sure to set the MTU for each interface that needs to transmit jumbo frames to a higher value than 
the default 1500; for example, set the value to 9000. See the “Configuring the MAC Address, MTU, 
and TCP MSS” section on page 13-13. In multiple context mode, set the MTU within each context.

• Be sure to adjust the TCP MSS, either to disable it for non-VPN traffic, or to increase it in accord 
with the MTU according to the “Configuring the MAC Address, MTU, and TCP MSS” section on 
page 13-13.

Detailed Steps

• Multiple mode—To enable jumbo frame support, choose Configuration > Context Management 
> Interfaces, and click the Enable jumbo frame support check box.

• Single mode—Setting the MTU larger than 1500 bytes automatically enables jumbo frames. To 
manually enable or disable this setting, choose Configuration > Device Setup > Interfaces, and 
click the Enable jumbo frame support check box.
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Monitoring Interfaces
This section includes the following topics:

• ARP Table, page 11-40

• MAC Address Table, page 11-40

• Interface Graphs, page 11-40

ARP Table
The Monitoring > Interfaces > ARP Table pane displays the ARP table, including static and dynamic 
entries. The ARP table includes entries that map a MAC address to an IP address for a given interface.

Fields

• Interface—Lists the interface name associated with the mapping.

• IP Address—Shows the IP address. 

• MAC Address—Shows the MAC address. 

• Proxy ARP—Displays Yes if proxy ARP is enabled on the interface. Displays No if proxy ARP is 
not enabled on the interface.

• Clear—Clears the dynamic ARP table entries. Static entries are not cleared.

• Refresh—Refreshes the table with current information from the ASA and updates Last Updated date 
and time.

• Last Updated—Display only. Shows the date and time the display was updated.

MAC Address Table
The Monitoring > Interfaces > MAC Address Table pane shows the static and dynamic MAC address 
entries. See the “MAC Address Table” section on page 11-40 for more information about the MAC 
address table and adding static entries.

Fields

• Interface—Shows the interface name associated with the entry.

• MAC Address—Shows the MAC address.

• Type—Shows if the entry is static or dynamic.

• Age—Shows the age of the entry, in minutes. To set the timeout, see the “MAC Address Table” 
section on page 11-40.

• Refresh—Refreshes the table with current information from the ASA.

Interface Graphs
The Monitoring  > Interfaces > Interface Graphs pane lets you view interface statistics in graph or table 
form. If an interface is shared among contexts, the ASA shows only statistics for the current context. The 
number of statistics shown for a subinterface is a subset of the number of statistics shown for a physical 
interface.
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Fields

• Available Graphs for—Lists the types of statistics available for monitoring. You can choose up to 
four types of statistics to show in one graph window. You can open multiple graph windows at the 
same time.

– Byte Counts—Shows the number of bytes input and output on the interface.

– Packet Counts—Shows the number of packets input and output on the interface.

– Packet Rates—Shows the rate of packets input and output on the interface.

– Bit Rates—Shows the bit rate for the input and output of the interface.

– Drop Packet Count—Shows the number of packets dropped on the interface.

These additional statistics display for physical interfaces:

– Buffer Resources—Shows the following statistics:

Overruns—The number of times that the ASA was incapable of handing received data to a 
hardware buffer because the input rate exceeded the ASA capability to handle the data.

Underruns—The number of times that the transmitter ran faster than the ASA could handle.

No Buffer—The number of received packets discarded because there was no buffer space in the 
main system. Compare this with the ignored count. Broadcast storms on Ethernet networks are 
often responsible for no input buffer events.

– Packet Errors—Shows the following statistics:

CRC—The number of Cyclical Redundancy Check errors. When a station sends a frame, it 
appends a CRC to the end of the frame. This CRC is generated from an algorithm based on the 
data in the frame. If the frame is altered between the source and destination, the ASA notes that 
the CRC does not match. A high number of CRCs is usually the result of collisions or a station 
transmitting bad data. 

Frame—The number of frame errors. Bad frames include packets with an incorrect length or 
bad frame checksums. This error is usually the result of collisions or a malfunctioning Ethernet 
device.

Input Errors—The number of total input errors, including the other types listed here. Other 
input-related errors can also cause the input error count to increase, and some datagrams might 
have more than one error; therefore, this sum might exceed the number of errors listed for the 
other types. 

Runts—The number of packets that are discarded because they are smaller than the minimum 
packet size, which is 64 bytes. Runts are usually caused by collisions. They might also be 
caused by poor wiring and electrical interference.

Giants—The number of packets that are discarded because they exceed the maximum packet 
size. For example, any Ethernet packet that is greater than 1518 bytes is considered a giant.

Deferred—For FastEthernet interfaces only. The number of frames that were deferred before 
transmission due to activity on the link.

– Miscellaneous—Shows statistics for received broadcasts. 

– Collision Counts—For FastEthernet interfaces only. Shows the following statistics:

Output Errors—The number of frames not transmitted because the configured maximum 
number of collisions was exceeded. This counter should only increment during heavy network 
traffic.
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Collisions—The number of messages retransmitted due to an Ethernet collision (single and 
multiple collisions). This usually occurs on an overextended LAN (Ethernet or transceiver cable 
too long, more than two repeaters between stations, or too many cascaded multiport 
transceivers). A packet that collides is counted only once by the output packets.

Late Collisions—The number of frames that were not transmitted because a collision occurred 
outside the normal collision window. A late collision is a collision that is detected late in the 
transmission of the packet. Normally, these should never happen. When two Ethernet hosts try 
to talk at once, they should collide early in the packet and both back off, or the second host 
should see that the first one is talking and wait. If you get a late collision, a device is jumping 
in and trying to send the packet on the Ethernet while the ASA is partly finished sending the 
packet. The ASA does not resend the packet, because it may have freed the buffers that held the 
first part of the packet. This is not a real problem because networking protocols are designed to 
cope with collisions by resending packets. However, late collisions indicate a problem exists in 
your network. Common problems are large repeated networks and Ethernet networks running 
beyond the specification. 

– Input Queue—Shows the number of packets in the input queue, the current and the maximum, 
including the following statistics:

Hardware Input Queue—The number of packets in the hardware queue.

Software Input Queue—The number of packets in the software queue.

– Output Queue—Shows the number of packets in the output queue, the current and the 
maximum, including the following statistics:

Hardware Output Queue—The number of packets in the hardware queue.

Software Output Queue—The number of packets in the software queue.

• Add—Adds the selected statistic type to the selected graph window.

• Remove—Removes the selected statistic type from the selected graph window. This button name 
changes to Delete if the item you are removing was added from another panel, and is not being 
returned to the Available Graphs pane.

• Show Graphs—Shows the graph window name to which you want to add a statistic type. If you have 
a graph window already open, a new graph window is listed by default. If you want to add a statistic 
type to an already open graph, choose the open graph window name. The statistics already included 
on the graph are shown in the Selected Graphs pane, to which you can add additional types. Graph 
windows are named for ASDM followed by the interface IP address and the name “Graph”. 
Subsequent graphs are named “Graph (2)” and so on.

• Selected Graphs—Shows the statistic types you want to show in the selected graph window. You an 
include up to four types.

– Show Graphs—Shows the graph window or updates the graph with additional statistic types if 
added.

Graph/Table

The Monitoring > Interfaces > Interface Graphs > Graph/Table window shows a graph for the selected 
statistics. The Graph window can show up to four graphs and tables at a time. By default, the graph or 
table displays the real-time statistics. If you enable History Metrics (see the “Enabling History Metrics” 
section on page 4-34), you can view statistics for past time periods.
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Fields

• View—Sets the time period for the graph or table. To view any time period other than real-time, 
enable History Metrics (see the “Enabling History Metrics” section on page 4-34). The data is 
updated according to the specification of the following options:

– Real-time, data every 10 sec

– Last 10 minutes, data every 10 sec

– Last 60 minutes, data every 1 min

– Last 12 hours, data every 12 min

– Last 5 days, data every 2 hours

• Export—Exports the graph in comma-separated value format. If there is more than one graph or 
table on the Graph window, the Export Graph Data dialog box appears. Choose one or more of the 
graphs and tables listed by checking the check box next to the name.

• Print—Prints the graph or table. If there is more than one graph or table on the Graph window, the 
Print Graph dialog box appears. Choose the graph or table you want to print from the Graph/Table 
Name list.

• Bookmark—Opens a browser window with a single link for all graphs and tables on the Graphs 
window, as well as individual links for each graph or table. You can then copy these URLs as 
bookmarks in your browser. ASDM does not have to be running when you open the URL for a graph; 
the browser launches ASDM and then displays the graph.

Where to Go Next
• For multiple context mode:

a. Assign interfaces to contexts and automatically assign unique MAC addresses to context 
interfaces. See Chapter 8, “Configuring Multiple Context Mode.”

b. Complete the interface configuration according to Chapter 13, “Completing Interface 
Configuration (Routed Mode),” or Chapter 14, “Completing Interface Configuration 
(Transparent Mode, 8.4 and Later).”

• For single context mode, complete the interface configuration according to Chapter 13, 
“Completing Interface Configuration (Routed Mode),” or Chapter 14, “Completing Interface 
Configuration (Transparent Mode, 8.4 and Later).”
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Feature History for ASA 5510 and Higher Interfaces
Table 11-3 lists the release history for this feature.

Table 11-3 Feature History for Interfaces

Feature Name Releases Feature Information

Increased VLANs 7.0(5) Increased the following limits:

• ASA5510 Base license VLANs from 0 to 10.

• ASA5510 Security Plus license VLANs from 10 to 25.

• ASA5520 VLANs from 25 to 100.

• ASA5540 VLANs from 100 to 200.

Increased interfaces for the Base license on the 
ASA 5510

7.2(2) For the Base license on the ASA 5510, the maximum 
number of interfaces was increased from 3 plus a 
management interface to unlimited interfaces.

Increased VLANs 7.2(2) VLAN limits were increased for the ASA 5510 (from 10 to 
50 for the Base license, and from 25 to 100 for the Security 
Plus license), the ASA 5520 (from 100 to 150), the ASA 
5550 (from 200 to 250).

Gigabit Ethernet Support for the ASA 5510 
Security Plus License

7.2(3) The ASA 5510 ASA now supports GE (Gigabit Ethernet) 
for port 0 and 1 with the Security Plus license. If you 
upgrade the license from Base to Security Plus, the capacity 
of the external Ethernet0/0 and Ethernet0/1 ports increases 
from the original FE (Fast Ethernet) (100 Mbps) to GE 
(1000 Mbps). The interface names will remain Ethernet 0/0 
and Ethernet 0/1. 

Jumbo packet support for the ASA 5580 8.1(1) The Cisco ASA 5580 supports jumbo frames. A jumbo 
frame is an Ethernet packet larger than the standard 
maximum of 1518 bytes (including Layer 2 header and 
FCS), up to 9216 bytes. You can enable support for jumbo 
frames for all interfaces by increasing the amount of 
memory to process Ethernet frames. Assigning more 
memory for jumbo frames might limit the maximum use of 
other features, such as ACLs.

This feature is also supported on the ASA 5585-X.

We modified the following screen: Configuration > Device 
Setup > Interfaces > Add/Edit Interface > Advanced. 

Increased VLANs for the ASA 5580 8.1(2) The number of VLANs supported on the ASA 5580 are 
increased from 100 to 250. 

Support for Pause Frames for Flow Control on 
the ASA 5580 10-Gigabit Ethernet Interfaces

8.2(2) You can now enable pause (XOFF) frames for flow control.

This feature is also supported on the ASA 5585-X.

We modified the following screens:
(Single Mode) Configuration > Device Setup > Interfaces > 
Add/Edit Interface > General
(Multiple Mode, System) Configuration > Interfaces > 
Add/Edit Interface.
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Support for Pause Frames for Flow Control on 
1-Gigabit Ethernet Interfaces

8.2(5)/8.4(2) You can now enable pause (XOFF) frames for flow control 
for 1-Gigabit interfaces on all models.

We modified the following screens:
(Single Mode) Configuration > Device Setup > Interfaces > 
Add/Edit Interface > General
(Multiple Mode, System) Configuration > Interfaces > 
Add/Edit Interface.

EtherChannel support 8.4(1) You can configure up to 48 802.3ad EtherChannels of eight 
active interfaces each.

We modified or introduced the following screens:
Configuration > Device Setup > Interfaces
Configuration > Device Setup > Interfaces > Add/Edit 
EtherChannel Interface
Configuration > Device Setup > Interfaces > Add/Edit 
Interface
Configuration > Device Setup > EtherChannel

Note EtherChannel is not supported on the ASA 5505.

Table 11-3 Feature History for Interfaces (continued)

Feature Name Releases Feature Information
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