Routing Command Reference for Cisco NCS 6000 Series Routers
EIGRP Commands
Downloads: This chapterpdf (PDF - 1.56MB) The complete bookPDF (PDF - 10.45MB) | Feedback

EIGRP Commands

EIGRP Commands

This module describes the commands used to configure and monitor the Enhanced Interior Gateway Routing Protocol (EIGRP).

For detailed information about EIGRP concepts, configuration tasks, and examples, see Implementing EIGRP on in Routing Configuration Guide for Cisco NCS 6000 Series Routers.

address-family (EIGRP)

To enable an IPv4 or IPv6 address family under Enhanced Interior Gateway Routing Protocol (EIGRP), use the address-family command in the appropriate mode. To remove the address family from the EIGRP configuration, use the no form of this command.

address-family { ipv4 | ipv6 }

no address-family { ipv4 | ipv6 }

Syntax Description

ipv4

Selects IPv4 address family.

ipv6

Selects IPv6 address family.

Command Default

No default behavior or values

Command Modes

Router configuration

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the address-family ipv4 command to configure IPv4 address family sessions in EIGRP and the address-family ipv6 command to configure IPv6 address family sessions in EIGRP.

Task ID

Task ID

Operations

eigrp

read, write

authentication keychain

To authenticate all EIGRP protocol traffic on one or more interfaces based on the MD5 algorithm, use the authentication keychain command in an appropriate configuration mode. To disable authentication, use the no form of this command.

authentication keychain key-chain-name

no authentication keychain key-chain-name

Syntax Description

key-chain-name

Name of the authentication keychain

Command Default

Authentication is disabled.

Command Modes

IPv4 address family interface configuration

IPv6 address family interface configuration

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the address-family ipv4 command to configure IPv4 address family sessions in EIGRP and the address-family ipv6 command to configure IPv6 address family sessions in EIGRP.

Task ID

Task ID

Operations

eigrp

read, write

Examples

The following example shows how to enable an EIGRP authentication keychain:

RP/0/RP0/CPU0:routerconfigure eigrp 1
RP/0/RP0/CPU0:router(config-eigrp)# address-family ipv4 
RP/0/RP0/CPU0:router(config-eigrp-af)# interface GigabitEthernet 0/2/0/0 
RP/0/RP0/CPU0:router(config-eigrp-if)# authentication key chain key1

Related Commands

Command

Description

router eigrp

Configures a routing process and enter router configuration mode for Enhanced Interior Gateway Routing Protocol (EIGRP).

auto-summary (EIGRP)

To allow automatic summarization of subnet routes into network-level routes for an Enhanced Interior Gateway Routing Protocol (EIGRP) process, use the auto-summary command in the appropriate configuration mode. To disable this function and send subprefix routing information across classful network boundaries, use the no form of this command.

auto-summary

no auto-summary

Syntax Description

This command has no keywords or arguments.

Command Default

The behavior of this command is disabled by default. (The software sends subnet routing information across classful network boundaries.)

Command Modes

IPv4 Address family configuration

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Route summarization reduces the amount of routing information in the routing tables. Use the auto-summary command to allow the software to create summary subprefixes to the classful network boundary when crossing classful network boundaries.

EIGRP summary routes are given an administrative distance value of 5. You cannot configure this value.

Task ID

Task ID

Operations

eigrp

read, write

Related Commands

Command

Description

summary-address (EIGRP)

Configures a summary aggregate address for a specified interface.

bandwidth-percent (EIGRP)

To configure the percentage of bandwidth that may be used by EIGRP on an interface, use the bandwidth-percent command in interface configuration mode. To restore the default value, use the no form of this command.

bandwidth-percent percent

no bandwidth-percent

Syntax Description

percent

Percentage of bandwidth that EIGRP may use.

Command Default

percent : 50

Command Modes

Interface configuration

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

EIGRP uses up to 50 percent of the bandwidth of a link, as defined by the bandwidth interface configuration command. This command may be used if some other fraction of the bandwidth is desired. Values greater than 100 percent may be configured. The configuration option may be useful if the bandwidth is set artificially low for other reasons.

Task ID

Task ID

Operations

eigrp

read, write

Examples

The following example shows how to configure EIGRP to use up to 75 percent (42 kbps) of an interface in autonomous system 209:

  RP/0/RP0/CPU0:router(config)# router eigrp 1
  RP/0/RP0/CPU0:router(config-eigrp)# address-family ipv4
  RP/0/RP0/CPU0:router(config-eigrp-af)# router-id 10.1.1.1
  RP/0/RP0/CPU0:router(config-eigrp-af)# interface GigabitEthernet 0/1/0/0
  RP/0/RP0/CPU0:router(config-eigrp-af-if)# bandwidth-percent 75
  
         

Related Commands

Command

Description

bandwidth (interface)

Sets a bandwidth value for an interface.

clear eigrp neighbors

To remove and re-establish Enhanced Interior Gateway Routing Protocol (EIGRP) neighbor entries from the appropriate table, use the clear eigrp neighbors command in XR EXEC mode.

clear eigrp [ as-number ] [ ipv4 | | ipv6 ] neighbors [ ip-address | type interface-path-id ] [ soft ]

Syntax Description

as-number

(Optional) Autonomous system number. Range is from 1 to 65535.

ipv4

(Optional) Specifies the IPv4 address family.

ipv6

(Optional) Specifies the IPv6 address family.

ip-address

(Optional) Address of the neighbor.

type

Interface type. For more information, use the question mark ( ? ) online help function.

interface-path-id

Physical interface or virtual interface.

Use the show interfaces command to see a list of all interfaces currently configured on the router.

For more information about the syntax for the router, use the question mark ( ? ) online help function.

soft

(Optional) Specifies a soft reset.

Command Modes

XR EXEC

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Task ID

Task ID

Operations

eigrp

read, write

clear eigrp topology

To remove and relearn Enhanced Interior Gateway Routing Protocol (EIGRP) topology entries from the appropriate table, use the clear eigrp topology command in XR EXEC mode.

clear eigrp [ as-number ] [ ipv4 | | ipv6 ] topology [ prefix mask | | prefixl/ength ]

Syntax Description

as-number

(Optional) Autonomous system number. Range is from 1 to 65535.

ipv4

(Optional) Specifies the IPv4 address family.

ipv6

(Optional) Specifies the IPv6 address family.

prefix

IP prefix, which limits output to a specific route.

mask

IP address mask.

/ length

Prefix length, which can be indicated as a slash (/) and number. For example, /8 indicates that the first eight bits in the IP prefix are network bits. If length is used, the slash is required.

Command Default

No EIGRP topology entries are cleared.

Command Modes

XR EXEC

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Task ID

Task ID

Operations

eigrp

read, write

Examples

The following example shows how to clear EIGRP topology entries for a specific route:

RP/0/RP0/CPU0:router# clear eigrp topology 10.1.0.0/8
         

default-information

To control the candidate default routing information for an Enhanced Interior Gateway Routing Protocol (EIGRP), use the defaultinformation command in the appropriate configuration mode. To suppress EIGRP candidate default information in incoming or outgoing updates, use the no form of this command.

default-information allowed { in | out } [ route-policy name ]

no default-information allowed { in | out } [ route-policy name ]

Syntax Description

allowed

Specifies EIGRP to allow default routing information.

in

Specifies EIGRP to allow inbound default routing information.

out

Specifies EIGRP to allow outbound default routing information.

route-policy name

(Optional) Specifies a route policy.

Command Default

Default routing information is not accepted or flagged.

Command Modes

Address family configuration

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Task ID

Task ID

Operations

eigrp

read, write

default-metric (EIGRP)

To set metrics for an Enhanced Interior Gateway Routing Protocol (EIGRP), use the defaultmetric command in the appropriate configuration mode. To remove the metric values and restore the default state, use the no form of this command.

default-metric bandwidth delay reliability loading mtu

no default-metric

Syntax Description

bandwidth

Minimum bandwidth of the route in kilobits per second. Range is 1 to 4294967295.

delay

Route delay in ten microsecond units. Range is 1 to 4294967295.

reliability

Likelihood of successful packet transmission expressed as a number between 0 and 255. The value 255 means 100-percent reliability; 0 means the link is not reliable.

loading

Effective bandwidth of the route expressed as a number from 1 to 255 (255 is 100-percent loading).

mtu

Minimum maximum transmission unit (MTU) size of the route in bytes. Range is from 1 to 65535.

Command Default

No default values

Command Modes

IPv4 address family configuration

IPv6 address family configuration

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the default-metric command to provide default metric values while redistributing a protocol into EIGRP.

Metric defaults have been carefully set to work for a wide variety of networks. Take great care when changing these values.

Task ID

Task ID

Operations

eigrp

read, write

Related Commands

Command

Description

redistribute

Redistributes routes from one routing domain into another routing domain.

distance (EIGRP)

To allow the use of one of two administrative distances—internal and external—that could provide a better route to a node, use the distance command in the appropriate configuration mode. To reset these values to their defaults, use the no form of this command.

distance internal-distance external-distance

no distance

Syntax Description

internal-distance

Administrative distance for EIGRP internal routes. Internal routes are those that are learned from another entity within the same autonomous system (AS). The distance can be a value from 1 to 255.

external-distance

Administrative distance for EIGRP external routes. External routes are those for which the best path is learned from a source external to the AS. The distance can be a value from 1 to 255.

Command Default

internal-distance : 90

external-distance : 170

Command Modes

IPv4 address family configuration

IPv6 address family configuration

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

An administrative distance is a rating of the trustworthiness of a routing information source, such as an individual router or a group of routers. Numerically, an administrative distance is an integer from 0 to 255. In general, the higher the value, the lower the trust rating. An administrative distance of 255 means the routing information source cannot be trusted at all and should be ignored.

Use the distance command if another protocol is known to provide a better route to a node than was actually learned through the external Enhanced Interior Gateway Routing Protocol (EIGRP) or some internal routes should be preferred by EIGRP.

To display the default administrative distance for a specified routing process, use the show protocols EXEC command.

Task ID

Task ID

Operations

eigrp

read, write

Related Commands

Command

Description

show protocols (EIGRP)

Displays information about the Enhanced Interior Gateway Routing Protocol (EIGRP) running on the router.

hello-interval (EIGRP)

To configure the hello interval for an interface, use the hello-interval command in interface configuration mode. To restore the default value, use the no form of this command.

hello-interval seconds

no hello-interval

Syntax Description

seconds

Hello interval (in seconds). Range is from 1 to 65535.

Command Default

For low-speed, nonbroadcast multiaccess (NBMA) networks: 60 seconds

For all other networks: 5 seconds

Command Modes

Interface configuration

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Task ID

Task ID

Operations

eigrp

read, write

Examples

The following example shows how to set the hello interval to 10 seconds for the interface:

  RP/0/RP0/CPU0:router(config)# router eigrp 1
  RP/0/RP0/CPU0:router(config-eigrp)# address-family ipv4
  RP/0/RP0/CPU0:router(config-eigrp)# router-id 10.1.1.1
  RP/0/RP0/CPU0:router(config-eigrp-af)# interface GigabitEthernet 0/1/0/0
  RP/0/RP0/CPU0:router(config-eigrp-af-if)# hello-interval 10
  
         

hold-time (EIGRP)

To configure the hold time for an interface, use the hold-time command in interface configuration mode. To restore the default value, use the no form of this command.

hold-time seconds

no hold-time

Syntax Description

seconds

Hold time (in seconds). Range is from 1 to 65535.

Command Default

Three times the default hello interval time of 15 seconds.

Command Modes

Interface configuration

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

On very congested and large networks, the default hold time might not be sufficient time for all routers to receive hello packets from their neighbors. In this case, you may want to increase the hold time.

We recommend that the hold time be at least three times the hello interval. If a router does not receive a hello packet within the specified hold time, routes through this router are considered unavailable.

Increasing the hold time delays route convergence across the network.

To ensure nonstop forwarding during RP failovers, we recommend that the hold time be increased to 30 seconds.

Task ID

Task ID

Operations

eigrp

read, write

Examples

The following example shows how to set the hold time to 0 to 40 seconds for the interface:

  RP/0/RP0/CPU0:router(config)# router eigrp 1
  RP/0/RP0/CPU0:router(config-eigrp)# address-family ipv4
  RP/0/RP0/CPU0:router(config-eigrp)# router-id 10.1.1.1
  RP/0/RP0/CPU0:router(config-eigrp-af)# interface GigabitEthernet 0/1/0/0
  RP/0/RP0/CPU0:router(config-eigrp-af-if)# hold-time 40
  
         

Related Commands

Command

Description

bandwidth (interface)

Sets a bandwidth value for an interface.

hello-interval (EIGRP)

Configures the hello interval for the EIGRP routing process designated by an autonomous system number.

interface (EIGRP)

To define the interfaces on which the Enhanced Interior Gateway Routing Protocol (EIGRP) routing protocol runs, use the interface command in the appropriate configuration mode. To disable EIGRP routing for interfaces, use the no form of this command.

interface type interface-path-id

no interface type interface-path-id

Syntax Description

type

Interface type. For more information, use the question mark ( ? ) online help function.

interface-path-id

Physical interface or virtual interface.

Note   

Use the show interfaces command to see a list of all interfaces currently configured on the router.

For more information about the syntax for the router, use the question mark ( ? ) online help function.

Command Default

When you do not specify this command in configuration mode, EIGRP routing for interfaces is not enabled.

Command Modes

IPv4 address family configuration

IPv6 address family configuration

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the interface command to associate a specific interface with an EIGRP process. The interface remains associated with the process even when the IPv4 address of the interface changes.

This command places the router in interface configuration mode, from which you can configure interface-specific settings. Commands configured under this mode (such as the hello-interval command) are automatically bound to that interface.

Task ID

Task ID

Operations

eigrp

read, write

Examples

The following example shows how to enter interface configuration mode for EIGRP process 1 and set the hello interval to 10 seconds for GigabitEthernet interface 0/1/0/0:

  RP/0/RP0/CPU0:router(config)# router eigrp 1
  RP/0/RP0/CPU0:router(config-eigrp)# address-family ipv4
  RP/0/RP0/CPU0:router(config-eigrp)# router-id 10.1.1.1
  RP/0/RP0/CPU0:router(config-eigrp-af)# interface GigabitEthernet 0/1/0/0
  RP/0/RP0/CPU0:router(config-eigrp-af-if)# hello-interval 10
  
         

log-neighbor-changes

To enable the logging of changes in Enhanced Interior Gateway Routing Protocol (EIGRP) neighbor adjacencies, use the log-neighbor-changes command in the appropriate configuration mode. To disable the logging of changes in EIGRP neighbor adjacencies, use the no form of this command.

log-neighbor-changes

no log-neighbor-changes

Command Default

This command has no keywords or arguments.

Adjacency changes are not logged.

Command Modes

IPv4 address family configuration

IPv6 address family configuration

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the log-neighbor-changes command to log neighbor adjacency changes, monitor the stability of the routing system, and help detect problems. Logging is disabled by default. To disable the logging of neighbor adjacency changes, use the no form of this command.

Task ID

Task ID

Operations

eigrp

read, write

Examples

The following example shows how to enable logging of neighbor changes for EIGRP 1:

  RP/0/RP0/CPU0:router(config)# router eigrp 1
  RP/0/RP0/CPU0:router(config-eigrp)# address-family ipv4
  RP/0/RP0/CPU0:router(config-eigrp-af)# log-neighbor-changes
  
         

log-neighbor-warnings

To enable the logging of Enhanced Interior Gateway Routing Protocol (EIGRP) neighbor warning messages, use the log-neighbor-warnings command in the appropriate configuration mode. To disable the logging of EIGRP neighbor warning messages, use the no form of this command.

log-neighbor-warnings

no log-neighbor-warnings

Syntax Description

This command has no keywords or arguments.

Command Default

Neighbor warning messages are not logged.

Command Modes

IPv4 address family configuration

IPv6 address family configuration

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the log-neighbor-warnings command to disable and enable neighbor warning messages. When neighbor warning messages occur, they are not logged by default.

Task ID

Task ID

Operations

eigrp

read, write

maximum-paths (EIGRP)

To control the maximum number of parallel routes that the Enhanced Interior Gateway Routing Protocol (EIGRP) can support, use the maximum-paths command in the appropriate configuration mode. To remove the maximum-paths command from the configuration file and restore the system to its default condition with respect to the routing protocol, use the no form of this command.

maximum-paths maximum

no maximum-paths

Syntax Description

maximum

Maximum number of parallel routes that EIGRP can install in a routing table. Range is from 1 to 32 routes .

Command Default

maximum : 4

Command Modes

IPv4 address family configuration

IPv6 address family configuration

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the maximum-paths command to allow the EIGRP protocol to install multiple paths into the routing table for each prefix. Multiple paths are installed for both internal and external routes, providing these routes are learned in the same autonomous system and that they are equal cost (according to the EIGRP best path algorithm).

Task ID

Task ID

Operations

eigrp

read, write

metric (EIGRP)

To set metrics for an Enhanced Interior Gateway Routing Protocol (EIGRP) interface, use the metric command in interface configuration mode. To remove the metric values and restore the default state, use the no form of this command.

metric { bandwidth | delay | load | reliability }

no metric

Syntax Description

bandwidth

Minimum interface bandwidth of the route in kilobits per second. Range is 1 to 4294967295.

delay

Interface route delay in tens of microseconds. Delay is 1 or any positive number that is a multiple of 39.1 nanoseconds. Range is 1 to 4294967295.

load

Effective bandwidth of the route expressed as a number from 1 to 255 (255 is 100-percent loaded).

reliability

Likelihood of successful packet transmission expressed as a number between 0 and 255. The value 255 means 100-percent reliability; 0 means no reliability.

Command Default

Metric values are not set.

Command Modes

Interface configuration

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the metric command to provide metric values while redistributing a protocol into an EIGRP interface. Metric defaults have been carefully set to work for a wide variety of networks. Take great care when changing these values.

Task ID

Task ID Operation

eigrp

read, write

Examples

This example shows how to configure metric values for interface POS 0/1/0/1 with values as bandwidth = 100, delay = 7, reliability = 250, and load = 100.

RP/0/RP0/CPU0:router# configure
RP/0/RP0/CPU0:router(config)# router eigrp 100
RP/0/RP0/CPU0:router(config-eigrp)# address-family ipv4
RP/0/RP0/CPU0:router(config-eigrp-af)# interface GigabitEthernet 0/1/0/1
RP/0/RP0/CPU0:router(config-eigrp-af-if)# metric bandwidth 100 delay 7 reliability 250 load 100

Related Commands

Command Description

default-metric (EIGRP)

Sets metrics for an Enhanced Interior Gateway Routing Protocol (EIGRP).

metric maximum-hops

To advertise as unreachable those Enhanced Interior Gateway Routing Protocol (EIGRP) routes with a hop count higher than is specified by the command, use the metric maximum-hops command in the appropriate configuration mode. To reset the value to the default, use the no form of this command.

metric maximum-hops hops-number

no metric maximum-hops

Syntax Description

hops-number

Maximum hop count. Range is from 1 to 255 hops.

Command Default

hops-number : 100

Command Modes

IPv4 address family configuration

IPv6 address family configuration

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the metric maximum-hops command to provide a safety mechanism that breaks any potential count-to-infinity problems. This command causes the EIGRP routing protocol to advertise as unreachable routes with a hop count greater than the value assigned to the hops-number argument.

Task ID

Task ID

Operations

eigrp

read, write

Examples

The following example shows how to configure a hop count to 200 for a router that has a complex WAN generating a large hop count under normal (nonlooping) operations.

  RP/0/RP0/CPU0:router(config)# router eigrp 1
  RP/0/RP0/CPU0:router(config-eigrp) address-family ipv4
  RP/0/RP0/CPU0:router(config-eigrp-af)# metric maximum-hops 200
  
         

Related Commands

Command

Description

metric weights

Allows the tuning of the EIGRP metric calculations.

metric weights

To allow the tuning of the Enhanced Interior Gateway Routing Protocol (EIGRP) metric calculations, use the metric weights command in the appropriate configuration mode. To reset the values to their defaults, use the no form of this command.

metric weights tos k1 k2 k3 k4 k5

no metric weights

Syntax Description

tos

Type of service (ToS) which must always be 0.

k1 k2 k3 k4 k5

Constants that convert an EIGRP metric vector into a scalar quantity. The range is 0 to 4294967295.

Command Default

tos: 0

k1: 1

k2: 0

k3: 1

k4: 0

k5: 0

Command Modes

IPv4 address family configuration

IPv6 address family configuration

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the metric weights command to alter the default behavior of EIGRP routing and metric computation and allow the tuning of the EIGRP metric calculation for a particular ToS.

If k5 equals 0, the composite EIGRP metric is computed according to the following formula:

metric = [k1 * bandwidth + (k2 * bandwidth)/(256 – load) + k3 * delay]

If k5 does not equal zero, an additional operation is performed:

metric = metric * [k5/(reliability + k4)]

Bandwidth is inverse minimum bandwidth of the path in BPS scaled by a factor of 2.56 * 1012. The range is from a 1200-bps line to 10 terabits per second.

Delay is in units of 10 microseconds. The range of delay is from 10 microseconds to 168 seconds. A delay of all 1s indicates that the network is unreachable.

The delay parameter is stored in a 32-bit field, in increments of 39.1 nanoseconds. The range of delay is from 1 (39.1 nanoseconds) to hexadecimal FFFFFFFF (decimal 4,294,967,040 nanoseconds). A delay of all 1s (that is, a delay of hexadecimal FFFFFFFF) indicates that the network is unreachable.

This table lists the default values used for several common media.

Table 1 Bandwidth Values by Media Type

Media Type

Delay

Bandwidth

Satellite

5120 (2 seconds)

5120 (500 megabits)

Ethernet

25600 (1 milliseconds [ms])

256000 (10 megabits)

1.544 Mbps

512000 (20,000 ms)

1,657,856 bits

64 kbps

512000 (20,000 ms)

40,000,000 bits

56 kbps

512000 (20,000 ms)

45,714,176 bits

10 kbps

512000 (20,000 ms)

256,000,000 bits

1 kbps

512000 (20,000 ms)

2,560,000,000 bits

Reliability is given as a fraction of 255. That is, 255 is a reliability of 100 percent or a perfectly stable link. Load is given as a fraction of 255. A load of 255 indicates a completely saturated link.

Task ID

Task ID

Operations

eigrp

read, write

Examples

The following example shows how to set the metric weights to change the default values:

  RP/0/RP0/CPU0:router(config)# router eigrp 1
  RP/0/RP0/CPU0:router(config-eigrp) address-family ipv4
  RP/0/RP0/CPU0:router(config-eigrp-af)# metric weights 0 2 0 2 0 0

neighbor (EIGRP)

To define a neighboring router with which to exchange Enhanced Interior Gateway Routing Protocol (EIGRP) information, use the neighbor command in interface configuration mode. To remove an entry, use the no form of this command.

neighbor ip-address

no neighbor ip-address

Syntax Description

ip-address

IP address of a peer router with which routing information is exchanged.

Command Default

No neighboring routers are defined.

Command Modes

Interface configuration

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the neighbor command to permit the point-to-point (nonbroadcast) exchange of routing information.

Multiple neighbor commands can be used to specify additional neighbors or peers.

Task ID

Task ID

Operations

eigrp

read, write

Examples

This example shows how to permit the sending of EIGRP updates to specific neighbors. One copy of the update is generated for each neighbor:

  RP/0/RP0/CPU0:router(config)# router eigrp 1
  RP/0/RP0/CPU0:router(config-eigrp) address-family ipv6
  RP/0/RP0/CPU0:router(config-eigrp-af)# interface GigabitEthernet 0/1/0/1
  RP/0/RP0/CPU0:router(config-eigrp-af-if)# neighbor 172.20.1.2

Related Commands

Command

Description

passive-interface (EIGRP)

Disables sending and receiving "hello" messages on (EIGRP) interface.

next-hop-self disable

To instruct the Enhanced Interior Gateway Routing Protocol (EIGRP) process to use the received next-hop value when advertising the routes, use the next-hop-self disablecommand in interface configuration mode. To revert to the default, use the no form of this command.

next-hop-self disable

no next-hop-self disable

Syntax Description

This command has no keywords or arguments.

Command Default

EIGRP always sets the IP next-hop value to be itself.

Command Modes

Interface configuration

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

EIGRP, by default, sets the IP next-hop value to be itself for routes that it is advertising, even when advertising those routes on the same interface from which learned them. To change this default, you must use the next-hop-self disable interface configuration command to instruct EIGRP to use the received next-hop value when advertising these routes.

The next-hop-self disable feature is not available for redistributed routes.

Task ID

Task ID

Operations

eigrp

read, write

Examples

The following example shows how to change the default IP next-hop value and instruct EIGRP to use the received next-hop value:

RP/0/RP0/CPU0:router(config)# router eigrp 1
RP/0/RP0/CPU0:router(config-eigrp) address-family ipv4
RP/0/RP0/CPU0:router(config-eigrp-af)# interface GigabitEthernet 0/1/0/0
RP/0/RP0/CPU0:router(config-eigrp-af-if)# next-hop-self disable

nsf disable (EIGRP)

To disable Enhanced Interior Gateway Routing Protocol (EIGRP) nonstop forwarding (NSF), use the nsf disable command in appropriate configuration mode. To re-enable the EIGRP NSF from a disabled state, use the no form of this command.

nsf disable

no nsf disable

Syntax Description

This command has no keywords or arguments.

Command Default

NSF in EIGRP is enabled.

Command Modes

Router Configration

IPv4 address family configuration

IPv6 address family configuration

Command History

Release Modification
Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

If NSF is disabled, EIGRP will not be able to retain the routes learnt from its peers and may result in traffic loss during ISSU.

Task ID

Task ID Operation

eigrp

read, write

Related Commands

Command Description

router eigrp

Configures a routing process and enters router configuration mode for Enhanced Interior Gateway Routing Protocol (EIGRP).

passive-interface (EIGRP)

To disable sending and receiving "hello" messages on an Enhanced Interior Gateway Routing Protocol (EIGRP) interface and to disable formation of neighbors on the interface, use the passive-interface command in interface configuration mode. To reenable sending and receiving "hello messages", use the no form of this command.

passive-interface

no passive-interface

Syntax Description

This command has no keywords or arguments.

Command Default

passive-interface command is disabled on an interface.

Command Modes

Interface configuration

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the passive-interface command to disable sending of "hello" massages. The particular subnet on that interface will continue to be advertised by EIGRP to neighbors on other interfaces.

Task ID

Task ID

Operations

eigrp

read, write

Examples

This example shows how to configure passive-interface command on GigabitEthernet interface 0/6/5/0:

  RP/0/RP0/CPU0:router(config)# router eigrp 1
  RP/0/RP0/CPU0:router(config-eigrp) address-family ipv6
  RP/0/RP0/CPU0:router(config-eigrp-af)# interface GigabitEthernet 0/6/5/0
  RP/0/RP0/CPU0:router(config-eigrp-af-if)# passive-interface

redistribute (EIGRP)

To inject routes from one routing domain into the Enhanced Interior Gateway Routing Protocol (EIGRP), use the redistribute command in the appropriate configuration mode. To remove the redistribute command from the configuration file and restore the system to its default condition in which the software does not redistribute routes, use the no form of this command.

redistribute { {bgp | connected | isis | ospf | ospfv3 | rip | static | eigrp} | [ as-number | instance-name ] } [ route-policy name ]

no redistribute

Syntax Description

bgp

Distributes routes from the BGP protocol.

connected

Distributes routes that are established automatically by virtue of having enabled IP on an interface.

isis

Distributes routes from the IS-IS protocol.

ospf

Distributes routes from the OSPF protocol. This protocol is supported in the IPv4 address family.

ospfv3

Distributes routes from the OSPFv3 protocol. This protocol is supported in the IPv6 address family.

static

Redistributes IP static routes.

as-number | instance-name

Represents one of the following three options:

For the bgp keyword:

Range for 2-byte Autonomous system numbers (ASNs) is 1 to 65535.

Range for 4-byte Autonomous system numbers (ASNs) in asplain format is 1 to 4294967295.

Range for 4-byte Autonomous system numbers (ASNs) is asdot format is 1.0 to 65535.65535.

For the isis keyword, an IS-IS instance name from which routes are to be redistributed. The value takes the form of a string. A decimal number can be entered, but it is stored internally as a string.

For the ospf keyword, an OSPF instance name from which routes are to be redistributed. The value takes the form of a string. A decimal number can be entered, but it is stored internally as a string.

route-policy name

(Optional) Specifies the identifier of a configured policy. A policy is used to filter the importation of routes from this source routing protocol to EIGRP.

Command Default

Route redistribution is disabled.

Command Modes

IPv4 address family configuration

IPv6 address family configuration

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Redistributed routing information should always be filtered by the route- policy name keyword and argument. This filtering ensures that only those routes intended by the administrator are redistributed by EIGRP.

A default metric is usually required to redistribute routes from another protocol into EIGRP. The metric is configured through the default-metric command or under the route policy configured with the redistribute command.

For information about routing policies, see the Routing Policy Commands on module of the Routing Command Reference.

Task ID

Task ID

Operations

eigrp

read, write

Examples

This example shows how to cause BGP routes to be redistributed into an EIGRP autonomous system:

  RP/0/RP0/CPU0:router(config)# router eigrp 1
  RP/0/RP0/CPU0:router(config-eigrp) address-family ipv4
  RP/0/RP0/CPU0:router(config-eigrp-af)# redistribute bgp 100
  
  
         

Related Commands

Command

Description

default-metric (EIGRP)

Sets metrics for an EIGRP.

route-policy (EIGRP)

To apply a routing policy to updates advertised to or received from an Enhanced Interior Gateway Routing Protocol (EIGRP) neighbor, use the route-policy command in the appropriate configuration mode. To disable applying routing policy to updates, use the no form of this command.

route-policy route-policy-name { in | out }

no route-policy route-policy-name { in | out }

Syntax Description

route-policy-name

Name of route policy.

in

Applies policy to inbound routes.

out

Applies policy to outbound routes.

Command Default

No policy is applied.

Command Modes

IPv4 address family configuration

IPv6 address family configuration

Interface configuration

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the route-policy command to specify a routing policy for an inbound or outbound route. The policy can be used to filter routes or modify route attributes.

Task ID

Task ID

Operations

eigrp

read, write

Examples

The following example shows how to apply the IN-Ipv4 policy to inbound IP Version 4 (IPv4) routes:

  RP/0/RP0/CPU0:router(config)# router eigrp 1
  RP/0/RP0/CPU0:router(config-eigrp) address-family ipv4
  RP/0/RP0/CPU0:router(config-eigrp-af)# route-policy IN-IPv4 in
  
         

router-id (EIGRP)

To configure a router ID for an Enhanced Interior Gateway Routing Protocol (EIGRP) process, use the router-id command in the appropriate configuration mode. To cause the software to use the default method of determining the router ID, use the no form of this command.

router-id router-id

no router-id

Syntax Description

router-id

32-bit router ID value specified in four-part, dotted-decimal notation.

Command Default

If this command is not configured, EIGRP chooses an IPv4 address as the router ID from one of its interfaces.

Command Modes

IPv4 address family configuration

IPv6 address family configuration

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

It is good practice to use the router-id command to explicitly specify a unique 32-bit numeric value for the router ID. This action ensures that EIGRP can function regardless of the interface address configuration.

Task ID

Task ID

Operations

eigrp

read, write

Examples

The following example shows how to assign the IP address of 172.20.1.1 to the EIGRP process 1:

  RP/0/RP0/CPU0:router(config)# router eigrp 1
  RP/0/RP0/CPU0:router(config-eigrp) address-family ipv4
  RP/0/RP0/CPU0:router(config-eigrp-af)# router-id 172.20.1.1
  
         

show protocols (EIGRP)

To display information about the Enhanced Interior Gateway Routing Protocol (EIGRP) process configuration, use the show protocols command in XR EXEC mode.

show protocols [ ipv4 | | | afi-all ] [ all | | protocol ] [ private ]

Syntax Description

ipv4

(Optional) Specifies an IPv4 address family.

ipv6

(Optional) Specifies an IPv6 address family.

afi-all

(Optional) Specifies all address families.

all

(Optional) Specifies all protocols for a given address family.

protocol

(Optional) Specifies a routing protocol.

For the IPv4 address family, the options are eigrp , bgp , isis , ospf , and rip .

For the IPv6 address family, the options are bgp , isis , and ospfv3 .

default-context

(Optional) Displays default context information. This keyword is available when the eigrp or rip protocol is specified.

private

(Optional) Displays private EIGRP data. This keyword is available when the eigrp is specified.

Command Modes

XR EXEC

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the show protocols command to get information about the protocols running on the router and to quickly determine which protocols are active. The command is designed to summarize the important characteristics of the running protocol, and command output varies depending on the specific protocol selected.

For EIGRP, the command output lists the instance number, default AS context, router ID, default networks, distance, maximum paths, and so on.

Task ID

Task ID

Operations

EIGRP

read

Examples

The following is sample output from the show protocols eigrp command:

  RP/0/RP0/CPU0:router# show protocols eigrp
  
  Routing Protocol: EIGRP, instance 1
   Default context AS: 1, Router ID: 192.168.0.22
    Address Family: IPv4
     Default networks not flagged in outgoing updates
     Default networks not accepted from incoming updates
     Distance: internal 90, external 170
     Maximum paths: 4
     EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
     EIGRP maximum hopcount 100
     EIGRP maximum metric variance 1
     EIGRP NSF: enabled
      NSF-aware route hold timer is 240s
      NSF signal timer is 20s
      NSF converge timer is 120s
      Time since last restart is 01:01:21
     SIA Active timer is 180s
     Interfaces:
      GigabitEthernet0/6/0/0
  
  

This table describes the significant fields shown in the display.



Table 2 show protocols Field Descriptions

Field

Descriptions

instance

AS number of the instance.

  • Range for 2-byte Autonomous system numbers (ASNs) is 1 to 65535.
  • Range for 4-byte Autonomous system numbers (ASNs) in asplain format is 1 to 4294967295.
  • Range for 4-byte Autonomous system numbers (ASNs) is asdot format is 1.0 to 65535.65535.

AS

AS number of this context.

  • Range for 2-byte Autonomous system numbers (ASNs) is 1 to 65535.
  • Range for 4-byte Autonomous system numbers (ASNs) in asplain format is 1 to 4294967295.
  • Range for 4-byte Autonomous system numbers (ASNs) is asdot format is 1.0 to 65535.65535.

Address Family

Address family for which the configuration status is shown.

Default Networks Candidate

Default network acceptance and announcement behavior.

Distance

Administrative distance of EIGRP routes.

Maximum paths

Maximum paths installed in RIB for a route.

Metric Weight

Current metric weights used by EIGRP.

Maximum hopcount

Maximum hop count accepted by EIGRP.

Variance

Metric variance used to find feasible paths for a route.

Route hold time

Time duration for which routes learned from a neighbor are held without deletion while the neighbor is undergoing a graceful restart.

signal time

Nonstop forwarding signal time.

converge time

Nonstop forwarding convergence time.

SIA Active time

Active time period for SIA.

Interfaces

List of interfaces configured for EIGRP.

split-horizon disable (EIGRP)

To disable split horizon for an Enhanced Interior Gateway Routing Protocol (EIGRP) process, use the split-horizon disable command in interface configuration mode. To enable split horizon, use the no form of this command.

split-horizon disable

no split-horizon disable

Syntax Description

This command has no keywords or arguments.

Command Default

Split horizon is enabled for an EIGRP process.

Command Modes

Interface configuration

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Task ID

Task ID

Operations

eigrp

read, write

Examples

The following example shows how to disable split horizon an a GigabitEthernet link:

  RP/0/RP0/CPU0:router(config)# router eigrp 1
  RP/0/RP0/CPU0:router(config-eigrp) address-family ipv4
  RP/0/RP0/CPU0:router(config-eigrp-af)# interface GigabitEthernet 0/1/0/0
  RP/0/RP0/CPU0:router(config-eigrp-af-if)# split-horizon disable
  
         

stub (EIGRP)

To configure a router as a stub for Enhanced Interior Gateway Routing Protocol (EIGRP), use the stub command in the appropriate configuration mode. To disable this function, use the no form of this command.

stub [ receive-only | [connected] [redistributed] [static] [summary] ]

no stub [ receive-only | [connected] [redistributed] [static] [summary] ]

Syntax Description

receive-only

(Optional) Sets the router as a receive-only neighbor.

connected

(Optional) Advertises connected routes.

redistributed

(Optional) Advertises redistributed routes from other protocols and autonomous systems.

static

(Optional) Advertises static routes.

summary

(Optional) Advertises summary routes.

Command Default

Stub routing is disabled.

When stub routing is specified, connected and summary routes are advertised by default.

Command Modes

IPv4 address family configuration

IPv6 address family configuration

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the stub command to configure a router as a stub in which the router directs all IP traffic to a distribution router.

The stub command can be modified with several options, and these options can be used in any combination except for the receive-only keyword.

The receive-only keyword restricts the router from sharing any of its routes with any other router in that EIGRP autonomous system and does not permit any other option to be specified because it prevents any type of route from being sent. The four other optional keywords ( connected , static , summary , and redistributed ) can be used in any combination but cannot be used with the receive-only keyword. If any of these four keywords is used with the stub command, only the route types specified by the particular keyword or keywords are sent. Route types specified by the nonused keyword or keywords are not sent.

The connected keyword permits EIGRP stub routing to send connected routes. If all the connected routes are not covered by EIGRP interfaces, it may be necessary to redistribute connected routes with the redistribute connected command under the EIGRP process. This option is enabled by default.

The static keyword permits EIGRP stub routing to send static routes. Without the configuration of this option, EIGRP does not send any static routes. You may still need to redistribute static routes with the redistribute static command.

The summary keyword permits EIGRP stub routing to send summary routes. Summary routes can be created manually with the summary address command or automatically at a major network border router with the auto-summary command enabled. This option is enabled by default.

The redistributed keyword permits EIGRP stub routing to send other routing protocols and autonomous systems. Without the configuration of this option, EIGRP does not advertise redistributed routes.

Task ID

Task ID

Operations

eigrp

read, write

Examples

The following example shows how to configure, as a stub, the router that advertises connected and summary routes:

  RP/0/RP0/CPU0:router(config)# router eigrp 1
  RP/0/RP0/CPU0:router(config-eigrp) address-family ipv4
  RP/0/RP0/CPU0:router(config-eigrp-af)# stub
  
  
         

The following example shows how to configure the router as a receive-only neighbor (connected, summary, and static routes are not sent):

  RP/0/RP0/CPU0:router(config)# router eigrp 1
  RP/0/RP0/CPU0:router(config-eigrp) address-family ipv4
  RP/0/RP0/CPU0:router(config-eigrp-af)# stub receive-only
  
         

Related Commands

Command

Description

redistribute (EIGRP)

Redistributes routes from one routing domain into EIGRP.

summary-address (EIGRP)

Configures a summary aggregate address for the specified EIGRP interface.

auto-summary (EIGRP)

Allows automatic summarization of subnet routes into network-level routes for an EIGRP process.

summary-address (EIGRP)

To configure a summary aggregate address for the specified Enhanced Interior Gateway Routing Protocol (EIGRP) interface, use the summary-address command in interface configuration mode. To disable a configuration, use the no form of this command.

summary-address ip-address { /length | mask } [admin-distance]

no summary-address ip-address { /length | mask }

Syntax Description

ip-address

The IP address argument specifies the summary IP address to apply to an interface in four-part, dotted-decimal notation.

/ length

Prefix length, which can be indicated as a slash (/) and number. For example, /8 indicates that the first eight bits in the IP prefix are network bits. If length is used, the slash is required.

mask

IP address mask.

admin-distance

(Optional) Administrative distance. A value from 1 to 255.

Command Default

An administrative distance of 5 is applied to EIGRP summary routes.

No summary addresses are predefined.

Command Modes

Interface configuration

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

The summary-address command is used to configure interface-level address summarization. EIGRP summary routes are given an administrative distance of 5. The administrative distance is used to advertise a summary without installing it in the routing table.

By default, EIGRP summarizes subnet routes to the network level. The no auto-summary command can be entered to configure subnet level summarization.

Task ID

Task ID

Operations

eigrp

read, write

Examples

The following example shows how to configure an administrative distance of 95 on an EIGRP interface for the 192.168.0.0/16 summary address:

  RP/0/RP0/CPU0:router(config)# router eigrp 1
  RP/0/RP0/CPU0:router(config-eigrp) address-family ipv4
  RP/0/RP0/CPU0:router(config-eigrp-af)# interface GigabitEthernet 0/1/0/0
  RP/0/RP0/CPU0:router(config-eigrp-af-if)# summary-address 192.168.0.0/16 95 
  
         

Related Commands

Command

Description

auto-summary (EIGRP)

Allows automatic summarization of subnet routes into network-level routes for an EIGRP process.

timers active-time

To adjust the Enhanced Interior Gateway Routing Protocol (EIGRP) routing wait time, use the timers active-time command in the appropriate configuration mode. To disable this function, use the timers active-time no form of the command.

timers active-time [ time-limit | disabled ]

no timers active-time

Syntax Description

time-limit

Active time limit (in minutes). Range is from 1 to 4294967295 minutes.

disabled

Disables the timers and permits the routing wait time to remain active indefinitely.

Command Default

Disabled

Command Modes

IPv4 address family configuration

IPv6 address family configuration

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the timers active-time command to control the time the router waits (after query is sent) before declaring the route to be in the stuck in active (SIA) state.

Task ID

Task ID

Operations

eigrp

read, write

Examples

The following example shows how to configure an indefinite routing wait time on the specified EIGRP route:

  RP/0/RP0/CPU0:router(config)# router eigrp 1
  RP/0/RP0/CPU0:router(config-eigrp) address-family ipv4
  RP/0/RP0/CPU0:router(config-eigrp-af)# timers active-time disabled
  
         

timers nsf route-hold (EIGRP)

To set the timer that determines how long an NSF-aware Enhanced Interior Gateway Routing Protocol (EIGRP) router holds routes for an inactive peer, use the timers nsf route-hold command in the appropriate configuration mode. To return the route hold timer to the default value, use the no form of this command.

timers nsf route-hold seconds

no timers nsf route-hold

Syntax Description

seconds

Time, in seconds, that EIGRP holds routes for an inactive peer. Range is from 20 to 6000 seconds.

Command Default

EIGRP NSF awareness is enabled.

seconds :480

Command Modes

IPv4 address family configuration

IPv6 address family configuration

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the timers nsf route-hold command to set the maximum period of time that the NSF-aware router holds known routes for an NSF-capable neighbor during a switchover operation or a well-known failure condition. The route hold timer is configurable so that you can tune network performance and avoid undesired effects, such as packet loss on routes if the switchover operation takes too much time. When this timer expires, the NSF-aware router scans the topology table and discards any stale routes, allowing EIGRP peers to find alternate routes instead of waiting during a long switchover operation.

Task ID

Task ID

Operations

eigrp

read, write

Examples

The following example shows how to set the route hold timer value for an NSF-aware router to 2 minutes (120 seconds):

RP/0/RP0/CPU0:router(config)# router eigrp 1
RP/0/RP0/CPU0:router(config-eigrp) address-family ipv4
RP/0/RP0/CPU0:router(config-eigrp-af)# timers nsf route-hold 120

variance

To control load balancing in an Enhanced Interior Gateway Routing Protocol (EIGRP)-based internetwork, use the variance command in the appropriate configuration mode. To reset the variance to the default value, use the no form of this command.

variance multiplier

no variance

Syntax Description

multiplier

Metric value used for load balancing. Range is from 1 to 128.

Command Default

multiplier : 1 (equal-cost load balancing)

Command Modes

IPv4 address family configuration

IPv6 address family configuration

Command History

Release

Modification

Release 5.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the variance command to set a variance on the EIGRP router so that the router can determine the feasibility of a potential route. A route is feasible if the next router in the path is closer to the destination than the current router and the metric for the entire path is within the variance. Only paths that are feasible can be used for load balancing and included in the routing table.

If the following two conditions are met, the route is considered feasible and can be added to the routing table:

  1. The local best metric must be greater than the metric learned from the next router.
  2. The multiplier times the local best metric for the destination must be greater than or equal to the metric through the next router.

Task ID

Task ID

Operations

eigrp

read, write

Examples

The following example shows how to set a variance of 4:

  RP/0/RP0/CPU0:router(config)# router eigrp 1
  RP/0/RP0/CPU0:router(config-eigrp) address-family ipv4
  RP/0/RP0/CPU0:router(config-eigrp-af)# variance 4