Guest

Cisco 1000 Series Connected Grid Routers

Cisco Connected Grid WPAN Module for CGR1000 Series Installation and RFLAN Configuration Guide

  • Viewing Options

  • PDF (186.8 KB)
  • Feedback
Cisco Connected Grid WPAN Module for CGR1000 Series Installation and RFLAN Configuration Guide

Table Of Contents

Cisco Connected Grid WPAN Module for CGR1000 Series Installation and RFLAN Configuration Guide

Kit Contents

Features

Hardware Overview

Front Panel

LED

Supported Cisco Antenna

Cisco Supported Cables

Interfaces

Configuration

Default Parameters

Environmental Specifications

Power Specifications

Installing and Removing the Module

Installation Warning Statements

Installing the WPAN Module

Removing the WPAN Module

Regulatory and Compliance Information

Software Overview

Prerequisites

Sample Router Configuration

Additional References

Hardware Overview and Installation

Supported Cisco Antennas and Accessories

Cisco System Software Commands

Regulatory, Compliance, and Safety Information

Technical Assistance

Tell Us What You Think


Cisco Connected Grid WPAN Module for CGR1000 Series Installation and RFLAN Configuration Guide


First Published: February 2012
OL-26243-02

This guide explains how to install the Wireless Personal Area Network (WPAN) module and contains the following topics:

Kit Contents

Features

Hardware Overview

Installing and Removing the Module

Regulatory and Compliance Information

Software Overview

Additional References

Technical Assistance

Tell Us What You Think


Warning Only trained and qualified personnel should be allowed to install, replace, or service this equipment. Statement 1030

Figure 1 Cisco Connected Grid WPAN Module

Kit Contents

For system requirements, important notes, limitations, open and resolved bugs, and last-minute documentation updates, see the Release Notes on Cisco.com: http://www.cisco.com/en/US/products/ps12256/prod_release_notes_list.html.

For translations of the warnings that appear in this document, see the Regulatory Compliance and Safety Information document for your router on Cisco.com:

http://www.cisco.com/en/US/docs/routers/connectedgrid/cgr1000/rcsi/cgr1000.rsci.html

When using the online publications, see the documents that match the Cisco system software version running on the WPAN module.

Features

The WPAN module provides IEEE 802.15.4 g/e-compliant, and highly secure wireless connectivity for the Cisco 1000 Series Connected Grid Routers to enable Field Area Network (FAN) applications.

The module is ideal for multi-hop mesh networks and long-reach solutions and helps enable a high ratio of endpoints to the Field Area Router (FAR). The WPAN module provides the following functionality:

Dynamic network discovery and self-healing network capabilities based on IEEE 802.15.4 g/e

A subset of the frequency range can be selected according to the regulations of your country. See Configuration

Advanced Encryption Standard (AES) 128-bit encryption

IEEE 802.1x networking protocol

WPAN module health monitoring

WPAN module reset and reprogram functionality

WPAN module interface statistics and status

Hardware Overview

The WPAN module hardware contains a Cortex-M3, microcontroller, Texas Instruments CC1101 RF Transceiver operating in the 900 MHz ISM band, Semtech SX1781 PLL Frequency Synthesizer, and RF Micro Devices RF6559 front-end module.

The WPAN module can be installed into any slot in CGR 1000 Series routers.

This section covers the following topics:

Front Panel

LED

Supported Cisco Antenna

Cisco Supported Cables

Configuration

Default Parameters

Environmental Specifications

Power Specifications

Front Panel

Figure 2 shows the front panel of the WPAN module.

Figure 2 Front Panel of the Cisco Connected Grid WPAN Module

LED

Table 1 lists the LED indicators and describes the behavior. The LED provides a visual indicator of the available services.

Table 1 LED Indicator

LED Name
Color
Description

Status

Green

Indicates the RF status:

Off: Module is not powered

On: System is functional - RF mesh interface is up (if installed)

Blinking: Hardware is functional - RF mesh interface is up (if installed)


Supported Cisco Antenna

The antenna is connected to the QMA, panel-mount, 50-ohm connector located on the faceplate of the WPAN module.

For more information about antennas, including installation steps, see the Cisco Connected Grid 1240 Router Installation Guide.

Table 2 lists the Cisco antennas supported for use with the WPAN module and the Cisco Connected Grid 1120 Router.

Table 2 CGR 1240 Supported Antennas and Cables for use with the WPAN Module

Description
Outdoor Cable
Antennas

WPAN module

10.5'or 17.5' cable through conduit

Single cable passes through conduit from inside to outside building.

900 MHz, 3G, 806 to 960 MHz, 1710 to 2700 MHz, monopole antenna, chassis mounted, omni-directional, includes non-integrated co-axial cable. No cable (option class).

ANT-MP-INT-OUT-M

900 MHz ISM band, outdoor, omnidirectional stick, 5 dBi gain, N(f), qty 1

ANT-WPAN-OM-OUT-N


Cisco Supported Cables

Table 3 lists the external cable options and internal cable/adapter available from Cisco for use with the WPAN module.

Table 3 Cisco External and Internal Cables for WPAN Module

Outdoor Cable Options
Indoor Cable/Adapter
Antennas

RA-N(m) to N(m), LMR-400-DB, 20', qty 1

CAB-L400-20-N-N

RA-N(m)-N(m), LMR-600-DB, 30', qty 1

CAB-L600-30-N-N

RA-QMA(m) to N(m), LMR-240-FR, 10', qty 1

CAB-L240-10-Q-N

Lightning arrestor, N(f)-N(f), qty 1

CGR-LA-NF-NF

900 MHz ISM band, omnidirectional stick, 5 dBi gain, N(f), qty 1

ANT-WPAN-OM-OUT-N

None

RA-QMA(m) to RA-MCX (m), LMR-100, 10.5", qty 2

CAB-L100-10-Q-M

900 MHz, 3G, 806 to 960 MHz, 1710 to 2700 MHz, monopole antenna, chassis mounted, omnidirectional, qty 2

ANT-MP-INT-OUT-M


Interfaces

The WPAN module includes the following physical interfaces to the host:

Single RF Transceiver—supports IEEE 802.15.4g in the 902-to-928 MHz ISM. The RF transceiver is used to provide mesh networking connectivity.

Single Serial UART—used to communicate with the Cisco Connected Grid 1240 Router host processor via the onboard FPGA I/O module, providing framing control and buffering for UART data communications.

GPIO—control and data communications

Configuration

The configuration parameters are set by the Connected Grid Network Management System (CG-NMS), through a series of CLI commands.

Statistics on network traffic is also retrieved from the interface through the RF port manager, through the use of the CLI.

Default Parameters

Table 4 lists the interface default values.

Table 4 List of Interface Default Values

Parameters
Default Value

Admin State

Enabled

802.15.4 Raw Data Rates

155 kbps (78.6 kbps with FEC on by default)

RF Transmit Power

28 dBm

Channels

52 (frequency hopping)

Link Retransmission Retries

16


Table 5 lists the default frequencies for each channel.

Table 5 List of Default Frequencies for each Channel 

Channel #
Channel f. (MHz)
Channel #
Channel f. (MHz)
Channel #
Channel f. (MHz)
Channel #
Channel f. (MHz)

1

902.250

14

908.750

27

915.250

40

921.750

2

902.750

15

909.250

28

915.750

41

922.250

3

903.250

16

909.750

29

916.250

42

922.750

4

903.750

17

910.250

30

916.750

43

923.250

5

904.250

18

910.750

31

917.250

44

923.750

6

904.750

19

911.250

32

917.750

45

924.250

7

905.250

20

911.750

33

918.250

46

924.750

8

905.750

21

912.250

34

918.750

47

925.250

9

906.250

22

912.750

35

919.250

48

925.750

10

906.750

23

913.250

36

919.750

49

926.250

11

907.250

24

913.750

37

920.250

50

926.750

12

907.750

25

914.250

38

920.750

51

927.250

13

908.250

26

914.750

39

921.250

52

927.750


Environmental Specifications

Following are the operating temperature range for the routers:

Connected Grid 1120 Router: -40 to 60° C (-40° F to 140° F)

Connected Grid 1240 Router: -40 to 70° C (-31° F to 158° F)

Table 6 lists the environmental specifications for the Connected Grid WPAN Module.

Table 6 WPAN Module Environmental Specifications

Environmental—Operational
Specifications

Temperature—operational

-40 to 70-degrees C (-40 to 158-degrees F)

Altitude

Up to 1500 meters

Humidity

RH95% noncondensing

Vibration

1.0 g from 1.0 to 150 Hz

Shock

30 G half sine 6 ms and 11 ms

Seismic

GR63-Core, Zone 4


Power Specifications

The Connected Grid WPAN Module has a 12V power rail and 3.3V standby power provided by the host system.

Installing and Removing the Module

Before installing the WPAN module, verify the following guidelines have been met:

Clearance to the I/O side view is such that the LED can be read

Airflow around the WPAN module and through the vents is unrestricted

Temperature around the unit does not exceed 140-degrees F (60-degrees C). If the WPAN module is installed in a closed or multi-rack assembly, the temperature around it might be higher than normal room temperature.

Relative humidity around the WPAN module does not exceed 95% (non-condensing)

Altitude at the installation site is not higher than 10,000 feet

After replacing or installing a module in the router, you must update the label (on the router exterior) that lists the module types contained in the router. The label must list the FCC ID number and the IC Certification number for each module installed in the router.

Installation Warning Statements

This section includes the basic installation warning statements. Translations of these warning statements appear in the Regulatory Compliance and Safety Information for Cisco Connected Grid Router 1000 Series Routers documents.


Warning Only trained and qualified personnel should be allowed to install, replace, or service this equipment. Statement 1030

Warning To prevent the system from overheating, do not operate it in an area that exceeds the maximum recommended ambient temperature of 140°F (60°C). Statement 1047

Warning To prevent airflow restriction, allow clearance around the ventilation openings to be at least: 1.75 in. (4.4 cm). Statement 1076

Installing the WPAN Module

Follow these steps to install the module into an available slot in the Cisco Connected Grid 1120 Router or the Cisco Connected Grid 1240 Router:


Caution The module can NOT be hot swapped—to install the module, you must first power down the module.


Step 1 Before you install (or remove) the Connected Grid WPAN Module from the host router, you must power down the router as described in the Hardware Installation Guide of your router.

Step 2 Insert the WPAN module into the slot.

Step 3 Using a screwdriver, secure the two captive screws into place.


Removing the WPAN Module

Follow these steps to remove the WPAN module from a slot in the Cisco Connected Grid 1120 Router, or the Cisco Connected Grid 1240 Router:


Caution The module can NOT be hot swapped—to install the module, you must first power down the module.


Step 1 Using a screwdriver, loosen the two captive screws on the Connected Grid WPAN Module.

Step 2 Gently pull the WPAN module out of the slot.


Regulatory and Compliance Information

For regulatory compliance and safety information for the WPAN module, refer to the Connected Grid Router 2000 Series Regulatory Compliance and Safety Information document:

http://www.cisco.com/en/US/docs/routers/access/2000/CGR2010/hardware/rcsi/rcsiCGR2000series.html

Software Overview

The Connected Grid WPAN Module is configured using the Cisco Connected Grid 1240 Router system software.

This section provides the following information for cell relay on the WPAN module.

Prerequisites

Sample Router Configuration

For more information, see the CGR 1000 configuration guides at http://www.cisco.com/en/US/products/ps12256/products_installation_and_configuration_guides_list.html.


Note Before configuring the CGR1000 with the cell relay feature, the WPAN module must be install in the router.


Prerequisites

The Cisco 1000 Series Connected Grid Routers have the following:

Two slots for WAN/LAN interface cards

An 8-port switch, out of which two are combo ports (ports 7 and 8)

One console port

One auxiliary port

Two serial ports

Connecting to the console port of the Cisco Connected Grid 1240 Router displays the loading sequence. Once the router has completed the boot process, the login prompt displays.


Note The system takes up to three minutes to come up after you initially login and start configuring the router. Please wait for the prompt before continuing and running CLI commands.


Refer to the Cisco Connected Grid 1240 Router Configuration Guide for details on how to bring up and log into the router.

Sample Router Configuration

The following is a sample configuration:

router# show running-config 
 
   
!Command: show running-config
!Time: Tue Oct  4 15:23:02 2011
 
   
version 5.2(1)
logging level feature-mgr 0
hostname Altamont37
vdc wireless-far id 1
  limit-resource vlan minimum 16 maximum 4094
  limit-resource vrf minimum 2 maximum 4096
  limit-resource u4route-mem minimum 9 maximum 9
  limit-resource u6route-mem minimum 24 maximum 24
  limit-resource m4route-mem minimum 58 maximum 58
  limit-resource m6route-mem minimum 8 maximum 8
 
   
feature telnet
feature crypto ike
crypto ike domain ipsec
  policy 10
    authentication pre-share
    group 5
  key Cisco123 address 11.0.0.1
  key Cisco123 address 192.10.0.1
  key Cisco123 address 192.168.168.1
feature scheduler
feature ospf
feature netflow
feature dhcp
feature tunnel
feature crypto ipsec virtual-tunnel
feature c1222r     <-- Cell Relay
 
   
logging level ntp 7
logging level evmc 7
logging level evms 7
logging level vshd 7
logging level wifipm 2
logging level netstack 3
 
   
username adminbackup password 5 !  role network-operator
username admin password 5 $1$clxfU5Ae$auC5BarZetpQMhU4gjA5a.  role network-admin
no password strength-check
ip domain-lookup
copp profile strict
snmp-server user admin network-admin auth md5 0xa4495f08940116511391f04d149fc878
 priv 0xa4495f08940116511391f04d149fc878 localizedkey
rmon event 1 log trap public description FATAL(1) owner PMON@FATAL
rmon event 2 log trap public description CRITICAL(2) owner PMON@CRITICAL
rmon event 3 log trap public description ERROR(3) owner PMON@ERROR
rmon event 4 log trap public description WARNING(4) owner PMON@WARNING
rmon event 5 log trap public description INFORMATION(5) owner PMON@INFO
ntp distribute
ntp peer 10.1.1.99
ntp source-interface  Ethernet2/1
ntp commit 
 
   
vrf context management
track 1 ip route 20.0.0.1/32 reachability
 delay up 120 down 120
 
   
crypto ipsec transform-set MyTransformSet esp-aes 128 esp-sha1-hmac
crypto ipsec profile MyProfile
  set transform-set MyTransformSet
vlan 1
 
   
service dhcp
ip dhcp relay
wifi ssid blah
  authentication open
 
   
interface Tunnel15
  ip address 23.0.5.2/30
  ip ospf cost 100
  ip ospf dead-interval 20
  ip ospf hello-interval 5
  ip ospf mtu-ignore
  ip router ospf 2 area 0.0.0.2
  tunnel mode ipsec ipv4
  tunnel source wimax5/1
  tunnel destination 192.10.0.1
  no keepalive
  tunnel protection ipsec profile MyProfile
  no shutdown
 
   
interface Tunnel16
  ip address 23.0.6.2/30
  ip ospf cost 500
  ip ospf dead-interval 20
  ip ospf hello-interval 5
  ip ospf mtu-ignore
  ip router ospf 2 area 0.0.0.2
  tunnel mode ipsec ipv4
  tunnel source cellular3/1
  tunnel destination 192.168.168.1
  no keepalive
  tunnel protection ipsec profile MyProfile
  no shutdown
 
   
interface Tunnel17
  ip address 23.0.7.2/30
  ip ospf cost 1000
  ip ospf dead-interval 20
  ip ospf hello-interval 5
  ip ospf mtu-ignore
  ip router ospf 2 area 0.0.0.2
  tunnel mode ipsec ipv4
  tunnel source Ethernet2/7
  tunnel destination 11.0.0.1
  no keepalive
  tunnel protection ipsec profile MyProfile
  no shutdown
 
   
interface Tunnel111
  ip address 2.2.2.2/24
  ipv6 address 2001:a:a:abcd::2/64
  tunnel source Ethernet2/7
  tunnel destination 11.0.0.1
  no keepalive
 
   
interface dialer1
  dialer persistent
  dialer pool 1
  dialer string gsm1
 
   
interface Ethernet2/1
  mac-address 0022.bde0.2f91
  ip address 172.27.166.60/8
  no shutdown
 
   
interface Ethernet2/2
  mac-address 0022.bde0.2f92
  no shutdown
 
   
interface Ethernet2/3
  mac-address 0022.bde0.2f93
 
   
interface Ethernet2/4
  mac-address 0022.bde0.2f94
  ip address dhcp
  no shutdown
  ip dhcp relay address 19.0.0.100 
 
   
interface Ethernet2/5
  mac-address 0022.bde0.2f95
 
   
interface Ethernet2/6
  mac-address 0022.bde0.2f96
  ipv6 address 80::1/64
  no shutdown
 
   
interface Ethernet2/7
  ip address 11.0.0.11/16
  no shutdown
 
   
interface Ethernet2/8
  mac-address 0022.bde0.2f98
 
   
interface loopback0
  ip address 20.0.0.2/24
  ip router ospf 2 area 0.0.0.2
 
   
interface loopback5
 
   
interface cellular3/1
  no shutdown
  dialer pool-member 1
 
   
interface wimax5/1
  no shutdown
  scan-list aaa
  ip address 192.10.0.21/16
 
   
interface wpan4/1
  panid 0
 
   
interface wifi2/1
clock timezone PST -8 0
clock summer-time PDT 2 Sun Mar 02:00 1 Sun Nov 02:00 60
line console
  exec-timeout 0
line vty
  exec-timeout 0
router ospf 2
ip route 10.1.1.0/24 20.0.0.1
ip route 128.0.0.0/8 172.27.166.1
ip route 171.0.0.0/8 172.27.166.1
ip route 172.0.0.0/8 172.27.166.1
ip route 182.0.0.0/8 25.0.0.1
ipv6 route 2001:a:a:abcd::/127 Tunnel111
event manager environment bh_iflist2 "tunnel1 tunnel15 tunnel16"
event manager environment bh_down_reset_thresh "30"
event manager environment bh_iflist "cell3/1 wimax5/1"
event manager environment bh_down_reload_thresh "60"
event manager environment bh_flap_thresh_cnt "10"
event manager environment bh_flap_thresh_duration "15"
event manager environment bhmgr_track_obj_instance "1"
event manager environment eem_dbg_level "1"
event manager applet bhmgrbhdown
  event track 1 state down
  action 1.0 syslog priority critical msg Backhaul is down
  action 2.0 cli tclsh bootflash:bhmgr.tcl bhmgr_process_bh_down
  action 3.0 cli command maximum-timeout
event manager applet bhmgrbhup
  event track 1 state up
  action 1.0 syslog priority errors msg Backhaul is up
  action 2.0 cli tclsh bootflash:bhmgr.tcl bhmgr_process_bh_up
  action 3.0 cli command maximum-timeout
event manager applet shutnoshutif
  event track 15 state down
  action 1.0 syslog priority critical msg Wimax went down - doing shut/no shut o
  
chat-script gsm1 PROFILE1
wimax scan-list aaa
  channel index 1 frequency 2550000 bandwidth 10000
  nap id 00:00:01 priority 1 channel-index 1
  nsp id 00:00:01 home
 
   
cgdm
logging logfile test 7
logging monitor 7
logging level user 2
 
   
 
   
scheduler job name bhmgr_monitor
tclsh bootflash:/bhmgr.tcl bhmgr_monitor
 
end-job
 
   
scheduler schedule name bhmgr_monitor_schedule
  job name bhmgr_monitor
  time start 2011:08:30:16:09 repeat 0:0:1
 
   
 
   
router# 

Additional References

Consult the following resources for related information about the Connected Grid WPAN Module for technical assistance.

Hardware Overview and Installation

Cisco Connected Grid Modules

http://www.cisco.com/go/cgmodules

Cisco CGR 1240 Hardware Installation Guide

http://www.cisco.com/go/cgr1000-docs

Supported Cisco Antennas and Accessories

Cisco CGR 1000 and 2000 Series Connected Grid Antennas Guide

http://www.cisco.com/en/US/docs/routers/connectedgrid/antennas/installing/cg_antenna_install_guide.html

Cisco System Software Commands

Cisco System Software

http://www.cisco.com/en/US/products/ps9372/tsd_products_support_series_home.html

Configuring Cisco EHWIC-3G-EDVO-x

http://www.cisco.com/en/US/docs/routers/access/1800/1861/software/feature/guide/mrwls_evdo.html

Cisco 1000 Series Connected Grid Routers Unicast Routing Software Configuration Guide

www.cisco.com/en/US/docs/routers/connectedgrid/cgr1000/1_0/software/configuration/guide/unicast/Unicast_Book.html

Regulatory, Compliance, and Safety Information

Cisco Network Modules and Interface Cards Regulatory Compliance and Safety Information

http://www.cisco.com/en/US/docs/routers/access/interfaces/rcsi/IOHrcsi.html

Technical Assistance

The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html

Tell Us What You Think

 

Send your feedback about this document directly to the Connected Energy Documentation Team.

Connected Energy Documentation Feedback Form