Cisco ASR 903 Router Chassis Software Configuration Guide, IOS XE Release 3.10S
Configuring Pseudowire
Downloads: This chapterpdf (PDF - 530.0KB) The complete bookPDF (PDF - 2.69MB) | Feedback

Table of Contents

Configuring Pseudowire

Pseudowire Overview

Circuit Emulation Overview

Structure-Agnostic TDM over Packet

Circuit Emulation Service over Packet-Switched Network

Asynchronous Transfer Mode over MPLS

Transportation of Service Using Ethernet over MPLS

Configuring CEM

Configuration Guidelines and Restrictions

Configuring a CEM Group

Using CEM Classes

Configuring CEM Parameters

Configuring Payload Size (Optional)

Setting the Dejitter Buffer Size

Setting an Idle Pattern (Optional)

Enabling Dummy Mode

Setting a Dummy Pattern

Shutting Down a CEM Channel

Configuring ATM

Configuring a Clear-Channel ATM Interface

Configuring ATM IMA

Configuring Structure-Agnostic TDM over Packet (SAToP)

Configuring Circuit Emulation Service over Packet-Switched Network (CESoPSN)

Configuring a Clear-Channel ATM Pseudowire

Configuring an ATM over MPLS Pseudowire

Configuring the Controller

Configuring an IMA Interface

Configuring the ATM over MPLS Pseudowire Interface

Configuring 1-to-1 VCC Cell Transport Pseudowire

Configuring N-to-1 VCC Cell Transport Pseudowire

Configuring 1-to-1 VPC Cell Transport

Configuring ATM AAL5 SDU VCC Transport

Configuring a Port Mode Pseudowire

Optional Configurations

Configuring an Ethernet over MPLS Pseudowire

Configuring Pseudowire Redundancy

Verifying the Interface Configuration

Configuration Examples

Example: CEM Configuration

Example: ATM IMA Configuration

Example: ATM over MPLS

Cell Packing Configuration Examples

Cell Relay Configuration Examples

Example: Ethernet over MPLS

Pseudowire Overview

The following sections provide an overview of pseudowire support on the Cisco ASR 903 Series Router.

Circuit Emulation Overview

Circuit Emulation (CEM) is a technology that provides a protocol-independent transport over IP networks. It enables proprietary or legacy applications to be carried transparently to the destination, similar to a leased line.

The Cisco ASR 903 Series Router supports two pseudowire types that utilize CEM transport: Structure-Agnostic TDM over Packet (SAToP) and Circuit Emulation Service over Packet-Switched Network (CESoPSN). The following sections provide an overview of these pseudowire types.

Structure-Agnostic TDM over Packet

SAToP encapsulates time division multiplexing (TDM) bit-streams (T1, E1, T3, E3) as PWs over public switched networks. It disregards any structure that may be imposed on streams, in particular the structure imposed by the standard TDM framing.

The protocol used for emulation of these services does not depend on the method in which attachment circuits are delivered to the provider edge (PE) devices. For example, a T1 attachment circuit is treated the same way for all delivery methods, including copper, multiplex in a T3 circuit, a virtual tributary of a SONET/SDH circuit, or unstructured Circuit Emulation Service (CES).

In SAToP mode the interface is considered as a continuous framed bit stream. The packetization of the stream is done according to IETF RFC 4553. All signaling is carried out transparently as a part of a bit stream. Figure 12-1 shows the frame format in Unstructured SAToP mode.

Figure 12-1 Unstructured SAToP Mode Frame Format

 

Table 12-1 shows the payload and jitter limits for the T1 lines in the SAToP frame format.

Table 12-1 SAToP T1 Frame: Payload and Jitter Limits

 

Maximum Payload
Maximum Jitter
Minimum Jitter
Minimum Payload
Maximum Jitter
Minimum Jitter

960

320

10

192

64

2

Table 12-2 shows the payload and jitter limits for the E1 lines in the SAToP frame format.

Table 12-2 SAToP E1 Frame: Payload and Jitter Limits

 

Maximum Payload
Maximum Jitter
Minimum Jitter
Minimum Payload
Maximum Jitter
Minimum Jitter

1280

320

10

256

64

2

For instructions on how to configure SAToP, see “Configuring Structure-Agnostic TDM over Packet (SAToP)” section.

Circuit Emulation Service over Packet-Switched Network

CESoPSN encapsulates structured TDM signals as PWs over public switched networks (PSNs). It complements similar work for structure-agnostic emulation of TDM bit streams, such as SAToP. Emulation of circuits saves PSN bandwidth and supports DS0-level grooming and distributed cross-connect applications. It also enhances resilience of CE devices due to the effects of loss of packets in the PSN.

CESoPSN identifies framing and sends only the payload, which can either be channelized T1s within DS3 or DS0s within T1. DS0s can be bundled to the same packet. The CESoPSN mode is based on IETF RFC 5086.

CESoPSN supports channel associated signaling (CAS) for E1 and T1 interfaces. CAS provides signaling information within each DS0 channel as opposed to using a separate signaling channel. CAS is also referred to as in-band signaling or robbed bit signaling.

Each supported interface can be configured individually to any supported mode. The supported services comply with IETF and ITU drafts and standards.

Figure 12-2 shows the frame format in CESoPSN mode.

Figure 12-2 Structured CESoPSN Mode Frame Format

 

Table 12-3 shows the payload and jitter for the DS0 lines in the CESoPSN mode.

Table 12-3 CESoPSN DS0 Lines: Payload and Jitter Limits

 

DS0
Maximum Payload
Maximum Jitter
Minimum Jitter
Minimum Payload
Maximum Jitter
Minimum Jitter

1

40

320

10

32

256

8

2

80

320

10

32

128

4

3

120

320

10

33

128

4

4

160

320

10

32

64

2

5

200

320

10

40

64

2

6

240

320

10

48

64

2

7

280

320

10

56

64

2

8

320

320

10

64

64

2

9

360

320

10

72

64

2

10

400

320

10

80

64

2

11

440

320

10

88

64

2

12

480

320

10

96

64

2

13

520

320

10

104

64

2

14

560

320

10

112

64

2

15

600

320

10

120

64

2

16

640

320

10

128

64

2

17

680

320

10

136

64

2

18

720

320

10

144

64

2

19

760

320

10

152

64

2

20

800

320

10

160

64

2

21

840

320

10

168

64

2

22

880

320

10

176

64

2

23

920

320

10

184

64

2

24

960

320

10

192

64

2

25

1000

320

10

200

64

2

26

1040

320

10

208

64

2

27

1080

320

10

216

64

2

28

1120

320

10

224

64

2

29

1160

320

10

232

64

2

30

1200

320

10

240

64

2

31

1240

320

10

248

64

2

32

1280

320

10

256

64

2

For instructions on how to configure SAToP, see Configuring Structure-Agnostic TDM over Packet (SAToP).

Asynchronous Transfer Mode over MPLS

An ATM over MPLS (AToM) PW is used to carry Asynchronous Transfer Mode (ATM) cells over an MPLS network. It is an evolutionary technology that allows you to migrate packet networks from legacy networks, while providing transport for legacy applications. AToM is particularly useful for transporting 3G voice traffic over MPLS networks.

You can configure AToM in the following modes:

  • N-to-1 Cell—Maps one or more ATM virtual channel connections (VCCs) or virtual permanent connection (VPCs) to a single pseudowire.
  • 1-to-1 Cell—Maps a single ATM VCC or VPC to a single pseudowire.
  • Port—Maps a single physical port to a single pseudowire connection.

The Cisco ASR 903 Series Router also supports cell packing and PVC mapping for AToM pseudowires.


Note This release does not support AToM N-to-1 Cell Mode or 1-to-1 Cell Mode.


For more information about how to configure AToM, see “Configuring an ATM over MPLS Pseudowire” section.

Transportation of Service Using Ethernet over MPLS

Ethernet over MPLS (EoMPLS) PWs provide a tunneling mechanism for Ethernet traffic through an MPLS-enabled Layer 3 core network. EoMPLS PWs encapsulate Ethernet protocol data units (PDUs) inside MPLS packets and use label switching to forward them across an MPLS network. EoMPLS PWs are an evolutionary technology that allows you to migrate packet networks from legacy networks while providing transport for legacy applications. EoMPLS PWs also simplify provisioning, since the provider edge equipment only requires Layer 2 connectivity to the connected customer edge (CE) equipment. The Cisco ASR 903 Series Router implementation of EoMPLS PWs is compliant with the RFC 4447 and 4448 standards.

The Cisco ASR 903 Series Router supports VLAN rewriting on EoMPLS PWs. If the two networks use different VLAN IDs, the router rewrites PW packets using the appropriate VLAN number for the local network.

For instructions on how to create an EoMPLS PW, see Configuring an Ethernet over MPLS Pseudowire.

Configuring CEM

This section provides information about how to configure CEM. CEM provides a bridge between a time-division multiplexing (TDM) network and a packet network, such as Multiprotocol Label Switching (MPLS). The router encapsulates the TDM data in the MPLS packets and sends the data over a CEM pseudowire to the remote provider edge (PE) router. Thus, function as a physical communication link across the packet network.

The following sections describe how to configure CEM:


Note Steps for configuring CEM features are also included in the Configuring Structure-Agnostic TDM over Packet (SAToP) and Configuring Circuit Emulation Service over Packet-Switched Network (CESoPSN) sections.


Configuration Guidelines and Restrictions

Not all combinations of payload size and dejitter buffer size are supported. If you apply an incompatible payload size or dejitter buffer size configuration, the router rejects it and reverts to the previous configuration.

Configuring a CEM Group

The following section describes how to configure a CEM group on the Cisco ASR 903 Series Router.

SUMMARY STEPS

1. enable

2. configure terminal

3. controller { t1 | e1 } slot / subslot / port

4. cem-group group-number { unframed | timeslots timeslot }

5. end

DETAILED STEPS

Command
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

controller {t1 | e1} slot / subslot / port

 

Router(config)# controller t1 1/0

Enters controller configuration mode.

  • Use the slot and port arguments to specify the slot number and port number to be configured.

Note The slot number is always 0.

Step 4

cem-group group-number {unframed | timeslots timeslot }

 

Router(config-controller)# cem-group 6 timeslots 1-4,9,10

Creates a circuit emulation channel from one or more time slots of a T1 or E1 line.

  • The group-number keyword identifies the channel number to be used for this channel. For T1 ports, the range is 0 to 23. For E1 ports, the range is 0 to 30.
  • Use the unframed keyword to specify that a single CEM channel is being created including all time slots and the framing structure of the line.
  • Use the timeslots keyword and the timeslot argument to specify the time slots to be included in the CEM channel. The list of time slots may include commas and hyphens with no spaces between the numbers.

Step 5

end

 

 

Router(config-controller)# end

Exits controller configuration mode and returns to privileged EXEC mode.

Using CEM Classes

A CEM class allows you to create a single configuration template for multiple CEM pseudowires. Follow these steps to configure a CEM class:


Note The CEM parameters at the local and remote ends of a CEM circuit must match; otherwise, the pseudowire between the local and remote PE routers will not come up.



Note You cannot apply a CEM class to other pseudowire types such as ATM over MPLS.


DETAILED STEPS

Command
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

Router(config)# class cem mycemclass

Creates a new CEM class

Step 4

Router(config-cem-class)# payload-size 512

Router(config-cem-class)# dejitter-buffer 10

Router(config-cem-class)# idle-pattern 0x55

Enter the configuration commands common to the CEM class. This example specifies a sample rate, payload size, dejitter buffer, and idle pattern.

Step 5

Router(config-cem-class)# exit

Returns to the config prompt.

Step 6

Router(config)# interface cem 0/0

Router(config-if)# no ip address

Router(config-if)# cem 0

Router(config-if-cem)# cem class mycemclass

Router(config-if-cem)# xconnect 10.10.10.10 200 encapsulation mpls

 

Configure the CEM interface that you want to use for the new CEM class.

Note The use of the xconnect command can vary depending on the type of pseudowire you are configuring.

Step 7

Router(config-if-cem)# exit

Router(config-if)#

 

Exits the CEM interface.

Step 8

exit

 
Router(config)# exit

Router#

Exits configuration mode.

Configuring CEM Parameters

The following sections describe the parameters you can configure for CEM circuits.


Note The CEM parameters at the local and remote ends of a CEM circuit must match; otherwise, the pseudowire between the local and remote PE routers will not come up.


Configuring Payload Size (Optional)

To specify the number of bytes encapsulated into a single IP packet, use the pay-load size command. The size argument specifies the number of bytes in the payload of each packet. The range is from 32 to 1312 bytes.

Default payload sizes for an unstructured CEM channel are as follows:

  • E1 = 256 bytes
  • T1 = 192 bytes
  • DS0 = 32 bytes

Default payload sizes for a structured CEM channel depend on the number of time slots that constitute the channel. Payload size (L in bytes), number of time slots (N), and packetization delay (D in milliseconds) have the following relationship: L = 8*N*D. The default payload size is selected in such a way that the packetization delay is always 1 millisecond. For example, a structured CEM channel of 16xDS0 has a default payload size of 128 bytes.

The payload size must be an integer of the multiple of the number of time slots for structured CEM channels.

Setting the Dejitter Buffer Size

To specify the size of the dejitter buffer used to compensate for the network filter, use the dejitter-buffer size command. The configured dejitter buffer size is converted from milliseconds to packets and rounded up to the next integral number of packets. Use the size argument to specify the size of the buffer, in milliseconds. The range is from 1 to 32 ms; the default is 5 ms.

Setting an Idle Pattern (Optional)

To specify an idle pattern, use the [no] idle-pattern pattern1 command. The payload of each lost CESoPSN data packet must be replaced with the equivalent amount of the replacement data. The range for pattern is from 0x0 to 0xFF; the default idle pattern is 0xFF.

Enabling Dummy Mode

Dummy mode enables a bit pattern for filling in for lost or corrupted frames. To enable dummy mode, use the dummy-mode [ last-frame | user-defined ] command. The default is last-frame. The following is an example:

Router(config-cem)# dummy-mode last-frame

Setting a Dummy Pattern

If dummy mode is set to user-defined, you can use the dummy-pattern pattern command to configure the dummy pattern. The range for pattern is from 0x0 to 0xFF. The default dummy pattern is 0xFF. The following is an example:

Router(config-cem)# dummy-pattern 0x55

Shutting Down a CEM Channel

To shut down a CEM channel, use the shutdown command in CEM configuration mode. The shutdown command is supported only under CEM mode and not under the CEM class.

Configuring ATM

The following sections describe how to configure ATM features on the T1/E1 interface module:

Configuring a Clear-Channel ATM Interface

To configure the T1 interface module for clear-channel ATM, follow these steps:

 

Command
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 1

Router(config)# controller {t1 } slot / subslot / port

Selects the T1 controller for the port you are configuring (where slot / subslot identifies the location and / port identifies the port).

Step 2

Router(config-controller)# atm

Configures the port (interface) for clear-channel ATM. The router creates an ATM interface whose format is atm/ slot / subslot / port .

Note The slot number is always 0.

Step 3

Router(config-controller)# end

Exits configuration mode.

To access the new ATM interface, use the interface atm slot / subslot / port command.

This configuration creates an ATM interface that you can use for a clear-channel pseudowire and other features. For more information about configuring pseudowires, see Chapter12, “Configuring Pseudowire”

Configuring ATM IMA

Inverse multiplexing provides the capability to transmit and receive a single high-speed data stream over multiple slower-speed physical links. In Inverse Multiplexing over ATM (IMA), the originating stream of ATM cells is divided so that complete ATM cells are transmitted in round-robin order across the set of ATM links. Follow these steps to configure ATM IMA on the Cisco ASR 903 Series Router.


Note ATM IMA is used as an element in configuring ATM over MPLS pseudowires. For more information about configuring pseudowires, see Chapter12, “Configuring Pseudowire”



Note The maximum ATM over MPLS pseudowires supported per T1/E1 interface module is 500.


To configure the ATM interface on the router, you must install the ATM feature license using the license install atm command. To activate or enable the configuration on the IMA interface after the ATM license is installed, use the license feature atm command.

For more information about installing licenses, see the Software Activation Configuration Guide, Cisco IOS XE Release 3S.


Note You can create a maximum of 16 IMA groups on each T1/E1 interface module.


SUMMARY STEPS

1. enable

2. configure terminal

3. card type { t1 | e1 } slot [ bay ]

4. controller { t1 | e1 } slot / subslot / port

5. clock source internal

6. ima group group-number

7. exit

8. interface ATM slot / subslot /I MA group-number

9. no ip address

10. atm bandwidth dynamic

11. no atm ilmi-keepalive

12. exit

DETAILED STEPS

Command
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

card type { t1 | e1 } slot [ bay ]

 

Router(config)# card type e1 0 0

Specifies the slot and port number of the E1 or T1 interface.

Step 4

controller { t1 | e1 } slot / subslot / port
 
Router(config)# controller E1 0/0/4

Router(config-controller)#

Specifies the controller interface on which you want to enable IMA.

Step 5

clock source internal
 
Router(config-controller)# clock source internal
 

Sets the clock source to internal.

Step 6

ima group group-number
 
Router(config-controller)# ima-group 0 scrambling-payload
 

Assigns the interface to an IMA group, and set the scrambling-payload parameter to randomize the ATM cell payload frames. This command assigns the interface to IMA group 0.

Note This command automatically creates an ATM0/IMAx interface.

Step 7

 

To add another member link, repeat Step 3 to Step 6.

Step 8

exit

 
Router(config-controller)# exit
Router(config)#

 

Exits the controller interface.

Step 9

interface ATM slot / subslot / IMA group-number

 

Router(config-if)# interface atm0/1/ima0

Specify the slot location and port of IMA interface group.

  • slot —The location of the ATM IMA interface module.
  • group-number —The IMA group.

The example specifies the slot number as 0 and the group number as 0.

Note To explicitly configure the IMA group ID for the IMA interface, use the optional ima group-id command. You cannot configure the same IMA group ID on two different IMA interfaces; therefore, if you configure an IMA group ID with the system-selected default ID already configured on an IMA interface, the system toggles the IMA interface to make the user-configured IMA group ID the effective IMA group ID. The system toggles the original IMA interface to select a different IMA group ID.

Step 10

no ip address

 

Router(config-if)# no ip address

Disables the IP address configuration for the physical layer interface.

Step 11

atm bandwidth dynamic

 

Router(config-if)# atm bandwidth dynamic

Specifies the ATM bandwidth as dynamic.

Step 12

no atm ilmi-keepalive

 

Router(config-if)# no atm ilmi-keepalive

Disables the Interim Local Management Interface (ILMI) keepalive parameters.

Step 13

exit

 
Router(config)# exit

Router#

Exits configuration mode.

The above configuration has one IMA shorthaul with two member links (atm0/0 and atm0/1).

Configuring Structure-Agnostic TDM over Packet (SAToP)

Follow these steps to configure SAToP on the Cisco ASR 903 Series Router:

 

Command
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

controller [T1|E1] 0/4
 

Router(config-controller)# controller t1

Configures the T1 or E1 interface.

Step 4

cem-group group-number { unframed | timeslots timeslot }

 

Example:

Router(config-if)# cem-group 4 unframed

Assigns channels on the T1 or E1 circuit to the CEM channel. This example uses the unframed parameter to assign all the T1 timeslots to the CEM channel.

Step 5

Router(config)# interface CEM0/4
Router(config-if)# no ip address

Router(config-if)# cem 4

Defines a CEM group.

Step 6

Router(config-if)# xconnect 30.30.30.2 304 encapsulation mpls

Binds an attachment circuit to the CEM interface to create a pseudowire. This example creates a pseudowire by binding the CEM circuit 304 to the remote peer 30.30.2.304.

Step 7

exit

 
Router(config)# exit

Router#

Exits configuration mode.


Note When creating IP routes for a pseudowire configuration, we recommend that you build a route from the xconnect address (LDP router-id or loopback address) to the next hop IP address, such as ip route 30.30.30.2 255.255.255.255 1.2.3.4.


Configuring Circuit Emulation Service over Packet-Switched Network (CESoPSN)

Follow these steps to configure CESoPSN on the Cisco ASR 903 Series Router.

 

Command
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

Router(config)# controller [e1|t1] 0/0

Router(config-controller)#

Enters configuration mode for the E1 or T1 controller.

Step 4

Router(config-controller)# cem-group 5 timeslots 1-24

Assigns channels on the T1 or E1 circuit to the circuit emulation (CEM) channel. This example uses the timeslots parameter to assign specific timeslots to the CEM channel.

Step 5

Router(config-controller)# exit

Router(config)#

Exits controller configuration.

Step 6

Router(config)# interface CEM0/5
Router(config-if-cem)# cem 5
 

Defines a CEM channel.

Step 7

Router(config-if-cem)# xconnect 30.30.30.2 305 encapsulation mpls

Binds an attachment circuit to the CEM interface to create a pseudowire. This example creates a pseudowire by binding the CEM circuit 5 to the remote peer 30.30.30.2.

Note When creating IP routes for a pseudowire configuration, we recommend that you build a route from the xconnect address (LDP router-id or loopback address) to the next hop IP address, such as ip route 30.30.30.2 255.255.255.255 1.2.3.4.

Step 8

Router(config-if-cem)# exit

Router(config)#

Exits the CEM interface.

Step 9

exit

 
Router(config)# exit

Router#

Exits configuration mode.

Configuring a Clear-Channel ATM Pseudowire

To configure the T1 interface module for clear-channel ATM, follow these steps:

 

Command
Purpose

Step 1

Router(config)# controller {t1 } slot / subslot / port

Selects the T1 controller for the port you are configuring.

Note The slot number is always 0.

Step 2

Router(config-controller)# atm

Configures the port (interface) for clear-channel ATM. The router creates an ATM interface whose format is atm/ slot / subslot / port .

Note The slot number is always 0.

Step 3

Router(config-controller)# exit

Returns you to global configuration mode.

Step 4

Router(config)# interface atm slot / subslot / port

Selects the ATM interface in Step 2 .

Step 5

Router(config-if)# pvc vpi / vci

Configures a PVC for the interface and assigns the PVC a VPI and VCI. Do not specify 0 for both the VPI and VCI.

Step 6

Router(config-if)# xconnect peer-router-id vcid { encapsulation mpls | pseudowire-class name }

Configures a pseudowire to carry data from the clear-channel ATM interface over the MPLS network.

Step 7

Router(config-if)# end

Exits configuration mode.

Configuring an ATM over MPLS Pseudowire

ATM over MPLS pseudowires allow you to encapsulate and transport ATM traffic across an MPLS network. This service allows you to deliver ATM services over an existing MPLS network.

The following sections describe how to configure transportation of service using ATM over MPLS:

Configuring the Controller

Follow these steps to configure the controller.

 

Command
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

Router(config)# card type e1 0 0

Configures IMA on an E1 or T1 interface.

Step 4

Router(config)# controller E1 0/4

Router(config-controller)#

Specifies the controller interface on which you want to enable IMA.

Step 5

Router(config-controller)# clock source internal

Sets the clock source to internal.

Step 6

Router(config-controller)# ima-group 0 scrambling-payload

If you want to configure an ATM IMA backhaul, use the ima-group command to assign the interface to an IMA group. For a T1 connection, use the no-scrambling-payload to disable ATM-IMA cell payload scrambling; for an E1 connection, use the scrambling-payload parameter to enable ATM-IMA cell payload scrambling.

The example assigns the interface to IMA group 0 and enables payload scrambling.

Step 7

exit

 
Router(config)# exit

Router#

Exits configuration mode.


Note For more information about configuring IMA groups, see the “Configuring ATM IMA” section.



 

Configuring an IMA Interface

If you want to use ATM IMA backhaul, follow these steps to configure the IMA interface.


Note You can create a maximum of 16 IMA groups on each T1/E1 interface module.


 

Command
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

Router(config-controller)# interface ATMslot/IMAgroup-number

 
Router(config-controller)# interface atm0/ima0

Router(config-if)#

Specifies the slot location and port of IMA interface group. The syntax is as follows:

  • slot —The slot location of the interface module.
  • group-number —The group number of the IMA group.

The example specifies the slot number as 0 and the group number as 0.

Note To explicitly configure the IMA group ID for the IMA interface, you may use the optional ima group-id command. You cannot configure the same IMA group ID on two different IMA interfaces; therefore, if you configure an IMA group ID with the system-selected default ID already configured on an IMA interface, the system toggles the IMA interface to make the user-configured IMA group ID the effective IMA group ID. At the same, the system toggles the original IMA interface to select a different IMA group ID.

Step 4

Router(config-if)# no ip address

Disables the IP address configuration for the physical layer interface.

Step 5

Router(config-if)# atm bandwidth dynamic

Specifies the ATM bandwidth as dynamic.

Step 6

Router(config-if)# no atm ilmi-keepalive

Disables the ILMI keepalive parameters.

Step 7

exit

 
Router(config)# exit

Router#

Exits configuration mode.

For more information about configuring IMA groups, see the “Configuring ATM IMA” section.


 

Configuring the ATM over MPLS Pseudowire Interface

You can configure ATM over MPLS is several modes according to the needs of your network. Use the appropriate section according to the needs of your network. You can configure the following ATM over MPLS pseudowire types:


Note Release 15.1(1)MR does not support N-to-1 VCC Cell Transport for mapping multiple PVCs, 1-to-1 VCC Cell Mode, or PVC mapping.



Note When creating IP routes for a pseudowire configuration, build a route from the xconnect address (LDP router-id or loopback address) to the next hop IP address, such as ip route 30.30.30.2 255.255.255.255 1.2.3.4.


Configuring 1-to-1 VCC Cell Transport Pseudowire

A 1-to-1 VCC cell transport pseudowire maps one ATM virtual channel connection (VCC) to a single pseudowire. Complete these steps to configure a 1-to-1 pseudowire.


Note Multiple 1-to-1 VCC pseudowire mapping on an interface is supported.


Mapping a Single PVC to a Pseudowire

To map a single PVC to an ATM over MPLS pseudowire, use the xconnect command at the PVC level. This configuration type uses AAL0 and AAL5 encapsulations. Complete these steps to map a single PVC to an ATM over MPLS pseudowire.


Note Release 15.1(1)MR does not support mapping multiple VCCs to a pseudowire.


 

Command
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

Router(config)# interface atm0/ima0

Configures the ATM IMA interface.

Step 4

Router(config-if-atm)# pvc 0/40 l2transport

Router(config-if-atm-l2trans-pvc)#

Defines a PVC. Use the l2transport keyword to configure the PVC as a layer 2 virtual circuit.

Step 5

Router(config-if-atm-l2trans-pvc)# encapsulation aal0

Defines the encapsulation type for the PVC. The default encapsulation type for the PVC is AAL5.

Step 6

Router(config-if-atm-l2trans-pvc)# xconnect 1.1.1.1 40 encapsulation mpls

Router(config-if-atm-l2trans-pvc-xconn)#

Binds an attachment circuit to the ATM IMA interface to create a pseudowire. This example creates a pseudowire by binding PVC 40 to the remote peer 1.1.1.1.

Step 7

Router(config-if-atm-l2trans-pvp-xconn)# end

Router#

Exits configuration mode.

Configuring N-to-1 VCC Cell Transport Pseudowire

An N-to-1 VCC cell transport pseudowire maps one or more ATM virtual channel connections (VCCs) to a single pseudowire. Complete these steps to configure an N-to-1 pseudowire.

 

Command
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

Router(config)# interface atm0/ima0.X multipoint

Router(config-subif)#

Configures the ATM IMA multipoint interface.

Step 4

Router(config-subif)# xconnect 1.1.1.1
40 encapsulation mpls
Router(config-subif-xconn)#

Creates a pseudowire on an ATM IMA interface. This example creates a pseudowire to the remote peer 1.1.1.1.

Step 5

Router(config-subif-xconn)# pvc 0/40
l2transport
Router(config-if-atm-l2trans-pvc)#

Defines the first PVC 0/40 and maps it under the pseudowire created in Step 4. Use the l2transport keyword to configure the PVC as a layer 2 virtual circuit.

Step 6

Router( config -if-atm-l2trans-pvc)# pvc 0/41 l2transport

Defines the second PVC 0/41 and maps it under the pseudowire created in Step 4. Use the l2transport keyword to configure the PVC as a layer 2 virtual circuit.

Step 7

Router ( config -if-atm-l2trans-pvc)# end
Router#

Exits configuration mode.

Configuring 1-to-1 VPC Cell Transport

A 1-to-1 VPC cell transport pseudowire maps one or more virtual path connections (VPCs) to a single pseudowire. While the configuration is similar to 1-to-1 VPC cell mode, this transport method uses the 1-to-1 VPC pseudowire protocol and format defined in RFCs 4717 and 4446. Complete these steps to configure a 1-to-1 VPC pseudowire.


Note Multiple 1-to-1 VCC pseudowire mapping on an interface is supported.


 

Command
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

Router(config)# interface atm0/ima0

Router(config-if-atm)#

Configures the ATM IMA interface.

Step 4

Router(config-if-atm)# atm pvp 10 l2transport
Router(config-if-atm-l2trans-pvp)#

Maps a PVP to a pseudowire.

Step 5

Router(config-if-atm-l2trans-pvp)# xconnect 30.30.30.2 305 encapsulation mpls

Router(config-if-atm-l2trans-pvp-xconn)#

Binds an attachment circuit to the ATM IMA interface to create a pseudowire. This example creates a pseudowire by binding the ATM circuit 305 to the remote peer 30.30.30.2.

Step 6

Router(config-if-atm-l2trans-pvp-xconn)# end

Router#

Exits the configuration mode.

Configuring ATM AAL5 SDU VCC Transport

An ATM AAL5 SDU VCC transport pseudowire maps a single ATM PVC to another ATM PVC. Follow these steps to configure an ATM AAL5 SDU VCC transport pseudowire.

 

Command
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

Router(config)# interface atm 0/ima0

Router(config-if)#

Configures the ATM IMA interface.

Step 4

Router(config-if)# pvc 0/12 l2transport

Router(config-if-atm-l2trans-pvc)#

Configures a PVC and specifies a VCI or VPI.

Step 5

Router(config-if-atm-l2trans-pvc)# encapsulation aal5

Sets the PVC encapsulation type to AAL5.

Note You must use the AAL5 encapsulation for this transport type.

Step 6

Router(config-if-atm-l2trans-pvc)# xconnect 25.25.25.25 125 encapsulation mpls

Binds an attachment circuit to the ATM IMA interface to create a pseudowire. This example creates a pseudowire by binding the ATM circuit 125 to the remote peer 25.25.25.25.

Step 7

exit

 
Router(config)# exit

Router#

Exits configuration mode.

Configuring a Port Mode Pseudowire

A port mode pseudowire allows you to map an entire ATM interface to a single pseudowire connection. Follow these steps to configure a port mode pseudowire:

 

Command
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

Router(config)# interface atm 0/ima0

Configures the ATM interface.

Step 4

Router(config-if)# xconnect 25.25.25.25 2000 encapsulation mpls

Binds an attachment circuit to the ATM IMA interface to create a pseudowire. This example creates a pseudowire by binding the ATM circuit 200 to the remote peer 25.25.25.25.

Step 5

exit

 
Router(config)# exit

Router#

Exits configuration mode.

Optional Configurations

You can apply the following optional configurations to a pseudowire link.

Configuring Cell Packing

Cell packing allows you to improve the efficiency of ATM-to-MPLS conversion by packing multiple ATM cells into a single MPLS packet. Follow these steps to configure cell packing.

 

Command
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

Router(config)# int atm1/0

Configures the ATM interface.

Step 4

Router(config)# int atm1/0

Router(config-if)# atm mcpt-timers 1000 2000 3000

Defines the three Maximum Cell Packing Timeout (MCPT) timers under an ATM interface. The three independent MCPT timers specify a wait time before forwarding a packet.

Step 5

Router(config)# pvc 0/11 l2transport
Router(config-if-atm-l2trans-pvc)# encapsulation aal0

Router(config-if-atm-l2trans-pvc)# cell-packing 20 mcpt-timer 3

Specifies the maximum number of cells in PW cell pack and the cell packing timer that the Cisco ASR 903 Series Router uses. This example specifies 20 cells per pack and the third MCPT timer.

Step 6

end

 
Router(config-if-atm-l2trans-pvc)# end

Router#

Exits the configuration mode.

Configuring an Ethernet over MPLS Pseudowire

Ethernet over MPLS PWs allow you to transport Ethernet traffic over an existing MPLS network. The Cisco ASR 903 Series Router supports EoMPLS pseudowires on EVC interfaces.

For more information about Ethernet over MPLS Pseudowires, see Transportation of Service Using Ethernet over MPLS. For more information about how to configure MPLS, see the Cisco IOS XE 3S Configuration Guides . For more information about configuring Ethernet Virtual Connections (EVCs), see Configuring Ethernet Virtual Connections on the Cisco ASR 903 Router.

Follow these steps to configure an Ethernet over MPLS Pseudowire on the Cisco ASR 903 Series Router.

 

Command
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

interface interface-id

 

Router(config)# interface gigabitethernet 0/0/4

Specifies the port on which to create the pseudowire and enters interface configuration mode. Valid interfaces are physical Ethernet ports.

Step 4

service instance number ethernet [ name ]

 

Router(config-if)# service instance 2 ethernet

Configure an EFP (service instance) and enter service instance configuration) mode.

  • The number is the EFP identifier, an integer from 1 to 4000.
  • (Optional) ethernet name is the name of a previously configured EVC. You do not need to use an EVC name in a service instance.

Note You can use service instance settings such as encapsulation, dot1q, and rewrite to configure tagging properties for a specific traffic flow within a given pseudowire session. For more information, see Configuring Ethernet Virtual Connections on the Cisco ASR 903 Router.

Step 5

encapsulation { default | dot1q | priority-tagged | untagged }

 

Router (config-if-srv)# encapsulation dot1q 2

Configure encapsulation type for the service instance.

  • default —Configure to match all unmatched packets.
  • dot1q —Configure 802.1Q encapsulation.
  • priority-tagged —Specify priority-tagged frames, VLAN-ID 0 and CoS value of 0 to 7.
  • untagged —Map to untagged VLANs. Only one EFP per port can have untagged encapsulation.

Step 6

xconnect peer-ip-address vc-id { encapsulation { l2tpv3 [ manual ] | mpls [ manual ]} | pw-class pw-class-name }[ pw-class pw-class-name ] [ sequencing { transmit | receive | both }]

 

Router (config-if-srv)# xconnect 10.1.1.2 101 encapsulation mpls

Binds the Ethernet port interface to an attachment circuit to create a pseudowire. This example uses virtual circuit (VC) 101 to uniquely identify the PW. Ensure that the remote VLAN is configured with the same VC.

Note When creating IP routes for a pseudowire configuration, we recommend that you build a route from the xconnect address (LDP router-id or loopback address) to the next hop IP address, such as ip route 10.30.30.2 255.255.255.255 10.2.3.4.

Step 7

exit

 
Router(config)# exit

Router#

Exits configuration mode.

Configuring Pseudowire Redundancy

A backup peer provides a redundant pseudowire (PW) connection in the case that the primary PW loses connection; if the primary PW goes down, the Cisco ASR 903 Series Router diverts traffic to the backup PW. This feature provides the ability to recover from a failure of either the remote PE router or the link between the PE router and CE router.

Figure 12-3 shows an example of pseudowire redundancy.

Figure 12-3 Pseudowire Redundancy

 


Note You must configure the backup pseudowire to connect to a router that is different from the primary pseudowire.


Follow these steps to configure a backup peer:

 

Command
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

pseudowire-class [ pw-class-name ]

 

Router(config)# pseudowire-class mpls

Specify the name of a Layer 2 pseudowire class and enter pseudowire class configuration mode.

Step 4

encapsulation mpls

 

Router(config-pw-class)# encapsulation mpls

Specifies MPLS encapsulation.

Step 5

interface serial slot / subslot / port

 

Router(config)# interface serial0/0

Enters configuration mode for the serial interface.

Note The slot number is always 0.

Step 6

Router(config)# backup delay enable-delay { disable-delay | never }

Configures the backup delay parameters.

Where:

  • enable-delay —Time before the backup PW takes over for the primary PW.
  • disable-delay —Time before the restored primary PW takes over for the backup PW.
  • never —Disables switching from the backup PW to the primary PW.

Step 7

Router(config-if)# xconnect 1.1.1.2 101 encapsulation mpls

Binds the Ethernet port interface to an attachment circuit to create a pseudowire.

Step 8

Router(config)# backup peer peer-router-ip-address vcid [ pw-class pw-class name ]

Defines the address and VC of the backup peer.

Step 9

exit

 
Router(config)# exit

Router#

Exits configuration mode.

Verifying the Interface Configuration

You can use the following commands to verify your pseudowire configuration:

  • show cem circuit —Displays information about the circuit state, administrative state, the CEM ID of the circuit, and the interface on which it is configured. If xconnect is configured under the circuit, the command output also includes information about the attached circuit.
Router# show cem circuit ?
<0-504> CEM ID
detail Detailed information of cem ckt(s)
interface CEM Interface
summary Display summary of CEM ckts
| Output modifiers
 
 
Router# show cem circuit
CEM Int. ID Line Admin Circuit AC
--------------------------------------------------------------
CEM0/1/0 1 UP UP ACTIVE --/--
CEM0/1/0 2 UP UP ACTIVE --/--
CEM0/1/0 3 UP UP ACTIVE --/--
CEM0/1/0 4 UP UP ACTIVE --/--
CEM0/1/0 5 UP UP ACTIVE --/--
 
  • show cem circuit —D isplays the detailed information about that particular circuit.
Router# show cem circuit 1
CEM0/1/0, ID: 1, Line State: UP, Admin State: UP, Ckt State: ACTIVE
Idle Pattern: 0xFF, Idle cas: 0x8, Dummy Pattern: 0xFF
Dejitter: 5, Payload Size: 40
Framing: Framed, (DS0 channels: 1-5)
Channel speed: 56
CEM Defects Set
Excessive Pkt Loss RatePacket Loss
 
Signalling: No CAS
Ingress Pkts: 25929 Dropped: 0
Egress Pkts: 0 Dropped: 0
CEM Counter Details
Input Errors: 0 Output Errors: 0
Pkts Missing: 25927 Pkts Reordered: 0
Misorder Drops: 0 JitterBuf Underrun: 1
Error Sec: 26 Severly Errored Sec: 26
Unavailable Sec: 5 Failure Counts: 1
Pkts Malformed: 0
 
  • show cem circuit summary —Displays the number of circuits which are up or down per interface basis.
Router# show cem circuit summary
CEM Int. Total Active Inactive
--------------------------------------
CEM0/1/0 5 5 0
 
 

show running configuration —The show running configuration command shows detail on each CEM group.

Configuration Examples

The following sections contain sample pseudowire configurations.

Example: CEM Configuration

The following example shows how to add a T1 interface to a CEM group as a part of a SAToP pseudowire configuration. For more information about how to configure pseudowires, see Chapter12, “Configuring Pseudowire”


Note This section displays a partial configuration intended to demonstrate a specific feature.


 
controller T1 0/0/0
framing unframed
clock source internal
linecode b8zs
cablelength short 110
cem-group 0 unframed
 
interface CEM0/0/0
no ip address
cem 0
xconnect 18.1.1.1 1000 encapsulation mpls
 

Example: ATM IMA Configuration

The following example shows how to add a T1/E1 interface to an ATM IMA group as a part of an ATM over MPLS pseudowire configuration. For more information about how to configure pseudowires, see Chapter12, “Configuring Pseudowire”


Note This section displays a partial configuration intended to demonstrate a specific feature.


controller t1 4/0/0
ima-group 0
clock source line
 
interface atm4/0/ima0
pvc 1/33 l2transport
encapsulation aal0
xconnect 1.1.1.1 33 encapsulation mpls

Example: ATM over MPLS

The following sections contain sample ATM over MPLS configurations:

Cell Packing Configuration Examples

The following sections contain sample ATM over MPLS configuration using Cell Relay:

VC Mode

CE 1 Configuration

 
interface Gig4/3/0
no negotiation auto
load-interval 30
 
interface Gig4/3/0
ip address 20.1.1.1 255.255.255.0
interface ATM4/2/4
no shut
exit
!
interface ATM4/2/4.10 point
ip address 50.1.1.1 255.255.255.0
pvc 20/101
encapsulation aal5snap
!
ip route 30.1.1.2 255.255.255.255 50.1.1.2
 

CE 2 Configuration

 
 
interface Gig8/8
no negotiation auto
load-interval 30
 
interface Gig8/8
ip address 30.1.1.1 255.255.255.0
interface ATM6/2/1
no shut
 
!
interface ATM6/2/1.10 point
ip address 50.1.1.2 255.255.255.0
pvc 20/101
encapsulation aal5snap
 
 
!
ip route 20.1.1.2 255.255.255.255 50.1.1.1
 

PE 1 Configuration

 
interface Loopback0
ip address 192.168.37.3 255.255.255.255
 
!
interface ATM0/0/0
no shut
 
!
interface ATM0/0/0
atm mcpt-timers 150 1000 4095
 
interface ATM0/0/0.10 point
pvc 20/101 l2transport
encapsulation aal0
cell-packing 20 mcpt-timer 1
xconnect 192.168.37.2 100 encapsulation mpls
 
!
interface Gig0/3/0
no shut
ip address 40.1.1.1 255.255.0.0
mpls ip
 
!
mpls ip
mpls label protocol ldp
mpls ldp router-id Loopback0 force
mpls ldp graceful-restart
 
router ospf 1
network 40.1.0.0 0.0.255.255 area 1
network 192.168.37.0 0.0.0.255 area 1
nsf
 

PE 2 Configuration

 
interface Loopback0
ip address 192.168.37.2 255.255.255.255
!
interface ATM9/3/1
no shut
 
!
interface ATM9/3/1
atm mcpt-timers 150 1000 4095
 
interface ATM9/3/1.10 point
pvc 20/101 l2transport
encapsulation aal0
cell-packing 20 mcpt-timer 1
xconnect 192.168.37.3 100 encapsulation mpls
 
 
 
!
interface Gig6/2
no shut
ip address 40.1.1.2 255.255.0.0
mpls ip
 
!
mpls ip
mpls label protocol ldp
mpls ldp router-id Loopback0 force
mpls ldp graceful-restart
 
router ospf 1
network 40.1.0.0 0.0.255.255 area 1
network 192.168.37.0 0.0.0.255 area 1
nsf
 
 

VP Mode

CE 1 Configuration

 
 
interface Gig4/3/0
no negotiation auto
load-interval 30
 
interface Gig4/3/0
ip address 20.1.1.1 255.255.255.0
interface ATM4/2/4
 
 
!
interface ATM4/2/4.10 point
ip address 50.1.1.1 255.255.255.0
pvc 20/101
encapsulation aal5snap
!
ip route 30.1.1.2 255.255.255.255 50.1.1.2
 
 
 

CE 2 Configuration

!
interface Gig8/8
no negotiation auto
load-interval 30
 
interface Gig8/8
ip address 30.1.1.1 255.255.255.0
interface ATM6/2/1
no shut
 
!
interface ATM6/2/1.10 point
ip address 50.1.1.2 255.255.255.0
pvc 20/101
encapsulation aal5snap
 
 
!
ip route 20.1.1.2 255.255.255.255 50.1.1.1
 

PE 1 Configuration

 
interface Loopback0
ip address 192.168.37.3 255.255.255.255
 
!
interface ATM0/0/0
no shut
 
!
interface ATM0/0/0
atm mcpt-timers 150 1000 4095
 
interface ATM0/0/0.50 multipoint
atm pvp 20 l2transport
cell-packing 10 mcpt-timer 1
xconnect 192.168.37.2 100 encapsulation mpls
 
 
 
!
interface Gig0/3/0
no shut
ip address 40.1.1.1 255.255.0.0
mpls ip
 
!
mpls ip
mpls label protocol ldp
mpls ldp router-id Loopback0 force
mpls ldp graceful-restart
 
router ospf 1
network 40.1.0.0 0.0.255.255 area 1
network 192.168.37.0 0.0.0.255 area 1
nsf
 
 

PE 2 Configuration

!
interface Loopback0
ip address 192.168.37.2 255.255.255.255
 
!
interface ATM9/3/1
no shut
 
!
interface ATM9/3/1
atm mcpt-timers 150 1000 4095
 
interface ATM9/3/1.50 multipoint
atm pvp 20 l2transport
cell-packing 10 mcpt-timer 1
xconnect 192.168.37.3 100 encapsulation mpls
 
 
 
!
interface Gig6/2
no shut
ip address 40.1.1.2 255.255.0.0
mpls ip
 
!
mpls ip
mpls label protocol ldp
mpls ldp router-id Loopback0 force
mpls ldp graceful-restart
 
router ospf 1
network 40.1.0.0 0.0.255.255 area 1
network 192.168.37.0 0.0.0.255 area 1
nsf
 
 

Cell Relay Configuration Examples

The following sections contain sample ATM over MPLS configuration using Cell Relay:

VC Mode

CE 1 Configuration

!
interface gigabitethernet4/3/0
no negotiation auto
load-interval 30
 
interface gigabitethernet4/3/0
ip address 20.1.1.1 255.255.255.0
!
interface ATM4/2/4
!
interface ATM4/2/4.10 point
ip address 50.1.1.1 255.255.255.0
pvc 20/101
encapsulation aal5snap
!
ip route 30.1.1.2 255.255.255.255 50.1.1.2
!
 

CE 2 Configuration

 
interface gigabitethernet8/8
no negotiation auto
load-interval 30
 
interface gigabitethernet8/8
ip address 30.1.1.1 255.255.255.0
interface ATM6/2/1
!
interface ATM6/2/1.10 point
ip address 50.1.1.2 255.255.255.0
pvc 20/101
encapsulation aal5snap
!
ip route 20.1.1.2 255.255.255.255 50.1.1.1
 

PE 1 Configuration

!
interface Loopback0
ip address 192.168.37.3 255.255.255.255
!
interface ATM0/0/0
!
 
interface ATM0/0/0.10 point
pvc 20/101 l2transport
encapsulation aal0
xconnect 192.168.37.2 100 encapsulation mpls
!
interface gigabitethernet0/3/0
ip address 40.1.1.1 255.255.0.0
mpls ip
 
!
mpls ip
mpls label protocol ldp
mpls ldp router-id Loopback0 force
mpls ldp graceful-restart
 
router ospf 1
network 40.1.0.0 0.0.255.255 area 1
network 192.168.37.0 0.0.0.255 area 1
nsf
 

PE 2 Configuration

!
interface Loopback0
ip address 192.168.37.2 255.255.255.255
!
interface ATM9/3/1
!
interface ATM9/3/1.10 point
pvc 20/101 l2transport
encapsulation aal0
xconnect 192.168.37.3 100 encapsulation mpls
 
!
interface gigabitethernet6/2
ip address 40.1.1.2 255.255.0.0
mpls ip
!
mpls ip
mpls label protocol ldp
mpls ldp router-id Loopback0 force
mpls ldp graceful-restart
 
router ospf 1
network 40.1.0.0 0.0.255.255 area 1
network 192.168.37.0 0.0.0.255 area 1
nsf
 

VP Mode

CE 1 Configuration

!
interface gigabitethernet4/3/0
no negotiation auto
load-interval 30
 
interface gigabitethernet4/3/0
ip address 20.1.1.1 255.255.255.0
!
interface ATM4/2/4
!
interface ATM4/2/4.10 point
ip address 50.1.1.1 255.255.255.0
pvc 20/101
encapsulation aal5snap
!
ip route 30.1.1.2 255.255.255.255 50.1.1.2
 

CE 2 Configuration

!
interface gigabitethernet8/8
no negotiation auto
load-interval 30
 
interface gigabitethernet8/8
ip address 30.1.1.1 255.255.255.0
interface ATM6/2/1
!
interface ATM6/2/1.10 point
ip address 50.1.1.2 255.255.255.0
pvc 20/101
encapsulation aal5snap
!
ip route 20.1.1.2 255.255.255.255 50.1.1.1
 

PE 1 Configuration

 
interface Loopback0
ip address 192.168.37.3 255.255.255.255
!
!
interface ATM0/0/0
 
interface ATM0/0/0.50 multipoint
atm pvp 20 l2transport
xconnect 192.168.37.2 100 encapsulation mpls
!
interface gigabitethernet0/3/0
ip address 40.1.1.1 255.255.0.0
mpls ip
 
!
mpls ip
mpls label protocol ldp
mpls ldp router-id Loopback0 force
mpls ldp graceful-restart
 
router ospf 1
network 40.1.0.0 0.0.255.255 area 1
network 192.168.37.0 0.0.0.255 area 1
nsf
 

PE 2 Configuration

 
interface Loopback0
ip address 192.168.37.2 255.255.255.255
!
!
interface ATM9/3/1
 
interface ATM9/3/1.50 multipoint
atm pvp 20 l2transport
xconnect 192.168.37.3 100 encapsulation mpls
!
interface gigabitethernet6/2
ip address 40.1.1.2 255.255.0.0
mpls ip
!
mpls ip
mpls label protocol ldp
mpls ldp router-id Loopback0 force
mpls ldp graceful-restart
 
router ospf 1
network 40.1.0.0 0.0.255.255 area 1
network 192.168.37.0 0.0.0.255 area 1
nsf
 

Example: Ethernet over MPLS

PE 1 Configuration

!
mpls label range 16 12000 static 12001 16000
mpls label protocol ldp
mpls ldp neighbor 10.1.1.1 targeted ldp
mpls ldp graceful-restart
multilink bundle-name authenticated
!
!
!
!
redundancy
mode sso
!
!
!
ip tftp source-interface GigabitEthernet0
!
!
interface Loopback0
ip address 10.5.5.5 255.255.255.255
 
!
interface GigabitEthernet0/0/4
no ip address
negotiation auto
!
service instance 2 ethernet
encapsulation dot1q 2
xconnect 10.1.1.1 1001 encapsulation mpls
!
service instance 3 ethernet
encapsulation dot1q 3
xconnect 10.1.1.1 1002 encapsulation mpls
!
!
interface GigabitEthernet0/0/5
ip address 172.7.7.77 255.0.0.0
negotiation auto
mpls ip
mpls label protocol ldp
!
router ospf 1
router-id 5.5.5.5
network 5.5.5.5 0.0.0.0 area 0
network 172.0.0.0 0.255.255.255 area 0
network 10.33.33.33 0.0.0.0 area 0
network 192.0.0.0 0.255.255.255 area 0
!
 

PE 2 Configuration

!
mpls label range 16 12000 static 12001 16000
mpls label protocol ldp
mpls ldp neighbor 10.5.5.5 targeted ldp
mpls ldp graceful-restart
multilink bundle-name authenticated
!
!
redundancy
mode sso
!
!
!
ip tftp source-interface GigabitEthernet0
!
!
interface Loopback0
ip address 10.1.1.1 255.255.255.255
 
!
interface GigabitEthernet0/0/4
no ip address
negotiation auto
!
service instance 2 ethernet
encapsulation dot1q 2
xconnect 10.5.5.5 1001 encapsulation mpls
!
service instance 3 ethernet
encapsulation dot1q 3
xconnect 10.5.5.5 1002 encapsulation mpls
!
!
interface GigabitEthernet0/0/5
ip address 172.7.7.7 255.0.0.0
negotiation auto
mpls ip
mpls label protocol ldp
!
router ospf 1
router-id 10.1.1.1
network 10.1.1.1 0.0.0.0 area 0
network 172.0.0.0 0.255.255.255 area 0
network 10.33.33.33 0.0.0.0 area 0
network 192.0.0.0 0.255.255.255 area 0
!