Cisco ASR 9000 Series Aggregation Services Router MPLS Layer 3 VPN Configuration Guide
Implementing IPv6 VPN Provider Edge Transport over MPLS
Downloads: This chapterpdf (PDF - 556.0KB) The complete bookPDF (PDF - 2.32MB) | Feedback

Implementing IPv6 VPN Provider Edge Transport over MPLS

Table Of Contents

Implementing IPv6 VPN Provider Edge Transport over MPLS

Contents

Prerequisites for Implementing 6PE/VPE

Information About 6PE/VPE

Overview of 6PE/VPE

Benefits of 6PE/VPE

Deploying IPv6 over MPLS Backbones

IPv6 on the Provider Edge and Customer Edge Routers

IPv6 Provider Edge Multipath

OSPFv3 6VPE

Multiple VRF Support

OSPFv3 PE-CE Extensions

VRF Lite

How to Implement 6PE/VPE

Configuring 6PE/VPE

Configuring PE to PE Core

Configuring PE to CE Core

Configuring OSPFv3 as the Routing Protocol Between the PE and CE Routers

Configuration Examples for 6PE

Configuring 6PE on a PE Router: Example

Configuring 6VPE on a PE Router: Example

Configuring OSPFv3 between PE to CE: Example:

Additional References

Related Document

Standards

MIBs

RFCs

Technical Assistance


Implementing IPv6 VPN Provider Edge Transport over MPLS


This module describes how to implement IPv6 VPN Provider Edge Transport over MPLS on Cisco ASR 9000 Series Aggregation Services Routers.

IPv6 VPN Provider Edge (6PE/VPE) uses the existing MPLS IPv4 core infrastructure for IPv6 transport. 6PE/VPE enables IPv6 sites to communicate with each other over an MPLS IPv4 core network using MPLS label switched paths (LSPs).

This feature relies heavily on multiprotocol Border Gateway Protocol (BGP) extensions in the IPv4 network configuration on the provider edge (PE) router to exchange IPv6 reachability information (in addition to an MPLS label) for each IPv6 address prefix. Edge routers are configured as dual-stack, running both IPv4 and IPv6, and use the IPv4 mapped IPv6 address for IPv6 prefix reachability exchange.

For detailed information about the commands used to configure L2TP functionality, see the Cisco ASR 9000 Aggregation Services Router Routing Command Reference.

Feature History for Implementing 6PE on Cisco ASR 9000 Series Routers

Release
Modification

Release 3.9.1

This feature was introduced.

Release 4.0.0

Support was added for the 6PE and 6VPE features for IPv6 L3VPN on A9K-SIP-700.

Support was added for the BGP per VRF/CE label allocation for 6PE feature.

Release 4.1.0

Support for the Open Shortest Path First version 3 (OSPFv3) IPv6 VPN Provider Edge (6VPE) feature was added.


Contents

Prerequisites for Implementing 6PE/VPE

Information About 6PE/VPE

How to Implement 6PE/VPE

Configuration Examples for 6PE

Additional References

Prerequisites for Implementing 6PE/VPE

These prerequisites are required to implement 6PE:

You must be in a user group associated with a task group that includes the proper task IDs. The command reference guides include the task IDs required for each command.

If you suspect user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Familiarity with MPLS and BGP4 configuration and troubleshooting.

Information About 6PE/VPE

To configure the 6PE feature, you should understand the concepts that are described in these sections:

Overview of 6PE/VPE

Benefits of 6PE/VPE

Deploying IPv6 over MPLS Backbones

IPv6 on the Provider Edge and Customer Edge Routers

IPv6 Provider Edge Multipath

OSPFv3 6VPE

Overview of 6PE/VPE

Multiple techniques are available to integrate IPv6 services over service provider core backbones:

Dedicated IPv6 network running over various data link layers

Dual-stack IPv4-IPv6 backbone

Existing MPLS backbone leverage

These solutions are deployed on service providers' backbones when the amount of IPv6 traffic and the revenue generated are in line with the necessary investments and the agreed-upon risks. Conditions are favorable for the introduction of native IPv6 services, from the edge, in a scalable way, without any IPv6 addressing restrictions and without putting a well-controlled IPv4 backbone in jeopardy. Backbone stability is essential for service providers that have recently stabilized their IPv4 infrastructure.

Service providers running an MPLS/IPv4 infrastructure follow similar trends because several integration scenarios that offer IPv6 services on an MPLS network are possible. Cisco Systems has specially developed Cisco 6PE or IPv6 Provider Edge Router over MPLS, to meet all those requirements.

Inter-AS support for 6PE requires support of Border Gateway Protocol (BGP) to enable address families and to allocate and distribute PE and ASBR labels.

Benefits of 6PE/VPE

Service providers who currently deploy MPLS experience these benefits of Cisco 6PE:

Minimal operational cost and risk—No impact on existing IPv4 and MPLS services.

Only provider edge routers upgrade—A 6PE/VPE router can be an existing PE router or a new one dedicated to IPv6 traffic.

No impact on IPv6 customer edge routers—The ISP can connect to any customer CE running Static, IGP or EGP.

Production services ready—An ISP can delegate IPv6 prefixes.

IPv6 introduction into an existing MPLS service—6PE/VPE routers can be added at any time.

Deploying IPv6 over MPLS Backbones

Backbones enabled by 6PE (IPv6 over MPLS) allow IPv6 domains to communicate with each other over an MPLS IPv4 core network. This implementation requires no backbone infrastructure upgrades and no reconfiguration of core routers because forwarding is based on labels instead of the IP header itself. This provides a very cost-effective strategy for IPv6 deployment.

Additionally, the inherent virtual private network (VPN) and traffic engineering (TE) services available within an MPLS environment allow IPv6 networks to be combined into VPNs or extranets over an infrastructure that supports IPv4 VPNs and MPLS-TE.

IPv6 on the Provider Edge and Customer Edge Routers

Service Provider Edge Routers

6PE is particularly applicable to service providers who currently run an MPLS network. One of its advantages is that there is no need to upgrade the hardware, software, or configuration of the core network, and it eliminates the impact on the operations and the revenues generated by existing IPv4 traffic. MPLS is used by many service providers to deliver services to customers. MPLS as a multiservice infrastructure technology is able to provide layer 3 VPN, QoS, traffic engineering, fast re-routing and integration of ATM and IP switching.

Customer Edge Routers

Using tunnels on the CE routers is the simplest way to deploy IPv6 over MPLS networks. It has no impact on the operation or infrastructure of MPLS, and requires no changes to the P routers in the core or to the PE routers. However, tunnel meshing is required as the number of CEs to connect increases, and it becomes difficult to delegate a global IPv6 prefix for an ISP.

Figure 7 illustrates the network architecture using tunnels on the CE routers.

Figure 7 IPv6 Using Tunnels on the CE Routers

IPv6 Provider Edge Multipath

Internal and external BGP multipath for IPv6 allows the IPv6 router to balance load between several paths (for example, the same neighboring autonomous system (AS) or sub-AS, or the same metrics) to reach its destination. The 6PE multipath feature uses multiprotocol internal BGP (MP-IBGP) to distribute IPv6 routes over the MPLS IPv4 core network and to attach an MPLS label to each route.

When MP-IBGP multipath is enabled on the 6PE router, all labeled paths are installed in the forwarding table with available MPLS information (label stack). This functionality enables 6PE to perform load balancing.

OSPFv3 6VPE

The Open Shortest Path First version 3 (OSPFv3) IPv6 VPN Provider Edge (6VPE) feature adds VPN routing and forwarding (VRF) and provider edge-to-customer edge(PE-CE) routing support to Cisco IOS XR OSPFv3 implementation. This feature allows:

Multiple VRF support per OSPFv3 routing process

OSPFV3 PE-CE extensions

Multiple VRF Support

OSPFv3 supports multiple VRFs in a single routing process that allows scaling to tens and hundreds of VRFs without consuming too much route processor (RP) resources.

Multiple OSPFv3 processes can be configured on a single router. In large-scale VRF deployments, this allows partition VRF processing across multiple RPs. It is also used to isolate default routing table or high impact VRFs from the regular VRFs. It is recommended to use a single process for all the VRFs. If needed, a second OSPFv3 process must be configured for IPv6 routing.


Note The maximum of four OSPFv3 processes are supported.


OSPFv3 PE-CE Extensions

IPv6 protocol is being vastly deployed in today's customer networks. Service Providers (SPs) need to be able to offer Virtual Private Network (VPN) services to their customers for supporting IPv6 protocol, in addition to the already offered VPN services for IPv4 protocol.

In order to support IPv6, routing protocols require additional extensions for operating in the VPN environment. Extensions to OSPFv3 are required in order for OSPFv3 to operate at the PE-CE links.

VRF Lite

VRF lite feature enables VRF deployment without BGP or MPLS based backbone. In VRF lite, the PE routers are directly connected using VRF interfaces. For OSPFv3, the following needs to operate differently in the VRF lite scenario, as opposed to the deployment with BGP or MPLS backbone:

DN bit processing—In VRF lite environment, the DN bit processing is disabled.

ABR status—In VRF context (except default VRF), OSPFv3 router is automatically set as an ABR, regardless to it's connectivity to area 0. This automatic ABR status setting is disabled in the VRF lite environment.


Note To enable VRF Lite, issue the capability vrf-lite command in the OSPFv3 VRF configuration submode.


How to Implement 6PE/VPE

This section includes these implementation procedures:

Configuring 6PE/VPE

Configuring PE to PE Core

Configuring PE to CE Core

Configuring OSPFv3 as the Routing Protocol Between the PE and CE Routers

Configuring 6PE/VPE

This task describes how to configure 6PE/VPE on PE routers to transport the IPv6 prefixes across the IPv4 cloud.

Ensure that you configure 6PE/VPE on PE routers participating in both the IPv4 cloud and IPv6 clouds.


Note For 6PE, you can use all routing protocols supported on Cisco IOS XR software such as BGP, OSPF, IS-IS, EIGRP, RIP, and Static to learn routes from both clouds. However, for 6VPE, you can use only the BGP, EIGRP and Static routing protocols to learn routes.


SUMMARY STEPS

1. configure

2. router bgp as-number

3. neighbor ip-address

4. address-family ipv6 labeled-unicast

5. exit

6. exit

7. address-family ipv6 unicast

8. allocate-label [all | route-policy policy_name]

9. end
or
commit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

configure

Example:

RP/0/RSP0/CPU0:router# configure

Enters global configuration mode.

Step 2 

router bgp as-number

Example:

RP/0/RSP0/CPU0:router(config)# router bgp 1

Enters the number that identifies the autonomous system (AS) in which the router resides.

Range for 2-byte numbers is 1 to 65535. Range for 4-byte numbers is 1.0 to 65535.65535.

Step 3 

neighbor ip-address

Example:

RP/0/RSP0/CPU0:router(config-bgp)# neighbor 1.1.1.1

Enters neighbor configuration mode for configuring Border Gateway Protocol (BGP) routing sessions.

Step 4 

address-family ipv6 labeled-unicast

Example:

RP/0/RSP0/CPU0:router(config-bgp-nbr)# address-family ipv6 labeled-unicast

Specifies IPv6 labeled-unicast address prefixes.

Note This option is also available in IPv6 neighbor configuration mode and VRF neighbor configuration mode.

Step 5 

exit

Example:

RP/0/RSP0/CPU0:router(config-bgp-nbr-af)# exit

Exits BGP address-family submode.

Step 6 

exit

Example:

RP/0/RSP0/CPU0:router(config-bgp-nbr)# exit

Exits BGP neighbor submode.

Step 7 

address-family ipv6 unicast

Example:

RP/0/RSP0/CPU0:router(config-bgp)# address-family ipv6 unicast

Specifies IPv6 unicast address prefixes.

Step 8 

allocate-label [all | route-policy policy_name]

Example:

RP/0/RSP0/CPU0:router(config-bgp-af)# allocate-label all

Allocates MPLS labels for specified IPv4 unicast routes.

Note The route-policy keyword provides finer control to filter out certain routes from being advertised to the neighbor.

Step 9 

end

or

commit

Example:

RP/0/RSP0/CPU0:router(config-bgp-af)# end

or

RP/0/RSP0/CPU0:router(config-bgp-af)# commit

Saves configuration changes.

When you issue the end command, the system prompts you to commit changes:

Uncommitted changes found, commit them before 
exiting(yes/no/cancel)? 
[cancel]:

Entering yes saves configuration changes to the running configuration file, exits the configuration session, and returns the router to EXEC mode.

Entering no exits the configuration session and returns the router to EXEC mode without committing the configuration changes.

Entering cancel leaves the router in the current configuration session without exiting or committing the configuration changes.

Use the commit command to save the configuration changes to the running configuration file and remain within the configuration session.

Configuring PE to PE Core

This task describes how to configure a Provider Edge (PE) to PE Core.

For information on configuring VPN Routing and Forwarding (VRF), refer to the Implementing BGP on Cisco ASR 9000 Series Router module of the Cisco ASR 9000 Series Aggregation Services Router Routing Configuration Guide.

SUMMARY STEPS

1. configure

2. router bgp

3. address-family vpnv6 unicast

4. bgp dampening [ half-life [ reuse suppress max-suppress-time ] | route-policy route-policy-name ]

5. bgp client-to-client reflection { cluster-id | disable }

6. neighbor ip-address

7. remote-as as-number

8. description text

9. password { clear | encrypted } password

10. shutdown

11. timers keepalive hold-time

12. update-source type interface-id

13. address-family vpnv6 unicast

14. route-policy route-policy-name { in | out }

15. exit

16. vrf vrf-name

17. rd { as-number : nn | ip-address : nn | auto }

18. end
or
commit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

configure

Example:

RP/0/RSP0/CPU0:router# configure

Enters global configuration mode.

Step 2 

router bgp as-number

Example:

RP/0/RSP0/CPU0:router(config)# router bgp 10

Specifies the BGP AS number and enters the BGP configuration mode, allowing you to configure the BGP routing process.

Step 3 

address-family vpnv6 unicast

Example:

RP/0/RSP0/CPU0:router(config-bgp)# address-family vpnv6 unicast

Specifies the vpnv6 address family and enters address family configuration submode.

Step 4 

bgp dampening [ half-life [ reuse suppress max-suppress-time ] | route-policy route-policy-name ]

Example:

RP/0/RSP0/CPU0:router(config-bgp-af)# bgp dampening 30 1500 10000 120

Configures BGP dampening for the specified address family.

Step 5 

bgp client-to-client reflection {cluster-id | disable }

Example:

RP/0/RSP0/CPU0:router(config-bgp-af)# bgp client-to-client reflection disable

Configures client to client route reflection.

Step 6 

exit

Example:

RP/0/RSP0/CPU0:router(config-bgp-af)# exit

Exits the address family configuration submode.

Step 7 

neighbor ip-address

Example:

RP/0/RSP0/CPU0:router(config-bgp)# neighbor 10.1.1.1

Places the router in neighbor configuration mode for BGP routing and configures the neighbor IP address as a BGP peer.

Step 8 

remote-as as-number

Example:

RP/0/RSP0/CPU0:router(config-bgp-nbr)# remote-as 100

Creates a neighbor and assigns a remote autonomous system number to it.

Step 9 

description text

Example:

RP/0/RSP0/CPU0:router(config-bgp-nbr)# description neighbor 172.16.1.1

Provides a description of the neighbor. The description is used to save comments and does not affect software function.

Step 10 

password { clear | encrypted } password

Example:

RP/0/RSP0/CPU0:router(config-bgp-nbr)# password encrypted 123abc

Enables Message Digest 5 (MD5) authentication on the TCP connection between the two BGP neighbors.

Step 11 

shutdown

Example:

RP/0/RSP0/CPU0:router(config-bgp-nbr)# router bgp 1

Terminates any active sessions for the specified neighbor and removes all associated routing information.

Step 12 

timers keepalive hold-time

Example:

RP/0/RSP0/CPU0:router(config-bgp-nbr)# timers 12000 200

Set the timers for the BGP neighbor.

Step 13 

update-source type interface-id

Example:

RP/0/RSP0/CPU0:router(config-bgp-nbr)# update-source gigabitEthernet 0/1/5/0

Allows iBGP sessions to use the primary IP address from a specific interface as the local address when forming an iBGP session with a neighbor.

Step 14 

address-family vpnv6 unicast

Example:

RP/0/RSP0/CPU0:router(config-bgp-nbr)# address-family vpvn6 unicast

Enters VPN neighbor address family configuration mode.

Step 15 

route-policy route-policy-name { in | out }

Example:

RP/0/RSP0/CPU0:router(config-bgp-nbr-af)# route-policy pe-pe-vpn-in in

Specifies a routing policy for an inbound route. The policy can be used to filter routes or modify route attributes.

Step 16 

route-policy route-policy-name { in | out }

Example:

RP/0/RSP0/CPU0:router(config-bgp-nbr-af)# route-policy pe-pe-vpn-out out

Specifies a routing policy for an outbound route. The policy can be used to filter routes or modify route attributes.

Step 17 

exit

Example:

RP/0/RSP0/CPU0:router(config-bgp-nbr-af)# exit

Exits address family configuration and neighbor submode.

Step 18 

vrf vrf-name

Example:

RP/0/RSP0/CPU0:router(config-bgp)# vrf vrf-pe

Configures a VRF instance.

Step 19 

rd { as-number : nn | ip-address : nn | auto }

Example:

RP/0/RSP0/CPU0:router(config-bgp-vrf)#
rd 345:567

Configures the route distinguisher.

Use the auto keyword if you want the router to automatically assign a unique RD to the VRF.

Step 20 

end

or

commit

Example:

RP/0/RSP0/CPU0:router(config-bgp-vrf)# end

or

RP/0/RSP0/CPU0:router(config-bgp-vrf)# commit

Saves configuration changes.

When you issue the end command, the system prompts you to commit changes:

Uncommitted changes found, commit them before 
exiting(yes/no/cancel)? 
[cancel]:

Entering yes saves configuration changes to the running configuration file, exits the configuration session, and returns the router to EXEC mode.

Entering no exits the configuration session and returns the router to EXEC mode without committing the configuration changes.

Entering cancel leaves the router in the current configuration session without exiting or committing the configuration changes.

Use the commit command to save the configuration changes to the running configuration file and remain within the configuration session.

Configuring PE to CE Core

This task describes how to configure a PE to Customer Edge (CE) core.

SUMMARY STEPS

1. configure

2. router bgp

3. vrf vrf-name

4. bgp router-id ip-address

5. label-allocation-mode { per-ce | per-vrf }

6. address-family ipv6 unicast

7. redistribute {connected | static | eigrp }

8. neighbor ip-address

9. remote-as as-number

10. ebgp-multihop { maximum hops | mpls }

11. address-family ipv6 unicast

12. site-of-origin [ as-number : nn | ip-address : nn ]

13. as-override

14. allowas-in [ as-occurrence-number ]

15. end
or
commit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

configure

Example:

RP/0/RSP0/CPU0:router# configure

Enters global configuration mode.

Step 2 

router bgp as-number

Example:

RP/0/RSP0/CPU0:router(config)# router bgp 10

Specifies the BGP AS number and enters the BGP configuration mode, allowing you to configure the BGP routing process.

Step 3 

vrf vrf-name

Example:

RP/0/RSP0/CPU0:router(config-bgp)# vrf vrf-pe

Configures a VRF instance.

Step 4 

bgp router-id ip-address

Example:

RP/0/RSP0/CPU0:router(config-bgp-vrf)#bgp router-id 172.16.9.9

Configures a fixed router ID for a BGP-speaking router.

Step 5 

label-allocation-mode { per-ce | per-vrf }


Example:

RP/0/RSP0/CPU0:router(config-bgp-vrf)# label-allocation-mode per-ce

Configures the per-CE label allocation mode to avoid an extra lookup on the PE router and conserve label space (per-prefix is the default label allocation mode). In this mode, the PE router allocates one label for every immediate next-hop (in most cases, this would be a CE router). This label is directly mapped to the next hop, so there is no VRF route lookup performed during data forwarding. However, the number of labels allocated would be one for each CE rather than one for each VRF. Because BGP knows all the next hops, it assigns a label for each next hop (not for each PE-CE interface). When the outgoing interface is a multiaccess interface and the media access control (MAC) address of the neighbor is not known, Address Resolution Protocol (ARP) is triggered during packet forwarding.

The per-vrf keyword configures the same label to be used for all the routes advertised from a unique VRF.

Step 6 

address-family ipv6 unicast


Example:

RP/0/RSP0/CPU0:router(config-bgp-vrf)# address-family ipv6 unicast

Specifies an IPv6 address family unicast and enters address family configuration submode.

To see a list of all the possible keywords and arguments for this command, use the CLI help (?).

Step 7 

redistribute {connected | static | eigrp }

Example:

RP/0/RSP0/CPU0:router(config-bgp-vrf-af)#

Causes routes from the specified instance to be redistributed into BGP.

Step 8 

neighbor ip-address


Example:

RP/0/RSP0/CPU0:router(config-bgp-vrf)#
neighbor 10.0.0.0

Configures a CE neighbor. The ip-address argument must be a private address.

Step 9 

remote-as as-number


Example:

RP/0/RSP0/CPU0:router(config-bgp-vrf-nbr)# remote-as 2

Configures the remote AS for the CE neighbor.

Step 10 

ebgp-multihop { maximum hops | mpls }


Example:

RP/0/RSP0/CPU0:router(config-bgp-vrf-nbr)# ebgp-multihop 55

Configures the CE neighbor to accept and attempt BGP connections to external peers residing on networks that are not directly connected.

Step 11 

address-family ipv6 unicast


Example:

RP/0/RSP0/CPU0:router(config-bgp-vrf-nbr)# address-family ipv6 unicast

Specifies an IPv6 address family unicast and enters address family configuration submode.

To see a list of all the possible keywords and arguments for this command, use the CLI help (?).

Step 12 

site-of-origin [as-number:nn | ip-address:nn ]

Example:

RP/0/RSP0/CPU0:router(config-bgp-vrf-nbr-af)# site-of-origin 234:111

Configures the site-of-origin (SoO) extended community. Routes that are learned from this CE neighbor are tagged with the SoO extended community before being advertised to the rest of the PEs. SoO is frequently used to detect loops when as-override is configured on the PE router. If the prefix is looped back to the same site, the PE detects this and does not send the update to the CE.

Step 13 

as-override

Example:

RP/0/RSP0/CPU0:router(config-bgp-vrf-nbr-af)# as-override

Configures AS override on the PE router. This causes the PE router to replace the CE's ASN with its own (PE) ASN.

Note This loss of information could lead to routing loops; to avoid loops caused by as-override, use it in conjunction with site-of-origin.

Step 14 

allowas-in [ as-occurrence-number ]

Example:

RP/0/RSP0/CPU0:router(config-bgp-vrf-nbr-af)# allowas-in 5

Allows an AS path with the PE autonomous system number (ASN) a specified number of times.

Hub and spoke VPN networks need the looping back of routing information to the HUB PE through the HUB CE. When this happens, due to the presence of the PE ASN, the looped-back information is dropped by the HUB PE. To avoid this, use the allowas-in command to allow prefixes even if they have the PEs ASN up to the specified number of times.

Step 15 

end

or

commit

Example:

RP/0/RSP0/CPU0:router(config-bgp-vrf-nbr-af)# 
end

or

RP/0/RSP0/CPU0:router(config-bgp-vrf-nbr-af)# commit

Saves configuration changes.

When you issue the end command, the system prompts you to commit changes:

Uncommitted changes found, commit them before 
exiting(yes/no/cancel)? 
[cancel]:

Entering yes saves configuration changes to the running configuration file, exits the configuration session, and returns the router to EXEC mode.

Entering no exits the configuration session and returns the router to EXEC mode without committing the configuration changes.

Entering cancel leaves the router in the current configuration session without exiting or committing the configuration changes.

Use the commit command to save the configuration changes to the running configuration file and remain within the configuration session.

Configuring OSPFv3 as the Routing Protocol Between the PE and CE Routers

Perform this task to configure provider edge (PE)-to-customer edge (CE) routing sessions that use Open Shortest Path First version 3 (OSPFv3).

SUMMARY STEPS

1. configure

2. router ospfv3 process-name

3. vrf vrf-name

4. capability vrf-lite

5. router-id {router-id | type interface-path-id}

6. domain-id type {0005 | 0105 | 0205 | 8005} value domain-id

7. redistribute bgp process-id [metric metric-value] [metric-type {1 | 2}] [route-policy policy-name] [tag tag-value]
or
redistribute connected [metric metric-value] [metric-type {1 | 2}] [route-policy policy-name] [tag tag-value]
or
redistribute ospf process-id [match {external [1 | 2] | internal | nssa-external [1 | 2]}] [metric metric-value] [metric-type {1 | 2}] [route-policy policy-name] [tag tag-value]
or
redistribute static [metric metric-value] [metric-type {1 | 2}] [route-policy policy-name] [tag tag-value]
or
redistribute eigrp process-id [match {external [1 | 2] | internal | nssa-external [1 | 2]}] [metric metric-value] [metric-type {1 | 2}] [route-policy policy-name] [tag tag-value]
or
redistribute rip [metric metric-value] [metric-type {1 | 2}] [route-policy policy-name] [tag tag-value]

8. area area-id

9. interface type interface-path-id

10. end
or
commit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

configure

Example:

RP/0/RSP0/CPU0:router# configure

Enters global configuration mode.

Step 2 

router ospf process-name

Example:

RP/0/RSP0/CPU0:router(config)# router ospf 109

Enters OSPF configuration mode allowing you to configure the OSPF routing process.

Step 3 

vrf vrf-name

Example:

RP/0/RSP0/CPU0:router(config-ospf)# vrf vrf_1

Configures a VPN routing and forwarding (VRF) instance and enters VRF configuration mode for OSPF routing.

Step 4 

capability vrf-lite

Example:

RP/0/RSP0/CPU0:router(config-ospf-vrf)# capability vrf-lite

Enables VRF Lite feature.

Step 5 

router-id {router-id | type interface-path-id}

Example:

RP/0/RSP0/CPU0:router(config-ospf-vrf)# router-id 172.20.10.10

Configures the router ID for the VRF.

Note Router ID configuration is required for each VRF.

Step 6 

domain-id type {0005 | 0105 | 0205 | 8005} value domain-id

Example:

RP/0/RSP0/CPU0:router(config-ospf-vrf)# domain-id type 0005 value CAFE00112233

Specifies the domain ID.

Step 7 

redistribute bgp process-id [metric metric-value] [metric-type {1 | 2}] [route-policy policy-name] [tag tag-value]

or

redistribute connected [metric metric-value] [metric-type {1 | 2}] [route-policy policy-name] [tag tag-value]

or

redistribute ospf process-id [match {external [1 | 2] | internal | nssa-external [1 | 2]}] [metric metric-value] [metric-type {1 | 2}] [route-policy policy-name] [tag tag-value]

or

redistribute static [metric metric-value] [metric-type {1 | 2}] [route-policy policy-name] [tag tag-value]

or

redistribute eigrp process-id [match {external [1 | 2] | internal | nssa-external [1 | 2]]}[metric metric-value] [metric-type {1 | 2}] [route-policy policy-name] [tag tag-value]

or

redistribute rip [metric metric-value] [metric-type {1 | 2}] [route-policy policy-name] [tag tag-value]

Example:

RP/0/RSP0/CPU0:router(config-ospf-vrf)# redistribute connected

Causes routes to be redistributed into OSPF. The routes that can be redistributed into OSPF are:

Border Gateway Protocol (BGP)

Connected

Enhanced Interior Gateway Routing Protocol (EIGRP)

OSPF

Static

Routing Information Protocol (RIP)

Step 8 

area area-id

Example:

RP/0/RSP0/CPU0:router(config-ospf-vrf)# area 0

Configures the OSPF area as area 0.

Step 9 

interface type interface-path-id

Example:

RP/0/RSP0/CPU0:router(config-ospf-vrf-ar)# interface GigabitEthernet 0/3/0/0

Associates interface GigabitEthernet 0/3/0/0 with area 0.

Step 10 

end

or

commit

Example:

RP/0/RSP0/CPU0:router(config-ospf-vrf-ar-if)# end

or

RP/0/RSP0/CPU0:router(config-ospf-vrf-ar-if)# commit

Saves configuration changes.

When you issue the end command, the system prompts you to commit changes:

Uncommitted changes found, commit them before 
exiting(yes/no/cancel)? 
[cancel]:

Entering yes saves configuration changes to the running configuration file, exits the configuration session, and returns the router to EXEC mode.

Entering no exits the configuration session and returns the router to EXEC mode without committing the configuration changes.

Entering cancel leaves the router in the current configuration session without exiting or committing the configuration changes.

Use the commit command to save the configuration changes to the running configuration file and remain within the configuration session.

Configuration Examples for 6PE

This section includes these configuration example:

Configuring 6PE on a PE Router: Example

Configuring 6VPE on a PE Router: Example

Configuring 6PE on a PE Router: Example

This sample configuration shows the configuration of 6PE on a PE router:

interface GigabitEthernet0/3/0/0
 ipv6 address 2001::1/64
!
router isis ipv6-cloud
 net 49.0000.0000.0001.00
 address-family ipv6 unicast
  single-topology
 interface GigabitEthernet0/3/0/0
  address-family ipv6 unicast
  !
!
router bgp 55400
 bgp router-id 54.6.1.1
 address-family ipv4 unicast
 !
 address-family ipv6 unicast
  network 55:5::/64
  redistribute connected
  redistribute isis ipv6-cloud
   allocate-label all

 !
 neighbor 34.4.3.3
  remote-as 55400
  address-family ipv4 unicast
  !
  address-family ipv6 labeled-unicast

Configuring 6VPE on a PE Router: Example

This sample configuration shows the configuration of 6VPE on a PE router:

vrf vpn1
 address-family ipv6 unicast
  import route-target
   200:2
  !
  export route-target
   200:2

interface Loopback0
 ipv4 address 10.0.0.1 255.255.255.255

interface GigabitEthernet0/0/0/1                             
 vrf  vpn1
 ipv6 address 2001:c003:a::2/64 

router bgp 1
 bgp router-id 10.0.0.1
 bgp redistribute-internal
 bgp graceful-restart
 address-family ipv4 unicast
!

address-family vpnv6 unicast
 !
 neighbor 10.0.0.2                >>>> Remote peer loopback address.
  remote-as 1
  update-source Loopback0
  address-family ipv4 unicast
  !
  address-family vpnv6 unicast
   route-policy pass-all in 
   route-policy pass-all out
 !

  vrf vpn1
   rd 100:2
   bgp router-id 140.140.140.140
   address-family ipv6 unicast
   redistribute connected
 !

 neighbor 2001:c003:a::1
   remote-as 6502
   address-family ipv6 unicast
   route-policy pass-all in
   route-policy pass-all out 
 !

Configuring OSPFv3 between PE to CE: Example:

This example shows you how to configure provider edge (PE)-to-customer edge (CE) routing sessions that use Open Shortest Path First version 3 (OSPFv3):

router ospfv3 0
 vrf V1
  router-id 100.0.0.2
  domain-id type 0005 value CAFE00112233
  domain-id secondary type 0105 value beef00000001
  domain-id secondary type 0205 value beef00000002
  capability vrf-lite
  redistribute bgp 1
  area 0
   interface POS0/3/0/1
 vrf V2
  router-id 200.0.0.2
  capability vrf-lite
  area 1
   interface POS0/3/0/2


Additional References

For additional information related to this feature, refer to these references:

Related Document

Related Topic
Document Title

Getting started material

Cisco ASR 9000 Series Aggregation Services Router Getting Started Guide


Standards

Standards 1
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.

1 Not all supported standards are listed.


MIBs

MIBs
MIBs Link

To locate and download MIBs using Cisco IOS XR software, use the Cisco MIB Locator found at this URL and choose a platform under the Cisco Access Products menu: http://cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml


RFCs

RFCs
Title


Technical Assistance

Description
Link

The Cisco Technical Support website contains thousands of pages of searchable technical content, including links to products, technologies, solutions, technical tips, and tools. Registered Cisco.com users can log in from this page to access even more content.

http://www.cisco.com/techsupport