Cisco ASR 9000 Series Aggregation Services Router Interface and Hardware Component Configuration Guide
Configuring Channelized SONET on the Cisco ASR 9000 Series Router
Downloads: This chapterpdf (PDF - 299.0KB) The complete bookPDF (PDF - 8.86MB) | Feedback

Configuring Channelized SONET on the Cisco ASR 9000 Series Router

Table Of Contents

Configuring Channelized SONET on the Cisco ASR 9000 Series Router

Contents

Prerequisites for Configuring Channelized SONET

Information About Configuring Channelized SONET

Channelized SONET Overview

Default Configuration Values for Channelized SONET

How to Configure Channelized SONET

Configuring SONET T3 and VT1.5-Mapped T1 Channels

Prerequisites

Configuring Clear Channel T3

Prerequisites

Configuring Channelized SONET APS

Prerequisites

Configuration Examples for Channelized SONET

Channelized SONET T3 to T1 Configuration: Example

Clear Channel T3 Configuration: Example

Channelized SONET APS Multirouter Configuration: Example

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance


Configuring Channelized SONET on the Cisco ASR 9000 Series Router


This module describes the configuration of Channelized SONET on the Cisco ASR 9000 Series Aggregation Services Routers.

Feature History for Configuring Channelized SONET on Cisco IOS XR Software

Release
Modification

Release 3.9.0

Support for the following shared port adapter (SPA) was introduced on the Cisco ASR 9000 Series Router:

Cisco 2-Port Channelized OC-12/DS0 SPA


Contents

Prerequisites for Configuring Channelized SONET

Information About Configuring Channelized SONET

How to Configure Channelized SONET

Configuration Examples for Channelized SONET

Prerequisites for Configuring Channelized SONET

You must be in a user group associated with a task group that includes the proper task IDs. The command reference guides include the task IDs required for each command. If you suspect user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Before configuring Channelized SONET, be sure that the following tasks and conditions are met:

You have at least one of the following SPAs installed in your chassis:

Cisco 2-Port Channelized OC-12/DS0 SPA

You should know how to apply and specify the SONET controller name and interface-path-id with the generalized notation rack/slot/module/port. The SONET controller name and interface-path-id are required with the controller sonet command.

Information About Configuring Channelized SONET

To configure Channelized SONET, you must understand the following concepts:

Channelized SONET Overview

Default Configuration Values for Channelized SONET

Channelized SONET Overview

Synchronous Optical Network (SONET) is an American National Standards Institute (ANSI) specification format used in transporting digital telecommunications services over optical fiber.

Synchronous Digital Hierarchy (SDH) is the international equivalent of SONET. SDH is not currently supported on the Cisco ASR 9000 Series Router.

Channelized SONET provides the ability to transport SONET frames across multiplexed T3 and virtual tributary group (VTG) channels.

Channelized SONET is supported on the following SPA:

Cisco 2-Port Channelized OC-12/DS0 SPA

SONET uses Synchronous Transport Signal (STS) framing. An STS is the electrical equivalent to an optical carrier 1 (OC1).

A channelized SONET interface is a composite of STS streams, which are maintained as independent frames with unique payload pointers. The frames are multiplexed before transmission.

When a line is channelized, it is logically divided into smaller bandwidth channels called paths. These paths carry the SONET payload. The sum of the bandwidth on all paths cannot exceed the line bandwidth.

When a line is not channelized, it is called clear channel, and the full bandwidth of the line is dedicated to a single channel that carries broadband services.

An STS stream can be channelized into the following types of channels:

T3

VT1.5 mapped T1

The T3 channels can be channelized further into T1s, and the T1s can be channelized into time slots (DS0s).


Note In Cisco IOS XR Release 3.9.0, the 2-Port Channelized OC-12/DS0 SPA on the Cisco ASR 9000 Series Router only supports configuration of the full 24 timeslots on the T1 channel.


Channelizing a SONET line consists of two primary processes:

Configuring the controller

Configuring the interface into channelized paths

You configure the controller first by setting the mode of the STS path. The mode can be set to T3, or VT1.5-mapped T1.

When the mode is specified, the respective controller is created, and the remainder of the configuration is applied on that controller. For example, mode T3 creates a T3 controller. The T3 controller can then be configured to a serial channel, or it can be further channelized to carry T1s, and those T1s can be configured to serial interfaces.

Each STS path can be independently configured into T3s or VTGs, and so on.

Figure 13 shows an example of three STS paths for a SONET controller. However, the 2-Port Channelized OC-12/DS0 SPA supports up to 12 STS paths.

Figure 13 SONET Controller STS Paths

Figure 14 shows an example of some SONET controller configuration combinations.

Figure 14 SONET Controller Configuration Combinations

Figure 15 shows the T3 paths that can be configured.

Figure 15 SONET T3 Channelized Paths

Figure 16 shows the VTG paths that can be configured.

Figure 16 SONET VTG Channelized Paths

Default Configuration Values for Channelized SONET

Table 3 describes the default configuration parameters that are present on the Channelized SONET.

Table 3 SONET/SDH Controller Default Configuration Values

Parameter
Default Value
Configuration File Entry

Clock source

line

clock source {internal | line}

SONET framing

sonet

framing sonet


How to Configure Channelized SONET

This section contains the following procedures:

Configuring SONET T3 and VT1.5-Mapped T1 Channels

Configuring Clear Channel T3

Configuring Channelized SONET APS

Configuring SONET T3 and VT1.5-Mapped T1 Channels

This task explains how to configure a SONET line into T3 and VT-mapped T1 Channels.

Prerequisites

You should know how to configure the SONET controller as specified in the "How to Configure Clear Channel SONET Controllers" section of the Configuring Clear Channel SONET Controllers on the Cisco ASR 9000 Series Router module.

STS paths can be channelized into T3s on the following SPA:

Cisco 2-Port Channelized OC-12/DS0 SPA

STS paths can be channelized into VTG mapped T1s on the following SPA:

Cisco 2-Port Channelized OC-12/DS0 SPA

T3 paths can be channelized into T1s or E1s on the followingSPA:

Cisco 2-Port Channelized OC-12/DS0 SPA

SUMMARY STEPS

1. configure

2. controller sonet interface-path-id

3. clock source {internal | line}

4. framing sonet

5. sts number

6. mode mode

7. root

8. controller controllerName instance

9. mode mode

10. root

11. controller t1 interface-path-id

12. channel-group number

13. timeslots num1:num2:num3:num4
or
timeslots range1-range2

14. show configuration

15. root

16. interface serial interface-path-id

17. encapsulation {hdlc | ppp}

18. ipv4 ip-address mask

19. no shutdown

20. end
or
commit

21. show

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

configure

Example:

RP/0/RSP0/CPU0:router# configure

Enters global configuration mode.

Step 2 

controller sonet interface-path-id

Example:

RP/0/RSP0/CPU0:router(config)# controller sonet 0/1/1/0

Enters SONET controller configuration submode and specifies the SONET controller name and interface-path-id with the rack/slot/module/port notation.

Step 3 

clock source {internal | line}

Example:

RP/0/RSP0/CPU0:router(config-sonet)# clock source internal

Configures the SONET port transmit clock source, where the internal keyword sets the internal clock and the line keyword sets the clock recovered from the line.

Use the line keyword whenever clocking is derived from the network. Use the internal keyword when two routers are connected back to back or over fiber for which no clocking is available.

line is the default keyword.

Note Internal clocking is required for SRP interfaces.

Step 4 

framing sonet

Example:

RP/0/RSP0/CPU0:router(config-sonet)# framing sonet

(Optional) Configures the controller framing with the sonet keyword for SONET framing.

SONET framing (sonet) is the default.

Step 5 

sts number

Example:

RP/0/RSP0/CPU0:router(config-sonet)# sts 1

Configures the STS stream specified by number. The ranges are:

1 to 12—2-Port Channelized OC-12/DS0 SPA

Step 6 

mode mode

Example:

RP/0/RSP0/CPU0:router(config-stsPath)# mode t3

Sets the mode of interface at the STS level. The possible modes are:

t3—SONET path carrying T3

vt15-t1—SONET path carrying virtual tributary 1.5 T1s (VT15 T1)

 

RP/0/RSP0/CPU0:router(config-stsPath)# width 3

Configures the number of the STS streams that are concatenated.
The possible values for number are:

1—Indicating one STS stream

3—Indicating three STS streams (STS-3c)

12—Indicating concatenation of 12 STS streams (STS-12c)

48—Indicating concatenation of 48 STS streams (STS-48c)

Widths 3, and 12, and 48 are configured on STS paths at natural boundaries, which coincide with the following path numbers:

1, 4, 7, 10, and so on, for STS-3c

1, 13, 25, and 37 for STS-12c

1 for STS-48c

Step 7 

root
Example:

RP/0/RSP0/CPU0:router(config-stsPath)# root

Exits to global configuration mode.

Step 8 

controller controllerName instance

Example:

RP/0/RSP0/CPU0:router(config)# controller t3 0/1/1/0/0

Enters controller configuration submode and specifies the controller name and instance identifier with the rack/slot/module/port/controllerName notation. The controller names are:

t3—SONET path carrying T3

vt15-t1—SONET path carrying virtual tributary 1.5 T1s (VT15 T1)

Step 9 

mode mode

Example:

RP/0/RSP0/CPU0:router(config-t3)# mode t1

Sets the mode of interface at this level. The possible modes are:

t1—Channelized into 28 T1s

serial—Clear channel carrying an HDLC-like payload

Step 10 

root
Example:

RP/0/RSP0/CPU0:router(config-t3)# root

Exits to global configuration mode.

Step 11 

controller t1 interface-path-id

Example:

RP/0/RSP0/CPU0:router(config)# controller t1 0/1/1/0/0/0

Enters T1 controller configuration submode and specifies the T1 controller name and interface-path-id with the rack/slot/module/port/T3Num/T1num notation.

Step 12 

channel-group number

Example:

RP/0/RSP0/CPU0:router(config-t1)# channel-group 1

Sets the channel group number to which time slots are assigned. The range is from 1 to 24.

Step 13 

timeslots range1-range2

Example:

RP/0/RSP0/CPU0:router(config-t1-channel_g roup)# timeslots 1-24

Specifies the range of timeslots with the range1-range2 notation.

Note The 2-Port Channelized OC-12/DS0 SPA only supports configuration of the full 24 timeslots.

Step 14 

show configuration

Example:

RP/0/RSP0/CPU0:router(config-t1-channel_g roup)# show configuration

Displays the contents of uncommitted configuration.

Step 15 

root
Example:

RP/0/RSP0/CPU0:router(config-t3)# root

Exits to global configuration mode.

Step 16 

interface serial interface-path-id

Example:

RP/0/RSP0/CPU0:router(config)# interface serial 0/1/1/0/0/0:0

Specifies the complete interface number with the rack/slot/module/port/T3Num/T1num:instance notation.

Step 17 

encapsulation {hdlc | ppp}

Example:

RP/0/RSP0/CPU0:router(config-if)# encapsulation ppp

Specifies the encapsulation type with the one of the following keywords:

hdlc—High-level Data Link Control (HDLC) synchronous protocol

ppp—Point-to-Point Protocol

Step 18 

ipv4 ip-address mask

Example:

RP/0/RSP0/CPU0:router(config-if)# ip address 10.10.10.10 255.255.255.255

Assigns an IP address and subnet mask to the interface.

Step 19 

no shutdown

Example:

RP/0/RSP0/CPU0:router(config-if)# no shutdown

Removes the shutdown configuration.

Note Removal of the shutdown configuration eliminates the forced administrative down on the interface, enabling it to move to an up or down state (assuming that the parent SONET layer is not configured administratively down).

Step 20 

end

or

commit

Example:

RP/0/0RSP0/CPU0:router(config-sonet)# end

or

RP/0/RSP0/CPU0:router(config-sonet)# commit

Saves configuration changes.

When you issue the end command, the system prompts you to commit changes:

Uncommitted changes found, commit them before 
exiting(yes/no/cancel)? 
[cancel]:
 
        

Entering yes saves configuration changes to the running configuration file, exits the configuration session, and returns the router to EXEC mode.

Entering no exits the configuration session and returns the router to EXEC mode without committing the configuration changes.

Entering cancel leaves the router in the current configuration session without exiting or committing the configuration changes.

Use the commit command to save the configuration changes to the running configuration file and remain within the configuration session.

Step 21 

show controllers sonet interface-path-id

Example:

RP/0/RSP0/CPU0:router# show controllers sonet 0/1/1/0

Verifies the SONET controller configuration.

Configuring Clear Channel T3

This task explains how to configure a SONET line into a single T3 serial channel called clear channel. Clear channel is established by setting the T3 controller mode to serial.

Prerequisites

You should know how to configure the SONET controller as specified in the "How to Configure Clear Channel SONET Controllers" section of the Configuring Clear Channel SONET Controllers on the Cisco ASR 9000 Series Router module.

SUMMARY STEPS

1. configure

2. controller sonet interface-path-id

3. clock source {internal | line}

4. framing sonet

5. sts number

6. mode t3

7. root

8. controller t3 interface-path-id

9. mode serial

10. root

11. interface serial interface-path-id

12. encapsulation hdlc | ppp}

13. ipv4 ip-address mask

14. no shutdown

15. end
or
commit

16. show controllers sonet interface-path-id

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

configure

Example:

RP/0/RSP0/CPU0:router# configure

Enters global configuration mode.

Step 2 

controller sonet interface-path-id

Example:

RP/0/RSP0/CPU0:router(config)# controller sonet 0/1/1/0

Enters SONET controller configuration submode and specifies the SONET controller name and interface-path-id with the rack/slot/module/port notation.

Step 3 

clock source {internal | line}

Example:

RP/0/RSP0/CPU0:router(config-sonet)# clock source internal

Configures the SONET port transmit clock source, where the internal keyword sets the internal clock and the line keyword sets the clock recovered from the line.

Use the line keyword whenever clocking is derived from the network. Use the internal keyword when two routers are connected back to back or over fiber for which no clocking is available.

line is the default keyword.

Note Internal clocking is required for SRP interfaces.

Step 4 

framing sonet

Example:

RP/0/RSP0/CPU0:router(config-sonet)# framing sonet

(Optional) Configures the controller framing with either the sdh keyword for Synchronous Digital Hierarchy (SDH) framing or the sonet keyword for SONET framing.

SONET framing (sonet) is the default.

Step 5 

sts number

Example:

RP/0/RSP0/CPU0:router(config-sonet)# sts 1

Configures the STS stream specified by number. The ranges are:

1 to 12—2-Port Channelized OC-12/DS0 SPA

Step 6 

mode t3

Example:

RP/0/RSP0/CPU0:router(config-stsPath)# mode t3

Sets the mode of the interface at the STS level for T3.

Step 7 

root
Example:

RP/0/RSP0/CPU0:router(config-stsPath)# root

Exits to global configuration mode.

Step 8 

controller t3 interface-path-id

Example:

RP/0/RSP0/CPU0:router(config)# controller t3 0/1/1/0/0

Enters T3 controller configuration submode and specifies the T3 controller name and interface-path-id identifier with the rack/slot/module/port/T3Num notation.

Step 9 

mode serial

Example:

RP/0/RSP0/CPU0:router(config-t3)# mode serial

Sets the mode of the interface to serial to establish a clear channel.

Step 10 

root
Example:

RP/0/RSP0/CPU0:router(config-t3)# root

Exits to global configuration mode.

Step 11 

interface serial interface-path-id

Example:

RP/0/RSP0/CPU0:router(config)# interface serial 0/1/1/0/0/0:0

Specifies the complete interface number with the rack/slot/module/port/T3Num/T1num:instance notation.

Step 12 

encapsulation {hdlc | ppp}

Example:

RP/0/RSP0/CPU0:router(config-if)# encapsulation ppp

Specifies the encapsulation type with the one of the following keywords:

hdlc—High-level Data Link Control (HDLC) synchronous protocol

ppp—Point-to-Point Protocol

Step 13 

ipv4 ip-address mask

Example:

RP/0/RSP0/CPU0:router(config-if)# ip address 10.10.10.10 255.255.255.255

Assigns an IP address and subnet mask to the interface.

Step 14 

no shutdown

Example:

RP/0/RSP0/CPU0:router(config-if)# no shutdown

Removes the shutdown configuration.

Note Removal of the shutdown configuration eliminates the forced administrative down on the interface, enabling it to move to an up or down state (assuming that the parent SONET layer is not configured administratively down).

Step 15 

end

or

commit

Example:

RP/0/RSP0/CPU0:router(config-sonet)# end

or

RP/0/RSP0/CPU0:router(config-sonet)# commit

Saves configuration changes.

When you issue the end command, the system prompts you to commit changes:

Uncommitted changes found, commit them before 
exiting(yes/no/cancel)? 
[cancel]:
 
        

Entering yes saves configuration changes to the running configuration file, exits the configuration session, and returns the router to EXEC mode.

Entering no exits the configuration session and returns the router to EXEC mode without committing the configuration changes.

Entering cancel leaves the router in the current configuration session without exiting or committing the configuration changes.

Use the commit command to save the configuration changes to the running configuration file and remain within the configuration session.

Step 16 

show controllers sonet interface-path-id

Example:

RP/0//RSP0/CPU0:router# show controllers sonet 0/1/1/0

Verifies the SONET controller configuration.

Configuring Channelized SONET APS

This task explains how to configure APS for channelized SONET lines. The Cisco ASR 9000 Series Router supports multirouter APS only on the 2-Port Channelized OC-12/DS0 SPA.

Prerequisites

You should know how to configure the SONET controller as specified in the "How to Configure Clear Channel SONET Controllers" section of the Configuring Clear Channel SONET Controllers on the Cisco ASR 9000 Series Router module.

You should know how to configure the SONET APS as specified in the "Configuring SONET APS" section of the Configuring Clear Channel SONET Controllers on the Cisco ASR 9000 Series Router module.

SUMMARY STEPS

1. aps group number

2. channel 0 local sonet interface
or
channel 0 remote ip-address

3. channel 1 local sonet interface
or
channel 1 remote ip-address

4. signalling sonet

5. end
or
commit

6. show aps

7. show aps group [number]

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

aps group number

Example:

RP/0/RSP0/CPU0:router(config)# aps group 1

Adds an APS group with a specified number and enters APS group configuration mode.

Use the aps group command in global configuration mode.

To remove a group, use the no form of this command, as in: no aps group number, where the value range is from 1 to 255.

Note To use the aps group command, you must be a member of a user group associated with the proper task IDs for APS commands.

Note The aps group command is used even when a single protect group is configured.

Step 2 

channel 0 local sonet interface

or

channel 0 remote ip-address

Example:

RP/0/RSP0/CPU0:router(config-aps)# channel 0 local SONET 0/0/0/1

or

RP/0/RSP0/CPU0:router(config-aps)# channel 0 remote 172.18.69.123

Creates a protect channel for the APS group, where 0 designates a protect channel.

Note The protect channel must be assigned before the active channel can be assigned.

Note To configure APS using two different routers where the active channel is on one router and the protect channel is on another router, use the channel local command for either the protect or the active channel, but use the channel remote command for the other channel.

Step 3 

channel 1 local sonet interface

or

channel 1 remote ip-address

Example:

RP/0/RSP0/CPU0:router(config-aps)# channel 1 local SONET 0/0/0/2

or

RP/0/0/CPU0:router(config-aps)# channel 1 remote 172.18.69.123

Creates an active channel for the APS group, where 1 designates an active channel.

Note The active channel must be assigned after the protect channel is assigned.

Note To configure APS using two different routers where the active channel is on one router and the protect channel is on another router, use the channel local command for either the protect or the active channel, but use the channel remote command for the other channel.

Step 4 

signalling sonet

Example:
RP/0/RSP0/CPU0:router(config-aps)# 
signalling sonet

Configures the K1K2 overhead byte used for automatic protection switching (APS) for the SONET signaling protocol .

Step 5 

end

or

commit

Example:

RP/0/RSP0/CPU0:router(config-sonet)# end

or

RP/0/RSP0/CPU0:router(config-sonet)# commit

Saves configuration changes.

When you issue the end command, the system prompts you to commit changes:

Uncommitted changes found, commit them before 
exiting(yes/no/cancel)? 
[cancel]:
 
        

Entering yes saves configuration changes to the running configuration file, exits the configuration session, and returns the router to EXEC mode.

Entering no exits the configuration session and returns the router to EXEC mode without committing the configuration changes.

Entering cancel leaves the router in the current configuration session without exiting or committing the configuration changes.

Use the commit command to save the configuration changes to the running configuration file and remain within the configuration session.

Step 6 

show aps

Example:

RP/0/RSP0/CPU0:router# show aps

(Optional) Displays the operational status for all configured SONET APS groups.

Step 7 

show aps group [number]

Example:

RP/0/RSP0/CPU0:router# show aps group 3

(Optional) Displays the operational status for configured SONET APS groups.

Note The show aps group command is more useful than the show aps command when multiple groups are defined.

Configuration Examples for Channelized SONET

This section contains the following examples:

Channelized SONET T3 to T1 Configuration: Example

Clear Channel T3 Configuration: Example

Channelized SONET APS Multirouter Configuration: Example

Channelized SONET T3 to T1 Configuration: Example

The following example shows SONET T3 to T1 configuration.

configure
 controller sonet 0/1/1/0
  clock source internal
  framing sonet
  sts 1
  mode t3
  width 3
  root
 controller t3 0/1/1/0/0
  mode t1
  root
 controller t1 0/1/1/0/0/0
  framing esf
  channel-group 0
   timeslots 1-24
   show configuration
  root
 interface serial 0/1/1/0/0/0:0
 encapsulation hdlc
 ip address 10.10.10.10 255.255.255.255
 no shutdown
  commit
show controllers sonet 0/1/1/0

Clear Channel T3 Configuration: Example

The following example shows SONET Clear Channel configuration.

configure
 controller sonet 0/1/1/0
  clock source internal
  framing sonet
  sts 1
  mode t3
  root
 controller t3 0/1/1/0/0
  mode serial
  root
 interface serial 0/1/1/0/0/0:0
 encapsulation ppp
 ip address 10.10.10.10 255.255.255.255
 no shutdown
  commit
show controllers sonet 0/1/1/0

Channelized SONET APS Multirouter Configuration: Example

The following example shows SONET APS multirouter configuration.

aps group 1

channel 0 local SONET 0/0/0/1

channel 1 remote 172.18.69.123

  signalling sonet

commit

show aps

show aps group 3

Additional References

The following sections provide references related to channelized SONET configuration.

Related Documents

Related Topic
Document Title

Cisco IOS XR master command reference

Cisco IOS XR Master Commands List

Cisco IOS XR interface configuration commands

Cisco IOS XR Interface and Hardware Component Command Reference

Initial system bootup and configuration information for a router using the Cisco IOS XR software

Cisco IOS XR Getting Started Guide

Information about user groups and task IDs

Configuring AAA Services on Cisco IOS XR Software module of Cisco IOS XR System Security Configuration Guide

Information about configuring router interfaces and other components from a remote Craft Works Interface (CWI) client management application

Cisco Craft Works Interface Configuration Guide


Standards

Standards
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.


MIBs

MIBs
MIBs Link

There are no applicable MIBs for this module.

To locate and download MIBs for selected platforms using
Cisco IOS XR software, use the Cisco MIB Locator found at the following URL:

http://cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml


RFCs

RFCs
Title

No new or modified RFCs are supported by this feature, and support for existing RFCs has not been modified by this feature.


Technical Assistance

Description
Link

The Cisco Technical Support website contains thousands of pages of searchable technical content, including links to products, technologies, solutions, technical tips, and tools. Registered Cisco.com users can log in from this page to access even more content.

http://www.cisco.com/techsupport