Intelligent Wireless Access Gateway Configuration Guide
IP Sessions Over Gigabit EtherChannel
Downloads: This chapterpdf (PDF - 1.25MB) The complete bookPDF (PDF - 6.18MB) | The complete bookePub (ePub - 1.55MB) | Feedback

IP Sessions Over Gigabit EtherChannel

IP Sessions Over Gigabit EtherChannel

The IP Sessions Over Gigabit EtherChannel (IPoGEC) feature enables you to add the Link Aggregation Control Protocol (LACP) functionality for IP sessions. The LACP defines a virtual interface for a port channel or a port bundle, and adds physical member links to the port channel. This section provides information about the IPoGEC and how to configure it.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Restrictions for IPoGEC

IP Sessions over Gigabit EtherChannel (IPoGEC) currently supports the 1:1 model, where only one member link is active while the second member link is passive and does not carry traffic.

Information About IP Sessions over Gigabit EtherChannel

The IP sessions over Gigabit EtherChannel (IPoGEC) feature ensures consistency between systems by adding redundancy and allows dynamic link management during local and remote system failures. LACP fast switchover enables the standby member link to take over instantly (in milliseconds) when the active member link goes down. As a result, the port channel remains up. The carrier-delay {delay-seconds | msec milliseconds} command used in the configuration of the IPoGEC ensures fast switchover, with the delay in switchover being in milliseconds rather than seconds.

Supported Features for IPoGEC

  • IPoGEC supports both simple IP sessions and mobile IP sessions.
  • IPoGEC is supported over virtual local area network (VLAN) and subinterfaces.
  • IPoGEC is supported on all Ethernet SPAs, including 10-Gigabit Ethernet ports and 1-Gigabit Ethernet ports.

Configuring IP Sessions over Gigabit EtherChannel

SUMMARY STEPS

    1.    configure terminal

    2.    interface port-channel channel-number

    3.    description string

    4.    ip address ip-address mask [secondary [vrf vrf-name] ]

    5.    load-interval seconds

    6.    lacp fast-switchover

    7.    lacp max-bundle max-bundle-number

    8.    service-policy type control policy-map-name

    9.    ip subscriber {l2-connected}

    10.    initiator {dhcp | radius-proxy | static ip subscriber list listname | unclassified ip | unclassified mac-address}

    11.    initiator {dhcp | radius-proxy | static ip subscriber list listname | unclassified ip | unclassified mac-address}


DETAILED STEPS
     Command or ActionPurpose
    Step 1configure terminal


    Example:
    Router# configure terminal
     

    Enters the global configuration mode.

     
    Step 2 interface port-channel channel-number


    Example:
    Router(config)#interface port-channel 1
     

    Creates a port-channel virtual interface.

     
    Step 3description string


    Example:
    Router(config-if)#description GEC:1 interface towards switch
     
    Adds a description to an interface configuration.  
    Step 4ip address ip-address mask [secondary [vrf vrf-name] ]


    Example:
    Router(config-if)#ip address 21.0.0.1 255.255.0.0
     
    Removes an IP address from an interface.  
    Step 5load-interval seconds


    Example:
    Router(config-if)#load-interval 30
     
    Changes the length of time for which data is used to compute load statistics.  
    Step 6lacp fast-switchover


    Example:
    Router(config-if)#lacp fast-switchover
     
    Enables the LACP 1:1 link redundancy.  
    Step 7lacp max-bundle max-bundle-number


    Example:
    Router(config-if)#lacp max-bundle 1
     
    Defines the maximum number of active, bundled LACP ports allowed in a port channel.  
    Step 8service-policy type control policy-map-name


    Example:
    Router(config-if)#service-policy type control BB_PMAP
     
    Applies a control policy to a context.  
    Step 9ip subscriber {l2-connected}


    Example:
    Router(config-if)#ip subscriber l2-connected
     

    Enables Cisco Intelligent Services Gateway (ISG) IP subscriber support on an interface, and specifies the access method that IP subscribers use for connecting to the Cisco ISG on an interface.

    Note   

    The iWAG does not support the routed access method.

     
    Step 10initiator {dhcp | radius-proxy | static ip subscriber list listname | unclassified ip | unclassified mac-address}


    Example:
    Router(config-subscriber)# initiator unclassified mac-address
     

    Enables the Cisco ISG to create an IP subscriber session upon receipt of a specified type of packet.

     
    Step 11initiator {dhcp | radius-proxy | static ip subscriber list listname | unclassified ip | unclassified mac-address}


    Example:
    Router(config-subscriber)# initiator dhcp
     

    Enables the Cisco ISG to create an IP subscriber session upon receipt of a specified type of packet.

     

    Configuring Member Links for IP Sessions over Gigabit EtherChannel

    SUMMARY STEPS

      1.    interface GigabitEthernet slot/subslot/port

      2.    no ip address ip-address mask [secondary [vrf vrf-name] ]

      3.    carrier-delay {delay-seconds | msec milliseconds}

      4.    lacp port-priority priority

      5.    channel-group channel-group-number mode {active | passive}


    DETAILED STEPS
       Command or ActionPurpose
      Step 1 interface GigabitEthernet slot/subslot/port


      Example:
      Router(config)#interface GigabitEthernet0/0/1
       

      Enters the interface configuration mode for Gigabit Ethernet interface.

       
      Step 2no ip address ip-address mask [secondary [vrf vrf-name] ]


      Example:
      Router(config-if)#no ip address
       
      Removes an IP address from an interface.  
      Step 3 carrier-delay {delay-seconds | msec milliseconds}


      Example:
      Router(config-if)# carrier-delay msec 50
       

      Sets the carrier delay on a serial interface. To achieve faster switchover from active to standby member link, the carrier delay value can be set to 0 ms.

       
      Step 4 lacp port-priority priority


      Example:
      Router(config-if)#lacp port-priority 4000
       

      Sets the LACP priority for a physical interface. IPoGEC currently supports 1:1 model, that is one active member link and one standby member link, which only requires choosing two different values for priority field to make sure one interface is active while the other is standby. The value set for the priority field shall match the value configured on the switch.

       
      Step 5 channel-group channel-group-number mode {active | passive}


      Example:
      Router(config-if)#channel-group 1 mode active
       

      Configures the interface in a channel group and sets the LACP mode.

       

      Configuration Examples for IP Sessions Over Gigabit EtherChannel

      Example: Configuring IPoGEC

      interface Port-channel1
      description GEC:1 interface towards switch
      ip address 21.0.0.1 255.255.0.0
      load-interval 30
      lacp fast-switchover
      lacp max-bundle 1
      service-policy type control BB_PMAP
      ip subscriber l2-connected
        initiator unclassified mac-address ipv4
        initiator dhcp
      

      Example: Configuring Member Links for IPoGEC

      interface GigabitEthernet0/0/1
      no ip address
      carrier-delay msec 50
      lacp port-priority 4000
      channel-group 1 mode active
      
      interface GigabitEthernet0/0/2
      no ip address
      carrier-delay msec 50
      lacp port-priority 3000
      channel-group 1 mode active
      

      Additional References

      Related Documents

      MIBs

      MIB

      MIBs Link

      No new or modified MIBs are supported by this feature.

      To locate and download MIBs for selected platforms, Cisco software releases, and feature sets, use Cisco MIB Locator found at the following URL:

      http:/​/​www.cisco.com/​go/​mibs

      Technical Assistance

      Description

      Link

      The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

      To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

      Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

      http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

      Feature Information for IP Sessions over Gigabit EtherChannel

      The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

      Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

      Table 1 Feature Information for IP Sessions over Gigabit EtherChannel

      Feature Name

      Releases

      Feature Information

      IP Sessions over Gigabit EtherChannel

      Cisco IOS XE Release 3.9

      The IP sessions over Gigabit EtherChannel (IPoGEC) feature enables you to add the Link Aggregation Control Protocol (LACP) functionality for IP sessions.

      In Cisco IOS XE Release 3.9S, this feature was implemented on the Cisco ASR 1000 Series Aggregation Services Routers.