Cisco VGD 1T3 Voice Gateway Software Configuration Guide
Using Cisco Unified Communications Manager to Configure Conferencing, Transcoding, and Media Termination Point
Downloads: This chapterpdf (PDF - 283.0KB) | Feedback

Using Cisco Unified Communications Manager to Configure Conferencing, Transcoding, and Media Termination Point

Table Of Contents

Using Cisco Unified Communications Manager to Configure Conferencing, Transcoding, and Media Termination Point

Prerequisites for Conferencing, Transcoding, and MTP for Cisco VGD 1T3 Voice Gateway

DSP Resources

Codecs

Restrictions for Conferencing, Transcoding, and MTP for the Cisco VGD 1T3 Voice Gateway

Information About Conferencing, Transcoding, and MTP for the Cisco VGD 1T3 Voice Gateway

DSP Farms

DSP Farm Profiles

Conferencing

Transcoding and MTP

Media Termination Point

Allocation of DSP Resources

Allocation of DSP Resources Within the Voice Network Module

Allocation of DSP Resources Within the DSP Farm

Transcoding Session Capacities

Configuring Conferencing, Transcoding, and MTP for the Cisco VGD 1T3 Voice Gateway

Determining DSP Resource Requirements

Enabling SCCP on the Cisco Unified Communications Manager Interface

Configuring Enhanced Conferencing and Transcoding

Configuring a DSP Farm Profile

Associating a DSP Farm Profile to a Cisco Unified Communications Manager Group

Modifying Default Settings for SCCP Connection to Cisco Unified Communications Manager

Verifying DSP Farm Configuration

Troubleshooting Tips for Conferencing and Transcoding on Voice Gateway Routers

Troubleshooting DSP-Farm Services

Configuring Conferencing, Transcoding, and MTP

Configuration Examples for Conferencing, Transcoding, and MTP

DSP-Farm Services on the Cisco VGD 1T3: Example

Out-Band to In-Band DTMF Relay: Example

Out-Band to In-Band DTMF Relay for MTP Device: Example

SIP Gateway: Example


Using Cisco Unified Communications Manager to Configure Conferencing, Transcoding, and Media Termination Point


This chapter describes the steps for enabling conferencing, transcoding, and media termination point (MTP) support on Cisco VGD 1T3 voice gateways in a Cisco Unified Communications Manager network. This feature provides enhanced multiservice support by enabling transcode functions and MTP in voice gateway routers. Using transcoding services reduces bandwidth needs resulting in tangible cost savings.

Digital signal processor (DSP) farms provide transcoding services using DSP resources on high-density digital voice/fax network modules. This chapter contains the following sections:

Prerequisites for Conferencing, Transcoding, and MTP for Cisco VGD 1T3 Voice Gateway

Restrictions for Conferencing, Transcoding, and MTP for the Cisco VGD 1T3 Voice Gateway

Information About Conferencing, Transcoding, and MTP for the Cisco VGD 1T3 Voice Gateway

Configuring Conferencing, Transcoding, and MTP for the Cisco VGD 1T3 Voice Gateway

Configuration Examples for Conferencing, Transcoding, and MTP

Prerequisites for Conferencing, Transcoding, and MTP for Cisco VGD 1T3 Voice Gateway

The prerequisites defined in the sections below apply to the configuration of conferencing, transcoding, and MTP for the Cisco VGD 1T3 Voice Gateway:

DSP Resources

Codecs

DSP Resources

The Cisco VGD 1T3 voice gateway uses PVDM2 modules to provide DSP resources for conferencing, transcoding, and hardware MTP services. Use Cisco Unified Communications Manager 5.0 (formerly known as Cisco CallManager 5.0) or later for conferencing, transcoding, and MTP. You must have Cisco IOS Release 12.4(24)T or later.

Codecs

End-user devices must be equipped with one of the following codecs:

Codec
Packetization Periods for Transcoding (ms)

G.711 a-law, G.711 mu-law

10, 20, or 30

G.729, G.729A, G.729B, G.729AB

10, 20, 30, 40, 50, or 60


Restrictions for Conferencing, Transcoding, and MTP for the Cisco VGD 1T3 Voice Gateway

DSP farm services communicate with Cisco Unified Communications Manager using Skinny Client Control Protocol (SCCP); other protocols are not supported.

DSP farm services are not supported for Cisco Survivable Remote Site Telephony (SRST) or Cisco Unified Communications Manager Express.

Hardware MTPs support only G.711 a-law and G.711 u-law. If you configure a profile as a hardware MTP, and you want to change the codec to other than G.711, you must first remove the hardware MTP by using the no maximum sessions hardware command.

Only one codec is supported for each MTP profile. To support multiple codecs, you must define a separate MTP profile for each codec.

If an MTP call is received but MTP is not configured, transcoding is used if resources are available.

Dynamic conference and transcoding resource allocation is not supported.

Fax is not supported for transcoding.

Information About Conferencing, Transcoding, and MTP for the Cisco VGD 1T3 Voice Gateway

To configure transcoding, you should understand the following concepts:

DSP Farms

DSP Farm Profiles

Conferencing

Transcoding and MTP

Media Termination Point

Allocation of DSP Resources

Transcoding Session Capacities

DSP Farms

A DSP farm is the collection of DSP resources available for conferencing, transcoding, and MTP services. DSP farms are configured on the voice gateway and managed by Cisco Unified Communications Manager through Skinny Client Control Protocol (SCCP).

The DSP farm can support a combination of transcoding sessions and MTP sessions simultaneously. The DSP farm maintains the DSP resource details locally. Cisco Unified Communications Manager requests transcoding services from the gateway, which either grants or denies these requests, depending on resource availability. The details of whether DSP resources are used, and which DSP resources are used, are transparent to Cisco Unified Communications Manager.

The DSP farm uses the DSP resources in network modules on Cisco routers to provide conferencing, transcoding, and hardware MTP services.


Tip To determine how many DSP resources your router supports, see the "Allocation of DSP Resources" section.


DSP Farm Profiles

DSP-farm profiles are created to allocate DSP-farm resources. Under the profile you select the service type (transcode or MTP), associate an application, and specify service-specific parameters such as codecs and maximum number of sessions. A DSP-farm profile allows you to group DSP resources based on the service type. Applications associated with the profile, such as SCCP, can use the resources allocated under the profile. You can configure multiple profiles for the same service, each of which can register with one Cisco Unified Communications Manager group. The profile ID and service type uniquely identify a profile, allowing the profile to uniquely map to a Cisco Unified Communications Manager group that contains a single pool of Cisco Unified Communications Manager servers.

Conferencing

Voice conferencing involves adding several parties to a phone conversation. In a traditional circuit-switched voice network, all voice traffic passes through a central device such as a PBX. Conference services are provided within this central device. In contrast, IP phones normally send voice signals directly between phones, without the need to go through a central device. Conference services, however, require a network-based conference bridge.

In an IP telephony network using Cisco Unified Communications Manager, the Conferencing and Transcoding for Voice Gateway Routers feature provides the conference-bridging service. Cisco Unified Communications Manager uses a DSP farm to mix voice streams from multiple participants into a single conference-call stream. The mixed stream is played out to all conference attendees, minus the voice of the receiving attendee.

The following conferencing features are supported:

A conference can be either of the following types:

Ad hoc—The person controlling the conference presses the telephone conference button and adds callers one by one.

Meet me—Participants call in to a central number and are joined in a single conference.

Participants whose end devices use different codec types are joined in a single conference; no additional transcoding resource is needed.

This feature provides voice conferencing at the remote site, without the need for access to the central site (see Figure 1).

Figure 1 Conferencing Service

Transcoding and MTP

Transcoding compresses and decompresses voice streams to match endpoint-device capabilities. Transcoding is required when an incoming voice stream is digitized and compressed (by means of a codec) to save bandwidth, but the local device does not support that type of compression. Ideally, all IP telephony devices would support the same codecs, but this is not the case. Rather, different devices support different codecs.

Transcoding is processed by DSPs on the DSP farm; sessions are initiated and managed by Cisco Unified Communications Manager which also refers to transcoders as hardware MTPs.

This feature provides transcoding at the remote site, without the need for access to the central site (see Figure 2).

Figure 2 Transcoding Service

Media Termination Point

A Media Termination Point (MTP) bridges the media streams between two connections allowing Cisco Unified Communications Manager to relay calls that are routed through SIP or H.323 endpoints.

The following MTP resources are supported for Cisco Unified Communications Manager 4.0 (formerly known as Cisco CallManager 4.0) and later releases:

Software MTP—Software-only implementation that does not use a DSP resource for endpoints using the same codec and the same packetization time.

Hardware MTP—Hardware-only implementation that uses a DSP resource for endpoints using the same G.711 codec but a different packetization time. The repacketization requires a DSP resource so it cannot be done by software only. Cisco Unified Communications Manager also uses the term software MTP when referring to a hardware MTP.

For MTP and transcoding, the DSP farm supports only two IP streams connected to each other at a time. If more than two streams need connecting, the streams must be connected using conferencing.

Allocation of DSP Resources

You must allocate DSP resources on two levels:

Within the voice network module, between the DSP farm and your voice trunk group that handles standard voice termination

Within the DSP farm, between conferencing, transcoding, and voice-conferencing services

Allocation of DSP Resources Within the Voice Network Module

You allocate DSP resources either to voice termination of the voice trunk group or to the DSP farm. Occasionally these allocations can conflict.

If you previously allocated DSP resources to voice termination and you now try to configure a DSP farm, you might find that insufficient DSP resources are available. Conversely, if you previously allocated DSP resources to a DSP farm and you now try to configure a trunk group, you might find that insufficient DSP resources are available.

If your requested configuration is rejected, you have two options:

Insert more DSPs on the voice network module (NM-HDV or NM-HDV2)

Allocate a different voice network module for either the DSP farm or the trunk group

Allocation of DSP Resources Within the DSP Farm

You should know the following about your system:

Number of DSPs required to handle your anticipated number of conference calls and transcoding sessions

Number of DSPs that your system can support

DSP resources can reside in packet-voice DSP modules (PVDM2s) installed in voice network modules or directly in the network module. Cisco VGD 1T3 voice gateway routers have onboard DSP resources located on PVDM2s installed directly on the motherboard. Your router supports up to six voice network modules.

Transcoding Session Capacities

Each DSP is individually configurable to support transcoding and standard voice termination. The total number of transcoding and voice termination sessions is limited by the capacity of the entire system, which includes the DSPs, hardware platform, physical voice interface, and Cisco Unified Communications Manager.

Table 1 and Table 2 list the maximum number of conference calls and transcoding sessions that DSPs can handle, in theory. Actual capacity may be less based on the total system design.

Table 1 DSP Theoretical Session Capacities 

Application
2 PVDM2-64
3 PVDM2-64
4 PVDM2-64
Transcoding

G.711 a-law/u-law <-> G.729a/G.729ab

64 sessions

96 sessions

128 sessions

G.711 a-law/u-law <-> G.729/G.729b

48 sessions

72 sessions

96 sessions

Voice Termination

G.711 a-law/u-law

128 sessions

192 sessions

256 sessions

G.726, G.729a, G.729ab

64 sessions

96 sessions

128 sessions

G.729, G.729b, G.723.1, G.728

48 sessions

72 sessions

96 sessions


Table 2 Theoretical System Capacities for One DSP 

Application
G.711 a-law/u-law
G729 a/ab
G.729, G.729b
Conferencing

8 sessions
(8 x 8 = 64 conferees)

2 sessions
(8 x 2 = 16 conferees)

2 sessions
(8 x 2 = 16 conferees)

Hardware MTP

16 sessions

Transcoding

8 sessions

8 sessions

6 sessions


Configuring Conferencing, Transcoding, and MTP for the Cisco VGD 1T3 Voice Gateway

This section contains the procedures for configuring conferencing, transcoding, and MTP support on Cisco VGD 1T3 voice gateways. The procedures that you perform depend on the type of voice network module you are using to allocate DSP resources:

Determining DSP Resource Requirements (required)

Enabling SCCP on the Cisco Unified Communications Manager Interface (required)

Configuring Enhanced Conferencing and Transcoding

Configuring Conferencing, Transcoding, and MTP (required)

Determining DSP Resource Requirements

DSPs reside on PVDM2s that are installed in a voice network module or on PVDM2s that are installed directly onto the motherboard. You must determine the number of PVDM2s or network modules that are required to support your transcoding services and install the modules on your router.

SUMMARY STEPS

1. Determine performance requirements.

2. Determine the number of DSPs that are required.

3. Verify your solution.

4. Install hardware.

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

Determine the number of transcoding sessions and conference calls that your router must support.

Establishes your performance requirements.

Step 2 

Determine the number of DSPs that are required to support the transcoding sessions. If voice termination is also required, determine the additional DSPs required.

Example:

8 G.711 conferences and 32 transcoding sessions require 1 PVDM2-64 (4 DSPs).

Establishes your hardware requirements.

Step 3 

Ensure that your requirements fall within router capabilities, taking into account whether your router supports multiple network modules. If necessary, reassess performance requirements.

Verifies your proposed solution.

Step 4 

Install PVDM2s and network modules, as needed (see the "Connecting Voice Network Modules" chapter in the Cisco Network Modules Hardware Installation Guide, and the Cisco Network Modules and Interface Cards Regulatory Compliance and Safety Information).

Prepares your system for DSP-farm configuration.


Enabling SCCP on the Cisco Unified Communications Manager Interface

Perform this task to enable SCCP on the local interface that the voice gateway uses to communicate with Cisco Unified Communications Manager.

SUMMARY STEPS

1. enable

2. configure terminal

3. sccp ccm {ip-address | dns} identifier identifier-number [port port-number] [version version-number]

4. sccp local interface-type interface-number

5. sccp ip precedence value

6. sccp

7. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

sccp ccm {ip-address | dns} identifier identifier-number [port port-number] [version version-number]

Example:

Router(config)# sccp ccm 10.0.0.0 identifier 1 version 4.0

Adds a Cisco Unified Communications Manager server to the list of available servers to which the Cisco VGD 1T3 voice gateway can register.

Repeat this step for each Cisco Unified Communications Manager server that the gateway registers with.

Step 4 

sccp local interface-type interface-number

Example:

Router(config)# sccp local Ethernet 1

Selects the local interface that SCCP applications use to register with Cisco Unified Communications Manager.

Step 5 

sccp ip precedence value

Example:

Router(config)# sccp ip precedence 3

(Optional) Sets the IP precedence value for SCCP.

This command enables you to increase the priority of voice packets over connections controlled by SCCP.

value—Range is 1(highest) to 7 (lowest). Default is 5.

Step 6 

sccp

Example:

Router(config)# sccp

Enables SCCP and brings it up administratively.

Step 7 

exit

Example:

Router(config)# exit

Exits global configuration mode.

Configuring Enhanced Conferencing and Transcoding

Perform the following procedures to configure enhanced conferencing and transcoding on the PVDM2:

Configuring a DSP Farm Profile (required)

Associating a DSP Farm Profile to a Cisco Unified Communications Manager Group (required)

Modifying Default Settings for SCCP Connection to Cisco Unified Communications Manager (optional)

Verifying DSP Farm Configuration (optional)

Troubleshooting DSP-Farm Services (optional)

Configuring a DSP Farm Profile

Perform this procedure to define a DSP farm on the NM-HDV2, NM-HD-1V, NM-HD-2V, NM-HD-2VE, or PVDM2. You must configure each conferencing, transcoding, and MTP profile separately.


Note Because a software-only MTP does not require DSP resources, you can configure a software-only MTP without a voice network module, or on the NM-HDV if you do not enable the dsp services dspfarm command for the voice card.


Prerequisites

Requires Cisco IOS Release 12.4(24)T or a later release.

SUMMARY STEPS

1. enable

2. configure terminal

3. voice-card slot

4. dsp services dspfarm

5. exit

6. dspfarm profile profile-identifier {conference | mtp | transcode}

7. description text

8. codec codec-type

9. maximum sessions number

or

maximum sessions {hardware | software} number

10. associate application sccp

11. no shutdown

12. exit

13. gateway

14. timer receive-rtp seconds

15. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

voice-card slot

Example:

Router(config)# voice-card 1

Enters voice-card configuration mode for the network module on which you want to enable DSP-farm services.

Step 4 

dsp services dspfarm

Example:

Router(config-voicecard)# dsp services dspfarm

Enables DSP-farm services for the voice card.

Step 5 

exit

Example:

Router(config-voicecard)# exit

Exits voice-card configuration mode.

Step 6 

dspfarm profile profile-identifier {conference | mtp | transcode}

Example:

Router(config)# dspfarm profile 20 conference

Enters DSP farm profile configuration mode to define a profile for DSP farm services.

Note The profile-identifier and service type uniquely identifies a profile. If the service type and profile-identifier pair is not unique, you are prompted to choose a different profile-identifier.

Step 7 

description text

Example:

Router(config-dspfarm-profile)# description art_dept

(Optional) Includes a specific description about the Cisco DSP farm profile.

Step 8 

codec codec-type

Example:

Router(config-dspfarm-profile)# codec g729ar8

Specifies the codecs supported by a DSP farm profile.

Repeat this step for each codec supported by the profile.

Note Hardware MTPs support only G.711 a-law and G.711 u-law. If you configure a profile as a hardware MTP, and you want to change the codec to other than G.711, you must first remove the hardware MTP by using the no maximum sessions hardware command.

Note Only one codec is supported for each MTP profile. To support multiple codecs, you must define a separate MTP profile for each codec.

Step 9 

maximum sessions number

or

maximum sessions {hardware | software} number

Example:

Router(config-dspfarm-profile)# maximum sessions 4

Specifies the maximum number of sessions that are supported by the profile.

number—Range is determined by the available registered DSP resources. Default is 0.

Note The hardware and software keywords apply only to MTP profiles.

Step 10 

associate application sccp

Example:

Router(config-dspfarm-profile)# associate application sccp

Associates the SCCP protocol to the DSP farm profile.

Step 11 

no shutdown

Example:

Router(config-dspfarm-profile)# no shutdown

Enables the profile, allocates DSP farm resources, and associates the application.

Step 12 

exit

Example:

Router(config-dspfarm-profile)# exit

Exits DSP farm profile configuration mode.

Step 13 

gateway

Example:

Router(config)# gateway

Enters gateway configuration mode.

Step 14 

timer receive-rtp seconds

Example:

Router(config-gateway)# timer receive-rtp 600

Sets the Real-Time Transport Protocol (RTP) timeout interval to clear hanging connections.

seconds—Range is 180 to 1800. Default is 1200.

Step 15 

exit

Example:

Router(config-gateway)# exit

Exits to global configuration mode.

Associating a DSP Farm Profile to a Cisco Unified Communications Manager Group

Perform this procedure to define a Cisco Unified Communications Manager group and to associate a DSP farm profile with the Cisco Unified Communications Manager group.


Note Secure conferencing is also supported on the Cisco VGD 1T3 voice gateway platform. For more information on secure conferencing, refer to the Media and Signaling Encryption (SRTP/TLS) on DSP Farm Conferencing feature documentation.


Prerequisites

This procedure requires Cisco IOS Release 12.4(24)T or later release.

SUMMARY STEPS

1. enable

2. configure terminal

3. sccp ccm group group-number

4. associate ccm identifier-number priority priority-number

5. associate profile profile-identifier register device-name

6. bind interface interface-type interface-number

7. description string

8. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

sccp ccm group group-number

Example:

Router(config)# sccp ccm group 118

Creates a Cisco Unified Communications Manager group and enters SCCP Cisco Unified Communications Manager configuration mode.

Step 4 

associate ccm identifier-number priority priority-number

Example:

Router(config-sccp-ccm)# associate ccm 125 priority 2

Adds a Cisco Unified Communications Manager server to the Cisco Unified Communications Manager group and establishes its priority within the group.

Repeat this step for each Cisco Unified Communications Manager server that you want to add to the group.

Step 5 

associate profile profile-identifier register device-name

Example:

Router(config-sccp-ccm)# associate profile register abgz12345

Associates a DSP farm profile to the Cisco Unified Communications Manager group.

device-name—Must match the device name configured in Cisco Unified Communications Manager; otherwise profile is not registered to Cisco Unified Communications Manager.

Repeat this step for each DSP farm profile that you want to register with this Cisco Unified Communications Manager group.

Step 6 

bind interface interface-type interface-number

Example:

Router(config-sccp-ccm)# bind interface fastethernet 2:1

Binds an interface to the Cisco Unified Communications Manager group.

Step 7 

description text

Example:

Router(config-sccp-ccm)# description boston office

(Optional) Includes a specific description of the Cisco Unified Communications Manager group.

Step 8 

end

Example:

Router(config)# end

Exits to privileged EXEC mode.

Modifying Default Settings for SCCP Connection to Cisco Unified Communications Manager

Perform this task to tune the performance of the SCCP connection between the DSP farm and Cisco Unified Communications Manager.


Note The optimum settings for these commands depend on your platform and individual network characteristics. Modify the defaults to meet your performance requirements.


SUMMARY STEPS

1. enable

2. configure terminal

3. sccp ccm group group-number

4. connect interval seconds

5. connect retries number

6. keepalive retries number

7. keepalive timeout seconds

8. registration retries retry-attempts

9. registration timeout seconds

10. switchover method {graceful | immediate}

11. switchback method {graceful | guard [timeout-value] | immediate | uptime uptime-value}

12. switchback interval seconds

13. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

sccp ccm group group-number

Example:

Router(config)# sccp ccm group 118

Enters SCCP Cisco Unified Communications Manager configuration mode.

group-number—Range is 1 to 65535.

Step 4 

connect interval seconds

Example:

Router(config-sccp-ccm)# connect interval 1200

(Optional) Specifies the amount of time that a DSP farm profile waits before attempting to connect to another Cisco Unified Communications Manager when the current Cisco Unified Communications Manager fails to connect.

seconds—Range is 1 to 3600. Default is 60.

Step 5 

connect retries number

Example:

Router(config-sccp-ccm)# connect retries 5

(Optional) Specifies the number of times that a DSP farm attempts to connect to a Cisco Unified Communications Manager when the current Cisco Unified Communications Manager connections fails.

number—Range is 1 to 32. Default is 3.

Step 6 

keepalive retries number

Example:

Router(config-sccp-ccm)# keepalive retries 7

(Optional) Sets the number of keepalive retries from SCCP to the Cisco Unified Communications Manager.

number—Range is 1 to 32. Default is 3.

Step 7 

keepalive timeout seconds

Example:

Router(config-sccp-ccm)# keepalive timeout 50

(Optional) Sets the number of seconds between keepalive messages from SCCP to the Cisco Unified Communications Manager.

seconds—Range is 1 to 180. Default is 30.

Step 8 

registration retries retry-attempts

Example:

Router(config-sccp-ccm)# registration retries 15

(Optional) Sets the number of registration retries that SCCP tries to register with the Cisco Unified Communications Manager.

retry-attempts—Range is 1 to 32. Default is 3.

Step 9 

registration timeout seconds

Example:

Router(config-sccp-ccm)# registration timeout 8

(Optional) Sets the number of seconds between registration messages sent from SCCP to the Cisco Unified Communications Manager.

seconds—Range is 1 to 180. Default is 3.

Step 10 

switchover method {graceful | immediate}

Example:

Router(config-sccp-ccm)# switchover method graceful

(Optional) Sets the switchover method that the SCCP client uses when the communication link to the active Cisco Unified Communications Manager fails.

Default is graceful.

Step 11 

switchback method {graceful | guard [timeout-value] | immediate | uptime uptime-value}

Example:

Router(config-sccp-ccm)# switchback method graceful

(Optional) Sets the switchback method to use when the primary or higher priority Cisco Unified Communications Manager becomes available again.

Default is guard, with a timeout value of 7200 seconds.

Step 12 

switchback interval seconds

Example:

Router(conf-sccp-ccm)# switchback interval 120

(Optional) Sets the number of seconds that the DSP farm waits before polling the primary Cisco Unified Communications Manager when the current Cisco Unified Communications Manager fails to connect.

seconds—Range is 1 to 3600. Default is 60.

Step 13 

end

Example:

Router(config-sccp-ccm)# end

Exits to privileged EXEC mode.

Verifying DSP Farm Configuration

To verify conferencing, transcoding, and MTP services, perform the following steps.

SUMMARY STEPS

1. show running-config

2. show sccp ccm group [group-number]

3. show dspfarm profile [profile-number]

4. show dspfarm all

5. show sccp

6. show sccp connections

7. show media resource status

DETAILED STEPS


Step 1 Use the show running-config command to display the configuration of the MTP profile, for example:

Router# show running-config
...
sccp local FastEthernet0/0
sccp ccm 10.40.10.10 identifier 10 version 4.0
sccp
!
sccp ccm group 999
 associate ccm 10 priority 1
 associate profile 12 register MTP123456789
 associate profile 2 register XCODE123456
!
dspfarm profile 12 mtp
 codec g711ulaw
 maximum sessions hardware 4
 maximum sessions software 40
 associate application SCCP
!

Step 2 show sccp ccm group [group-number]

Use this command to verify the configuration of the Cisco Unified Communications Manager group, for example:

Router# show sccp ccm group 999

CCM Group Identifier: 999
 Description: None
 Associated CCM Id: 10, Priority in this CCM Group: 1
 Associated Profile: 2, Registration Name: XCODE1234567
 Associated Profile: 12, Registration Name: MTP123456789
 Registration Retries: 3, Registration Timeout: 10 sec
 Keepalive Retries: 3, Keepalive Timeout: 30 sec
 CCM Connect Retries: 3, CCM Connect Interval: 10 sec
 Switchover Method: GRACEFUL, Switchback Method: GRACEFUL_GUARD
 Switchback Interval: 10 sec, Switchback Timeout: 7200 sec
 Signaling DSCP value: default, Audio DSCP value: default

Step 3 show dspfarm profile [profile-number]

Use this command to verify the configured DSP farm profiles, for example:

Router# show dspfarm profile 12

Dspfarm Profile Configuration

 Profile ID = 12, Service = MTP, Resource ID = 2
 Profile Admin State : UP
 Profile Operation State : ACTIVE
 Application : SCCP   Status : ASSOCIATED
 Resource Provider : FLEX_DSPRM   Status : UP
 Number of Resource Configured : 14
 Number of Resource Available : 14
 Hardware Configured Resources 4
 Hardware Available Resources 4
 Software Resources 10
 Codec Configuration
 Codec : g711ulaw,  sa

Router# show dspfarm profile 6

Dspfarm Profile Configuration

 Profile ID = 6, Service = TRANSCODING, Resource ID = 1   
 Profile Admin State : UP 
 Profile Operation State : ACTIVE 
 Application : SCCP   Status : ASSOCIATED 
 Resource Provider : FLEX_DSPRM   Status : UP 
 Number of Resource Configured : 4 
 Number of Resource Available : 4
 Codec Configuration 
 Codec : g711ulaw, Maximum Packetization Period : 30 
 Codec : g711alaw, Maximum Packetization Period : 30 
 Codec : g729ar8, Maximum Packetization Period : 60 
 Codec : g729abr8, Maximum Packetization Period : 60 
 Codec : g729br8, Maximum Packetization Period : 60 


Note This command is not supported on the NM-HDV or Cisco 1700 series.


Step 4 show dspfarm all

Use this command to verify the status of the DSP farm, for example:

Router# show dspfarm all

DSPFARM Configuration Information:
Admin State: UP, Oper Status: ACTIVE - Cause code: NONE
Transcoding Sessions: 0(Avail: 0), Conferencing Sessions: 2 (Avail: 2)
Trans sessions for mixed-mode conf: 0 (Avail: 0), RTP Timeout: 600
Connection check interval 600 Codec G729 VAD: ENABLED

Total number of active session(s) 0, and connection(s) 0

SLOT  DSP   CHNL  STATUS USE   TYPE   SESS-ID   CONN-ID   PKTS-RXED PKTS-TXED

0     0     1     UP     FREE  conf   -         -         -         -
0     0     2     UP     FREE  conf   -         -         -         -
0     0     3     UP     FREE  conf   -         -         -         -
0     0     4     UP     FREE  conf   -         -         -         -
0     0     5     UP     FREE  conf   -         -         -         -
0     0     6     UP     FREE  conf   -         -         -         -

Step 5 show sccp

Use the show sccp command to verify that the DSP farm is registered, for example:

Router# show sccp

SCCP Admin State: UP
Gateway IP Address: 10.10.100.29, Port Number: 0
IP Precedence: 5
User Masked Codec list:
Call Manager: 10.10.100.51, Port Number: 2000
                Priority: N/A, Version: 4.0, Identifier: 2
Call Manager: 10.10.100.50, Port Number: 2000
                Priority: N/A, Version: 4.0, Identifier: 1
 
Transcoding Oper State: ACTIVE - Cause Code: NONE
Active Call Manager: 10.10.100.51, Port Number: 2000
TCP Link Status: CONNECTED, Profile Identifier: 10
Reported Max Streams: 6, Reported Max OOS Streams: 0
Supported Codec: g711ulaw, Maximum Packetization Period: 30
Supported Codec: g711alaw, Maximum Packetization Period: 30
Supported Codec: g729ar8, Maximum Packetization Period: 60
Supported Codec: g729abr8, Maximum Packetization Period: 60
Supported Codec: g729br8, Maximum Packetization Period: 60
Supported Codec: rfc2833 dtmf, Maximum Packetization Period: 20
 
Software MTP Oper State: ACTIVE - Cause Code: NONE
Active Call Manager: 10.10.100.51, Port Number: 2000
TCP Link Status: CONNECTED, Profile Identifier: 20
Reported Max Streams: 176, Reported Max OOS Streams: 0
Supported Codec: g711ulaw, Maximum Packetization Period: 30
Supported Codec: rfc2833 dtmf, Maximum Packetization Period: 20

Step 6 show sccp connections

Use this command to verify the active SCCP connections, for example:

Router# show sccp connections

sess_id    conn_id    stype mode     codec   ripaddr         rport sport
 
16777268   2164263392 mtp   recvonly g711u   0.0.0.0         0     17540
 
Total number of active session(s) 1, and connection(s) 1

Step 7 show media resource status

Use this command to verify the current media resource status, for example:

Router# show media resource status

 Resource Providers:

 Resource  Provider ID :: FLEX_DSPRM Status :: REGISTERED
 Service Profiles
 MTP :: 
 TRANSCODING :: 6 11 
 CONFERENCING :: 10 
 Applications : 
 Application ID : SCCP, Status : REGISTERED


Troubleshooting Tips for Conferencing and Transcoding on Voice Gateway Routers

This section describes techniques for troubleshooting DSP-farm services.

Basic Troubleshooting Procedures

1. Verify the Cisco Unified Communications Manager 4.0 (formerly known as Cisco CallManager 4.0) or later.

2. Verify that Cisco Unified Communications Manager is properly configured to provision conferencing, transcoding, and MTP resources.

3. Organize your Cisco Unified Communications Manager group IDs, device IDs, and DSP farm profile names. Use the show dsp command to verify that the association between SCCP Cisco Unified Communications Manager and the DSP farm profiles match your organizational plan.

4. Verify that the VoIP dial peer application exists on the terminating gateway.

5. Collect relevant information from debug and show commands, and configuration files before contacting Cisco Technical Support for assistance.

6. You can clear any of the following by disabling the DSP farm or SCCP:

Active calls

DSPs

Active connection to a Cisco Unified Communications Manager

MTP Troubleshooting Tips

MTP profiles can use only G.711 a-law or G.711 u-law. If you define a profile for a hardware MTP, and you want to change the codec to other than G.711, you must first remove the hardware MTP by using the no maximum sessions hardware command.

Verify that only one codec is assigned for each MTP profile. To support multiple codecs, you must define a separate MTP profile for each codec.

Troubleshooting DSP-Farm Services

You can troubleshoot performance by performing any of the following steps.

SUMMARY STEPS

1. debug sccp {all | errors | events | packets | parser}

2. debug dspfarm {all | errors | events | packets}

3. debug media resource provisioning {all | errors | events}

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

debug sccp {all | errors | events | packets | parser}

Example:

Router# debug sccp all

(Optional) Sets debugging levels for SCCP and its applications.

Step 2 

debug dspfarm {all | errors | events | packets}

Example:

Router# debug dspfarm all

(Optional) Sets debugging levels for DSP-farm service.

Step 3 

debug media resource provisioning {all | errors | events}

Example:

Router# debug media resource provisioning all

(Optional) Sets debugging levels for media resource provisioning.

Configuring Conferencing, Transcoding, and MTP

For detailed instructions on how to configure Conferencing on Cisco Unified Communications Manager, refer to the Conference Bridge Configuration section in the Media Resource Configuration chapter in the Cisco Unified Communications Manager Administration Guide.

For detailed instructions on how to configure Transcoding on Cisco Unified Communications Manager, refer to the Transcoder Configuration section in the Media Resource Configuration chapter in the Cisco Unified Communications Manager Administration Guide.

For detailed instructions on how to configure MTP on Cisco Unified Communications Manager, refer to the Media Termination Point Configuration section in the Media Resource Configuration chapter in the Cisco Unified Communications Manager Administration Guide.

Configuration Examples for Conferencing, Transcoding, and MTP

This section provides the following configuration examples:

DSP-Farm Services on the Cisco VGD 1T3: Example

Out-Band to In-Band DTMF Relay: Example

Out-Band to In-Band DTMF Relay for MTP Device: Example

SIP Gateway: Example

DSP-Farm Services on the Cisco VGD 1T3: Example

The following example shows a configuration of transcoding services on a PVDM2. DSP farm profile 6, which supports transcoding, is assigned to Cisco Unified Communications Manager group 988.


Note This configuration requires Cisco IOS Release 12.4(24)T or later.


Current configuration : 2661 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname sjl23
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
!
ip host boating 223.255.254.254
no ftp-server write-enable
!
voice-card 1
 no dspfarm
 dsp services dspfarm
!
!
voice service voip 
 h323
!
!
!
interface FastEthernet0/0
 ip address 10.4.20.7 255.255.255.0
 no ip mroute-cache
 speed auto
 half-duplex
 no cdp enable
!
interface FastEthernet0/1
 no ip address
 no ip mroute-cache
 shutdown 
 duplex auto
 speed auto
 no cdp enable
!
ip default-gateway 10.4.0.1
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
ip route 223.255.254.254 255.255.255.255 10.4.0.1
no ip http server
!
!
no cdp run
!
!
control-plane
!
!
sccp local FastEthernet0/0
sccp ccm 10.4.20.24 identifier 1 version 4.0
sccp ccm 10.4.20.25 identifier 2 version 4.0
sccp ccm 10.4.20.26 identifier 3 version 4.0
sccp ip precedence 3
sccp
!
sccp ccm group 988
 associate ccm 1 priority 1
 associate ccm 2 priority 2
 associate ccm 3 priority 3
associate profile 6 register MTP123456789988
 keepalive retries 5
 switchover method immediate
 switchback method immediate
 switchback interval 15
!
dspfarm profile 6 transcode
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec gsmfr
 maximum sessions 4
 associate application SCCP
!
!
dial-peer cor custom
!
!
dial-peer voice 200 voip
 destination-pattern 111....
 session target ipv4:10.4.205.24
!
dial-peer voice 2600 voip
 destination-pattern 666....
 session target ipv4:10.4.205.24
 codec g711ulaw
!
dial-peer voice 100 voip
 destination-pattern 5550...
 session target ipv4:10.4.205.24
 codec g711ulaw
!
dial-peer voice 10 pots
 destination-pattern 7770000
 forward-digits 0
!
dial-peer voice 11 pots
 destination-pattern 7771111
!
dial-peer voice 999 voip
 session target ipv4:10.4.205.8
!
gateway 
 timer receive-rtp 1200
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password test
 login
!
!
end

Out-Band to In-Band DTMF Relay: Example

In the following configuration, the voice gateway acts as both a H.323 gateway and DSP farm.

Building configuration...

Current configuration :2091 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname vgd 1t3
!
boot-start-marker
boot-end-marker
!
no logging console
!
no network-clock-participate wic 1
network-clock-participate wic 2
no network-clock-participate wic 3
network-clock-participate wic 4
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
ip cef
!
!
!
no ftp-server write-enable
isdn switch-type primary-net5
voice-card 0
 dsp services dspfarm
!
!
!
controller T1 2/0:1
 shutdown
 framing esf
 linecode b8zs
!
controller T1 3/0:1
 framing esf
 linecode b8zs
!
!
!
interface FastEthernet0/0
 ip address 192.168.12.21 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface BRI4/0
 no ip address
 isdn switch-type basic-net3
!
interface BRI4/1
 no ip address
 isdn switch-type basic-net3
!
ip classless
ip http server
!
!
!
control-plane
!
!
!
voice-port 3/0:1
!
voice-port 3/1:1
!
voice-port 4/0:1
!
voice-port 4/1:1
!
!
sccp local FastEthernet0/0
sccp ccm 192.168.12.131 identifier 1 version 4.0
sccp ip precedence 4
sccp
!
sccp ccm group 1
 bind interface FastEthernet0/0
 associate ccm 1 priority 1
 associate profile 2 register amalthea-mtp
 associate profile 1 register amalthea-xcode
 registration retries 20
 registration timeout 30
 keepalive retries 10
 connect retries 30
 connect interval 30
!
dspfarm profile 1 transcode
 description xcode func
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec gsmfr
 codec g729r8
 maximum sessions 2
 associate application SCCP
!
dspfarm profile 2 mtp
 codec g711ulaw
 maximum sessions hardware 2
 maximum sessions software 2
 associate application SCCP
!
!
dial-peer voice 1 pots
 destination-pattern 4444
 port 3/0
!
dial-peer voice 2 voip
 destination-pattern 52..
 session target ipv4:192.168.12.131
 dtmf-relay h245-alphanumeric
!
gateway
 timer receive-rtp 1200
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

Out-Band to In-Band DTMF Relay for MTP Device: Example

The following running configuration example shows the MTP device configuration.

Building configuration...

Current configuration : 1435 bytes
!
version 12.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router1
!
voice-card 1
 no dspfarm
 dsp services dspfarm
!
voice-card 2
 dspfarm
!
no aaa new-model
ip subnet-zero
!
ip host sample 10.10.10.5
mpls ldp logging neighbor-changes
no ftp-server write-enable
no scripting tcl init
no scripting tcl encdir
!
no voice hpi capture buffer
no voice hpi capture destination
!
interface FastEthernet0/0
 ip address 10.4.118.13 255.255.255.255
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip default-gateway 10.4.0.10
ip classless
ip route 10.0.0.0 255.255.255.255 FastEthernet0/0
ip route 223.255.255.255 255.255.255.255 FastEthernet0/0
!
ip http server
!
sccp local FastEthernet0/0
sccp ccm 10.40.10.10 identifier 10 version 4.0
sccp ccm 10.10.10.51 identifier 20 version 4.0
sccp
!
sccp ccm group 999
 associate ccm 10 priority 1
 associate ccm 20 priority 2
 associate profile 12 register MTP123456789
 associate profile 2 register XCODT123456
!
dspfarm profile 2 transcode
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec gsmfr
 maximum sessions 2
 associate application SCCP
!
dspfarm profile 12 mtp
 codec g711ulaw
 maximum sessions hardware 4
 maximum sessions software 40
 associate application SCCP
!

SIP Gateway: Example

The following running configuration example shows the SIP gateway configuration for the Out-Band to In-Band DTMF Relay feature.

Building configuration...

Current configuration : 2051 bytes
!
version 12.4
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cisco_sip_gw
!
logging buffered 6000000 debugging
!
voice-card 2
 dspfarm
!
no aaa new-model
ip subnet-zero
!
!
ip domain name cisco.com
ip host sample 10.10.10.5
ip host myhost 10.4.175.2
mpls ldp logging neighbor-changes
no ftp-server write-enable
no scripting tcl init
no scripting tcl encdir
!
!
no voice hpi capture buffer
no voice hpi capture destination 
!
!
ccm-manager mgcp
ccm-manager music-on-hold
ccm-manager config server 10.4.175.2  
ccm-manager config
!
!
controller T1 2/0:1
 framing esf
 linecode b8zs
 ds0-group 1 timeslots 1-24 type e&m-fgb
!
controller T1 2/0:2
 framing sf
 linecode ami
!
!
!
interface FastEthernet0/0
 ip address 10.4.175.14 255.255.0.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
! 
interface BRI1/0
 no ip address
!
ip default-gateway 10.4.0.1
ip classless
ip route 0.0.0.0 255.255.0.0 FastEthernet0/0
ip route 223.255.254.254 255.255.255.255 FastEthernet0/0
!
ip http server
!
!
voice-port 1/0:0
!
voice-port 1/0:1
!
voice-port 1/1:0
!
voice-port 2/0:1
!
mgcp profile default
!
!
dial-peer voice 1 voip
 destination-pattern 2000
 session protocol sipv2
 session target ipv4:10.4.175.2
 dtmf-relay rtp-nte
 codec g711ulaw
!
dial-peer voice 3 pots
 application mgcpapp
 port 2/0:1
!
dial-peer voice 999201 pots
 application mgcpapp
 port 2/0:1
!
dial-peer voice 2 pots
 destination-pattern 2005
 port 1/0/0
!
dial-peer voice 5 pots
 destination-pattern 2001
 port 1/0/0
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end