Guest

Cisco SOHO 70 Series Routers

Configuration Note for the Cisco SOHO 76 and 77 Routers

  • Viewing Options

  • PDF (293.5 KB)
  • Feedback
Configuration Note for the Cisco SOHO 76 and 77 Routers

Table Of Contents

Configuration Note for the Cisco SOHO 76 and 77 Routers

Overview of Features

Memory Requirements

Software Requirements

Related Documents

New and Changed Information

clear vpdn tunnel pppoe Command No Longer Supported

debug Commands No Longer Supported

show Commands No Longer Supported

vpdn Configuration Commands No Longer Supported

Command Reference

show pppoe session Command

clear pppoe Command

debug pppoe Command

Configuration Instructions

Configuring a Bridged RFC 1483 DHCP Client

Configuration Example

Configuring a Bridged RFC 1483 Interface with a Static IP Address

Configuration Example

Configuring PPP over Ethernet

Configuration Example

MMI Support

Configuring MMI for Auto-Provisioning

MMI Configuration Example

Notes for the DSL Provider

Obtaining Documentation and Submitting a Service Request


Configuration Note for the Cisco SOHO 76 and 77 Routers


This document describes software configuration information for the Cisco small office/home office (SOHO) 76 router, SOHO 77 router, and SOHO 77H router. For additional information on these routers, see the "Related Documents" section.

This document contains the following sections:

Overview of Features

Related Documents

New and Changed Information

Command Reference

Configuration Instructions

Obtaining Documentation and Submitting a Service Request

Overview of Features

The SOHO 76 and SOHO 77 routers are asymmetric digital subscriber line (ADSL) routers that provide entry-evel access to the Internet. The routers include an Ethernet interface and an ADSL interface. The ATM interface supports the AAL5 (ATM Adaptation Layer 5) format.

Memory Requirements

The memory required for running the SOHO 76 and SOHO 77 and 77H routers is as follows:

8 MB of Flash memory

16 MB of dynamic RAM (DRAM)

The Flash memory and DRAM cannot be upgraded.

Software Requirements

The SOHO 76, SOHO 77 and SOHO 77H routers support a subset of the IP/Firewall feature set.

Related Documents

The following documents provide additional information about installing and configuring these routers and configuring router software:

Cisco 826 and SOHO 76 Routers Hardware Installation Guide—provides installation information on the Cisco 826 and SOHO 76 routers.

Cisco 826 and Cisco SOHO 76 Router Cabling and Setup Quick Start Guide—provides quick installation information for the SOHO 76 router.

Cisco 827 and SOHO 77 Routers Hardware Installation Guide—provides installation information on the Cisco 827 and SOHO 77 routers.

Cisco 820 Series and SOHO Series Router Cabling and Setup Quick Start Guide—provides quick installation information for the Cisco SOHO series routers.

Cisco 827 Routers Software Configuration Guide—provides sample networks and router configurations for the Cisco 827 routers. Only the data configurations in the guide apply to the SOHO 76 and 77 routers.

Regulatory Compliance and Safety Information for the Cisco 800 Series and SOHO Series Routers document—provides safety warnings and compliance information for the router.

Cisco IOS configuration guides and command references—provide IOS commands and configurations for the router.

For more information on the Cisco DSL CPE image provisioning, refer to the following documents:

Cisco DSL CPE Automated Configuration Solution Guide

Cisco DSL CPE Manager

New and Changed Information

This section describes information that has changed from previous software releases. A number of configuration commands, and show and debug commands run from EXEC mode, are no longer available on the Cisco SOHO 76, 77, and 77H routers. The configuration commands are no longer necessary. The show and debug commands have been replaced by new commands that are described in the "Command Reference" section.

clear vpdn tunnel pppoe Command No Longer Supported

The following virtual private dial-up network (VPDN) clear commands will no longer work for Point-to-Point Protocol over Ethernet (PPPoE) client sessions.

clear vpdn tunnel pppoe

This command has been replaced by the clear pppoe command, which is described in the "Command Reference" section.

debug Commands No Longer Supported

The following VPDN debug commands will no longer work for PPPoE client sessions:

debug vpdn pppoe-event

debug vpdn pppoe-error

debug vpdn pppoe-packet

debug vpdn pppoe-data

These commands have been replaced by the debug pppoe command, which is described in the "Command Reference" section.

show Commands No Longer Supported

The following VPDN show commands will no longer work for PPPoE client sessions.

show vpdn tunnel

show vpdn session

show vpdn

These commands have been replaced by the show pppoe session command, which is described in the "Command Reference" section.

vpdn Configuration Commands No Longer Supported

The following commands are no longer necessary for configuring a PPPoE client on a SOHO 77 or 77H router:

vpdn enable

vpdn group number

See the "Configuring PPP over Ethernet" section for new configuration instructions.

Command Reference

This section describes new commands that are supported on the SOHO 76, 77, and 77H routers.

show pppoe session Command

The show pppoe session command provides information about currently active PPPoE sessions. The syntax of this command is shown below:

show pppoe session [ { all | packets } ]

Syntax Description

all

Show detailed information about the PPPoE session.

packets

Show packet statistics for the PPPoE session.

Default

None.

Command Mode

This command is available in EXEC mode.

Command History

Release
Modification

Cisco IOS Release 12.2(4)YG

This command was introduced on the Cisco SOHO 76, 77, and 77H routers.


Example

The following example shows output for the show pppoe session command:

SOHO-02#show pppoe session
Total PPPoE sessions 3

PPPoE Session Information
UID    SID    RemMAC         OIntf          Intf      Session
              LocMAC                        VASt      state
0      2      0004.4d10.04c1 Et0            Vi4       N/A
              0004.27fc.dd50               UP
0      1      0004.4d10.04c1 Et0            Vi3       N/A
              0004.27fc.dd50               UP
0      22     0005.019e.70a8 ATM0           Vi5       N/A
              0004.27fc.dd50 VP/VC:  2/41   UP
SOHO-02#

clear pppoe Command

Use the clear pppoe command to terminate one or more PPPoE sessions that have been established by PCs attached to the router. The syntax of this command is as follows:

clear pppoe { interface if-type if-number [ vc { [ vpi / vci ] vci | vc-name } ] |
rmac mac-addr [ sid session-id ] | all }

Syntax Description

interface

Clear PPPoE sessions on specified interface.

rmac

Clear PPPoE sessions from specified client.

all

Clear all PPPoE sessions.


Default

None

Command Mode

This command is available in Privileged mode.

Command History

Release
Modification

Cisco IOS Release 12.2(4)YG

This command was introduced on the Cisco SOHO 76, 77, and 77H routers.


debug pppoe Command

The debug pppoe command provides information that is helpful for debugging PPPoE problems. The syntax of this command is shown below. To disable the debugging output, use the no form of this command.

debug pppoe [ data | errors | events | packets ]

no debug pppoe [ data | errors | events | packets ]

Syntax Description

data

Displays data packets of PPPoE sessions.

errors

Displays PPPoE protocol errors that prevent a session from being established, or displays errors that cause an established sessions to be closed.

events

Displays PPPoE protocol messages about events that are part of normal session establishment or shutdown.

packets

Displays each PPPoE protocol packet exchanged.


Default

None.

Command Mode

This command is available in Privileged mode.

Usage Guidelines

The debug commands typically display a large number of debug messages. These should generally be used only on a debug router with a single active session.

Command History

Release
Modification

Cisco IOS Release 12.2(4)YG

This command was introduced on the Cisco SOHO 76, 77, and 77H routers.


Configuration Instructions

This section contains configuration instructions for the SOHO 76,77, and 77H routers.

Configuring a Bridged RFC 1483 DHCP Client

Perform the following steps to configure bridged RFC 1483 DHCP client support:


Step 1 Configure the Bridge Group Virtual Interface (BVI) interface by entering the ip address dhcp client-id Ethernet 0 command.

Specifying the value client-id ethernet 0 means that the MAC address of the Ethernet interface will be used as the client ID when the DHCP request is sent. Otherwise, the MAC address of the BVI interface is used as the client ID.

Step 2 Configure Network Address Translation (NAT):

a. Configure the BVI interface by entering the ip nat outside command.

b. Configure the Ethernet interface by entering the ip nat inside command.

c. Create an access list under NAT by entering the access-list 1 permit ip address command to match all Ethernet IP addresses.

d. Configure the source list under NAT by entering the
ip nat inside source list 1 interface BVI 1 overload command.

Step 3 Configure the SOHO router to act as a Dynamic Host Configuration Protocol (DHCP) server. This step is optional.

a. At the (config-if)# router prompt, enter the ip dhcp pool server name command.

b. Enter the import all command to have the SOHO series router retrieve the Microsoft Windows name server (WINS) and Domain Name System (DNS) server addresses for name resolution.


Configuration Example

The following example shows a configuration of the DHCP client:

bridge irb
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
no ip directed-broadcast
ip nat inside
!
interface ATM0
no ip address
no ip directed-broadcast
no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
no ip directed-broadcast
pvc 1/35

!
encapsulation aal5snap
!
bridge-group 1

!
interface BVI1
ip address dhcp client-id Ethernet0

!
no ip directed-broadcast
ip nat outside

!
!

!
ip route 0.0.0.0 0.0.0.0 BVI1

!
access-list 1 permit 192.168.1.0 0.0.0.255

!
bridge 1 protocol ieee
bridge 1 route ip

Configuring a Bridged RFC 1483 Interface with a Static IP Address

Perform the following steps to configure the router for bridged RFC 1483 with a static IP address:


Step 1 Configure the BVI interface by entering the ip address static address 0 command.

Step 2 Configure NAT.

a. Configure the BVI interface by entering the ip nat outside command.

b. Configure the Ethernet interface by entering the ip nat inside command.

c. Create an access list under NAT by entering the access-list 1 permit ip address command to match all Ethernet IP addresses.

d. Configure the source list under NAT by entering the
ip nat inside source list 1 interface BVI 1 overload command.

e. Configure the static route command ip route 0.0.0.0 0.0.0.0 gateway-address, where gateway-address is provided by your service provider.

Step 3 Configure the router to act as a DHCP server. This step is optional.

a. At the (config-if)# router prompt, enter the ip dhcp pool server name command.

b. Enter the import all command to have the router retrieve the Microsoft Windows name server (WINS) and Domain Name System (DNS) server addresses for name resolution.


Configuration Example

The following example shows a bridged RFC 1483 configuration with a static IP address. The default gateway address is provided by your service provider.

bridge irb
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
no ip directed-broadcast
ip nat inside
!
interface ATM0
no ip address
no ip directed-broadcast
no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
no ip directed-broadcast
pvc 1/35

!
encapsulation aal5snap
!
bridge-group 1

!
interface BVI1
ip address 194.152.25.53 255.255.255.0

!
no ip directed-broadcast
ip nat outside

!
!

!
ip route 0.0.0.0 0.0.0.0 192.152.25.1

!
access-list 1 permit 192.168.1.0 0.0.0.255

!
bridge 1 protocol ieee
bridge 1 route ip

Configuring PPP over Ethernet

This feature supports the PPPoE client on an ATM permanent virtual circuit (PVC). Only one PPPoE client on a single ATM PVC is supported. Figure 1 shows a typical deployment scenario for PPPoE support.


Note The PPPoE configuration procedure and example in this section are different from those appearing in previous editions of this release note. The vpdn enable and vpdn group commands have been removed from the procedure and example because they are no longer supported on the SOHO 77 or SOHO 77H routers.


Figure 1 PPPoE Deployment Scenarios

A PPPoE session is initiated on the client side by the network shown in Figure 1. If the session has a timeout, or if it is disconnected, the PPPoE client immediately attempts to reestablish the session.

Follow these steps to configure the router for PPPoE client support:


Step 1 Configure the ATM interface with PPPoE support:

a. Configure the ATM interface by entering the interface atm 0 command.

b. Specify the ATM PVC by entering the pvc number command.

c. Configure the PPPoE client and specify the dialer interface to use for cloning by entering the pppoe-client dial-pool-number number command.

Step 2 Configure the dialer interface by entering the int dialer number command:

a. Configure the IP address as negotiated by entering the ip address negotiated command.

b. Configure authentication for your network by entering the ppp authentication protocol command. This step is optional.

c. Configure the dialer pool number by entering the dialer pool number command.

d. Configure the dialer-group number by entering the dialer-group number command.

e. Configure a dialer list for the dialer-group by entering the dialer-list 1 protocol ip permit command.


Note Multiple PPPoE clients can run on a different PVCs, in which case, each client has to use a separate dialer interface and a separate dialer pool, and the PPP parameters must be applied on the dialer interface.



If you enter the clear pppoe command with a PPPoE client session already established, the PPPoE client session terminates and the PPPoE client immediately tries to reestablish the session.

Configuration Example

The following example shows a configuration of a PPPoE client.

!
interface Ethernet0
 ip address 192.168.100.1 255.255.255.0
 ip nat inside
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 8/35 
  pppoe-client dial-pool-number 1
!
dsl operating-mode auto
hold-queue 224 in
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username sohodyn password 7 141B1309000528
!
ip nat inside source list 101 interface Dialer1 overload
ip route 0.0.0.0.0.0.0.0 Dialer1
access-list 101 permit ip 192.168.100.0.0.0.0.255 any
!

MMI Support

The Modem Management Interface (MMI) is software that enables auto-provisioning for the SOHO 76, 77, and 77H routers. The MMI uses a fixed PVC to communicate with the proxy element (PE) that resides on the digital subscriber line access multiplexer (DSLAM). Using MMI, the router updates the running image. Then the router downloads the prescribed configuration using a configuration file or configuration values in a provisioning information database.

Configuring MMI for Auto-Provisioning

The customer premises equipment (CPE) can be automatically configured by using the Cisco digital subscriber line (DSL) CPE download, but the CPE can be configured only with the image provisioning feature. The following provisioning configuration files are not supported:

profiles

Cisco DSL CPE Manager (CDCM) objects below the CPE level (that is, the ATM virtual channel connection [VCC] objects)

propVirtual objects and interface objects (ATMif and Ethernetif)

Follow these steps to configure the router for MMI support in configure-terminal mode:


Step 1 To set the configuration approach for MMI, enter one of the following commands:

mmi auto-configure

no mmi auto-configure

If the auto-configure parameter is enabled, the router is provisioned by the PE. By default, this parameter is enabled.

If the auto-configure parameter is disabled, the router is configured by the startup configuration file.

Step 2 To set the polling interval for the router to check the PE for any updated image or configuration files, enter the following command:

mmi polling-interval time

where time is the number of seconds. The polling-interval range is from 1 to 65535, with the default set to 60 seconds.

Step 3 To set the ATM PVC so the MMI communicates with the PE, enter the following command:

mmi pvc vpi/vci

where vpi/vci is the virtual path identifier/virtual channel identifier. The default PVC for MMI is 0/16 ilmi, but if it is not available, you must set the specific PVC for the router to communicate with the PE.

Step 4 To set the timer to monitor the image file download, enter the following command in configure terminal mode:

mmi snmp-timeout time

where time is 1 to 1800 seconds, which is the allowed interval for downloading any two consecutive blocks. If you enter the no mmi snmp-timeout command, the default time is set to 180 seconds.

Step 5 To eliminate the ADSL line training delay, enter the following command:

dsl operating-mode auto

If the DSLAM is using a Cisco 4xDMT ADI-based card, enter the following command:

dsl operating-mode ansi-dmt

Step 6 To set up the debug process for MMI, enter the following command:

debug mmi

Step 7 Save the configuration file to NVRAM, and enter the reload command. The router's OK LED on the front panel blinks while the image is being auto-provisioned. The PVC is set up when the reboot occurs.


MMI Configuration Example

The following example shows an MMI configuration:

SOHO-voice1#sh run
Building configuration...

Current configuration :947 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SOHO-voice1
!
no logging buffered
no logging buffered
logging rate-limit console 10 except errors
!
mmi polling-interval 1000
no mmi auto-configure
mmi pvc 0/16
debug mmi
ip subnet-zero
no ip finger
!
!
!
interface Ethernet0
	no ip address
shutdown
!
interface Virtual-Template1
	no ip address
!
interface ATM0
	no ip address
	pvc 0/101
!
	bundle-enable
	dsl operating-mode auto
ip classless
no ip http server
!
snmp-server manager
!
voice-port 1
!
voice-port 2
!
voice-port 3
!
voice-port 4
>
line con 0
	transport input none
	stopbits 1
line vty 0 4
	login
!
scheduler max-task-time 5000
end

Notes for the DSL Provider

To use the Cisco automated configuration solution with SOHO 76, 77 and SOHO 77H CPE, follow these steps:


Step 1 Enable the MMI configuration, as described in the "Configuring MMI for Auto-Provisioning" section.

Step 2 Ping from the DSLAM to the CPE to ensure the DSLAM is a PE host.

Step 3 Store the MMI configuration file on an FTP server that acts as the PE's image server.

Step 4 Use CDCM to add the configuration file to the PE's image table. The image file can also be added to the PE.

Step 5 Use CDCM to deploy the CPE. You can manually deploy it, or you can use autodiscovery to deploy multiple CPEs.

Step 6 Use CDCM to provision an image for each CPE, which will associate a specific configuration file to the CPE.


Obtaining Documentation and Submitting a Service Request

For information on obtaining documentation, submitting a service request, and gathering additional information, see the monthly What's New in Cisco Product Documentation, which also lists all new and revised Cisco technical documentation, at:

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html

Subscribe to the What's New in Cisco Product Documentation as a Really Simple Syndication (RSS) feed and set content to be delivered directly to your desktop using a reader application. The RSS feeds are a free service and Cisco currently supports RSS version 2.0.