Guest

Cisco Voice Feature Card VCWare

Cisco VCWare Version Checker

  • Viewing Options

  • PDF (141.9 KB)
  • Feedback
VCWare Version Checker

Table Of Contents

VCWare Version Checker

Feature Overview

Supported Platforms

Supported Standards, MIBs, and RFCs

Prerequisites

Monitoring and Maintaining

Cisco VCWare Version Checker Warning Output at Bootup

Update to show vfc version Output

Glossary


VCWare Version Checker


Feature History

Release
Modification

12.2(10)

This feature was introduced on the Cisco AS5300.

12.2(11)T

This feature was integrated into Cisco IOS Release 12.2(11)T



Note This document is still under development. Please revisit this site for future updates. 1/2/08


This document describes the VCWare Version Checker feature in Cisco IOS Release 12.2(11)T. This document includes the following sections:

Feature Overview

Supported Platforms

Supported Standards, MIBs, and RFCs

Prerequisites

Monitoring and Maintaining

Glossary

Feature Overview

This release adds version checker information output when you bootup and when you use the show vfc version vcware and show vfc version dspware commands. This new version checker feature detects possible mismatches between Cisco IOS software and Cisco VCWare and DSPWare. If a software mismatch is found, a compatibility mismatch advisory is ouput at bootup and when the show vfc version commands are used. If no mismatch is found, there is no advisory output. The new information is advisory only, so there is no action taken whether the software is compatible or incompatible.

Examples of the new version checker feature are shown in the following sections:

Cisco VCWare Version Checker Warning Output at Bootup

Update to show vfc version Output

Supported Platforms

Cisco AS5300

Determining Platform Support Through Cisco Feature Navigator

Cisco IOS software is packaged in feature sets that are supported on specific platforms. To get updated information regarding platform support for this feature, access Cisco Feature Navigator. Cisco Feature Navigator dynamically updates the list of supported platforms as new platform support is added for the feature.

Cisco Feature Navigator is a web-based tool that enables you to quickly determine which Cisco IOS software images support a specific set of features and which features are supported in a specific Cisco IOS image. You can search by feature or release. Under the release section, you can compare releases side by side to display both the features unique to each software release and the features in common.

To access Cisco Feature Navigator, you must have an account on Cisco.com. If you have forgotten or lost your account information, send a blank e-mail to cco-locksmith@cisco.com. An automatic check will verify that your e-mail address is registered with Cisco.com. If the check is successful, account details with a new random password will be e-mailed to you. Qualified users can establish an account on Cisco.com by following the directions found at this URL:

http://www.cisco.com/register

Cisco Feature Navigator is updated regularly when major Cisco IOS software releases and technology releases occur. For the most current information, go to the Cisco Feature Navigator home page at the following URL:

http://www.cisco.com/go/fn

Availability of Cisco IOS Software Images

Platform support for particular Cisco IOS software releases is dependent on the availability of the software images for those platforms. Software images for some platforms may be deferred, delayed, or changed without prior notice. For updated information about platform support and availability of software images for each Cisco IOS software release, refer to the online release notes or, if supported, Cisco Feature Navigator.

Supported Standards, MIBs, and RFCs

Standards

None

MIBs

None

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://tools.cisco.com/ITDIT/MIBS/servlet/index

If Cisco MIB Locator does not support the MIB information that you need, you can also obtain a list of supported MIBs and download MIBs from the Cisco MIBs page at the following URL:

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

To access Cisco MIB Locator, you must have an account on Cisco.com. If you have forgotten or lost your account information, send a blank e-mail to cco-locksmith@cisco.com. An automatic check will verify that your e-mail address is registered with Cisco.com. If the check is successful, account details with a new random password will be e-mailed to you. Qualified users can establish an account on Cisco.com by following the directions found at this URL:

http://www.cisco.com/register

RFCs

None

Prerequisites

Cisco IOS Release 12.2(11)T or a later release must be running.

Monitoring and Maintaining

Cisco VCWare Version Checker Warning Output at Bootup

The following is an example of the version checker warning message that appears when a mismatch of firmware and software is detected at bootup:

Firmware version mismatch for bundle AS5300 VCWare 
  - version found (11.17x (eng)) is higher than maximum allowed (10.xx) 
Firmware version mismatch for bundle AS5300 C549 
  - version found (4.1.17x) is higher than maximum allowed (4.0.xx)

Update to show vfc version Output

The following is sample ouput that shows compatible firmware and software when using the show vfc 1 version vcware command:

Router# show vfc 1 version vcware

Voice Feature Card in Slot 1:
     VCWare Version     : 7.35
     ROM Monitor Version: 1.3
     DSPWare Version    : 3.4.46L
     Technology         : C549
VCWare/DSPWare version compatibility OK

Table 1 describes the fields shown in the display.

Table 1 show vfc version vcware Field Descriptions 

Field
Description

Voice Feature Card in Slot 1

The voice feature card is in slot 1.

VCWare Version

The VCWare version shows 7.35, which is the required minimum for Cisco IOS Release 12.2(11)T or a later release.

ROM Monitor Version

The ROM monitor version shows 1.3.

DSPWare Version

The DSPWare version shows 3.4.46L, which is the required minimum for this release.

Technology

The technology shows C549. C549 technology is available to support either medium-complexity codecs or high-complexity codecs.

VCWare/DSPWare version compatibility

The Cisco VCWare and DSPWare versions are compatible with Cisco IOS Release software. VCWare/DSPWare version compatibility is OK or shows a mismatch.


The following is sample ouput that shows compatible firmware and software when using the show vfc 1 version dspware command:

Router# show vfc 1 version dspware

DSPWare version in VFC slot 1 is 3.4.46L
VCWare/DSPWare version compatibility OK

Table 2 describes the fields shown in the display.

Table 2 show vfc version dspware Field Descriptions 

Field
Description

DSPWare Version

The DSPWare version shows 3.4.46L, which is the required minimum for Cisco IOS Release 12.2(11)T or higher.

VCWare/DSPWare version compatibility

The Cisco VCWare and DSPWare versions are compatible with Cisco IOS Release software. VCWare/DSPWare version compatibility is OK or shows a mismatch.


If you were to enter an explicit request using the show vfc 1 version vcware command and the software were incompatible, the following output would be seen:

Router# show vfc 1 version vcware

Voice Feature Card in Slot 1:
     VCWare Version     : 6.04
     ROM Monitor Version: 1.3
     DSPWare Version    : 3.3.10L
     Technology         : C549
Firmware version mismatch for bundle AS5300 VCWare 
  - version found (6.04) is lower than minimum required (7.14)
Firmware version mismatch for bundle AS5300 C549 
  - version found (3.3.10L) is lower than minimum required (3.4.26L)

If you were to enter an explicit request using the show vfc 1 version dspware command and the software were incompatible, the following output would be seen:

Router# show vfc 1 version dspware

DSPWare version in VFC slot 1 is 3.3.10L
Firmware version mismatch for bundle AS5300 VCWare 
  - version found (6.04) is lower than minimum required (7.14)
Firmware version mismatch for bundle AS5300 C549 
  - version found (3.3.10L) is lower than minimum required (3.4.26L)

Glossary

DSPWare—digital signal processor (DSP) firmware.

VCWare—voice feature card software.Cisco VCWare supports modem and facsimile detection and Pulse Code Modulation (PCM) switchover with VoIP RealTime Transport Protocol (RTP) into platform-independent DSPWare.