Guest

Cisco Services-Ready Engine (SRE) Modules

Cisco ISR G2 Multi Gigabit Fabric

  • Viewing Options

  • PDF (377.3 KB)
  • Feedback
Cisco ISR G2 Multi Gigabit Fabric

Table Of Contents

Cisco ISR G2 Multi Gigabit Fabric

Contents

Information About MGF

Before You Configure MGF

MGF in Releases Earlier than Cisco IOS Release 15.1(3)T

MGF in Cisco IOS Release 15.1(3)T and Later Releases

Changes to the Running Configuration in Cisco IOS Release 15.1(3)T

Restrictions

Configuring the MGF Interface on the Cisco SRE in Cisco IOS Release 15.1(3)T and Later Releases

Configuring the MGF Interface on the Cisco SRE in Cisco IOS Release 15.1(3)T and Later Releases: Example

Cisco SRE Configuration

Cisco Enhanced EtherSwitch Service Module Configuration

Cisco Gigabit EtherSwitch EHWIC Configuration

Configuring MGF on Cisco Enhanced EtherSwitch Service Modules

Reconfiguring Existing MGF Interfaces

You Do Not Have to Reconfigure MGF Interfaces

You Have to Reconfigure MGF Interfaces

Additional References

Related Documents

Technical Assistance


Cisco ISR G2 Multi Gigabit Fabric


First Published: November 5, 2010
Last Updated: July 25, 2011

The Multi Gigabit Fabric (MGF) feature enables one or more modules in a router to communicate with each other without involving the router's CPU. The MGF feature is supported on the following modules:

Cisco SRE Internal Service Module-Services Ready Engine (Cisco SRE ISM)

Cisco SRE Service Module-Services Ready Engine (Cisco SRE SM)

Cisco Enhanced EtherSwitch Service Module (Cisco SM-ES and Cisco SM-ES-D)

This document describes MGF configuration on Cisco Integrated Services Routers Generation 2 (Cisco ISRs G2) running Cisco IOS Release 15.1(3)T or a later software release. For information about MGF configuration on Cisco ISR G2s running an earlier software release, see Cisco SRE Service Module Configuration and Installation Guide.

Contents

Information About MGF

Before You Configure MGF

Configuring the MGF Interface on the Cisco SRE in Cisco IOS Release 15.1(3)T and Later Releases

Configuring MGF on Cisco Enhanced EtherSwitch Service Modules

Reconfiguring Existing MGF Interfaces

Additional References

Information About MGF

The MGF is a GigabitEthernet switch that connects a number of devices within the router, including the modules listed at the beginning of this document, and the CPU. As shown in Figure 1, without MGF, all communication between devices within a router involves the CPU.

Figure 1 ISR-G2 Hardware Architecture before MGF

Using MGF offloads the CPU and allows it to be used for other purposes. Modules can communicate with each other without involving the router CPU. Figure 2 shows the communication between modules in a Cisco ISR G2 with MGF.

Figure 2 ISR-G2 Hardware Architecture with MGF

Figure 3 shows packet flow between applications on different modules over MGF.

Figure 3 Example Packet Flow over MGF

In releases earlier than Cisco IOS Release 15.1(3)T, the slot/1 interface is created and you can assign an IP address to the interface. You could then use High-Speed Intrachassis Module Interconnect (HIMI) connections or VLAN connections to connect different modules via the MGF switch.

In Cisco IOS Release 15.1(3)T and later releases, the behavior of the Cisco SRE SM modules is different. By default, the slot/1 interface is now managed by the switch-pm. As a result, the MGF interface behaves like a switch port and creates VLAN 1 by default. VLAN 1 is created by default when there are switch modules inserted into the router. The exception to this is that any Cisco EtherSwitch Service Modules will not create VLAN 1 by default because they have separate switch Cisco IOS software running as a separate entity.

HIMI connections are not supported on the MGF interfaces in Cisco IOS Release 15.1(3)T and later releases. If the router already has legacy switch modules Cisco EtherSwitch HWIC or Cisco EtherSwitch Network Module, the slot/1 interface behaves as in releases earlier than Cisco IOS Release 15.1(3)T and IP addresses can be assigned to the interfaces. HIMI or VLAN connections can be used to connect modules, as explained earlier.

Table 1 shows the compatibility between modules using MGF.

Table 1 Module to Module Compatibility Using MGF 

 
Cisco EtherSwitch Network Module and
Cisco EtherSwitch HWIC
Cisco Enhanced EtherSwitch Service Module

Cisco EtherSwitch Network Module and
Cisco EtherSwitch HWIC

Supported. Requires external stacking. Limited to two switch modules.

Supported. Needs external trunking, if desired; no need to connect together.

Cisco Enhanced EtherSwitch Service Module

Supported. Needs external trunking, if desired; no need to connect together.

Supported. Can trunk externally if desired.

Cisco SRE ISM and Cisco SRE SM

Not supported. SRE function is limited. The modules are not compatible.

Defaults to pre-Cisco IOS Release 15.1(3)T behavior.

Supported.


Table 2 shows the SKUs of the modules mentioned in this document.

Table 2 Module Names and SKUs

Module
SKU

Cisco EtherSwitch HWIC

HWIC-4ESW, HWIC-4ESW-C,

HWIC-D-9ESW, HWIC-D-9ESW-C

Cisco Gigabit Etherswitch EHWIC

EHWIC-4ESG, EHWIC-4ESG-P,

EHWIC-D-8ESG, EHWIC-D-8ESG-P

Cisco EtherSwitch Network Module

NM-16ESW

Cisco Enhanced EtherSwitch

SM-ES2-16-P, SM-ES3-16-P,

SM-ES3G-16-P, SM-ES2-24,

SM-ES2-24-P, SM-ES3-24-P,

SM-ES3G-24-P, SM-D-ES2-48,

SM-D-ES3-48-P, SM-D-ES3G-48-P

Cisco EtherSwitch Service Module

NME-16ES-1G, NME-16ES-1G-P, NME-X-23ES-1G, NME-X-23ES-1G-P, NME-XD-24ES-1S-P, NME-XD-48ES-2S-P


Before You Configure MGF

Configuration of the MGF feature changed in Cisco IOS Release 15.1(3)T. Before you configure MGF, you should understand the difference between configuring MGF in releases earlier than Cisco IOS Release 15.1(3)T and configuring MGF in Cisco IOS Release 15.1(3)T and later releases explained in the following sections.

MGF in Releases Earlier than Cisco IOS Release 15.1(3)T

MGF in Cisco IOS Release 15.1(3)T and Later Releases

Changes to the Running Configuration in Cisco IOS Release 15.1(3)T

Restrictions

MGF in Releases Earlier than Cisco IOS Release 15.1(3)T

In releases earlier than Cisco IOS Release 15.1(3)T, the MGF interface is a Layer 3 port, so you can configure an IP address on it. When the IP address is configured on the MGF interface, you can configure High-Speed Intrachassis Module Interconnect (HIMI) and VLAN connections to enable communications between devices within the router.

MGF in Cisco IOS Release 15.1(3)T and Later Releases

In Cisco IOS Release 15.1(3)T and later releases, the MGF interface is a Layer 2 port, so you cannot configure an IP address on it. The MGF interface is called interface sm slot/1 for SRE SM and ism 0/1 for SRE ISM. The MGF interface is called interface GigabitEthernet slot/1 for Cisco Enhanced EtherSwitch Service Modules. These interfaces are now Layer 2 interfaces; you can configure them in trunk mode to allow multiple VLAN traffic to flow. You can also configure these interfaces as access VLANs, which allows only one VLAN explicitly.

The MGF feature has two parts:

service-module mgf commands that are designed to be used with SRE SM and SRE ISM. For more information about these commands, see the Cisco IOS Interface and Hardware Component Command Reference:

http://www.cisco.com/en/US/docs/ios/interface/command/reference/ir_book.html

A Layer 2 switch interface for configuring trunk or access mode with SRE SM, SRE ISM, and Cisco Enhanced EtherSwitch Service Modules.

The MGF interface is a Layer 2 switch port which must be part of a VLAN. In releases earlier than Cisco IOS Release 15.1(3)T, you can configure an IP address on the MGF interface for SRE SM and SRE ISM only. In Cisco IOS Release 15.1(3)T and later releases, a default VLAN (VLAN 1) is created automatically. You configure an IP address on VLAN 1. On these Layer 2 interfaces, only limited commands are available to configure the switch mode as trunk or access. No other Layer 2 feature support is available unless it is explicitly mentioned in this document.

Changes to the Running Configuration in Cisco IOS Release 15.1(3)T

If your Cisco ISR G2 is running a release earlier than Cisco IOS Release 15.1(3)T and you have existing MGF interfaces configured, then you upgrade to Cisco IOS Release 15.1(3)T or a later release, the IP addresses configured for the slot/1 interface and any other configuration for that interface do not appear in the running configuration. The new default VLAN 1 configuration appears in the running configuration.

If your Cisco ISR G2 is running Cisco IOS Release 15.1(3)T or a later release and contains a Cisco Enhanced EtherSwitch Service Module, the new GigabitEthernet slot/1 interface and the new default VLAN 1 configuration appear in the running configuration.

Restrictions

The MGF feature is only available for the following modules:

Cisco SRE ISM

Cisco SRE SM

Cisco Enhanced EtherSwitch Service Module (Cisco SM-ES and Cisco SM-ES-D)

If Cisco EtherSwitch HWIC and Cisco EtherSwitch Network Module are not present in the system, no HIMI or VLAN connect is available for Cisco Enhanced EtherSwitch Service Module and SRE. You cannot use HIMI or VLAN connect with any Cisco EtherSwitch Service Module module in the system.

The maximum number of VLANs is 64, not including the native VLAN.

SMs can only use VLAN 1 as the native VLAN. This native restriction does not apply to Cisco Enhanced EtherSwitch Service Modules.

PVDMs cannot communicate with other modules even if they are on the same VLAN. Cisco Enhanced EtherSwitch Service Module and Cisco Gigabit EtherSwitch EHWIC ports can communicate without external cabling. Only Cisco 1941s support WLAN.

The service-module mgf commands are visible only when the Linux application supports the MGF feature. See your Linux application documentation to determine MGF support.

Creating VLANs and storing them in the VLAN database is the same as having a legacy switch module like the Cisco EtherSwitch HWIC and/or Cisco EtherSwitch Network Module.

If your router is running an earlier release of Cisco IOS than Cisco IOS Release 15.2(1)T,
Online Insertion and Removal (OIR) is not supported by the MGF feature on Cisco SRE  SM, Cisco SRE ISM, or Cisco Enhanced EtherSwitch Service Modules. When using one of these earlier releases of Cisco IOS, you must reload the router after OIR.

Configuring the MGF Interface on the Cisco SRE in Cisco IOS Release 15.1(3)T and Later Releases

This deployment scenario in which the router has only Cisco SRE SM, Cisco SRE ISM, and/or Cisco Enhanced EtherSwitch Service Modules is the most common.

The native VLAN is configured when the SRE MGF port is configured as trunk. The default native VLAN is VLAN 1. All VLAN configuration is performed on interface SM slot/1. Multiple IP addresses must be assigned to each VLAN.

Configuring the MGF Interface on the Cisco SRE in Cisco IOS Release 15.1(3)T and Later Releases: Example

SUMMARY STEPS

From the Host-Router CLI

1. enable

2. configure terminal

3. interface ism 0/0

or

interface sm 1/0

4. service-module mgf ip address module-side-ip-address subnet-mask

5. service-module mgf ip default-gateway gateway-ip-address

6. service-module mgf ip address module-side-ip-address subnet-mask vlan vlan-id

7. service-module mgf ip default-gateway gateway-ip-address vlan vlan-id

8. end

9. interface ism 0/1

or

interface sm 1/1

10. switchport mode trunk

11. end

12. interface ism 0/0

or

interface sm 2/0

13. service-module mgf ip address module-side-ip-address subnet-mask

14. service-module mgf ip default-gateway gateway-ip-address

15. service-module mgf ip address module-side-ip-address subnet-mask vlan vlan-id

16. service-module mgf ip default-gateway gateway-ip-address vlan vlan-id

17. end

18. interface ism 0/1

or

interface sm 2/1

19. switchport mode trunk

20. end

21. interface vlan 1

22. ip address ip-address mask

23. interface vlan 2

24. ip address ip-address mask

DETAILED STEPS

 
Command or Action
Purpose
 
From the Host-Router CLI

Step 1 

enable

password

Example:

Router> enable

Password: password

Router#

Enters privileged EXEC mode on the host router. Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode on the host router.

Step 3 

interface ism 0/0


or

interface sm 1/0

Example:

Router(config)# interface ism 0/0


or

Router(config)# interface sm 1/0

Enters interface configuration mode for the slot and port where the Cisco ISM-SRE resides.

or

Enters interface configuration mode for the slot and port where the Cisco SM-SRE resides.

Step 4 

service-module mgf ip address module-side-ip-address subnet-mask

Example:

Router(config-if)# service-module mgf ip address 10.0.0.2

Specifies the IP address for the module side of the interface.

This IP address is used by the native VLAN.

module-side-ip-address—IP address for the module.

subnet-mask—Subnet mask to append to the IP address; must be in the same subnet as the host router.

Step 5 

service-module mgf ip default-gateway gateway-ip-address

Example:

Router(config-if)# service-module mgf ip default-gateway 10.0.0.1

(Optional) Defines a default gateway (router) for a service module.

gateway-ip-address—IP address for the module.

The default gateway's IP address does not have to be in the same subnet as the IP address of the VLAN.

The default gateway's IP address must be reachable from the module.

Step 6 

service-module mgf ip address module-side-ip-address subnet-mask vlan vlan-id

Example:

Router(config-if)# service-module mgf ip address 10.2.0.2 vlan 2

Specifies the IP address for the module side of the interface for the VLAN specified.

module-side-ip-address—IP address for the module.

subnet-mask—Subnet mask to append to the IP address; must be in the same subnet as the host router.

vlan vlan-id—The number of the VLAN to be assigned. The valid range is from 2 to 4094.

Step 7 

service-module mgf ip default-gateway gateway-ip-address vlan vlan-id

Example:

Router(config-if)# service-module mgf ip default-gateway 10.2.0.1 vlan 2

(Optional) Defines a default gateway (router) for a service module.

gateway-ip-address—IP address for the module.

vlan vlan-id—The number of the VLAN to be assigned. The valid range is from 2 to 4094.

Step 8 

end

Example:

Router(config-if)# end

Returns to global configuration mode on the host router.

Step 9 

interface ism 0/1


or

interface sm 1/1

Example:

Router(config)# interface ism 0/1


or

Router(config)# interface sm 1/1

Enters interface configuration mode for the slot and port where the Cisco ISM-SRE resides.

or

Enters interface configuration mode for the slot and port where the Cisco SM-SRE resides.

Step 10 

switchport mode trunk

Example:

Router(config-if)# switchport mode trunk

Sets the interface type to trunking VLAN Layer 2.

Step 11 

end

Example:

Router(config-if)# end

Returns to global configuration mode on the host router.

Step 12 

interface ism 0/0


or

interface sm 2/0

Example:

Router(config)# interface ism 0/0


or

Router(config)# interface sm 2/0

Enters interface configuration mode for the slot and port where the Cisco ISM-SRE resides.

or

Enters interface configuration mode for the slot and port where the Cisco SM-SRE resides.

Step 13 

service-module mgf ip address module-side-ip-address subnet-mask

Example:

Router(config-if)# service-module mgf ip address 10.0.0.3

Specifies the IP address for the module side of the interface.

module-side-ip-address—IP address for the module.

subnet-mask—Subnet mask to append to the IP address; must be in the same subnet as the host router

Step 14 

service-module mgf ip default-gateway gateway-ip-address

Example:

Router(config-if)# service-module mgf ip default-gateway 10.0.0.1

(Optional) Defines a default gateway (router) for a service module.

gateway-ip-address—IP address for the module.

The default gateway's IP address does not have to be in the same subnet as the IP address of the VLAN.

The default gateway's IP address must be reachable from the module.

Step 15 

service-module mgf ip address module-side-ip-address subnet-mask vlan vlan-id

Example:

Router(config-if)# service-module mgf ip address 10.2.0.3 vlan 2

Specifies the IP address for the module side of the interface.

module-side-ip-address—IP address for the module.

subnet-mask—Subnet mask to append to the IP address; must be in the same subnet as the host router.

vlan vlan-id—The number of the VLAN to be assigned. The valid range is from 2 to 4094.

If vlan is not specified, the configuration is applied to the native VLAN.

Step 16 

service-module mgf ip default-gateway gateway-ip-address vlan vlan-id

Example:

Router(config-if)# service-module mgf ip default-gateway 10.2.0.1 vlan 2

(Optional) Defines a default gateway (router) for a service module.

gateway-ip-address—IP address for the module.

vlan vlan-id—The number of the VLAN to be assigned. The valid range is from 2 to 4094.

Step 17 

end

Example:

Router(config-if)# end

Returns to global configuration mode on the host router.

Step 18 

interface ism 0/1


or

interface sm 2/1

Example:

Router(config)# interface ism 0/1


or

Router(config)# interface sm 2/1

Enters interface configuration mode for the slot and port where the Cisco ISM-SRE resides.

or

Enters interface configuration mode for the slot and port where the Cisco SM-SRE resides.

Step 19 

switchport mode trunk

Example:

Router(config-if)# switchport mode trunk

Sets the interface type to trunking VLAN Layer 2.

Step 20 

end

Example:

Router(config-if)# end

Returns to global configuration mode on the host router.

Step 21 

interface vlan 1


Example:

Router(config)# interface vlan 1

Configures an interface type and enters interface configuration mode.

Step 22 

ip address ip-address mask

Example:

Router(config-if)# ip address 10.0.0.1 255.255.255.0

Sets a primary or secondary IP address for an interface.

Step 23 

interface vlan 2


Example:

Router(config)# interface vlan 2

Configures an interface type and enters interface configuration mode.

Step 24 

ip address ip-address mask

Example:

Router(config-if)# ip address 10.2.0.1 255.255.255.0

Sets a primary or secondary IP address for an interface.

Configuring the MGF Interface on the Cisco SRE in Cisco IOS Release 15.1(3)T and Later Releases: Example

Cisco SRE Configuration

Cisco Enhanced EtherSwitch Service Module Configuration

Cisco Gigabit EtherSwitch EHWIC Configuration

Cisco SRE Configuration

The following is the Cisco SRE configuration when Cisco EtherSwitch HWIC and Cisco EtherSwitch Network Module are not present in the network. In the following configuration, the SM1 interface is connected to the MGF on VLAN 1, and the SM2 interface is connected to the MGF on VLAN 2. Trunk mode is required because the SM is a member of multiple VLANs. The native VLAN defaults to 1.

! SM 1
interface SM 1/0
service-module mgf ip address 10.0.0.2
service-module mgf ip default-gateway 10.0.0.1
service-module mgf ip address 10.2.0.2 vlan 2
service-module mgf ip default-gateway 10.2.0.1 vlan 2

interface SM 1/1
switchport mode trunk

! SM 2
! Defining a default gateway is optional.
interface SM 2/0
service-module mgf ip address 10.0.0.3
service-module mgf ip default-gateway 10.0.0.1
service-module mgf ip address 10.2.0.3 vlan 2
service-module mgf ip default-gateway 10.2.0.1 vlan 2

interface SM 2/1
switchport mode trunk

! Common configuration at the router level
interface vlan 1
ip address 10.0.0.1 255.255.255.0

interface vlan 2
ip address 10.2.0.1 255.255.255.0

Cisco Enhanced EtherSwitch Service Module Configuration

The following is the Cisco Enhanced EtherSwitch Service Module configuration when Cisco EtherSwitch HWIC and Cisco EtherSwitch Network Module are not present in the network:

interface GigabitEthernet1/1
switchport mode trunk
! Cisco Enhanced EtherSwitch Service Module port 
! needs to be configured on Cisco Enhanced EtherSwitch Service Module
! side

! Common configuration at the router level
interface vlan 1
ip address 10.0.0.1 255.255.255.0

interface vlan 2
ip address 10.2.0.1 255.255.255.0

Cisco Gigabit EtherSwitch EHWIC Configuration

The following is the Cisco Gigabit EtherSwitch EHWIC configuration. Cisco EtherSwitch HWIC and Cisco EtherSwitch Network Module cannot be present in the network with Cisco Gigabit EtherSwitch EHWIC. Once legacy modules are inserted in the router, all the new MGF commands are no longer available.

! SM
interface SM 1/0
service-module mgf ip address 10.0.0.2
service-module mgf ip address 10.2.0.2 vlan 2

interface SM 1/1
switchport mode trunk

! Cisco Gigabit EtherSwitch EHWIC
interface GigabitEthernet 0/1/0
! Will communicate with application on VLAN 1 running on SRE in slot 1

interface GigabitEthernet 0/1/1
switchport access vlan 2
! Will communicate with application on VLAN 2 running on SRE in slot 1

interface GigabitEthernet 0/1/2
switchport mode trunk
! Will communicate with application on VLAN 1 & 2 running on SRE in slot 1

! Common configuration at the router level
interface vlan 1
ip address 10.0.0.1 255.255.255.0

interface vlan 2
ip address 10.2.0.1 255.255.255.0

Configuring MGF on Cisco Enhanced EtherSwitch Service Modules

On Cisco ISRs G2 running a release earlier than Cisco IOS Release 15.1(3)T, you cannot configure MGF on Cisco Enhanced EtherSwitch Service Modules from the Cisco IOS software command line. The MGF interface was hidden from the user.

On Cisco ISRs G2 running Cisco IOS Release 15.1(3)T and later software, you can use the newly created MGF interface to configure trunk or access mode so that the traffic generated from Cisco Enhanced EtherSwitch Service Modules can be directed to other Cisco Enhanced EtherSwitch Service Modules or the VLAN interface. To configure Cisco Enhanced EtherSwitch Service Modules, see the product documentation.

On Cisco ISRs G2 running Cisco IOS Release 15.1(3)T and later software releases, you may configure the port on the Cisco Enhanced EtherSwitch Service Module side as follows:

interface GigabitEthernet1/1
 switchport mode trunk

interface GigabitEthernet2/1
 switchport mode trunk

interface vlan 1
 ip address 10.0.0.1 255.255.255.0

interface vlan 2
 ip address 10.2.0.1 255.255.255.0

Reconfiguring Existing MGF Interfaces

Depending on the Cisco IOS software release your router is running, the release to which you upgrade, and the modules in your router, you may have to reconfigure existing MGF interfaces.

You Do Not Have to Reconfigure MGF Interfaces

In the following scenario, you do not have to reconfigure existing MGF interfaces:

If your Cisco ISR G2:

Is running a release earlier than Cisco IOS Release 15.1(3)T and

Has Cisco EtherSwitch HWICs or Cisco EtherSwitch Network Modules

and

You upgrade your Cisco ISR G2 to Cisco IOS Release 15.1(3)T or a later release and

You keep your Cisco EtherSwitch HWICs or Cisco EtherSwitch Network Modules

You do not have to reconfigure your MGF interfaces.

You Have to Reconfigure MGF Interfaces

In the following scenarios, you have to reconfigure existing MGF interfaces:

Scenario 1

If your Cisco ISR G2:

Is running a release earlier than Cisco IOS Release 15.1(3)T and

Has Cisco EtherSwitch HWICs or Cisco EtherSwitch Network Modules

and

You upgrade your Cisco ISR G2 to Cisco IOS Release 15.1(3)T or a later release and

You remove your Cisco EtherSwitch HWICs or Cisco EtherSwitch Network Modules

You have to reconfigure your MGF interfaces as described in the "Configuring the MGF Interface on the Cisco SRE in Cisco IOS Release 15.1(3)T and Later Releases" section.

Scenario 2

If your Cisco ISR G2:

Is running a release earlier than Cisco IOS Release 15.1(3)T and

Has no Cisco EtherSwitch HWICs or Cisco EtherSwitch Network Modules

and

You upgrade your Cisco ISR G2 to Cisco IOS Release 15.1(3)T or a later release

You have to reconfigure your MGF interfaces as described in the "Configuring the MGF Interface on the Cisco SRE in Cisco IOS Release 15.1(3)T and Later Releases" section.

Additional References

The following sections provide references related to the Cisco SM-SRE.

Related Documents


Technical Assistance

Description
Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

http://www.cisco.com/techsupport