Guest

Cisco Transceiver Modules

Configuring Gigabit Ethernet High-Speed WAN Interface Cards (EHWIC 1 GE-SFP-CU)

  • Viewing Options

  • PDF (280.4 KB)
  • Feedback
Configuring Gigabit Ethernet Enhanced High-Speed WAN Interface Cards

Table Of Contents

Configuring Gigabit Ethernet Enhanced High-Speed WAN Interface Cards

Contents

Prerequisites for the EHWIC 1 GE-SFP-CU

Restrictions for the EHWIC 1 GE-SFP-CU

Overview of the EHWIC 1 GE-SFP-CU

Feature History

Faceplate

LEDs

Configuring the EHWIC 1 GE-SFP-CU

Configuring Loopback

Configuration Examples for EHWIC 1 GE-SFP-CU

EHWIC 1 GE-SFP-CU Running Configuration

Show Controller Output

Show Interface Output

Configuring SFPs

Configuring Third-Party SFPs

Examples

Additional References

Standards

MIBs

RFCs

Technical Assistance


Configuring Gigabit Ethernet Enhanced High-Speed WAN Interface Cards


First Published: March 15, 2011

This document describes how to configure the Cisco Gigabit Ethernet enhanced high-speed WAN interface card (EHWIC). The EHWIC 1 GE-SFP-CU can be installed on the Cisco Integrated Services Routers Generation 2 (ISR G2) family platforms and has a dual-purpose uplink (DPU) that can run in small-form-factor pluggable (SFP) or copper mode. It supports the following features:

Digital Optical Monitoring (DOM)

Support for T1/E1 and T3/E3 SFPs

Support for the Ethernet passive optical network (EPON) SFP

EHWIC 1 GE-SFP-CU is the SKU for the single port EHWIC.

For a list of SFPs supported on the EHWIC 1 GE-SFP-CU, see Connecting Gigabit Ethernet High-Speed WAN Interface Cards document at the following URL: http://www.cisco.com/en/US/docs/routers/access/interfaces/ic/hardware/installation/guide/EHWIC_1_ GE_SFP_CU.html.

Finding Feature Information in This Module

Your Cisco IOS software release may not support all of the features documented in this module.

Finding Support Information for Platforms and Cisco IOS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.

Contents

Prerequisites for the EHWIC 1 GE-SFP-CU

Restrictions for the EHWIC 1 GE-SFP-CU

Overview of the EHWIC 1 GE-SFP-CU

Configuring the EHWIC 1 GE-SFP-CU

Configuring Loopback

Configuration Examples for EHWIC 1 GE-SFP-CU

Configuring SFPs

Configuring Third-Party SFPs

Additional References

Prerequisites for the EHWIC 1 GE-SFP-CU

This section lists the prerequisites for configuring the EHWIC 1 GE-SFP-CU.

Ensure that you have the appropriate Cisco access router to serve as the host router. The following Cisco access routers support EHWIC 1 GE-SFP-CU.

- Cisco 1921 ISR

- Cisco 1941 ISR

- Cisco 2901 ISR

- Cisco 2911 ISR

- Cisco 2921 ISR

- Cisco 2951 ISR

- Cisco 3925 ISR

- Cisco 3925E ISR

- Cisco 3945 ISR

- Cisco 3945E ISR

Use the show version command to ensure that the router is running Cisco IOS Release 15.1(4)M or later.


Note When minimum release requirements are met, you can change images on the router without affecting performance. Install the EHWIC 1 GE-SFP-CU on the router, using the directions provided in Installing Cisco Interface Cards in Cisco Access Routers and Cisco Network Modules and Interface Cards Regulatory Compliance and Safety Information.


Restrictions for the EHWIC 1 GE-SFP-CU

Online insertion and removal is not supported for EHWIC 1 GE-SFP-CU.

Overview of the EHWIC 1 GE-SFP-CU

The Cisco Gigabit Ethernet WAN EHWIC (EHWIC 1 GE-SFP-CU) is an enhanced high-speed interface card providing copper and optical Gigabit Ethernet ports and connectivity of T1/E1 and T3/E3 over optical for Cisco ISRs.

The EHWIC 1 GE-SFP-CU provides copper and optical Gigabit Ethernet connectivity through a dual-purpose uplink.


Note The EHWIC 1GE SFP CU provides maximum 800 Mbps unidirectional and 1600 Mbps bidirectional Ethernet throughput, but the actual throughput is limited by the platform.


The SFP slot supports Cisco certified copper or optical SFPs. For a list of supported SFPs, see Connecting Gigabit Ethernet High-Speed WAN Interface Cards.

The EHWIC 1GE SFP CU is a true routed port card. IP addresses can be directly configured on the EHWIC interface unlike SVI configurations in which the port is configured for VLAN trunking.

The Mean Time Between Failover(MTBF) for this module is 3162805 hours.

Feature History

Release
Modification

15.1(4)M

The feature was introduced.


Faceplate

Figure 1 shows the faceplate for the EHWIC 1 GE-SFP-CU.

Figure 1 Cisco EHWIC 1 GE-SFP-CU Faceplate

1

SFP EN LED, which shows connectivity to the router.

2

ACT LED, which shows TX/RX activity.

3

LNK LED, which shows link status.

4

SPD LED, which shows transmission speed.


LEDs

Table 1 lists the LEDs and describes their functionality and different states. The LEDs provide a visual indication of your available services.

Table 1

LED
Color
Description

SFP EN

Off

Not present.

Green

Present and enabled.

Amber

Present with failure.

ACT

Solid or blinking green

Blinks proportional to valid Ethernet traffic.

Off

No packet transfers are occurring.

LNK

Green

Solid green indicates the Ethernet port has a link partner.

SPD

Off

No link.

Green

Note Blink indicates port speed.

blinking

1 blink before pause—10 Mbps link speed.

2 blinks before pause—100 Mbps link speed.

3 blinks before pause—1000 Mbps link speed.


LED Indicators

Configuring the EHWIC 1 GE-SFP-CU

This section describes how to configure your EHWIC 1 GE-SFP-CU.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type slot/subslot/port number

4. ip address ip-address mask

5. shutdown

6. no shutdown

7. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal
Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface type slot/subslot/port number
Example:

Router(config)# interface ethernet 0/3/0

Enters the configuration mode for Ethernet transport on the EHWIC interface on the router.

Step 4 

ip address ip-address mask
Example:

Router(config-if)# ip address 192.168.12.2 255.255.255.0

Sets the IP address and subnet mask for the interface.

Step 5 

shutdown
Example:

Router(config-if)# shutdown

Disables the interface, changing its state from administratively up to administratively down.

Step 6 

no shutdown
Example:

Router(config-if)# no shutdown

Enables the interface, changing its state from administratively down to administratively up.

Step 7 

exit
Example:

Router(config-if)# exit

Router(config)#

Exits configuration mode and returns to global configuration mode.


Configuring Loopback

Use the loopback command in interface configuration mode to configure loopback. The

EHWIC 1 GE-SFP-CU supports MAC layer loopback and driver type loopback. The MAC loopback is used to detect MAC failure. The driver loopback is used to detect transceiver failure. Use the show interface to see the loopback mode and check if the hardware is functional.

Configuration Examples for EHWIC 1 GE-SFP-CU

This section provides the following configuration examples:

EHWIC 1 GE-SFP-CU Running Configuration

Show Controller Output

Show Interface Output

EHWIC 1 GE-SFP-CU Running Configuration

The following example shows the running configuration with the EHWIC 1 GE-SFP-CU on a Cisco 3945 ISR.

Router# sh run
Building configuration...
Current configuration : 2132 bytes
!
! Last configuration change at 01:33:00 PDT Tue Sep 28 2010
!
version 15.1
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
no service password-encryption
service internal
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no logging console
!
no aaa new-model
clock timezone PDT -7 0
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
crypto pki token default removal timeout 0
!
!
license udi pid CISCO3900-MPE140 sn FHH123000GX
license boot module c3900 technology-package securityk9
license boot module c3900 technology-package uck9
hw-module pvdm 0/0
!
hw-module sm 1
!
hw-module sm 2
!
 
   
!
!
!
redundancy
!
!
!
!
!
!
!
interface GigabitEthernet0/0 
no ip address 
duplex auto 
speed auto
!
interface GigabitEthernet0/1 
no ip address 
shutdown 
duplex auto 
speed auto
!
interface GigabitEthernet0/2 
no ip address 
duplex auto 
speed auto
!
interface GigabitEthernet0/3/0
!
interface GigabitEthernet0/3/1
!
interface GigabitEthernet0/3/2
!
interface GigabitEthernet0/3/3
!
interface GigabitEthernet0/0/0 
no ip address 
duplex auto 
speed auto 
media-type rj45
!
interface GigabitEthernet0/1/0 
no ip address 
media-type sfp
!
interface GigabitEthernet0/2/0 
ip address 192.168.205.20 255.255.255.0 
duplex full 
speed 100 
media-type sfp
!
interface GigabitEthernet1/0 
no ip address 
shutdown
!
interface GigabitEthernet2/0 
no ip address 
shutdown
!
interface Vlan1 
no ip address
!
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
logging esm config
!
!
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
line aux 0
line 67
no activation-character
no exec
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
flowcontrol software
line 131
no activation-character
no exec
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
login
transport input all
!
scheduler allocate 20000 1000
end
Router#
Router# show inventory
NAME: "CISCO3945", DESCR: "CISCO3945"
PID: CISCO3945 , VID: N/A , SN:
NAME: "CISCO3900-MPE140 Mother board 3GE, integrated VPN and 4W on Slot 0", DESCR: 
"CISCO3900-MPE140 Mother board 3GE, integrated VPN and 4W"
PID: CISCO3900-MPE140 , VID: V00 , SN: FHH123000GX
NAME: "Enhanced High Speed WAN Interface Card-1 Port Gigabit Ethernet SFP/Cu on Slot 0 
SubSlot 0", DESCR: "Enhanced High Speed WAN Interface Card-1 Port Gigabit Ethernet SFP/Cu"
PID: EHWIC-1GE-SFP-CU , VID: V00, SN: FOC14271QTW
NAME: "Enhanced High Speed WAN Interface Card-1 Port Gigabit Ethernet SFP/Cu on Slot 0 
SubSlot 1", DESCR: "Enhanced High Speed WAN Interface Card-1 Port Gigabit Ethernet SFP/Cu"
PID: EHWIC-1GE-SFP-CU , VID: V00, SN: FOC14271QT6
NAME: "Enhanced High Speed WAN Interface Card-1 Port Gigabit Ethernet SFP/Cu on Slot 0 
SubSlot 2", DESCR: "Enhanced High Speed WAN Interface Card-1 Port Gigabit Ethernet SFP/Cu"
PID: EHWIC-1GE-SFP-CU , VID: V00, SN: FOC14271QSD
NAME: "1000BASE-BX10U SFP", DESCR: "1000BASE-BX10U SFP"
PID: 9612C-SL10G-CIC , VID: 10 , SN: FBX14070404
NAME: "1000BASE-ZX SFP", DESCR: "1000BASE-ZX SFP"
PID: FTRJ1519P1BCL-CSA , VID: A , SN: FNS12200RA6
NAME: "4 Port GE POE EHWIC Switch on Slot 0 SubSlot 3", DESCR: "4 Port GE POE EHWIC 
Switch"
PID: EHWIC-4ESG-P , VID: 1.0, SN: FOC135146A3
NAME: "PVDMII DSP SIMM with four DSPs on Slot 0 SubSlot 4", DESCR: "PVDMII DSP SIMM with 
four DSPs"
PID: PVDM2-64 , VID: V01 , SN: FOC1052368L
NAME: "SM-ES3-24-P: EtherSwitch SM L3 + PoE + 23 10/100 + 1 10/100/1000 on Slot 1", DESCR: 
"SM-ES3-24-P: EtherSwitch SM L3 + PoE + 23 10/100 + 1 10/100/1000"
PID: SM-ES3-24-P , VID: V01 , SN: FOC14134LR0
NAME: "Network Module Adapter for SM Slot on Slot 2", DESCR: "Network Module Adapter for 
SM Slot"
PID: SM-NM ADPTR , VID: V00, SN: FOC12355UNC
NAME: "NME-16ES-1G-P: EtherSwitch SM 16 10/100T PoE + 1 GE on Slot 2", DESCR: 
"NME-16ES-1G-P: EtherSwitch SM 16 10/100T PoE + 1 GE"
PID: NME-16ES-1G-P , VID: V01 , SN: FOC11165VL6
NAME: "C3900 AC-POE Power Supply 2", DESCR: "C3900 AC-POE Power Supply 2"
PID: PWR-3945-AC , VID: V01 , SN: SON1224001T
Router#

Show Controller Output

The following example shows the output for the show controllers gigabitethernet command.

Router# show controllers gigabitEthernet 0/0/0
Interface GigabitEthernet0/0/0 (idb 0x308188DC)
network link is up, loopback is not set, type none, i/f is not throttled
= Media Fiber Optic =
FPGA/Board Version is 0x10000
== SFP Registers ==
Reg 0x00: 03 04 07 00 00 00 00 00
Reg 0x08: 00 00 00 02 01 00 0A 64
Reg 0x10: 00 00 00 00 43 49 53 43
Reg 0x18: 4F 2D 53 55 4D 49 54 4F
Reg 0x20: 4D 4F 20 20 00 00 00 5F
Reg 0x28: 53 43 50 36 38 30 33 2D
Reg 0x30: 43 31 2D 42 4D 20 20 20
Reg 0x38: 4E 20 20 20 05 1E 00 7E
Reg 0x40: 00 1A 00 00 45 43 4C 31
Reg 0x48: 32 33 31 30 36 34 35 20
Reg 0x50: 20 20 20 20 30 38 30 39
Reg 0x58: 30 33 34 39 00 00 00 C5
Reg 0x60: 2C 00 0B F6 11 4E BF D6
Reg 0x68: A9 F6 29 A1 55 92 A3 11
Reg 0x70: 09 EA 25 00 00 00 00 00
Reg 0x78: 00 00 00 00 69 C1 F2 AA
SFP Registers Decode:
identifier 0x03 (SFP)
connector 0x07 (LC)
sfp_transceiver_code 0x00 (-)
sfp_cisco_extended_id 0x2C (100BaseLX10)
encoding 0x02 (4B5B)
br_nominal (100MHz) 1
length_9km (100m) 10
length_9m (100m) 100
length_50m (100m) 0
length_62_5m (100m) 0
length_cu (10m) 0
vendor_name CISCO-SUMITOMO
vendor_oui 0x00 00 5F
vendor_pn SCP6803-C1-BM
vendor_rev N
cc_base 0x7E
options[0] 0x00000000
options[1] 0x0000001A
br_max (%) 0
br_min (%) 0
vendor_sn ECL12310645
date_code 08090349 (yymmddvv, v=vendor specific)
cc_ext 0xC5
Digital Diag Type 0x00 (Not available)
PHY Registers
-------------
Register 0x00: 1000 01CD 0362 5D12 0000 0000 0004 2001
Register 0x08: 0000 0000 0000 xxxx xxxx xxxx xxxx C000
Register 0x10: 0000 0001 0000 0000 0000 xxxx xxxx xxxx
Register 0x18: 73E7 1000 0000 FFFF 7C6B 0000 0000 0000
PHY Control (0x00):
AUTONEG_EN
PHY Status (0x01):
LINK_UP
Auto-Negotiation Advertisement (0x04):
Link Partner Ability (0x05):
1000BASE-T Control (0x09):
M/S_AUTO DTE
1000BASE-T Status (0x0A):
M/S_CFG_OK SLAVE
Mode Control Register(0x1C) shadow(0x1F): = 0x7C6B
Auto-Detect Medium Register(0x1C) shadow(0x1E): = 0x7866
Misc control Register(0x18) shadow(111): = 0x73E7
SGMII slave Register(0x1C) shadow(0x15): = 0x5768
Serdes 100FX control Register(0x1C) shadow(0x13): = 0x4C0B
Serdes 100FX Status Register(0x1C) shadow(0x11): = 0x4603
Register(0x1C) shadow(0x02): = 0xA03
Software MAC Address Filter (hash:length/addr/mask/hits)
--------------------------------------------------------
0x000: 0 ffff.ffff.ffff 0000.0000.0000 1
0x001: 0 3333.0000.0001 0000.0000.0000 0
0x002: 0 3333.0000.0002 0000.0000.0000 0
0x0C0: 0 0180.c200.0002 0000.0000.0000 0
0x0C0: 1 0100.0ccc.cccc 0000.0000.0000 3
0x0C5: 0 0180.c200.0007 0000.0000.0000 0
0x0D4: 0 3333.ffa2.912b 0000.0000.0000 0
0x0DC: 0 000f.f7a2.912b 0000.0000.0000 0
0x0FF: 0 3333.ff00.0000 0000.0000.0000 0
Software filtered frames: 0
Unicast overflow mode: 0
Multicast overflow mode: 1
Promiscuous mode: 0
Total Number of HW entries: 1
SFP LED Status: Green
===============
EHWIC-1GE-SFP Mac Rx Statistics:
=============================================
Bytes Received OK : 1084
Frames Received OK : 4
Frames Received with FCS Error : 0
GMAC Broadcast Frames Received OK : 1
GMAC Multicast Frames Received OK : 3
64 byte Frames Received OK : 1
65-127 byte Frames Received OK : 0
128-255 byte Frames Received OK : 0
256-511 byte Frames Received OK : 3
512-1023 byte Frames Received OK : 0
1024-Max_Frame_Size byte Frames Received OK : 0
Control Frames Received OK : 0
Out of Range Length/Type Fields : 0
VLAN Frames Received OK : 0
PAUSE Frames Received OK : 0
Control Frames with Bad Opcodes : 0
Oversized Frames Received : 0
Undersized Frames Received : 0
Fragment Frames Received : 0
In-Range Length Errors : 0
Alignment Errors Received : 0
Symbol Errors Received : 0
Internal MAC Errors : 0
EHWIC-1GE-SFP Mac Tx Statistics:
=============================================
Bytes Transmitted : 2997
Frames Transmitted OK : 22
Broadcast Frames Transmitted OK : 2
Multicast Frames Transmitted OK : 20
Underrun Error : 0
Control Frames Transmitted OK : 4
64 byte Frames Transmitted OK : 6
65-127 byte Frames Transmitted OK : 13
128-255 byte Frames Transmitted OK : 0
256-511 byte Frames Transmitted OK : 3
512-1023 byte Frames Transmitted OK : 0
1024-Max_Frame_Size byte Frames Transmitted OK : 0
VLAN Frames Transmitted OK : 0
PAUSE Frames Transmitted OK : 4
Oversized Frames Transmitted OK : 0
Single Collision Frames : 0
Multiple Collision Frames : 0
Deferred Frames : 0
Late Collision Frames : 0
Frames Aborted due to Excessive Collisions : 0
Carrier Sense Errors : 0
******* HWIC Common Registers at 10000000 *******
HWIC ID: 0x2
HWIC Revision: 0x0
HWIC Status: 0x0
HWIC DDR TXCRC:0x0
HWIC Control: 0xC080
DDR Enable 1 Software Reset 1
Interrupt Module Reset 0 GDF Module Reset 0
DMA Module Reset 0 Flow Control Reset 0
IRQ2 Global Int Mask 1 IRQ1 Global Int Mask 0
DDR TXCRC Int Mask 0 DDR TXClk Loss Int Mask 0
TX Fifo Overrun Int Mask 0
HWIC Interrupt Event: 0x0
DDR TXCRC Int 0 DDR TXClk Loss Int 0
TX Fifo Overrun Int 0
HWIC Diag 1: 0x0
HWIC Diag 2: 0x1C0F
******* HWIC Host Registers at 10FE0000 *******
Status (0x00):
Card Present Low 0 Graceful Stop Tx Complete 0
Config (0x00007322):
Hwic Reset 0 Hwic Host Reset 0
Hwic IRQ2 Type Net Hwic IRQ1 Type unknown
Rx Queue Watermark Enable 0 Auto XOFF When Full 0
Rx Int On Last 1 Graceful Stop Tx 0
Generic Rx Enable 0 Generic Tx Enable 0
DDR Enable 1 Loopback 0
Error Interrupt Enable (0x34DFF):
Rx Done Error Int 1 Card Present Change Int 1
Hwic Int Frame Error Int 0x04 Tx First Last Error Int 1
Tx Done Error Int 1 IRQ2 Int 0
IRQ1 Int 1 Host Specific Error Int 1
Rx Overrun Int 1 DDR RxClk Missing Int 1
Reg RW Timeout Int 1 Reg RW Error Int 1
Rx CRC Int 1 Rx Format Error Int 1
DMA Error Int 1
Management Interrupt Enable (0x6000):
Hwic Int Frame Mgmt Int 0x06
IRQ2 Int 0
IRQ1 Int 0 Graceful Stop Tx Int 0
Network Interrupt Enable (0x3C00):
Rx Frame Drop Int 1 Generic Frame Tx Int 1
Generic Frame Rx Int 1 DMA Write Int 1
IRQ2 Int 0 IRQ1 Int 0
Int Frame Network Int 0x00
Error Interrupt Event (0x0000):
Rx Done Error Event 0 Card Present Change Event 0
Hwic Int Frame Error Event 0x00 Tx First Last Error Event 0
Tx Done Error Event 0 IRQ2 Event 0
IRQ1 Event 0 Host Specific Error Event 0
Rx Overrun Event 0 DDR RxClk Missing Event 0
Reg RW Timeout Event 0 Reg RW Error Event 0
Rx CRC Event 0 Rx Format Error Event 0
DMA Error Event 0
Management Interrupt Event (0x1C0F):
Hwic Int Frame Mgmt Event 0x01
IRQ2 Int 0
IRQ1 Int 0 Graceful Stop Tx Event 1
Network Interrupt Event (0x0013):
Rx Frame Drop Event 0 Generic Frame Tx Event 0
Generic Frame Rx Event 0 DMA Write Event 0
IRQ2 Event 0 IRQ1 Event 0
Int Frame Network Event 0x13
HWICRegisterOffset 0x0000 HWICRegisterErrorAddress 0x00000000
HWICRegisterTimeout 0x0000C350
TxControlFrameCounter 0x0047F9 RxControlFrameCounter 0x004488
TxDataFrameCounter 0x000013 RxDataFrameCounter 0x000005
RegisterRWErrorCounter 0x0000 RxOverrunErrorCounter 0x0000
RxCRCErrorCounter 0x0000 RxFrameDropCounter 0x0000
TxBufferExtension 0x00 RxBufferExtension 0x00
HWICQueueBaseExtension 0x00 HWICQueueBase 0x0E01
TXQueueTailBase Register 0x7098
TxQueueBase 0x0E TxQueueTail 0x13
TxQueueSize 0x80 TxQueueHead 0x13
RxQueueHeadBase Register 0x7820
RxQueueBase 0x0F RxQueueHead 0x04
RxQueueSize 0x00 RxQueueTail 0x04
RxBufferSize 0x060C RxQueueHighWaterMark 0xC0
RxQueueLowWaterMark 0x40 DMAOffsetExtension 0x00
DMAOffset 0x0000 DMAWindow 0x0000
******* HWIC Rx/Tx Rings *******
rxr @(E017800) head (4) tail (2) entries (256) serviced (4)
txr @(E017000) head (19) tail (19) entries (128) serviced (19) count (0)
bd(E017800): flags 0000 length 0000 address 0E0180C0
bd(E017808): flags 0000 length 0000 address 0E018740
....................................................................
....................................................................
bd(E0173E8): flags 0001 length 0000 address 00000000
bd(E0173F0): flags 0001 length 0000 address 00000000
bd(E0173F8): flags 0001 length 0000 address 00000000
Router#

Show Interface Output

The following example show the output for the show interfaces gigabitethernet command.

Router# show interfaces gigabitEthernet 0/0/0
GigabitEthernet0/0/0 is up, line protocol is up
Hardware is EHWIC-1GE-SFP-CU, address is 000f.f7a2.912b (bia 000f.f7a2.912b)
Internet address is 1.1.1.2/24
MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive not set
Full Duplex, 100Mbps, media type is LX10
output flow-control is XON, input flow-control is XON
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:50, output 00:00:11, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
13 packets input, 4092 bytes, 0 no buffer
Received 13 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 0 multicast, 0 pause input
32 packets output, 7269 bytes, 0 underruns
0 output errors, 0 collisions, 3 interface resets
1 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out
Router#

Configuring SFPs

The SFP driver is responsible for periodically monitoring the SFP for any change in the SFP status or SFP type. Once an SFP module is detected, the SFP driver reads the contents of the SFP EEPROM cookie and validates the SFP. When a valid SFP is detected, the SFP speed and SFP duplex restrictions are applied on the PHY chip and reflected in Cisco CLI.

Configuring Third-Party SFPs

Small Form-Factor Pluggables (SFPs) that are not Cisco certified are called third-party SFPs. Cisco approved means the SFPs have undergone rigorous testing with Cisco products and the SFPs are guaranteed to have 100% compatibility.

Third-party SFPs are manufactured by companies that are not on the Cisco-approved Vendor List (AVL). Currently, Cisco ISR G2 routers support only Cisco-approved SFPs. From Release 15.3(2)T, Cisco ISR G2 routers recognize third-party SFPs.


Note Cisco does not provide any kind of support for the third-party SFPs because they are not validated by Cisco.


Restrictions

Supports only 100BASE SFPs and 1000BASE SFPs under two speed configurations:

100 Mbps speed for 100BASE SFPs

1000 Mbps speed for 1000BASE SFPs

Only the following routers and modules support third-party SFPs:

Cisco 2921 Integrated Services Router

Cisco 2951 Integrated Services Router

Cisco 3900 Integrated Services Router

Cisco 3900E Series Integrated Services Routers

Cisco 892-F Gigabit Ethernet Security Router

Cisco 898-EA Gigabit Ethernet Security Router

EHWIC-1GE-SFP

SUMMARY STEPS

1. enable

2. configure terminal

3. service unsupported-transceiver

4. interface type slot/subslot/port number

5. media-type sfp

6. speed value

7. shutdown

8. no shutdown

9. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables the privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters the global configuration mode.

Step 3 

service unsupported-transceiver

Example:

Router(config)# service unsupported-transceiver

Enables third-party SFP support.

Step 4 

interface type slot/subslot/port number

Example:

Router(config)# interface ethernet 0/3/0

Selects an interface to configure.

Step 5 

media-type sfp

Example:

Router(config-if)# media-type sfp

Changes media type to SFP.

Step 6 

speed value

Example:

Router(config-if)# speed 100

Configures the speed of the interface.

Note For 100BASE SFPs, configure the speed to 100 Mbps only. Similarly, for 1000BASE SFPs, configure the speed to 1000 Mbps only.

Step 7 

shutdown

Example:

Router(config-if)# shutdown

Disables the interface, changing its state from administratively UP to administratively DOWN.

Step 8 

no shutdown

Example:

Router(config-if)# no shutdown

Enables the interface, changing its state from administratively DOWN to administratively UP.

Step 9 

exit

Example:

Router(config-if)# exit

Router(config)#

Exits the configuration mode and returns the global configuration mode.


Examples

This example shows how to configure a third-party SFP on a Cisco ISR G2 Series Router:

Router# configure terminal 
Router(config-if)# service unsupported-transceiver
Router(config)# interface ethernet 0/3/0
Router(config-if)# media-type sfp
Router(config-if)# speed 100
Router(config-if)# shutdown 
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# exit
 
   

Additional References

The following sections provide references related to EHWIC 1 GE-SFP-CU.

Standards

Standard
Title

ITU G.8261

Timing distribution aspects through packet switched networks


MIBs

MIB
MIBs Link

OLD-CISCO-CHASSIS-MIB

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs

ENTITY-MIB(RFC 2737)

IF-MIB (RFC 2233)

ETHERLIKE-MIB (RFC 2665)

CISCO-ENTITY-SENSOR-MIB


RFCs

RFC
Title

No new or modified RFCs are supported by this feature, and support for existing RFCs have not been modified by this feature.

-


Technical Assistance

Description
Link

The Cisco Technical Support & Documentation website contains thousands of pages of searchable technical content, including links to products, technologies, solutions, technical tips, and tools. Registered Cisco.com users can log in from this page to access even more content.

http://www.cisco.com/techsupport


Any Internet Protocol (IP) addresses used in this document are not intended to be actual addresses. Any examples, command display output, and figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses in illustrative content is unintentional and coincidental.

©2011- 2013 Cisco Systems, Inc. All rights reserved.