Guest

Cisco High-Speed WAN Interface Cards

Configuring the Cisco 1-, 2-, and 4-port Serial Network Interface Modules for the Cisco 4400 Series ISRs

  • Viewing Options

  • PDF (382.3 KB)
  • Feedback

Table of Contents

Configuring the Cisco 1-, 2-, and 4-port Serial Network Interface Modules for Cisco 4400 Series ISRs

Information About the Cisco 1-, 2-, and 4-port Serial Network Interface Modules

Platform and Software Requirements

Supported Features

Cyclic Redundancy Checking

Timing Signals

Encapsulation Protocols

Configuring the Cisco 1-, 2-, and 4-port Serial Network Interface Modules

Configuring Required Features

Configuring Optional Features

Verifying the Configuration

Verifying Interface Port Connection

Verifying the Cisco 1-, 2-, and 4-port Serial NIM Connection Using the loopback Command

Verifying Using show commands

Additional References

Related Documents

MIBs

Technical Assistance

Configuring the Cisco 1-, 2-, and 4-port Serial Network Interface Modules for Cisco 4400 Series ISRs

July 21, 2014

OL-31531-01

This document provides information that you should know to perform the configuration tasks for configuring required and optional features of the Cisco 1-, 2-, and 4-port Serial Network Interface Modules on the Cisco 4400 Series Integrated Services Routers (ISRs). This document contains the following sections:

Information About the Cisco 1-, 2-, and 4-port Serial Network Interface Modules

The Cisco 1-port, 2-port, and 4-port Serial Network Interface Modules (NIMs) are multi-protocol synchronous serial NIMs supported on the Cisco 4400 Series ISRs. The Cisco 1-, 2-, and 4-port Serial NIMs expand the capabilities of the router to provide connectivity for synchronous interfaces in a wide range of applications including up to 8Mbps date rate for high speed high-level data link control (HDLC). These capabilities can be utilized as Point-to-Point Cisco HDLC WAN interface or frame relay interface. The Cisco 1-, 2-, and 4-port Serial NIM software is capable of anti-counterfeit protection and provides periodic system status information. The Cisco 1-, 2-, and 4-port Serial NIMs have their own serial communication controllers (SCCs) and they do not rely on the host platform for SCCs. For more information on the Cisco 1-, 2-, and 4-port Serial NIM LED and hardware features, see the Hardware Installation Guide .

Table 1 Cisco 1-port, 2-port, and 4-port Serial HWICs

Serial HWICs
SKUs
Connector Type
Number of Connectors
Ports per Connectors
Supported Interfaces
Maximum data rate per Port

1 port multi-protocol Synchronous Serial NIM

NIM-1T

12in1

1

1

V.35, RS232, X.21, RS449, RS530, RS530A

8Mbps

2 port multi-protocol Synchronous Serial NIM

NIM-2T

12in1

2

1

V.35, RS232, X.21, RS449, RS530, RS530A

8Mbps

4 port multi-protocol Synchronous Serial NIM

NIM-4T

12in1

4

1

V.35, RS232, X.21, RS449, RS530, RS530A

8Mbps

Platform and Software Requirements

The Cisco 1-, 2-, and 4-port Serial NIMs are supported on the Cisco 4400 Series ISRs and runs on the Cisco IOS XE Release 3.12S and later.

Supported Features

The following are the software features supported on the Cisco 1-, 2-, and 4-port Serial Network Interface Modules:

Cyclic Redundancy Checking

Cyclic redundancy checking (CRC) is an error-checking technique that uses a calculated numeric value to detect errors in transmitted data. All the Serial HWIC interfaces use a 16-bit frame check sequence (FCS) CRC by default. The sender of a data frame calculates the FCS. The sender appends the FCS value to the message before sending a frame.The receiver recalculates the FCS and compares its calculation to the FCS from the sender. If there is a difference between the two calculations, the receiver assumes that a transmission error occurred and sends a resend request to the sender. See the Step 4 for configuring CRC.

Timing Signals

The Cisco 1-, 2-, and 4-port Serial NIM interfaces support both the data terminal equipment (DTE) and data communication equipment (DCE) mode, depending on the mode of the compact serial cable attached to the port. To use a port as a DTE interface, you only need to connect a DTE compact serial cable to the port. When the system detects the DTE mode cable, it automatically uses the external timing signal. To use a port in DCE mode, you must connect a DCE compact serial cable and set the clock speed with the clock rate configuration command. See Step 4 for setting up a clock rate.

Encapsulation Protocols

Encapsulation protocols connect the layer- 2 (link layer) protocols with the layer-3 (network layer) protocols. When traffic crosses a WAN link, the connection needs a layer 2 protocol to encapsulate traffic. The Cisco 1-, 2-, and 4-port Serial NIM interfaces support the High-Level Data Link Control (HDLC), Point-to-point (PPP), and Frame Relay encapsulation protocols. The HDLC protocol, is the router proprietary protocol that decodes proprietary framing used by the routers on the PPP links. The standard PPP protocol supports the PPP links analyzed by the HDLC and can also be utilized for Frame Relay. The standard Frame Relay encapsulation protocol is a versatile and common encapsulation protocol used with Frame Relay. See Step 4 to set the encapsulation method.

Configuring the Cisco 1-, 2-, and 4-port Serial Network Interface Modules

This section contains the following sections:

Configuring Required Features

Prerequisites

  • You must properly install the Cisco 1-, 2-, and 4-port Serial Network Interface Modules on your router following the instructions provided in the Hardware Installation Guide.
  • You must confirm the Cisco 1-, 2-, and 4-port Serial Network Interface Modules are recognized by your router.

Restrictions

  • Only synchronous serial interfaces are supported.
  • Network timing interface is not supported
  • Only hdlc/ppp/frame-relay protocols are supported
  • Half duplex operation is not supported. Only the full duplex operation is supported.

Detailed Steps

Command
Purpose

Step 1

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 2

interface serial slot/subslot/port

 

Router(config)# interface serial 0/3/0

Selects the interface to configure and enters interface configuration mode.

  • slot/subslot/port—Specifies the location of the interface.

Step 3

ip address address mask

 

Router(config-if)# ip address 10.0.0.1 255.255.255.0

Sets the IP address and subnet mask.

  • address—IP address
  • mask—Subnet mask

Step 4

clock rate bps

 

Router(config-if)# clock rate 8000000

Configures the clock rate for the hardware to an acceptable bit rate per second (bps). Range is from 1200-8000000 bits per second.

Note The clock rate configuration is only applicable to the DCE interfaces.

Note The following clock rate options are supported: 1200, 2400, 4800, 9600, 14400, 19200, 28800, 32000, 38400, 48000, 56000, 57600, 64000, 72000, 115200, 125000, 148000, 192000, 250000, 256000, 384000, 500000, 512000, 768000, 800000, 1000000, 2000000, 4000000, 5300000, 8000000

Step 5

encapsulation {hdlc | ppp | frame-relay}

 

Router(config-if)# encapsulation {hdlc | ppp | frame-relay}

Sets the encapsulation type on the interface.

  • hdlc—High-Level Data Link Control (HDLC) protocol for serial interface. This is the default.
  • ppp—Point-to-Point Protocol (PPP).
  • frame-relay—Frame Relay.

Step 6

mtu bytes

 

Router(config-if)# mtu 1500

Configures the MTU size for the interface. Default is 1500 bytes.

  • bytes—The range is 64 to 8100.

Configuring Optional Features

This section provides you the information on configuring options features and the Cisco IOS XE commands required to configure these features:

Enhanced Object Tracking

On your serial NIM, you can enable the Enhanced Object Tracking (EOT) feature to consider the carrier-delay timer when tracking the status of an interface. The carrier-delay command in tracking configuration mode enables tracking to consider the carrier-delay timer configured on an interface. You can specify a period of time (in seconds) to delay communicating status change of a tracked interface.

 

Router(config)# track 3 interface ethernet 0/1 line-protocol

Router(config-track)# carrier-delay ?

<0-60> Carrier Transitions delay seconds

msec delay specified in milliseconds

Router(config-track)# delay up 30

 

Setting up NIM Bring up Time

You can set a specific amount of time for the router to wait before trying to bring up a NIM interface after the NIM goes down using the serial restart-delay command in the interface configuration mode.

 

Router(config-if)# serial restart-delay 500

NRZI Line-Coding Format

The serial NIM supports the non return to zero inverted (NRZI) line-coding format for signal transitions.NRZI uses relational encoding to interpret signals rather than determining absolute values. You can enable NRZI format using the nrzi-encoding command in the interface configuration mode.

 

Router(config-if)# nrzi-encoding

Enabling DTR Pulse-Time

You can enable the data terminal ready (DTR) pulse signal intervals on the serial interfaces using the pulse-time command in interface configuration mode. When the serial line protocol goes down (for example, because of loss of synchronization), the interface hardware is reset and the DTR signal is held inactive for at least the specified interval. Setting up the DTR pulse signal intervals is useful for handling encryption or other similar devices that use the toggling of the DTR signal to resynchronize.

 

Router(config-if)# pulse-time 3

Monitoring DSR As a Line Up/Down Indicator

When the serial interface is operating in DTE mode, by default, it monitors the Data Carrier Detect (DCD) signal as the line up/down indicator. The attached DCE device sends the DCD signal by default. When the DTE interface detects the DCD signal, it changes the state of the interface to up.

In some configurations, such as an the Synchronous Data Link Control (SDLC) multidrop environment, the DCE device sends the Data Set Ready (DSR) signal instead of the DCD signal, which prevents the interface from coming up. To tell the interface to monitor the DSR signal instead of the DCD signal as the line up/down indicator, configure the ignore dcd command in the interface configuration mode.

 

Router(config-if)# ignore dcd

Ignoring Input Signals

You can configure the ignore [cts|dcd|dsr|dtr|rts] command to ignore the incoming signals that may be flapping due to certain cabling issues. When the ignore [cts|dcd|dsr|dtr|rts] command is configured, a signal is automatically seen as asserted.

 

Router(config-if)# ignore [cts|dcd|dsr|dtr|rts]


NoteFor the For the ignore command, the availability of cts, dcd, dsr, dtr and rts keyword options depend on whether the interface is a DTE or DCE interface.


Inverting the Clock Signal

Systems that use long cables or cables that are not transmitting the TxC (clock) signal might experience high error rates when operating at higher transmission speeds. If a Serial NIM port is reporting a high number of error packets, a phase shift might be the problem; inverting the clock might correct this phase shift.

When the EIA/TIA-232 interface is a DTE, the invert-txclock command inverts the TxC signal the DTE receives from the remote DCE. When the EIA/TIA-232 interface is a DCE, the invert-txclock command inverts the clock signal to the remote DTE port. You can use the no invert-txclock command to change the clock signal back to its original phase.

 

Router(config-if)# invert txclock

Verifying the Configuration

Follow these tasks to verify your configuration:

Verifying Interface Port Connection

Using the ping command, you can verify that an interface port is functioning properly.

The ping command sends echo request packets out to a remote device at an IP address that you specify. After sending an echo request, the system waits a specified time for the remote device to reply. Each echo reply is displayed as an exclamation point (!) on the console terminal; each request that is not returned before the specified timeout is displayed as a period (.). A series of exclamation points (!!!!!) indicates a good connection; a series of periods (.....) or the messages [timed out] or [failed] indicate a bad connection.

Following is an example of a successful ping command to a remote server with the address 10.0.0.10:

Router# ping 10.0.0.10

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echoes to 10.0.0.10, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/15/64 ms

Router#

 

If the connection fails, verify that you have the correct IP address for the destination and that the device is active (powered on), and repeat the ping command.

Verifying the Cisco 1-, 2-, and 4-port Serial NIM Connection Using the loopback Command

You can run a loopback test using a loopback command in DCE mode to verify the connection between the peer router and the Serial NIM. When the loopback command is configured on a Cisco 1-port, 2-port, and 4-port Serial HWIC DCE serial port, any incoming data is looped back out on the transmit line. Also, any traffic sent from the Cisco 1-, 2-, and 4-port Serial NIM’s host router is looped back to itself without being processed by the NIM’s serial controller.


NoteOn a Cisco 1-, 2-, and 4-port Serial Network Interface Modules, the looback feature works as intended only when a serial interface is connected to a DCE cable. On a Cisco 1-, 2-, and 4-port Serial Network Interface Modules, the looback feature works as intended only when a serial interface is connected to a DCE cable.


F ollowing example shows loopback command configured under interface configuration mode:

Router(config-if)# loopback

Verifying Using show commands

You can use the output from the following show commands to verify your configuration:

show version

Router# show version

Cisco IOS XE Software, Version BLD_V154_2_S_XE312_THROTTLE_LATEST_20140205_020103

Cisco IOS Software, ISR4400 Software (X86_64_LINUX_IOSD-UNIVERSALK9-M), Experimental Version 15.4(20140205:045828) [v154_2_s_xe312_throttle-BLD-BLD_V154_2_S_XE312_THROTTLE_LATEST_20140205_020103-ios 202]

Copyright (c) 1986-2014 by Cisco Systems, Inc.

Compiled Wed 05-Feb-14 00:17 by ciscouser

 

Cisco IOS-XE software, Copyright (c) 2005-2014 by cisco Systems, Inc.

All rights reserved. Certain components of Cisco IOS-XE software are

licensed under the GNU General Public License (“GPL”) Version 2.0. The

software code licensed under GPL Version 2.0 is free software that comes

with ABSOLUTELY NO WARRANTY. You can redistribute and/or modify such

GPL code under the terms of GPL Version 2.0. For more details, see the

documentation or “License Notice” file accompanying the IOS-XE software,

or the applicable URL provided on the flyer accompanying the IOS-XE

software.

 

 

ROM: IOS-XE ROMMON

 

Router uptime is 1 hour, 27 minutes

Uptime for this control processor is 1 hour, 28 minutes

System returned to ROM by reload at 13:58:53 CST Mon Feb 10 2014

System restarted at 14:01:31 CST Mon Feb 10 2014

System image file is "bootflash:isr4400-universalk9.BLD_V154_2_S_XE312_THROTTLE_LATES"

Last reload reason: Reload Command

 

 

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

 

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

 

If you require further assistance please contact us by sending email to

export@cisco.com .

 

 

Technology Package License Information:

-----------------------------------------------------------------

Technology Technology-package Technology-package

Current Type Next reboot

------------------------------------------------------------------

appx appxk9 RightToUse appxk9

uc uck9 RightToUse uck9

security securityk9 RightToUse securityk9

ipbase ipbasek9 Permanent ipbasek9

 

cisco ISR4451-X/K9 (2RU) processor with 1376390K/6147K bytes of memory.

Processor board ID FGL17091013

4 Gigabit Ethernet interfaces

4 Serial interfaces

32768K bytes of non-volatile configuration memory.

4194304K bytes of physical memory.

7393215K bytes of flash memory at bootflash:.

 

Configuration register is 0x2102

show platform

Router# show platform

Chassis type: ISR4451-X/K9

 

Slot Type State Insert time (ago)

--------- ------------------- --------------------- -----------------

0 ISR4451-X/K9 ok 01:27:42

0/0 ISR4451-X-4x1GE ok 01:26:46

0/1 NIM-1T admin down 01:26:52

0/2 NIM-1T admin down 01:26:52

0/3 NIM-4T ok 00:27:49

1 ISR4451-X/K9 ok 01:27:42

2 ISR4451-X/K9 ok 01:27:42

R0 ISR4451-X/K9 ok, active 01:27:42

F0 ISR4451-X/K9 ok, active 01:27:42

P0 Unknown ps, fail never

P1 PWR-4450-AC ok 01:27:26

P2 ACS-4450-FANASSY ok 01:27:26

 

Slot CPLD Version Firmware Version

--------- ------------------- ---------------------------------------

0 13061029 12.2(20130629:014040) [ciscouser-ISR4...

1 13061029 12.2(20130629:014040) [ciscouser-ISR4...

2 13061029 12.2(20130629:014040) [ciscouser-ISR4...

R0 13061029 12.2(20130629:014040) [ciscouser-ISR4...

F0 13061029 12.2(20130629:014040) [ciscouser-ISR4...

 

show interfaces

Router# show interfaces serial 0/3/0

Serial0/3/0 is up, line protocol is up

Hardware is NIM-4T

Internet address is 11.1.4.1/24

MTU 1500 bytes, BW 8000 Kbit/sec, DLY 20000 usec,

reliability 255/255, txload 250/255, rxload 250/255

Encapsulation HDLC, loopback not set

Keepalive not set

Last input never, output 1d19h, output hang never

Last clearing of "show interface" counters never

Input queue: 0/375/0/0 (size/max/drops/flushes); Total output drops: 3184797855

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 7870000 bits/sec, 18920 packets/sec

5 minute output rate 7853000 bits/sec, 18876 packets/sec

2987797065 packets input, 155365447380 bytes, 0 no buffer

Received 0 broadcasts (0 IP multicasts)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

2983666535 packets output, 155150668066 bytes, 0 underruns

0 output errors, 0 collisions, 18 interface resets

0 unknown protocol drops

0 output buffer failures, 0 output buffers swapped out

1 carrier transitions

RTS up, CTS up, DTR up, DCD up, DSR up

 

 

show start (start up config)

Router# show startup-config

Using 5456 out of 33554432 bytes

!

! Last configuration change at 15:07:45 CST Mon Feb 10 2014

! NVRAM config last updated at 15:07:46 CST Mon Feb 10 2014

!

version 15.4

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

no platform punt-keepalive disable-kernel-core

platform shell

platform hardware throughput level 1000000

!

hostname Router-1

!

boot-start-marker

boot system bootflash:isr4400-universalk9.BLD_V154_2_S_XE312_THROTTLE_LATEST_20140205_020103.SSA.bin

boot-end-marker

!

aqm-register-fnf

!

vrf definition Mgmt-intf

!

address-family ipv4

exit-address-family

!

address-family ipv6

exit-address-family

!

logging buffered 10000000

!

no aaa new-model

clock timezone CST 8 0

!

!

!

!

!

!

!

!

!

 

 

no ip domain lookup

 

!

ip dhcp pool LOCAL

!

!

!

!

!

!

!

!

!

!

subscriber templating

!

frame-relay fast-restart

multilink bundle-name authenticated

!

!

!

!

!

!

!

!

!

!

!

!

!

license udi pid ISR4451-X/K9 sn FOC17042FJV

license accept end user agreement

license boot level appxk9

license boot level uck9

license boot level securityk9

hw-module subslot 0/1 shutdown unpowered

hw-module subslot 0/2 shutdown unpowered

spanning-tree extend system-id

!

!

redundancy

mode none

!

!

!

!

!

!

ip ftp source-interface GigabitEthernet0

ip ftp username root

ip ftp password cisco

!

class-map match-any serial

match protocol ftp

match protocol ftp-data

match protocol ftp-agent

match any

class-map match-all serial_mlp_low

match dscp af21

class-map match-all test

match any

class-map match-any serial1

match any

class-map match-all mlp_lfi

class-map match-all serial_mlp_high

match dscp af41

!

policy-map serial

class serial

priority level 2

policy-map serial1

class serial

priority level 1

policy-map serial_mlp

class serial_mlp_high

priority

class serial_mlp_low

policy-map test

class test

!

pseudowire-class fr_fr

encapsulation l2tpv3

ip local interface Loopback0

!

!

!

!

!

!

!

crypto isakmp performance

!

!

crypto ipsec transform-set serial ah-sha512-hmac esp-3des esp-sha-hmac

mode tunnel

!

!

!

!

!

!

!

!

!

interface Loopback0

ip address 192.168.1.1 255.255.255.0

!

interface Port-channel1

no ip address

no negotiation auto

service instance 1 ethernet

encapsulation untagged

bridge-domain 40

!

!

interface Port-channel2

no ip address

negotiation auto

service instance 1 ethernet

encapsulation untagged

bridge-domain 20

!

!

interface Multilink1

ip address 100.0.0.1 255.255.255.0

ip ospf 1 area 0

no keepalive

ppp multilink

ppp multilink interleave

ppp multilink group 1

ppp multilink fragment delay 10

ppp timeout multilink lost-fragment 0 10

service-policy output serial_mlp

!

interface Multilink2

ip address 101.1.1.1 255.255.255.0

ppp multilink

ppp multilink group 2

!

interface GigabitEthernet0/0/0

no ip address

negotiation auto

!

interface GigabitEthernet0/0/0.10

encapsulation dot1Q 10

ip address 1.1.1.1 255.255.255.0

no cdp enable

!

interface GigabitEthernet0/0/0.20

encapsulation dot1Q 20

ip address 1.2.1.1 255.255.255.0

no cdp enable

!

interface GigabitEthernet0/0/0.30

encapsulation dot1Q 30

ip address 1.3.1.1 255.255.255.0

no cdp enable

!

interface GigabitEthernet0/0/0.40

encapsulation dot1Q 40

ip address 1.4.1.1 255.255.255.0

no cdp enable

!

interface GigabitEthernet0/0/1

no ip address

negotiation auto

service instance 2 ethernet

encapsulation dot1q 20

bridge-domain 30

!

!

interface GigabitEthernet0/0/2

no ip address

shutdown

negotiation auto

!

interface GigabitEthernet0/0/3

no ip address

shutdown

negotiation auto

channel-group 2

!

interface Serial0/3/0

ip address 10.1.1.1 255.255.255.0

no keepalive

!

interface Serial0/3/1

ip address 11.1.1.1 255.255.255.0

no keepalive

!

interface Serial0/3/2

ip address 12.1.1.1 255.255.255.0

no keepalive

!

interface Serial0/3/3

ip address 13.1.1.1 255.255.255.0

no keepalive

!

interface GigabitEthernet0

vrf forwarding Mgmt-intf

ip address 10.74.30.216 255.255.255.0

negotiation auto

!

router ospf 1

network 1.1.1.0 0.0.0.255 area 0

network 8.8.8.0 0.0.0.255 area 0

!

ip forward-protocol nd

no ip http server

no ip http secure-server

ip route 2.1.1.0 255.255.255.0 Serial0/3/0

ip route vrf Mgmt-intf 0.0.0.0 0.0.0.0 10.74.30.1

!

!

arp 200.1.1.2 00c0.0100.0002 ARPA

arp 102.0.0.12 00c0.0200.0001 ARPA

!

snmp-server community public RO

!

!

control-plane

!

!

!

!

!

!

mgcp behavior rsip-range tgcp-only

mgcp behavior comedia-role none

mgcp behavior comedia-check-media-src disable

mgcp behavior comedia-sdp-force disable

!

mgcp profile default

!

!

!

!

!

alias exec shell request platform software system shell

alias exec shfirm1 show platform software subslot 0/1 module firmware

alias exec shfirm2 show platform software subslot 0/2 module firmware

alias exec shfirm3 show platform software subslot 0/3 module firmware

alias exec shdrop show platform hardware qfp active statistics drop

alias exec bqs show plat hard qfp ac infras bqs sche output default interf Serial

alias exec ship show ip int bri

alias exec shfp show plat soft object-m f0 statistic

!

line con 0

exec-timeout 0 0

privilege level 15

length 0

stopbits 1

line aux 0

stopbits 1

line vty 0 4

exec-timeout 20 0

privilege level 15

no login

length 0

line vty 5 6

exec-timeout 0 0

privilege level 15

no login

length 0

!

monitor event-trace voip ccsip max-dump-limit 1000000

ntp source GigabitEthernet0

ntp peer 10.75.221.108

ntp server vrf Mgmt-intf 10.75.221.108

!

end

 

show run (running configuration)

Router# show run

Building configuration...

 

Current configuration : 5585 bytes

!

! Last configuration change at 15:28:40 CST Mon Feb 10 2014

! NVRAM config last updated at 15:07:46 CST Mon Feb 10 2014

!

version 15.4

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

no platform punt-keepalive disable-kernel-core

platform shell

platform hardware throughput level 1000000

!

hostname Router-1

!

boot-start-marker

boot system bootflash:isr4400-universalk9.BLD_V154_2_S_XE312_THROTTLE_LATEST_20140205_020103.SSA.bin

boot-end-marker

!

aqm-register-fnf

!

vrf definition Mgmt-intf

!

address-family ipv4

exit-address-family

!

address-family ipv6

exit-address-family

!

logging buffered 10000000

!

no aaa new-model

clock timezone CST 8 0

!

!

!

!

!

!

!

!

!

 

 

no ip domain lookup

 

!

ip dhcp pool LOCAL

!

!

!

!

!

!

!

!

!

!

subscriber templating

!

frame-relay fast-restart

multilink bundle-name authenticated

!

!

!

!

!

!

!

!

!

!

!

!

!

license udi pid ISR4451-X/K9 sn FOC17042FJV

license accept end user agreement

license boot level appxk9

license boot level uck9

license boot level securityk9

hw-module subslot 0/1 shutdown unpowered

hw-module subslot 0/2 shutdown unpowered

spanning-tree extend system-id

!

!

redundancy

mode none

!

!

!

!

!

!

ip ftp source-interface GigabitEthernet0

ip ftp username root

ip ftp password cisco

!

class-map match-any serial_nim

match protocol ftp

match protocol ftp-data

match protocol ftp-agent

match any

class-map match-all serial_nim_mlp_low

match dscp af21

class-map match-all test

match any

class-map match-any serial_nim1

match any

class-map match-all mlp_lfi

class-map match-all serial_mlp_high

match dscp af41

!

policy-map serial

class serial_nim

priority level 2

policy-map serial_nim1

class serial_nim

priority level 1

policy-map serial_mlp

class serial_nim_mlp_high

priority

class serial_mlp_low

policy-map test

class test

!

pseudowire-class fr_fr

encapsulation l2tpv3

ip local interface Loopback0

!

!

!

!

!

!

!

crypto isakmp performance

!

!

crypto ipsec transform-set serial ah-sha512-hmac esp-3des esp-sha-hmac

mode tunnel

!

!

!

!

!

!

!

!

!

interface Loopback0

ip address 192.168.1.1 255.255.255.0

!

interface Port-channel1

no ip address

no negotiation auto

service instance 1 ethernet

encapsulation untagged

bridge-domain 40

!

!

interface Port-channel2

no ip address

negotiation auto

service instance 1 ethernet

encapsulation untagged

bridge-domain 20

!

!

interface Multilink1

ip address 100.0.0.1 255.255.255.0

ip ospf 1 area 0

no keepalive

ppp multilink

ppp multilink interleave

ppp multilink group 1

ppp multilink fragment delay 10

ppp timeout multilink lost-fragment 0 10

service-policy output serial_mlp

!

interface Multilink2

ip address 101.1.1.1 255.255.255.0

ppp multilink

ppp multilink group 2

!

interface GigabitEthernet0/0/0

no ip address

negotiation auto

!

interface GigabitEthernet0/0/0.10

encapsulation dot1Q 10

ip address 1.1.1.1 255.255.255.0

no cdp enable

!

interface GigabitEthernet0/0/0.20

encapsulation dot1Q 20

ip address 1.2.1.1 255.255.255.0

no cdp enable

!

interface GigabitEthernet0/0/0.30

encapsulation dot1Q 30

ip address 1.3.1.1 255.255.255.0

no cdp enable

!

interface GigabitEthernet0/0/0.40

encapsulation dot1Q 40

ip address 1.4.1.1 255.255.255.0

no cdp enable

!

interface GigabitEthernet0/0/1

no ip address

negotiation auto

service instance 2 ethernet

encapsulation dot1q 20

bridge-domain 30

!

!

interface GigabitEthernet0/0/2

no ip address

shutdown

negotiation auto

!

interface GigabitEthernet0/0/3

no ip address

shutdown

negotiation auto

channel-group 2

!

interface Serial0/3/0

ip address 10.1.1.1 255.255.255.0

no keepalive

!

interface Serial0/3/1

ip address 11.1.1.1 255.255.255.0

no keepalive

!

interface Serial0/3/2

ip address 12.1.1.1 255.255.255.0

no keepalive

!

interface Serial0/3/3

ip address 13.1.1.1 255.255.255.0

no keepalive

!

interface GigabitEthernet0

vrf forwarding Mgmt-intf

ip address 10.74.30.216 255.255.255.0

negotiation auto

!

router ospf 1

network 1.1.1.0 0.0.0.255 area 0

network 8.8.8.0 0.0.0.255 area 0

!

ip forward-protocol nd

no ip http server

no ip http secure-server

ip route 2.1.1.0 255.255.255.0 Serial0/3/0

ip route 2.2.1.0 255.255.255.0 Serial0/3/1

ip route 2.3.1.0 255.255.255.0 Serial0/3/2

ip route 2.4.1.0 255.255.255.0 Serial0/3/3

ip route vrf Mgmt-intf 0.0.0.0 0.0.0.0 10.74.30.1

!

!

arp 200.1.1.2 00c0.0100.0002 ARPA

arp 102.0.0.12 00c0.0200.0001 ARPA

!

snmp-server community public RO

!

!

control-plane

!

!

!

!

!

!

mgcp behavior rsip-range tgcp-only

mgcp behavior comedia-role none

mgcp behavior comedia-check-media-src disable

mgcp behavior comedia-sdp-force disable

!

mgcp profile default

!

!

!

!

!

alias exec shell request platform software system shell

alias exec shfirm1 show platform software subslot 0/1 module firmware

alias exec shfirm2 show platform software subslot 0/2 module firmware

alias exec shfirm3 show platform software subslot 0/3 module firmware

alias exec shdrop show platform hardware qfp active statistics drop

alias exec bqs show plat hard qfp ac infras bqs sche output default interf Serial

alias exec ship show ip int bri

alias exec shfp show plat soft object-m f0 statistic

!

line con 0

exec-timeout 0 0

privilege level 15

length 0

stopbits 1

line aux 0

stopbits 1

line vty 0 4

exec-timeout 20 0

privilege level 15

no login

length 0

line vty 5 6

exec-timeout 0 0

privilege level 15

no login

length 0

!

monitor event-trace voip ccsip max-dump-limit 1000000

ntp source GigabitEthernet0

ntp peer 10.75.221.108

ntp server vrf Mgmt-intf 10.75.221.108

!

end

Additional References

Related Documents

Related Topic
Document Title

Information about Installing the Cisco 1-, 2-, and 4-port Serial Network Interface Modules.

Installing the Cisco 1-, 2-, and 4-port Serial Network Interface Modules for Cisco 4400 Series ISRs

Information on installing the Cisco 4400 Series Integrated Services Router

Hardware Installation Guide for the Cisco 4400 Series Integrated Services Router

Information on configuring Cisco 4400 Series Integrated Services Routers

Software Configuration Guide for the Cisco 4400 Series Integrated Services Router

Information on Interface Commands.

Cisco IOS Interface and Hardware Component Command Reference

Regulatory compliance and safety information

Cisco Network Modules and Interface Cards Regulatory Compliance and Safety Information

MIBs

MIB
MIBs Link
  • OLD-CISCO-CHASSIS-MIB
  • CISCO-ENTITY-VENDORTYPE-OID-MIB
  • CISCO-PRODUCTS-MIB

To locate and download MIBs for selected platforms, Cisco software releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs

Technical Assistance

Description
Link

Technical Assistance Center (TAC) home page, containing 30,000 pages of searchable technical content, including links to products, technologies, solutions, technical tips, and tools. Registered Cisco.com users can log in from this page to access even more content.

http://www.cisco.com/public/support/tac/home.shtml