Guest

Cisco 800 Series Routers

Release Notes for C881G-U-K9

  • Viewing Options

  • PDF (409.4 KB)
  • Feedback
Release Notes for Cisco C881G-U-K9

Table Of Contents

Release Notes for Cisco C881G-U-K9

Contents

Introduction

New Features

Dual SIM

GPS

SMS

3G WWAN MIB Persistence

Remotely Initiated Data Call Back Using SMS

List of New Commands

Obtaining Documentation and Submitting a Service Request


Release Notes for Cisco C881G-U-K9


First Published: May 30, 2011
Release: Cisco IOS Release 15.1(4)M or later releases
OL-24268-01

Contents

Introduction

New Features

List of New Commands

Introduction

This document describes the release features of the Universal High Speed Packet Access (HSPA-U) version of the Cisco C881G Series Integrated Services Router (ISR). The C881G-U-K9 ISR comes with an embedded modem. This modem is a multiband, multiservice WAN modem for use over GSM networks.

For more information about this release, see www.cisco.com/go/3g.

New Features

This section describes the new features in this release.

Dual SIM

SMS

GPS

3G WWAN MIB Persistence

Remotely Initiated Data Call Back Using SMS

Dual SIM

The Dual SIM feature implements auto-switch and failover between two cellular networks on a C881G-U-K9 ISR. This feature is enabled by default with SIM slot 0 being the primary slot and slot 1 being the secondary (failover) slot.

The GPS feature provides the following commands:

Command
Syntax
Description

gsm failovertimer

gsm failovertimer <1-7>

Sets the failover timer in minutes.

gsm sim authenticate

gsm sim authenticate <0,7> <pin> slot <0-1>

Verifies the SIM CHV1 code.

gsm sim max-retry

gsm sim max-retry <0-65535>

Specifies the maximum number of failover retries. The default value is 10.

gsm sim primary slot

gsm sim primary slot <0-1>

Modifies the primary slot assignment.

gsm sim profile

gsm sim profile <1-16> slot <0-1>

Configures the SIM profile.


Note the following:

For auto-switch and failover to work, configure the SIM profile for slots 0 and 1 using the gsm sim profile command.

For auto-switch and failover to work, configure the chat script without a specific profile number.

If no SIM profile is configured, profile #1 is used by default.

If no GSM failover timer is configured, the default failover timeout is 2 minutes.

If no GSM SIM primary slot is configured, the default primary SIM is slot 0.

This example shows you how to set SIM switchover the timeout period to 3 minutes:

router#conf t
router(config-controller)# gsm failovertimer 3

This example shows you how to authenticate using an unencrypted pin:

router(config-controller)#gsm sim authenticate 0 1234 slot 0

This example shows you how to set the maximum number of SIM switchover retries to 20:

router(config-controller)#gsm sim max-retry 20

This example shows you how to set SIM slot 1 as the primary slot:

router(config-controller)#gsm sim primary slot 1

This example shows you how to configure the SIM card in slot 0 to use profile 10:

router(config-controller)#gsm sim profile 10 slot 0

GPS

The GPS feature provides the following commands:

Command
Syntax
Description

cdma gps mode

gsm gps mode standalone

Enables the GPS standalone mode.

cdma gps nmea

gsm gps nmea

Enables the NMEA mode.

show cellular gps

show cellular unit gps

Displays a summary of GPS data.

show cellular unit gps detail

Displays a detailed list of GPS data.


In the syntax of these commands, the value of the unit parameter refers is:

(EHWIC-3G-HSPA-U) The router slot, WAN interface card (WIC) slot, and port separated by slashes (for example, 0/1/0).

(C881G-U-K9) The number 0.

These examples show how to enable GPS standalone and NMEA for EHWIC-3G-HSPA-U:

router(config)#controller cellular 0/0
router(config-controller)#gsm gps mode standalone
...
controller Cellular 0/0
 gsm gps mode standalone 
!

router(config-controller)#gsm gps nmea
...
controller Cellular 0/0
 gsm gps nmea            
!

These examples show how to display summary and detailed GPS data for C881G-U-K9:

router#show cellular 0 gps 
GPS Info
-------------
GPS State: GPS enabled
GPS Mode Configured: standalone
Latitude: 37 Deg 24 Min 59 Sec North
Longitude: 121 Deg 55 Min 8 Sec West
Timestamp (GMT): Thu Jul 29 11:08:39 2010
Fix type: 3D, Height: -6 m
Heading: 408, Velocity Horiz: 3, Velocity Vert: 0
Satellite Info
----------------
Satellite #13, elevation 75, azimuth 46, SNR 21 
...

router#show cellular 0 gps detail
GPS Info
-------------
GPS State: GPS enabled
GPS Mode Configured: standalone
Latitude: 37 Deg 24 Min 59 Sec North
Longitude: 121 Deg 55 Min 7 Sec West
Timestamp (GMT): Thu Jul 29 22:17:57 2010
Fix type: 3D, Height: 12 m
Heading: 0, Velocity Horiz: 0, Velocity Vert: 0
HEPE: 2680 cm
Uncertainty Info:
  Angle: 0 deg, A: 24 m, Position: 12 m, Vertical: 12 m
Satellite Info
----------------
Satellite #7, elevation 16, azimuth 123, SNR 14 *
...


Note Obtaining a GPS-fixed location requires a supported GPS antenna to be connected to the DIV/GPS port.



Note Obtaining a GPS-fixed location using the Standalone mode can take up to 12 minutes. This depends on the location and type of antenna used.


SMS

The SMS feature enables the router to send and receive SMS messages. This feature also enables the router to save and store the SMS messages in an FTP server.


Note SMS is enabled by default. However, you need to define the FTP server to store incoming and outgoing SMS messages.


The SMS feature provides the following commands:

Command
Syntax
Description

cellular cdma sms send

cellular unit gsm sms send telNum message

Sends SMS messages (up to 160 characters per message).

cellular cdma sms delete

cellular unit gsm sms delete {all | msg_ID}

Deletes SMS messages.

cellular cdma sms view

cellular unit gsm sms view {summary | all | msg_ID}

Displays SMS messages.

cdma sms archive path

gsm sms archive path ftp:path_to_FTP_server

Saves SMS messages on an FTP server.


In the syntax of these commands, the value of the unit parameter refers is:

(EHWIC) The router slot, WIC slot, and port separated by slashes (for example, 0/1/0).

(C881G-U-K9) The number 0.



Note You can use the call screening command dialer caller number callback to authenticate SMS messages that you can use to establish data connections.


This example shows you how to send an SMS message (C881G-U-K9):

router#cellular 0 gsm sms send <phone number> "Test message"

This example deletes all SMS messages (EHWIC-3G-HSPA-U):

router#cellular 0/1/0 gsm sms delete all

This example shows you how to display a summary of SMS messages (EHWIC-3G-HSPA-U):

router#cellular 0/1/0 gsm sms view summary 
ID   FROM                  YY/MM/DD HR:MN:SC  SIZE  CONTENT
0    4087993680            10/05/04 21:29:55  32    from John ...
1    4087993680            10/05/04 21:52:45  32    from Jane ...
2    4087993680            10/05/04 21:56:56  32    from Jake ...
3    4087993680            10/05/04 21:56:58  32    from Tom ...
4    4087993680            10/05/04 21:57:00  32    from Sam ...

The following example sets FTP path to the SMS_archive directory on the FTP server at 192.168.1.3 (C881G-U-K9 and EHWIC-3G-HSPA-U):

router(config-controller)# gsm sms archive path 
ftp://username:password@192.168.1.3/SMS_archive

3G WWAN MIB Persistence

This feature allows you to retain 3G WWAN MIB object values and trap settings across router reloads.

Before configuring 3G WWAN MIB, you should perform some SNMP pre-configuration to avoid getting warning messages. The following is an example of SNMP pre-configuration:

snmp-server community public RO
snmp-server community private RW
snmp-server enable traps c3g

The following example shows you how the settings that you need to configure this feature:

controller Cellular 0
	gsm event rssi onset mib-trap All-gsm
	gsm event rssi onset threshold -84
	gsm event rssi abate mib-trap All-gsm
	gsm event rssi abate threshold -82
	gsm event temperature onset mib-trap
	gsm event temperature onset threshold 41
	gsm event temperature abate mib-trap
	gsm event temperature abate threshold 40
	gsm event modem-state mib-trap down
	gsm event modem-state mib-trap up
	gsm event service mib-trap
	gsm event network mib-trap
	gsm event connection-status mib-trap All-gsm
   ! 

Remotely Initiated Data Call Back Using SMS

This feature remotely brings up the cellular interface by sending SMS messages over GSM networks.

The following example shows you how to configure this feature:


Note In this example, the phone number of the administrator who wants to remotely bring up the link using SMS is 408-123-4567 on a GSM network. Replace this number with your own number.


chat-script wcdma "" "atdt*99#" TIMEOUT 180 "CONNECT"

interface Loopback1
 ip address 1.1.1.1 255.255.255.0
interface Cellular 0
 	 ip address negotiated
 ip virtual-reassembly in
 encapsulation ppp
 load-interval 30
 dialer in-band
 dialer pool-member 1
 dialer idle-timeout 0
 no peer default ip address
 async mode interactive
 ppp chap hostname abc.cell.org
 ppp chap password 0 nopassword
 ppp ipcp dns request
 routing dynamic

interface Dialer1
 ip address negotiated
 encapsulation ppp
 dialer pool 1
 dialer idle-timeout 0
 dialer string wcdma
 dialer caller 4081234567 callback
 dialer-group 1
 ppp chap hostname abc.cell.org
 	 ppp chap password 0 nopassword
 ppp ipcp dns request

ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 1 permit any
dialer-list 1 protocol ip list 1
!
line 3
 script dialer wcdma
 login
 modem InOut
 	 no exec
 	 transport input all
 	 transport output all

To test this example, send an SMS message from phone number 408-123-4567. This brings the cellular link up.

List of New Commands

The following is a list of the new commands supported by the EHWIC-3G-HSPA-U card embedded in the C881G-U-K9 ISR:

cellular gsm sms delete

cellular gsm sms send

cellular gsm sms view

debug cellular messages gps

debug cellular messages nmea

debug cellular messages sms

gsm event connection-status mib-trap

gsm event ecio abate

gsm event ecio onset

gsm event modem-state mib-trap

gsm event network mib-trap

gsm event rssi abate

gsm event rssi onset

gsm event service mib-trap

gsm event temperature abate

gsm event temperature onset

gsm failovertimer

gsm gps mode standalone

gsm gps nmea

gsm sim authenticate

gsm sim profile

gsm sim primary slot

gsm sim max-retry

gsm sms archive path

show cellular gps

show cellular sms

These commands are described in the Configuring Cisco EHWIC-3G-HSPA-U and C881G-U-K9 guide.

Obtaining Documentation and Submitting a Service Request

For information on obtaining documentation, submitting a service request, and gathering additional information, see the monthly What's New in Cisco Product Documentation, which also lists all new and revised Cisco technical documentation, at:

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html

Subscribe to the What's New in Cisco Product Documentation as a Really Simple Syndication (RSS) feed and set content to be delivered directly to your desktop using a reader application. The RSS feeds are a free service. Cisco currently supports RSS Version 2.0.


Cisco and the Cisco Logo are trademarks of Cisco Systems, Inc. and/or its affiliates in the U.S. and other countries. A listing of Cisco's trademarks can be found at www.cisco.com/go/trademarks. Third party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1005R)