Guest

Cisco 800 Series Routers

Release Notes for C881G-B/S/V-K9

  • Viewing Options

  • PDF (390.2 KB)
  • Feedback
Release Notes for C881G-B/S/V-K9

Table Of Contents

Release Notes for C881G-B/S/V-K9

Contents

Introduction

New Features

GPS

SMS

3G WWAN MIB Persistence

Remotely Initiated Data Call Back Using SMS

Rebranding of C8xx-B and EHWIC-3G-EVDO-B

List of New Commands

Obtaining Documentation and Submitting a Service Request


Release Notes for C881G-B/S/V-K9


First Published: May 30, 2011
Last Updated: March 18, 2013
Release: Cisco IOS Release 15.1(4)M or later releases
OL-24269-01

Contents

Introduction

New Features

List of New Commands

Introduction

This document describes the release features of the EVDO versions (BSNL, Sprint, and Verizon) of the Cisco C881G Series Integrated Services Routers (ISRs). These routers come with embedded multiband, multiservice WAN modems for use over WCDMA Radio Access Networks (RAN).

For more information about this release, see www.cisco.com/go/3g.

New Features

This section describes the new features in this release.

GPS

SMS

3G WWAN MIB Persistence

Remotely Initiated Data Call Back Using SMS

Rebranding of C8xx-B and EHWIC-3G-EVDO-B

GPS

The GPS feature provides the following commands:

Command
Syntax
Description

cdma gps mode

cdma gps mode standalone

Enables the GPS standalone mode.

cdma gps nmea

cdma gps nmea

Enables the NMEA mode.

show cellular gps

show cellular unit gps

Displays a summary of GPS data.

show cellular unit gps detail

Displays a detailed list of GPS data.


In the syntax of these commands, the unit parameter refers to:

(EHWIC-3G-EVDO-x) The router slot, WAN interface card (WIC) slot, and port separated by slashes (for example, 0/1/0).

(C881G-x-K9) The number 0.

These examples show how to enable GPS standalone and NMEA for EHWIC-3G-EVDO-x:

router(config)#controller cellular 0/0
router(config-controller)#cdma gps mode standalone
...
controller Cellular 0/0
 cdma gps mode standalone 
 
   
router(config-controller)#cdma gps nmea
...
controller Cellular 0/0
 cdma gps mode standalone   
 cdma gps nmea              
!
 
   

These examples show how to display summary and detailed GPS data for C881G-x-K9:

router#show cellular 0 gps 
GPS Info
-------------
GPS State: GPS enabled
GPS Mode Configured: standalone
Latitude: 37 Deg 24 Min 59 Sec North
Longitude: 121 Deg 55 Min 8 Sec West
Timestamp (GMT): Thu Jul 29 11:08:39 2010
Fix type: 3D, Height: -6 m
Heading: 408, Velocity Horiz: 3, Velocity Vert: 0
Satellite Info
----------------
Satellite #13, elevation 75, azimuth 46, SNR 21 
...
 
   
router#show cellular 0 gps detail
GPS Info
-------------
GPS State: GPS enabled
GPS Mode Configured: standalone
Latitude: 37 Deg 24 Min 59 Sec North
Longitude: 121 Deg 55 Min 7 Sec West
Timestamp (GMT): Thu Jul 29 22:17:57 2010
Fix type: 3D, Height: 12 m
Heading: 0, Velocity Horiz: 0, Velocity Vert: 0
...

Note Obtaining a GPS-fixed location requires a supported GPS antenna to be connected to the DIV/GPS port.



Note Obtaining a GPS-fixed location using the Standalone mode can take up to 12 minutes. This depends on the location and type of antenna used.


SMS

This feature enables the router to send and receive SMS messages. This feature also enables the router to save and store the SMS messages in an FTP server.


Note SMS is enabled by default. However, you need to define the FTP server to store incoming and outgoing SMS messages.


The SMS feature provides the following commands:

Command
Syntax
Description

cellular cdma sms send

cellular unit cdma sms send telNum message

Sends SMS messages (up to 160 characters per message).

cellular cdma sms delete

cellular unit cdma sms delete {all | msg_ID}

Deletes SMS messages.

cellular cdma sms view

cellular unit cdma sms view {summary | all | msg_ID}

Displays SMS messages.

cdma sms archive path

cdma sms archive path ftp:path_to_FTP_server

Saves SMS messages on an FTP server.


In the syntax of these commands, the unit parameter refers to:

(EHWIC-3G-EVDO-x) The router slot, WIC slot, and port separated by slashes (for example, 0/1/0).

(C881G-x-K9) The number 0.


Note You can use the call screening command dialer caller number callback to authenticate SMS messages that you can use to establish data connections.


This example shows you how to send an SMS message (C881G-x-K9):

router#cellular 0 cdma sms send <phone number> "Test message"
 
   

This example deletes all SMS messages (EHWIC-3G-EVDO-x):

router#cellular 0/1/0 cdma sms delete all
 
   

This example shows you how to display a summary of SMS messages (EHWIC-3G-EVDO-x):

router#cellular 0/1/0 cdma sms view summary 
ID   FROM                  YY/MM/DD HR:MN:SC  SIZE  CONTENT
0    4087993680            10/05/04 21:29:55  32    from John ...
1    4087993680            10/05/04 21:52:45  32    from Jane ...
2    4087993680            10/05/04 21:56:56  32    from Jake ...
3    4087993680            10/05/04 21:56:58  32    from Tom ...
4    4087993680            10/05/04 21:57:00  32    from Sam ...
 
   

The following example sets FTP path to the SMS_archive directory on the FTP server at 192.168.1.3 (C881G-x-K9 and EHWIC-3G-EVDO-x):

router(config-controller)# gsm sms archive path 
ftp://username:password@192.168.1.3/SMS_archive
 
   

3G WWAN MIB Persistence

This feature allows you to retain 3G WWAN MIB object values and trap settings across router reloads.

Before configuring 3G WWAN MIB, you should perform some SNMP pre-configuration to avoid getting warning messages. The following is an example of SNMP pre-configuration:

snmp-server community public RO
snmp-server community private RW
snmp-server enable traps c3g
 
   

This example shows you the settings that you need to configure this feature for EHWIC-3G-EVDO-x:

controller Cellular 0/1
	cdma event rssi onset mib-trap 1xrtt
	cdma event rssi onset mib-trap evdoRel0
	cdma event rssi onset mib-trap evdoRelA
	cdma event rssi onset threshold -84
	cdma event rssi abate mib-trap 1xrtt
	cdma event rssi abate mib-trap evdoRel0
	cdma event rssi abate mib-trap evdoRelA
	cdma event rssi abate threshold -82
	cdma event ecio onset mib-trap 1xrtt
	cdma event ecio onset mib-trap evdoRel0
	cdma event ecio onset mib-trap evdoRelA
	cdma event ecio onset threshold -7
	cdma event ecio abate mib-trap 1xrtt
	cdma event ecio abate mib-trap evdoRel0
	cdma event ecio abate mib-trap evdoRelA
	cdma event ecio abate threshold -5
	cdma event temperature onset mib-trap
	cdma event temperature onset threshold 34
	cdma event temperature abate mib-trap
	cdma event temperature abate threshold 33
	cdma event modem-state mib-trap down
	cdma event modem-state mib-trap up
	cdma event service mib-trap
	cdma event network mib-trap
	cdma event connection-status mib-trap All-cdma
   !
 
   
 
   

Remotely Initiated Data Call Back Using SMS

This feature remotely brings up the cellular interface by sending SMS messages over CDMA networks.

The following example shows you how to configure this feature for the EHWIC:


Note In the example below, the phone number of the administrator who wants to remotely bring up the link using SMS is 408-123-4567 on a GSM network (dialer caller 4081234567 callback). Replace this number with your own number. To test this example and bring the cellular link up, send an SMS message from your phone.


chat-script cdma "" "atdt#777" TIMEOUT 60 "CONNECT"
 
   
interface Loopback1
 ip address 1.1.1.1 255.255.255.0
interface Cellular 0
 	 ip address negotiated
 ip virtual-reassembly in
 encapsulation ppp
 load-interval 30
 dialer in-band
 dialer pool-member 1
 dialer idle-timeout 0
 no peer default ip address
 async mode interactive
 ppp chap hostname abc.cell.org
 ppp chap password 0 nopassword
 ppp ipcp dns request
 routing dynamic
 
   
interface Dialer1
 ip address negotiated
 encapsulation ppp
 dialer pool 1
 dialer idle-timeout 0
 dialer string cdma
 dialer caller 4081234567 callback
 dialer-group 1
 ppp chap hostname abc.cell.org
 	 ppp chap password 0 nopassword
 ppp ipcp dns request
 
   
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 1 permit any
dialer-list 1 protocol ip list 1
!
line 3
 script dialer cdma
 login
 modem InOut
 	 no exec
 	 transport input all
 	 transport output all
 
   

Rebranding of C8xx-B and EHWIC-3G-EVDO-B

The C881G-B-K9, C819G-B-K9, and EHWIC-EVDO-B (Bharat) SKUs are introduced as an umbrella SKU to cover BSNL, Tata, and Reliance service providers in India.

Software based mechanism is introduced to identify specific carrier.

Carrier ID and name are displayed under "show cellular <unit> hardware".

The software mechanism is backward compatible with other existing CDMA SKUs such as HWIC-3G-CDMA(-S,-V) and PCEX-3G-CDMA(-S,-V).

Cisco IOS Requirement

15.3(2)T, 15.3(3)M or later. New MIB objects for carrier ID and name will be introduced in later release.

Sample CLI Output

Router#show cellular 0/0/0 hardware
Modem Firmware Version = p2813301
Modem Firmware built = 06-24-10
Hardware Version = MC5728V Rev 1.0
Electronic Serial Number (ESN) = 0x60E62C87 [09615084679] Preferred Roaming List (PRL) 
Version = 10 PRI SKU ID = 535479 Carrier ID = 19 Carrier Name = Reliance Current Modem 
Temperature = 30 degrees Celsius Endpoint Port Map = 75
Router#
Router#show cellular 0/1/0 hardware
Modem Firmware Version = p2813301
Modem Firmware built = 06-24-10
Hardware Version = MC5728V Rev 1.0
Electronic Serial Number (ESN) = 0x60E62431 [09615082545] Preferred Roaming List (PRL) 
Version = 10 PRI SKU ID = 535479 Carrier ID = 29 Carrier Name = Tata Current Modem 
Temperature = 30 degrees Celsius Endpoint Port Map = 75
Router#

List of New Commands

The following is a list of the new commands supported by the EHWIC-3G-EVDO-x cards:

cdma event connection-status mib-trap

cdma event ecio abate

cdma event ecio onset

cdma event modem-state mib-trap

cdma event network mib-trap

cdma event rssi abate

cdma event rssi onset

cdma event service mib-trap

cdma event temperature abate

cdma event temperature onset

cdma gps mode

cdma gps nmea

cdma sms archive path

cellular cdma sms delete

cellular cdma sms send

cellular cdma sms view

debug cellular messages gps

debug cellular messages nmea

debug cellular messages sms

show cellular gps

show cellular sms

These commands are described in the Configuring Cisco EHWIC-3G-EVDO-B/S/V and
C881G-B/S/V-K9
guide.

Obtaining Documentation and Submitting a Service Request

For information on obtaining documentation, submitting a service request, and gathering additional information, see the monthly What's New in Cisco Product Documentation, which also lists all new and revised Cisco technical documentation, at:

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html

Subscribe to the What's New in Cisco Product Documentation as a Really Simple Syndication (RSS) feed and set content to be delivered directly to your desktop using a reader application. The RSS feeds are a free service. Cisco currently supports RSS Version 2.0.


Cisco and the Cisco Logo are trademarks of Cisco Systems, Inc. and/or its affiliates in the U.S. and other countries. A listing of Cisco's trademarks can be found at www.cisco.com/go/trademarks. Third party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1005R)