Cisco 812 Integrated Services Router Software Configuration Guide
Router configuration
Downloads: This chapterpdf (PDF - 102.0KB) The complete bookPDF (PDF - 324.0KB) | Feedback

Basic Router Configurations

Table Of Contents

Basic Router Configurations

Configuring 3G Interface

Configuring WLAN Interface

Configuration Examples for Cisco 812 ISR

Configuring IP NAT: Example

Additional References

Related Documents

MIBs

Technical Assistance


Basic Router Configurations


Revised: January 31, 2013, OL-27408-01

This chapter provides procedures for configuring the basic parameters of Cisco 812 ISR.

Configuring 3G Interface

Configuring WLAN Interface

Configuration Examples for Cisco 812 ISR

Additional References

Configuring 3G Interface

For more information on configuring 3G features on the Cisco 812 ISR, see the following documents:

Information Needed for Configuration

Configuring the Cellular Wireless WAN Interface

Cellular Wireless Modem as Backup with NAT and IPsec Configuration

Configuring WLAN Interface

For more information on configuring WLAN features on the Cisco 812 ISR, see the following documents:

Minimum software version needed to support AP802

Basic Wireless Device Configuration

Configuring Radio Settings

Configuration Examples for Cisco 812 ISR

The following example shows how to configure IP NAT:

Configuring IP NAT: Example

The following example shows how to configure IP NAT. The example translates the 10.10.10.x network of the Vlan1 and the second core AP addresses to the IP address of interface g0. The access list 1 defines the 10.10.10x address subnet.

Router# sh run
Building configuration...
 
   
Current configuration : 1768 bytes
!
! No configuration change since last restart
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
service-module wlan-ap 0 bootimage autonomous
crypto pki token default removal timeout 0
!
!
ip auth-proxy max-login-attempts 5
ip admission max-login-attempts 5
!
!
!
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool wlan
 import all
 network 10.10.10.0 255.255.255.0
 default-router 10.10.10.1
 option 43 hex f104.c0a8.6432
 lease infinite
!
!
ip cef
no ipv6 cef
!
!
multilink bundle-name authenticated
license udi pid C812G-CIFI-V-A-K9 sn FGL160326DR
license boot module c800 level advipservices
!
!
!
!
!
!
!
controller Cellular 0
!
!
!
!
!
!
!
!
!
!
interface Cellular0
 no ip address
 encapsulation ppp
!
interface GigabitEthernet0
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in
 no ip route-cache
 duplex auto
 speed auto
!
interface Wlan-GigabitEthernet0
 description Internal switch interface connecting to the embedded AP
 no ip address
!
interface wlan-ap0
 description Embedded Service module interface to manage the embedded AP
 ip address 10.1.1.1 255.255.0.0
!
interface Vlan1
 ip address 10.10.10.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list 1 interface GigabitEthernet0 overload
!
access-list 1 permit 10.10.10.0 0.0.0.255
!
!
control-plane
!
!
!
line con 0
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 stopbits 1
line 3
 no exec
 speed 144000
line vty 0 4
 login
 transport input all
!
scheduler allocate 20000 1000
!
end
 
   
router1

Additional References

The following sections provide references related to Cisco 812 ISR:

Related Documents


MIBs

MIBs
MIBs Link

CISCO-PRODUCTS-MIB

To locate and download MIBs for selected platforms, Cisco software releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs

CISCO-ENTITY-VENDORTYPE-OID-MIB

OLD-CISCO-CHASSIS-MIB


Technical Assistance

Description
Link

The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html