Cisco 3900 Series, 2900 Series, and 1900 Series Software Configuration Guide
Basic Router Configuration
Downloads: This chapterpdf (PDF - 319.0KB) The complete bookPDF (PDF - 3.29MB) | Feedback

Table Of Contents

Basic Router Configuration

Default Configuration

Configuring Global Parameters

Configuring I/O Memory Allocation

Interface Ports

Configuring Gigabit Ethernet Interfaces

Configuring Wireless LAN Interfaces

Configuring Interface Card and Module Interfaces

Configuring a Loopback Interface

Example

Verifying Configuration

Configuring Command-Line Access

Example

Configuring Static Routes

Example

Verifying Configuration

Configuring Dynamic Routes

Configuring Routing Information Protocol

Example

Verifying Configuration

Configuring Enhanced Interior Gateway Routing Protocol

Example

Verifying Configuration


Basic Router Configuration


This module provides configuration procedures for Cisco 3900 series, Cisco 2900 series, and Cisco 1900 series integrated services routers (ISRs). It also includes configuration examples and verification steps whenever possible.


Note See "Cisco IOS CLI for Initial Configuration" for information on how to perform the initial configuration using the Cisco Internet Operating System (IOS) command line interface on Cisco 3900 series, Cisco 2900 series, and Cisco 1900 series integrated services routers.


Basic Configuration

Default Configuration

Configuring Global Parameters

Interface Configuration

Interface Ports

Configuring Gigabit Ethernet Interfaces

Configuring Wireless LAN Interfaces

Configuring Interface Card and Module Interfaces

Configuring a Loopback Interface

Routing Configuration

Configuring Command-Line Access

Configuring Static Routes

Configuring Dynamic Routes

Default Configuration

When you boot up your Cisco router for the first time, you notice some basic configuration has already been performed. Use the show running-config command to view the initial configuration, as shown in the following example.

Router# show running-config
Building configuration...
Current configuration : 723 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
no ipv6 cef
ip source-route
ip cef
!
!
!         
!
multilink bundle-name authenticated
!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip forward-protocol nd
!
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 3
 login
!
exception data-corruption buffer truncate
scheduler allocate 20000 1000
end

Configuring Global Parameters

To configure the global parameters for your router, follow these steps.

SUMMARY STEPS

1. configure terminal

2. hostname name

3. enable secret password

4. no ip domain-lookup

DETAILED STEPS

 
Command
Purpose

Step 1 

configure terminal

Example:

Router> enable

Router# configure terminal

Router(config)#

Enters global configuration mode, when using the console port.

Use the following to connect to the router with a remote terminal:

telnet router name or address

Login: login id

Password: *********

Router> enable

Step 2 

hostname name

Example:

Router(config)# hostname Router

Router(config)#

Specifies the name for the router.

Step 3 

enable secret password

Example:

Router(config)# enable secret cr1ny5ho

Router(config)#

Specifies an encrypted password to prevent unauthorized access to the router.

Step 4 

no ip domain-lookup

Example:

Router(config)# no ip domain-lookup Router(config)#

Disables the router from translating unfamiliar words (typos) into IP addresses.

For complete information on global parameter commands, see the Cisco IOS Release configuration guide documentation set.

Configuring I/O Memory Allocation

To reallocate the percentage of DRAM in use for I/O memory and processor memory on Cisco 3925E and Cisco 3945E routers, use the memory-size iomem i/o-memory-percentage command in global configuration mode. To revert to the default memory allocation, use the no form of this command. This procedure enables smartinit.

Syntax
Description

i/o-memory-percentage

The percentage of DRAM allocated to I/O memory. The values permitted are 5, 10, 15, 20, 25, 30, 40, and 50. A minimum of 201 MB of memory is required for I/O memory.



Tip We recommend that you configure the memory-size iomem below 25%. Any value above 25% should be used only for enhancing IPSec performance.


When you specify the percentage of I/O memory in the command line, the processor memory automatically acquires the remaining percentage of DRAM memory.

Example

The following example allocates 25% of the DRAM memory to I/O memory and the remaining 75% to processor memory:

Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# memory-size iomem 5
IO memory size too small:  minimum IO memory size is 201M 
Router(config)# 
Router(config)# memory-size iomem ?
<5-50>  percentage of DRAM to use for I/O memory: 5, 10, 15, 20, 25, 30, 40, 50
 
 
Router(config)# memory-size iomem 25
Smart-init will be disabled and new I/O memory size will take effect upon reload.
Router(config)# end
 
 

Verifying IOMEM Setting

Router# show run
Current configuration : 6590 bytes
!
! Last configuration change at 16:48:41 UTC Tue Feb 23 2010 !
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service internal
!
hostname Router1
!
!
no aaa new-model
!
memory-size iomem 25
!

Interface Ports

Table 1 lists the interfaces that are supported on Cisco 3900 series, Cisco 2900 series, and Cisco 1900 series integrated services routers.

Table 1 Interfaces by Cisco Router 

Slots, Ports, Logical Interface, Interfaces
1941
2901 1
2911 & 2921
2951 & 3925 & 3945
3925E & 3945E

Onboard GE ports

Gi0/0,Gi0/1

Gi0/0,Gi0/1

Gi0/0,Gi0/1,GI0/2

Gi0/0,Gi0/1,GI0/2

Gi0/0,Gi0/1,GI0/2, GI0/3

Onboard WLAN

Wlan-ap0

not supported

not supported

not supported

not supported

Onboard WLAN GE connection to MGF2

Wlan-Gi0/0

not supported

not supported

not supported

not supported

Onboard ISM GE interface on the PCIe

service-module-name-ISM 0/0

service-module-
name-
ISM 0/0

service-module-
name-
ISM 0/0

service-module-
name-
ISM 0/0

not supported

Onboard ISM GE connection to MGF

service-module-name-ISM 0/1

service-module-
name-
ISM 0/1

service-module-
name-
ISM 0/1

service-module-
name-
ISM 0/1

not supported

USB

usbflash0, usbflash1

usbtoken0, usbtoken1

usbflash0, usbflash1

usbtoken0, usbtoken1

usbflash0, usbflash1

usbtoken0, usbtoken1

usbflash0, usbflash1

usbtoken0, usbtoken1

usbflash0, usbflash1

usbtoken0, usbtoken1

Interfaces on HWIC and VWIC

interface0/0/ port
interface
0/1/ port

interface0/0/port
interface
0/1/port
interface
0/2/port
interface
0/3/port

interface0/0/port
interface
0/1/port
interface
0/2/port
interface
0/3/port

interface0/0/port
interface
0/1/port
interface
0/2/port
interface
0/3/port

<int>0/0/<port>
<int>0/1/<port>
<int>0/2/<port>

Interfaces on Double Wide-HWIC

interface0/1
port

interface0/1/port

interface0/3/port

interface0/1/port

interface0/3/port

interface0/1/port

interface0/3/port

<int>0/1/<port>

Interfaces on SM

not supported

not supported

interface1/port

interface1-2/port3 interface1-4/port4

interface1-2/port
interface1-4/port

Interfaces on Double Wide-SM

not supported

not supported

not supported

interface 2/port5 interface4/port6

interface 2/port
interface
4/port

Interfaces HWIC on SM

Interfaces VWIC on SM

not supported

not supported

interface1wic-slot/port

interface1-2/wic-
slot/port7

interface1-4/wic-
slot/port8

interface1-2/wic-
slot/port
interface1-4/wic-
slot/port

1 On the Cisco 2901 router, the numbering format for configuring an asynchronous interface is 0/slot/port. To configure the line associated with an asynchronous interface, simply use the interface number to specify the asynchronous line. For example, line 0/1/0 specifies the line associated with interface serial 0/1/0 on a WIC-2A/S in slot 1. Similarly, line 0/2/1 specifies the line associated with interface async 0/2/1 on a WIC-2AM in slot 2.

2 MGF = multi-gigabit fabric

3 Applies only to Cisco 2951, Cisco 3925, and Cisco 3925E routers.

4 Applies only to Cisco 3945 and Cisco 3945E routers.

5 Applies only to Cisco 2951, Cisco 3925, and Cisco 3925E routers.

6 Applies only to Cisco 3945 and Cisco 3945E routers.

7 Applies only to Cisco 2951, Cisco 3925, and Cisco 3925E routers.

8 Applies only to Cisco 3945 and Cisco 3945E routers.


Configuring Gigabit Ethernet Interfaces

To manually define onboard Gigabit Ethernet (GE) interfaces, follow these steps, beginning in global configuration mode.

SUMMARY STEPS

1. interface gigabitethernet slot/port

2. ip address ip-address mask

3. no shutdown

4. exit

DETAILED STEPS

 
Command
Purpose

Step 1 

interface gigabitethernet slot/port

Example:

Router(config)# interface gigabitethernet 0/1

Router(config-if)#

Enters the configuration mode for a Gigabit Ethernet interface on the router.

Step 2 

ip address ip-address mask

Example:

Router(config-if)# ip address 192.168.12.2 255.255.255.0

Router(config-if)#

Sets the IP address and subnet mask for the specified GE interface.

Step 3 

no shutdown

Example:

Router(config-if)# no shutdown

Router(config-if)#

Enables the GE interface, changing its state from administratively down to administratively up.

Step 4 

exit

Example:

Router(config-if)# exit

Router(config)#

Exits configuration mode for the GE interface and returns to global configuration mode.

Configuring Wireless LAN Interfaces

The wireless LAN interface on the Cisco 1941W router enables connection to the router through interface wlan-ap0. For more information about configuring a wireless connection, see the "Configuring the Wireless Device" section.

Configuring Interface Card and Module Interfaces

To configure interface cards and modules inserted in internal services module (ISM), enhanced high-speed WAN interface card (EHWIC), Ethernet WAN interface card (EWIC), and service module (SM) slots, see the appropriate interface card or module configuration documents on Cisco.com.

Configuring a Loopback Interface

The loopback interface acts as a placeholder for the static IP address and provides default routing information.

For complete information on the loopback commands, see the Cisco IOS Release configuration guide documentation set.

To configure a loopback interface, follow these steps, beginning in global configuration mode.

SUMMARY STEPS

1. interface type number

2. ip address ip-address mask

3. exit

DETAILED STEPS

 
Command
Purpose

Step 1 

interface type number

Example:

Router(config)# interface Loopback 0

Router(config-if)#

Enters configuration mode for the loopback interface.

Step 2 

ip address ip-address mask

Example:

Router(config-if)# ip address 10.108.1.1 255.255.255.0

Router(config-if)#

Sets the IP address and subnet mask for the loopback interface.

Step 3 

exit

Example:

Router(config-if)# exit

Router(config)#

Exits configuration mode for the loopback interface and returns to global configuration mode.

Example

The loopback interface in this sample configuration is used to support Network Address Translation (NAT) on the virtual-template interface. This configuration example shows the loopback interface configured on the gigabit ethernet interface with an IP address of 200.200.100.1/24, which acts as a static IP address. The loopback interface points back to virtual-template1, which has a negotiated IP address.

!
interface loopback 0
ip address 200.200.100.1 255.255.255.0 (static IP address)
ip nat outside
!
interface Virtual-Template1
ip unnumbered loopback0
no ip directed-broadcast
ip nat outside
!
 
 

Verifying Configuration

To verify that you have properly configured the loopback interface, enter the show interface loopback command. You should see verification output similar to the following example.

Router# show interface loopback 0
Loopback0 is up, line protocol is up 
  Hardware is Loopback
  Internet address is 200.200.100.1/24
  MTU 1514 bytes, BW 8000000 Kbit, DLY 5000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation LOOPBACK, loopback not set
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/0, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
 
 

Another way to verify the loopback interface is to ping it:

Router# ping 200.200.100.1 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.200.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
 
 

Configuring Command-Line Access

To configure parameters to control access to the router, follow these steps, beginning in global configuration mode.

SUMMARY STEPS

1. line [aux | console | tty | vty] line-number

2. password password

3. login

4. exec-timeout minutes [seconds]

5. line [aux | console | tty | vty] line-number

6. password password

7. login

8. end

DETAILED STEPS

 
Command
Purpose

Step 1 

line [aux | console | tty | vty] line-number

Example:

Router(config)# line console 0

Router(config-line)#

Enters line configuration mode, and specifies the type of line.

This example specifies a console terminal for access.

Step 2 

password password

Example:

Router(config)# password 5dr4Hepw3

Router(config-line)#

Specifies a unique password for the console terminal line.

Step 3 

login

Example:

Router(config-line)# login

Router(config-line)#

Enables password checking at terminal session login.

Step 4 

exec-timeout minutes [seconds]

Example:

Router(config-line)# exec-timeout 5 30

Router(config-line)#

Sets the interval that the EXEC command interpreter waits until user input is detected. The default is 10 minutes. Optionally, add seconds to the interval value.

This example shows a timeout of 5 minutes and 30 seconds. Entering a timeout of 0 0 specifies never to time out.

Step 5 

line [aux | console | tty | vty] line-number

Example:

Router(config-line)# line vty 0 4

Router(config-line)#

Specifies a virtual terminal for remote console access.

Step 6 

password password

Example:

Router(config-line)# password aldf2ad1

Router(config-line)#

Specifies a unique password for the virtual terminal line.

Step 7 

login

Example:

Router(config-line)# login

Router(config-line)#

Enables password checking at the virtual terminal session login.

Step 8 

end

Example:

Router(config-line)# end

Router#

Exits line configuration mode, and returns to privileged EXEC mode.

Example

The following configuration shows the command-line access commands.

You do not need to input the commands marked "default." These commands appear automatically in the configuration file generated when you use the show running-config command.

!
line con 0
exec-timeout 10 0
password 4youreyesonly
login
transport input none (default)
stopbits 1 (default)
line vty 0 4
password secret
login
!
 
 

Configuring Static Routes

Static routes provide fixed routing paths through the network. They are manually configured on the router. If the network topology changes, the static route must be updated with a new route. Static routes are private routes unless they are redistributed by a routing protocol.

To configure static routes, follow these steps, beginning in global configuration mode.

SUMMARY STEPS

1. ip route prefix mask {ip-address | interface-type interface-number [ip-address]}

2. end

DETAILED STEPS

 
Command
Purpose

Step 1 

ip route prefix mask {ip-address | interface-type interface-number [ip-address]}

Example:

Router(config)# ip route 192.168.1.0 255.255.0.0 10.10.10.2

Router(config)#

Specifies the static route for the IP packets.

For details about this command and about additional parameters that can be set, see Cisco IOS IP Command Reference, Volume 2 of 4: Routing Protocols, Release 12.3

Step 2 

end

Example:

Router(config)# end

Router#

Exits router configuration mode, and enters privileged EXEC mode.

Example

In the following configuration example, the static route sends out all IP packets with a destination IP address of 192.168.1.0 and a subnet mask of 255.255.255.0 on the Gigabit Ethernet interface to another device with an IP address of 10.10.10.2. Specifically, the packets are sent to the configured PVC.

You do not need to enter the command marked "(default)." This command appears automatically in the configuration file generated when you use the show running-config command.

!
ip classless (default)
ip route 192.168.1.0 255.255.255.0 10.10.10.2!
 
 

Verifying Configuration

To verify that you have properly configured static routing, enter the show ip route command and look for static routes signified by the "S."

You should see verification output similar to the following:

Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
 
Gateway of last resort is not set
 
 
     10.0.0.0/24 is subnetted, 1 subnets
C       10.108.1.0 is directly connected, Loopback0
S* 0.0.0.0/0 is directly connected, FastEthernet0
 
 

Configuring Dynamic Routes

In dynamic routing, the network protocol adjusts the path automatically, based on network traffic or topology. Changes in dynamic routes are shared with other routers in the network.

The Cisco routers can use IP routing protocols, such as Routing Information Protocol (RIP) or Enhanced Interior Gateway Routing Protocol (EIGRP), to learn routes dynamically. You can configure either of these routing protocols on your router.

"Configuring Routing Information Protocol" section

"Configuring Enhanced Interior Gateway Routing Protocol" section

Configuring Routing Information Protocol

To configure the RIP routing protocol on the router, follow these steps, beginning in global configuration mode.

SUMMARY STEPS

1. router rip

2. version {1 | 2}

3. network ip-address

4. no auto-summary

5. end

DETAILED STEPS

 
Command
Task

Step 1 

router rip

Example:

Router> configure terminal

Router(config)# router rip

Router(config-router)#

Enters router configuration mode, and enables RIP on the router.

Step 2 

version {1 | 2}

Example:

Router(config-router)# version 2

Router(config-router)#

Specifies use of RIP version 1 or 2.

Step 3 

network ip-address

Example:

Router(config-router)# network 192.168.1.1

Router(config-router)# network 10.10.7.1

Router(config-router)#

Specifies a list of networks on which RIP is to be applied, using the address of the network of each directly connected network.

Step 4 

no auto-summary

Example:

Router(config-router)# no auto-summary

Router(config-router)#

Disables automatic summarization of subnet routes into network-level routes. This allows subprefix routing information to pass across classful network boundaries.

Step 5 

end

Example:

Router(config-router)# end

Router#

Exits router configuration mode, and enters privileged EXEC mode.

Example

The following configuration example shows RIP version 2 enabled in IP network 10.0.0.0 and 192.168.1.0.

To see this configuration, use the show running-config command from privileged EXEC mode.

!
Router# show running-config
router rip
 version 2
 network 10.0.0.0
 network 192.168.1.0
 no auto-summary
!
 
 

Verifying Configuration

To verify that you have properly configured RIP, enter the show ip route command and look for RIP routes signified by "R." You should see a verification output like the example shown below.

Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
 
Gateway of last resort is not set
 
 
     10.0.0.0/24 is subnetted, 1 subnets
C       10.108.1.0 is directly connected, Loopback0
R    3.0.0.0/8 [120/1] via 2.2.2.1, 00:00:02, Ethernet0/0

Configuring Enhanced Interior Gateway Routing Protocol

To configure Enhanced Interior Gateway Routing Protocol GRP (EGRP), follow these steps, beginning in global configuration mode.

SUMMARY STEPS

1. router eigrp as-number

2. network ip-address

3. end

DETAILED STEPS

 
Command
Purpose

Step 1 

router eigrp as-number

Example:

Router(config)# router eigrp 109

Router(config)#

Enters router configuration mode, and enables EIGRP on the router. The autonomous-system number identifies the route to other EIGRP routers and is used to tag the EIGRP information.

Step 2 

network ip-address

Example:

Router(config)# network 192.145.1.0

Router(config)# network 10.10.12.115

Router(config)#

Specifies a list of networks on which EIGRP is to be applied, using the IP address of the network of directly connected networks.

Step 3 

end

Example:

Router(config-router)# end

Router#

Exits router configuration mode, and enters privileged EXEC mode.

Example

The following configuration example shows the EIGRP routing protocol enabled in IP networks 192.145.1.0 and 10.10.12.115. The EIGRP autonomous system number is 109.

To see this configuration use the show running-config command, beginning in privileged EXEC mode.

Router# show running-config
...
!
router eigrp 109
	network 192.145.1.0
		network 10.10.12.115
!
...

Verifying Configuration

To verify that you have properly configured IP EIGRP, enter the show ip route command, and look for EIGRP routes indicated by "D." You should see verification output similar to the following:

Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
 
Gateway of last resort is not set
 
 
     10.0.0.0/24 is subnetted, 1 subnets
C       10.108.1.0 is directly connected, Loopback0
D    	3.0.0.0/8 [90/409600] via 2.2.2.1, 00:00:02, Ethernet0/0