Cisco 7600 Series Cisco IOS Software Configuration Guide, 12.1E
Configuring Layer 3 Ethernet Interfaces
Downloads: This chapterpdf (PDF - 224.0KB) The complete bookPDF (PDF - 7.08MB) | Feedback

Configuring Layer 3 Interfaces

Table Of Contents

Configuring Layer 3 Interfaces

Configuring IP Routing and Addresses

Configuring IPX Routing and Network Numbers

Configuring AppleTalk Routing, Cable Ranges, and Zones

Configuring Other Protocols on Layer 3 Interfaces


Configuring Layer 3 Interfaces


This chapter contains information about how to configure Layer 3 interfaces on the Catalyst 6500 series switches, which supplements the information and procedures in the Release 12.1 publications at this URL:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/index.htm

This chapter consists of these sections:

Configuring IP Routing and Addresses

Configuring IPX Routing and Network Numbers

Configuring AppleTalk Routing, Cable Ranges, and Zones

Configuring Other Protocols on Layer 3 Interfaces


NoteFor complete syntax and usage information for the commands used in this chapter, refer to the Catalyst 6500 Series Switch Cisco IOS Command Reference publication and the Release 12.1 publications at this URL:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/index.htm

Release 12.1(13)E and later releases support configuration of 4,096 Layer 3 VLAN interfaces.

We recommend that you configure a combined total of no more than 2,000 Layer 3 VLAN interfaces and Layer 3 ports on an MSFC2 with either Supervisor Engine 1 or Supervisor Engine 2.

We recommend that you configure a combined total of no more than 1,000 Layer 3 VLAN interfaces and Layer 3 ports on an MSFC.

With releases earlier than Release 12.1(13)E, an MSFC2 with either Supervisor Engine 1 or Supervisor Engine 2 supports a combined maximum of 1,000 Layer 3 VLAN interfaces and Layer 3 ports.

With releases earlier than Release 12.1(13)E, an MSFC with Supervisor Engine 1 supports a maximum of 256 Layer 3 VLAN interfaces.

To support VLAN interfaces, create and configure VLANs and assign VLAN membership to Layer 2 LAN ports. For more information, see Chapter 9, "Configuring VLANs" and Chapter 8, "Configuring VTP."

Catalyst 6500 series switches support Layer 3 trunks only on the 4-port Gigabit Ethernet WAN modulea (OSM-4GE-WAN and OSM-2+4GE-WAN+). You cannot configure subinterfaces or use the encapsulation keyword on LAN ports. Catalyst 6500 series switches support Layer 2 trunks and Layer 3 VLAN interfaces, which provide equivalent capabilities for LAN ports. See Chapter 7, "Configuring LAN Ports for Layer 2 Switching" and the "Configuring IP Routing and Addresses" section.

With Release 12.1(11b)E and later, when you are in configuration mode you can enter EXEC mode-level commands by entering the do keyword before the EXEC mode-level command.


Configuring IP Routing and Addresses

For complete information and procedures, refer to these publications:

Cisco IOS IP and IP Routing Configuration Guide, Release 12.1, at this URL:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/ip_c/index.htm

Cisco IOS IP and IP Routing Command Reference, Release 12.1, at this URL:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/ip_r/index.htm

For information about the maximum paths command in Release 12.1 E, refer to the Catalyst 6500 Series Switch Cisco IOS Command Reference publication.

The Policy Feature Card 2 (PFC2) and any Distributed Feature Cards (DFCs) provide hardware support for policy-based routing (PBR) for route-map sequences that use the match ip address and set ip next-hop keywords.

With Release 12.1(11b)E and later, the PFC2 and any DFCs provide hardware support for the ip default next-hop PBR keywords.

The Multilayer Switch Feature Card 2 (MSFC2) provides processing in software for route-map sequences that use the match length and set interface keywords.

To configure PBR, refer to the Cisco IOS Quality of Service Solutions Configuration Guide, Release 12.1, "Classification," "Configuring Policy-Based Routing," at this URL:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/qos_c/qcprt1/qcdpbr.htm

To configure IP routing and an IP address on a Layer 3 interface, perform this task:

 
Command
Purpose

Step 1 

Router(config)# ip routing

Enables IP routing. (Required only if IP routing is disabled.)

Step 2 

Router(config)# router ip_routing_protocol

Specifies an IP routing protocol.

Step 3 

Router(config-router)# ip_routing_protocol_commands

Configures the IP routing protocol.

Step 4 

Router(config-router)# exit

Exists IP routing protocol configuration mode.

Step 5 

Router(config)# interface {vlan vlan_ID} | {type1  slot/port} | {port-channel port_channel_number}

Selects an interface to configure.

Step 6 

Router(config-if)# ip address ip_address subnet_mask

Configures the IP address and IP subnet.

Step 7 

Router(config-if)# no shutdown

Enables the interface.

Step 8 

Router(config-if)# end

Exits configuration mode.

Step 9 

Router# show interfaces [{vlan vlan_ID} | {type1 slot/port} | {port-channel port_channel_number}]

Router# show ip interfaces [{vlan vlan_ID} | {type1 slot/port} | {port-channel port_channel_number}]

Router# show running-config interfaces [{vlan vlan_ID} | {type1 slot/port} | {port-channel port_channel_number}]

Verifies the configuration.

1 type = ethernet, fastethernet, gigabitethernet, tengigabitethernet, or ge-wan

This example shows how to enable IP Routing Information Protocol (RIP) routing:

Router# configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)# ip routing 
Router(config)# router rip 
Router(config-router)# network 10.0.0.0 
Router(config-router)# end 
Router#

This example shows how to configure an IP address on Fast Ethernet port 5/4:

Router# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)# interface fastethernet 5/4
Router(config-if)# ip address 172.20.52.106 255.255.255.248
Router(config-if)# no shutdown
Router(config-if)# end 
Router#

This example uses the show interfaces command to display the interface IP address configuration and status of Fast Ethernet port 5/4:

Router# show interfaces fastethernet 5/4
FastEthernet5/4 is up, line protocol is up
  Hardware is Cat6K 100Mb Ethernet, address is 0050.f0ac.3058 (bia 0050.f0ac.3058)
    Internet address is 172.20.52.106/29
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:01, output never, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     7 packets input, 871 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     8 packets output, 1658 bytes, 0 underruns
     0 output errors, 0 collisions, 4 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Router#

This example uses the show ip interface command to display the detailed configuration and status of Fast Ethernet port 5/4:

Router# show ip interface fastethernet 5/4
FastEthernet5/4 is up, line protocol is up
    Internet address is 172.20.52.106/29
  Broadcast address is 255.255.255.255
  Address determined by setup command
  MTU is 1500 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Multicast reserved groups joined: 224.0.0.10
  Outgoing access list is not set
  Inbound  access list is not set
  Proxy ARP is enabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are always sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is enabled
  IP fast switching on the same interface is disabled
  IP Flow switching is disabled
  IP CEF switching is enabled
  IP Fast switching turbo vector
  IP Normal CEF switching turbo vector
  IP multicast fast switching is enabled
  IP multicast distributed fast switching is disabled
  Router Discovery is disabled
  IP output packet accounting is disabled
  IP access violation accounting is disabled
  TCP/IP header compression is disabled
  RTP/IP header compression is disabled
  Probe proxy name replies are disabled
  Policy routing is disabled
  Network address translation is disabled
  WCCP Redirect outbound is disabled
  WCCP Redirect exclude is disabled
  BGP Policy Mapping is disabled
  IP multicast multilayer switching is disabled
  IP mls switching is enabled
Router#

This example uses the show running-config command to display the interface IP address configuration of Fast Ethernet port 5/4:

Router# show running-config interfaces fastethernet 5/4 
Building configuration...
 
Current configuration:
!
interface FastEthernet5/4
 description "Router port"
  ip address 172.20.52.106 255.255.255.248
 no ip directed-broadcast
!

Configuring IPX Routing and Network Numbers

For complete information and procedures, refer to these publications:

Cisco IOS AppleTalk and Novell IPX Configuration Guide, Release 12.1, at this URL:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/atipx_c/index.htm

Cisco IOS AppleTalk and Novell IPX Command Reference, Release 12.1, at this URL:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/atipx_r/index.htm

To configure routing for Internetwork Packet Exchange (IPX) and configure IPX on a Layer 3 interface, perform this task:

 
Command
Purpose

Step 1 

Router(config)# ipx routing

Enables IPX routing.

Step 2 

Router(config)# router ipx_routing_protocol

Specifies an IP routing protocol. This step might include other commands, such as specifying the networks to route with the network command.

Step 3 

Router(config)# interface {vlan vlan_ID} | {type1  slot/port} | {port-channel port_channel_number}

Selects an interface to configure.

Step 4 

Router(config-if)# ipx network [network | unnumbered] encapsulation encapsulation_type

Configures the IPX network number. This enables IPX routing on the interface. When you enable IPX routing on the interface, you can also specify an encapsulation type.

Step 5 

Router(config-if)# no shutdown

Enables the interface.

Step 6 

Router(config-if)# end

Exits configuration mode.

Step 7 

Router# show interfaces [{vlan vlan_ID} | {type1 slot/port} | {port-channel port_channel_number}]

Router# show ipx interfaces [{vlan vlan_ID} | {type1 slot/port} | {port-channel port_channel_number}]

Router# show running-config interfaces [{vlan vlan_ID} | {type1 slot/port} | {port-channel port_channel_number}]

Verifies the configuration.

1 type = ethernet, fastethernet, gigabitethernet, tengigabitethernet, or ge-wan

This example shows how to enable IPX routing and assign an IPX network address to interface VLAN 100:

Router# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)# ipx routing 
Router(config)# ipx router rip 
Router(config-ipx-router)# network all 
Router(config-ipx-router)# interface vlan 100 
Router(config-if)# ipx network 100 encapsulation snap 
Router(config-if)# no shutdown 
Router(config-if)# end 
Router# copy running-config startup-config 

Configuring AppleTalk Routing, Cable Ranges, and Zones

For complete information and procedures, refer to these publications:

Cisco IOS AppleTalk and Novell IPX Configuration Guide, Release 12.1, at this URL:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/atipx_c/index.htm

Cisco IOS AppleTalk and Novell IPX Command Reference, Release 12.1, at this URL:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/atipx_r/index.htm

To configure routing for AppleTalk, perform this task beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# appletalk routing

Enables AppleTalk routing.

Step 2 

Router(config)# interface {vlan vlan_ID} | {type1  slot/port} | {port-channel port_channel_number}

Selects an interface to configure.

Step 3 

Router(config-if)# appletalk cable-range cable_range

Assigns a cable range to the interface.

Step 4 

Router(config-if)# appletalk zone zone_name

Assigns a zone name to the interface.

Step 5 

Router(config-if)# no shutdown

Enables the interface.

Step 6 

Router(config-if)# end

Exits configuration mode.

Step 7 

Router# show interfaces [{vlan vlan_ID} | {type1 slot/port} | {port-channel port_channel_number}]

Router# show appletalk interfaces [{vlan vlan_ID} | {type1 slot/port} | {port-channel port_channel_number}]

Router# show running-config interfaces [{vlan vlan_ID} | {type1 slot/port} | {port-channel port_channel_number}]

Verifies the configuration.

1 type = ethernet, fastethernet, gigabitethernet, tengigabitethernet, or ge-wan

This example shows how to enable AppleTalk routing and assign an AppleTalk cable-range and zone name to interface VLAN 100:

Router# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)# appletalk routing
Router(config)# interface vlan 100
Router(config-if)# appletalk cable-range 100-100
Router(config-if)# appletalk zone Engineering
Router(config-if)# no shutdown
Router(config-if)# end 
Router# copy running-config startup-config

Configuring Other Protocols on Layer 3 Interfaces

Refer to these publications for information about configuring other protocols on Layer 3 interfaces:

Cisco IOS Apollo Domain, VINES, DECnet, ISO CLNS, and XNS Configuration Guide, Release 12.1, at this URL:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/apollo_c/index.htm

Cisco IOS Apollo Domain, VINES, DECnet, ISO CLNS, and XNS Command Reference, Release 12.1, at this URL:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/apollo_r/index.htm