Cisco 10000 Series Router Quality of Service Configuration Guide
Simultaneous Policy Maps
Downloads: This chapterpdf (PDF - 490.0KB) The complete bookPDF (PDF - 21.32MB) | Feedback

Simultaneous Policy Maps

Table Of Contents

Simultaneous Policy Maps

Simultaneous QoS Policy Map on an Interface and PPP Session

Feature History for Simultaneous Policy Maps

QoS Actions

Simultaneous Policies and Displaying Statistical Information

Restrictions for Simultaneous Policy Maps

Configuring Simultaneous Policy Maps

Configuring the Two Policy Maps

Attaching Simultaneous Policies to PPPoE Sessions Traversing an Ethernet Interface

Attaching a Policy to a PPPoE Session

Attaching a Policy to an Ethernet Interface

Attaching Simultaneous Policies to PPPoA Sessions Traversing an ATM VC

Attaching a Policy to a PPPoA Session

Attaching a Policy to an ATM VC with PPPoA Sessions

Attaching Simultaneous Policies to PPPoE Sessions Traversing an ATM VC

Attaching a Policy to PPPoE Sessions

Attaching a Policy to an ATM VC with PPPoE Sessions

Configuration Examples for Simultaneous Policy Maps

Configuration Example for Applying Simultaneous Policy Maps on Ethernet Interfaces and PPPoE Sessions

Configuration Example for Applying Simultaneous Policies on 802.1Q Interfaces and PPPoE Sessions

Configuration Example for Applying Simultaneous Policies on 802.1Q QinQ Interfaces and PPPoE Sessions

Configuration Example for Applying Simultaneous Policies on ATM VCs and PPPoA Sessions

Configuration Example for Applying Simultaneous Policies on ATM VCs and PPPoE Sessions

Verifying Simultaneous Policy Maps

Verification Examples for Traffic Policing

Displaying Simultaneous Policy Map Information for Interfaces

Displaying Simultaneous Policy Map Information for PTA Virtual Interfaces

Displaying Simultaneous Policy Map Information for Virtual Access Interfaces

Displaying Simultaneous Policy Map Information for a LAC Session


Simultaneous Policy Maps


Simultaneous policy maps provide multiple levels of QoS hierarchy that can shape traffic at different points of congestion in the Layer 2 network.

This chapter describes simultaneous policy maps on the Cisco 10000 series router and consists of the following topics:

Simultaneous QoS Policy Map on an Interface and PPP Session

Restrictions for Simultaneous Policy Maps

Configuring Simultaneous Policy Maps

Configuration Examples for Simultaneous Policy Maps

Verifying Simultaneous Policy Maps

Verification Examples for Traffic Policing

Simultaneous QoS Policy Map on an Interface and PPP Session

The Simultaneous QoS Policy Map on Interface and PPP Session—A-DSLAM Case feature allows the broadband aggregation system (BRAS) to provide multiple levels of QoS hierarchy that shape traffic at different points of congestion in the Layer 2 network. This enables the BRAS to avoid congestion in downstream links within the network.The BRAS prioritizes the traffic based on the subscriber's contracted bandwidth and subscribed services.

Using simultaneous policy maps, you can apply QoS at the session level and at the Ethernet subinterface or PVC level for a single ATM PVC with two or more PPPoE sessions. At the session level, you can configure the BRAS to mark any traffic above a specified rate with a particular designation. When the traffic arrives at the Ethernet subinterface or ATM PVC, the BRAS uses the specified designation to give a higher drop probability to packets marked with the designation. As a service provider, this enables you to ensure that each of the separate sessions receives a minimum level of the subinterface or PVC capacity and allows any one session to receive the full capacity of the subinterface or PVC if the other sessions are idle.

When configuring simultaneous policy maps, you configure policy maps at the interface and session levels in a serial fashion: one policy applied to a VAI or a LAC session and another policy applied to an ATM PVC or an Ethernet-based subinterface as the following describes:

Session-level policy—You associate this service policy with a PPP session on the VAI or LAC. This policy must contain only non-queuing QoS actions such as policing and set actions. You can statically configure this policy under a virtual template or use RADIUS Attributes 37 and 39 to dynamically associate the policy with the PPP session. The BRAS applies this policy only at the PPP session level.

Interface-level policy—You apply this service policy to a main interface, an ATM PVC, or an Ethernet-based subinterface such as a VLAN subinterface. This policy can contain queuing-related features, but it cannot have hierarchical policing policies. The BRAS applies this policy to the aggregate traffic associated with a specific interface.

The BRAS recognizes that simultaneous policy maps exist and applies the appropriate QoS services to the packets that are subject to both policies. The BRAS aggregates all of the packets of sessions at the interface level. For example, if policing is applied on a traffic class in an interface policy, the BRAS polices the aggregate of all of the packets on any of the sessions that match that class.

Feature History for Simultaneous Policy Maps

Cisco IOS Release
Description
Required PRE

Release 12.2(33)SB

The Simultaneous QoS Policy Map on Interface and PPP Session—A-DSLAM Case feature was introduced on the PRE2, PRE3, and PRE4.

PRE2, PRE3, PRE4


QoS Actions

Table 14-1 lists the types of QoS actions allowed in simultaneous policy maps.

Table 14-1 Allowable QoS Actions in Simultaneous Policy Maps

Policy Type
QoS Actions Permitted

Session-level or interface-level input policies
session-level output policies

Non-queuing related actions

VC and Ethernet-based interface-level output policies

Queuing, policing, and marking actions


Simultaneous Policies and Displaying Statistical Information

To display information about simultaneous policies and their associated statistical information, the output from the show commands display information at both the interface level and the session level. At the session level, a unique session owns each policy, and the QoS actions and statistics displayed apply to that unique session. At the interface level, however, the BRAS treats all of the sessions in aggregate. The information the BRAS gathers for display represents the aggregate QoS actions and statistics of all of the sessions passing over the PVC or VLAN.

For simultaneous policies, the way in which the BRAS processes actions at one policy level and at a subsequent policy level is consistent with the behavior of the BRAS when processing hierarchical input policies. Table 14-2 describes how the actions at one policy level affect the classification or actions at a subsequent policy level.

Table 14-2 Influence of Session-Level Policy Actions on Interface-Level Policy Actions

Session-Level Policy Actions
Effect on Interface-Level Policy Actions

match cos

Valid as an input classification criteria on an Ethernet interface. Configurable on the Ethernet interface, including a VLAN and QinQ subinterface, and on a PPPoE session traversing an Ethernet interface.

The interface-level policy does not influence the classification done by the session policy.

Both the session-level and interface-level policies may use this criteria.

Note The session-level policy with the set cos command can cause more packets to be classified by an interface-level policy with the match cos command. The session policy sets the CoS bits of the appropriate traffic and the interface policy classifies the packets according to their CoS values.

match ip precedence
match dscp

Valid as an input or output criteria and valid on all interface and session types.

The action (or class) taken by the session-level policy influences the class of the interface-level policy that the packet matches.

match discard-class
match qos-group

Valid as an output criteria on either session-level or interface-level policies. Set as an input action and used in output classification. Therefore, the input action does not affect the output classification.

If both input policies attempt to set the discard-class or qos-group, the value set by the session-level policy takes precedence.

Note Typically, the discard-class is used in a queuing policy to allow different drop probabilities. Therefore, limit discard-class usage to only the interface-level policy.

match interface

Valid as an output classification criteria and is not influenced by any actions at any of the policy levels.

Note In this case, the interface is the session.

match exp

Not applicable to these types of session interfaces.

match acl

Dependent on the statements contained in the ACL. The only values that may change between the session- and interface-level policies is the precedence and DSCP fields. All other fields do not change. Therefore, the session-level policy does not influence the classification action of the interface-level policy, except in the case of the precedence and DSCP fields.

match protocol

Valid as an input or output criteria on all interface and session types, and is unchanged by the policies. Therefore, the session-level policy does not influence the classification action of the interface-level policy.

bandwidth, shape, priority, random-detect, queue-limit (queuing actions)

Valid in the interface-level output policy only. No interaction with any other policy levels.

police

Indirect effect from one level to the next level. If a packet is dropped by the session-level policy, the BRAS does not count the packet in the token bucket calculations of the interface-level policy.

set

Direct interaction between policy levels. The action at the interface-level overrides the action at the session-level. This occurs if the set command is used or if the set action is specified in a police command.

A set command configured in a policy applied at the session level can change the statistical information collected at the interface level if the interface policy contains an action that matches a set command in the session policy. For example, suppose a virtual template policy contains the set ip prec 4 command and the interface policy contains a policing action that transmits or drops precedence 4 traffic. The session policy sets precedence 4 on the appropriate traffic and the interface policy handles the resulting precedence 4 traffic group by transmitting or dropping the traffic.

Note Some set commands, such as the set clp command, are specific to certain interface types, but this does not change the behavior.


Restrictions for Simultaneous Policy Maps

The router does not support hierarchical queuing policies when implementing simultaneous policy maps. However, you can have nested policy maps.

The interface policy cannot be an hierarchical policing policy.

You cannot configure a hierarchical policing policy as the session policy when a policy is present on the interface.

The session-level policy must contain only non-queueing actions such as police or set actions. Queueing and shaping actions can be done in user-defined classes on VLAN subinterface.


Note The Hierarchical Queueing for Ethernet DSLAMS feature allows a parent shaping and child queueing policy attached to the session while shaping the VLAN subinterface (in class-default class only). The VLAN subinterface can aggregate multiple sessions. The Hierarchical Queueing for Ethernet DSLAMs feature allows a flat shaping policy on the VLAN subinterface where the flat shaping policy must contain class-default class only. For more information on the Hierarchical Queueing for Ethernet DSLAM feature, see the QoS---Hierarchical Queueing for Ethernet DSLAMS guide.


The session-level policy takes precedence over the interface policy.

The simultaneous policy maps feature does not support LNS sessions, multilink PPP (MLPPP) sessions, or IP sessions.

The simultaneous policy maps feature does not support a policy on an ATM main interface and a policy on an ATM PVC at the same time. If this occurs, the PVC does not inherit the policy of the main interface.

You cannot use RADIUS Attributes 37 and 39 to dynamically associate a QoS policy to a VLAN subinterface.

The show policy-map command does not display the relationship of the two simultaneous policies. Instead, use the show pxf statistics qos policy-map interface command and the show pxf statistics qos policy-map session sid commands.

You cannot display the statistical information applicable to the two policies by issuing one CLI command. Instead, to display the actions taken on the packets traversing the session, you must issue two separate commands: show pxf statistics qos policy-map interface and show pxf statistics qos policy-map session sid.

Configuring Simultaneous Policy Maps

To configure simultaneous policy maps, perform the following configuration tasks for Ethernet or ATM configurations:

Configuring the Two Policy Maps

Attaching Simultaneous Policies to PPPoE Sessions Traversing an Ethernet Interface

Attaching Simultaneous Policies to PPPoA Sessions Traversing an ATM VC

Attaching Simultaneous Policies to PPPoE Sessions Traversing an ATM VC

Configuring the Two Policy Maps

Simultaneous policy maps requires that you configure a policy map with non-queuing actions for the session-level policy and a policy map with any actions, including queuing actions, for the interface-level policy.

To configure the two policy maps, enter the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# policy-map policy-map-name

Creates or modifies a policy map template with the name you specify and enters policy-map configuration mode.

policy-map-name is the name of the policy map. The name can be a maximum of 40 alphanumeric characters.

Step 2 

Router(config-pmap)# class class-map-name

Specifies the class to which the policy map applies.

Note On a given interface, the router uses the class-default class to assign QoS policies to any packets that do not belong to the classes defined in a policy map.

class-map-name is the name of the class map. The name can be a maximum of 40 alphanumeric characters.

Step 3 

Router(config-pmap-c)# police [cir] bps [bcburst-normal [pir pir] [beburst-excess [conform-action action] [exceed-action action] [violate-action action]

(Optional) Configures bits per second-based traffic policing.

For information about the police command options, see the Cisco IOS Command Reference Guide for Cisco IOS Release 12.2 SB.

Note For session-level policies, specify the police or set commands. You can only specify non-queuing actions for this policy.

Step 4 

Router(config-pmap-c)# bandwidth {bandwidth-kbps | percent percentage | remaining percent percentage}

(Optional) Specifies the minimum bandwidth allocated for a traffic class.

For information about the bandwidth command options, see the Cisco IOS Command Reference Guide for Cisco IOS Release 12.2 SB.

Note For interface-level policies, you may specify any valid QoS actions, including queuing actions, to define the traffic classes specified in the policy map. See the "QoS Actions" section

Attaching Simultaneous Policies to PPPoE Sessions Traversing an Ethernet Interface

To attach simultaneous policies to PPPoE sessions traversing an Ethernet interface, perform the following configuration tasks:

Attaching a Policy to a PPPoE Session

Attaching a Policy to an Ethernet Interface

Attaching a Policy to a PPPoE Session

To attach a policy map to a PPPoE session, enter the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface type number

Creates or modifies a subinterface. Enters subinterface configuration mode.

type is the interface type (for example, GigabitEthernet).

number is the slot, module, port, subinterface number of the interface (for example, 4/0/1.10).

Step 2 

Router(config-subif)# protocol pppoe

Specifies the tunneling protocol that a virtual private dialup network (VPDN) subgroup is to use, in this case PPPoE.

Step 3 

Router(config-subif)# exit

Exits subinterface configuration mode.

Step 4 

Router(config)# interface virtual-template number

Creates a virtual template interface that can be configured and applied dynamically in creating virtual access interfaces.

number is a number used to identify the virtual template interface.

Step 5 

Router(config-if)# ip unnumbered type number

Enables IP processing on an interface without assigning an explicit IP address to the interface.

type is an interface on which the router has assigned an IP address (for example, loopback). The interface cannot be an unnumbered interface.

number is an interface or subinterface number (for example, 1).

Step 6 

Router(config-if)# service-policy output policy-map-name

Attaches the specified policy map to the interface in the outbound direction.

policy-map-name is the name of a previously configured policy map.

Configuration Example of Attaching the Interface Policy for Simultaneous Policy Maps

The following example configuration shows how to attach the interface policy for simultaneous policy maps. In this example, the policy named pppoe_sess_output_policy is attached to the virtual template interface named Virtual-Template1, which the BRAS uses when creating a virtual access interface (VAI) for a session.

interface GigabitEthernet3/0/0.10
protocol pppoe
!
interface Virtual-Template1
ip unnumbered Loopback1
service-policy output pppoe_sess_output_policy

Attaching a Policy to an Ethernet Interface

To attach a policy map to an Ethernet interface, enter the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface type number

Creates or modifies a subinterface. Enters subinterface configuration mode.

type is the interface type (for example, GigabitEthernet).

number is the slot, module, port, subinterface number of the interface (for example, 4/0/1.10).

Step 2 

Router(config-subif)# protocol pppoe

Specifies the tunneling protocol that a virtual private dialup network (VPDN) subgroup is to use, in this case PPPoE.

Step 3 

Router(config-if)# service-policy output policy-map-name

Attaches the specified policy map to the interface in the outbound direction.

policy-map-name is the name of a previously configured policy map.

Configuration Example of Attaching a Policy to an Ethernet Interface

The following example configuration shows how to attach a simultaneous policy map to an Ethernet interface. In this example, the policy named pppoe_output_policy is attached to the Gigabit Ethernet subinterface 3/0/0.10 in the outbound direction.

interface GigabitEthernet3/0/0.10
protocol pppoe
service-policy output pppoe_output_policy

Attaching Simultaneous Policies to PPPoA Sessions Traversing an ATM VC

To attach simultaneous policies to PPPoA sessions traversing an ATM VC, perform the following configuration tasks:

Attaching a Policy to a PPPoA Session

Attaching a Policy to an ATM VC with PPPoA Sessions

Attaching a Policy to a PPPoA Session

To attach a policy map to a PPPoA session, enter the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface type number [point-to-point | multipoint]

Creates or modifies a subinterface. Enters subinterface configuration mode.

type is the interface type (for example, GigabitEthernet).

number is the slot, module, port, subinterface number of the interface (for example, 4/0/1.10).

point-to-point indicates that the subinterface connects directly to one endpoint.

multipoint indicates that the subinterface connects to multiple endpoints.

Step 2 

Router(config-subif)# range pvc start-vpi/end-vpi start-vci/end-vci

Defines a range of ATM permanent virtual circuits (PVCs).

(Optional) start-vpi/ is the beginning value for a range of virtual path identifiers (VPIs). In the absence of the "/" and a VPI value, the VPI value defaults to 0. Valid values are from 0 to 255.

(Optional) end-vpi is the end value for a range of virtual path identifiers (VPIs). In the absence of an end-VPI value, the end-VPI value defaults to the start-VPI value. Valid values are from 0 to 255.

start-vci/ is the beginning value for a range of virtual channel identifiers (VCIs). Valid values are from 32 to 65535. You must specify the slash mark (/).

end-vci is the end value for a range of virtual channel identifiers (VCIs). Valid values are from 32 to 65535.

Step 3 

Router(config-subif-atm-vc)# encapsulation aal5mux ppp virtual-template number

Configures the ATM adaptation layer (AAL) and encapsulation type for the PVC range.

ppp configures the interface for PPP routing.

number is a number that identifies the virtual template.

Step 4 

Router(config-subif-atm-vc)# exit

Exits ATM VC configuration mode.

Step 5 

Router(config-subif)# exit

Exits subinterface configuration mode.

Step 6 

Router(config)# interface virtual-template number

Creates a virtual template interface that can be configured and applied dynamically in creating virtual access interfaces.

number is a number that identifies the virtual template interface.

Step 7 

Router(config-if)# ip unnumbered type number

Enables IP processing on the an interface without assigning an explicit IP address to the interface.

loopback is an interface on which the router has assigned an IP address. The interface cannot be an unnumbered interface.

number identifies the interface or subinterface (for example, loopback1).

Step 8 

Router(config-if)# service-policy output policy-map-name

Attaches the specified policy map to the interface in the outbound direction.

policy-map-name is the name of a previously configured policy map.

Configuration Example of Attaching a Policy to PPPoA Sessions

The following example shows how to attach a policy map to PPPoA sessions for simultaneous policy maps. The example creates Virtual-Template1 and applies the policy map named pppoa_int_output_policy to it. Virtual-Template1 is applied to PVC range 42/101 42/110 on ATM interface 3/0/0.42101. The router uses Virtual-Template1 when it creates virtual access interfaces (VAIs) for the sessions arriving on the PVC range.

interface ATM3/0/0.42101 multipoint
range pvc 42/101 42/110
encapsulation aal5mux ppp Virtual-Template1
!
interface Virtual-Template1
ip unnumbered Loopback1
service-policy output pppoa_int_output_policy

Attaching a Policy to an ATM VC with PPPoA Sessions

To attach a simultaneous policy to an ATM VC with PPPoA sessions, enter the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface atm number [point-to-point | multipoint]

Creates or modifies a subinterface. Enters subinterface configuration mode.

number is the slot, module, port, subinterface number of the interface (for example, 4/0/1.10).

point-to-point indicates that the subinterface connects directly to one endpoint.

multipoint indicates that the subinterface connects to multiple endpoints.

Step 2 

Router(config-subif)# range pvc start-vpi/end-vpi start-vci/end-vci

Defines a range of ATM permanent virtual circuits (PVCs).

(Optional) start-vpi/ is the beginning value for a range of virtual path identifiers (VPIs). In the absence of the "/" and a VPI value, the VPI value defaults to 0. Valid values are from 0 to 255.

(Optional) end-vpi is the end value for a range of virtual path identifiers (VPIs). In the absence of an end-VPI value, the end-VPI value defaults to the start-VPI value. Valid values are from 0 to 255.

start-vci/ is the beginning value for a range of virtual channel identifiers (VCIs). Valid values are from 32 to 65535. You must specify the slash mark (/).

end-vci is the end value for a range of virtual channel identifiers (VCIs). Valid values are from 32 to 65535.

Step 3 

Router(config-subif-atm-vc)# vbr-nrt output-pcr output-scr output-mbs

Configures the variable bit rate-nonreal time (VBR-NRT) quality of service (QoS).

output-pcr is the output peak cell rate (PCR), in kbps.

output-scr is the output sustained cell rate (SCR), in kbps.

output-mbs is the output maximum burst cell size, expressed in number of cells.

Step 4 

Router(config-subif-atm-vc)# encapsulation aal5mux ppp virtual-template number

Configures the ATM adaptation layer (AAL) and encapsulation type for the PVC range.

ppp configures the interface for PPP routing.

number is a number that identifies the virtual template.

Step 5 

Router(config-atm-vc)# service-policy output policy-map-name

Attaches the specified policy map to the specified PVC range in the outbound direction.

policy-map-name is the name of a previously configured policy map.

Configuration Example of Attaching a Policy to an ATM VC with PPPoA Sessions

The following example shows how to attach a simultaneous policy map named pppoa_output_policy to PVCs in the range of 42/101 to 42/110 on the multipoint ATM interface 3/0/0.42101:

interface ATM3/0/0.42101 multipoint
range pvc 42/101 42/110
vbr-nrt 2000 2000 1
encapsulation aal5mux ppp Virtual-Template1
service-policy output pppoa_output_policy

Attaching Simultaneous Policies to PPPoE Sessions Traversing an ATM VC

To attach simultaneous policies to PPPoE sessions traversing an ATM VC, perform the following configuration tasks:

Attaching a Policy to a PPPoA Session

Attaching a Policy to an ATM VC with PPPoA Sessions

Attaching a Policy to PPPoE Sessions

To attach a policy map to PPPoE sessions, enter the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface type number [point-to-point | multipoint]

Creates or modifies a subinterface. Enters subinterface configuration mode.

type is the interface type (for example, GigabitEthernet).

number is the slot, module, port, subinterface number of the interface (for example, 4/0/1.10).

point-to-point indicates that the subinterface connects directly to one endpoint.

multipoint indicates that the subinterface connects to multiple endpoints.

Step 2 

Router(config-subif)# range pvc start-vpi/end-vpi start-vci/end-vci

Defines a range of ATM permanent virtual circuits (PVCs).

(Optional) start-vpi/ is the beginning value for a range of virtual path identifiers (VPIs). In the absence of the "/" and a VPI value, the VPI value defaults to 0. Valid values are from 0 to 255.

(Optional) end-vpi is the end value for a range of virtual path identifiers (VPIs). In the absence of an end-VPI value, the end-VPI value defaults to the start-VPI value. Valid values are from 0 to 255.

start-vci/ is the beginning value for a range of virtual channel identifiers (VCIs). Valid values are from 32 to 65535. You must specify the slash mark (/).

end-vci is the end value for a range of virtual channel identifiers (VCIs). Valid values are from 32 to 65535.

Step 3 

Router(config-subif-atm-vc)# encapsulation aal5snap

Configures the ATM adaptation layer (AAL) and encapsulation type for the PVC range

Step 4 

Router(config-subif-atm-vc)# protocol pppoe

Specifies the tunneling protocol that a virtual private dialup network (VPDN) subgroup is to use, in this case PPPoE.

Step 5 

Router(config-subif-atm-vc)# exit

Exits ATM VC configuration mode.

Step 6 

Router(config-subif)# exit

Exits subinterface configuration mode.

Step 7 

Router(config)# interface virtual-template number

Creates a virtual template interface that can be configured and applied dynamically in creating virtual access interfaces.

number is a number that identifies the virtual template interface.

Step 8 

Router(config-if)# ip unnumbered loopback number

Enables IP processing on the an interface without assigning an explicit IP address to the interface.

loopback is an interface on which the router has assigned an IP address. The interface cannot be an unnumbered interface.

number identifies the interface or subinterface (for example, loopback1).

Step 9 

Router(config-if)# service-policy output policy-map-name

Attaches the specified policy map to the interface in the outbound direction.

policy-map-name is the name of a previously configured policy map.

Configuration Example for Attaching a Policy to PPPoE Sessions

The following example shows how to attach a simultaneous policy map to PPPoE sessions that are traversing an ATM VC. The example creates Virtual-Template1 and applies the policy map named pppoe_int_output_policy to it. The Virtual-Template1 is applied to the bba-group named VRF_1, which is attached to PVC range 81/801 to 81/810 on the multipoint subinterface ATM 2/0/0.81801.

interface ATM2/0/0.81801 multipoint
range pvc 81/801 81/810
encapsulation aal5snap
protocol pppoe group VRF_1
!
bba-group pppoe VRF_1
	Virtual-Template 1
 sessions per-vc limit 1000
 sessions per-mac limit 1000
 sessions per-vlan limit 1000
!
interface Virtual-Template1
ip unnumbered Loopback1
service-policy output pppoe_int_output_policy

Attaching a Policy to an ATM VC with PPPoE Sessions

To attach a policy map to an ATM VC with PPPoE sessions, enter the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface atm number [point-to-point | multipoint]

Creates or modifies a subinterface. Enters subinterface configuration mode.

number is the slot, module, port, subinterface number of the interface (for example, 4/0/1.10).

point-to-point indicates that the subinterface connects directly to one endpoint.

multipoint indicates that the subinterface connects to multiple endpoints.

Step 2 

Router(config-subif)# range pvc start-vpi/end-vpi start-vci/end-vci

Defines a range of ATM permanent virtual circuits (PVCs).

(Optional) start-vpi/ is the beginning value for a range of virtual path identifiers (VPIs). In the absence of the "/" and a VPI value, the VPI value defaults to 0. Valid values are from 0 to 255.

(Optional) end-vpi is the end value for a range of virtual path identifiers (VPIs). In the absence of an end-VPI value, the end-VPI value defaults to the start-VPI value. Valid values are from 0 to 255.

start-vci/ is the beginning value for a range of virtual channel identifiers (VCIs). Valid values are from 32 to 65535. You must specify the slash mark (/).

end-vci is the end value for a range of virtual channel identifiers (VCIs). Valid values are from 32 to 65535.

Step 3 

Router(config-subif-atm-vc)# vbr-nrt output-pcr output-scr output-mbs

Configures the variable bit rate-nonreal time (VBR-NRT) quality of service (QoS).

output-pcr is the output peak cell rate (PCR), in kbps.

output-scr is the output sustained cell rate (SCR), in kbps.

output-mbs is the output maximum burst cell size, expressed in number of cells.

Step 4 

Router(config-subif-atm-vc)# encapsulation aal5snap

Configures the ATM adaptation layer (AAL) and encapsulation type for the PVC range.

Step 5 

Router(config-subif-atm-vc)# protocol pppoe

Specifies the tunneling protocol that a virtual private dialup network (VPDN) subgroup is to use, in this case PPPoE.

Configuration Example for Attaching a Policy to an ATM VC with PPPoE Sessions

The following example shows how to attach a simultaneous policy map to an ATM VC over which PPPoE sessions traverse the network. The policy map named pppoe_sess_output_policy is attached to Virtual-Template1, which is applied to the BBA group named VRF_1. The BBA group is attached to the PVC range 81/801 to 81/810 on subinterface ATM 2/0/0.81801.

interface ATM2/0/0.81801 multipoint
range pvc 81/801 81/810
vbr-nrt 2000 2000 1
encapsulation aal5snap
protocol pppoe group VRF_1
!
bba-group pppoe VRF_1
	Virtual-Template 1
 sessions per-vc limit 1000
!
interface Virtual-Template1
ip unnumbered Loopback1
service-policy output pppoe_sess_output_policy

Configuration Examples for Simultaneous Policy Maps

This section provides the following configuration examples:

Configuration Example for Applying Simultaneous Policy Maps on Ethernet Interfaces and PPPoE Sessions

Configuration Example for Applying Simultaneous Policies on 802.1Q Interfaces and PPPoE Sessions

Configuration Example for Applying Simultaneous Policies on 802.1Q QinQ Interfaces and PPPoE Sessions

Configuration Example for Applying Simultaneous Policies on ATM VCs and PPPoA Sessions

Configuration Example for Applying Simultaneous Policies on ATM VCs and PPPoE Sessions

Configuration Example for Applying Simultaneous Policy Maps on Ethernet Interfaces and PPPoE Sessions

The following configuration example shows how to create and apply simultaneous policy maps on Ethernet interfaces and PPP sessions. The Client Configuration shows that no policies have been applied. In the PTA Configuration, the interface policy named cbwfq_out_policy is applied to the Gigabit subinterface Ethernet 1/0/0.2 and the session policy named police_out_policy is applied to the virtual template named Virtual-Template1, which is in turn applied to the BBA group named VRF_1.

Client Configuration

bba-group pppoe VRF_1
 virtual-template 1
 sessions per-vc limit 1000
 sessions per-mac limit 1000
 sessions per-vlan limit 1000
!
interface GigabitEthernet8/0/0
 no ip address
!
interface GigabitEthernet8/0/0.2
 encapsulation dot1Q 2
 pppoe enable group VRF_1
!
Interface Virtual-Template1
 mtu 1492
 ip address negotiated
 keepalive 30
 ppp max-terminate 10
 ppp max-failure 10
 ppp lcp delay 1
 ppp pap sent-username gomer1@domain1.com password 0 gomer
 ppp timeout retry 1
 ppp timeout authentication 15

PTA Configuration

aaa new-model
!
Username gomer1@domain1.com password 0 gomer
aaa authentication ppp default local
aaa authentication login mylist enable line aaa authentication ppp
vpdn enable
ppp hold-queue 80000
no mpls ldp logging neighbor-changes
no virtual-template snmp
!
buffers small permanent 15000
buffers middle permanent 12000
buffers big permanent 8000
bba-group pppoe VRF_1
 virtual-template 1
 sessions per-vc limit 1000
 sessions per-mac limit 1000
 sessions per-vlan limit 1000
!
class-map match-any voip
 match ip precedence 5
!
class-map match-any all_pkts
 match any
!
class-map match-any video
 match ip precedence 4
!

! The policy map named cbwfq_out_policy is the interface policy that is inherited by all sessions.

policy-map cbwfq_out_policy
 class voip
   police 24000 9216 0 conform-action transmit exceed-action drop violate-action drop
 priority
 class video
   bandwidth 20
 class class-default
!
policy-map in_pmap
 class all_pkts
   police 64000 9216 0 conform-action transmit exceed-action drop violate-action drop
!

! The policy map named police_out_policy is the session policy that is owned by each session.

policy-map police_out_policy
 class voip
   police 12000 4000 0 conform-action transmit exceed-action drop violate-action drop
 class video
   police 10000 4000 0 con conform-action transmit exceed-action drop violate-action drop
 class class-default
 class all_pkts
   police 32000 4000 0 conform-action transmit exceed-action drop violate-action drop
!
interface GigabitEthernet6/0/0
  no ip address
!

! Interface policy named cbwfq_out_policy is applied to the GE interface.

interface GigabitEthernet6/0/0.2
 encapsulation dot1Q 2
 pppoe enable group VRF_1
 service-policy output cbwfq_out_policy
!

! Session policy named police_out_policy is applied to the virtual template.

interface Virtual-Template1
 mtu 1492
 ip unnumbered Loopback0
 no logging event link-status
 no snmp trap link-status
 peer default ip address pool pppoe-pool default
 keepalive 30
 ppp max-terminate 10
 ppp max-failure 10
 ppp lcp delay 1
 ppp authentication pap
 ppp ipcp address required
 ppp timeout retry 1
 ppp timeout authentication 15
 service-policy output police_out_policy
!
ip local pool pppoe-pool 111.1.1.1 111.1.4.254

Configuration Example for Applying Simultaneous Policies on 802.1Q Interfaces and PPPoE Sessions

The following configuration example shows how to attach simultaneous policy maps to an 802.1Q interface and PPP sessions. The policy map named pppoe_int_output_policy is attached to subinterface GigabitEthernet 3/0/0.10. The policy maps named pppoe_sess_output_policy and pppoe_sess_input_policy are attached to the virtual template named Virtual-Template1. The router applies the virtual template to the session when it creates the virtual access interface (VAI) for the session.

Session

interface GigabitEthernet3/0/0.10
 encapsulation dot1Q 10
 pppoe enable
!
interface Virtual-Template1
 ip unnumbered Loopback1
 service-policy output pppoe_sess_output_policy
service-policy input pppoe_sess_input_policy

Interface

interface GigabitEthernet3/0/0.10
 encapsulation dot1Q 10
 pppoe enable
 service-policy output pppoe_int_output_policy

Configuration Example for Applying Simultaneous Policies on 802.1Q QinQ Interfaces and PPPoE Sessions

The following configuration example shows how to attach simultaneous policy maps to an 802.1Q QinQ interface and PPPoE sessions. The policy maps named pppoe_int_output_policy and pppoe_int_input_policy are attached to the QinQ subinterface Gigabit Ethernet 3/0/0.10. The policy named pppoe_sess_output_policy is attached to the virtual template named Virtual-Template1. The router applies the virtual template to the session when it creates the virtual access interface (VAI) for the session.

Session

interface GigabitEthernet3/0/0.10
 encapsulation dot1Q 10 second-dot1q 19
 pppoe enable
!
interface Virtual-Template1
 ip unnumbered Loopback1
 service-policy output pppoe_sess_output_policy

Interface

interface GigabitEthernet3/0/0.10
 encapsulation dot1Q 10 second-dot1q 19
 pppoe enable
 service-policy output pppoe_int_output_policy
service-policy input pppoe_int_input_policy

Configuration Example for Applying Simultaneous Policies on ATM VCs and PPPoA Sessions

The following configuration example shows how to attach simultaneous policy maps to ATM PVCs and PPPoA sessions. The policy map named pppoa_int_output_policy is attached to the PVC range 42/101 to 42/110 for outbound traffic. The policies named pppoa_sess_output_policy and pppoa_sess_input_policy are attached to the virtual template named Virtual-Template1 for outbound and inbound traffic, respectively. The router applies the virtual template to the session when it creates the virtual access interface (VAI) for the session.

Session

interface ATM3/0/0.42101 multipoint
 range pvc 42/101 42/110
  encapsulation aal5mux ppp Virtual-Template1  
!
interface Virtual-Template1
 ip unnumbered Loopback1
 service-policy output pppoa_sess_output_policy
service-policy input pppoa_sess_input_policy

VC

interface ATM3/0/0.42101 multipoint
 range pvc 42/101 42/110
  vbr-nrt 2000 2000 1
  encapsulation aal5mux ppp Virtual-Template1
  service-policy output pppoa_int_output_policy

Configuration Example for Applying Simultaneous Policies on ATM VCs and PPPoE Sessions

The following configuration example shows how to attach simultaneous policy maps to ATM PVCs and PPPoE sessions traversing the ATM PVCs. The policy maps named pppoa_int_output_policy and pppoa_int_input_policy are attached to the PVC range 01/001 to 01/010. The policy map named pppoe_sess_output_policy is attached to the virtual template named Virtual-Template1. The router applies the virtual template to the session when it creates the virtual access interface (VAI) for the session.

Session

interface ATM2/0/0.81801 multipoint
 range pvc 81/801 81/810
  encapsulation aal5snap
  protocol pppoe
!
interface Virtual-Template1
 ip unnumbered Loopback1
 service-policy output pppoe_sess_output_policy

VC

interface ATM2/0/0.81801 multipoint
 range pvc 81/801 81/810
  vbr-nrt 2000 2000 1
  encapsulation aal5snap
	service-policy output pppoa_int_output_policy
	service-policy input pppoa_int_input_policy
  protocol pppoe

Verifying Simultaneous Policy Maps

When displaying statistical information for simultaneous policy maps, the BRAS displays information for both the session-level and interface-level policies as the following describes:

Session level—Each unique session owns each policy. Therefore, the information that displays represents the statistics of the session.

Interface level—The information that displays represents the aggregate statistics of all of the sessions passing over the ATM PVC or Ethernet-based subinterface (the sessions' inherited policy).

To verify and monitor simultaneous policy maps, enter any of the following commands in privileged EXEC mode:

Command
Purpose

Router# show policy-map

Displays statistical and configuration information about all of the configured policy maps.

Router# show policy-map policy-map-name

Displays statistical and configuration information about the policy map you specify.

Router# show policy-map interface interface

Displays statistical and configuration information about all of the input and output policy maps attached to the interface you specify.

Note To view the statistics for simultaneous policy maps, you must issue both the show policy-map interface command and the show policy-map session sid command.

Router# show policy-map session sid sid

Displays statistical and configuration information about the policy map applied to the session you specify.

Note To view the statistics for simultaneous policy maps, you must issue both the show policy-map interface command and the show policy-map session sid command.

Router# show pxf statistics qos policy-map session sid sid

Displays the relationship of the two simultaneous policies and statistical information applicable to the two policies. Displays the policy map applied to the specified session (for example, the session-owned policy) and the policy map applied to the interface over which the sessions traverse (for example, the inherited policy).

Router# show pxf statistics qos policy-map interface interface

Displays the relationship of the two simultaneous policies and statistical information applicable to the two policies. Displays statistical information for the session and for the subinterface or VC-level policy the session inherited. The information that displays at the subinterface or VC level is the aggregate information of all of the sessions using the subinterface or VC; for example, the aggregate of the packets that were matched, dropped, marked, queued, and so on.



Note The router does not support displaying relationships between the two simultaneous policies.


Verification Examples for Traffic Policing

This section provides the following verification examples. In the examples, the policy named parent1 is applied on the interface and the policy named prec-only is applied on the virtual template or pushed from RADIUS for the session.

Displaying Simultaneous Policy Map Information for Interfaces

Displaying Simultaneous Policy Map Information for PTA Virtual Interfaces

Displaying Simultaneous Policy Map Information for Virtual Access Interfaces

Displaying Simultaneous Policy Map Information for a LAC Session

Displaying Simultaneous Policy Map Information for Interfaces

The following example shows sample output from the show pxf statistics qos policy-map interface command. The output shows policy map information for the specified Gigabit Ethernet subinterface 6/0/0.2, which is the inherited policy of the sessions that use the subinterface. The output also shows the policy maps owned by the sessions traversing the subinterface.

Router# show pxf statistics qos policy-map interface gigabitethernet 6/0/0.2
 
   
Simultaneous Policymap Info for GigabitEthernet6/0/0.2 - 
 
   
  Input Policy owned by GigabitEthernet6/0/0.2 [VCCI 2524] - 'parent1': 
 
   
Class	Pkts	Bytes 	Pkts 	Pkts 	Pkts
	Matched 	Matched 	Conformed 	Exceeded 	Violated
----------------  -----------  ------------  ---------------  -----------  -----------
prec5                 1000       66000          0                   0	0       
class-default	0	0	0	0	0       
 
   
  Input Policy owned by Virtual-Access3.4 [VCCI 3241] - ''prec-only":
 
   
Class	Pkts	Bytes 	Pkts 	Pkts 	Pkts
	Matched 	Matched 	Conformed 	Exceeded 	Violated
----------------  -----------  ------------  ---------------  -----------  -----------
prec5                500           33000         0                  0	0       
prec3 	0	0 	0	0	0       
prec2 	0	0 	0	0	0       
class-default 	0	0 	0	0	0       
 
   
  Input Policy owned by Virtual-Access3.3 [VCCI 3240] - 'prec-only': 
 
   
Class	Pkts	Bytes 	Pkts 	Pkts 	Pkts
	Matched 	Matched 	Conformed 	Exceeded 	Violated
----------------  -----------  ------------  ---------------  -----------  -----------
prec5                500           33000         0                  0	0       
prec3 	0 	0 	0	0	0       
prec2 	0 	0 	0	0	0       
class-default 	0 	0 	0	0	0       

Displaying Simultaneous Policy Map Information for PTA Virtual Interfaces

The following example shows sample output from the show pxf statistics qos policy-map session command. The output shows policy map information for the specified session and for the virtual access interface (VAI) created for the session.

Router# show pxf statistics qos policy-map session sid 11
 
   
Simultaneous Policymap Info for Session ID #11 ( Virtual-Access3.3 ) - 
 
   
Simultaneous Policymap Info for Virtual-Access3.3 - 
 
   
  Input Policy owned by Virtual-Access3.3 [VCCI 3240] - 'prec-only': 
 
   
Class	Pkts	Bytes 	Pkts	Pkts	Pkts
	Matched 	Matched	Conformed 	Exceeded 	Violated
----------------  -----------  ------------  ---------------  -----------  -----------
prec5	500	33000	0	0	 0       
prec3 	0 	0 	0	0	0       
prec2 	0 	0 	0	0	0       
class-default 	0 	0 	0	0	0 
Input Policy inherited from GigabitEthernet6/0/0.2 [VCCI 2524] - 'parent1': 
 
   
Class	Pkts	Bytes 	Pkts 	Pkts 	Pkts
	Matched 	Matched 	Conformed 	Exceeded 	Violated
----------------  -----------  ------------  ---------------  -----------  -----------
prec5 	1000 	66000 	0 	0 	0       
class-default 	0 	0 	0 	0 	0 

Displaying Simultaneous Policy Map Information for Virtual Access Interfaces

The following example shows sample output from the show pxf statistics qos policy-map interface command when a virtual access interface (VAI) is specified as the interface:

Router# show pxf statistics qos policy-map interface vi3.3
 
   
Simultaneous Policymap Info for Virtual-Access3.3 - 
 
   
  Input Policy owned by Virtual-Access3.3 [VCCI 3240] - 'prec-only': 
 
   
Class	Pkts	Bytes 	Pkts 	Pkts 	Pkts
	Matched 	Matched 	Conformed 	Exceeded 	Violated
----------------  -----------  ------------  ---------------  -----------  -----------
prec5 	500	33000	0	0	0       
prec3 	0 	0 	0	0	0       
prec2 	0 	0 	0	0	0       
class-default 	0 	0 	0	0	0       
 
   
 
   
  Input Policy inherited from GigabitEthernet6/0/0.2 [VCCI 2524] - 'parent1': 
 
   
Class	Pkts	Bytes 	Pkts 	Pkts 	Pkts
	Matched 	Matched 	Conformed 	Exceeded 	Violated
----------------  -----------  ------------  ---------------  -----------  -----------
prec5	1000 	33000	0	0	0       
class-default	0 	0 	0	0	0       

Displaying Simultaneous Policy Map Information for a LAC Session

The following example shows sample output from the show pxf statistics qos policy-map interface command when a LAC session is traversing the Gigabit Ethernet subinterface 6/0/0.2.

Router# show pxf statistics qos policy-map interface gigabitethernet 6/0/0.2
 
   
Simultaneous Policymap Info for GigabitEthernet6/0/0.2 -
 
   
  Input Policy owned by GigabitEthernet6/0/0.2 [VCCI 2524] - 'parent1': 
 
   
Class	Pkts	Bytes 	Pkts 	Pkts 	Pkts
	Matched 	Matched 	Conformed 	Exceeded 	Violated
----------------  -----------  ------------  ---------------  -----------  -----------
prec5 	332	 21912 	332 	0 	0
class-default	668	44088	668	0	0
 
   
 
   
  Input Policy owned by LAC Session traversing GigabitEthernet6/0/0.2 [VCCI 2529] - 
'prec-only': 
 
   
Class	Pkts	Bytes 	Pkts 	Pkts 	Pkts
	Matched 	Matched 	Conformed 	Exceeded 	Violated
----------------  -----------  ------------  ---------------  -----------  -----------
prec5 	332	 21978 	333 	0 	0
prec3	0	0	0	0	0
prec2	0	0	0	0	0
class-default	667	44022	0	0	0